自定菜单

隐藏菜单命令和对其着色,可以避免菜单出现杂乱现象,并可突出常用的命令。请注意,隐藏菜单命令只是将其从视图中删除,不会停用任何功能。您可以随时查看隐藏的命令,具体方法是:选中菜单底部的“显示全部菜单项目”命令;或者,您可以选取窗口 > 工作区 > 显示完整菜单,以显示所选工作区的全部菜单。可将自定菜单包括在存储的工作区内。

可以自定主菜单、上下文菜单和面板菜单。右键单击 (Windows) 或在按住 Control 键单击 (Mac OS) 某区域时,会出现上下文菜单。单击面板右上角的图标时,会出现面板菜单。

注意:

如果选择其他工作区(如“排版规则”),有些菜单命令则会隐藏起来。要显示菜单命令,请选择菜单底部的“显示全部菜单项目”,或者选择其他工作区,例如“高级”。

创建自定菜单集

  1. 选取编辑 > 菜单

    您不能编辑默认菜单集。

  2. 单击存储为,键入菜单集的名称,然后单击“确定”。
  3. 从“类别”菜单中,选择“应用程序菜单”或“上下文菜单和面板菜单”,以此确定要自定哪些类型的菜单。
  4. 单击菜单类别左边的箭头以显示子类别或菜单命令。对于每一个要自定义的命令,请单击“可视性”下方的眼睛图标以显示或隐藏此命令;单击“颜色”下方的“无”可从菜单中选择一种颜色。
  5. 请单击“存储”,然后单击“确定”。

选择自定菜单集

  1. 选取编辑 > 菜单

  2. 从“集”菜单中选择相应菜单集,然后单击“确定”。

编辑或删除自定菜单集

  1. 选取编辑 > 菜单

  2. 从“集”菜单中选择相应菜单集,然后执行下列操作之一:
    • 要编辑某一菜单集或者更改菜单命令的可视性或颜色,请单击“存储”,然后单击“确定”。

    • 要删除某一菜单集,请单击“删除”,然后单击“是”。如果已修改菜单集但未存储它,则系统将提示您存储当前的菜单集。单击“是”存储菜单集,或者单击“否”放弃更改。

显示隐藏的菜单项目

  • 选取窗口 > 工作区 > 显示完整菜单。此命令会打开所选工作区的所有菜单。也可通过重置工作区,再次隐藏菜单。
  • 在包含隐藏命令的菜单底部,选取显示全部菜单项目

注意:

按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击菜单名称,可短暂显示已经通过自定菜单操作隐藏的任何菜单命令。

缺失的菜单命令

如果无法找到某一菜单命令,它可能已经隐藏。如果选择除“高级”之外的工作区,某些菜单命令将会隐藏。也可能是因为您或其他用户使用“菜单”命令隐藏了一些菜单项。

如果找不到需要的命令,请尝试以下任一技巧:

  • 选取菜单底部的显示全部菜单项目

  • 选取窗口 > 工作区 > 显示完整菜单

  • 选取窗口 > 工作区,然后选择其他工作区(如果选择“高级”,则可以显示所有菜单项目)。

  • 选取编辑 > 菜单,找到所需的菜单命令,确保该命令没有被隐藏。

如果菜单命令仍然缺失,请尝试恢复首选项。

使用键盘快捷键集

工具提示为快捷键提供了即时的参考。InDesign 还提供快捷键编辑器,在该编辑器中,不仅可以查看并生成所有快捷键的列表,而且可以编辑或创建自己的快捷键。快捷键编辑器包括所有接受快捷键的命令,但这些命令中有一部分未在“默认”快捷键集里定义。

也可以将键盘快捷键与段落或字符样式(请参阅添加段落和字符样式)或脚本关联。

更改现用快捷键集

  1. 如果要为所有文档激活快捷键,请确保没有打开任何文档。
  2. 选取编辑 > 键盘快捷键

  3. 在“集”菜单中选择一个快捷键集。例如,选择“QuarkXPress® 4.0 的快捷键”。
  4. 单击“确定”。

查看快捷键

  1. 选取编辑 > 键盘快捷键

  2. 对于“集”,请选择一个快捷键集。
  3. 对于“产品区域”,请选择包含要查看命令的区域。
  4. 从“命令”中选择一个命令。该快捷键将显示在“当前快捷键”部分中。

生成用于打印的快捷键列表

  1. 选取编辑 > 键盘快捷键

  2. 对于“集”,请选择一个快捷键集。
  3. 单击显示集

将打开一个文本文件,其中包含该集的所有当前快捷键和未定义的快捷键。

创建新快捷键集

  1. 选取编辑 > 键盘快捷键

  2. 单击新建集

  3. 键入新集的名称,在“基于集”菜单中选择一个快捷键集,然后单击“确定”。

创建或重新定义快捷键

  1. 选取编辑 > 键盘快捷键

  2. 对于集,选择一个快捷键集,或者单击新建集,以创建一个新的快捷键集。

    注意:

    无法编辑“默认”或“QuarkXPress”快捷键集。而是基于这些集之一创建新集,然后编辑新建集。

  3. 对于“产品区域”,请选择包含要定义或重新定义的命令的区域。
  4. 在“命令”列表中,选择要定义或重新定义的命令。
  5. 在“新建快捷键”框中,直接在键盘上按下用作新快捷键的键。如果组合键被另一命令所使用,InDesign 会在“当前快捷键”下显示该命令。也可以选择更改原快捷键,或尝试使用其他快捷键。

    注意:

    不要为菜单命令指定单键快捷键,因为单键快捷键会妨碍文本的键入。如果在键入单键快捷键时插入点处于文本录入状态,则 InDesign 会激活此键盘快捷键,而不是在文本中插入该字符。

  6. 在“上下文”列表中,选择要键盘快捷键发挥作用的环境。如此可确保快捷键按照预期方式发挥作用。例如,可以指定 Ctrl+G 合并表单元格(“表”上下文),指定 Ctrl+G 插入特殊字符(“文本”上下文)。

    注意:

    如果无论文档的当前状态是什么均希望快捷键发挥作用,请在“默认”上下文中指定快捷键。在其他上下文(如“表”或“文本”)中指定的快捷键会覆盖在“默认”上下文中指定的快捷键。

  7. 执行以下操作之一:
    • 如果当前不存在任何快捷键,请单击“指定”创建新快捷键。

    • 单击“指定”为命令添加另一个快捷键。菜单命令可拥有多个键盘快捷键。

  8. 单击“确定”关闭对话框,或单击“存储”将对话框保持为打开状态以便输入更多快捷键。

复制键盘快捷键集

键盘快捷键集 (*.indk) 存储在两个位置。应用程序预设的快捷键显示在应用程序主文件夹的“Presets”文件夹中。您创建的快捷键集显示在以下位置的“Shortcut Sets”文件夹中:

Windows XP

Documents and Settings\[用户名]\Application Data\Adobe\InDesign\[版本]\[语言]InDesign Shortcut Sets

Windows Vista、Windows 7 和 Windows 10

Users\[用户名]\AppData\Roaming\Adobe\InDesign\[版本]\[语言]\InDesign Shortcut Sets

Mac OS

用户/[用户名]/资源库/Preferences/Adobe InDesign/[版本]/[语言]/InDesign Shortcut Sets

如果在一台计算机上创建了键盘快捷键集,希望在另外一台计算机上使用,请将 *.indk 文件复制到目标计算机上的相同位置处。

您可以将键盘集从自定位置移动到应用程序文件夹。这样,共享该计算机的所有用户都可以使用这套自定快捷键。但是,请确保两个集的名称及位置均不同。确保应用程序键盘集和自定集具有不同的名称。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略