匯出影像與圖像

PNG 連續圖畫

您可以從「元件庫」或「舞台」的個別影片片段、按鈕或圖像元件匯出一系列影像檔案。匯出期間,Animate CC (先前稱為 Flash Professional CC) 會為元件中的每個影格建立個別影像檔案。如果從「舞台」匯出,影像輸出會保留您曾經套用至元件實體的任何變形 (例如縮放)。

若要匯出 PNG 連續圖畫:

  1. 選取「元件庫」或「舞台」上的單一影片片段、按鈕或圖像元件。

  2. 以滑鼠右鍵按一下選項並選擇「匯出 PNG 連續圖畫」。

    select-png-sequence
  3. 在「另存新檔」對話方塊中,選擇輸出的位置並按一下「確定」。

     

  4. 在「匯出 PNG 連續圖畫」對話方塊中設定您想要的選項。

    export-pngsequence

    寬度 - 影像輸出的寬度。您可以藉由變更此值來縮放輸出。預設值為元件內容的寬度。

    高度 - 影像輸出的高度。您可以藉由變更此值來縮放輸出。預設值為元件內容的高度。

    解析度 - 影像輸出的解析度。預設值為 72dpi。

    顏色 - 影像輸出的位元深度。您可以選擇 8、24 或 32 位元。預設值為 32 位元,支援透明度。如果您選擇不支援透明度的 24 位元或 8 位元,「背景」設定就會變更為「舞台」。請參閱下面內容。

    背景 - 做為影像輸出背景顏色的顏色。只有在「顏色」選項設定為 8 位元或 24 位元時,才能使用這個設定。當「顏色」設定為 32 位元時,影像背景一律為透明。當「顏色」選項設定為 8 位元或 24 位元時,「背景」選項會預設為「舞台」顏色。在 8 位元或 24 位元的影像中,您可以將設定變更為「不透明」,然後從顏色挑選器選取背景顏色。或者,為背景選擇 Alpha 值,以建立透明度。

    平滑化 - 切換是否將平滑化套用至影像輸出的邊緣。如果您不是使用透明背景,且影像採用不同於目前「舞台」顏色的背景顏色,請關閉這個選項。

  5. 按一下「匯出」匯出 PNG 連續圖畫。

匯出 GIF 動畫

您可以在 Animate 中執行下列步驟以匯出 GIF 動畫檔案:

  1. 移至「檔案 > 匯出 > 匯出 GIF 動畫」。

    隨即出現對話方塊。 

    export-animated-gif
  2. 在對話方塊中,選擇您所要的選項並按一下「完成」,將您的動畫匯出為 GIF 動畫檔案。

    animated-gif-dialog

    您也可以選擇「檔案 > 匯出 > 匯出影像」,以匯出靜態 GIF 影像檔案。

將影像和圖像匯出至 CC Library

若要將您的影像或圖像匯出至 CC Library,請選取「視窗 > CC Library」。

「CC Libraries」視窗隨即出現。 

add-to-cc-library

按一下「CC Libraries」視窗左下角的 + 圖示,選取影像或圖像檔案,然後按一下「增加」。

FXG 圖形交替格式 (Animate CC 不建議使用)

關於 FXG 檔案

FXG 格式是 Animate /Flash 平台的圖形交替檔案格式。FXG 是以 MXML 子集為基礎,而 MXML 則是 Flex 架構使用的 XML 型程式設計語言。FXG 格式可讓設計人員與開發人員以絕佳的精確度交換圖形內容,進而協助他們更有效率地協同合作。設計人員可以使用 Adobe 設計工具來建立圖形並將它們匯出為 FXG 格式。然後,您就可以在 Adobe Flash Builder 和 Adobe Flash Catalyst 等工具中使用 FXG 檔案來開發豐富的網際網路使用經驗和應用程式。

建立 FXG 檔案時,向量圖形會直接儲存在檔案中。FXG 中沒有對應標記的元素會匯出成為點陣圖圖形,並供 FXG 檔案參考。這些元素包括點陣圖、某些濾鏡、某些混合模式、漸層、遮色片和 3D。其中有些效果可以匯出成為 FXG,但無法由開啟 FXG 檔案的應用程式匯入。

當您使用 FXG 匯出功能來匯出包含向量和點陣圖影像的檔案時,就會與 FXG 檔案一起建立個別的資料夾。這個資料夾名為 <filename.assets> 而且包含與 FXG 檔案相關聯的點陣圖影像。

如需有關 FXG 檔案格式的詳細資訊,請參閱 FXG 2.0 規格

FXG 匯出限制

Animate 允許您在舞台上選取一或多個物件,以匯出為 FXG。匯出為 FXG 格式時,會保留物件與圖層名稱。

下列項目在儲存為 FXG 檔案時有所限制:

  • 九宮格縮放:可匯出,但只能使用 Adobe Illustrator 讀取。

  • 聲音與視訊:不匯出。

  • 組件:不匯出。

  • 多個影格的補間動畫與動畫:不匯出,但選取的影格會匯出為靜態物件。

  • 內嵌字體:不匯出。

  • Button 元件:Animate 僅匯出按鈕的「一般」狀態。

  • 3D 屬性:不匯出。

  • 反向運動 (IK) 屬性:不匯出。

  • 文字特質:部分特質可能不匯出。

以 FXG 格式匯出 Animate 內容

在 Animate 中,有兩種方式可將內容匯出為 FXG 格式:

  • 若要將「舞台」上的物件匯出為 FXG,請選取物件並選擇「匯出 > 匯出選取範圍」,然後從「存檔類型」選單選取 FXG 格式。

  • 若要將整個舞台儲存為 FXG,請選擇「匯出 > 匯出影像」,然後從「存檔類型」選單選取「Adobe FXG」。

JPEG 連續圖畫和 JPEG 影像

這些選項符合 JPEG 的「發佈設定」選項。然而,「符合螢幕」會在匯出的影像出現在螢幕上時,讓影像符合 Animate 內容的大小。「符合影片」會使 JPEG 影像與 Animate 內容相符,並且維持原始影像的比例。

PNG 連續圖畫和 PNG 影像

PNG 匯出設定選項與 PNG 的「發佈設定」選項相似 (您也可以加以套用),但有以下例外:

尺寸

可將匯出之點陣圖影像的大小,設定為您在「寬度」和「高度」欄位中輸入的像素數目。

解析度

以 dpi 為單位輸入解析度。若要使用螢幕解析度,並維持原始影像的比例,請選取「符合螢幕」。

顏色

與 PNG「發佈設定」索引標籤的「位元深度」選項相同,可設定建立影像時所用每個像素的位元數。對於 256 色影像,請選取 8 位元;數千種顏色的影像,請選取 24 bpc;具有透明度及數千種顏色的影像 (32 bpc),請選取含 Alpha 的 24 bpc。位元深度越高,檔案便越大。

包含

選擇匯出最小影像區域,或是指定完整文件大小。

註解:

匯出的 GIF 尺寸限制為小於 4000 像素的值。這項尺寸限制適用於 CS6 以後的版本。

註解:

如果選取「256 色」選項,「純色遞色」選項便不會運作。這表示,如果為 GIF 選取的色彩配置是 256 色,GIF 影像便不會呈現遞色。

(Animate CC 不建議使用) 點陣圖 (BMP) 影像

建立要在其他應用程式中使用的點陣圖影像。「匯出點陣圖」對話方塊包含下列選項:

尺寸

以像素為單位,設定匯出之點陣圖影像的大小。 您所指定的大小會一直與原始影像具有相同比例。

解析度

以每英吋的點數 (dpi) 為單位設定匯出點陣圖影像的解析度,並根據繪圖大小自動計算寬度和高度。若要將解析度設成與顯示器相符,可以選取「符合螢幕」。

顏色深度

指定影像的位元深度。有些 Windows 應用程式不支援點陣圖影像較新的每個色版 32 位元 (bpc) 深度。如果您使用 32 bpc 格式時發生問題,請使用 24 bpc 格式。

平滑化

可對匯出的點陣圖套用消除鋸齒功能。 消除鋸齒可產生較高品質的點陣圖影像,但會在彩色背景上的影像周圍產生灰色像素的暈圈。 如果出現暈圈,請將它取消選取。

Animate 文件 (SWF)

若要將 Animate 內容放置在其他應用程式 (例如 Dreamweaver),可以將整份文件匯出為 SWF 檔案。Animate 會使用 FLA 檔案的「發佈設定」中的目前設定來匯出 SWF 檔案。

使用 Adobe Media Encoder 匯出 HD 視訊

Animate CC 可讓您將補間動畫、元件和圖像匯出成各種格式的高畫質視訊。以 Animate 匯出的 HD 視訊可以與具有 Communications 功能的應用程式搭配使用,作為視訊會議、串流和分享之用。

根據預設,Animate 只能匯出成 QuickTime 影片 (.MOV) 檔案。若要使用匯出功能,您必須安裝最新的 QuickTime Player 版本,因為匯出 MOV 檔案時 Animate 會使用 QuickTime 元件庫。

HD 視訊匯出工作流程已重新經過模型化,因為 Animate 現在已與 Adobe Media Encoder 整合在一起。它可讓您將 MOV 檔案轉換成各種其他格式。總歸一句,Adobe Media Encoder 已最佳化成可以只顯示 Animate 內容的相關匯出格式。如需有關使用 Adobe Media Encoder 編碼和轉存視訊的詳細資訊,請參閱編碼以及轉存視訊和音訊

註解:

當您從 Creative Cloud 桌面應用程式安裝 Animate CC 時,就會自動安裝 Adobe Media Encoder。

舊版與新版匯出視訊工作流程的差異

新版工作流程與 CS6 和更早版本的匯出視訊工作流程不同。

主要不同之處在於:

  • 與 Adobe Media Encoder 整合:Animate CC 已經與 Adobe Media Encoder 7.0 整合,並且更早版本未取決於 AME。
  • 匯出格式:Animate CC 只能匯出 QuickTime 影片。
  • HD 視訊:Animate CC 可讓您匯出 HD 視訊。

此外,CS6 工作流程過去存在下列問題:

  • 使用 QuickTime 的 MOV 匯出工作流程容易出錯,而且會耗用許多記憶體。
  • AVI 匯出不支援影片片段。

在 Animate CC 中,上述問題都已獲得修正,包括「影格遺失」問題。有了 Adobe Media Encoder 工作流程,您就可以在 Animate CC 中順暢地匯出成 MOV 檔案。您可以運用全新的 AME 工作流程,將 Animate 內容匯出至 MOV 檔案,並於稍後使用 AME 將 MOV 檔案轉換成任何所需的輸出。

從影格 #2 開始匯出

視「時間軸」的建構方式而定,匯出的視訊可能是下列任一案例的結果:

  1. 如果根時間軸上有一個以上的影格,匯出將會從影格 #2 開始。
  2. 如果根時間軸上只有一個影格,匯出將會包含影格 #1。
  3. 如果根時間軸上有一個以上的影格,並且影格 #1 加入了 ActionScript 或聲音,將不會呼叫該影格。

匯出 HD 視訊

在您開始匯出之前,請先執行下列動作:

  • 安裝 QuickTime
  • 將影格速率設定為等於或小於 60 fps 的值。如需詳細資訊,請參閱動畫基礎概念
  1. 建立或開啟現有 FLA。

  2. 前往「檔案 > 匯出 > 匯出視訊」。

    export-video
    「匯出視訊」對話方塊

  3. 在「匯出視訊」對話方塊中,「顯示寬度」和「顯示高度」會假設為針對「舞台」大小所設定的寬度和高度值。

  4. 在「匯出視訊」對話方塊設定您所要的選項:

    • 顯示大小 HW:根據您要匯出的解析度設定顯示大小,結果會依您所選的 HD 視訊或標準匯出設定而有所不同。設定的值分別等於「舞台」的「寬度」和「高度」。如果您想要變更「顯示寬度」和「顯示高度」值,請據此修改「舞台」大小。Animate 會根據「舞台」尺寸維持比例。
    • 「忽略舞台顏色 (產生 Alpha 色版)」:使用舞台顏色建立 Alpha 色版。Alpha 色版會編碼為透明軌道,讓您將匯出的 QuickTime 影片重疊於其他內容上,以更改背景顏色或場景。
    • 「在 Adobe Media Encoder 中轉換視訊」:如果您想要使用 AME 將匯出的 MOV 檔案轉換成不同格式,請選取這個選項。選取後,AME 會在 Animate 完成匯出視訊時啟動。
    • 「停止匯出」:指定 Animate 何時終止匯出。
      • 「達到最後一個影格時」:如果您希望在最後一個影格終止,請選取這個選項。
      • 「經過後續時間之後」:選取這個選項可指定您要在特定時間間隔後終止匯出。這個選項可讓您個別匯出視訊的區段。
    • 「匯出視訊的路徑」:輸入或瀏覽至您要匯出視訊的路徑。
  5. 按一下「匯出」。如果您選取了「在 Adobe Media Encoder 中轉換視訊」選項,就會啟動 AME,並且匯出的 MOV 檔案會出現在新佇列中。若要深入了解如何使用 AME 編碼及轉換視訊,請參閱編碼以及轉存視訊和音訊

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策