使用匯入的點陣圖

將點陣圖匯入 Animate 時,您可以修改該點陣圖,並以各種方式用於 Animate 文件中。

如果 Animate 文件顯示的匯入點陣圖大於原本的大小,影像可能會呈現扭曲。若要確定影像是否正確顯示,請預覽匯入的點陣圖。

在「舞台」上選取某個點陣圖時,「屬性」檢測器會顯示該點陣圖的元件名稱,以及該點陣圖在「舞台」上的像素尺寸和位置。使用「屬性」檢測器可替換點陣圖的實體,也就是使用目前文件中的另一個點陣圖實體來取代此實體。

 

顯示含點陣圖屬性的屬性檢測器

  1. 在「舞台」上選取點陣圖實體。

  2. 選取「視窗 > 屬性」。

用另一個點陣圖的實體取代這個點陣圖實體

  1. 在「舞台」上選取點陣圖實體。

  2. 選取「視窗 > 屬性」,然後按一下「替換」。

  3. 選取點陣圖以取代目前指定給此實體的點陣圖。

設定點陣圖屬性

您可以將消除鋸齒功能套用至匯入的點陣圖,以便將影像的邊緣平滑化。您也可以選取壓縮選項,以便減少點陣圖檔案的大小,並將點陣圖格式化為適合在網頁上顯示的檔案。

  1. 在「元件庫」面板中選取點陣圖,然後按一下「元件庫」面板底部的「屬性」按鈕。
  2. 選取「允許平滑化」。可以縮放點陣圖影像時,使用平滑化可以改善影像品質。
  3. 針對「壓縮」,請選取下列其中一個選項:

    相片 (JPEG)

    將影像壓縮為 JPEG 格式。若要使用原本為匯入影像指定的預設壓縮品質,請選取「使用文件預設品質」。若要指定新的壓縮品質設定,請取消選取「使用文件預設品質」,然後在「品質」文字欄位中輸入介於 1 和 100 之間的值 (設定值愈高,就能保留愈良好的影像完整性,但檔案大小也越大)。

    不失真 (PNG/GIF)

    使用不失真的壓縮方式將影像壓縮,而且不會捨棄影像的任何資料。

    注意:針對顏色或色調變化複雜的影像,例如相片或具有漸層填色的影像,請使用「相片」壓縮方式。針對形狀簡單且顏色較少的影像,請使用「不失真」壓縮。

  4. 若要判斷檔案壓縮的結果,請按一下「測試」。若要決定是否可以接受選取的壓縮設定,請比較原始檔案大小和壓縮檔案大小。
  5. 按一下「確定」。

註解:

在「發佈設定」對話方塊中選取的「JPEG 品質」設定不會指定匯入 JPEG 檔案的品質設定。請在「點陣圖屬性」對話方塊中指定每一個匯入之 JPEG 檔案的品質設定。

(僅適用於 Animate CC) 替換多個點陣圖

「替換點陣圖」選項可讓您將元件和點陣圖替換為選取的元件或點陣圖。

  1. 在 Animate Pro CC 中,選取舞台上的多個點陣圖。

  2. 在「屬性」面板中,按一下「替換」。
  3. 在「替換元件」對話方塊中,選取您要用來取代所有選取之元件/點陣圖的點陣圖。
  4. 按一下「確定」。

在執行階段匯入點陣圖

若要在執行階段新增點陣圖到文件中,請使用 ActionScript® 2.0 或 ActionScript 3.0 的 BitmapData 命令。若要這樣做,請指定點陣圖的連結識別名稱。如需詳細資訊,請參閱學習 ActionScript 2.0 中的「指定連結到元件庫中的資源」,或 ActionScript 3.0 開發人員指南中的匯出元件庫元件給 ActionScript 使用

  1. 在「元件庫」面板中選取點陣圖。
  2. 請執行下列其中一項:
    • 在面板右上角的「面板」選單中選取「連結」。

    • 在「元件庫」面板中的點陣圖名稱上按一下右鍵 (Windows) 或按住 Control 並按一下 (Macintosh),然後在快顯選單中選取「屬性」。

      如果「屬性」對話方塊中沒有顯示「連結」屬性,請按一下「進階」。

  3. 針對「連結」,請選取「匯出給 ActionScript 使用」。
  4. 在文字欄位中輸入識別名稱字串,然後按一下「確定」。

套用點陣圖當做填色

若要將點陣圖當做填色內容套用至圖像物件,請使用「顏色」面板。將點陣圖當做填色套用時,會將該點陣圖並排顯示於物件填色範圍之內。「漸層變形」工具可讓您對影像和影像的點陣圖填色進行縮放、旋轉或傾斜。

  1. 若要將填色套用至現有的圖案,請在「舞台」上選取一個或多個圖案物件。
  2. 選取「視窗 > 顏色」。
  3. 在面板右下角的彈出式選單中選取「點陣圖」。
  4. 若要使用更大的預覽視窗,在目前的文件中顯示更多點陣圖,請按一下右下角的箭頭,展開「顏色」面板。
  5. 按一下點陣圖,選取該點陣圖。

    這個點陣圖會成為目前的填色顏色。如果您在步驟 1 中選取了圖案,這個點陣圖就會當做填色套用至該圖案。

在外部編輯器中編輯點陣圖

如果您要編輯匯入成平面化影像的 Fireworks PNG 檔案,請編輯該點陣圖的 PNG 來源檔案 (如果可用的話)。

註解:

您無法在外部影像編輯器中,針對匯入成可編輯物件之 Fireworks PNG 檔案的點陣圖進行編輯。

如果系統上安裝了 Fireworks 3 或更新版本,或是安裝了其他的影像編輯應用程式,您就可以從 Animate 啟動該應用程式,對匯入的點陣圖進行編輯。

使用 Photoshop CS5 或更新版本編輯點陣圖

註解:

如果您使用 CS5.5,您需要使用 Photoshop CS5.1 才能存取此功能。

  1. 在「元件庫」面板中以滑鼠右鍵按一下 (Windows) 或 Control+按一下 (Macintosh) 點陣圖圖示,然後選取「使用 Photoshop CS5 編輯」。

  2. 在 Photoshop 中對檔案執行所需的修改。

  3. 在 Photoshop 中,選取「檔案 > 儲存」。(請勿更改檔案名稱或格式。)

  4. 返回 Animate。

    此檔案會自動在 Animate 中完成更新。

使用 Fireworks 3 或更新版本來編輯點陣圖

  1. 在「元件庫」面板中的點陣圖圖示上按一下右鍵 (Windows) 或 Control+按一下點陣圖圖示 (Macintosh),然後選取「使用 Fireworks 3 編輯」。

  2. 指定要開啟 PNG 來源檔案還是點陣圖檔案。

  3. 在 Fireworks 中對檔案執行所要的修改。

  4. 在 Fireworks 中選取「檔案 > 更新」。

  5. 返回 Animate。

    此檔案會自動在 Animate 中完成更新。

使用其他影像編輯應用程式編輯點陣圖

  1. 在「元件庫」面板中的點陣圖圖示上按一下右鍵 (Windows) 或按住 Control 並按一下點陣圖圖示 (Macintosh),然後選取「編輯程式」。

  2. 選取可開啟點陣圖檔案的影像編輯應用程式,然後按一下「確定」。

  3. 在影像編輯應用程式中,對檔案進行您想要的修改。

  4. 在影像編輯應用程式中,將檔案儲存起來。

    此檔案會自動在 Animate 中完成更新。

  5. 返回 Animate 繼續編輯文件。

打散點陣圖並建立點陣圖填色

打散「舞台」上的點陣圖會將「舞台」上的影像從其元件庫項目中分離,並將該影像從點陣圖實體轉換成形狀。打散點陣圖之後,您就可以使用 Animate 繪圖和上色工具來修改點陣圖。您可以使用「魔術棒」工具,選取包含相同或相似顏色的點陣圖區域。

若要使用打散後的點陣圖進行繪圖,請使用「滴管」工具選取點陣圖,然後使用「油漆桶」或其他繪圖工具將點陣圖當做填色套用。

打散點陣圖

  1. 在目前的場景中選取點陣圖。

  2. 選取「修改 > 打散」。

變更打散後的點陣圖填色區域

  1. 在「工具」面板中,選取「魔術棒」工具。如果沒有看到「魔術棒」工具,請按一下「套索工具」,並從彈出式選單中選取「魔術棒」工具。在「屬性」檢測器中設定下列選項:

    • 針對「臨界值」,請輸入介於 1 和 200 之間的值,定義相鄰的像素顏色之間必須接近到何種程度,才能包含在選取範圍中。數字越高,包含的顏色範圍就越廣。如果輸入 0,只會選取與第一個按下的像素顏色完全相同的像素。

    • 針對「平滑化」,請選取選項來定義選取範圍邊緣的平滑化程度。

  2. 若要選取區域,請按一下點陣圖。若要加入至選取範圍,請繼續按一下。

  3. 若要將選取區域填入點陣圖中,請從「填色顏色」控制項選取要使用的填色。

  4. 若要套用新的填色,請選取「油漆桶」工具,並在選取區域內的任何位置按一下。

將點陣圖轉換成向量圖像

「轉換成向量圖」命令會將點陣圖轉換成向量圖像,而且向量圖像內將包含可編輯的分離顏色區域。您可以將影像當做向量圖像操作,而且可以減少檔案大小。

將點陣圖轉換成向量圖像之後,向量圖像就不再連結到「元件庫」面板中的點陣圖元件。

註解:

如果匯入的點陣圖包含複雜的形狀和大量顏色,轉換後的向量圖像檔案可能會大於原始的點陣圖大小。若要找出檔案大小和影像品質之間的平衡點,請在「轉換成向量圖」對話方塊中嘗試各項設定。

您也可以打散點陣圖,以便使用 Animate 的繪圖和上色工具來修改影像。

  1. 在目前的場景中選取點陣圖。

  2. 選取「修改 > 點陣圖 > 轉換成向量圖」。

  3. 輸入顏色臨界值。

    在對兩個像素進行比較時,如果 RGB 顏色值的差異小於顏色臨界值,這兩個像素將被視為相同的顏色。增加臨界值,顏色的數目便會減少。

  4. 針對「最小區域」,請輸入一個值來設定為像素指定顏色時周圍像素的數目。

  5. 針對「曲線符合」,請選取選項來決定繪製外框的平滑度。

  6. 針對「轉角臨界值」,請選取選項來決定要保留銳利的邊緣還是進行平滑化。

    若要建立看起來最接近原始點陣圖的向量圖像,請輸入下列值:

    • 顏色臨界值:10

    • 最小區域:1 個像素

    • 曲線符合:像素

    • 轉角臨界值:很多轉角

使用滴管工具來套用點陣圖填色

  1. 選取「滴管」工具,然後在「舞台」上按一下打散之後的點陣圖。「滴管」工具會將點陣圖設成目前的填色,並將作用中的工具變更為「油漆桶」。

  2. 請執行下列其中一項:

    • 若要將點陣圖當做填色套用,請使用「油漆桶」工具按一下現有的圖像物件。

    • 選取「橢圓形」、「矩形」或「鋼筆」工具,然後繪製新的物件。該物件會以打散之後的點陣圖填滿。

      若要針對點陣圖填色進行縮放、旋轉或斜切,請使用「自由變形」工具。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策