關於多國語言文字

您可以設定 FLA 檔案,視播放 Animate 內容的作業系統的語言而定,以不同語言顯示文字。

註解:

網頁上已提供最新的完整「說明」。應用程式未偵測到網際網路連線。如需本主題的詳細資訊,請按下列連結或搜尋完整的說明,網址:http://helpx.adobe.com/tw/support.html

您可以設定 FLA 檔案,視播放 Animate 內容的作業系統的語言而定,以不同語言顯示文字。

請參閱線上說明中與多國語言文字相關的討論,以了解如何在 Animate 中使用多國語言文字。

Animate 中的多國語言文字

按照下列的方式,您可以將多國語言文字併入文件中:

  • (不建議與 Animate CC 搭配使用)「字串」面板讓當地語系化人員可以在 Animate 內部的中心位置編輯字串,或使用偏好的軟體或翻譯記憶庫在外部 XML 檔案中編輯字串。Animate 在「字串」面板和 XML 檔案中都支援多行字串。

  • 您可以選擇要內嵌於應用程式的字元集,以此來限制所發佈 SWF 檔中的字元 Glyph 的數量,並減少檔案大小。

  • 您可以使用「西歐」樣式的鍵盤在「舞台」上建立中文、日文及韓文文字。

  • 如果系統中已安裝 Unicode 字體,您可以直接在文字欄位中輸入文字。由於該字體並不是內嵌的,因此使用者同樣也要有 Unicode 字體才行。

    下列為在 Animate 文件中納入多國語言文字時,其他幾種較不常見的方法:

  • 使用 #include 動作,在動態或輸入文字欄位包含外部文字檔案。

  • 在執行階段使用 loadVariablesgetURL 動作,或 LoadVarsXML 物件將外部文字或 XML 檔案載入 Animate 應用程式。

  • 您可以在動態或輸入文字欄位變數的字串值中,輸入 Unicode 反斜線字元。

  • 您可以在「元件庫」中建立做為元件的內嵌字體。

    為了讓以 Unicode 編碼的文字可以正確顯示,使用者必須可存取其中包含用於該文字中之文字 (字元) 的字體。

如需多國語言內容的範例,請參閱 www.adobe.com/go/learn_fl_samples_tw 上的「Animate 範例」網頁。下載並解壓縮 Samples 這個壓縮檔,然後瀏覽至 Text\MultilingualContent 資料夾存取範例。

關於 Unicode 編碼文字的字體

當您使用以 Unicode 編碼的外部檔案時,使用者必須要能存取包含文字檔案所使用所有文字的字體。根據預設,Animate 會儲存用於動態或輸入文字欄位中的字體名稱。在播放 SWF 檔期間,Flash Player 7 (以及較早版本) 會在執行該播放程式的作業系統中尋找那些字體。

如果 SWF 檔中包含不受指定字體支援的 Glyph,Flash Player 7 和 Flash Player 8 均會嘗試在支援這些 Glyph 的使用者系統中尋找字體。播放程式不一定每次都能找到適當的字體。這個狀況取決於使用者系統上可用的字體,同時也跟執行 Flash Player 的作業系統相關。

XML 字體內嵌表格

當您選取字體範圍以嵌入 FLA 檔案時,Animate 會使用 UnicodeTable.xml 檔案,以判斷要嵌入哪些字元。UnicodeTable.xml 檔案內含各種語言所需的字元範圍,且位於電腦的使用者設定檔資料夾中。檔案會位於下列目錄:

  • Windows:<開機磁碟>\Documents and Settings\<使用者>\Local Settings\Application Data\Adobe\Flash<版本>\<語言>\Configuration\FontEmbedding\

  • Macintosh:<使用者>/Library/Application Support/Adobe/Flash <版本>/<語言>/Configuration/FontEmbedding/

字體集是以 Unicode Consortium 所定義的 Unicode Block 為根據來進行分組。若要提供更簡單的工作流程,當選取特定語言時,相關的文字範圍即使散佈在不相連的群組中,也全都會嵌入。

例如,如果您選取「韓文」,就會嵌入下列 Unicode 字元範圍:

3131-318E 韓文 (Hangul) 符號

3200-321C 韓文 (Hangul) 特殊符號

3260-327B 韓文 (Hangul) 特殊符號

327F-327F 韓文 (Korean) 符號

AC00-D7A3 韓文 (Hangul) 符號

如果您選取韓文 (Korean) + CJK,則會嵌入大型字體集:

3131-318E 韓文 (Hangul) 符號

3200-321C 韓文 (Hangul) 特殊符號

3260-327B 韓文 (Hangul) 特殊符號

327F-327F 韓文 (Korean) 符號

4E00-9FA5 CJK 符號

AC00-D7A3 韓文 (Hangul) 符號

F900-FA2D CJK 符號

如需不同撰寫系統特定 Unicode 範圍的詳細資訊,請參閱 Unicode 5.2.0 規格

下表列出更多有關內嵌字體之字體選項的詳細資訊:

範圍

說明

大寫字母 [A - Z]

基本拉丁大寫文字,加上空白字元 0x0020。

小寫字母 [a - z]

基本拉丁小寫文字,加上空白字元 0x0020。

數字 [0 - 9]

基本拉丁數字文字

標點符號 [!@#%...]

基本拉丁標點符號

基本拉丁

在 Unicode 範圍中從 0x0020 到 0x007E 的基本拉丁文字。

日文假名

平假名與片假名文字 (包括半形格式)

日文漢字 – 階層 1

日文漢字字元

日文 (全部)

日文假名與漢字 (包括標點符號與特殊字元)

基本韓文

最常用的韓文字元、羅馬字元、標點符號以及特殊字元/符號

韓文 (全部)

11,720 個韓文字元 (按「韓文」音節排序)、羅馬字元、標點符號以及特殊字元/符號

繁體中文 – 階層 1

在台灣最常用的 5000 個繁體中文字元

繁體中文 (全部)

所有在台灣以及香港使用的繁體中文字元與標點符號

簡體中文 – 階層 1

在中國大陸最常用的 6000 個簡體中文字元與標點符號

中文 (全部)

所有繁體與簡體中文字元和標點符號

泰文

所有泰文文字

梵文

所有梵文文字

拉丁 I

拉丁 1 補充範圍 0x00A1 到 0x00FF (包括標點符號、上標與下標、貨幣元件以及類似字母的符號)

拉丁擴充 A

拉丁擴充-A 範圍 0x0100 到 0x01FF (包括標點符號、上標與下標、貨幣元件以及類似字母的符號)

拉丁擴充 B

拉丁擴充-B 範圍 0x0180 到 0x024F (包括標點符號、上標與下標、貨幣元件以及類似字母的符號)

拉丁擴充附加

拉丁擴充附加範圍 0x1E00 到 0x1EFF (包括標點符號、上標與下標、貨幣符號以及類似字母的符號)

希臘文

希臘文與埃及古語,加上希臘文擴充 (包括標點符號、上標與下標、貨幣符號以及類似字母的符號)

斯拉夫文

斯拉夫文 (包括標點符號、上標與下標、貨幣符號以及類似字母的符號)

亞美尼亞文

亞美尼亞文加上連字

阿拉伯文

阿拉伯文加上「表現形式 - A」以及「表現形式 - B」

希伯來文

希伯來文加上表現形式 (包括標點符號、上標與下標、貨幣符號以及類似字母的符號)

非 Unicode 的外部檔案

如果您將非 Unicode 編碼的外部文字或 XML 檔案載入到 Flash Player 7 應用程式,當 Flash Player 嘗試以 Unicode 顯示這些文字或檔案時,外部檔案中的文字就無法正確顯示。若要讓 Flash Player 使用執行播放程式之作業系統的傳統字碼頁,請在載入資料之 Animate 應用程式的第一個影格中加入下列程式碼並使其位於第一行:

system.useCodepage = true;

在文件中請只設定 system.useCodepage 屬性一次。在文件中,請不要多次使用此屬性,讓播放程式一下以 Unicode 解譯某些外部檔案,一下又以其他編碼解譯其他外部檔案,這樣會導致無法預期的結果。

如果您將 system.useCodepage 屬性設定為 true,請記得執行播放程式之作業系統的傳統字碼頁中,必須包含外部文字檔案使用的文字,以便能夠顯示文字。例如,如果您載入包含中文字元的外部文字檔案,那些字元將不會顯示在使用 CP1252 字碼頁的系統上,因為該字碼頁並不包含中文字元。為確保所有平台上的使用者都可以檢視您 Animate 應用程式中所用的外部文字檔案,請將所有外部文字檔案編碼成為 Unicode,並根據預設將 system.useCodepage 維持設定成 false。這樣會讓 Flash Player 將文字以 Unicode 解譯。如需詳細資訊,請參閱 ActionScript 2.0 語言參考中的 useCodepage (System.useCodepage 屬性)。

文字編碼

電腦中所有的文字都以一連串位元組的形式編碼。有許多不同的編碼方式 (因此也會有不同的位元組) 會用來代表文字。不同的作業系統會使用不同類型的文字編碼方式。例如,西歐 Windows 作業系統通常使用 CP1252 編碼方式,西歐 Macintosh 作業系統通常使用 MacRoman 編碼方式,而日本的 Windows 與 Macintosh 系統通常使用 Unicode 編碼方式。

全世界使用的語言及字元大部分都能以 Unicode 編碼。電腦所使用的其他文字編碼方式都是 Unicode 格式的子集,專為世界上特定的區域量身訂做。在這些編碼方式中,有的在某些方面是相容的,在其他方面則不相容,所以使用正確的編碼方式非常重要。

Unicode 具有數種格式。Flash Player 6、7 與更新版本都支援使用 8 位元 Unicode 格式的 UTF-8、16 位元 Unicode 格式的 UTF-16 BE (Big Endian) 以及 UTF-16 LE (Little Endian) 的文字或外部檔案。

Unicode 與 Flash Player

Flash Player 6 與更新版本都支援 Unicode 的文字編碼方式。任何安裝 Flash Player 6 或更新版本的使用者,只要有安裝正確的字體,不論執行該播放程式的作業系統使用何種語言,都能檢視多國語言文字。

除非命令播放程式,否則 Flash Player 會假設所有與 Flash Player 應用程式相關聯的外部文字檔都以 Unicode 編碼。

對於 Flash Player 5 以及更早版本 (使用 Flash MX 或更早版本所編寫) 中的 Animate 應用程式,Flash Player 6 與更早的版本會使用執行該播放程式之作業系統上的傳統字碼頁來顯示文字。

如需 Unicode 的背景資訊,請到 Unicode.org。

Flash Player 中的文字編碼

根據預設,Flash Player 7 與更新版本會假設所有遇到的文字,都是以 Unicode 編碼。如果您的文件載入外部文字或 XML 檔,這些檔案中的文字應該都是以 UTF-8 來編碼。您可以使用「字串」面板、文字或可將檔案以 Unicode 格式儲存的 HTML 編輯器來建立這些檔案。

Flash Player 支援的 Unicode 編碼格式

在閱讀 Animate 中的文字資料時,Flash Player 會檢視檔案最前面的兩個位元組,以偵測位元組順序標記 (BOM),這是用來識別 Unicode 編碼格式的標準格式化慣例。如果沒有偵測到 BOM,就會將文字編碼解譯為 UTF-8 (8 位元編碼格式)。建議您在應用程式中使用 UTF-8 編碼方式。

如果 Flash Player 偵測到下列其中一項 BOM,就會將文字編碼格式解譯如下:

  • 如果檔案的第一個位元是 OxFE,第二個是 OxFF,就會將編碼方式解譯為 UTF-16 BE (Big Endian)。這適用於 Macintosh 作業系統。

  • 如果檔案的第一個位元是 OxFF,第二個是 OxFE,就會將編碼方式解譯為 UTF-16 LE (Little Endian)。這適用於 Windows 作業系統。

    大部分能夠以 UTF-16BE 或 LE 儲存檔案的文字編輯器都會自動將 BOM 加入檔案。

    注意:如果您將 system.useCodepage 屬性設定為 true,文字會使用執行該播放程式的作業系統上的傳統字碼頁解譯,不會以 Unicode 解譯。

在外部 XML 檔案中進行編碼

您無法透過變更編碼標籤來變更 XML 檔的編碼。Flash Player 會以用於所有外部檔案的相同規則來識別外部 XML 檔的編碼。如果在檔案的開頭沒有遇到 BOM,就會假設檔案是以 UTF-8 來編碼。如果遇到 BOM,就會以 UTF-16BE 或 LE 解譯該檔案。

建立多國語言文字

您可以設定 FLA 檔案,視播放 Animate 內容的作業系統的語言而定,以不同語言顯示文字。

註解:

網頁上已提供最新的完整「說明」。應用程式未偵測到網際網路連線。如需本主題的詳細資訊,請按下列連結或搜尋完整的說明,網址:http://helpx.adobe.com/tw/support.html

您可以設定 FLA 檔案,視播放 Animate 內容的作業系統的語言而定,以不同語言顯示文字。

請參閱線上說明中與建立多國語言文字相關的討論,以了解如何新增多國語言文字至您的 FLA 檔。

使用字串面板編寫多國語言文字的工作流程

「字串」面板可讓您建立與更新多國語言內容。您可以指定合併多國語言的文字欄位內容,並讓 Animate 根據執行 Flash Player 電腦所用的語言,自動決定顯示的內容。

下列步驟說明了一般的工作流程:

以一種語言編寫 FLA 檔。

任何您想要以另一種語言來輸入的文字,都必須放在動態或輸入文字欄位中。

在「字串」面板的「設定」對話方塊中,選取您想要併入的語言,並選取其中一項做為預設語言。

「字串」面板中就會加入該語言欄。當您儲存、測試或發佈應用程式時,就會針對每一種語言建立一個包含 XML 檔的資料夾。

在「字串」面板中,為每一個含有 ID 的文字字串編碼。

發佈應用程式

針對您所選取的每種語言都會建立一個資料夾,每種語言的資料夾中就是用於該語言的 XML 檔。

將發佈的 FLA 檔和 XML 資料夾以及檔案傳送給譯者。

您可以使用自己的語言來編寫,並讓譯者進行翻譯。譯者可以直接在 XML 檔或 FLA 檔中使用翻譯軟體。

當您從譯者那裡收到翻譯之後,請將翻譯後的 XML 檔匯入 FLA 檔。

註解:

具有從「字串」面板填入消除鋸齒傳統、動態文字欄位的 Flash Pro CS4 檔案,在更新為 Flash Pro CS5 後可能無法正確顯示。這是因為 Flash Pro CS5 中內嵌的字體有所變更。若要解決此問題,請手動內嵌文字欄位所使用的字體。如需指示,請參閱一致文字外觀的內嵌字體

選取並移除翻譯的語言

「舞台」上最多可以顯示 100 種不同的語言,並放在「字串」面板中以供翻譯。每種選取的語言在「字串」面板都會有一個欄位。若要用選取的任何語言在「舞台」上顯示文字,請變更「舞台」語言。當您發佈或測試檔案時,會顯示所選的語言。

在選取語言時,您可以使用彈出式選單中提供的任何語言,以及其他任何支援 Unicode 的語言。

選取語言

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「設定」。
  2. 執行下列步驟之一以新增語言:
    • 在「語言」方塊中,反白標示以選取某個語言,然後按一下「增加」。

    • 如果該語言沒有出現在「語言」方塊中,請在「語言」方塊下方的空白欄位中,輸入格式為 xx 的語言代碼 (該語言代碼是由 ISO 639-1 所訂定)。按一下「新增」。

  3. 重複先前步驟,直到已新增所有想要的語言為止。
  4. 從「預設執行階段語言」選單中,選取預設語言。這個語言會在不含某個您選取之作用中語言的系統上顯示。
  5. 如果想在執行階段從不同的 URL 為語言載入 XML 檔,請在 URL 文字方塊中輸入該 URL 後按一下「確定」。

    在「字串」面板中會顯示每種選取語言的語言欄。語言欄會依照字母順序出現。

  6. 儲存 FLA 檔。儲存 FLA 檔時,會將所選取之每種語言的資料夾建立在 SWF 發佈路徑所指定的相同資料夾內。如果沒有選取任何 SWF 的發佈路徑,它就會建立在 FLA 檔所在的資料夾內。每一個語言檔中建立的 XML 檔都會用於載入已翻譯的文字。

移除語言

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「設定」。
  2. 在「作用中的語言」欄位中,反白標示某一語言並按一下「移除」。
  3. 重複步驟 3,直到已移除所有想要移除的語言為止。
  4. 移除語言完成之後,按一下「確定」。

    在「字串」面板中就不會再顯示已移除語言的語言欄。

註解:

當您從「字串」面板中移除某個語言時,並不會將該語言的 XML 檔從本機檔案系統中刪除。這種作法可以讓您利用之前的 XML 檔,將該語言新增回「字串」面板,以避免無心的刪除動作。若要完全移除該語言,您必須刪除或取代該語言的 XML 檔。

在字串面板中新增字串

您可以使用下列方式將文字字串指定到「文字」面板:

  • 將字串 ID 指定到動態或輸入文字欄位

  • 新增字串 ID 至字串面板而不指定到文字欄位

  • 將現有的字串 ID 指定到現有的動態或輸入文字欄位

將字串 ID 指定到文字欄位

  1. 選取「視窗 > 其他面板 > 字串」。
  2. 選取「文字」工具。在舞台上,建立輸入或動態文字欄位。
  3. 當選取文字欄位時,在「字串」面板的 ID 欄位中輸入唯一的 ID。
  4. 按一下「設定」按鈕,並從「設定」對話方塊的清單中選取一種或多種語言。您所選取的語言應該包括您想要使用的預設語言,以及您打算用來發佈工作的任何其他語言。
  5. 按一下「套用」。

註解:

如果在「舞台」上選取靜態文字方塊,則「字串」面板上的「舞台」文字選取部分會顯示「靜態文字沒有相關的 ID」訊息。如果選取了非文字項目或多個項目,就會顯示「目前的選取範圍沒有相關的 ID」訊息。

新增字串 ID 至字串面板而不指定到文字欄位

  1. 選取「視窗 > 其他面板 > 字串」。
  2. 按一下「設定」按鈕,並從「設定」對話方塊的清單中選取一種或多種語言。您所選取的語言應該包括您想要使用的預設語言,以及您打算用來發佈工作的任何其他語言。
  3. 在「字串」面板中輸入新的字串 ID 以及新的字串,然後按一下「套用」。

將現有的 ID 指定到文字欄位

  1. 選取「文字」工具。在舞台上,建立輸入或動態文字欄位。
  2. 在「字串」面板上的 ID 區域中,輸入現有 ID 的名稱,然後按一下「套用」。

註解:

您可以按 Shift+Enter,將 ID 套用至文字欄位;或者,如果焦點在 ID 欄位上的話,請直接按 Enter 即可。

在字串面板中編輯字串

當您在「字串」面板中輸入文字字串之後,請使用下列其中一種方法編輯這些文字字串:

  • 直接在「字串」面板的儲存格中進行編輯。

  • 在以選取做為「舞台」語言之語言所顯示的「舞台」上,使用如尋找、取代和拼字檢查這類功能進行編輯。使用這些功能變更的文字,也會在「舞台」上以及「字串」面板中變更。

  • 直接編輯 XML 檔。

變更舞台上顯示的語言

  1. 選取「視窗 > 其他面板 > 字串」。
  2. 在「舞台語言」選單中,選取「舞台」語言要使用的語言。該語言必須是已新增的可用語言。

    變更舞台語言之後,您在舞台上新輸入的任何文字都會以該語言顯示。如果您先前已經在「字串」面板中輸入該語言的文字字串,則「舞台」上的任何文字都會以選取的語言顯示。如果沒有,則已經在舞台上的文字欄位會變空白。

在西歐鍵盤上輸入亞洲字元

在 Animate 中,您可以使用「輸入法編輯器」(IME) 和標準的西歐鍵盤在「舞台」上輸入亞洲字元。Animate 支援超過二十多種不同的 IME。

例如,若要建立亞洲使用者都可以檢視的網站,您可以使用標準西歐 (QWERTY) 鍵盤並變更 IME 以建立中文、日文和韓文文字。

註解:

這只會影響「舞台」上的文字輸入,而不會影響在「動作」面板中輸入的文字。所有支援的 Windows 作業系統及 Mac OS X 都有這項功能。

  1. 選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),然後按一下「類別」清單中的「文字」。

  2. 在「輸入方法」底下,選取其中一個選項以使用西歐鍵盤輸入字元。預設的選項為「中文和日文」,而且針對西歐語言,也應該選取此選項。

發佈多國語言 FLA 檔案

當您儲存、發佈或測試 FLA 檔時,會針對在「字串」面板中所選取的每種可用語言建立包含 XML 檔的資料夾。XML 資料夾與檔案的預設位置與指定的 SWF 發佈路徑位於相同的資料夾內。如果尚未選取 SWF 發佈路徑,XML 資料夾和檔案將會儲存在 FLA 檔所在的資料夾。例如,如果您在 mystuff 資料夾中有一個名為 Test 的檔案,且已選取英文 (en)、德文 (de) 和西班牙文 (es) 做為作用中的語言,不過還沒有選取 SWF 的發佈路徑,那麼當您儲存 FLA 檔時,就會建立下列資料夾結構:

\mystuff\Test.fla 
\mystuff\de\Test_de.xml 
\mystuff\en\Test_en.xml 
\mystuff\es\Test_es.xml

當您在啟動 SWF 檔案時,也必須啟動相關的 XML 檔案,以及包含在內之 Web 伺服器中的字串翻譯。包含文字的第一個影格要在 XML 檔整個下載完畢後才能顯示。

在發佈階段手動取代字串

發佈 Animate SWF 檔案時,您可以使用「舞台」語言手動取代字串。這個方法會使用「舞台」語言,取代包含相關字串 ID 之輸入和動態文字的所有實體。在這樣的情況下,文字字串只會在發佈 SWF 檔時才更新。由於語言偵測並不會自動進行,所以您必須為每種要支援的語言發佈 SWF 檔。

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「設定」。
  2. 在「取代字串」核取方塊中,選取「在執行階段自動執行」。

搭配預設語言使用自動語言偵測

您可以將預設執行階段語言變更為任何已選取的可用語言。當開啟自動語言偵測功能,而且您在使用該語言的系統中檢視 SWF 時,所有其語言設定為其中一個作用中語言以外的系統都會使用預設的語言。例如,如果您將預設語言設定為英文,同時選取 ja、en 以及 fr 做為作用中的語言,那麼系統語言設定為日文、英文或法文的使用者,便會自動看到以他們語言所顯示的文字字串。然而,使用者如果將系統語言設定為瑞典文,由於瑞典文並不在您所選的語言之列,使用者會看見系統自動以您所選的預設語言顯示文字字串,在這個範例中即是以英文來顯示。

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「設定」。
  2. 在「預設」語言選單中,選取預設語言。該語言必須是已新增的可用語言。
  3. 若要啟用自動語言偵測功能,請在「取代字串」核取方塊中選取「在執行階段自動執行」,並按一下「確定」。

Animate 會產生下列 ActionScript®,其中儲存語言 XML 檔案的路徑。您可以將這個程式碼視為自己的語言偵測指令碼起點來使用。

import mx.lang.Locale; 
Locale.setFlaName("<flaFileName>"); 
Locale.setDefaultLang("langcode"); 
Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

註解:

「字串」面板產生的 ActionScript 程式碼並不會使用 Locale.initialize 函數。您必須根據專案所需的語言偵測自訂內容,決定呼叫這個函數的方式。

使用自訂語言偵測

若要存取語言 XML 檔以便在指定的時間控制取代文字,請建立您自己的自訂組件,或使用 ActionScript 程式碼。例如,您可能會建立彈出式選單,讓使用者選取檢視內容時使用的語言。

如需有關撰寫 ActionScript 程式碼建立自訂語言偵測的詳細資訊,請參閱學習 ActionScript 2.0 中的「關於字串面板」。

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「設定」。
  2. 在「預設」語言選單中,選取預設語言。

    該語言必須是已新增的可用語言。

  3. 選取「取代字串」中的「在執行階段透過 ActionScript」,然後按一下「確定」。

    Animate 會產生下列 ActionScript 程式碼,其中儲存語言 XML 檔案的路徑。您可以將這個程式碼視為自己的語言偵測指令碼起點來使用。

    import mx.lang.Locale; 
    Locale.setFlaName("<flaFileName>"); 
    Locale.setDefaultLang("langcode"); 
    Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

註解:

「字串」面板產生的 ActionScript 並不會使用 Locale.initialize 函數。您必須根據專案所需的語言偵測自訂內容,決定呼叫這個函數的方式。

額外的資源

多國語言文字的 XML 檔案格式

當您在 Animate 中使用多國語言文字時,文字會儲存成 XML 檔案。

註解:

網頁上已提供最新的完整「說明」。應用程式未偵測到網際網路連線。如需本主題的詳細資訊,請按下列連結或搜尋完整的說明,網址:http://helpx.adobe.com/tw/support.html

當您在 Animate 中使用多國語言文字時,文字會儲存成 XML 檔案。

請參閱線上說明中與 XML 檔格式相關的討論,以了解如何使用這些 XML 檔,以及如何將這些 XML 檔匯入至 FLA 檔中。

關於 XML 檔格式

匯出的 XML 為 UTF-8 格式,並遵循 XML Localization Interchange File Format (XLIFF) 1.0 標準。它定義可延伸的 Localization Interchange Format 的規格,會讓任何軟體供應商都可以生產出單一的 Interchange Format,使當地語系化服務供應商都能夠接收與理解。如需有關 XLIFF 的詳細資訊,請參閱 www.oasis-open.org/committees/xliff/

XLIFF 範例

如果在「字串」面板中輸入下列任一字元,在寫出至 XML 檔時會以適當的項目參考來取代該字元:

字元

取代為

&

&amp;

'

&apos;

"

&quot;

<

&lt;

>

&gt;

匯出的 XML 檔範例

下列範例顯示由「字串」面板所產生的 XML 檔,在以原始語言和另一種語言顯示時的樣子。在這個範例中,原始語言是英文,而另一種語言是法文:

原始的英文版範例:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="en"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>welcome to our web site!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Would you like to be on our mailing list?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>see you soon!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

原始的法文版範例:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="fr"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>Bienvenue sur notre site web!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Voudriez-vous être sur notre liste de diffusion?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>A bientôt!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

在字串面板或 XML 檔中翻譯文字

在傳送檔案給譯者時,您不僅要併入 FLA 檔,而且也要併入 XML 檔的資料夾以及每種語言的 XML 檔。

譯者可以直接處理「字串」面板中的語言欄,也可以處理每種語言的 XML 檔,將 FLA 檔翻譯成選取的語言。如果要直接在 XML 檔中翻譯,您就必須將 XML 檔匯入「字串」面板,或者將其儲存在該語言的預設目錄中。

在字串面板中翻譯文字

  1. 選取「視窗 > 其他面板 > 字串」。
  2. 為每種要翻譯的語言選取適當的語言欄,然後輸入該語言的翻譯文字,以跟每個字串 ID 相連結。
  3. 若要以您所選取的語言在舞台上顯示文字,請在「舞台語言」欄位中選取語言。
  4. 完成時,請儲存、發佈或測試檔案。

    「字串」面板中的資訊會覆寫所有語言的所有 XML 檔。

    註解:

    如果您要保留 XML 檔中的翻譯,請將其儲存在不同的資料夾中。

在 XML 檔中翻譯文字

  1. 使用 XML 檔編輯程式或翻譯軟體,開啟所需語言的資料夾,然後開啟該語言的 XML 檔。XML 檔中會填入了每個文字字串的 ID。
  2. 在 ID 旁邊輸入該語言的文字字串。
  3. 如有必要,請將翻譯後的 XML 檔匯入到「字串」面板。

將 XML 檔匯入到字串面板中

修改 XML 檔案之後,如果您將其放入該語言的「字串」面板所指定的資料夾中,則 XML 檔案開啟時會載入到 Animate 文件 (FLA 檔案) 中。

不論匯入的 XML 位於何處,當您儲存、測試或發佈此 FLA 檔時,都會在指定發佈 SWF 檔的所在處,為「字串」面板中的每一種語言建立一個資料夾,並為每一種語言建立一個 XML 檔。如果沒有指定發佈路徑,資料夾和檔案將會一起儲存在 FLA 檔所在的資料夾。「字串」面板所產生的 XML 檔,固定都會以「字串」面板中的資訊來填入。

您也可以從別的位置將 XML 檔匯入到「字串」面板中。匯入之後,當您在儲存、測試或發佈該檔案時,就會覆寫該語言所指定資料夾中的 XML 檔。只有在「字串」面板中已選取為可用語言的語言,其 XML 檔才能匯入。您也可以新增語言以及匯入具有該種語言之翻譯的 XML 檔。

  1. 選取「視窗 > 其他面板 > 字串」,然後按一下「匯入 XML」。
  2. 在「選取語言」選單中,選取您要匯入之 XML 檔的語言,然後按一下「確定」。
  3. 瀏覽到該資料夾以及要匯入的 XML 檔。

    針對您在步驟 3 當中所選的語言,XML 資訊會載入到「字串」面板上該語言的語言欄。

註解:

請選取步驟 2 和 3 中的相同語言。否則,舉例來說,您可能就會將法文 XML 檔匯入到德文那一欄。

多國語言文字和 ActionScript

您可以使用 ActionScript® 控制多國語言文字,以及匯入多國語言 XML 檔案。

註解:

網頁上已提供最新的完整「說明」。應用程式未偵測到網際網路連線。如需本主題的詳細資訊,請按下列連結或搜尋完整的說明,網址:http://helpx.adobe.com/tw/support.html

您可以使用 ActionScript® 控制多國語言文字,以及匯入多國語言 XML 檔案。

請參閱線上說明中與建立多國語言文字相關的討論,以了解如何在 ActionScript 中使用多國語言文字。

使用 ActionScript 來載入外部檔案

若要載入現有的 XML 資料,或是針對此 XML 檔使用不同的格式,請使用 loadVariables 動作、getURL 動作、LoadVars 物件或 XML 物件來建立包含多國語言文字的文件,其方式是將該文字放到外部文字或 XML 檔中,並在執行階段將此檔案載入影片片段中。

您應該使用支援 UTF-8 (建議使用)、UTF-16BE 或 UTF-16LE 格式的應用程式來儲存外部檔案。如果您使用的是 UTF-16BE 或 UTF-16LE 格式,則檔案必須以 BOM 開頭,以便讓 Flash Player 識別其編碼格式。下表列出要包含用來識別其編碼的 BOM:

注意:大部分能夠以 UTF‑16BE 或 LE 儲存檔案的文字編輯器都會自動將 BOM 加入檔案。

UTF 格式

第一個位元組

第二個位元組

UTF‑16BE

OxFE

OxFF

UTF‑16LE

OxFF

OxFE

註解:

如果外部檔案為 XML 檔,您就不能使用 XML 編碼標籤來變更其編碼。所以,請以支援的 Unicode 格式來儲存檔案。

  1. 在 Animate 編寫應用程式中,建立動態或輸入文字欄位以顯示文件中的文字。

  2. 在「屬性」檢測器中,先選取文字欄位,然後指定該文字欄位的實體名稱。
  3. 在 Animate 外面,建立定義文字欄位變數值的文字或 XML 檔案。

  4. 以 UTF-8 (建議使用)、UTF-16BE 或 UTF-16LE 格式儲存 XML 檔。
  5. 請使用下列其中一個 ActionScript 程序,以參考外部檔案並將其載入到動態或輸入文字欄位中:
    • 使用 loadVariables 動作來載入外部檔案。

    • 使用 getURL 動作,以從指定的 URL 載入外部檔案。

    • 使用 LoadVars 物件 (預先定義的主從式物件),以從指定的 URL 載入外部文字檔案。

    • 使用 XML 物件 (預先定義的主從式物件),以從指定的 URL 載入外部 XML 檔。如需詳細資訊,請參閱 ActionScript 語言參考中的 XML。

使用 #include 動作建立多國語言文件

若要建立包含多國語言的文件,請使用 #include 動作。

您可以使用支援 UTF-8 編碼的應用程式 (如 Dreamweaver),以 UTF-8 格式儲存文字檔案。

若要讓 Animate 編寫工具知道該檔案是以 Unicode 編碼,請將下列檔頭加入成為檔案中的第一行:

//!-- UTF8

註解:

請在第二個破折號 (-) 之後加上一個空格。

根據預設,Animate 編寫應用程式會假設使用 #include 動作的外部檔案是以執行該編寫工具之作業系統的傳統字碼頁來編碼。在檔案中使用 //!-- UTF8 標頭可讓編寫工具知道該外部檔案是以 UTF-8 編碼。

  1. 在 Animate 編寫工具中,建立動態或輸入文字欄位以顯示文件中的文字。

  2. 在「屬性」檢測器中,先選取文字欄位,然後指定該文字欄位的實體名稱。
  3. 在 Animate 外面,建立定義文字欄位變數值的文字檔。在檔案的開頭加入 //!-- UTF8 檔頭。

  4. 以 UTF-8 格式儲存此文字檔。
  5. 若要在動態或輸入文字欄位中包含外部檔案,請使用 #include 指令。如需詳細資訊,請參閱 ActionScript 語言參考中的 #include 指令。

使用文字變數建立多國語言文件

若要在文字變數中包含 Unicode 編碼的內容,請使用語法 \uXXXX,其中 XXXX 是 Unicode 的四位數十六進位字碼點 (或稱「逸出」字元)。Animate 編寫工具支援 Unicode 逸出字元,範圍到 \uFFFF。如果要取得 Unicode 字元的字碼點,請參閱 Unicode.org 的「Unicode 標準」。

您只能在文字欄位變數中使用 Unicode 的反斜線字元。Flash Player 6 無法辨識外部檔案中的 Unicode 反斜線字元,因此不能在外部文字或 XML 檔中併入 Unicode 的反斜線字元。

例如,若要設定包含日文、韓文、中文、英文、希臘文字元及歐元符號的動態文字欄位 (使用實體名稱 myTextVar),您可以輸入下列內容:

myTextVar.text = "\u304B\uD55C\u6C49hello\u03BB\u20AC";

在播放 SWF 檔時,文字欄位會顯示下列字元:

在建立含有多國語言的文字欄位時,若要有最好的效果,請務必使用含有所有文字需要的 Glyph 之字體。

使用 XMLConnector 組件連接外部 XML 檔

您可以使用第 2 版的 XMLConnector 組件來連接外部 XML 文件,以便繫結文件中的屬性。目的是使用 HTTP GET 作業、POST 作業或兩者都使用來讀取或寫入 XML 文件。它會扮演其他組件與外部 XML 文件之間的連接器。XMLConnector 會使用 Animate 編寫環境的資料繫結功能或是 ActionScript 程式碼,與應用程式中的組件進行通訊。如需詳細資訊,請參閱 ActionScript 組件語言參考中的「XML Connector 組件」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策