使用手冊 取消

如何在 Animate 中使用場景

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多種檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用 Animate 繪製及建立物件
    9. 調整線條和形狀
    10. 使用 Animate CC 中的筆畫、填色和漸層
    11. 使用 Adobe Premiere Pro 和 After Effects
    12. Animate CC 中的色彩面板
    13. 使用 Animate 開啟 Flash CS6 檔案
    14. 在 Animate 中使用傳統文字
    15. 將圖案放入 Animate 中
    16. Animate 中匯入的點陣圖
    17. 3D 圖像
    18. 在 Animate 中使用元件
    19. 使用 Adobe Animate 繪製線條和形狀
    20. 使用 Animate 中的元件庫
    21. 匯出聲音
    22. 在 Animate CC 中選取物件
    23. 在 Animate 中使用 Illustrator AI 檔案
    24. 套用混合模式
    25. 排列物件
    26. 使用命令選單自動執行工作
    27. 多國語言文字
    28. 使用 Animate 中的攝影機
    29. 圖像濾鏡
    30. 聲音和 ActionScript
    31. 繪圖偏好設定
    32. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. Animate 工作區中的輔助功能
    12. 撰寫和管理指令碼
    13. 啟用自訂平台的支援
    14. 自訂平台支援概觀
    15. 使用自訂平台支援外掛程式
    16. ActionScript 3.0 的除錯
    17. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 最佳作法 - 建立行動裝置內容的秘訣
    9. 最佳作法 - 視訊慣例
    10. 最佳作法 - SWF 應用程式編寫原則
    11. 最佳作法 - 建構 FLA 檔
    12. 最佳化 Animate 的 FLA 檔案的最佳作法
    13. ActionScript 發佈設定
    14. 指定 Animate 的發佈設定
    15. 匯出放映檔
    16. 匯出影像和 GIF 動畫
    17. HTML 發佈範本
    18. 使用 Adobe Premiere Pro 和 After Effects
    19. 快速分享和發佈您的動畫
  9. 疑難排解
    1. 已修正問題
    2. 已知問題

 

若要依照主題組織文件,可以使用場景。例如,您可能會想要使用不同的場景,來呈現簡介、載入中的訊息和感謝辭。雖然使用場景上有些缺點,但有些情況瑕不掩瑜,如建立長篇動畫時。當您使用場景時,可以避免管理大量 FLA 檔案,因為每個場景會包含在單一 FLA 檔案中。

使用場景類似於同時使用數個 FLA 檔來建立較大型的簡報。每個場景都有一個時間軸。文件中的影格會依照場景順序,完成連續編號。例如,如果某份文件包含兩個各有 10 個影格的場景,則場景 2 中的影格會編號成 11 至 20。文件中的場景會根據本身在「場景」面板中所列的順序來播放。當播放磁頭到達場景最後一個影格時,播放磁頭會前進至下一個場景。

場景的缺點

發佈 SWF 檔時,各個場景的時間軸就會結合成 SWF 檔中的單一時間軸。編譯了 SWF 檔之後,它的行為就如同使用單一場景來建立 FLA 檔一般。因為這個行為,場景有些缺點:

  • 場景可能會混淆要編輯的文件,特別是在多個編寫者的環境中。任何使用 FLA 文件的人都可能需要在 FLA 檔內搜尋數個場景,以找出程式碼和資源的地方。請考慮載入外部 SWF 內容或使用影片片段來取代。

  • 場景通常會產生大型的 SWF 檔。使用場景會促使您在單一 FLA 檔中放入更多內容,因而產生較大的 FLA 檔和 SWF 檔。

  • 即使使用者並不打算或不想看整個檔案,場景還是會迫使使用者以漸進方式下載整個 SWF 檔。如果能避免使用場景,使用者就可以在瀏覽 SWF 檔時,自行決定想要下載的內容,

  • 結合 ActionScript 的場景可能會產生無法預期的結果。因為各個場景時間軸都會壓縮至單一時間軸上,您可能會遇到涉及 ActionScript 和場景的錯誤,而且需要額外進行複雜的除錯。

控制場景播放

若要在每個場景之後停止或暫停文件,或是要讓使用者以非線性方式瀏覽文件,請使用 ActionScript。如需詳細資訊,請參閱 ActionScript

顯示場景面板

  1. 選取「視窗 > 其他面板 > 場景」。

增加場景

  1. 選取「插入 > 場景」,或在「場景」面板中按一下「增加場景」按鈕 

刪除場景

  1. 按一下「場景」面板上的「刪除場景」按鈕

變更場景名稱

  1. 連按兩下「場景」面板上的場景名稱,再輸入新名稱。

重製場景

  1. 按一下「場景」面板中的「重製場景」按鈕

變更文件中的場景順序

  1. 將場景名稱拖曳到「場景」面板中的另一個位置。

檢視特定場景

  1. 執行下列其中一項:
    • 選取「檢視 > 前往」,然後在子選單中選取場景名稱。

    • 按一下文件視窗右上角的「編輯場景」按鈕,然後從彈出式選單中選擇場景名稱。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上