還原、重做和重複命令

若要針對個別的物件或目前文件內的所有物件還原或重做動作,請指定物件層級或文件層級的「還原」和「重做」命令 (「編輯 > 還原」或「編輯 > 重做」)。預設行為指令為文件層級「還原」和「重做」。

若要選擇物件層級或文件層級還原選項,請執行下列動作:

  1. 在 Animate CC 中,選取「編輯 > 偏好設定」。
  2. 在「一般」索引標籤上,選取「還原」下拉式清單中的「物件層級還原」。

請注意,使用物件層級「還原」時,無法還原某些動作。這些動作包括進入和退出「編輯」模式;選取、編輯和移動元件庫項目;以及建立、刪除和移動場景。

若要將步驟重新套用至相同或不同的物件,請使用「重複」命令。例如,如果您移動了名稱為 shape_A 的形狀,則可以選取「編輯 > 重複」以再次移動該形狀,或是選取另一個名稱為 shape_B 的形狀,並選取「編輯 > 重複」,將第二個形狀移動相同的單位。

根據預設,Animate 可提供「還原」選單命令 100 層的還原支援。請在 Animate 的「偏好設定」中選取還原及重做的層數 (2 至 300)。

根據預設,使用「編輯 > 還原」或「操作記錄」面板還原步驟時,文件的檔案大小不會變更,即使您刪除了文件中的項目亦然。例如,如果在文件中匯入視訊檔案,然後還原匯入動作,則這份文件的檔案大小仍然包括該視訊檔案的大小。執行「還原」命令時,從文件中刪除的所有項目都會保留下來,以讓您稍後使用「重做」命令復原這些項目。

使用操作記錄面板

「操作記錄」面板 (「視窗 > 操作記錄」) 的清單內會顯示從建立或開啟作用中文件開始,在該文件中執行過的步驟,並以指定的最大步驟數目作為上限 (「操作記錄」面板不會顯示您在其他文件中執行過的步驟)。「操作記錄」面板中的滑動軸一開始是指向您執行過的最後一個步驟。

  • 若要還原或重做個別步驟,或是一次還原或重做多個步驟,請使用「操作記錄」面板。您可以將「操作記錄」面板中的步驟套用至文件中的相同物件或不同物件。但是,無法重新安排「操作記錄」面板中的步驟順序。「操作記錄」面板會依照步驟執行的順序進行記錄。

    注意:若您在文件中還原了一個步驟或一系列的步驟,接著又執行了新的步驟,就無法在「操作記錄」面板重做這些步驟;這些步驟會從面板中消失。

  • 根據預設,Animate 可提供「操作記錄」面板 100 層的還原支援。請在 Animate 的「偏好設定」中選取還原及重做的層數 (2 至 300)。

  • 若要刪除目前文件的操作記錄清單,請清除「操作記錄」面板。清除操作記錄清單後,無法還原已經清除的步驟。清除操作記錄清單並不會還原步驟,只是將這些步驟的記錄從目前文件的記憶體中移除。

關閉文件時,也會一併清除操作記錄。若要在關閉文件後使用該文件中的步驟,請使用「複製步驟」命令,或是將這些步驟儲存成一道命令。

透過操作記錄面板還原步驟

還原步驟時,該步驟將會在「操作記錄」面板中呈現暗灰色。

  • 若要還原最後一個執行的步驟,請將「操作記錄」面板的滑動軸在清單中向上拖曳一個步驟。

  • 若要一次還原多個步驟,請拖曳滑動軸以指向任一個步驟,或沿著滑動軸的路徑,按一下該步驟的左邊。滑桿會自動捲動至該步驟,並隨著捲動還原後續的所有步驟。

注意:捲動至步驟 (並選取後續幾個步驟) 和選取個別步驟是不同的。若要捲動至某個步驟,請按一下該步驟的左邊。

使用操作記錄面板重播步驟

使用「操作記錄」面板重播步驟時,播放的步驟是「操作記錄」面板中選取的步驟 (以反白顯示);滑桿目前正指向的步驟則不一定會播放。

您可以將「操作記錄」面板中的步驟套用至您在文件中選取的任何物件。

重播一個步驟

  1. 請在「操作記錄」面板中選取一個步驟,接著按一下「重播」按鈕。

重播一系列連續的步驟

  1. 請執行下列步驟之一,在「操作記錄」面板中選取步驟:
    • 自某個步驟拖曳至另一個步驟。(不要拖曳滑動軸,請從某個步驟的文字標籤拖曳至另一個步驟的文字標籤)。

    • 選取第一個步驟,然後按 Shift + 按一下最後一個步驟;或是選取最後一個步驟,然後按 Shift + 按一下第一個步驟。

  2. 按一下「重播」。這些步驟將會依照順序進行重播,而一道標記為「重播步驟」的新步驟將會出現於「操作記錄」面板中。

重播非連續步驟

  1. 在「操作記錄」面板中選取步驟,然後按 Control + 按一下 (Windows) 或 Command + 按一下 (Macintosh),並在其他幾個步驟上按一下。若要取消選取所選取的步驟,請按 Control + 按一下或按 Command + 按一下。
  2. 按一下「重播」。

在文件間複製和貼上步驟

每一份已開啟的文件都有獨立的步驟操作記錄。若要複製文件中的步驟,並將其貼到另一份文件中,請使用「操作記錄」面板選項選單中的「複製步驟」命令。若您將步驟複製至文字編輯器中,則這些步驟將以 JavaScript™ 程式碼的形式貼上。

  1. 在含有要重複使用之步驟的文件中,選取「操作記錄」面板中的這些步驟。
  2. 在「操作記錄」面板的選項選單中,選取「複製步驟」。
  3. 開啟要將步驟貼入其中的文件。
  4. 選取要套用步驟的物件。
  5. 選取「編輯 > 貼上」,貼上這些步驟。當步驟貼入文件的「操作記錄」面板時,便會播放這些步驟。這些步驟在「操作記錄」面板中僅會顯示為一道名為「貼成步驟」的步驟。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策