使用手冊 取消

撰寫和管理指令碼

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

格式化程式碼

您可以將程式碼格式化,並在輸入時自動進行縮排。如果使用動態字體對應,便可確保有針對多國語言文字使用正確的字體。

設定自動格式化選項

  1. 執行下列其中一項:
    • 從面板選單  (位於「動作」面板右上角) 中,選取「偏好設定」。

    • 在「Script」視窗中,選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh)。

  2. 在「偏好設定」對話方塊中,選取「自動格式化」。
  3. 選取任何一個「自動格式化」選項。

    在設定「自動格式化」選項後,會自動將設定套用到所撰寫的程式碼,而非現有程式碼;您必須手動將設定套用到現有程式碼。

根據自動格式化設定來格式化程式碼

  • 在「動作」面板或 Script 視窗工具列上按一下「自動格式化」
  • 從面板選單 (位於「動作」面板右上角) 中,選取「自動格式化」。
  • 按 Control+Shift+F (Windows) 或 Command+Shift+F (Macintosh)。
  • 在 Script 視窗中,選取「工具 > 自動格式化」。

使用動態字體對應

  1. 若要開啟或關閉動態字體對應,可以在「偏好設定」對話方塊中選取或取消選取「使用動態字體對應」。

    由於編寫指令碼時,動態字體對應會增加執行的時間,所以預設是關閉的。如果您正在處理多國語言文字,請開啟動態字體對應,如此將有助於確保使用的是正確字體。

使用自動縮排

  1. 若要開啟或關閉自動縮排,可以在「偏好設定」對話方塊中選取或取消選取「自動縮排」。

    當開啟自動縮排時,您在左圓括弧 "(" 或左大括弧 "{" 之後輸入的文字會依據 ActionScript 偏好設定中的「定位鍵距離」設定進行自動縮排。

    在指令碼中,只要選取程式碼行再按 Tab 鍵,即可將此行縮排。若要移除縮排,請選取程式碼行並按 Shift+Tab 鍵。

為程式碼區段加上註解

程式碼註解是程式碼的一部分,而 ActionScript 編譯器會忽略這部分。註解行會說明程式碼的作用,或者將不要刪除的程式碼暫時停用。若要為某一行程式碼加上註解,請用雙斜線 (//) 當做這一行的開頭。編譯器會將位於該行雙斜線後面的所有文字予以忽略。您也可以在程式碼區塊的開頭放置斜線和星號 (/*),並在程式碼區塊結尾放置星號和斜線 (*/),為更大的程式碼區塊加上註解。

您可以手動輸入這些註解標記,或者使用位於「動作」面板或 Script 視窗上方的按鈕來加入註解標記。

為程式碼行加上註解

  1. 將插入點放在程式碼行的開頭,或是要開始加入註解的字元位置。
  2. 以滑鼠右鍵按一下並選取「註解」。您也可以使用鍵盤快速鍵 Ctrl + M (Windows) 或 Command + M,或者移至「編輯 > 註解選取範圍」。

插入點上便會放置雙斜線 (//)。

加入多行程式碼的註解

  1. 選取要加入註解的程式碼行。(選取範圍的第一行和最後一行可以是部分字行)。
  2. 以滑鼠右鍵按一下並選取「註解」。您也可以使用鍵盤快速鍵 Ctrl + M (Windows) 或 Command + M,或者移至「編輯 > 註解選取範圍」。

區塊註解字元便會放在選取範圍的開頭 (/*) 和結尾 (*/)。

註解:

如果選取的文字行之間有註解,將會在所有選取的字行上套用字行註解。

移除註解

  1. 將插入點放在含有註解的程式碼行,或者選取有加上註解的程式碼區塊。
  2. 以滑鼠右鍵按一下並選取「取消註解」。您也可以使用鍵盤快速鍵 Ctrl + Shift + M (Windows) 或 Command + Shift + M,或者移至「編輯 > 取消註解選取範圍」。

使用語法標色

在 ActionScript 中和在其他語言中一樣,「語法」是將元素結合在一起以產生意義的方式。如果使用不正確的 ActionScript 語法,Script 將無法運作。

若要將語法錯誤反白標示,請將顏色編碼設為指令碼的一部分。例如,假設您設定語法標色偏好設定,好讓關鍵字顯示成藍色。當您輸入 var 時,var 一字便會顯示成藍色。不過,如果您誤將它輸入為 vaevae 一字仍會維持黑色,使您知道有輸入的錯誤。

請執行下列其中一項:

  • 選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),接著按一下「類別」清單中的「程式碼編輯器」,再指定「語法標色」設定。

  • 當插入點在「Script」窗格中時,請按 Control + U (Windows) 或 Command + U (Macintosh)。

註解:

在「動作」面板中撰寫指令碼時,目標的播放程式版本不支援的命令會在「動作工具箱」中顯示成黃色。例如,假設將 Flash Player SWF 檔案版本設為 Flash 7,則只有 Flash Player 8 支援的 ActionScript 才會在「動作工具箱」中顯示成黃色。

在執行階段使用識別名稱和關鍵字清單

啟動 Animate 時,會從資源檔案讀取識別名稱和關鍵字清單,並加以快取。除了從資源讀取預設清單以外,還會掃描「Preference」資料夾中的其他關鍵字和識別名稱清單。您只要在下列資料夾中加入「.txt files」,就能加入其他關鍵字和識別名稱:

  • C:\Users\<使用者名稱>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<使用者名稱>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<使用者名稱>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<使用者名稱>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

使用行號和文字換行

當您編輯或修改程式碼時,行號可以讓程式碼更容易捲動和剖析。文字換行能讓您避免水平捲動過長的程式碼行 (特別是在編寫環境或低螢幕解析度下工作時)。

啟用或停用行號

  • 在「Script」視窗中,選取「檢視 > 行號」。
  • 按 Control+Shift+L (Windows) 或 Command+Shift+L (Macintosh)。

反白標示特定的程式碼行

  • 在 Script 視窗中,選取「編輯 > 前往行數」。

啟用或停用文字換行

  • 在「Script」視窗中,選取「檢視 > 文字換行」。
  • 按 Control+Shift+W (Windows) 或 Command+Shift+W (Macintosh)。

顯示隱藏的字元

在 ActionScript 程式碼中,空格字元、定位鍵和斷行符號等都是隱藏的字元。您可能需要顯示這些字元,例如,您必須找出並移除不屬於字串值的雙位元組空格字元,因為這些字元會造成編譯器錯誤。

  • 按 Control+Shift+8 (Windows) 或 Command+Shift+8 (Macintosh)。

下列符號用於顯示隱藏的字元。

隱藏字元

元件

單位元組空格字元

.

雙位元組空格字元

l

定位鍵

>>

斷行符號


尋找指令碼中的文字

「尋找」工具能讓您尋找和取代指令碼中的文字字串。

註解:

若要在 Animate 文件中搜尋每一個指令碼中的文字,可以使用「影片結構檢視器」。

尋找文字

  1. 在「動作」面板或 Script 視窗中,按一下「尋找」 ,或是按 Control+F (Windows) 或 Command+F (Macintosh)。
  2. 輸入搜尋字串。
  3. 按一下「尋找下一個」。

尋找和取代指令碼中的文字

  1. 在「動作」面板或 Script 視窗中,按一下「尋找」 ,或是按 Control+F (Windows) 或 Command+F (Macintosh)。
  2. 輸入搜尋字串。
  3. 在「取代」方塊中,輸入新的字串。
  4. 按一下「尋找下一個」。
  5. 若要取代此字串,可以按一下「取代」;若要取代所有出現的字串,可以按一下「全部取代」。

(Animate 不建議使用) 在動作面板中重複搜尋

  1. 從面板選單 (位於「動作」面板右上角) 中,選取「再次尋找」。

(Animate 不建議使用) 在 Script 視窗中重複搜尋

  1. 選取「編輯 > 再次尋找」。

(Animate 不建議使用) 檢查語法和標點符號

您不需要發佈 FLA 檔案,便可以快速檢查 ActionScript 程式碼。

在檢查語法時,就會檢查目前的指令碼。如果目前的指令碼會呼叫 ActionScript 的類別,也會檢查這些類別。但不會檢查其他可能位於 FLA 檔案中的指令碼。

對 ActionScript 2.0 的檔案而言,「檢查語法」會透過編譯器執行程式碼,產生語法和編譯器錯誤。

對 ActionScript 3.0 的檔案而言,「檢查語法」只會造產生語法錯誤。若要產生編譯器錯誤 (例如類型不相符、不適當的傳回值,以及變數或方法名稱的拼字錯誤),您必須使用「控制 > 測試」命令。

檢查語法

若要檢查語法,請執行下列其中一項:

  • 在「動作」面板或 Script 視窗中,按一下「檢查語法」
  • 按一下「Script」窗格,然後按 Control+T (Windows) 或 Command+T (Macintosh)。按一下「Script」窗格或在其中打字,將焦點帶回「Script」窗格。如果焦點是在「舞台」中的物件,則會改開啟「變形」面板。

「編譯器錯誤」面板中會列出語法錯誤。

註解:

在「Script」視窗內的外部 ActionScript 類別檔案中,全域類別路徑 (AS2) 或來源路徑 (AS3) 會影響語法檢查。即使全域類別路徑或來源路徑的設定正確,也可能產生錯誤,這是因為編譯器沒有注意到這個類別正在編譯中。

檢查成對的標點符號

  1. 在指令碼中的一對大括弧 {}、方括弧 [] 或圓括弧 () 中間按一下。
  2. 在 Windows 上,按 Control+' (單引號);在 Macintosh 上,按 Command+' (單引號)。大括弧、方括弧或圓括弧之間的文字便會反白標示,好讓您可以檢查左標點符號是否有對應的右標點符號。

(Animate 不建議使用) 匯入和匯出指令碼

您可以將指令碼匯入「動作」面板或 Script 視窗,也可以從「動作」面板中將指令碼匯出至外部 ActionScript 檔案(使用 Script 視窗時,因為您可以另存成 AS 檔案,因此不需要匯出)。

如果在開啟或匯入檔案時,Script 中的文字看起來與預期的不同,請變更匯入編碼偏好設定。

匯入外部 AS 檔案

  1. 在「Script」窗格中,將插入點放在您要找出外部指令碼第一行的位置。
  2. 請執行下列其中一項:
    • 在「動作」面板中,從面板選單中選取「匯入指令碼」,或者按 Control+Shift+I (Windows) 或 Command+Shift+I (Macintosh)。

    • 在「Script」視窗中,選取「檔案 > 匯入指令碼」,或者按 Control+Shift+I (Windows) 或 Command+Shift+I (Macintosh)。

從動作面板中匯出指令碼

  1. 選取要匯出的指令碼。然後從「動作」面板選單中選取「匯出指令碼」,或者按 Control+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。
  2. 儲存 ActionScript (AS) 檔案。

設定文字編碼選項

  1. 選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),然後在「類別」清單中選取「ActionScript」。

  2. 設定下列任何選項:

    開啟/匯入

    選取「UTF-8 編碼」,以便使用 Unicode 編碼開啟或匯入;或是選取「預設編碼」,以便使用系統目前使用的語言編碼格式開啟或匯入。

    儲存/匯出

    選取「UTF-8 編碼」,以便使用 Unicode 編碼儲存或匯出;或是選取「預設編碼」,以便使用系統目前使用的語言編碼格式儲存或匯出。

開啟或關閉匯出編碼警告

  1. 選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),然後在「類別」清單中選取「警告」。

  2. 選取或取消選取「匯出 ActionScript 檔案編碼衝突時提出警告」。

(Animate 不建議使用) 匯入和匯出的指令碼所用的編碼

您可以設定 ActionScript 偏好設定,以指定匯入或匯出的 ActionScript 檔案中所要使用的編碼類型。「UTF-8 編碼」為 8 位元 Unicode 格式,它可讓您在檔案中包含多種語言;「預設編碼」為系統目前使用的語言所支援的編碼,也稱為「傳統字碼頁」

註解:

在英文系統上使用非英文的應用程式時,如果 SWF 檔案路徑的任何部分包含了無法以「多位元組字元集」(MBCS) 編碼配置表示的字元,則「測試影片」命令就會失敗。例如,日文路徑在日文系統上有效,但在英文系統上卻無效。在英文系統上務必只使用英文路徑名稱。使用「測試影片」播放程式的所有應用程式範圍都受到此限制。

在動作面板中鎖定指令碼

使用「鎖定 Script」功能可以鎖定「Script」窗格中個別指令碼的標籤,並且據此加以移動。如果您尚未將 FLA 檔案內的程式碼整理到一個集中的位置,或是您正在使用多個指令碼,這個功能會很有用。

您可以鎖定指令碼,以便在「動作」面板中保留程式碼的開放位置,並且在各種開啟的程式碼之間切換使用。這個動作在除錯時特別有用。 

此外,您也可以取消鎖定指令碼或取消鎖定所有指令碼,以取消鎖定所選的指令碼或取消鎖定「動作」面板中的所有指令碼。

在下圖中,與時間軸上目前位置關聯的指令碼是位於 Cleanup 圖層的「影格 1」上(最左邊的標籤會永遠跟隨您在時間軸上的位置)。此外,指令碼也會鎖定顯示為最右邊的標籤。下列是兩個已鎖定的指令碼:

  • 在影格 1
  • 在名為 Intro 的圖層的影格 15

使用鍵盤快速鍵或按一下標籤,即可移動鎖定的指令碼。在各個鎖定的指令碼之間移動時,並不會變更時間軸上的目前位置。如果在「動作」指令碼導覽器中選取了新的指令碼,焦點就會移到第一個影格,例如「影格 1」。

註解:

如果「Script」窗格中的內容沒有變更來反映時間軸上所選取的位置,則「Script」窗格可能顯示鎖定的指令碼。按一下「Script」窗格左上方的目前影格標籤,即可顯示與您在時間軸上的位置相關聯的指令碼。

鎖定的指令碼

鎖定指令碼

  1. 按一下「時間軸」,讓指令碼顯示在「動作」面板中「Script」窗格左上方的目前影格標籤內。

  2. 請執行下列其中一項:
    • 按一下標籤右邊的「圖釘」圖示。
    • 選取「檢視 > 鎖定 Script」以鎖定指令碼。

     

取消鎖定所有指令碼

  1. 選取「動作」面板中鎖定的指令碼。

  2. 選取「檢視 > 取消鎖定 Script」,從「動作」面板中取消鎖定所選的指令碼。

  3. 選取「檢視 > 取消鎖定所有指令碼」,從「動作」面板中取消鎖定所有指令碼。

取消鎖定選項

鎖定指令碼的鍵盤快速鍵

當插入點位於「Script」窗格時,請使用下列鍵盤快速鍵來處理鎖定的指令碼。

動作

Windows 

Macintosh

鎖定指令碼

Control+Shift+= (等號)

Command+Shift+=

取消鎖定指令碼

Control+Shift+- (減號)

Command+Shift+-

插入目標路徑

許多指令碼動作是要影響影片片段、按鈕和其他元件實體。在程式碼中,您可以插入「目標路徑」 (也就是要做為目標之實體的位址),參考時間軸上的元件實體。您可以設定絕對或相對目標路徑。絕對路徑包含實體的整個位址。相對路徑只包含與 FLA 檔案中指令碼本身的位址不同的位址部分,而且如果將指令碼移至其他位置,相對路徑將不再有效。

  1. 在「動作」面板中,按一下指令碼中的動作。
  2. 按一下「目標路徑」。
  3. 輸入目標實體的路徑,或者從清單中選取目標。
  4. 選取「絕對」或「相對」路徑選項。

使用程式碼提示

當您在「動作」面板或 Script 視窗中工作時,此軟體可以偵測出您所輸入的動作,並顯示程式碼提示。程式碼提示共分為兩種:一種是工具提示 (包含該動作的完整語法),而另一種是彈出式選單,它會列出可能的 ActionScript 元素,例如方法或屬性名稱 (有時稱為「程式碼完成」的形式)。

預設會啟用程式碼提示。透過設定偏好設定,您可以停用程式碼提示,或是決定程式碼提示出現的速度。在偏好設定中停用程式碼提示後,您還是可以手動顯示特定命令的程式碼提示。

註解:

如果您無法為 ActionScript 2.0 中建立的變數或物件顯示程式碼提示,但在 ActionScript 偏好設定中已啟用程式碼提示,請確定您有使用適當的字尾來命名變數或物件,或是確定變數或物件有使用嚴謹資料輸入。

啟用程式碼提示

您能以多種方式觸發程式碼提示。

為物件進行嚴謹資料輸入

當您使用 ActionScript 2.0 而且針對以內建類別 (如 Button、Array 等) 為根據的變數使用嚴謹資料輸入時,「Script」窗格便會顯示該變數的程式碼提示。例如,假設您輸入以下兩行程式碼:

var foo:Array = new Array(); 
foo.

一旦您輸入句號 (.),Animate 就會在彈出式選單中顯示 Array 物件可用的方法及屬性清單,因為您已將此變數當做陣列輸入。

字尾和程式碼提示

如果您使用的是 ActionScript 1.0,或者只要為沒有進行嚴謹類型轉換的物件顯示程式碼提示,則請在建立物件時為每個物件名稱加上字尾。例如,觸發 Camera 類別之程式碼提示的字尾為 _cam。假設您輸入下列程式碼:var my_array = new Array(); var my_cam = Camera.get();

如果接著輸入 my_cam 並緊接著句號,便會出現 Camera 物件的程式碼提示。

對於出現在「舞台」上的物件,請在「屬性」檢測器的「實體名稱」方塊中使用字尾。例如,若要顯示 MovieClip 物件的程式碼提示,可以使用「屬性」檢測器,將內含 _mc 字尾的實體名稱指定給所有的 MovieClip 物件。然後,每當您輸入實體名稱及跟隨的句號時,程式碼提示便會出現。

var my_array = new Array(); 
var my_cam = Camera.get();
註解:

雖然在針對物件使用嚴謹資料輸入時,觸發程式碼提示並不需要字尾,但若能一致使用字尾,將有助於程式碼的可讀性。

下表列出會在 ActionScript 2.0 中觸發物件提示的字尾:

物件類型

變數字尾

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

註解和程式碼提示

您也可以使用 ActionScript 註解,為程式碼提示指定物件的類別。在下列範例中,註解會告知 ActionScript theObject 實體的類別為 Object,以此類推。

// Object theObject;// Array theArray;// MovieClip theMC;

如果接著輸入 theMC 及其後的句號,便會出現程式碼提示,顯示著 MovieClip 方法及屬性的清單。如果接著輸入 theArray 並跟隨著句號,便會出現程式碼提示,其中會顯示 Array 方法及屬性的清單,以此類推。

不過,Adobe 建議您不要使用這個方法,而是改用嚴謹資料輸入或字尾,因為這些方法能自動啟用程式碼提示,也能讓程式碼更具可讀性。

指定自動程式碼提示的偏好設定

  • 在「動作」面板或「Script」視窗中,選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),再按「類別」清單中的「程式碼編輯器」,然後啟用或停用「程式碼提示」。

(Animate 不建議使用) 指定程式碼提示的延遲時間

  1. 在「動作」面板或「Script」視窗中,選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh)。

  2. 在「類別」清單中按一下「ActionScript」。
  3. 使用滑桿選取延遲時間 (秒)。

使用工具提示類型的程式碼提示

  1. 在需要有括弧的元素 (例如方法名稱、ifdo..while 之類的命令等) 後面輸入左括弧 "(",以顯示程式碼提示。
    左括弧會叫用程式碼提示

  2. 輸入參數值。

    如果為多個參數,請以逗號來分隔值。如果為函數或陳述式 (例如 for 迴圈),請以分號來分隔參數。

    多載的命令 (也就是可以使用各組參數來進行叫用的函數或方法),例如 gotoAndPlay()for,這些命令會顯示指示器,讓您選取要設定的參數。若要選取參數,可以按一下小箭頭,或按 Control + 向左鍵和 Control + 向右鍵。

    具有多組參數的程式碼提示

  3. 若要關閉程式碼提示,請執行下列其中一項:
    • 輸入右括弧 ")"。

    • 在陳述式之外按一下。

    • 按 Esc 鍵。

使用選單類型的程式碼提示:

  1. 在變數或物件名稱後面輸入句號,以顯示程式碼提示。
    選單類型的程式碼提示

  2. 若要瀏覽所有的程式碼提示,可以使用向上鍵和向下鍵。
  3. 若要選取選單中的項目,可以按一下 Enter 或 Tab 鍵,或是按兩下該項目。
  4. 若要關閉程式碼提示,請執行下列其中一項:
    • 選取其中一個選單項目。

    • 在選單視窗的上方或下方按一下。

    • 如果已輸入左括弧 "(",請輸入右括弧 ")"。

    • 按 Esc 鍵。

手動顯示程式碼提示

  1. 按一下程式碼提示可出現的程式碼位置,如下列位置:
    • 在陳述式或命令之後的點 (.) 後面,必須在這裡輸入屬性或方法

    • 在方法名稱的括弧 [()] 之間

  2. 請執行下列其中一項:
    • 若要手動啟用「程式碼提示」,請選取「檢視 > 顯示程式碼提示」。

    • 按 Control + 空白鍵 (Windows) 或 Command + 空白鍵 (Macintosh)。

自訂類別的程式碼提示

當您建立自訂 ActionScript 3.0 類別時,Animate 會剖析類別並判斷其中所包含的物件、屬性與方法。如此一來,當您撰寫參考自訂類別的程式碼時,Animate 便能提供程式碼提示。自訂類別程式碼會自動完成您要透過 import 命令連結至其他程式碼的任何類別。

程式碼提示可讓開發人員的工作速度變快,因為他們不必記住該類別使用的所有物件、方法及屬性。設計人員可以使用他人所編寫的類別,因為設計人員並不需要對於如何使用該類別有直接的了解。

程式碼提示包括下列項目:

  • 巢狀類別參考的程式碼提示

    當您編寫巢狀參考時,程式碼提示的持續協助會很有幫助。

  • “this” 的程式碼提示

    在類別檔案中輸入 "this" 時,您便可取得相同類別的程式碼提示。

  • “new+<space>” 的程式碼提示

    當您輸入「new+<space>」時,Animate 會顯示可用類別與套件的清單。

  • “import” 的程式碼提示

    當您輸入「import + <space>」時,Animate 會顯示所有內建套件與自訂套件的清單。

  • SWC 元件庫的程式碼提示

    當您將 SWC 元件庫新增至元件庫路徑或外部元件庫路徑時,Animate 可對包含於 SWC 檔案中的所有類別提供程式碼提示。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?