關於元件

「元件」是您在 Animate (先前稱為 Flash Professional CC) 編寫環境中所完成,或使用 SimpleButton (AS 3.0) 和 MovieClip 類別所建立的圖像、按鈕或影片片段。此後您便可在整份文件或其他文件中重複使用該元件。

元件可以包括從另一個應用程式匯入的圖案。您建立的所有元件都會自動成為目前文件之元件庫的一部分。

「實體」是位於「舞台」上或以巢狀方式置入另一個元件之中的元件副本。實體在顏色、大小和功能上可能與它的父元件有所差異。編輯元件會更新元件的所有實體,但套用至元件實體上的特效只會更新該實體。

在文件中使用元件會大幅降低檔案大小;與儲存元件內容的多個副本相較,儲存數個元件實體所需的存放空間較小。舉例來說,若您將靜態圖像 (如背景影像) 轉換成元件並加以重複使用,就可以縮減文件的檔案大小。使用元件也可以加快 SWF 檔播放的速度,因為元件只需下載到 Flash® Player 一次就可以了。

在編寫或執行階段,您可以將元件當做共用元件庫資源,在文件之間共用。就執行階段共享資源的部分,您可以將來源文件中的資源連結到任意數目的目的文件,而不必將這些資源匯入目的文件中。對於編寫階段共享的資源,您可以使用區域網路上任何其他的可用元件,更新或取代元件。

如果匯入的元件庫資源和元件庫中已有的資源名稱相同,則您可以解決命名衝突,而不會意外覆寫現有的資源。

以下資源提供與元件相關的其他初步指示:

元件的類型

每個元件都有獨立的時間軸和舞台,再加上圖層。就像主時間軸一樣,您也可以在元件的時間軸內加入影格、關鍵影格及圖層。建立元件時,您可以選擇元件類型。

  • 若是要當做靜態影像使用,或是要建立與主「時間軸」相結合、並可重複使用的動畫片段時,請使用圖像元件 。圖像元件會與主時間軸同步運作。互動式控制項及聲音無法在圖像元件的連續動畫中發揮作用。圖像元件增加的 FLA 檔大小少於按鈕或影片片段,因為它們不使用時間軸。

  • 若要建立對按下滑鼠鈕、滑鼠滑過或其他動作產生回應的互動式按鈕,請使用按鈕元件 。請定義和各種按鈕狀態相關聯的圖像,然後將動作指定給按鈕實體。如需詳細資訊,請參閱 ActionScript 3.0 開發人員指南中的處理事件

  • 若要建立可重複使用的動畫片段,請使用影片片段元件 。影片片段有自己的多影格時間軸,且獨立於主時間軸之外—您不妨將它們想像成以巢狀方式放置於主時間軸中的影片片段,可以包含互動式控制項、聲音、甚至是其他影片片段實體。您也可以將影片片段實體放在按鈕元件的時間軸中,以建立動畫按鈕。此外,還可以使用 ActionScript® 編寫影片片段的程式碼。

  • 您可以使用字體元件匯出字體,並在其他 Animate 文件中使用。

    Animate 提供了內建的「組件」(具有已定義參數的影片片段),讓您可以用來在文件中加入按鈕、核取方塊或捲軸等使用者介面元素。如需詳細資訊,請參閱「使用 ActionScript 3.0 組件」中的關於 ActionScript 3.0 組件

    注意:若要在 Animate 編寫環境中預覽組件實體中的動畫及 9 分割縮放影片片段的縮放,請選取「控制 > 啟動即時預覽」。

建立元件

在 Animate 中,您可以由「舞台」上的已選取物件建立元件、建立空白元件、在元件編輯模式下製作或匯入內容,以及建立字體元件。元件可以包含 Animate 所能建立的所有功能,包括動畫。

使用包含動畫的元件,可讓您建立包含大量動作的 Animate 應用程式,並縮減檔案大小。當動畫具有重複或週期性的動作時,例如鳥兒翅膀的上下拍擊,請考慮將動畫建立在元件中。

若要將元件加入至文件,請在編寫或執行階段使用共享元件庫資源。

將選取的元素轉換成元件

  1. 選取舞台上的一個或多個元素。請執行下列其中一項:
    • 選取「修改 > 轉換成元件」。

    • 將選取範圍拖曳到「元件庫」面板中。

    • 按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後在快顯選單中選取「轉換成元件」。

  2. 在「轉換成元件」對話方塊中輸入元件名稱,然後選取行為指令。
  3. 在註冊格線中按一下,定位元件的註冊點。
  4. 按一下「確定」。

    Animate 便會將元件加入元件庫中。「舞台」上的選取範圍會變成元件的實體。建立元件之後,您可以選擇「編輯 > 編輯元件」,在元件編輯模式下進行編輯,或者選擇「編輯 > 在原地編輯」,以在「舞台」的環境中編輯內容。您也可以變更元件的註冊點。

建立空白元件

  1. 請執行下列其中一項:
    • 請選取「插入 > 新增元件」。

    • 按一下「元件庫」面板左下角的「新增元件」按鈕。

    • 在「元件庫」面板右上角的「元件庫面板」選單中選取「新增元件」。

  2. 在「建立新元件」對話方塊中輸入元件名稱,然後選取行為指令。
  3. 按一下「確定」。

    Animate 會將元件加入元件庫中,並切換到元件編輯模式。在元件編輯模式中,元件的名稱會出現在「舞台」的左上角上方,十字準線則代表元件的註冊點。

  4. 若要建立元件內容,可以使用時間軸、使用繪圖工具繪製、匯入媒體,或是建立其他元件的實體。
  5. 若要回到文件編輯模式,請執行下列其中一個步驟:
    • 按一下「上一步」按鈕。

    • 選取「編輯 > 編輯文件」。

    • 按一下「編輯」列中的場景名稱。

      建立元件時,註冊點會在元件編輯模式中置於視窗正中央。您可以將元件內容放置於視窗內相對於註冊點的位置。若要在編輯元件時變更註冊點,請移動相對於註冊點的元件內容。

  6. 在「ActionScript 連結」區段中,您可以選取「匯出給 ActionScript 使用」核取方塊,藉此選擇匯出給 ActionScript 使用。「類別」和「基底類別」隨即自動顯示 (您可以選擇重新命名類別名稱)。Animate 會在外部 AS 檔案或連結的 SWC 檔案中搜尋類別定義。如果在這些位置中找不到類別定義,Animate 就會自動產生類別檔案。如需詳細資訊,請參閱這篇文章

(僅適用於 Animate ) 替換多個元件

「替換元件」選項可讓您將元件替換為選取的元件或點陣圖。

  1. 在 Animate 文件中,選取舞台上的多個元件。

  2. 在「屬性」面板中,按一下「替換」。
  3. 在「替換元件」對話方塊中,選取您要用來取代所有選取之元件/點陣圖的元件。
  4. 按一下「確定」。

將舞台上的動畫轉換成影片片段 元件

若要重複使用舞台上的連續動畫,或將它當做實體來操作,請加以選取並儲存為影片片段元件。

  1. 在主時間軸上,選取要在舞台上每個動畫圖層中使用的影格。如需有關選取影格的詳細資訊,請參閱將影格插入時間軸
  2. 複製影格,請執行下列步驟之一:
    • 在任一選取的影格上按一下右鍵 (Windows) 或按 Control + 按一下 (Macintosh),然後在快顯選單中選取「複製影格」。若要在連續動畫轉換成影片片段後加以刪除,請選取「剪下」。

    • 選取「編輯 > 時間軸 > 複製影格」。若要在連續動畫轉換成影片片段後加以刪除,請選取「剪下影格」。

  3. 取消選取該選取範圍,並確定未選取舞台上的任何項目。請選取「插入 > 新增元件」。
  4. 為該元件命名。針對「類型」選取「影片片段」,然後按一下「確定」。
  5. 請在「時間軸」上按一下「圖層 1」上的「影格 1」,然後選取「編輯 > 時間軸 > 貼上影格」。

    這個動作會將您從「主時間軸」上複製的影格 (以及任何圖層和圖層名稱) 貼到這個影片片段元件的「時間軸」上。此時您從影格所複製的任何動畫、按鈕或互動程式都會變成獨立的動畫 (影片片段元件),可以在文件中重複使用。

  6. 若要回到文件編輯模式,請執行下列其中一個步驟:
    • 按一下「上一步」按鈕。

    • 選取「編輯 > 編輯文件」。

    • 請按一下舞台上方「編輯」列中的場景名稱。

重製元件

重製元件能讓您使用現有的元件,做為建立新元件的起點。

若要建立各種不同外觀的元件版本,也請使用實體。

使用元件庫面板重製元件

  1. 在「元件庫」面板中選取元件,然後執行下列其中一個步驟:
    • 按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後在快顯選單中選取「重製」。

    • 在「元件庫面板」選單中選取「複製」。

選取實體以重製元件

  1. 在舞台上選取元件的實體。
  2. 選取「修改 > 元件 > 重製元件」。

    將會複製元件,而複製元件的實體會取代此實體。

編輯元件

編輯元件時,Animate 會更新文件中元件的所有實體。請使用下列方式編輯元件:

  • 在「舞台」上還有其他物件的情況下,請使用「在原地編輯」命令進行編輯。其他的物件會變成灰色,為的是要和正在編輯的元件作出區別。正在編輯的元件,其名稱會顯示於舞台上方「編輯」列內目前場景名稱的右邊。

  • 在不同的視窗中,使用「在新視窗中編輯」命令。在不同的視窗中編輯元件,可以讓您同時看到元件和主時間軸。您正在編輯的元件名稱會顯示於「舞台」頂端的「編輯」列中。

    您也可以使用元件編輯模式,將視窗由舞台檢視切換至僅能看到該元件的檢視來編輯元件。您正在編輯的元件名稱會顯示於「舞台」上方「編輯」列內目前場景名稱的右邊。

    編輯元件時,Animate 會更新該元件在整份文件中的所有實體,以反映您的編輯結果。編輯元件時,您可以使用任何一種繪圖工具、匯入媒體,或建立其他元件的實體。

  • 您可以使用任何元件編輯方法,變更元件的註冊點 (亦即座標為 0,0 的點)。

 

在原地編輯元件

  1. 請執行下列其中一項:
    • 在舞台上按兩下元件的實體。

    • 在「舞台」上選取元件的實體,並按一下右鍵 (Windows) 或按 Control + 按一下 (Macintosh),然後選取「在原地編輯」。

    • 在「舞台」上選取元件的實體,然後選取「編輯 > 在原地編輯」。

  2. 編輯元件。
  3. 若要退出在原地編輯模式並返回文件編輯模式,請執行下列步驟之一:
    • 按一下「上一步」按鈕。

    • 從「編輯」列的「場景」選單中選取目前的場景名稱。

    • 選取「編輯 > 編輯文件」。

    • 在元件內容外部連按兩下。

在新視窗中編輯元件

  1. 在「舞台」上選取元件的實體,並按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後選取「在新視窗中編輯」。
  2. 編輯元件。
  3. 請按一下右上角 (Windows) 或左上角 (Macintosh) 的「關閉」方塊關閉新視窗,然後在主文件視窗中按一下,繼續對主文件進行編輯。

在元件編輯模式中編輯元件

  1. 執行下列步驟之一,選取元件:
    • 在「元件庫」面板中連按兩下元件的圖示。

    • 在舞台上選取元件的實體,再按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後在快顯選單中選取「編輯」。

    • 在「舞台」上選取元件的實體,然後選取「編輯 > 編輯元件」。

    • 在「元件庫」面板中選取元件,然後在「元件庫面板」選單中選取「編輯」,或是在「元件庫」面板中的元件上按一下右鍵 (Windows) 或按 Control + 按一下 (Macintosh),然後選取「編輯」。

  2. 編輯元件。
  3. 若要結束元件編輯模式,繼續對文件進行編輯,請執行下列步驟之一:
    • 按一下舞台頂端之「編輯」列左邊的「後退」按鈕。

    • 選取「編輯 > 編輯文件」。

    • 按一下舞台頂端之「編輯」列中的場景名稱。

    • 在元件內容外部連按兩下。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策