Guía del usuario Cancelar

Combinación de datos mediante el panel Variables

  1. Guía del usuario de Illustrator
  2. Descubra Illustrator
    1. Introducción a Illustrator
      1. Novedades de Illustrator
      2. Preguntas habituales
      3. Requisitos del sistema de Illustrator
      4. Illustrator para Apple Silicon
    2. Espacio de trabajo
      1. Conceptos básicos del espacio de trabajo
      2. Aprenda más rápido con el panel Descubrir de Illustrator
      3. Creación de documentos
      4. Barra de herramientas
      5. Métodos abreviados de teclado predeterminados
      6. Personalizar métodos abreviados de teclado
      7. Introducción a las mesas de trabajo
      8. Organizar mesas de trabajo
      9. Personalizar el espacio de trabajo
      10. Panel Propiedades
      11. Configuración de preferencias
      12. Espacio de trabajo táctil
      13. Compatibilidad con Microsoft Surface Dial en Illustrator
      14. Deshacer ediciones y administrar el historial del diseño
      15. Rotar vista
      16. Reglas, cuadrículas y guías
      17. Accesibilidad en Illustrator
      18. Modo seguro
      19. Modo de visualización de la ilustración
      20. Uso de Touch Bar con Illustrator
      21. Archivos y plantillas
    3. Herramientas en Illustrator
      1. Herramientas de un vistazo
      2. Selección de herramientas
        1. Selección
        2. Selección directa
        3. Selección de grupos
        4. Varita mágica
        5. Lazo
        6. Mesa de trabajo
      3. Herramientas de navegación
        1. Mano
        2. Rotar vista
        3. Zoom
      4. Herramientas de pintura
        1. Degradado
        2. Malla
        3. Creador de formas
      5. Herramientas de texto
        1. Texto
        2. Texto en trazado
        3. Texto vertical
      6. Herramientas de dibujo
        1. Pluma
        2. Añadir Punto de ancla
        3. Eliminar Puntos de ancla
        4. Punto de ancla
        5. Curvatura
        6. Segmento de línea
        7. Rectángulo
        8. Rectángulo redondeado
        9. Elipse
        10. Polígono
        11. Estrella
        12. Pincel
        13. Pincel de manchas
        14. Lápiz
        15. Shaper
        16. Sector
      7. Modificación de herramientas
        1. Rotar
        2. Reflejar
        3. Escala
        4. Distorsionar
        5. Anchura
        6. Transformación libre
        7. Cuentagotas
        8. Fusión
        9. Borrador
        10. Tijeras
        11. Dimensión
    4. IA generativa (no disponible en China continental)
      1. Generar un gráfico vectorial con una indicación de texto
      2. Cambiar el color de la ilustración con una indicación de texto
    5. Acciones rápidas
      1. Texto retro
      2. Texto con resplandor de neón
      3. Texto de la vieja escuela
      4. Volver a colorear
      5. Convertir boceto en vector
  3. Illustrator en la web (beta)
    1. Información general de Illustrator en la web (beta)
    2. Preguntas frecuentes sobre Illustrator en la web (beta)
    3. Preguntas frecuentes sobre la solución de problemas
    4. Métodos abreviados de teclado de Illustrator en la web (beta)
    5. Crear y combinar formas en la web
    6. Añadir y editar texto en la web
    7. Aplicar colores y degradados en la web
    8. Dibujar y editar trazados en la web
    9. Trabajar con documentos en la nube en la web
    10. Invitar a colaboradores a editar en la web
  4. Illustrator para iPad
    1. Presentación de Illustrator para iPad
      1. Información general sobre Illustrator para iPad
      2. Preguntas frecuentes de Illustrator para iPad
      3. Requisitos del sistema | Illustrator para iPad
      4. Lo que puede o no puede hacer con Illustrator para iPad
    2. Espacio de trabajo
      1. Espacio de trabajo de Illustrator para iPad
      2. Métodos abreviados y gestos táctiles
      3. Métodos abreviados de teclado de Illustrator para iPad
      4. Ajustar la configuración de la aplicación
    3. Documentos
      1. Usar documentos en Illustrator para iPad
      2. Importar documentos de Photoshop y Fresco
    4. Seleccionar y organizar objetos
      1. Crear objetos repetidos
      2. Fusionar objetos
    5. Dibujo
      1. Dibujar y editar trazados
      2. Dibujar y editar formas
    6. Texto
      1. Trabajar con texto y fuentes
      2. Crear diseños de texto a lo largo de un trazado
      3. Añadir fuentes propias
    7. Uso de imágenes
      1. Vectorizar imágenes de trama
    8. Color
      1. Aplicar colores y degradados
  5. Documentos en la nube
    1. Conceptos básicos
      1. Trabajar con documentos en la nube de Illustrator
      2. Compartir documentos en la nube de Illustrator y colaborar en ellos
      3. Compartir documentos para revisar
      4. Ampliar el almacenamiento en la nube de Adobe Illustrator
      5. Documentos en la nube de Illustrator | Preguntas habituales
    2. Solución de problemas
      1. Solución de problemas de creación o guardado de documentos en la nube de Illustrator
      2. Solucionar errores de documentos en la nube de Illustrator
  6. Añadir y editar contenido
    1. Dibujo y acotación
      1. Conceptos básicos de dibujo
      2. Editar trazados
      3. Dibujar ilustraciones con píxeles perfectos
      4. Dibujar con la herramienta Pluma, Curvatura o Lápiz
      5. Dibujar líneas y formas sencillas
      6. Dibujar cuadrículas rectangulares y polares
      7. Dibujar y editar destellos
      8. Calco de imagen
      9. Simplificar un trazado
      10. Herramientas y conjuntos de símbolos
      11. Ajustar segmentos de trazado
      12. Diseñar una flor en cinco sencillos pasos
      13. Crear y editar una cuadrícula de perspectiva
      14. Dibujar y modificar objetos en una cuadrícula de perspectiva
      15. Usar objetos como símbolos para uso repetido
      16. Dibujar trazados con pixelado perfecto en flujos de trabajo web
      17. Medir y trazar dimensiones
    2. Objetos y materiales 3D
      1. Acerca de los efectos 3D en Illustrator
      2. Crear gráficos 3D
      3. Mapear ilustraciones en objetos 3D
      4. Crear texto 3D
      5. Crear objetos 3D
    3. Color
      1. Acerca del color
      2. Seleccionar colores
      3. Uso y creación de muestras
      4. Ajustar colores
      5. Uso del panel Temas de Adobe Color
      6. Grupos de colores (armonías)
      7. Panel Temas de color
      8. Volver a colorear su ilustración
    4. Pintura
      1. Acerca de la pintura
      2. Pintar con rellenos y trazos
      3. Grupos de pintura interactiva
      4. Degradados
      5. Pinceles
      6. Transparencia y modos de fusión
      7. Aplicar un trazo a un objeto
      8. Creación y edición de motivos
      9. Mallas
      10. Motivos
    5. Seleccionar y organizar objetos
      1. Seleccionar objetos
      2. Capas
      3. Agrupar y expandir objetos
      4. Mover, alinear y distribuir objetos
      5. Apilar objetos    
      6. Bloquear, ocultar y eliminar objetos
      7. Copiar y duplicar objetos
      8. Rotar y reflejar objetos
      9. Entrelazar objetos
      10. Cree maquetas de ilustraciones realistas
    6. Cambiar la forma de objetos
      1. Recortar imágenes
      2. Transformar objetos
      3. Combinar objetos
      4. Cortar, dividir y recortar objetos
      5. Deformación de posición libre
      6. Escalar y distorsionar objetos
      7. Fusionar objetos
      8. Cambiar formas con envolventes
      9. Cambiar forma de objetos con efectos
      10. Crear nuevas formas con las herramientas Shaper y Creador de formas
      11. Uso de vértices interactivos
      12. Flujos de trabajo para cambiar de forma mejorados con compatibilidad táctil
      13. Editar máscaras de recorte
      14. Formas interactivas
      15. Crear formas mediante la herramienta Creador de formas
      16. Edición global
    7. Texto
      1. Añadir texto y trabajar con objetos tipográficos
      2. Crear listas numeradas y con viñetas
      3. Administrar área de texto
      4. Fuentes y tipografía
      5. Convertir el texto dentro de imágenes en texto editable
      6. Añadir formato básico al texto
      7. Añadir formato avanzado al texto
      8. Importar y exportar texto
      9. Aplicar formato a párrafos
      10. Caracteres especiales
      11. Crear texto en un trazado
      12. Estilos de carácter y de párrafo
      13. Tabulaciones
      14. Encontrar fuentes que faltan (flujo de trabajo de Typekit)
      15. Texto en árabe y hebreo
      16. Fuentes | Preguntas frecuentes y soluciones de problemas
      17. Crear efecto de texto 3D
      18. Diseños de tipografía creativos
      19. Ampliar y rotar texto
      20. Espaciado entre líneas y caracteres
      21. Separación de sílabas y saltos de línea
      22. Ortografía y diccionarios de idiomas
      23. Aplicar formato de caracteres asiáticos
      24. Modos de composición de alfabetos asiáticos
      25. Crear diseños de texto con objetos de fusión
      26. Crear un póster con texto con Calco de imagen
    8. Crear efectos especiales
      1. Trabajar con efectos
      2. Estilos gráficos
      3. Atributos de apariencia
      4. Crear bosquejos y mosaicos
      5. Sombras paralelas, resplandor y desvanecimiento
      6. Resumen de efectos
    9. Gráficos web
      1. Métodos óptimos para crear gráficos web
      2. Gráficas
      3. SVG
      4. Sectores y mapas de imágenes
  7. Importación, exportación y almacenamiento
    1. Importación
      1. Colocar varios archivos
      2. Administrar archivos vinculados e incrustados
      3. Información sobre vínculos
      4. Desincrustar imágenes
      5. Importar ilustraciones de Photoshop
      6. Importar imágenes de mapa de bits
      7. Importar archivos Adobe PDF
      8. Importar archivos EPS, DCS y de AutoCAD
    2. Bibliotecas Creative Cloud en Illustrator 
      1. Bibliotecas Creative Cloud en Illustrator
    3. Guardar
      1. Guardar ilustraciones
    4. Exportar
      1. Usar ilustraciones de Illustrator en Photoshop
      2. Exportar ilustraciones
      3. Recopilar recursos y exportar en lotes
      4. Empaquetado de archivos
      5. Creación de archivos de Adobe PDF
      6. Extraer CSS | Illustrator CC
      7. Opciones de Adobe PDF
      8. Panel Información del documento
  8. Impresión
    1. Prepárese para imprimir
      1. Ajuste de los documentos para impresión
      2. Cambiar el tamaño y la orientación de la página
      3. Especificar marcas de recorte para separación o alineación
      4. Primeros pasos con un lienzo grande
    2. Impresión
      1. Sobreimprimir
      2. Imprimir mediante gestión del color
      3. Impresión PostScript
      4. Ajustes prestablecidos de impresión
      5. Marcas de impresora y sangrados
      6. Imprimir y guardar ilustraciones transparentes
      7. Reventado
      8. Impresión de separaciones de color
      9. Imprimir degradados, mallas y fusiones de color
      10. Sobreimpresión en blanco
  9. Automatizar tareas
    1. Combinar datos mediante el panel Variables
    2. Automatización con scripts
    3. Automatización con acciones
  10. Solución de problemas 
    1. Problemas conocidos
    2. Errores de bloqueo
    3. Recuperar archivos después de un cierre inesperado
    4. Problemas de archivos
    5. Formatos de archivo admitidos
    6. Problemas con controladores de dispositivos GPU
    7. Problemas con dispositivos Wacom
    8. Problemas con archivos DLL
    9. Problemas de memoria
    10. Problemas con archivos de preferencias
    11. Problemas de fuentes
    12. Problemas con la impresora
    13. Enviar informe de error a Adobe
    14. Mejora del rendimiento de Illustrator

Combine un documento de Illustrator con un archivo de fuente de datos (archivo CSV o XML) con el panel Variables para crear múltiples variaciones de su ilustración. Puede cambiar los nombres de los participantes en las insignias para eventos o cambiar las imágenes de banners web y postales sin tener que rehacer la ilustración. Cree un diseño y, a continuación, produzca rápidamente variaciones mediante la importación de los nombres o las imágenes desde un archivo de origen de datos.

Cree variaciones personalizadas de la plantilla de diseño para diferentes proyectos, como pósteres imprimibles, banners web e insignias para eventos, mediante el panel Variables.

Antes de continuar

Todo lo que necesita para combinar datos es un archivo de origen de datos y un documento de destino. 

  • El archivo de origen de datos contiene la información que varía en cada versión del documento de destino, como los nombres, las fotografías y las direcciones de los destinatarios de un formulario de carta. Un archivo de origen de datos puede ser un archivo delimitado por comas (.csv) o de lenguaje de marcado extensible (.xml). 
  • El documento de destino es un documento de Illustrator que contiene la ilustración de base para utilizarla como plantilla. Este documento puede contener el marcador de posición de campo de datos y los elementos que se mantienen igual en cada versión del documento combinado.

Acceso a la función de combinación de datos

Se puede acceder a la función de combinación de datos desde el panel Variables de Illustrator (Ventana > Variables). El tipo y el nombre de cada variable del documento aparecerán en el panel. Si la variable se encuentra vinculada a un objeto, la columna Objetos mostrará el nombre del objeto vinculado tal como aparece en el panel Capas. Puede ordenar las filas haciendo clic en los elementos de la barra de cabecera: por nombre de variable, por nombre de objeto o por tipo de variable.

Panel Variables

A. Conjunto de datos B. Menú del panel C. Cambio entre conjuntos de datos D. Nombre del objeto vinculado E. Nombre de la variable F. Tipo de variable G. Bloquear variables H. Hacer dinámico el objeto I. Hacer dinámica la visibilidad J. Desvincular variables K. Creación de variables L. Eliminación de variables 

Pasos rápidos para combinar datos

  1. Cree un documento de Illustrator para usarlo como la plantilla.

  2. Configure el archivo de origen de datos con formato CSV o XML. Para obtener más información, consulte Preparación de un archivo de origen de datos.

  3. Importe un archivo de origen de datos en Illustrator mediante el panel Variables. Para obtener más información, consulte Importación de un archivo de origen de datos.

  4. Enlace una variable a un objeto en su plantilla. Para obtener más información, consulte Enlace de variables a objetos.

  5. Previsualice el documento con cada conjunto de datos antes de exportar todos los archivos. Para obtener más información, consulte Previsualice el documento con cada conjunto de datos.

  6. Exporte un lote de archivos a partir de los datos mediante el panel Acciones en Illustrator. Para obtener más información, consulte Exportación de archivos mediante el panel Acciones.

Preparación de un archivo de origen de datos

Los archivos de origen de datos deben guardarse en formato delimitado por comas (.csv) o de lenguaje de marcado extensible (.xml).

Configuración de los archivos de origen CSV

En un archivo delimitado por comas (.csv), los registros están separados con saltos de párrafo y los campos con comas o tabulaciones. El archivo de origen de datos también puede incluir texto o rutas de acceso a imágenes en disco. Antes de importar un archivo CSV, haga lo siguiente para permitir que Illustrator identifique el tipo de variable.

  1. Abra la hoja de cálculo.

  2. Especifique el nombre del campo de datos en la primera fila de la hoja de cálculo. A continuación, realice lo siguiente:

    • Al comienzo del nombre del campo de datos, escriba un símbolo de “arroba” (@) para introducir texto o rutas que hagan referencia a archivos de imágenes. El símbolo @ es necesario solo en la primera línea; las líneas posteriores deben incluir las rutas de acceso a las imágenes.
    • De manera similar, al comienzo del nombre del campo de datos, escriba un “símbolo de porcentaje” (%) para los gráficos y un símbolo de "almohadilla" (#) para la visibilidad.
    • Para definir la visibilidad de un objeto, especifique verdadero o falso para cada campo de datos.
    Nota:
    • Los nombres de los campos de datos de la hoja de cálculo no deben contener espacios en blanco. Por ejemplo, puede especificar el campo de datos como Nombre_empresa en lugar de Nombre empresa
    • Del mismo modo, las rutas que hacen referencia a archivos de imágenes y gráficas no deben contener espacios en blanco. Por ejemplo, la ruta de un archivo de imagen debe ser C:\Fotos\MiguelRamos en lugar de C:\Fotos\Miguel Ramos.
    • Todos los archivos de gráficas enlazados al archivo de origen de datos se deben guardar como archivos delimitados por comas (.csv).
    • Si aparece un mensaje de error al escribir el símbolo @ al comienzo del campo, escriba un apóstrofe (') delante del signo @ (por ejemplo, '@Fotos) para validar la función. Algunas aplicaciones, como Microsoft Excel, reservan el símbolo @ para funciones.

    (Windows) Ejemplo de referencias de imagen y gráficas en archivo de origen de datos

    Nombre

    Edad

    @Fotos

    %Gráficas

    #Visibilidad

    Miguel Ramos

    36

    C:\Fotos\MiguelRamos.jpg

    C:\Fotos\MiguelRamos.csv

    Verdadero

    Eugenio Ruiz

    53

    C:\Mis documentos\dat.jpg

    C:\Mis documentos\dat.csv

    Verdadero

    Ángeles Ortega

    26

    C:\Fotos\Ortega.jpg

    C:\Fotos\Ortega.csv

    Falso

    (macOS) Ejemplo de referencias de imagen y gráficas en archivo de origen de datos

    Nombre

    Edad

    @Fotos

    %Gráficas

    #Visibilidad

    Miguel Ramos

    36

    /Usuarios/fotos/MiguelRamos.jpg

    /Usuarios/fotos/MiguelRamos.csv

    Verdadero

    Eugenio Ruiz

    53

    /Usuarios/familia/fotos/dat.jpg

    /Usuarios/familia/fotos/dat.csv

    Verdadero

    Ángeles Ortega

    26

    /Usuarios/alfa/fotos/Ortega.jpg

    /Usuarios/alfa/fotos/Ortega.csv

    Falso

  3. Introduzca sus datos en la hoja de cálculo.

  4. Lleve a cabo uno de los procedimientos siguientes:

    • Guarde las hojas de cálculo creadas con la última versión de Microsoft Excel (versión 2016) en los siguientes formatos de archivo:
      • CSV (delimitado por comas) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Guarde las hojas de cálculo creadas con Apple Numbers en formato CSV con codificación Unicode (UTF-8).
    Nota:

    Actualmente, los archivos CSV exportados con los formatos anteriores son compatibles con Illustrator. Otros formatos de archivo CSV, como los separados por comas para Mac (.csv), no se pueden utilizar para la combinación de datos.

Preparación de un archivo XML

  1. Defina una variable en su documento. Para obtener más información, consulte Enlace de variables a objetos.

  2. Seleccione el botó Capturar conjunto de datos  en el panel Variables.

  3. Después de crear el número deseado de conjuntos de datos, seleccione Guardar biblioteca de variables en el menú del panel Variables para guardar los conjuntos de datos como un archivo XML. Especifique un nombre de archivo y una ubicación y seleccione Guardar.

    Exporte las variables que haya creado en Illustrator como un archivo XML.

  4. Ahora, edite el archivo XML en una aplicación de edición de texto, como Notepad++ (Windows) o TextWrangler (macOS), para incluir los conjuntos de datos en este archivo.

    Ejemplo: edición de un archivo XML con cualquier aplicación de edición de texto

    A. Sustitución de la ruta de la imagen B. Sustitución de una cadena de texto  

  5. Seleccione Cargar biblioteca de variables en el menú del panel Variables para importar su archivo XML en Illustrator. Seleccione el archivo XML y seleccione Abrir.

    Importe variables en Illustrator

Importación de un archivo de origen de datos

Para enlazar variables a los datos deseados, importe un origen de datos en el panel Variables. Solo se puede seleccionar un archivo de origen de datos por cada documento.

  1. Seleccione Ventana > Variables.

  2. En el panel Variables, seleccione Importar.

  3. En el cuadro de diálogo Cargar biblioteca de variables, seleccione un archivo de origen de datos en formato CSV o XML, y seleccione Abrir.

  4. Puede editar, cambiar el nombre o eliminar el conjunto de datos posteriormente seleccionándolo en el menú desplegable Conjunto de datos y editando sus opciones.

    • Seleccione un conjunto de datos de la lista Conjunto de datos en el panel Variables para cambiar entre conjuntos de datos. También puede seleccionar el botón Conjunto de datos anterior  o el botón Conjunto de datos siguiente .
    • Para aplicar los datos de la mesa de trabajo al conjunto de datos actual, elija Actualizar conjunto de datos  en el menú del panel Variables .
    • Para cambiar el nombre de un conjunto de datos, edite el texto directamente en el cuadro de texto Conjunto de datos. Puede hacer doble clic en las palabras Conjunto de datos (a la izquierda del cuadro de texto Conjunto de datos), introduzca un nombre nuevo y haga clic en OK.
    • Para eliminar un conjunto de datos, seleccione el icono Eliminar. También puede seleccionar Eliminar conjunto de datos en el menú del panel Variables.
    Nota:

    Los archivos CSV (UTF-8 delimitados por comas) que contienen caracteres de doble byte creados a través de Excel no se pueden importar en el panel Variables. Si abre el mismo archivo en formato de texto y luego lo guarda como CSV con codificación UTF-8, el archivo se importa correctamente.

Enlace de variables a objetos

Utilice variables para definir los elementos de una plantilla que desea cambiar. Puede definir cuatro tipos de variables: variable Visibilidad, variable Cadena de texto, variable Archivo enlazado y variable Datos de gráfica. El tipo de la variable indica los atributos de objeto que se pueden cambiar (dinámicos). El tipo y el nombre de cada variable del documento aparecerán en el panel. Si la variable se encuentra vinculada a un objeto, la columna Objetos mostrará el nombre del objeto vinculado tal como aparece en el panel Capas.

Tipo de variable

Icono para indicar el tipo de variable

Definición

Variable Visibilidad

Visualización u ocultación de ilustraciones.

Variable Cadena de texto

Sustitución de una cadena de texto.

Variable Archivo enlazado

Sustitución del objeto en la mesa de trabajo con un objeto de otro archivo.

Variable Datos de gráfica

Sustitución de los valores en un gráfico.

Variable sin tipo (sin vincular)

No vinculado a ningún objeto.

Siga estos pasos para definir variables en Illustrator:

  1. Seleccione un objeto.

  2. En el panel Variables (Ventana > Variables), seleccione la variable con la que desea enlazarlo.

  3.  Seleccione el botón Hacer dinámico el objeto  para vincular el objeto con la variable.

Siga estos pasos para crear una variable sin vincularla a un objeto:

  1. Seleccione el botón Nueva variable  en el panel Variables.

  2. Para vincular posteriormente un objeto a una variable, seleccione el objeto y la variable y seleccione el botón Hacer dinámica la visibilidad o en el botón Hacer dinámico el objeto .

Nota:

Los nombres de variables no admiten pares sustitutos ni caracteres de 4 bytes. Si utiliza estos caracteres en un nombre de variable, se muestra un mensaje de error.

Trabajo con variables

Puede editar el tipo o el nombre de una variable, desvincularla y bloquearla utilizando el panel Variables.

Al desvincular una variable se rompe el enlace entre la variable y su objeto. El bloqueo de variables impide la creación y eliminación de variables, así como la modificación de sus opciones. Sin embargo, es posible vincular objetos a variables bloqueadas o desvincularlos de las mismas.

Cambio del nombre y el tipo de variable

  1. Seleccione la variable en el panel Variables y seleccione Opciones de variable en el menú del panel.

Desvincular una variable

  1. Seleccione el botón Desvincular variables  en el panel Variables.

Bloqueo y desbloqueo de todas las variables de un documento

  1. Seleccione el botón Bloquear variables  o el botón Desbloquear variables en el panel Variables.

Eliminación de variables

Elimine una variable para quitarla del panel Variables. Si elimina una variable vinculada a un objeto, este se convertirá en estático (a menos que esté también vinculado a otro tipo de variable).

  1. Seleccione la variable que desee eliminar.

  2. Siga una de las siguientes opciones:

    • Seleccione el botón Eliminar variable  en el panel Variables.

    • Para eliminar una variable sin previa confirmación, arrástrela hasta el botón Eliminar variable .

Edición de objetos dinámicos

Para cambiar los datos asociados a una variable debe editar el objeto al que está vinculada. Por ejemplo, si está trabajando con una variable Visibilidad, cambie el estado de visibilidad del objeto en el panel Capas. La edición de objetos dinámicos permite la creación de varios conjuntos de datos en la plantilla.

  1. Seleccione un objeto dinámico de la mesa de trabajo, o realice uno de los procedimientos siguientes para seleccionar un objeto dinámico automáticamente:

    • Pulse la tecla Alt (Windows) o la tecla Opción + clic (macOS) y en una variable en el panel Variables.

    • Seleccione una variable en el panel Variables y seleccione Seleccionar objeto vinculado en el menú del panel Variables.

    • Seleccione Todos los objetos enlazados en el menú del panel Variables para seleccionar todos los objetos dinámicos.

  2. Edite los datos asociados al objeto de la manera siguiente:

    • Edite la cadena de texto en la mesa de trabajo.

    • Reemplace la imagen con el panel Enlaces o el comando Archivo > Colocar para archivos vinculados.

    • Edite los datos de los gráficos en el cuadro de diálogo Datos de gráfica.

    • Para todos los objetos con visibilidad dinámica, cambie el estado de visibilidad del objeto en el panel Capas.

Identificación de objetos dinámicos utilizando identificadores XML

El panel Variables muestra los nombres de objetos dinámicos tal como aparecen en el panel Capas. Si guarda la plantilla en formato SVG para utilizarla con otros productos de Adobe, estos nombres de objeto deben cumplir las convenciones XML de asignación de nombres. Por ejemplo, los nombres XML deben empezar por una letra, un guion bajo o dos puntos y no pueden contener espacios.

Illustrator asigna un identificador XML válido automáticamente a cada objeto creado. Para ver, editar y exportar nombres de objeto utilizando identificadores XML, seleccione Edición > Preferencias > Unidades (Windows) o Illustrator > Preferencias > Unidades (macOS) y, a continuación, seleccione ID XML.

Previsualice el documento con cada conjunto de datos

Para ver el aspecto final de los gráficos, puede previsualizarlos antes de exportar todos los archivos. Utilice las teclas de flecha situadas junto a Conjunto de datos en el panel Variables para navegar y obtener una vista previa de los datos deseados definidos en el documento.

Exportación de archivos mediante el panel Acciones

Tras definir las variables y uno o varios conjuntos de datos, puede procesar ilustraciones, en modo de lote, con los valores del conjunto de datos. Lleve a cabo el procedimiento siguiente:

  1. Mediante el panel Acciones (Ventana > Acciones), grabe una acción para guardar el documento en el formato deseado. Para obtener más información, consulte Automatización con acciones.

  2. Seleccione Lote en el menú del panel Acciones y seleccione la acción que ha creado en el paso anterior.

  3. En Origen, seleccioneConjuntos de datos para reproducir la acción en cada conjunto de datos en el archivo actual.

  4. En Destino, especifique lo que desea hacer con los archivos procesados. Puede dejar los archivos abiertos sin guardar los cambios (Ninguno), guardar y cerrar el archivo en su ubicación actual (Guardar y cerrar) o guardar los archivos en una ubicación diferente (Carpeta).

    Dependiendo de la opción Destino, puede definir opciones adicionales para guardar los archivos. Para obtener más información, vea Reproducción de una acción en un lote de archivos.

  5. Seleccione OK.

Guardar una plantilla para combinar datos

Al definir variables en un documento de Illustrator, se crea una plantilla para combinar datos. Es posible guardar la plantilla en formato SVG para utilizarla con otros productos de Adobe como Adobe® Graphics Server. Por ejemplo, un desarrollador que esté trabajando con Adobe Graphics Server puede vincular las variables del archivo SVG a una base de datos o a directamente a otra fuente de datos.

  1. Seleccione Archivo > Guardar como, introduzca un nombre de archivo, seleccione SVG como formato de archivo y haga clic en Guardar.

  2. Haga clic en Más opciones y seleccione Incluir datos de Adobe Graphics Server. Esta opción incluye toda la información necesaria para la sustitución de variables en el archivo SVG.

  3. Haga clic en OK.

¿Experimenta problemas al importar el archivo CSV?

Si experimenta el error: La biblioteca de variable entrante no es válida al cargar un archivo de origen de datos CSV, compruebe si:

  • El archivo CSV no está en blanco.
  • Las hojas de cálculo creadas con la versión más reciente de Microsoft Excel se han guardado como archivo CSV (delimitado por comas) (*.csv) o CSV (MS-DOS) (*.csv) y las creadas con Apple Numbers se han guardado en formato CSV con codificación Unicode (UTF-8). Tenga en cuenta que los archivos de origen de datos guardados en cualquier otro formato de archivo, como separados por comas para Mac (*.csv) no se pueden utilizar para la combinación de datos.
  • Todas las columnas tienen un nombre del campo de datos. Por ejemplo, Illustrator muestra un mensaje de error cuando una columna del archivo de origen de datos contiene datos pero no tiene ningún nombre del campo de datos.
  • El archivo de origen de datos no tiene ninguna columna en blanco entre las columnas rellenas. Por ejemplo, Illustrator muestra el mensaje de error cuando las columnas B y D del archivo de origen de datos contienen datos pero la columna C está vacía.
Ejemplo: errores al configurar un archivo de origen CSV para la combinación de datos

A. Falta el nombre del campo de datos para una columna B. Hay una columna en blanco entre columnas rellenas 

  • Los nombres de los campos de datos de la hoja de cálculo no contienen espacios en blanco.
  • Las rutas que hacen referencia a los archivos de imágenes y gráficas del archivo de origen no contienen espacios en blanco.
  • Los archivos de gráficas enlazados desde el archivo de origen de datos se guardan como archivos delimitados por comas (.csv).

recursos relacionados

Póngase en contacto con nosotros

Nos encantaría conocer su opinión. Comparta sus ideas con la Comunidad de Adobe Illustrator

 Adobe

Obtén ayuda de forma más rápida y sencilla

¿Nuevo usuario?