將文字新增至文件

您可藉由輸入文字,或是從文書處理應用程式貼上或置入文字,將文字新增至文件中。如果您的文書處理應用程式支援拖放功能,也可以將文字拖移至 InDesign 框架中。處理大量文字區塊時,「置入」指令是新增文字至文件的有效、多功能方法。InDesign 支援多種不同文書處理、試算表和文字檔案格式。

置入或貼上文字時,不需要先建立文字框;InDesign 會自動為您建立文字框。

置入文字時,可以選取「顯示讀入選項」,決定讀入的文字是否維持其樣式和格式設定。貼上文字前,您可以選取「剪貼簿處理偏好設定」底下的「所有資訊」或「僅文字」,決定貼上的文字是否包含其他資訊,例如色票和樣式。

註解:

如果讀入文件的文字包含粉紅色、綠色或其他加亮標明顏色,表示您可能開啟了一或多個排版偏好設定選項。請開啟「偏好設定」對話框的「排版」區段,注意「加亮標明」底下已開啟哪些選項。例如,若是貼上的文字以無法使用的字體進行格式化,則該文字會以粉紅色標示。

在文件中輸入文字

  1. 請執行下列任一項動作,將插入點置入文字框內:
    • 使用「文字」工具 ,拖移以建立新的文字框,或按一下現有的文字框。

    • 使用選取工具,在現有文字框內按兩下。「文字」工具便會自動選取。

  2. 開始輸入。

如果已在主版頁面上建立文字框,當您按一下文件頁面的框架時,請按住 Ctrl+Shift 鍵 (Windows) 或 Command+Shift 鍵 (Mac OS)。便可在文件頁面上建立主版頁面框架的拷貝。然後您可以使用「文字」工具,將文字新增至選取的框架中。

使用內嵌輸入法輸入亞洲文字

  1. 選擇「編輯 > 偏好設定 > 進階文字」(Windows) 或「InDesign > 偏好設定 > 進階文字」(Mac OS)。
  2. 選取「非拉丁文字使用內嵌輸入」,然後按一下「確定」。

(如果可用) 您可以使用系統輸入法,以新增 2 位元組和 4 位元組字元。這個方法在輸入亞洲字元時特別有用。

插入預留位置文字

InDesign 可以加入預留位置文字,您可在稍後輕易地以真實文字取代。加入預留位置文字可讓您對文件的設計有更完整的概念。

  1. 使用「選取」工具選取一或多個文字框,或者使用「文字」工具在文字框中按一下。
  2. 選擇「文字 > 以預留位置文字填滿」。

如果將預留位置文字加入串連到其他框架的框架中,則預留位置文字會增加到第一個文字框的開頭 (如果所有框架均為空白),或現有文字的結尾 (如果串連的框架中已有一些文字),一直到最後一個串連框架的結尾。

如果要移除或取代預留位置文字,請在任一個串連的框架中按兩下,並選擇「編輯 > 全部選取」,然後刪除文字。

註解:

如果要變更當做預留位置文字使用的文字,請以您要使用的文字建立文字檔案,將其命名為「Placeholder.txt」,並儲存在應用程式檔案夾中。

貼上文字

當您將文字貼至 InDesign 中時,如果插入點不在文字框內,將建立新的純文字框。如果插入點位在文字框內,文字將會貼入該框架內。當您貼上時,如果有選取的文字,貼上的文字將會覆寫選取的文字。

貼上來自其他應用程式的文字

  1. 如果要保留樣式和索引標記之類的格式設定和資訊,請開啟「偏好設定」對話框的「剪貼簿處理」區段,然後選取「貼上」底下的「所有資訊」。如果要在貼上時移除這些項目和其他格式設定,請選取「僅文字」。
  2. 剪下或拷貝另一個應用程式或 InDesign 文件中的文字。
  3. 如果需要,您可以選取文字或在文字框中按一下; 否則,文字會貼入其自己的新框架中。
  4. 執行下列任一項作業:
    • 選擇「編輯 > 貼上」。如果貼上的文字未包含所有格式設定,可能需要在「讀入選項」對話框中,變更 RTF 文件的設定。

    • 選擇「編輯 > 貼上但不套用格式設定」 (如果已在「剪貼簿處理偏好設定」中選取「僅文字」,則貼上來自另一個應用程式的文字時,「貼上但不套用格式設定」會呈現為灰色)。

註解:

您也可以從其他應用程式,將文字拖放到 InDesign 文件中,或直接從「Windows 檔案總管」或 Mac OS Finder,將文字檔案或文書處理檔案插入 InDesign 文件中。文字將會加入新框架中。按住 Shift 鍵並拖移,會移除格式設定。您在「偏好設定」對話框的「剪貼簿處理」區段中選取的選項,會決定是否保留索引標記和色票之類的資訊。

貼上文字時自動調整間距

貼上文字時,會根據上下文自動增加或移除空格。例如,若剪下一個單字,然後將它貼到兩個單字之間,則單字的前後會顯示空格。如果將該單字貼到句子結尾處的句號之前,便不會加入空格。

註解:

這項功能主要是搭配羅馬文字使用。同時,只有在「字元」面板中,將要貼上的羅馬文字設定為羅馬語言時,才能使用這項功能。

  1. 選擇「編輯 > 偏好設定 > 文字」(Windows) 或「InDesign > 偏好設定 > 文字」(Mac OS)。
  2. 選取「剪下及貼上單字時自動調整間距」,然後按一下「確定」。

拖放文字

您可以在「內文編輯器」或「版面檢視」中,使用滑鼠拖放文字。甚至可以將文字從「內文編輯器」拖移到版面視窗中 (反之亦然),或是拖移到如「尋找/變更」的一些對話框中。從已鎖定或存回的內文拖移文字會拷貝文字,而不會移動文字。您也可以在拖放文字時,拷貝文字或建立新框架。

Jeff Witchel 在使用 InDesign 拖放文字中提供有關拖放功能的教學課程影片。

  1. 若要啟動拖放功能,請選擇「編輯 > 偏好設定 > 文字」(Windows) 或「InDesign > 偏好設定 > 文字」(Mac OS),選取「在版面檢視中啟動」、「在內文編輯器中啟動」(InDesign) 或「在校稿/內文檢視中啟動」(InCopy),然後按一下「確定」。
  2. 選取要移動或拷貝的文字。
  3. 將指標停駐在選取的文字上方,直到拖放圖示 顯示為止,然後拖移文字。

    在拖移時,選取的文字會保持在原處,不過會出現一條垂直線,指示放開滑鼠按鈕時文字將顯示的位置。垂直線會出現在滑鼠拖移到的任何文字框中。

  4. 執行下列任一項作業:
    • 如果要將文字放置到新位置,請將垂直線移到希望文字顯示的位置,然後放開滑鼠按鈕。

    • 如果要將文字放置到新框架中,請在開始拖移後按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS),然後在放開按鍵前放開滑鼠按鈕。

    • 如果要放置文字但不套用格式設定,請在開始拖移後按住 Shift 鍵,然後在放開按鍵前放開滑鼠按鈕。

    • 如果要拷貝文字,請在開始拖移後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),然後在放開按鍵前放開滑鼠按鈕。

註解:

您也可以使用這些輔助按鍵的組合。例如,如果要將未格式化的文字拷貝至新框架中,請在開始拖移後按住 Alt+Shift+Ctrl (Windows) 或 Option+Shift+Command (Mac OS)。

如果放置的文字沒有適當的間距,請選取「文字偏好設定」中的「自動調整間距」選項。

置入 (讀入) 文字

置入文字或試算表檔案時,可以指定選項,決定讀入文字的格式化方式。

  1. (選擇性) 如果要在置入的檔案中建立連結,請在「偏好設定」對話框中按一下「檔案處理」,然後選取「置入文字和試算表檔案時建立連結」。

    選取這個選項,會建立已置入檔案的連結。您可以使用「連結」面板更新文字檔案的連結、重新連結或移除連結。不過,如果是在 InDesign 中設定連結文字的格式,則在更新連結時可能不會保留此格式。如果未選取這個選項,則會嵌入 (而非連結) 讀入的文字檔案和試算表檔案。

  2. 執行下列任一項作業:
    • 如果要為置入的文字建立新框架,請確認沒有插入點存在,且沒有選取任何文字或框架。

    • 如果要在框架中新增文字,請使用「文字」工具 選取文字或置入插入點。

    • 如果要取代現有框架的內容,請使用「選取」工具選取框架。如果選取串連的框架,則會出現載入的文字游標。

    註解:

    如果不小心使用此方法取代文字檔案或圖形,請選擇「編輯 > 還原取代」,然後按一下或拖移以建立文字框。

  3. 選擇「檔案 > 置入」。
  4. 如果要以讀入的檔案取代選取的框架內容、取代選取的文字,或將其新增至文字框中的插入點位置,請選取「取代選取項目」。取消選取此選項,可將讀入的檔案排文到新框架中。
  5. 選取「顯示讀入選項」,然後按兩下要讀入的檔案。
  6. 設定讀入選項,然後按一下「確定」。

如果尚未指定接收文字的現有框架,指標會變成已載入的文字圖示,準備好將文字排文到任何您按一下或拖移之處。

註解:

根據「內文」面板中的設定,置入的文字框可以轉換為純文字框或框架格點。您可以選擇「文字 > 書寫方向 > 水平 (或垂直)」決定框架的書寫方向。當文字置入框架格點中時,「格點」工具中的文件預設集將套用至框架格點。視需要套用格點格式設定。

如果出現警告訊息,指出找不到要求的過濾器,您可能嘗試從不同的文書處理應用程式或舊版 Microsoft® Word (例如 Word 6) 置入檔案。請在原始應用程式中開啟檔案並儲存為 RTF 格式,如此可保留大多數的格式設定。

如果所讀入 Microsoft Excel 文件的儲存格中出現紅點,請調整儲存格大小或文字屬性,讓溢排內容成為可見的。您也可以將檔案做為未格式化的定位點分隔文字來置入,然後將此定位點分隔文字轉換為表格。

關於讀入過濾器

InDesign 會從文字檔案讀入多數字元和段落格式設定屬性,但會忽略多數頁面版面資訊,例如邊界和欄設定 (這些可在 InDesign 中設定)。請注意下列事項:

  • InDesign 通常會讀入在文書處理應用程式中指定的所有格式設定資訊,除了無法在 InDesign 中使用的文書處理功能相關資訊外。

  • InDesign 可以將讀入的樣式新增到其文件的樣式清單中。讀入的樣式旁會顯示磁碟圖示 (請參閱將 Word 樣式轉換為 InDesign 樣式)。

  • 在「置入」對話框中選取「顯示讀入選項」,或是讀入 Excel 檔案時,會顯示讀入選項。如果取消選取「顯示讀入選項」,InDesign 會使用上次用於類似文件類型的讀入選項。除非變更選項,否則您設定的選項將持續使用。

  • 如果 InDesign 找不到依據其檔案類型或副檔名辨識檔案的過濾器,則會顯示警告訊息。為了在 Windows 中獲得最佳結果,對於要讀入的檔案類型,請使用標準副檔名 (例如「.doc」、「.docx」、「.txt」、「.rtf」、「.xls」或「.xlsx」)。您可能需要在原始應用程式中開啟檔案,並以不同格式儲存,例如 RTF 或純文字。

如需有關讀入篩選器的詳細資訊,請參閱篩選器讀我 PDF 檔案,網址為 www.adobe.com/go/lr_indesignfilters_cs5_tw

Microsoft Word 和 RTF 讀入選項

如果在置入 Word 檔案或 RTF 檔案時選取了「顯示讀入選項」,您便可以選擇下列選項:

目錄文字

讀入目錄成為內文中文字的一部分。這些項目會讀入為純文字。

索引文字

讀入索引成為內文中文字的一部分。這些項目會讀入為純文字。

註腳

讀入 Word 註腳。會保留註腳與參照,不過會根據文件的註腳設定重新編號。如果讀入的 Word 註腳不正確,請嘗試將 Word 文件儲存為 RTF 格式,然後再讀入 RTF 檔案。

章節附註

讀入章節附註成為內文結尾處文字的一部分。

使用印刷體引號

確保讀入的文字包含左右引號 (“ ”) 和單引號 (’),而非直式雙引號 (" ") 和單引號 (')。

移除文字與表格中的樣式及格式設定

從讀入的文字 (包括表格中的文字) 移除格式設定,例如字體、文字顏色和文字樣式。如果選取這個選項,將不會讀入段落樣式和內嵌圖形。

保留本機優先選項

選擇從文字與表格中移除樣式及格式設定時,可以選取「保留本機優先選項」,保留套用至部分段落的字元格式設定,例如粗體和斜體。取消選取此選項,可移除所有格式設定。

將表格轉換為

選擇從文字與表格中移除樣式及格式設定時,可以將表格轉換為基本的未格式化表格,或是未格式化的 Tab 字元分隔文字。

如果要讀入未格式化文字和格式化表格,請讀入不含格式設定的文字,然後從 Word 拷貝表格並貼入 InDesign 中。

保留文字與表格中的樣式及格式設定

在 InDesign 或 InCopy 文件中保留 Word 文件的格式設定。您可以使用「格式設定」區段中的其他選項,決定保留樣式及格式設定的方式。

手動分頁符號

決定如何在 InDesign 或 InCopy 中格式化來自 Word 檔案的分頁。您可以選取「保留分頁符號」,使用與 Word 中所用相同的分頁,也可以選取「轉換為分欄符號」或「不換行」。

讀入內嵌圖形

在 InDesign 中保留來自 Word 文件的內嵌圖形。

讀入未使用的樣式

讀入來自 Word 文件的所有樣式,即使是未套用至文字的樣式。

將項目符號和編號轉換為文字

讀入項目符號和編號做為實際字元,並且保留段落外觀。不過,在編號清單中,變更清單項目時不會自動更新編號。

追蹤修訂

選取此選項會使 Word 文件中的「追蹤修訂」標記出現在 InDesign 文件中。在 InDesign 中,請檢視「內文編輯器」中的追蹤修訂。

自動讀入樣式

將來自 Word 文件的樣式讀入 InDesign 或 InCopy 文件中。如果「樣式名稱衝突」旁出現黃色警告三角形,表示來自 Word 文件的一或多個段落或是字元樣式,與 InDesign 樣式的名稱相同。

如果要決定解決這些樣式名稱衝突的方式,請從「段落樣式衝突」和「字元樣式衝突」選單中選取選項。選擇「使用 InDesign 樣式定義」,會根據 InDesign 樣式設定讀入之樣式文字的格式。選擇「重新定義 InDesign 樣式」,會根據 Word 樣式設定讀入之樣式文字的格式,並變更以該樣式格式化的現有 InDesign 文字。選擇「自動重新命名」,會重新命名讀入的 Word 樣式。例如,若是 InDesign 和 Word 都有「Subheading」樣式,當選取「自動重新命名」時,會將讀入的 Word 樣式重新命名為「Subheading_wrd_1」。

註解:

InDesign 會轉換段落和字元樣式,但不會轉換項目符號和編號清單樣式。

自訂樣式讀入

您可以使用「樣式對應」對話框,為讀入文件中的每個 Word 樣式,選取應使用的 InDesign 樣式。

儲存預設

儲存目前的「Word 讀入選項」,供日後重複使用。指定讀入選項,按一下「儲存預設」,輸入預設名稱,然後按一下「確定」。當下次讀入 Word 樣式時,可以從「預設」選單中,選取您所建立的預設。如果要使用選取的預設,做為未來讀入 Word 文件的預設值,請按一下「設定為預設值」。

文字檔案讀入選項

如果在置入文字檔案時選取了「顯示讀入選項」,您可以選擇下列這些選項:

字元集

指定用來建立文字檔案的電腦語言字元集,例如 ANSI、Unicode UTF8、或 Windows CE。預設選項是對應至 InDesign 或 InCopy 預設語言和平台的字元集。

指定用於建立文字檔案的電腦語言字元集,例如 ANSI、Unicode UTF8、Shift JIS 或 Chinese Big 5。預設選項是對應至 InDesign 或 InCopy 預設語言和平台的字元集。

平台

指定檔案是在 Windows 中或 Mac OS 中建立。

將字典設定為

指定讀入的文字要使用的字典。

額外換行符號

指定讀入額外段落換行符號的方式。請選擇「在每行結尾移除」或「在段落之間移除」。

取代

以定位鍵取代指定的空格數。

使用印刷體引號

確保讀入的文字包含左右引號 (“ ”) 和單引號 (’),而非直式雙引號 (" ") 和單引號 (')。

Microsoft Excel 讀入選項

讀入 Excel 檔案時,可以選擇下列選項:

工作表

指定要讀入的工作表。

檢視

指定是否要讀入任何已儲存的自訂或個人檢視,或者忽略這些檢視。

儲存格範圍

指定儲存格的範圍,將會使用冒號 (:) 來指定範圍 (例如 A1:G15)。如果工作表內有已命名範圍,這些名稱會顯示在「儲存格範圍」選單中。

讀入未儲存於檢視中的隱藏儲存格

包含任何在 Excel 試算表中格式化為隱藏儲存格的儲存格。

表格

指定試算表資訊在文件中顯示的方式。

設定表格格式

InDesign 會嘗試保留 Excel 中所用的相同格式設定,不過可能不會保留每個儲存格內的文字格式設定。如果是連結試算表而不是內嵌試算表,則更新連結時會覆寫 InDesign 中已套用至表格的任何格式設定。

未設定表格格式

表格讀入時不會帶有試算表的任何格式設定。選取這個選項時,您可以將表格樣式套用至讀入的表格。如果您使用段落和字元樣式設定文字格式,就算您更新試算表的連結,還是會保留這些格式設定。

未設定格式的定位點分隔文字

表格會讀入為 Tab 字元分隔文字,接著您便可以在 InDesign 或 InCopy 中轉換為表格。

僅設定格式一次

InDesign 會在初始讀入期間保留 Excel 中所使用的相同格式設定。如果是連結試算表而不是內嵌試算表,當您更新連結時,連結表格中會忽略對試算表所進行的格式設定變更。InCopy 未提供此選項。

表格樣式

將您指定的表格樣式套用至讀入的文件。只有在已選取「未設定表格格式」時,才能使用這個選項。

儲存格對齊方式

為讀入的文件指定儲存格對齊方式。

包含內嵌圖形

在 InDesign 中保留來自 Excel 文件的內嵌圖形。

包含的小數位數

指定試算表數字的小數位數。

使用印刷體引號

確保讀入的文字包含左右引號 (“ ”) 和單引號 (’),而非直式雙引號 (" ") 和單引號 (')。

標記文字讀入選項

您可以使用「標記文字」格式,讀入 (或轉存) 可利用 InDesign 格式設定功能的文字檔案。標記文字檔案是文字檔案,其中包含您要 InDesign 套用之格式設定的描述資訊。適當標記的文字幾乎可以描述任何能在 InDesign 內文中顯示的項目,包括所有段落層級屬性、字元層級屬性以及特殊字元。

如需有關指定標記的詳細資訊,請檢視「標記文字」(PDF),網址為 www.adobe.com/go/learn_id_taggedtext_cs5_tw

當您讀入標記文字檔案,並在「置入」對話框中選取「顯示讀入選項」後,可以使用下列選項。

使用印刷體引號

確保讀入的文字包含左右引號 (“ ”) 和單引號 (’),而非直式雙引號 (" ") 和單引號 (')。

移除文字格式設定

從讀入的文字移除格式設定,例如字體、文字顏色和文字樣式。

解決文字樣式衝突時使用

指定當標記文字檔案中的樣式與 InDesign 文件中的樣式發生衝突時,要套用的字元或段落樣式。選取「出版物定義」,可使用 InDesign 文件中該樣式已經具有的定義。如果要使用如同標記文字中所定義的樣式,請選取「標記檔案定義」。

置入前顯示問題標記清單

顯示無法辨識的標記清單。出現這份清單時,您可以選擇取消或繼續讀入。如果繼續,檔案看起來可能會與預期的不同。

將 Word 或 RTF 讀入選項儲存為預設集

  1. 置入 Word 或 RTF 檔案時,確認已選取「顯示讀入選項」,然後選擇「開啟」。
  2. 在「讀入選項」對話框中,指定所需的設定。
  3. 按一下「儲存預設」,輸入預設名稱,然後按一下「確定」。
  4. (選擇性) 按一下「設定為預設值」,每次讀入相同檔案類型的檔案時都會使用此預設。

每次開啟 Word 或 RTF 檔案時,您就可以從「讀入選項」對話框的「預設」選單中選取自訂預設集。

讀入 Buzzword 文件

Buzzword 是一種網路架構的文字編輯器,可讓使用者在網頁伺服器上建立和儲存文字檔案。在 InDesign CS5 中,您可以從 Buzzword 文件讀入和轉存文字。

當您讀入 Buzzword 文件時,會在伺服器上建立 Buzzword 文件之以 URL 為基礎的連結。在 InDesign 外更新 Buzzword 文件時,可以使用「連結」面板更新 InDesign 中讀入的版本。但是,這樣做會移除您在 InDesign 中對 Buzzword 文字所做的任何變更。

註解:

Acrobat.com Buzzword 應用程式只提供英文、法文和德文版本。

  1. 選擇「檔案 > 從 Buzzword 置入」。

  2. 如果您尚未登入 CS Live,請按一下「登入」,指定您的電子郵件地址和密碼,然後再按一下「登入」

    登入之後,「置入 Buzzword 文件」對話框會顯示您可以讀入的 Buzzword 文件清單。

  3. 選取一或多個您想要讀入的文件,或將 Buzzword 文件的 URL 貼入「貼上 URL」欄位中。

  4. 選取下列任一選項,然後按一下「確定」。

    顯示讀入選項

    如果選取此選項,「Buzzword 讀入選項」對話框會在置入檔案之前顯示。

    取代選取的項目

    選取此選項可取代目前文件中選取的物件。

    連結至文件

    選取此選項可在 Buzzword 文件和置入的文字之間建立連結。如果您建立連結並更新 Buzzword 文件,則「連結」面板會指出檔案已修改。如果您更新連結,InDesign 中的文字也會隨之更新。但是,您在 InDesign 中對此文字進行的格式變更會遺失。

  5. 如果您已選取「顯示讀入選項」,請在「Buzzword 讀入選項」對話框中指定設定。

    此對話框包含的選項與「RTF 讀入選項」對話框中找到的大部分選項相同。請參閱 Microsoft Word 和 RTF 讀入選項。Buzzword 目前沒有樣式功能,所以此時所有樣式選項都無效。

  6. 使用載入的文字游標來按一下或拖移,即可建立文字框。

依預設,置入 InDesign 中的文字不會連結到原始文字檔案。但是,如果在置入檔案前選取「檔案處理」偏好設定中的「置入文字和試算表檔案時建立連結」選項,則文字檔案名稱會顯示在「連結」面板中。您可以使用「連結」面板,更新及管理檔案。更新連結的文字檔案時,在 InDesign 中所套用的任何編輯或格式設定變更都會遺失。由於有此風險,因此在編輯原始檔案時,不會自動更新連結的文字檔案。不過,您可以輕鬆地使用「連結」面板來更新內容或解除連結 (嵌入) 檔案。

  1. 執行下列任一項作業:
    • 如果要將此變更套用至文件,請開啟文件。

    • 如果要將此變更套用至您建立的任何新文件,請關閉所有文件。

  2. 選擇「編輯 > 偏好設定 > 檔案處理」(Windows) 或「InDesign > 偏好設定 > 檔案處理」(Mac OS)。
  3. 如果要在置入的檔案中建立連結,請選取「置入文字和試算表檔案時建立連結」。如果這個選項已開啟,請使用「連結」面板更新連結、重新連結或移除連結。如果這個選項已關閉,則會嵌入 (而非連結) 文字檔案。

註解:

若要解除 (嵌入) 所連結文字檔案的連結,請選取「連結」面板中的檔案,然後從「連結」面板選單中選取「解除連結」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策