建立書冊檔案

「書冊檔案」是可共用樣式、色票、主版頁面及其他項目的文件集合。 您可以將書冊的文件頁面按順序編號、列印書冊中的選取文件,或是將文件轉存為 PDF。 單一文件可隸屬於多個書冊檔案。

加入書冊檔案的其中一個文件就是「樣式來源」。 依照預設,樣式來源是書冊中的第一份文件,但您可隨時選取新的樣式來源。 將書冊中文件「同步化」時,樣式來源中所指定的樣式與色票會取代其他書冊文件中的樣式與色票。

Michael Murphy 在書冊基礎概念提供建立書冊的教學課程影片。

  1. 選擇「檔案 > 新增 > 書冊」。
  2. 為該書冊輸入名稱,選擇儲存位置,然後按一下「儲存」。

    「書冊」面板便會出現。 該書冊檔案會以副檔名為 .indb 的檔案名稱儲存。

  3. 將文件新增至書冊檔案。

將文件新增至書冊檔案

建立書冊檔案時,該檔案會在「書冊」面板中開啟。 「書冊」面板是書冊檔案的工作區,您可以在其中新增、移除或重新排列文件。

  1. 在「書冊」面板選單中選擇「新增文件」,或按一下位於「書冊」面板底部的加號按鈕
  2. 選取要新增的一個或多個 Adobe InDesign 文件,然後按一下「開啟」。

    註解:

    您可以從「檔案總管」(Windows) 或 Finder (Mac OS) 視窗,將檔案拖放至「書冊」面板。 也可以從一部書冊中將文件拖移至另一書冊。 按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS) 來拷貝文件。

  3. 如果納入以舊版 InDesign 建立的文件,則該文件在加入書冊時,就會轉換為 Adobe InDesign CS5 格式。在「另存新檔」對話框中,指定轉換後文件的新名稱 (或保留原有名稱),然後按一下「儲存」。

    註解:

    但將 Adobe PageMaker 或 QuarkXPress 文件加入書冊檔案之前,則必須先進行轉換。

  4. 如有必要,請將文件上下拖移至清單中的適當位置,以變更面板中文件的順序。
  5. 如果要將文件指定為樣式來源,請按一下面板中文件名稱旁邊的方框。

如果要開啟書冊檔案中的文件,請在「書冊」面板中按兩下該文件名稱。

管理書冊檔案

在「書冊」面板中,每個開啟的書冊檔案都會出現在各自的索引標籤下。 如果同時開啟多部書冊,按一下索引標籤,即可將該書冊帶到前端,並存取使用其面板選單。

「書冊」面板中的圖示會指出文件的目前狀態,例如開啟 、遺失 (文件已移動、重新命名或刪除)、已修改 (在書冊關閉時,文件已經過編輯或其頁面或章節頁碼已變更),或使用中 (如果已有人在管理工作流程中開啟該文件)。在關閉的文件旁則不會出現圖示。

註解:

如果要檢視書冊中任何文件的路徑名稱,請在文件名稱上方按住滑鼠指標,直到出現工具提示。 或者,在「書冊」面板選單選擇「文件資訊」。

儲存書冊檔案

書冊檔案不同於文件檔案。 例如,選擇「儲存書冊」指令時,InDesign 會將變更儲存於書冊,而非書冊中的文件。

  1. 執行下列任一項作業:
    • 如果要以新名稱儲存書冊,請從「書冊」面板選單中選擇「另存書冊」,指定位置與檔案名稱,然後按一下「儲存」。

    • 如果要以相同名稱儲存現有書冊,請從「書冊」面板選單中選擇「儲存書冊」,或是按一下「書冊」面板底部的「儲存」按鈕

註解:

如果透過伺服器共用書冊檔案,請確認已設置檔案管理系統,儲存檔案時才不會不小心蓋掉其他人所做的變更。

關閉書冊檔案

  • 如果要關閉單一書冊,請在書冊的面板選單中選擇「關閉書冊」。
  • 如果要關閉固定在同一個面板中所有開啟的書冊,請按一下「書冊」面板標題列上的「關閉」按鈕。

移除書冊文件

  1. 在「書冊」面板中選取文件。
  2. 在「書冊」面板選單中選擇「移除文件」。

從書冊中移除文件並不會刪除磁碟中的檔案;只會從書冊檔案中移除該文件。

取代書冊文件

  1. 在「書冊」面板中選取文件。
  2. 從「書冊」面板選單中選擇「取代文件」,找出要用來取代的文件,然後按一下「開啟」。

在檔案總管或 Finder 中開啟書冊檔案

  1. 在書冊面板中選取文件。

  2. 從書冊面板選單,選擇「顯現在檔案總管中」(Windows) 或「顯現在 Finder」中 (Mac OS)。

此時會開啟顯示所選檔案的瀏覽器視窗。

同步化書冊文件

同步化書冊中的文件時,所指定的項目 (樣式、變數、主版頁面、補漏白預設、交互參照格式、條件文字設定、編號清單和色票) 都會從樣式來源拷貝到書冊中指定的文件,取代名稱完全相同的任何項目。

如果進行同步化的文件中找不到樣式來源中的項目,就表示已加入這些項目。 樣式來源中未包含的項目會在進行同步化的文件中原樣保留。

選取要同步化的項目

  1. 從「書冊」面板選單中選擇「同步選項」。
  2. 選取您要從該樣式來源拷貝到其他書冊文件的項目。

    務必要選取其他樣式的定義中所包含的所有樣式。 例如,物件樣式可能包含段落與字元樣式,這些樣式中又會包含色票。

  3. 選取「智慧型比對樣式群組」可避免唯一命名的樣式群組在移入或移出樣式群組時出現重複的現象。

    假設樣式來源包含樣式群組中的字元樣式,而要同步化的文件包含樣式群組以外的這個相同字元樣式。如果選取這個選項,該字元樣式會移入已同步化文件中的樣式群組。

    如果未選取這個選項,則會使用符合樣式來源的選項在樣式群組中建立該字元樣式的第二個例項。在樣式群組外的字元樣式不會改變。

    註解:

    如果文件包含多個同名的樣式 (例如,樣式群組中有「字元樣式群組 1」,樣式群組外也有「樣式群組 1」),InDesign 會當做未選取這個選項。為獲得最佳結果,請以唯一的名稱建立樣式。

  4. 按一下「確定」。

將書冊檔案中的文件同步化

您可以在書冊中的文件關閉時,進行書冊的同步化。 InDesign 會開啟關閉的文件、進行變更,然後儲存並關閉文件。 在進行同步化時為開啟狀態的文件,將變更但不會儲存。

  1. 在「書冊」面板中,按一下要做為樣式來源之文件旁邊的空白方框;樣式來源圖示 會指出做為樣式來源的文件。
    選取的樣式來源
    選取的樣式來源

  2. 確認已在「同步選項」對話框中選取要從樣式來源拷貝的項目。
  3. 從「書冊」面板中,選取要與樣式來源文件進行同步化的文件。 如果未選取任何文件,整部書冊都將同步化。

    註解:

    如果要確認未選取任何文件,請按一下書冊文件下方的灰色空白區域,您可能需要捲動「書冊」面板或調整其大小。 您也可以按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS),然後按一下已選取的文件來取消選取。

  4. 從「書冊」面板選單中選擇「同步化選取的文件」或「同步化書冊」,或是按一下「書冊」面板底部的「同步」按鈕

註解:

選擇「編輯 > 還原」只會還原同步化進行時,對開啟狀態文件所做的變更。

同步主版頁面

主版頁面的同步化處理方式與其他項目相同,若與樣式來源中的主版頁面使用相同的名稱 (例如「A 主版」),則該主版頁面會被取代。 對於使用相同設計元素 (例如動態表頭與表尾) 的文件來說,將主版頁面同步化很有用。但是,如果要在文件中的主版頁面上保留樣式來源以外的頁面項目,就不要將主版頁面同步化,也不要用不同的名稱建立主版頁面。

初次將主版同步化之後,文件頁面上任何被覆寫的主版頁面項目都會與主版分離。因此,如果準備要將書冊中的主版頁面同步化,最好是在開始進行設計程序時,就將書冊中所有文件同步化。 如此一來,被忽略的主版頁面項目將會維持與主版頁面的連線,並將繼續從樣式來源中的已修改主版頁面進行更新。

只使用一個樣式來源進行主版頁面同步化也是很好的做法。 如果從不同的樣式來源進行同步化,被忽略的主版頁面項目可能會與主版頁面分離。 如果必須使用不同的樣式來源進行同步化,請在同步化之前取消選取「同步選項」對話框中的「主版頁面」選項。

轉換舊版 InDesign 書冊檔案

如果要轉換在舊版 InDesign 中建立的書冊檔案,可以在 InDesign CS5 中開啟並儲存該檔案。 在同步化、重新編頁、列印、封裝或轉存已轉換的書冊時,書冊所包含的文件也會轉換為 InDesign CS5 格式。您可以決定要覆寫或保留原始文件檔案。

轉換書冊檔案供 InDesign CS5 使用

  1. InDesign CS5 中,選擇「檔案 > 開啟舊檔」。
  2. 選取在舊版 InDesign 中建立的書冊檔案,然後按一下「確定」。

    如果書冊檔案包含以舊版 InDesign 格式儲存的文件,就會出現警告。

  3. 從「書冊」面板選單中選取「另存書冊」。 為已轉換的書冊檔案指定新名稱,然後按一下「儲存」。

轉換書冊檔案中的文件

  1. InDesign CS5 中開啟書冊檔案。
  2. 在「書冊」面板選單中:
    • 如果要在轉換過程中覆寫原始文件,請選取「自動文件轉換」。

    • 如果要保留原始文件,而用新名稱儲存轉換的文件,請取消選取「自動文件轉換」 (書冊清單會更新以包含轉換的檔案,而不是包含原始檔案)。

  3. 執行下列任一項以轉換文件:
    • 從「書冊」面板選單中選擇「同步化書冊」 (請參閱同步化書冊文件。)

    • 從「書冊」面板選單中選擇「更新編號 > 更新所有編號」。

  4. 如果未選取「自動文件轉換」,InDesign 會提示您以新名稱儲存各個已轉換的文件。

註解:

將書冊列印或轉存為 Adobe PDF 時,也會轉換文件。

編排書冊中的頁碼和章節編號

您可以決定如何將書冊中的頁面、章節和段落編號。 在書冊檔案中,頁面和章節的編號樣式和起始編號是依各文件在「編頁與章節選項」對話框或「文件編號選項」對話框中的設定而定。若要開啟前述對話框,請在文件中選擇「版面 > 編頁與章節選項」,或在「書冊」面板選單中選擇「文件編號選項」。

如需新增頁碼至文件的詳細資訊,請參閱新增基本編排頁碼

對於已編號的段落 (如圖表清單),編號方式由段落樣式所包含的編號清單樣式定義決定。

頁面範圍會出現在「書冊」面板的各文件名稱旁。 依預設,在新增或移除書冊文件中的頁面,或變更書冊檔案 (例如,重新排列、新增或移除文件) 時,InDesign 會在「書冊」面板中更新頁面及章節頁碼。 如果您關閉自動更新頁面及章節頁碼的設定,則可在書冊中手動更新編頁。

如果更新書冊,而且編號似乎不正確時,問題可能是出在「一般」偏好設定中顯示了獨立編號,而不是章節編號。請參閱在頁面面板中顯示獨立或章節編號

如果文件遺失或無法開啟文件,頁面範圍 從遺失文件應在的位置開始一直到書冊結尾都會顯示為 “?”,表示真正的頁面範圍不明。 在重新編頁之前移除或取代遺失的文件。 如果出現「使用中」圖示 ,表示有人已使用不同的電腦在管理工作流程中開啟該文件;這名使用者必須關閉文件,您才能重新進行編頁。

變更各文件的頁面和章節頁碼選項

  1. 在「書冊」面板中選取文件。
  2. 在「書冊」面板選單中選擇「文件編號選項」,或在「書冊」面板中按兩下文件的頁碼。
  3. 指定頁面、區段和章節編號選項 (請參閱文件編號選項。)
  4. 按一下「確定」。

註解:

如果在書冊的文件中指定起始的頁碼,而非選取「自動產生頁碼」,該書冊的文件會從特定書頁開始;所有書冊中的後續文件將跟著重新編頁。

從奇數或偶數頁開始編頁

您可以在書冊的文件中,自奇數或偶數頁開始編排文件的頁碼。

  1. 從「書冊」面板選單中選擇「書冊編排頁碼選項」。
  2. 選擇「從下一個奇數頁繼續」或「從下一個偶數頁繼續」。
  3. 選取「插入空白頁面」,在後續文件必須自奇數或偶數頁開始的任意文件最後面加入空白頁,然後按一下「確定」。

關閉書冊中的自動編頁

  1. 從「書冊」面板選單中選擇「書冊編排頁碼選項」。
  2. 取消選取「自動更新頁面和章節編號」,然後按一下「確定」。
  3. 如果要手動重新編頁,請在「書冊」面板選單中選擇「更新編號 > 更新所有編號」。

    您也可以只更新頁面和區段編號,或只更新章節和段落編號。

在書冊中使用連續段落編號

如果要讓圖表、表格或其他項目的清單使用連續段落編號,必須先定義用於段落樣式中的編號清單。 您所定義的編號清單可決定段落編號是否在書冊中跨文件連續編號。

  1. 開啟用做書冊樣式來源的文件。
  2. 選擇「文字  > 項目符號和編號清單  > 定義清單」。
  3. 按一下「新增」以定義清單,或選取現有清單然後選擇「編輯」。
  4. 同時選取「跨越內文延續編號」和「延續書冊的上一個文件編號」。
  5. 按一下「確定」。
  6. 定義使用編號清單的段落樣式,並套用至包含清單的各文件中文字。(請參閱為動態清單建立段落樣式。)

註解:

如果要確認書冊中所有文件都使用相同的編號清單,請在「同步選項」對話框中選取「段落樣式」和「編號清單」選項,然後進行書冊同步化。

使用書冊檔案的優點之一,就是可使用單一指令 (列印、預檢、封裝或轉存為 EPUB 或 PDF) 輸出所選取書冊的文件或是整部書冊。

  1. 在「書冊」面板中,執行下列任一項作業:
    • 如果要輸出特定文件,請選取所要的文件。

    • 如果要輸出整部書冊,請確認未選取任何文件。

  2. 從「書冊」面板選單中選擇輸出指令 (例如「列印書冊」或「列印選取的文件」)。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策