重複使用圖形與文字的方式

InDesign 提供幾種方法再利用圖形和文字。

程式碼片段

程式碼片段是包含物件的檔案,會描述頁面或跨頁上物件彼此的相對位置(請參閱使用片段)。

物件庫

物件庫會提供方便的位置,供您儲存如標誌、側欄、重要引述和其他重複的項目(請參閱使用物件庫)。

範本

範本是包含預留位置文字與圖形的文件(請參閱使用文件範本)。

使用程式碼片段

程式碼片段是包含物件的檔案,會描述頁面或跨頁上物件彼此的相對位置。 使用程式碼片段能讓您方便重新使用和定位頁面物件。將物件儲存在程式碼片段檔案中 (副檔名為 .IDMS),建立程式碼片段(舊版 InDesign 使用的副檔名為 .INDS)。將程式碼片段檔案置入 InDesign 時,您可以決定置於其原始位置還是您按一下的位置。您可以將程式碼片段儲存在「物件庫」、Adobe Bridge 和硬碟上。

置入時程式碼片段內容會保留其圖層關聯。當程式碼片段包含資源定義,而且貼入的文件中也有這些定義時,程式碼片段會使用文件中的資源定義。

您在 InDesign CS5 中建立的程式碼片段可在 InDesign CS4 中開啟,但在其他舊版 InDesign 中則無法開啟。

建立程式碼片段

  1. 執行下列任一項作業:
    • 使用選取工具選取一或多個物件,然後選擇「檔案 > 轉存」。 從「存檔類型」中 (Windows),或「格式」(Mac OS) 選單中,選擇「InDesign 程式碼片段」。 輸入檔案名稱,然後按一下「儲存」。

    • 使用選取工具選取一或多個物件,然後將選取的項目拖移到桌面上,就會建立程式碼片段檔案。將檔案重新命名。

    • 選取一或多個物件,然後將選取的項目拖移至「Mini Bridge」面板。就會建立程式碼片段檔案。將檔案重新命名。

    • 從「結構檢視」中將項目拖移至您的桌面。

將程式碼片段新增至文件

  1. 選擇「檔案 > 置入」。
  2. 選取一或多個程式碼片段 (*IDMS 或 *.INDS) 檔案。
  3. 在您希望程式碼片段檔案左上角出現的位置,按一下載入的程式碼片段游標。

    如果您已將插入點置於文字框架中,程式碼片段就會置於文字中,成為錨定物件。

    置入程式碼片段之後,所有物件都會維持選取狀態。透過拖移,您可以調整所有物件的位置。

  4. 如果載入多個程式碼片段,請捲動並按一下載入的程式碼片段游標,置入其他程式碼片段。

註解:

您可以從桌面將程式碼片段檔案拖移至 InDesign 文件中,然後在您希望程式碼片段檔案左上角出現的位置上按一下。

選擇置入程式碼片段的方式

除了依照頁面點選位置來置入程式碼片段物件,您還可以將它們置於其原始位置。例如,屬於程式碼片段時,出現在頁面中間的文字框,會在置入為程式碼片段時出現在相同位置。

  1. 在「檔案處理」偏好設定中,從「置於」選單中選擇「原始位置」,可在程式碼片段中保留物件的原始位置。從「置於」選單中選擇「游標位置」,則會依照頁面點按位置來置入程式碼片段。

註解:

您可以按下 Alt 鍵 (Windows) 或 Option 鍵 (Mac),覆寫您為處理程式碼片段選取的「位置」設定。例如,選取「置於游標位置」但是又想要將程式碼片段物件置於其原始位置,請按住 Alt/Option 鍵並在頁面上按一下載入的程式碼片段游標。

使用物件庫

物件庫可幫助您組織圖形、文字和最常使用的頁面。您也可以將尺標參考線、格點、繪製的形狀以及群組化的影像加入資料庫。您可依需要建立任意數目的資料庫,例如針對不同專案或客戶建立不同的物件庫。

在工作階段期間,您可以在系統記憶體允許的狀態下開啟任意數目的資料庫。物件庫可共用於伺服器和平台間,但一次只有一個人能夠開啟物件庫。如果物件庫包含文字檔案,請確認檔案的字體可為所有將存取物件庫的系統使用和啟動。

在將頁面元素 (例如圖形) 加入物件庫時,InDesign 會保留所有讀入或套用的屬性。例如,如果取自 InDesign 文件的圖形加入物件庫,物件庫拷貝將會複製原始圖形,包括其連結資訊,如此您便可在磁碟中的檔案變更時更新圖形。

如果從 InDesign 文件中刪除物件,該物件的縮圖仍將出現在「程式庫」面板中,而所有連結資訊將維持不變。 如果移動或刪除原始物件,當下一次將該物件從「程式庫」面板置入文件時,「連結」面板中的物件名稱旁邊會出現遺失的連結圖示。

在各物件庫中,您可利用標題、加入物件庫的日期或是關鍵字,辨識和搜尋項目。您也可以透過排序物件庫項目和顯示其子集,簡化物件庫之檢視。例如,您可以隱藏所有項目,只留下 EPS 檔案。

「程式庫」面板中的物件庫
「程式庫」面板中的物件庫

A. 物件縮圖和名稱 B. 程式庫項目資訊按鈕 C. 顯示程式庫子集按鈕 D. 新增程式庫項目按鈕 E. 刪除程式庫項目按鈕 

在新增項目至物件庫時,InDesign 會以下列方式儲存所有頁面、文字和影像屬性,並維持物件庫物件與其他頁面元素之間的相互關係:

  • InDesign 文件中,在拖移至「程式庫」面板時加以群組的元素,在拖移離開「程式庫」面板時,仍會維持已群組狀態。

  • 文字會保留其格式。

  • 段落、字元與物件樣式,在使用於目的地文件時具有相同名稱的樣式,會轉換至目的地文件的樣式;那些具有不同名稱的樣式,則將加入文件中。

  • 若選取「圖層」面板選單中的「貼上時記住圖層位置」,便會保留物件的原始圖層。

建立物件庫

物件庫會以具名檔案的形式存在磁碟中。在建立物件庫時,指定其儲存位置。開啟物件庫時,它會以面板的形式出現,您可將之與其他面板組成群組;物件庫的檔案名稱會出現在其面板索引標籤中。 關閉物件庫會將其自現有工作階段中移除,但是不會刪除其檔案。

您可在物件庫新增或移除物件,或是選取頁面元素或整頁元素。您也可以在物件庫間新增或移動物件庫物件。

  1. 選擇「檔案 > 新增 > 程式庫」。
  2. 在「CC 資料庫」對話框中,您可以選擇繼續使用 InDesign 的物件庫,您也可以使用 CC 資料庫來組織、瀏覽和存取您所有的創意資產。如需詳細資訊,請參閱 Creative Cloud Libraries - 共同作業、同步和共用資產

  3. 指定物件庫的位置和名稱,並按一下「儲存」。請記住,您所指定的名稱會成為物件庫之面板索引標籤的名稱。

開啟現有的物件庫

  1. 執行下列任一項作業:
    • 如果您已在目前工作階段中開啟物件庫 (並且尚未關閉),請在「視窗」選單中選擇物件庫檔案。

    • 如果尚未開啟物件庫,請選擇「檔案 > 開啟舊檔」,並選取一或多個物件庫。 在 Windows 中,物件庫檔案使用 INDL 副檔名。InDesign 會將舊版程式的新開啟物件庫轉換為新物件庫格式;系統會詢問您是否要以新名稱儲存這些物件庫。

關閉物件庫

  1. 按一下想要關閉之物件庫的標籤。
  2. 執行下列任一項作業:
    • 在「物件庫」面板選單中選擇「關閉程式庫」。

    • 選擇「視窗」選單上的程式庫檔案名稱。

刪除程式庫

  1. 在「檔案總管」(Windows) 或 Finder (Mac OS) 中,將程式庫檔案拖移至「資源回收筒」(Windows) 或「垃圾筒」(Mac OS)。在 Windows 中,物件庫檔案使用 INDL 副檔名。

將物件或頁面新增至物件庫

  1. 執行下列任一項作業:
    • 將一或多個物件,從文件視窗中拖移至使用中的「物件庫」面板。

    • 從文件視窗中選取一或多個物件,然後按一下「物件庫」面板中的「新增程式庫項目」按鈕。

    • 從文件視窗中選取一或多個物件,然後選擇「物件庫」面板選單中的「新增項目」。

    • 選擇「物件庫」面板選單中的「將頁面 [數字] 上的項目視為獨立物件新增」,藉此將所有物件新增為個別物件庫的物件。

    • 選擇「物件庫」面板選單中的「新增頁面 [數字] 上的項目」,藉此將所有物件新增為單一物件庫物件。

    • 將元素從「結構」窗格拖移至使用中的「物件庫」面板。

註解:

如果在執行任何上述指令時按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS) 鍵,在物件庫加入項目時會出現「項目資訊」對話框。

將物件庫中的物件新增至文件中

  1. 執行下列任一項作業:
    • 將物件從「物件庫」面板拖移至文件視窗。

    • 在「物件庫」面板中選取物件,然後在「物件庫」面板選單中選擇「置入項目」。 這個方法會將物件置於其原始 X,Y 座標。

    • 將 XML 元素拖移至「結構」窗格中的父元素或頁面。

管理物件庫物件

使用「物件庫」面板來管理物件。

以新項目更新物件庫物件

  1. 在文件視窗中,選取您想要加入「程式庫」面板的項目。
  2. 在「程式庫」面板中,選取您想要取代的物件,然後在「物件庫」面板選單中選擇「更新程式庫項目」。

在程式庫間拷貝或移動物件

  1. 將一程式庫的面板索引標籤,拖移離開「物件庫」面板群組並予以分離,如此可於同時檢視兩個程式庫。
  2. 執行下列任一項作業:
    • 如果要在程式庫間拷貝物件,請將項目在「程式庫」面板索引標籤間拖移。

    • 如果要在程式庫間移動物件,請按住 Alt 鍵 (Windows) 或是 Option 鍵 (Mac OS),然後將項目在「程式庫」面板索引標籤之間拖移。

從物件庫刪除物件

  1. 在「物件庫」面板中選取物件,並執行下列任一項作業:
    • 按一下「刪除程式庫項目」。

    • 將項目拖移至「刪除程式庫項目」按鈕。

    • 從「物件庫」面板選單中選擇「刪除項目」。

變更物件庫顯示

物件庫可以將物件顯示為縮圖或文字清單。您可利用物件名稱、建立時間或類型,排序縮圖或文字清單。如果已經為物件分類,清單檢視和排序選項將有最佳效果。

  1. 執行下列任一項作業:
    • 如果要以縮圖方式檢視物件,請從「物件庫」面板選單中選擇「縮圖檢視」或「大型縮圖檢視」。

    • 如果要以文字清單方式檢視物件,請從「物件庫」面板選單中選取「清單檢視」。

    • 如果要排序物件,請從「物件庫」面板選單中選取「排序項目」,然後選取排序方式。

檢視所有物件

  1. 在「物件庫」面板選單中選取「全部顯示」。

檢視、新增或編輯程式庫資訊

如果有大型或數目眾多的物件庫,物件庫資訊可使用顯示物件的名稱、物件類型或是描述字進行分類。

  1. 在「物件庫」面板中,執行下列任一項作業:
    • 按兩下任何物件。

    • 選取物件,然後按一下「程式庫項目資訊」按鈕。

    • 選取物件,然後在「物件庫」面板選單中選擇「項目資訊」。

  2. 依需要檢視或變更「項目名稱」、「物件類型」或「描述」選項,然後按一下「確定」。

尋找物件庫中的物件

在搜尋物件時,只有搜尋結果所找到的物件會出現在檢視中。您也可使用搜尋功能,顯示和隱藏特定類別的物件。例如,您可以只顯示在名稱中具有「star」一字的物件項目。

  1. 在「物件庫」面板選單中選擇「顯示子集」,或是按一下「顯示程式庫子集」按鈕。
  2. 執行下列任一項作業:
    • 如果要搜尋物件庫中的所有物件,請選取「搜尋整個程式庫」。

    • 如果只要在目前物件庫所列出的物件中進行搜尋 (提升前次搜尋的精確度),請選取「搜尋目前顯示的項目」。

  3. 從「參數」區段的第一個選單中選擇類別。
  4. 在第二個選單中,指定在第一個選單中所選取的類別必須包含或排除於搜尋之外。
  5. 在第二個選單的右邊,輸入您想在指定類別內搜尋的單字或片語。
  6. 如果要新增搜尋條件,按五下「更多選項」;每按一下會新增一個搜尋詞。如果要移除搜尋條件,依需要按一下「較少選項」;每按一下會移除一個搜尋詞。
  7. 如果只要顯示符合所有搜尋條件的物件,請選取「全部相符」。如果要顯示符合任何搜尋條件的物件,請選取「符合任一個」。
  8. 按一下「確定」可開始進行搜尋。

註解:

如果要再次顯示所有物件,請在「物件庫」面板選單中選擇「全部顯示」。

將物件庫資產移轉至 CC 資料庫

Creative Cloud 資料庫可協助您組織、瀏覽及存取創意資產。在 InDesign 中,您可以使用 CC 資料庫來取代物件庫。

註解:

InDesign 仍繼續支援物件庫。

InDesign 允許您將物件庫資產移轉至 CC 資料庫。

  1. 在「物件庫」面板中,按一下「移轉」按鈕,從目前程式庫移轉所有資產。

    或者,您也可以在程式庫中複選資產,按一下滑鼠右鍵並選擇選項來移轉選取的資產。

  2. 在「移轉資產」對話框中,選擇選項,將資產移轉至新的或現有的 Creative Cloud 資料庫。

如需 CC Libraries 的詳細資訊,請參閱 Creative Cloud Libraries - 共同作業、同步和共用資產

Creative Cloud Libraries - 共同作業、同步和共用資產
Creative Cloud Libraries - 共同作業、同步和共用資產
Creative Cloud Libraries - 共同作業、同步和共用資產

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策