Codage des couleurs et couleur HDR (High Dynamic Range)

Le codage des couleurs (ou nombre de bits par pixel) est le nombre de bits par couche (bpc ou b/c) utilisés pour représenter la couleur d’un pixel. Plus le nombre de bits d’une couche RVB (rouge, vert et bleu) est élevé, plus le nombre de couleurs pouvant être représentées par chaque pixel est important.

Dans After Effects, vous pouvez utiliser les modes de couleur 8 bpc, 16 bpc ou 32 bpc.

Outre le codage des bits couleur, une caractéristique distincte des nombres utilisés pour représenter les valeurs des pixels est leur représentation sous la forme d’entiers ou de nombres à virgule flottante. Les nombres à virgule flottante peuvent représenter une série bien plus longue de nombres avec le même nombre de bits. Dans After Effects, les valeurs de pixels 32 bpc sont des valeurs numériques à virgule flottante.

Les pixels 8 bpc peuvent avoir une valeur pour chaque couche de couleur, de 0 (noir) à 255 (couleur pure, saturée). Les pixels 16 bpc peuvent avoir une valeur pour chaque couche de couleur, de 0 (noir) à 32 768 (couleur pure, saturée). Si les trois couches de couleur sont définies sur la valeur maximale (couleur pure), on obtient du blanc. Les pixels 32 bpc peuvent avoir des valeurs inférieures à 0,0 et supérieures à 1,0 (couleur pure, saturée) ; ainsi le mode 32 bpc d’After Effects est également un mode HDR (High Dynamic Range). Les valeurs HDR peuvent être bien plus lumineuses que le blanc.

Définition du codage des couleurs et modification des paramètres d’affichage des couleurs

Le paramètre du codage des couleurs d’un projet détermine le nombre de bits par pixel des valeurs de couleur dans l’ensemble d’un projet.

Pour définir le codage des couleurs d’un projet, effectuez l’une des opérations suivantes :

  • Maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée et cliquez sur le bouton Paramètres du projet dans le panneau Projet.

  • Sélectionnez Fichier > Paramètres du projet ou cliquez sur le bouton Paramètres du projet dans le panneau Projet et choisissez un codage de couleurs dans le menu correspondant.

Vous pouvez définir un codage des couleurs pour chaque élément de rendu. Celui-ci prévaut sur le codage des couleurs du projet lors du rendu final. Vous pouvez également spécifier le codage des couleurs à utiliser pour chaque élément de rendu dans les paramètres de module de sortie (voir Paramètres de rendu et Modules de sortie et paramètres des modules de sortie).

Remarque :

Pour modifier le format d’affichage des valeurs chromatiques dans le panneau Info et dans certains contrôles d’effets, choisissez une option, par exemple Pourcent ou Web dans le menu du panneau Info. L’option Affichage couleur permet de basculer automatiquement entre les modes d’affichage des valeurs 8 bpc, 16 bpc et 32 bpc, selon le codage des couleurs du projet.

Même si de nombreux effets peuvent utiliser tous les codages de couleurs, certains effets ne fonctionnent qu’avec des codages inférieurs. Vous pouvez paramétrer le panneau Effets et paramètres prédéfinis pour n’afficher que les effets qui fonctionnent avec le codage des couleurs du projet en cours (voir Panneau Effets et paramètres prédéfinis).

Avantages comparatifs de chaque codage des couleurs

La gamme dynamique (rapport entre les zones foncées et les zones claires) du monde physique est bien supérieure à l’étendue de la vision humaine et à la gamme des images imprimées sur papier ou affichées sur un moniteur. Les valeurs chromatiques 8 bpc et 16 bpc de plage dynamique réduite peuvent uniquement représenter des niveaux RVB du noir au blanc, ce qui constitue une infime partie de la plage dynamique dans le monde réel.

Les valeurs chromatiques HDR 32 bpc à virgule flottante peuvent représenter des niveaux de luminosité nettement supérieurs au blanc, notamment des objets aussi lumineux qu’une flamme ou que le soleil.

Effets Lueur diffuse et Flou gaussien appliqués à une image en mode 32 bpc et 16 bpc
Effets Lueur diffuse et Flou gaussien appliqués à une image en mode 32 bpc (à gauche) et 16 bpc (à droite)

Définissez le codage des couleurs du projet sur 32 bpc pour utiliser des métrages HDR ou pour travailler avec des valeurs dépassant la plage habituelle, c’est-à-dire supérieures à 1,0 (blanc). Ces dernières ne sont pas prises en charge par les modes 8 bpc ou 16 bpc. Les valeurs supérieures à la plage habituelle préservent l’intensité des tons clairs, ce qui est utile pour les effets synthétiques, tels que les lumières, les flous et les lueurs, comme c’est le cas avec le métrage HDR. La marge disponible avec les valeurs 32 bpc permet d’éviter les pertes de données pendant certaines opérations telles que la correction colorimétrique et la conversion des profils colorimétriques.

Même si vous utilisez le métrage 8 bpc et que vous créez des films au format 8 bpc, vous pouvez obtenir de meilleurs résultats en paramétrant le codage des couleurs du projet sur 16 bpc ou 32 bpc. Le recours à un nombre de bits par pixel plus élevé permet d’obtenir une meilleure précision des calculs et de réduire de manière considérable les défauts de quantification (effets de bande au niveau des dégradés, par exemple).

Remarque :

si le nombre de bits par pixel du format de sortie est faible, la simple augmentation du codage des couleurs dans un projet ne suffit pas à éliminer les dégradés. Afin de réduire les effets de bande, After Effects applique l’interpolation des couleurs lorsque celles-ci sont converties en couleurs 8 bits par couche, notamment lors du rendu et de l’exportation vers un format 8 bits par couche. Cette interpolation n’apparaît pas dans les prévisualisations. Afin de forcer l’interpolation dans les prévisualisations, appliquez sur un calque de réglage un effet 8 bits par couche inactif (un effet Opérations avec les valeurs par défaut, par exemple).

Etant donné que les images 16 bpc sollicitent une capacité de mémoire deux fois inférieure aux images 32 bpc, le rendu des prévisualisations dans un projet 16 bpc est plus rapide et les prévisualisations elles-mêmes peuvent être plus longues que dans un projet 32 bpc. Les images 8 bpc sollicitent une capacité de mémoire encore inférieure, mais le compromis entre qualité et performance peut devenir flagrant avec un codage des couleurs de 8 bpc.

Remarques relatives à l’utilisation des couleurs HDR (High Dynamic Range)

Vous pouvez utiliser l’effet Compresseur-extenseur HDR pour compresser la gamme dynamique d’un calque avec un élément de métrage HDR comme source. Cela vous permet d’utiliser des outils ne prenant pas en charge le format de couleur HDR, tels que les effets 8 bpc et 16 bpc. Une fois cela fait, utilisez le Compresseur-extenseur HDR pour annuler la compression de la gamme dynamique. L’effet Compression des tons clairs HDR vous permet de compresser les valeurs de tons clairs d’une image HDR de sorte que celles-ci entrent dans la gamme de valeurs d’une image à gamme dynamique réduite.

Comme nous ne voyons qu’un sous-ensemble des valeurs de luminance d’une scène réelle sur une image HDR reproduite sur un moniteur, il est parfois nécessaire de régler l’exposition (quantité de lumière capturée dans une image) quand on travaille sur une image HDR. Le réglage de l’exposition d’une image HDR est semblable au réglage de l’exposition lors de la prise de vue d’une scène réelle ; il permet de faire ressortir les détails des zones sombres ou claires. Vous pouvez utiliser l’effet Exposition pour modifier les valeurs chromatiques d’un calque en vue de la sortie finale, ou vous pouvez ajuster l’exposition dans un visualiseur spécifique à des fins de prévisualisation.

Remarque :

comme certaines opérations (notamment les lueurs, les flous et certains modes de fusion) se comportent différemment en mode 32 bpc qu’en mode 8 bpc ou 16 bpc, votre composition peut présenter un aspect très différent lorsque vous passez d’une plage dynamique élevée à une plage dynamique réduite dans les paramètres d’un projet.

Ressources supplémentaires sur la couleur HDR

Chris Meyer explique le champ d’application d’une couleur HDR 32 bpc à virgule flottante dans une présentation vidéo disponible sur le site Web Lynda.com.

Sur son site Web Video Copilot, Andrew Kramer propose un didacticiel vidéo dans lequel il présente les avantages de l’utilisation de couleurs 32 bits par couche avec le flou de mouvement.

Sur son site Web fnord, Brendan Bolles explique comment utiliser l’effet Convertisseur profil couleurs et les profils colorimétriques de film pour régler des couleurs et effectuer un « tone mapping » afin de faire apparaître une image HDR comme si elle avait été prise sur pellicule cinématographique.

Sélection d’une couleur ou modification d’un dégradé

Dans de nombreux contextes, vous pouvez cliquer sur l’icône Pipette pour activer l’outil correspondant ou cliquer sur une nuance de couleur pour accéder à un sélecteur de couleurs. Si vous utilisez le sélecteur de couleurs Adobe, vous pouvez également activer l’outil Pipette dans la boîte de dialogue correspondante.

Si vous cliquez sur une nuance de dégradé (Dégradé linéaire ou Fond en dégradé) pour le contour ou le fond d’un calque de forme, le Sélecteur de couleurs Adobe s’ouvre sous la forme de l’Éditeur de dégradés ; en haut de cette boîte de dialogue, vous trouverez des commandes supplémentaires pour modifier les dégradés. Vous pouvez également cliquer sur le bouton Modifier le dégradé dans le panneau Montage pour ouvrir l’Éditeur de dégradés.

Dans une vidéo sur le site Web Creative COW, Andrew Devis explique comment modifier les fonds et contours dégradés des calques de forme, ainsi que quelques autres options.

Remarque :

la méthode d’expression sampleImage est une autre manière d’échantillonner les valeurs de couleur. Utilisez cette méthode pour entrer les valeurs colorimétriques de certains pixels dans une expression. Reportez-vous à la section Méthodes et attributs généraux du calque (référence de l’expression).

Écran Éditeur de dégradés
A. Etape d’opacité B. Etape de couleur C. Milieu de l’opacité D. Pipette E. Nouveau rectangle de couleur F. Rectangle de couleur d’origine 

Choix d’un sélecteur de couleurs

  • Pour choisir la couleur système, cliquez sur Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS) et cochez la case Utiliser le sélecteur de couleurs système.
  • Pour utiliser le Sélecteur de couleurs Adobe, désélectionnez la case Utiliser le sélecteur de couleurs système et sélectionnez Fenêtre > Extensions > Thèmes Adobe Color.

Remarque :

Sur son site Web redefinery, Jeff Almasol vous propose son script PickerSwitcher pour activer et désactiver le paramètre Utiliser le sélecteur de couleurs système. Vous l’apprécierez pour passer rapidement du sélecteur de couleurs Adobe au sélecteur de couleurs de votre système d’exploitation, et inversement, selon vos préférences de travail pour certaines tâches.

Sélection d’une couleur à l’aide de la pipette

  1. Cliquez sur le bouton Pipette et déplacez le pointeur vers le pixel que vous souhaitez prélever. L’échantillon de couleur en regard du bouton Pipette est remplacé de manière dynamique par la couleur se trouvant sous la Pipette.
  2. Effectuez l’une des opérations suivantes :
    • Pour sélectionner la couleur d’un seul pixel, cliquez sur ce pixel.

    • Pour échantillonner la moyenne de couleur d’une zone de 5 x 5 pixels, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquez sur cette zone.

    Remarque :

    lors d’un échantillonnage dans l’image de composition du panneau Composition, la pipette ignore par défaut la couleur d’arrière-plan de la composition et n’échantillonne que les couches de couleurs directes. Pour échantillonner des couches de couleurs prémultipliées avec la couleur d’arrière-plan d’une composition, maintenez enfoncée la touche Maj tout en cliquant avec la pipette. L’opération Maj-clic avec la pipette échantillonne les couleurs comme elles apparaissent dans l’image de la composition dans le panneau Composition.

Remarque :

Appuyez sur la touche Echap pour désactiver la pipette.

Sélection d’une couleur avec le sélecteur de couleurs Adobe

Dans la fenêtre Sélecteur de couleurs Adobe, vous pouvez choisir une couleur à partir de l’un des modèles colorimétriques ou en utilisant le curseur et le champ de couleur.

Les modèles colorimétriques suivants sont proposés :

  • TSL
  • RVB
  • Lab
  • CMJN
  • Hex

Utilisez le curseur pour choisir une couleur :

  • Faites glisser les triangles le long de la bande chromatique ou cliquez à l’intérieur de la bande pour ajuster les couleurs affichées dans le spectre de couleurs.
  • Cliquez ou faites glisser le curseur à l’intérieur du grand carré de spectre de couleurs pour sélectionner une couleur. Un repère circulaire indique l’emplacement de la couleur dans le spectre de couleurs.
  1. Cliquez sur Fenêtre > Extensions > Thèmes Adobe Color pour afficher le Sélecteur de couleurs Adobe.

  2. Pour éviter que les panneaux ne soient mis à jour avec les résultats de la sélection de couleurs avant que vous ne cliquiez sur OK pour valider la couleur, désélectionnez l’option Prévisualisation dans la boîte de dialogue Sélecteur de couleurs (facultatif). L’option Prévisualisation n’est pas disponible dans tous les contextes.

    Remarque :

    l’option Prévisualisation est pratique pour vérifier les résultats des couleurs sélectionnées avant de les valider, mais cela risque de réduire les performances, car les nouvelles images sont rendues pour l’aperçu dans le panneau Composition ou Calque.

  3. Entrez les valeurs des composantes dans les zones de texte. Sélectionnez la composante à utiliser pour afficher le spectre de couleurs :

    TSL

    Pour TSL, spécifiez une teinte (T) sous la forme d’un angle, de 0 ° à 360 °, correspondant à un emplacement sur la roue chromatique. Définissez la saturation (S) et la luminosité (L) sous forme de pourcentages (de 0 à 100).

    H

    Affiche toutes les teintes dans la bande chromatique. La sélection d’une teinte dans cette bande affiche la plage de saturation et de luminosité de la teinte sélectionnée dans le spectre de couleurs, la saturation augmentant de gauche à droite et la luminosité de bas en haut.

    S

    Affiche toutes les teintes dans le spectre de couleurs avec leur luminosité maximale en haut et leur luminosité minimale en bas. La bande chromatique affiche la couleur sélectionnée dans le spectre de couleurs avec sa saturation maximale en haut et sa saturation minimale en bas.

    B

    Affiche toutes les teintes dans le spectre de couleurs avec leur saturation maximale en haut et leur saturation minimale en bas. La bande chromatique affiche la couleur sélectionnée dans le spectre de couleurs avec sa luminosité maximale en haut et sa luminosité minimale en bas.

    RVB

    Pour RVB, définissez les valeurs des composants. Dans un projet HDR, vous pouvez définir les couleurs sur des valeurs inférieures ou supérieures à la plage habituelle comprise entre 0,0 et 1,0.

    R

    Affiche la composante de couleur rouge dans la bande chromatique, avec sa luminosité maximale en haut et sa luminosité minimale en bas. Lorsque la bande chromatique est réglée sur la luminosité minimale, le spectre de couleurs affiche les couleurs produites par les composantes de couleur verte et bleue. L’utilisation de la bande chromatique pour augmenter la luminosité du rouge a pour effet de mélanger davantage de rouge aux couleurs affichées dans le spectre de couleurs.

    G

    Affiche la composante de couleur verte dans la bande chromatique, avec sa luminosité maximale en haut et sa luminosité minimale en bas. Lorsque la bande chromatique est réglée sur la luminosité minimale, le spectre de couleurs affiche les couleurs produites par les composantes de couleur rouge et bleue. L’utilisation de la bande chromatique pour augmenter la luminosité du vert a pour effet de mélanger davantage de vert aux couleurs affichées dans le spectre de couleurs.

    B

    Affiche la composante de couleur bleue dans la bande chromatique, avec sa luminosité maximale en haut et sa luminosité minimale en bas. Lorsque la bande chromatique est réglée sur la luminosité minimale, le spectre de couleurs affiche les couleurs produites par les composantes de couleur verte et rouge. L’utilisation de la bande chromatique pour augmenter la luminosité du bleu a pour effet de mélanger davantage de bleu aux couleurs affichées dans le spectre de couleurs.

    CMJN

    Spécifiez la valeur de chaque composante sous la forme d’un pourcentage de cyan, magenta, jaune et noir dans la zone de texte pour obtenir une couleur spécifique.

    Lab

    L

    Indique la luminance d’une couleur (de 0 à 100)

    a

    Quantité de rouge ou de vert dans une couleur (entre -128 et +127)

    b

    Quantité de bleu ou de jaune dans une couleur (entre -128 et +127)

    Hex

    Entrez les valeurs au format hexadécimal. Les nombres peuvent aller de #000000 à #ffffff. Par exemple, #000000 représente le noir et #ffffff, le blanc.

Modification d’un dégradé

Un dégradé est défini par des étapes chromatiques et des étapes d’opacité. Chaque étape a un emplacement sur le dégradé et une valeur chromatique ou d’opacité. Les valeurs entre les étapes sont interpolées. Par défaut, l’interpolation est linéaire, mais vous pouvez déplacer le milieu chromatique ou d’opacité entre deux étapes pour modifier l’interpolation.

  • Pour ajouter une étape chromatique ou d’opacité, cliquez au-dessus ou en dessous de la barre de dégradé dans la boîte de dialogue Éditeur de dégradés.
  • Pour supprimer une étape, éloignez-la de la barre de dégradé ou sélectionnez-la et cliquez sur Supprimer.
  • Pour modifier la valeur d’une étape, sélectionnez-la et définissez la valeur Opacité ou utilisez les options du sélecteur de couleurs Adobe situées sous les options de l’éditeur de dégradés.
  • Pour choisir un type de dégradé, cliquez sur le bouton Dégradé linéaire ou Dégradé radial dans l’angle supérieur gauche de la boîte de dialogue Éditeur de dégradés.

Remarque :

utilisez la propriété Style pour choisir le type de dégradé du style de calque Incrustation en dégradé.

Didacticiel de formation

Vous pouvez créer et enregistrer des thèmes de couleurs, explorer et rechercher des thèmes existants ou encore parcourir les thèmes de couleurs enregistrés depuis votre profil Adobe Creative Cloud. Suivez ce didacticiel pour apprendre à utiliser Adobe Color dans After Effects.

Correction colorimétrique, étalonnage colorimétrique et réglage des couleurs

Lorsque vous assemblez une composition, vous êtes souvent amené à régler ou à corriger les couleurs d’un ou plusieurs calques. De tels ajustements peuvent être justifiés par plusieurs raisons. Exemples :

  • Vous souhaitez donner à plusieurs métrages les mêmes conditions de prise de vue afin de les composer ou les modifier ensemble.

  • Vous devez régler les couleurs pour simuler une prise de vue nocturne à partir d’une prise de vue diurne.

  • Vous devez régler l’exposition d’une image pour récupérer les détails des tons clairs surexposés.

  • Vous devez accentuer une couleur dans une prise de vue, car vous souhaitez effectuer un montage avec un élément graphique dans cette couleur.

  • Vous devez limiter les couleurs à une gamme donnée, comme la plage de diffusion.

Les termes correction colorimétrique et étalonnage colorimétrique sont souvent utilisés de manière interchangeable ; le terme étalonnage colorimétrique, toutefois, désigne parfois distinctement les réglages de couleurs apportés à des fins créatives plutôt que pour corriger des problèmes au niveau des couleurs. Dans After Effects, le terme correction colorimétrique est utilisé dans un sens général.

After Effects propose de nombreux effets intégrés pour corriger les couleurs, y compris l’effet Courbes, l’effet Niveaux et d’autres effets dans la catégorie d’effets Correction colorimétrique. Vous pouvez également utiliser l’effet Appliquer la table de correspondance des couleurs afin d’appliquer, à des fins de correction colorimétrique, le mappage des couleurs à une table de correspondance des couleurs (voir Effets Correction colorimétrique et Effet Appliquer la table de correspondance des couleurs).

Le module externe Camera Raw peut être utilisé pour corriger et régler les images fixes aux formats JPEG, TIFF et aux divers formats bruts Camera Raw.

Le module externe Synthetic Aperture Color Finesse fourni avec After Effects comprend d’excellents outils de correction colorimétrique. Le module Color Finesse 3 de Synthetic Aperture est inclus dans After Effects CC et CS6. Reportez-vous à la section Ressources relatives à Synthetic Aperture Color Finesse.

Ressources supplémentaires pour la correction et le réglage des couleurs

Cet article de blog d’Adobe rassemble plusieurs didacticiels vidéo et d’autres ressources relatifs à la correction et à l’étalonnage des couleurs dans After Effects et Premiere Pro.

Sur son site Web Motionworks, John Dickinson propose des médias visuels illustrant l’utilisation des effets Courbes et Niveaux pour le réglage des couleurs :

Cette vidéo de la série After Effects: Learn By Video explique comment combiner le suivi de mouvement et la rotoscopie pour isoler et corriger de manière sélective les couleurs du visage d’un acteur.

L’animation prédéfinie Rebel CC est un outil de correction des couleurs simple de style télécinéma destiné à la colorisation ou à l’étalonnage d’un film. Cette animation prédéfinie utilise des expressions pour contrôler l’effet Niveaux (options individuelles). Pour en savoir plus et télécharger l’animation prédéfinie, rendez-vous sur le blog ProLost de Stu Maschwitz.

Sur son blog ProLost, Stu Maschwitz a posté un article qui traite de la correction de la coloration de la peau. Cet article s’accompagne de liens vers des ressources sur les configurations de test qui affichent différentes colorations de peau sur un vectorscope.

Mark Christiansen propose des conseils et des techniques détaillées sur la correction, le réglage et la correspondance des couleurs dans le chapitre « Color Correction in Adobe After Effects » (Correction des couleurs dans Adobe After Effects) de son livre After Effects Studio Techniques, disponible sur le site web Presse de Peachpit.

Utilisation d’histogrammes pour régler les couleurs

Un histogramme est une représentation du nombre de pixels à chaque valeur de luminance dans une image. Un histogramme qui présente des valeurs différentes de zéro pour chaque valeur de luminance indique une image qui tire parti de la gamme de tons complète. Un histogramme qui n’utilise pas la gamme de tons complète correspond à une image terne qui manque de contraste.

Dans le cadre de la correction des couleurs, une tâche courante consiste à régler l’image afin de répartir les valeurs de pixels de manière plus uniforme de la gauche vers la droite de l’histogramme, au lieu de les « entasser » toutes à l’une des extrémités. Appliquer un effet Niveaux et régler ses propriétés Blanc en entrée et Noir en entrée dans l’histogramme constitue une manière simple et efficace d’accomplir cette tâche pour de nombreuses images.

Histogramme d’une image qui n’utilise pas la gamme de tons complète
Histogramme d’une image qui n’utilise pas la gamme de tons complète

Curseurs d’entrée déplacés de sorte que le résultat utilise la gamme de tons complète
Curseurs d’entrée déplacés de sorte que le résultat utilise la gamme de tons complète

Histogramme montrant un écrêtage des tons clairs
Histogramme montrant un écrêtage des tons clairs

Histogramme montrant un écrêtage des tons foncés
Histogramme montrant un écrêtage des tons foncés

Panneau Modes Lumetri

Le panneau Modes Lumetri met à votre disposition des modes vidéo intégrés pour afficher les propriétés de couleur de votre vidéo. Les modes vidéos sont les suivants :

  • Vectorscopes
  • Histogrammes
  • Parade
  • Signal
Modes vidéo dans le panneau Modes Lumetri
Modes vidéo dans le panneau Modes Lumetri

Chaque image vidéo est composée de pixels et chaque pixel est associé à des propriétés de couleur, lesquelles peuvent être classées dans les catégories chrominance, luminance et saturation. Vous pouvez évaluer les propriétés de couleur afin d’effectuer une correction colorimétrique de votre vidéo et de garantir l’homogénéité entre les plans.

Prise en charge des modes Lumetri pour le workflow de télédiffusion

Le panneau Modes Lumetri est conçu pour le workflow des couleurs TV. Le panneau mesure les couleurs dans les espaces colorimétriques Rec. 601, Rec. 709 et Rec. 2020. Pour ouvrir les espaces colorimétriques, cliquez avec le bouton droit sur le panneau Modes Lumetri et sélectionnez ensuite Espace couleur

  • Rec. 601 : l’espace colorimétrique est utilisé pour encoder les signaux vidéo analogiques au format vidéo numérique.
  • Rec. 709 : l’espace colorimétrique est utilisé pour les workflows normaux HDTV.
  • Rec. 2020 : l’espace colorimétrique est utilisé pour les formats HDR et UHDTV (UHD 4K et UHD 8K).

Si vous avez défini un espace colorimétrique différent pour votre projet After Effects, les modes représentent l’apparence de votre composition conformément à votre espace colorimétrique, mais convertie dans l’espace colorimétrique (601, 709 ou 2020) défini dans le panneau Modes Lumetri.

Pour plus d’informations sur le workflow Couleurs TV, voir Couleur TV

Espace de travail destiné à l’utilisation des outils de couleur

Un nouvel espace de travail, nommé Couleur, permettant d’utiliser le panneau Mode Lumetri et l’effet Lumetri Color, est disponible dans After Effects. Pour ouvrir cet espace de travail, sélectionnez Fenêtre > Espace de travail.

Ouverture de l’espace de travail pour l’utilisation des outils de couleur
Ouverture de l’espace de travail pour l’utilisation des outils de couleur

Synchronisation du panneau de la visionneuse en cours

Le panneau Modes Lumetri analyse et affiche les modifications effectuées dans le panneau de la visionneuse en cours. Il mesure la couleur à partir du panneau Composition, Calque ou Métrage en cours. Vous pouvez modifier la visionneuse active afin d’afficher des résultats différents. Pour verrouiller l’affichage des modes Lumetri sur un panneau de visionneuse spécifique, activez l’option Visionneuse principale dans le panneau de cette visionneuse. Par exemple, lorsque vous modifiez les courbes de couleur RVB de la composition, la forme d’onde prélève la couleur et affiche les informations de modification correspondantes.

Pour plus d’informations sur les panneaux, voir Panneaux et espaces de travail.

Avant d’utiliser les modes Lumetri pour lire les informations de couleur
Avant d’utiliser les modes Lumetri pour lire les informations de couleur

Après avoir apporté des modifications à la composition conformément aux informations de couleur des modes Lumetri
Après avoir apporté des modifications à la composition conformément aux informations de couleur des modes Lumetri


Panneau Modes Lumetri d’After Effects

Panneau Modes Lumetri d’After Effects
Regardez cette vidéo pour en savoir plus sur les améliorations apportées aux couleurs à l’aide du panneau Modes Lumetri d’After Effects

Le panneau Modes Lumetri d’After Effects est identique au panneau Domaines Lumetri de Premiere Pro. Pour plus d’informations sur le panneau, voir Domaines Lumetri dans Adobe Premiere Pro.

Ressources relatives à Synthetic Aperture Color Finesse

Le module externe Synthetic Aperture Color Finesse fourni avec After Effects comprend d’excellents outils de correction colorimétrique. Vous trouverez des didacticiels et des informations supplémentaires sur l’utilisation de Color Finesse sur le site Web de Synthetic Aperture.

Color Finesse installe sa documentation dans le sous-dossier du module externe dans le dossier Plug-ins. After Effects inclut le module externe Synthetic Aperture Color Finesse 3. (voir Modules externes).

Modèles et espaces colorimétriques

Un modèle colorimétrique permet de décrire la couleur à partir de nombres interprétés par les ordinateurs. Le modèle colorimétrique utilisé dans After Effects est RVB. Chaque couleur est décrite en termes de quantité de rouge, de vert et de bleu mélangés pour former la couleur. Parmi les autres modèles colorimétriques, citons CMJN, TSL, YUV et XYZ.

Un espace colorimétrique est une variante d’un modèle colorimétrique. Un espace colorimétrique se distingue par une gamme (plage de couleurs), un ensemble de couleurs primaires, un point blanc et une réponse des tons. Le modèle colorimétrique RVB recouvre par exemple les espaces colorimétriques suivants (par ordre décroissant de taille de gamme) : ProPhoto RVB, Adobe RVB, sRGB IEC61966-2.1 et Apple RVB. Ces espaces colorimétriques décrivent les couleurs à l’aide des trois mêmes axes (R, V et B), mais dans des gammes et des courbes de réponse des tons différentes.

Même si de nombreux périphériques utilisent les composants rouge, vert et bleu pour capturer ou exprimer les couleurs, ces composants présentent des caractéristiques différentes, par exemple le bleu d’un appareil photo n’est pas identique au bleu d’un autre appareil. Chaque périphérique qui capture ou reproduit les couleurs possède son propre espace colorimétrique. Lorsqu’une image passe d’un périphérique à un autre, ses couleurs peuvent varier, car chaque périphérique interprète les valeurs RVB en fonction de son propre espace colorimétrique.

La gestion des couleurs utilise les profils colorimétriques pour convertir les couleurs entre deux espaces colorimétriques, ce qui permet aux couleurs issues de deux périphériques différents d’être identiques.

Gamma et réponse des tons

La réponse des tons pour un espace colorimétrique est la relation de l’intensité lumineuse avec le signal qui crée ou enregistre (perçoit) la lumière.

L’œil humain ne répond pas de manière linéaire à la lumière. En d’autres termes, notre perception de la luminosité ne double pas lorsqu’un nombre de photons deux fois supérieur touchent notre rétine à un instant précis. De même, les éléments d’affichage d’un écran CRT n’émettent pas une luminosité d’une intensité double lorsqu’une tension double est appliquée. La relation entre l’intensité de la lumière et l’intensité du signal d’un périphérique d’affichage est exprimée par une fonction de puissance. L’exposant de cette fonction de puissance est appelé gamma. En règle générale, la relation entre l’intensité de la lumière et l’intensité du signal d’un périphérique d’entrée est l’inverse de celle d’un périphérique de sortie, bien que les valeurs gamma des périphériques d’entrée et de sortie ne soient pas toujours identiques (de façon à prendre en compte la différence entre l’éclairage de la scène et celui de l’environnement d’affichage).

Remarque :

déplacer le curseur des tons moyens (option Gamma de l’effet Niveaux, par exemple) dans un histogramme de correction des couleurs revient à modifier la valeur gamma et la courbe de la réponse des tons sans déplacer le point blanc. Modifier la courbe de l’effet Courbes modifie également la réponse des tons, mais pas nécessairement avec une courbe gamma.

D’excellentes sources d’information sur le gamma et d’autres concepts de la couleur vous attendent sur le site Web de Charles Poynton.

Réponse linéaire des tons : lorsque le gamma est égal à 1

Si vous élevez un nombre à la puissance 1, le résultat obtenu correspond au nombre d’origine. Un gamma de 1,0 est utilisé pour exprimer le comportement de la lumière dans un contexte réaliste, en dehors de nos systèmes perceptifs non linéaires. On considère parfois qu’une valeur gamma de 1,0 fonctionne en mode de lumière linéaire, alors qu’une valeur gamma autre que 1,0 correspond à l’œil humain et fonctionne en mode perceptuel.

Si vous avez activé le mode de gestion des couleurs (en spécifiant un espace colorimétrique de travail), vous pouvez effectuer toutes les opérations colorimétriques à la lumière linéaire, en linéarisant l’espace colorimétrique de travail. Un espace colorimétrique linéarisé utilise les mêmes couleurs primaires et le même point blanc que la version non linéaire ; la courbe de réponse des tons est rectiligne.

Remarque :

Pour de nombreuses opérations de composition, telles que la combinaison de couleurs avec des modes de fusion, l’utilisation d’un espace colorimétrique linéaire s’avère bénéfique. Il est donc conseillé de travailler dans un espace de ce type pour bénéficier d’une fusion des couleurs naturelle et réaliste. Si vous n’avez pas activé la gestion des couleurs, vous pouvez quand même effectuer des opérations de fusion en utilisant une valeur gamma de 1,0 (voir Linéarisation de l’espace de travail et activation de la fusion linéaire).

Gamma système, gamma périphérique et différence entre la scène et l’environnement d’affichage

La valeur gamma d’un système (depuis la capture jusqu’à la production et l’affichage dans un environnement adapté) est le produit des valeurs gamma utilisées à chaque phase du système. Ce produit n’est pas systématiquement égal à 1,0 (ce serait le cas si les opérations d’encodage correspondaient exactement à l’inverse des opérations de décodage). Une valeur gamma différente de 1,0 provient souvent de la différence entre les conditions d’éclairage au moment de la capture d’une scène et les conditions d’éclairage des salles de visionnage. (N’oubliez pas qu’un film est souvent projeté dans un environnement faiblement éclairé alors que les scènes sont tournées dans un environnement éclairé.)

Par exemple, la valeur gamma périphérique d’une caméra HD est d’environ 1/1,9, alors que celle de l’affichage HD est d’environ 2,2. Si vous multipliez ces valeurs, vous obtenez une valeur gamma système proche de 1,15, adaptée aux conditions de visionnage standard (salon faiblement éclairé par exemple). Dans le cas de films animés, la valeur gamma système, bien plus élevée (environ 1,5 à 2,5), est adaptée à l’environnement de visionnage plus sombre des salles de cinéma. La valeur gamma du négatif du film est d’environ 1/1,7 ; celle de la projection est d’environ 3 ou 4.

Les profils colorimétriques sont dits à référence scène si leurs courbes de réponse tonale dépendent des conditions de la scène type. Les profils colorimétriques sont dits à référence sortie si leurs courbes de réponse tonale dépendent des conditions de l’environnement d’affichage.

Lorsque vous utilisez la gestion des couleurs, After Effects règle automatiquement le contraste des images lors d’une conversion entre des profils colorimétriques à référence scène et des profils colorimétriques à référence sortie. Cette conversion automatique (réglage de l’état des images) est basée sur les valeurs gamma spécifiées dans la norme vidéo HDTV.

  • Pour désactiver cette conversion de couleur automatique, désélectionnez l’option Compenser les profils scène de la boîte de dialogue Paramètres du projet (Fichier > Paramètres du projet).

La fonction Compenser les profils scène existe également dans Adobe Photoshop CS4 (et versions ultérieures), mais pas dans d’autres applications. Pour reprendre les couleurs d’autres applications, dont After Effects CS3 et les versions antérieures, désactivez la conversion automatique. Lorsque vous ouvrez un projet créé dans After Effects CS3 ou une version antérieure, l’option Compenser les profils scène est désélectionnée.

Vous pouvez également définir chaque instance de l’effet Convertisseur profil couleurs de façon à compenser ou non les profils scène ou à utiliser le paramètre indiqué par l’option Compenser les profils scène du projet (voir Effet Convertisseur profil couleurs).

Pour obtenir des informations supplémentaires sur la compensation des profils scène, consultez cet article de Todd Kopriva et Peter Constable sur le site Web d’Adobe.

QuickTime et gamma dans les projets sans gestion des couleurs

After Effects 7.0 et les versions antérieures du logiciel utilisaient les modules de compression QuickTime pour décoder divers types de support, et les réglages gamma effectués par QuickTime sous Windows étaient différents des réglages réalisés sous Mac OS. Les réglages gamma effectués par After Effects CS3 et version ultérieure sont différents de ceux appliqués par les modules de compression QuickTime. Les réglages gamma After Effects CS3 et version ultérieure sont identiques sous Windows et Mac OS. En outre, si les modules de compression QuickTime ne sont pas utilisés, After Effects conserve les valeurs hors plage dans les projets en mode 32 bpc.

Dans la boîte de dialogue Paramètres du projet, sélectionnez Correspondance des réglages Gamma QuickTime After Effects existants pour les motifs suivants :

  • Eviter des variations chromatiques dans les projets créés dans After Effects 7.0 ou versions antérieures

  • Respecter les couleurs d’un projet créé dans After Effects 7.0 ou versions antérieures

  • Garantir la correspondance des couleurs entre le panneau Composition et le lecteur QuickTime

L’option Correspondance des réglages Gamma QuickTime After Effects existants est sélectionnée par défaut pour les projets créés dans After Effects 7.0 ou versions antérieures. Nous vous recommandons de créer des projets sans sélectionner cette option.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne