Consigli e suggerimenti

Progetta e crea più velocemente i prototipi in Adobe XD usando questi consigli e suggerimenti.

Di seguito sono riportati alcuni consigli che possono esserti di aiuto quando utilizzi Adobe XD.

Consigli e suggerimenti generali

  • Anziché copiare e incollare gruppi di elementi nella progettazione, prova a utilizzare lo strumento Griglia di ripetizione (disponibile nella finestra di Ispezione proprietà).
  • Puoi duplicare una forma selezionandola, tenendo premuto il tasto Opzione (Mac) o Alt (Windows) e trascinando una sua nuova copia.
  • Gli elementi possono essere bloccati con Oggetto > Blocca o Comando+L (Mac). Questo in realtà alterna il blocco, quindi usa lo stesso comando per sbloccare gli elementi. In Windows, fai clic con il pulsante destro sull’oggetto e seleziona Blocca dal menu di scelta rapida.
  • Attiva la selezione diretta tenendo premuto il tasto Comando o Ctrl. Questo ti consente di selezionare oggetti nidificati.
  • Crea rapidamente una maschera rilasciando un’immagine su una forma: il riempimento della forma diventa l’immagine.
  • Crea una maschera modificabile importando un’immagine, quindi disegna una forma su di essa. Seleziona entrambe, quindi scegli Oggetto> Maschera con forma (Mac) o fai clic con il pulsante destro sugli oggetti e scegli Maschera con forma dal menu di scelta rapida. Puoi modificare la maschera o l’immagine in un secondo momento facendo doppio clic sul gruppo con maschera.

Disegno e testo

  • Puoi disattivare le guide di aggancio tenendo premuto il tasto Comando/Ctrl.
  • Fai doppio clic su un qualsiasi punto di ancoraggio per alternare tra una curva e un angolo.
  • Tieni premuto il tasto Opzione/Alt mentre trascini la maniglia di una curva per renderla indipendente. (Per renderla nuovamente dipendente, fai doppio clic per tornare a un angolo, quindi fai nuovamente doppio clic).
  • Puoi selezionare i punti di ancoraggio quando disegni usando lo strumento Penna.
  • Fai doppio clic per accedere al contesto di modifica di un gruppo (puoi aggiungere elementi in questo contesto) o fai semplicemente clic su un oggetto in un gruppo tenendo premuto il tasto Comando/Ctrl per selezionarlo.
  • Seleziona un elemento di testo, quindi creane uno nuovo per applicare tutti gli stili dal primo elemento al secondo.
  • Le combinazioni di tracciati (Aggiungi/Sottrai/Interseca/Escludi aree sovrapposte) non sono distruttive. Puoi alternare tra attivate e disattivate.

Importazione del contenuto

  • Per inserire il contenuto da Illustrator, seleziona la forma vettoriale in Illustrator, quindi copia e incolla in Adobe XD.
  • Per inserire contenuto bitmap da Photoshop, seleziona tutto (Comando+A o Ctrl+A) in un livello bitmap o testo (o converti prima un livello o un gruppo vettoriale in un oggetto avanzato), quindi copialo e incollalo in Adobe XD. Il livello incollato è una bitmap. Puoi anche copiare contenuto da Photoshop effettuando una selezione usando lo strumento Selezione rettangolare. Quindi, dai menu, scegli Modifica > Copia (per ottenere la selezione sul livello corrente) o Modifica > Copia unito (per ottenere la selezione su tutti i livelli nella selezione).
  • Per inserire il contenuto da Sketch, seleziona uno o più livelli o gruppi e fai clic su Rendi esportabile. Scegli SVG come formato e trascina il livello da Sketch ad Adobe XD. Questo crea contenuto vettoriale modificabile in Adobe XD.
  • Per importare risorse (PNG, JPG, TIFF, GIF, SVG) da Mac, puoi usare File> Importa oppure trascina oppure copia e incolla le immagini in Adobe XD dal Finder.
    In Windows, seleziona il menu hamburger e fai clic su Importa oppure trascina oppure copia e incolla le immagini da Esplora file.
    Puoi anche copiare e incollare dal browser ad Adobe XD.

Controlli da tastiera

  • Quando regoli il raggio angolo puoi tenere premuto il tasto OPZIONE per limitare la regolazione a un singolo angolo.
  • Per disattivare temporaneamente l’aggancio quando sposti o ridimensioni gli elementi, tieni premuto il tasto Comando o Ctrl.
  • Tieni premuto il tasto MAIUSC durante il ridimensionamento di un elemento per mantenere le proporzioni dell’elemento.
  • Tieni premuto il tasto ALT mentre disegni una forma per iniziare dal centro anziché dal punto predefinito (che si trova in alto a sinistra).
  • Per cambiare rapidamente l’opacità di un elemento selezionato, premi i seguenti tasti numerici. Quindi, 1= 10%, 2 = 20% e così via; 0 = 100%.
  • Quando sposti una forma o un punto di controllo utilizzando i tasti freccia, tieni premuto il tasto MAIUSC per spostare di 10 px.
  • Tieni premuta la barra spaziatrice per attivare la modalità mano. Puoi fare clic e trascinare per attraversare l’area di lavoro.

Tavole da disegno

  • Per selezionare una tavola da disegno, fai clic sul suo titolo, fai clic sul suo sfondo tenendo premuto il tasto Comando/Ctrl o fai doppio clic sul suo sfondo.
  • Per selezionare una tavola da disegno vuota, fai clic sul suo sfondo.
  • Per duplicare una tavola da disegno (e il suo contenuto), selezionala e tieni premuto il tasto Comando (Mac) o Alt (Windows) mentre trascini per creare la copia.
  • Per rinominare la tavola da disegno, fai doppio clic sul suo titolo.

Griglia di ripetizione

  • Per regolare il riempimento tra gli elementi ripetuti in una griglia di ripetizione, seleziona la griglia di ripetizione, quindi passa il mouse sopra lo spazio tra gli elementi e trascina. Se stai modificando un elemento nella griglia di ripetizione, dovrai premere ESC per uscire dalla modalità di modifica.

Prototipazione e anteprima

  • Seleziona qualsiasi oggetto su una tavola da disegno (o l’intera tavola da disegno) e trascina un collegamento per attivare un’interazione tra le tavole da disegno.
  • Rimuovi il collegamento trascinandolo via dalla destinazione per annullare l’interazione che avevi impostato.
  • Utilizza la transizione Dissolvenza quando progetti per il Web.
  • Puoi vedere tutte le connessioni tra le tavole da disegno (tranne quelle che sono attivate direttamente dalle tavole da disegno) premendo i tasti Comando+A (Mac) o Ctrl+A (Windows) nella modalità Prototipo.
  • Nella finestra Anteprima è visualizzata la tavola da disegno che contiene la selezione corrente. Se non è presente nessuna selezione, la finestra Anteprima è visualizzata con la tavola da disegno Home per prima.
  • Dalla finestra Anteprima, puoi registrare un video del tuo prototipo interattivo. Per iniziare il video, fai clic sull’icona di registrazione sulla barra del titolo.
  • Facendo nuovamente clic sul pulsante di registrazione OPPURE premendo il tasto ESC interrompi la registrazione del video.
  • Nei prototipi, puoi anche utilizzare gli attivatori con scelte rapide da tastiera o gamepad in base al tipo di esperienza che progetti. 

Condivisione

  • Per condividere, devi aver effettuato l’accesso con un account Adobe dall’app desktop Adobe Creative Cloud o qualsiasi altra applicazione Adobe (ad esempio, Photoshop, Illustrator e così via).
    Sono supportati Adobe ID, Enterprise ID e Federated ID.
  • Se condividi il file della progettazione senza prima aggiungere interazioni, sono caricate tutte le tavole da disegno e gli utenti potranno navigare usando i tasti freccia della tastiera. L’ordine delle tavole da disegno parte da in alto a sinistra, spostandosi verso destra.
  • Se la progettazione include interazioni, saranno caricate e condivise solo le tavole da disegno collegate alla tavola da disegno Home.
  • La tavola da disegno definita come Home è la prima tavola da disegno che gli utenti vedono quando aprono la progettazione condivisa.
  • Puoi cambiare la tavola da disegno Home dalla modalità Prototipo, selezionando l’icona Home nella tavola da disegno desiderata. L’icona Home della tavola da disegno è visualizzata solo nelle tavole da disegno selezionate (o la destinazione di un obiettivo selezionato).
  • Quando visualizzi il prototipo in un browser Web per dispositivi mobili, puoi salvarne il collegamento nella schermata principale del dispositivo. Questo rende la presentazione del prototipo più simile a un’applicazione nativa.

Altri argomenti correlati

Logo Adobe

Accedi al tuo account