Corrigir o erro do Generator ao iniciar o Adobe Photoshop

Última atualização em 2 de nov de 2026

Saiba como corrigir o erro do Generator no Adobe Photoshop verificando as configurações de segurança, removendo plug-ins conflitantes e revisando logs.

O Generator é um aplicativo Node.js que lida com a comunicação entre o Photoshop e os plug-ins do Generator. Ele fornece a lógica de criação de ativos para Exportar como e Ativos de imagem.

Ao iniciar o Photoshop ou selecionar Arquivo > Exportar > Exportar como, uma caixa de diálogo aparece informando: "Há um problema com o Generator. Saia do Photoshop e tente novamente. Se o problema persistir, remova todos os plug-ins de terceiros ou tente reinstalar o Photoshop."

Tente as seguintes soluções na ordem em que aparecem.

O software de segurança bloqueia o Generator

O software de segurança ou antivírus pode bloquear a comunicação do Generator na porta 8010 ou impedir a execução do processo node.

Abra as configurações de segurança ou antivírus.

Adicione o Photoshop à lista de aplicativos permitidos.

Verifique se a porta 8010 está aberta para o Generator.

Adicione node.exe à lista de aplicativos permitidos em C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe no Windows.

No macOS, permita o processo node em /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

No Windows, permita que o Photoshop acesse pastas controladas.

Reinicie o Photoshop e selecione Arquivo > Exportar > Exportar como para testar o Generator.

Um plug-in de terceiros entra em conflito com o Generator

Os plug-ins de terceiros na pasta Generator do Photoshop podem ser incompatíveis com a versão atual ou entrar em conflito com o plug-in padrão {1}Image Assets{2}.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Crie uma pasta temporária no desktop chamada Disabled Generator Plug-ins.

Mova as pastas dos plug-ins de terceiros para a pasta temporária. Deixe o plug-in padrão Image Assets na pasta Generator.

Inicie o Photoshop e selecione Arquivo > Exportar > Exportar como.

Se o erro desaparecer, adicione os plug-ins de volta, um de cada vez, e reinicie o Photoshop após cada adição até o erro voltar.

Mantenha o plug-in padrão Image Assets na pasta Generator. Mova somente os plug-ins instalados separadamente.

O gerador não inicia e você não precisa dele.

Se você não usa Exportar como ou Image Assets, desative o Generator como solução alternativa.

Inicie o Photoshop.

No Windows, selecione Editar > Preferências > Plug-ins. No macOS, selecione Photoshop > Configurações > Plug-ins.

Desmarque Habilitar o Gerador.

Selecione OK e reinicie o Photoshop.

Selecionar Arquivo > Exportar > Exportar como ativa o Generator novamente. Se você precisar de Exportar como, resolva o erro do Generator em vez de deixá-lo desativado.

Os logs do Generator mostram erros de inicialização.

Os logs do Generator podem conter informações sobre plug-ins que falham ao carregar ou problemas do sistema que impedem a inicialização do Generator.

No Windows, navegue até C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

No macOS, navegue até /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Abra o log mais recente do Generator e procure mensagens de erro.

Se a pasta Generator não existir, verifique se você tem permissão de gravação na pasta principal.

Se precisar de ajuda adicional, use a Adobe Log Collector Tool para coletar logs de diagnóstico.

As pastas AppData do Windows e Library do macOS são ocultas por padrão. As instruções para mostrar arquivos e pastas ocultos no Windows podem ajudar você a localizar os logs do Windows.

Erros do Generator ocorrem no Apple Silicon.

Se o gerador continuar falhando em um Mac com Apple Silicon, executar o Photoshop com o Rosetta pode ajudar a determinar se a compatibilidade no modo nativo está causando o problema.

Saia do Photoshop.

No Finder, abra Aplicativos e localize o Adobe Photoshop.

Control-clique no Adobe Photoshop e, depois, selecione Obter informações.

Selecione Abrir usando o Rosetta e, depois, inicie o Photoshop e teste o Generator.

Se o erro persistir, forneça os logs do Generator ao contatar o suporte da Adobe para obter ajuda. Para problemas de Exportar como não relacionados ao Generator, use o guia de solução de problemas para operações de exportação e salvamento.