Benutzerhandbuch Abbrechen

SVG

  1. Illustrator-Benutzerhandbuch
  2. Illustrator kennenlernen
    1. Einführung in Illustrator
      1. Neue Funktionen in Illustrator
      2. Häufige Fragen
      3. Systemanforderungen für Illustrator
      4. Illustrator für Apple-Chip
    2. Arbeitsbereich
      1. Arbeitsbereich – Grundlagen
      2. Erstellen von Dokumenten
      3. Symbolleiste
      4. Standardtastaturbefehle
      5. Anpassen von Tastaturbefehlen
      6. Einführung in Zeichenflächen
      7. Zeichenflächen verwalten
      8. Anpassen des Arbeitsbereichs
      9. Eigenschaftenbedienfeld
      10. Festlegen von Voreinstellungen
      11. Touch-Arbeitsbereich
      12. Unterstützung des Microsoft Surface Dial in Illustrator
      13. Wiederherstellen, Rückgängigmachen, Verlauf und Automatisierung
      14. Drehen der Ansicht
      15. Lineale, Raster und Hilfslinien
      16. Barrierefreiheit in Illustrator
      17. Abgesicherter Modus
      18. Anzeigen von Bildmaterial
      19. Verwenden der Touch Bar in Illustrator
      20. Dateien und Vorlagen
    3. Werkzeuge in Illustrator
      1. Werkzeuge-Überblick
      2. Auswahl-Werkzeuge
        1. Auswahl
        2. Direktauswahl
        3. Gruppenauswahl
        4. Zauberstab
        5. Lasso
        6. Zeichenfläche
      3. Navigieren-Werkzeuge
        1. Hand
        2. Drehen der Ansicht
        3. Zoom
      4. Malwerkzeuge
        1. Verlauf
        2. Raster
        3. Formerstellung
      5. Textwerkzeuge
        1. Text
        2. Pfadtext
        3. Vertikaler Text
      6. Zeichnen-Werkzeuge
        1. Zeichenstift
        2. Ankerpunkt hinzufügen
        3. Ankerpunkt löschen
        4. Ankerpunkt
        5. Krümmung
        6. Liniensegment
        7. Rechteck
        8. Abgerundetes Rechteck
        9. Ellipse
        10. Polygon
        11. Stern
        12. Pinsel
        13. Tropfenpinsel
        14. Schraffur
        15. Shaper
        16. Slice
      7. Änderungswerkzeuge
        1. Drehen
        2. Reflektieren
        3. Skalieren
        4. Verbiegen
        5. Breite
        6. Frei transformieren
        7. Pipette
        8. Angleichen
        9. Radiergummi
        10. Schere
  3. Illustrator auf dem iPad
    1. Einführung in Illustrator auf dem iPad
      1. Illustrator auf dem iPad – Übersicht
      2. Häufige Fragen zu Illustrator auf dem iPad
      3. Systemanforderungen | Illustrator auf dem iPad
      4. Funktionsumfang von Illustrator auf dem iPad
    2. Arbeitsbereich
      1. Arbeitsbereich von Illustrator auf dem iPad
      2. Touch-Kurzbefehle und Gesten
      3. Tastaturbefehle für Illustrator auf dem iPad
      4. Verwalten von App-Einstellungen
    3. Dokumente
      1. Arbeiten mit Dokumenten in Illustrator auf dem iPad
      2. Importieren von Photoshop- und Fresco-Dokumenten
    4. Auswählen und Anordnen von Objekten
      1. Erstellen von Wiederholungsobjekten
      2. Angleichen von Objekten
    5. Zeichnen
      1. Zeichnen und Bearbeiten von Pfaden
      2. Zeichnen und Bearbeiten von Formen
    6. Text
      1. Arbeiten mit Text und Schriftarten
      2. Erstellen von Text-Designs entlang eines Pfads
      3. Hinzufügen eigener Schriften
    7. Arbeiten mit Bildern
      1. Vektorisieren von Rasterbildern
    8. Farben
      1. Anwenden von Farben und Farbverläufen
  4. Cloud-Dokumente
    1. Grundlagen
      1. Arbeiten mit Illustrator-Cloud-Dokumenten
      2. Freigeben und gemeinsame Bearbeitung von Illustrator-Cloud-Dokumenten
      3. Upgraden des Cloud-Speicherplatzes für Adobe Illustrator
      4. Illustrator-Cloud-Dokumente | Häufige Fragen
    2. Fehlerbehebung
      1. Fehlerbehebung beim Erstellen oder Speichern von Problemen für Illustrator-Cloud-Dokumente
      2. Beheben von Problemen mit Illustrator-Cloud-Dokumenten
  5. Hinzufügen und Bearbeiten von Inhalten
    1. Zeichnen
      1. Zeichnen – Grundlagen
      2. Bearbeiten von Pfaden
      3. Zeichnen pixelgenauer Grafiken
      4. Zeichnen mit dem Zeichenstift-, Krümmungs- oder Buntstift-Werkzeug
      5. Zeichnen von einfachen Linien und Formen
      6. Bildnachzeichner
      7. Vereinfachen von Pfaden
      8. Definieren von Perspektivenrastern
      9. Symbol-Werkzeuge und Symbolsätze
      10. Anpassen von Pfadsegmenten
      11. Zeichnen einer Blume in fünf einfachen Schritten
      12. Perspektivisches Zeichnen
      13. Symbole
      14. Zeichnen von an Pixeln ausgerichteten Pfaden für Web-Workflows
    2. 3D-Effekte und Adobe Substance-Materialien
      1. Grundlagen von 3D‑Effekten in Illustrator
      2. Erstellen von 3D‑Grafiken
      3. Zuordnen von Bildmaterial auf 3D-Objekte
      4. Erstellen von 3D-Objekten
      5. Erstellen von 3D-Text
    3. Farben
      1. Wissenswertes zu Farben
      2. Auswählen von Farben
      3. Verwenden und Erstellen von Farbfeldern
      4. Anpassen von Farben
      5. Verwenden des Bedienfelds „Adobe Color-Themen“
      6. Farbgruppen (Harmonien)
      7. Adobe Color-Themen-Bedienfeld
      8. Bildmaterial neu färben
    4. Malen
      1. Wissenswertes zum Malen
      2. Malen mit Flächen und Konturen
      3. Interaktive Malgruppen
      4. Verläufe
      5. Pinsel
      6. Transparenz und Füllmethoden
      7. Anwenden einer Kontur auf ein Objekt
      8. Erstellen und Bearbeiten von Mustern
      9. Raster
      10. Muster
    5. Auswählen und Anordnen von Objekten
      1. Auswählen von Objekten
      2. Ebenen
      3. Gruppieren und Umwandeln von Objekten
      4. Verschieben, Ausrichten und Verteilen von Objekten
      5. Übereinanderlegen von Objekten    
      6. Sperren, Ausblenden und Löschen von Objekten
      7. Duplizieren von Objekten
      8. Drehen und Spiegeln von Objekten
    6. Ändern der Form von Objekten
      1. Freistellen von Bildern
      2. Transformieren von Objekten
      3. Kombinieren von Objekten
      4. Ausschneiden, Aufteilen und Zuschneiden von Objekten
      5. Formraster
      6. Skalieren, Verbiegen und Verzerren von Objekten
      7. Angleichen von Objekten
      8. Verformen mit Hüllen
      9. Ändern der Form von Objekten mit Effekten
      10. Erstellen neuer Formen mit den Shaper- und Formerstellungswerkzeugen
      11. Verwenden von interaktiven Ecken
      12. Verbesserte Workflows zum Ändern von Formen mit Touch-Unterstützung
      13. Bearbeiten von Schnittmasken
      14. Interaktive Formen
      15. Erstellen von Formen mit dem Formerstellungswerkzeug
      16. Globale Bearbeitung
    7. Text
      1. Hinzufügen von Text und Arbeiten mit Textobjekten
      2. Erstellen von Aufzählungslisten und nummerierten Listen
      3. Verwalten des Textbereichs
      4. Schriftarten und Typografie
      5. Formatieren von Text
      6. Importieren und Exportieren von Text
      7. Formatieren von Absätzen
      8. Sonderzeichen
      9. Erstellen von Pfadtext
      10. Zeichen- und Absatzformate
      11. Registerkarten
      12. Text und Schrift
      13. Suchen von fehlenden Schriftarten (Typekit-Workflow)
      14. Aktualisieren von Text aus Illustrator 10
      15. Arabische und hebräische Schrift
      16. Schriftarten | Häufige Fragen und Tipps zur Fehlerbehebung
      17. Erstellen eines 3D-Texteffekts
      18. Kreative Typografie-Designs
      19. Skalieren und Drehen von Text
      20. Zeilen- und Zeichenabstand
      21. Silbentrennung und Zeilenumbrüche
      22. Textverbesserungen
      23. Rechtschreibungs- und sprachspezifische Wörterbücher
      24. Formatieren asiatischer Zeichen
      25. Setzer für asiatische Schriften
      26. Erstellen von Textdesigns mit Angleichungsobjekten
      27. Erstellen eines Textposters mithilfe des Bildnachzeichners
    8. Erstellen von Spezialeffekten
      1. Arbeiten mit Effekten
      2. Grafikstile
      3. Erstellen von Schlagschatten
      4. Aussehen-Attribute
      5. Erstellen von Zeichnungen und Mosaiken
      6. Schlagschatten, Schein und weiche Kanten
      7. Übersicht der Effekte
    9. Webgrafiken
      1. Empfehlungen zum Erstellen von Webgrafiken
      2. Diagramme
      3. SVG
      4. Erstellen von Animationen
      5. Slices und Imagemaps
  6. Importieren, Exportieren und Speichern
    1. Importieren
      1. Platzieren mehrerer Dateien
      2. Verwalten verknüpfter und eingebetteter Dateien
      3. Verknüpfungsinformationen
      4. Einbettung von Bildern aufheben
      5. Importieren von Bildmaterial aus Photoshop
      6. Importieren von Bitmap-Bildern
      7. Importieren von Adobe PDF-Dateien
      8. Importieren von EPS-, DCS- und AutoCAD-Dateien
    2. Creative Cloud-Bibliotheken in Illustrator 
      1. Creative Cloud-Bibliotheken in Illustrator
    3. Speichern
      1. Speichern von Grafiken
    4. Exportieren
      1. Verwenden von Illustrator-Grafiken in Photoshop
      2. Grafiken exportieren
      3. Sammeln von Elementen und Exportieren in Stapeln
      4. Dateien verpacken
      5. Erstellen von Adobe PDF-Dateien
      6. CSS extrahieren | Illustrator CC
      7. Adobe PDF-Optionen
      8. Dateiinformationen und Metadaten
  7. Drucken
    1. Vorbereitung für den Druck
      1. Einrichten von Dokumenten zum Drucken
      2. Ändern von Seitenformat und Ausrichtung
      3. Festlegen von Schnittmarken für das Zuschneiden oder Ausrichten
      4. Erste Schritte mit großen Arbeitsflächen
    2. Drucken
      1. Überdrucken
      2. Drucken mit Farbmanagement
      3. Drucken von PostScript-Dateien
      4. Druckvorgaben
      5. Druckermarken und Anschnitt
      6. Drucken und Speichern von transparentem Bildmaterial
      7. Überfüllen
      8. Drucken von Farbseparationen
      9. Drucken von Verläufen, Rastern und Farbübergängen
      10. Weiß überdrucken
  8. Automatisieren von Aufgaben
    1. Zusammenführen von Daten über das Variablenbedienfeld
    2. Automatisieren mit Skripten
    3. Automatisieren mit Aktionen
  9. Fehlerbehebung 
    1. Probleme beim Absturz
    2. Wiederherstellen von Dateien nach Absturz
    3. Dateiprobleme
    4. Unterstützte Dateiformate
    5. Probleme mit GPU-Gerätetreibern
    6. Probleme mit Wacom-Geräten
    7. Probleme mit DLL-Dateien
    8. Arbeitsspeicherprobleme
    9. Probleme mit der Voreinstellungendatei
    10. Schriftprobleme
    11. Druckerprobleme
    12. Absturzbericht an Adobe senden
    13. Leistung von Illustrator verbessern

Erfahren Sie mehr über die Arbeit mit SVG, um XML und JavaScript zur Erstellung von Webgrafiken zu nutzen, die auf Benutzeraktionen mit komplexen Effekten wie Hervorhebung, QuickInfos, Audiowiedergabe und Animation reagieren.

Wissenswertes zu SVG

Bei Bitmap-Formaten für das Web, beispielsweise GIF, JPEG, WBMP und PNG, werden die Bilder mithilfe eines Pixelgitters beschrieben. Die dabei entstehenden Dateien sind häufig recht groß, haben nur eine einzige (oft niedrige) Auflösung und benötigen eine große Bandbreite im Web. Das SVG-Format ist dagegen ein Vektorformat, das Bilder als Formen, Pfade, Text und Filtereffekte beschreibt. Die resultierenden Dateien sind kompakt und liefern professionelle Grafiken für Web und Druck und sogar für Handhelds, deren Ressourcen beschränkt sind. SVG-Bilder können ohne Schärfe- oder Detailverluste auf dem Bildschirm vergrößert werden. Außerdem bietet SVG hervorragende Unterstützung für Text und Farben, wodurch sichergestellt wird, dass die Bilder auch beim Besucher der Website genau so angezeigt werden, wie sie auf der Illustrator-Zeichenfläche erstellt wurden.

Das SVG-Format basiert vollständig auf XML und bietet Entwicklern und Besuchern der Website eine Reihe von Vorteilen. Erfahren Sie mehr über die Arbeit mit SVG, um XML und JavaScript zur Erstellung von Webgrafiken zu nutzen, die auf Benutzeraktionen mit komplexen Effekten wie Hervorhebung, QuickInfos, Audiowiedergabe und Animation reagieren.

Sie können Bildmaterial im SVG-Format mit den Befehlen „Speichern“, Speichern unter, Kopie speichern oder Für Web und Geräte speichern speichern. Sie können auf alle SVG-Exportoptionen zugreifen, indem Sie die Befehle „Speichern“, „Speichern unter“ und „Kopie speichern“ verwenden. Über den Befehl „Für Web und Geräte speichern“ können Sie auf eine Untergruppe der SVG-Exportoptionen zugreifen, die sich für die weborientierte Arbeit eignet.

Das Aussehen der endgültigen SVG-Datei hängt davon ab, wie Sie Ihr Bildmaterial in Illustrator einrichten. Dabei ist Folgendes zu beachten:

  • Verwenden Sie Ebenen, um der SVG-Datei Struktur zu verleihen. Wenn Sie Bildmaterial im SVG-Format speichern, wird jede Ebene in ein Gruppenelement (<g>) umgewandelt. (Aus einer Ebene namens „Schaltfläche1“ wird in der SVG-Datei beispielsweise <g id="Schaltfläche1_ver3.0">.) Verschachtelte Ebenen werden in SVG zu verschachtelten Gruppen und ausgeblendete Ebenen werden mit der SVG-Stileigenschaft „display="none"“ beibehalten.

  • Wenn Sie möchten, dass Objekte auf unterschiedlichen Ebenen transparent erscheinen, ändern Sie die Deckkraft der einzelnen Objekte, nicht die der einzelnen Ebenen. Wenn Sie die Deckkraft der Ebenen ändern, erscheint die Transparenz in der SVG-Datei nicht so wie in Illustrator.

  • Rasterdaten sind im SVG Viewer nicht skalierbar und lassen sich nicht wie andere SVG-Elemente bearbeiten. Vermeiden Sie es daher möglichst, Bildmaterial zu erstellen, das in der SVG-Datei in ein Pixelbild umgewandelt wird. Verlaufsgitter und Objekte, bei denen die Effekte „In Pixelbild umwandeln“, „Kunstfilter“, „Malfilter“, „Scharfzeichnungsfilter“, „Stilisierungsfilter“, „Strukturierungsfilter“, „Vergröberungsfilter“, „Verzerrungsfilter“, „Videofilter“, „Weichzeichnungsfilter“ und „Zeichenfilter“ zum Einsatz kommen, werden beim Speichern im SVG-Format in Pixelbilder umgewandelt. Bei Grafikstilen, die diese Effekte umfassen, kommt es ebenfalls zu einer Umwandlung in Pixelbilder. Verwenden Sie SVG-Effekte, um Grafikeffekte hinzuzufügen, ohne die Grafik dabei in ein Pixelbild umzuwandeln.

  • Verwenden Sie Symbole und vereinfachen Sie die Pfade im Bildmaterial, um die SVG-Datei zu optimieren. Wenn die Arbeitsgeschwindigkeit eine große Rolle spielt, sollten Sie Pinsel vermeiden, die viele Pfaddaten erstellen. Dazu gehören z. B. die Pinselarten „Kohle“, „Asche“ und „Federkiel“.

  • Verwenden Sie zum Einfügen von Web-Links in eine SVG-Datei Slices, Imagemaps und Skripte.

  • Skriptsprachen, wie z. B. JavaScript, ermöglichen eine unbegrenzte Funktionsvielfalt in SVG-Dateien. Mit dem Mauszeiger und der Auswahl einer Taste auf der Tastatur können Skriptfunktionen, wie z. B. Rollover-Effekte, ausgelöst werden. Skripte können darüber hinaus über das DOM (Document Object Model) auf die SVG-Datei zugreifen und diese ändern, indem sie beispielsweise SVG-Elemente hinzufügen oder löschen.

Anwenden von SVG-Effekten

Verwenden Sie SVG-Effekte, um Ihr Bildmaterial mit Eigenschaften wie beispielsweise Schlagschatten zu versehen. Im Gegensatz zu Bitmap-Effekten basieren SVG-Effekte auf XML und sind auflösungsunabhängig. Ein SVG-Effekt ist praktisch nichts anderes als eine Reihe von XML-Eigenschaften, die verschiedene mathematische Vorgänge beschreiben. Der sich ergebende Effekt wird statt auf die Ausgangsgrafik auf das Zielobjekt angewendet.

Illustrator bietet Ihnen eine Standardauswahl an SVG-Effekten. Sie können diese Effekte mit ihren Standardeigenschaften nutzen, durch Bearbeiten des XML-Codes eigene Effekte erstellen oder neue SVG-Effekte programmieren.

Hinweis:

Wenn Sie die SVG-Standardfilter von Illustrator ändern möchten, bearbeiten Sie die Datei „Adobe SVG Filters. svg“. Die Datei befindet sich im Ordner „Dokumente und Einstellungen/<Benutzerverzeichnis>/ Anwendungsdaten/Adobe/Adobe Illustrator <Versionsnummer> Einstellungen/<Speicherort>“. Sie können die vorhandenen Filterdefinitionen bearbeiten, Filterdefinitionen löschen oder neue Filterdefinitionen hinzufügen.

  1. Wählen Sie ein Objekt oder eine Gruppe aus (oder wählen Sie im Ebenenbedienfeld eine Ebene als Ziel aus).
  2. Führen Sie einen der folgenden Schritte durch:
    • Soll ein Effekt mit seinen Standardeinstellungen angewendet werden, wählen Sie den Effekt im unteren Bereich des Untermenüs Effekt > SVG-Filter aus.

    • Soll ein Effekt mit benutzerdefinierten Einstellungen angewendet werden, wählen Sie Effekt > SVG-Filter > SVG-Filter anwenden. Wählen Sie im daraufhin angezeigten Dialogfeld den Effekt aus und klicken Sie auf die Schaltfläche  „SVG-Filter bearbeiten“. Bearbeiten Sie den Standardcode und klicken Sie auf OK.

    • Soll ein neuer Effekt erstellt und angewendet werden, wählen Sie Effekt > SVG-Filter > SVG-Filter anwenden. Klicken Sie im Dialogfeld auf die Schaltfläche  „Neuer SVG-Filter“, geben Sie den neuen Code ein und klicken Sie auf OK.

      Wenn Sie einen SVG-Filtereffekt anwenden, zeigt Illustrator auf der Zeichenfläche eine Pixelbildversion des Effekts an. Sie können die Auflösung dieses Vorschaubildes steuern, indem Sie die Einstellung für die Pixelbildauflösung des Dokuments ändern.

      Hinweis: Wenn einem Objekt mehrere Effekte zugewiesen sind, muss der SVG-Effekt der letzte Effekt sein. Er muss also am unteren Ende des Aussehenbedienfelds (direkt über dem Eintrag „Transparenz“) stehen. Folgen dem SVG-Effekt noch weitere Effekte, wird in der SVG-Ausgabe ein Pixelbildobjekt ausgegeben.

Importieren von Effekten aus einer SVG-Datei

  1. Wählen Sie Effekt > SVG-Filter > SVG-Filter importieren.

  2. Wählen Sie die SVG-Datei aus, die Sie importieren möchten, und klicken Sie auf Öffnen.

SVG-Interaktivität-Bedienfeld – Übersicht

Mit dem SVG-Interaktivität-Bedienfeld (Fenster > SVG-Interaktivität) können Sie interaktive Funktionen in Bildmaterial einfügen, wenn dieses für die Anzeige in einem Webbrowser exportiert wird. So können Sie beispielsweise durch Erstellen eines Ereignisses, das einen JavaScript-Befehl auslöst, leicht dafür sorgen, dass auf der Webseite eine Reaktion zu sehen ist, sobald der Besucher Ihrer Website eine bestimmte Aktion ausführt (beispielsweise wenn er mit dem Mauszeiger auf ein Objekt zeigt). Mit dem SVG-Interaktivität-Bedienfeld können Sie außerdem alle zur aktuellen Datei gehörenden Ereignisse und JavaScript-Dateien anzeigen.

Löschen eines Ereignisses aus dem SVG-Interaktivität-Bedienfeld

  • Soll ein Ereignis gelöscht werden, wählen Sie es aus und klicken Sie auf die Schaltfläche „Löschen“ oder wählen Sie im Bedienfeldmenü den Befehl Ereignis löschen.
  • Sollen alle Ereignisse gelöscht werden, wählen Sie im Bedienfeldmenü den Befehl Ereignisse löschen.

Auflisten, Hinzufügen oder Entfernen von Ereignissen, die mit einer Datei verknüpft sind

  1. Klicken Sie auf die Schaltfläche „JavaScript-Dateien verknüpfen“ .
  2. Wählen Sie im Dialogfeld „JavaScript-Dateien“ einen JavaScript-Eintrag aus und führen Sie einen der folgenden Schritte durch:
    • Klicken Sie auf Hinzufügen, um weitere JavaScript-Dateien zu suchen.

    • Klicken Sie auf Entfernen, um den ausgewählten JavaScript-Eintrag zu löschen.

Einfügen von SVG-Interaktivität in Bildmaterial

  1. Wählen Sie im SVG-Interaktivität-Bedienfeld ein Ereignis aus. (Siehe SVG-Ereignisse.)

  2. Geben Sie das jeweilige JavaScript-Skript ein und drücken Sie die Eingabetaste.

SVG-Ereignisse

onfocusin

Löst eine Aktion aus, sobald der Fokus auf dem Element liegt (beispielsweise durch Auswahl mit dem Mauszeiger).

onfocusout

Löst eine Aktion aus, sobald der Fokus nicht mehr auf dem Element liegt (weil beispielsweise ein anderes Element den Fokus erhält).

onactivate

Löst eine Aktion per Mausklick oder Tastendruck (je nach SVG-Element) aus.

onmousedown

Löst eine Aktion aus, wenn die Maustaste über einem Element gedrückt wird.

onmouseup

Löst eine Aktion aus, wenn die Maustaste über einem Element losgelassen wird.

onclick

Löst eine Aktion aus, wenn über einem Element auf die Maustaste geklickt wird.

onmouseover

Löst eine Aktion aus, wenn der Mauszeiger auf ein Element verschoben wird.

onmousemove

Löst eine Aktion aus, während sich der Mauszeiger über einem Element befindet.

onmouseout

Löst eine Aktion aus, wenn der Mauszeiger von einem Element weg bewegt wird.

onkeydown

Löst eine Aktion aus, wenn eine Taste gedrückt wird.

onkeypress

Löst eine Aktion aus, während eine Taste gedrückt wird.

onkeyup

Löst eine Aktion aus, wenn eine Taste losgelassen wird.

onload

Löst eine Aktion aus, nachdem das SVG-Dokument vom Browser vollständig analysiert wurde. Verwenden Sie dieses Ereignis zum Aufruf von nur einmalig stattfindenden Initialisierungsfunktionen.

onerror

Löst eine Aktion aus, wenn ein Element nicht ordnungsgemäß geladen wird oder ein anderer Fehler auftritt.

onabort

Löst eine Aktion aus, wenn das Laden der Seite gestoppt wird, bevor das Element vollständig geladen ist.

onunload

Löst eine Aktion aus, wenn das SVG-Dokument aus einem Fenster oder Frame entfernt wird.

onzoom

Löst eine Aktion aus, wenn der Zoomfaktor für das Dokument geändert wird.

onresize

Löst eine Aktion aus, wenn die Größe des Dokuments geändert wird.

onscroll

Löst eine Aktion aus, wenn der Besucher der Website die Bildlaufleisten am rechten oder unteren Rand des Fensters verwendet, um durch das Dokument zu blättern.

Web-optimierte SVG-Exportoptionen

Eine neue SVG-Exportoption (Datei > Exportieren > SVG) steht nun zur Verfügung. Mit dem neuen Arbeitsablauf können Sie standardisierte, Web-optimierte SVG-Dateien für Web- und Bildschirmdesign-Projekte erstellen.

Folgende Optionen stehen zur Verfügung:

  • Stil: Wählen Sie aus, wie visuelle Formatierungsinformationen im SVG-Markup gespeichert werden.
    • Präsentationsattribute: Verwendet separate XML-Attribute für jede einzelne Formatierungseigenschaft in jedem SVG-Tag. Diese Formatierung ist erforderlich, um SVG-Assets mit Android Studio verwenden zu können.
    • Internes CSS: Verwendet für CSS-Klassen ein einziges <style>-Tag und nutzt dieselben Formatierungseinstellungen für alle Objekte mit derselben Formatierung. Dies kann zu kleineren Dateien führen.
    • Inline-Format: Verwendet ein einzelnes style-Attribut pro SVG-Tag, das alle Formatierungseigenschaften des Tags in CSS-Syntax kombiniert.

Hinweis: Der Standardstil für SVG ist auf Präsentationsattribute festgelegt, da dies die Kompatibilität mit gängigen Entwicklertools wie Android Studio verbessert.

  • Schriftart. Wählen Sie aus, wie Schriftarten in der SVG-Datei dargestellt werden. Konturen behalten die Pfaddefinition bei und sind am besten kompatibel.
  • Bilder: Wählen Sie diese Option, wenn die Bilder als im Dokument eingebettet oder als verknüpfte Dateien außerhalb des Dokuments gespeichert werden sollen.
  • Objekt-IDs: Wählen Sie aus, wie ID-Typen (Namen) Objekten in der SVG-Datei zugewiesen werden. Wählen Sie zwischen Ebenennamen, Minimal oder Individuell aus. Diese Option legt fest, wie doppelte Namen von Objekten bearbeitet werden und wie die Objekte im exportierten CSS-Code benannt werden.
  • Dezimal: Wählen Sie, wie viele Informationen über die Genauigkeit der Objektspeicherorte Sie beibehalten möchten. Durch einen höheren Dezimalwert werden Objekte genauer angeordnet. Dies erhöht die visuelle Genauigkeit der gerenderten SVGs. Wenn Sie einen Dezimalwert erhöhen, erhöht sich auch die Dateigröße der daraus resultierenden exportierten SVG-Datei.
  • Herabsetzen: Optimiert die Dateigröße der SVGs durch Entfernen von leeren Gruppen und Leerstellen. Bei Auswahl dieser Option verringert sich auch die Lesbarkeit des resultierenden SVG-Codes.
  • Interaktiv. Wenn Sie diese Option wählen, wird sichergestellt, dass die erstellte SVG in einem Browser skaliert wird. Keine absoluten Größenwerte werden gespeichert.
  • Code anzeigen: Öffnet den exportierten Inhalt im Standard-Texteditor.
  • In Browser anzeigen (Symbol): Zeigt das Bild im Standard-Webbrowser an.
Adobe-Logo

Bei Ihrem Konto anmelden