Découvrez ce qu’il est possible de faire pour rendre Illustrator plus rapide et efficace sous macOS.

Plusieurs facteurs ont une incidence sur la rapidité et l’efficacité d’Adobe Illustrator, par exemple, le système d’exploitation et la configuration matérielle, votre flux de production et les options que vous sélectionnez. Si vous remarquez que l’exécution d’Illustrator est plus lente que d’habitude, il existe plusieurs techniques que vous pouvez essayer, non seulement pour optimiser les performances d’Illustrator, mais également celles des autres applications.

Une amélioration des performances est plus évidente lorsque vous travaillez avec des fichiers volumineux.

Avant de commencer

Avant de procéder aux étapes ci-dessous, assurez-vous de disposer de la dernière version d’Illustrator ou des dernières mises à jour de la version que vous utilisez. Les mises à jour de logiciel contiennent souvent des correctifs ou des améliorations liés aux performances.

Si vous utilisez Illustrator CC, vous pouvez mettre à jour Illustrator par l’intermédiaire de l’application de bureau Creative Cloud.

Optimisation de macOS

La configuration de votre système d’exploitation pour qu’il s’exécute efficacement augmente la quantité de mémoire disponible pour les applications, ce qui leur permet de fonctionner de façon plus fluide. Essayez les techniques suivantes pour optimiser macOS et améliorer les performances d’Illustrator.

Gestion des polices

Chaque police de caractère installée augmente la quantité de RAM utilisée par macOS. Installez uniquement les polices dont vous avez besoin afin d’améliorer les performances du système ainsi que les performances des applications qui accèdent à ces polices. Faites appel à un utilitaire de gestion des polices pour vous aider à gérer un grand nombre de polices.

Utilisation d’un pilote d’imprimante PostScript

Les pilotes d’imprimante non PostScript peuvent entrer en conflit avec Illustrator. Par conséquent, Adobe conseille de définir un pilote d’imprimante PostScript comme imprimante par défaut sous macOS.

Étape 1. Configuration d’une imprimante PostScript comme imprimante par défaut

Remarque :

Pour terminer cette procédure, assurez-vous qu’une imprimante PostScript est connectée directement, ou via un réseau, à l’ordinateur.

  1. Dans le menu Apple, sélectionnez Préférences système, puis cliquez sur Imprimantes et scanners.

  2. Si aucune imprimante PostScript n’est répertoriée, cliquez sur +, accédez à une imprimante PostScript et cliquez sur Ajouter.

  3. Sélectionnez une imprimante PostScript dans le menu contextuel de l’imprimante par défaut.

Etape 2. Configuration d’Illustrator de manière qu’il imprime sur une imprimante autre que celle par défaut

  1. Ouvrez un document dans Illustrator, puis sélectionnez Fichier > Imprimer.

  2. Dans la boîte de dialogue Impression, sélectionnez Fichier Adobe PostScript ou le nom de l’imprimante dans le menu Imprimante.

  3. Cliquez sur Enregistrer.

Optimisation de la configuration matérielle

Le matériel que vous utilisez a une incidence sur les performances d’Illustrator car plus le processeur ou le disque dur est rapide, plus Illustrator peut traiter les informations rapidement. D’autres améliorations apportées au matériel, telles que l’installation de RAM supplémentaire, l’utilisation d’un système à plusieurs processeurs ou l’optimisation et la défragmentation de disques, peuvent également améliorer les performances. Voici quelques tâches qui peuvent permettre d’optimiser la configuration matérielle et ainsi améliorer les performances d’Illustrator.

Utilisation d’un processeur plus rapide

La vitesse de l’unité centrale de traitement de votre ordinateur (CPU) a une incidence sur la vitesse d’Illustrator. Illustrator manipulant une grande quantité de données et effectue un grand nombre de calculs, sa vitesse dépend donc de celle du processeur. Envisagez d’utiliser un ordinateur doté d’un processeur plus rapide.

Installation de RAM supplémentaire

Si Illustrator ne dispose pas d’une quantité suffisante de RAM, il fait appel à l’espace disponible sur le disque dur (à savoir, le disque de travail) pour traiter les informations. Illustrator fonctionne plus vite s’il peut traiter les informations dans la mémoire, sans avoir à recourir au disque dur.

Optimisation de l’espace disque

Voici quelques façons d’optimiser l’espace disque :

  • Vérifiez la présence d’erreurs sur le disque dur ou défragmentez les fichiers à l’aide d’un utilitaire de disque tiers (Norton Utilities, par exemple). Si vous utilisez macOS, la défragmentation du disque ne devrait pas être nécessaire, mais la réparation à l’aide d’un utilitaire de disque tiers peut s’avérer utile.
  • Enregistrez vos fichiers sur des lecteurs offrant des vitesses d’accès plus rapides. Par exemple, utilisez un disque dur interne, plutôt qu’un serveur réseau (lecteur réseau) ou un lecteur externe.

Utilisation efficace des fonctionnalités d’Illustrator

La méthode de travail dans Illustrator et en particulier la manière dont vous affichez les illustrations peuvent avoir un impact sur les performances d’Illustrator. Voici quelques façons d’utiliser les fonctionnalités d’Illustrator qui vous aident à maintenir un fonctionnement fluide de ce dernier.

Utilisation de l’affichage Contour

L’affichage Contour masque les attributs de peinture pour afficher l’illustration sous la forme de tracés non remplis. L’utilisation de l’affichage des contours peut accélérer l’affichage des illustrations complexes telles que les objets remplis avec des dégradés ou des motifs. L’affichage Contour facilite également la modification d’objets masqués derrière d’autres objets remplis.

Pour utiliser l’affichage Contour pour un document Illustrator, sélectionnez Affichage > Contour.

Création de vues personnalisées

Vous pouvez créer des vues personnalisées du document. Les vues personnalisées permettent de modifier rapidement le mode d’affichage, le grossissement, la position de défilement et les options de calque.

Pour créer une vue personnalisée d’un document Illustrator, définissez les attributs d’affichage que vous voulez enregistrer. Sélectionnez ensuite Affichage > Nouvelle vue et saisissez un nom dans la boîte de dialogue Nouvelle vue. La vue personnalisée s’affiche dans le menu Affichage.

Modification des paramètres des effets de pixellisation

Vous pouvez changer la résolution des effets de pixellisation pour optimiser les performances d’Illustrator.

Pour ce faire, sélectionnez Effet > Paramètres des effets de pixellisation du document, puis sélectionnez l’un des paramètres suivants dans la liste déroulante Résolution  :

  • Si vous modifiez des fichiers, cliquez sur Ecran. Illustrator utilise une résolution de 72 ppi pour les effets de pixellisation, ce qui augmente la vitesse d’affichage.
  • Si vous imprimez des fichiers, cliquez sur Élevée. Illustrator utilise une résolution de 300 ppp pour les effets de pixellisation, ce qui réduit la vitesse d’impression, mais augmente la vitesse d’affichage.

Cliquez ensuite sur OK.

Masquage des calques et suppression des vignettes

Illustrator redessine l’écran plus rapidement lorsque vous masquez des calques qui contiennent des illustrations complexes ou des images bitmap en haute résolution.

Pour masquer un calque, cliquez sur l’icône représentant un œil situé à gauche du nom du calque, décochez Afficher les calques et cliquez sur OK. Pour afficher uniquement le calque sélectionné, cliquez sur l’icône en forme d’œil en appuyant sur la touche Alt.

Le panneau Calques permet d’afficher des vignettes des calques de niveau supérieur, des calques, des groupes et des objets imbriqués. Pour réduire le nombre de vignettes afin qu’Illustrator redessine l’écran plus rapidement, sélectionnez Options de panneau dans le menu du panneau Calques, puis réduisez le nombre de vignettes.

  • Pour supprimer toutes les vignettes du panneau Calques, sélectionnez Petite dans la section Taille de la rangée, puis cliquez sur OK.
  • Pour supprimer les vignettes d’éléments spécifiques dans le panneau Calques, désactivez les options Calques, Groupes ou Objets dans la section Vignettes, puis cliquez sur OK.

Désactivation de l’aperçu de la surimpression

L’option Aperçu de la surimpression fournit un « aperçu des encres » qui est une approximation de l’aspect de la fusion, de la transparence et de la surimpression dans une sortie en trichromie. Pour améliorer les performances, évitez d’utiliser l’Aperçu de la surimpression.

Pour activer et désactiver l’option Aperçu de la surimpression, sélectionnez Affichage > Aperçu de la surimpression.

Suppression des plans de travail inutilisés

Les plans de travail représentent les zones qui peuvent contenir des illustrations imprimables. Pour optimiser les performances, pensez à supprimer les plans de travail inutilisés ou non indispensables.

Pour gérer les plans de travail, sélectionnez Fenêtre > Plans de travail. Sélectionnez ensuite un plan de travail à supprimer et cliquez surSupprimer.

Modification des préférences de disque de travail

Lorsque vous travaillez sur une image bitmap intégrée et que le système ne dispose pas d’assez de mémoire vive, Illustrator utilise l’espace disque comme disque de travail. Il faut plus de temps pour accéder aux informations présentes sur un disque dur qu’à celles présentes dans la mémoire. Par conséquent, l’utilisation d’une partie du disque dur en tant que mémoire virtuelle peut réduire les performances. Si vous avez besoin de davantage de mémoire pour travailler dans Illustrator, essayez d’installer une plus grande quantité de RAM.

Par défaut, Illustrator utilise le disque système comme disque de travail. Modifiez le paramètre de disque de travail principal d’Illustrator pour qu’il soit votre disque dur le plus rapide.

Pour changer les préférences de disque de travail, procédez comme suit :

  1. Sélectionnez Illustrator > Préférences > Modules externes et disques de travail.

  2. Choisissez un disque dur dans le menu contextuel Disque 1. Si vous prévoyez de travailler avec des images volumineuses et que vous possédez plusieurs disques durs, choisissez un second disque dans le menu contextuel Disque 2.
  3. Cliquez sur OK et relancez Illustrator.

Suppression des éléments inutilisés dans les profils de document

Les profils de document d’Illustrator contiennent les motifs, dégradés, symboles de graphes, couleurs, bibliothèques de couleurs et formes par défaut qui apparaissent dans les nouveaux documents Illustrator. Ces fichiers déterminent également le niveau de zoom, la taille des fenêtres, les préférences d’affichage et la position de défilement des nouveaux documents. Réduisez la taille des nouveaux documents en supprimant les nuanciers et pointes de pinceau inutiles des profils des nouveaux documents Illustrator.

Pour obtenir des instructions sur la création de profils de documents personnalisés, reportez-vous à l’article Startup Profiles: A great tool to customize your new documents.

Suppression des éléments inutilisés dans des modèles

Les modèles vous permettent de créer des documents qui partagent des paramètres et des éléments de conception communs. Vous pouvez réduire la taille de fichiers des nouveaux documents en supprimant les nuances, les symboles, les styles de graphique et les pinceaux superflus des modèles.

Pour obtenir des instructions sur la création de fichiers de modèles, consultez Fichiers et modèles.

Activation de liens vers des images

Les images bitmap incorporées (par exemple, TIFF, BMP ou Photoshop EPS) peuvent augmenter considérablement la taille d’un document Illustrator, ce qui ralentit les performances. Pour améliorer les performances, activez l’option Lien lorsque vous placez une image bitmap. L’option Lien référence l’image placée sur le disque dur.

  • Accédez à Fichier > Placer. Dans la boîte de dialogue Placer, sélectionnez Lien.

Si un prestataire de services demande des images intégrées, enregistrez une copie des fichiers. Sélectionnez Inclure les fichiers liés dans la boîte de dialogue Options de format natif d’Illustrator ou Options de format EPS.

Utilisation des aperçus de fichiers EPS en basse résolution

Si un document contient des images EPS liées disposant d’aperçus en haute résolution, Illustrator réactualise l’écran plus lentement lorsque vous modifiez les illustrations. Pour permettre à Illustrator de redessiner plus rapidement l’écran, utilisez les aperçus EPS en basse résolution. Procédez comme suit :

  1. Sélectionnez Illustrator > Préférences > Gestion des fichiers et presse-papiers..

  2. Sélectionnez Utiliser une vignette basse résolution pour les fichiers EPS liés et cliquez sur OK.

Désactivation de l’option Afficher l’interaction de la transparence DCS

La boîte de dialogue Options du panneau Liens contient une option Afficher l’interaction de la transparence DCS. Si cette option est sélectionnée, le panneau Liens affiche une icône jaune pour identifier les graphiques EPS DCS liés qui sont des objets transparents or transparents se chevauchant. Cette option obligeant Illustrator à déterminer régulièrement si les fichiers EPS liés interagissent avec la transparence, elle peut réduire les performances.

Pour désactiver l’option Afficher l’interaction de la transparence DCS, procédez comme suit :

  1. Sélectionnez Fenêtre > Liens. Dans le menu du panneau Liens, choisissez Options du panneau.

  2. Désactivez l’option Afficher l’interaction de la transparence DCS et cliquez sur OK.

Masquage du panneau Navigation

Le panneau Navigation affiche une vignette de l’illustration en cours pour faciliter la navigation. Le temps de traitement nécessaire pour mettre à jour la vignette à chaque modification du document dépend de la complexité de l’illustration. Afin d’améliorer la vitesse de réactualisation de l’écran et les performances dans un document complexe, masquez le panneau Navigation.

  • Sous le menu Fenêtre, désélectionnez Navigateur.

Vous pouvez configurer les vues personnalisées de manière qu’elles zooment plus efficacement sur des zones particulières de votre document.

Désactivation de l’option Illustration lissée

L’option Illustration lissée lisse le texte et les graphiques en fusionnant la couleur des pixels de contour d’un objet avec celle des pixels adjacents. Ce procédé peut toutefois ralentir la réactualisation de l’écran. Pour désactiver cette option, procédez comme suit :

  1. Sélectionnez Illustrator > Préférences > Général.

  2. Désactivez l’option Illustration lissée et cliquez sur OK.

Application de la commande Simplifier

La commande Simplifier réduit le nombre de points d’ancrage dans les tracés et formes de tracés, ce qui réduit la taille des fichiers et augmente les performances. Pour appliquer la commande Simplifier, sélectionnez le chemin ou l’objet de votre choix, puis Objet > Chemin > Simplifier.

Pour plus d’informations sur la commande Simplifier, voir Édition des chemins.

Désactivation des repères commentés

Les repères commentés vous permettent de créer, d’aligner, de modifier et de transformer les objets Illustrator par rapport à d’autres objets. Si votre illustration contient plusieurs objets, Illustrator aura besoin de plus de temps pour afficher les Repères commentés.

  • Pour désactiver les repères commentés, cliquez sur le menu Affichage et désactivez Repères commentés.

Obtenez de plus amples informations sur les Repères commentés.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne