Il modulo è compilabile?

Non tutti i moduli sono compilabili. Talvolta gli autori dei moduli non convertono i PDF in moduli compilabili interattivi. Oppure creano intenzionalmente un modulo che può essere compilato solo a mano o con lo strumento Aggiungi testo. Questi moduli non interattivi sono chiamate moduli semplici.

Moduli compilabili in Reader XI
Moduli compilabili in Reader XI

A. Nei moduli interattivi vengono evidenziati i campi in cui si deve digitare del testo. B. Se in un modulo è disponibile lo strumento Aggiungi commento testo, è possibile aggiungere del testo ovunque nel modulo. 

Compilare moduli interattivi

Un modulo interattivo contiene campi che è possibile selezionare o compilare.

Modulo interattivo compilabile
Modulo interattivo compilabile

A. La barra dei messaggi viola indica la presenza di campi compilabili. B. Se si fa clic, viene mostrato dove si trovano i campi compilabili. 
  1. Se necessario, fare clic con il pulsante destro del mouse sul documento e selezionare lo strumento Mano o Selezione dal menu a comparsa.

    Il puntatore assume l’aspetto di un’icona diversa quando viene spostato su un campo. Ad esempio, quando è possibile digitare del testo nel campo modulo lo strumento Mano  diventa un indicatore a I . Alcuni campi di testo sono dinamici, vale a dire che si ridimensionano automaticamente per contenere la quantità di dati immessi e possono essere composti da più pagine.

  2. (Facoltativo) Per agevolare l’identificazione dei campi modulo, fare clic sul pulsante Evidenzia campi  nella barra dei messaggi del documento. I campi modulo vengono visualizzati con uno sfondo colorato, per impostazione predefinita azzurro, e tutti i campi obbligatori vengono delineati in un colore diverso, per impostazione predefinita rosso.

  3. Fare clic per selezionare le opzioni, quali pulsanti radio. Fare clic all’interno di un campo di testo per digitare del testo.
  4. Premere Tab per passare al campo successivo o Maiuc+Tab per passare a quello precedente.
  5. Al termine, fare clic sul pulsante Invio per inviare dati a un server o creare un messaggio e-mail per l’invio dei dati. Il pulsante Invia può essere visualizzato nella barra dei messaggi viola nella parte superiore del modulo o nel contenuto del modulo.

Per suggerimenti sulla risoluzione di problemi relativi alla compilazione dei moduli, consultare queste note tecniche.

Compilare moduli semplici con lo strumento Aggiungi testo

Un modulo semplice non contiene campi interattivi. Tuttavia, è possibile utilizzare lo strumento Aggiungi testo per immettere informazioni sul tipo nei campi di modulo vuoti. Acrobat e Reader XI includono lo strumento Aggiungi testo. Con Reader X o versioni precedenti, è possibile aggiungere testo solo se l’autore del modulo ha abilitato lo strumento Aggiungi testo o Typewriter.

Nota:

il testo aggiunto con lo strumento Aggiungi testo è un tipo di commento e viene visualizzato nell’Elenco commenti (Commento > Elenco commenti).

Moduli compilabili semplici (tre varianti) con lo strumento Aggiungi testo
Moduli compilabili semplici (tre varianti). Lo strumento Aggiungi testo consente di digitare nei moduli semplici.

A. Strumento Aggiungi testo nella barra degli strumenti mobile nel browser. B. Strumento Aggiungi testo nella barra dei messaggi viola. C. Strumento Aggiungi testo selezionato nel pannello Firma, dal quale viene poi visualizzata la barra degli strumenti mobile. 
  1. Effettuare una delle operazioni seguenti, a seconda di come il modulo viene visualizzato nella finestra:

    • Nella barra dei messaggi viola o nella barra degli strumenti mobile, fare clic sul pulsante Aggiungi testo.

    • Nell’applicazione Acrobat (non in un browser), scegliere Firma > Aggiungi testo.

    Selezionare Aggiungi testo e digitare nel modulo
    Selezionare Aggiungi testo e digitare nel modulo.

    Se il modulo viene visualizzato in una finestra del browser, passare il cursore nella parte inferiore del modulo e fare clic sull’icona Salva  nella barra di strumenti mobile semitrasparente. Aprire il modulo PDF in Acrobat e scegliere Firma > Aggiungi testo.

    Aprire in Acrobat e selezionare Contrassegna > Aggiungi testo.
    Barra degli strumenti Aggiungi testo non visualizzata. Salvare il modulo, quindi aprire Acrobat e selezionare Firma > Aggiungi testo.

  2. Fare clic su un campo modulo vuoto e digitare il testo desiderato.

  3. (Facoltativo) Impostare le opzioni nella barra dei messaggi viola o nella barra di strumenti mobile per modificare le dimensioni del testo, la posizione o il font. Per ulteriori informazioni sullo strumento Aggiungi testo e la relativa barra degli strumenti, consultare Aggiungere testo con lo strumento Aggiungi testo.

  4. Al termine, stampare una copia del modulo compilato.

    Nota:

    non è possibile inviare elettronicamente un modulo compilato con lo strumento Aggiungi testo. È necessario stampare il modulo compilato. Selezionare Documento e marcature nella finestra di dialogo Stampa.

Compilare moduli semplici in un browser

Un modulo PDF può essere visualizzato in un browser Web, ad esempio quando si fa clic su un collegamento in un sito Web. Se il modulo non contiene campi interattivi, è possibile utilizzare lo strumento Aggiungi testo per compilarlo. Alcuni moduli vengono aperti con la barra degli strumenti Aggiungi testo visualizzata. Per altri moduli, invece, occorre prima salvare il modulo, quindi aprirlo direttamente in Acrobat. Reader XI include lo strumento Aggiungi testo. Nelle versioni precedenti di Reader è disponibile solo se l’autore del modulo lo ha abilitato.

Se la barra degli strumenti Aggiungi testo viene visualizzata, fare clic su Aggiungi testo. Quindi fare clic sulla pagina e iniziare a digitare. Per ulteriori informazioni, vedere Compilare moduli semplici con lo strumento Aggiungi testo.

Strumento Aggiungi testo disponibile nella barra degli strumenti mobile
Strumento Aggiungi testo disponibile nella barra degli strumenti mobile

Se la barra degli strumenti Aggiungi testo non è visibile e non è possibile selezionare o scrivere nei campi di testo, salvare il PDF sul proprio computer. Passare il cursore nella parte inferiore del modulo e fare clic sull’icona Salva  nella barra di strumenti mobile semitrasparente. Aprire il modulo PDF in Acrobat e scegliere Firma > Aggiungi testo. Quindi fare clic sulla pagina e iniziare a digitare.

Salvare il modulo, quindi aprire Acrobat e selezionare Firma > Aggiungi testo.
Barra degli strumenti Aggiungi testo non visualizzata. Salvare il modulo, quindi aprire Acrobat e selezionare Firma > Aggiungi testo.

Nota:

Se la barra degli strumenti Aggiungi testo è stata chiusa, passare il cursore nella parte inferiore del modulo e fare clic sull’icona Acrobat  nella barra di strumenti mobile semitrasparente. La barra degli strumenti Aggiungi testo viene nuovamente visualizzata. Se si chiude nuovamente la barra degli strumenti Aggiungi testo, scorrere verso il basso fino alla barra di strumenti mobile e fare clic sul pulsante Modalità lettura . Fare di nuovo clic sull’icona Acrobat.

Opzioni per i moduli

Tasto

Risultato

Tab o Maiusc+Tab

Conferma il testo digitato e passa al campo successivo o precedente

Freccia su/sinistra

Seleziona il pulsante di scelta precedente di un gruppo

Freccia giù/destra

Seleziona il pulsante di scelta successivo

Esc

Rifiuta il testo inserito e deseleziona il campo modulo.

Esc (premuto due volte)

Esce dalla modalità schermo intero

Invio o A capo (campo di testo a riga singola)

Conferma il testo inserito e deseleziona il campo

Invio o A capo (campo di testo multiriga)

Crea un ritorno a capo nello stesso campo modulo

Invio o A capo (casella di controllo)

Attiva o disattiva la casella di controllo

Invio (tastierino numerico)

Conferma il testo inserito e deseleziona il campo modulo corrente

(Windows) Ctrl+Tab Inserisce una tabulazione nel campo di testo
(Mac) Alt+Tab Inserisce una tabulazione nel campo di testo

Moduli a completamento automatico (solo moduli interattivi)

La funzione di completamento automatico memorizza il testo digitato in un campo modulo interattivo. Vengono quindi suggerite o immesse automaticamente le risposte che corrispondono a quanto digitato in altri campi modulo. I suggerimenti vengono visualizzati in un menu a comparsa da cui è possibile selezionare quello desiderato. Per impostazione predefinita, la funzione di completamento automatico non è attiva. Per utilizzarla, è necessario attivarla nella finestra delle preferenze dei moduli.

Per rimuovere una voce memorizzata dalla funzione di completamento automatico, ad esempio una voce digitata in modo errato e successivamente corretta, è possibile modificare l’elenco nelle preferenze.

Come abilitare l’opzione Completamento automatico in Acrobat | lynda.com (video, 2:43)

Nota:

Le preferenze per moduli determinano come l’applicazione gestisce i moduli aperti durante il lavoro. Le preferenze non vengono salvate unitamente ai moduli PDF.

Abilitare l’opzione di completamento automatico

  1. Scegliere Modifica > Preferenze (Windows) oppure Acrobat/Adobe Reader > Preferenze (Mac OS).

  2. Selezionare Moduli dall’elenco a sinistra.

  3. Nella sezione Completa automaticamente, scegliere Base o Avanzate dal menu.

  4. Selezionare Ricorda dati numerici affinché con la funzione di completamento automatico vengano memorizzate le cifre digitate nei moduli.

Nota:

Selezionando un’opzione dal menu relativo al completamento automatico, nell’area di testo sottostante viene descritto il modo in cui la selezione influenza il funzionamento della funzione di completamento automatico.

Eliminare una voce dalla funzione di completamento automatico

  1. Aprire la finestra di dialogo Preferenze.

  2. Selezionare Moduli dall’elenco a sinistra.

  3. Fare clic su Modifica elenco voci.

  4. Nella finestra di dialogo Completa automaticamente elenco voci, scegliere una delle seguenti procedure e fare clic su nella finestra di dialogo di conferma.

    • Per rimuovere tutte le voci, fare clic su Rimuovi tutto.
    • Per rimuovere alcune voci, selezionare le voci desiderate e fare clic su Rimuovi. Fare clic tenendo premuto Maiusc per selezionare più voci adiacenti o il tasto Ctrl per selezionare più voci non adiacenti.

Modificare moduli semplici per renderli compilabili (Acrobat Pro)

È possibile modificare un modulo semplice e renderlo compilabile utilizzando la procedura guidata per i Moduli o semplicemente consentendo l’utilizzo dello strumento Aggiungi testo. Gli utenti di Acrobat e Reader XI possono uutilizzare lo strumento Aggiungi testo per compilare i moduli semplici.  Tuttavia, le precedenti versioni di Reader non includono lo strumento Aggiungi testo (o Typewriter) a meno non venga abilitato in maniera esplicita nel PDF.

Modulo interattivo

Per creare un modulo interattivo, utilizzare la procedura guidata per Moduli. Consultare Creare moduli tramite Acrobat.

Modulo semplice

Per abilitare lo strumento Aggiungi testo, scegliere File > Salva con nome > PDF per Reader con funzioni estese > Abilita aggiunta di testo in documenti (che non sono moduli compilabili). Questa opzione visualizza la barra degli strumenti Aggiungi testo in una barra dei messaggi viola quando il modulo viene aperto in Acrobat o Reader. Se il modulo è aperto in un browser, la barra degli strumenti Aggiungi testo viene invece visualizzata.

Lo strumento Aggiungi testo è abilitato solo per il modulo corrente. Quando si crea un altro modulo, è necessario ripetere questa operazione per consentire agli utenti di Reader di utilizzare lo strumento Aggiungi testo.

Salvare i moduli

  • Per salvare il modulo compilato, scegliere File > Salva con nome e rinominare il file.

  • Per rimuovere le funzioni estese per Reader, scegliere File > Salva una copia.

  • Affinché gli utenti di Reader possano salvare i dati immessi, scegliere File > Salva come altro > PDF per Reader con funzioni estese > Abilita altri strumenti (inclusi compilazione moduli e salvataggio).

  1. Fare clic sul pulsante Stampa oppure scegliere File > Stampa.

  2. Scegliere una stampante dal menu nella parte superiore della finestra di dialogo Stampa.

  3. Nel menu Commenti e moduli in alto a destra della finestra di dialogo Stampa, scegliere una delle seguenti opzioni e fare clic su OK.

    • (Modulo interattivo o semplice) Per stampare il modulo e il testo inserito, scegliere Documento. Con questa opzione viene stampato il testo digitato con lo strumento Aggiungi testo.

    • (Modulo interattivo o semplice) Per stampare il modulo, il testo inserito ed eventuali commenti aggiunti al modulo, scegliere Documento e marcature. Con questa opzione viene stampato il testo digitato con lo strumento Aggiungi testo.

    • (Solo modulo interattivo) Per stampare solo il testo inserito e non il modulo stesso, scegliere Solo campi modulo.

Cancellare i moduli

Cancellare un modulo in un browser

  1. Effettuare una delle seguenti operazioni:
    • Fare clic sul pulsante Reimposta modulo, se presente. Questa operazione non può essere annullata.
    • Chiudere e riavviare il browser.

    Nota:

    se si fa clic sui pulsanti Ricarica, Aggiorna o Indietro del browser Web oppure su un link in un’altra pagina, il contenuto del modulo potrebbe non venire cancellato completamente.

Cancellare le voci modulo non salvate

  1. Scegliere Strumenti > Moduli > Altre opzioni dei moduli > Cancella modulo.

Moduli di esempio

Patti Sokol, di Sokol Consulting, ha creato due moduli campione per mostrare le differenze tra un modulo semplice e uno interattivo. Fare clic qui per visualizzare un modulo semplice. Si noti che non è possibile digitare il testo nei campi di un modulo semplice. Fare clic qui per visualizzare un modulo interattivo. È possibile evidenziare i campi e compilarli.

Accertarsi di leggere le informazioni contenute nella casella in alto di ogni modulo campione. Quindi, spostare il cursore sui campi per visualizzare le azioni disponibili. È inoltre possibile stampare e salvare i moduli sul computer in uso.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online