Acrobat PDFMaker の問題のトラブルシューティング(Windows 版 Acrobat 8)



 

この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

 

日本語環境での動作保証はしておりませんのでご了承ください。

 

内容 (What's Covered)

 

A. Microsoft Office と Acrobat の互換性を確認します

B. Distiller および Adobe PDF プリンタに関するトラブルシューティング

B-1. Adobe PDF プリンタから PDF を作成

B-2. Distiller から PDF を作成

B-3. エラーログの確認

C. PDFMaker に関するトラブルシューティング

D. 文書に固有の問題に関するトラブルシューティング

D-1. 文書が使用している PDFMaker の機能のみ有効にします

D-2. 表示モードの変更

D-3. 文書の再作成

D-4. 見出しスタイルの再作成

D-5. コンフリクトの原因を特定

D-6. アプリケーションの再インストール

D-7. 文書保護の解除

E. Word の他のマクロとのコンフリクトに関するトラブルシューティング

F. Word の問題に関するトラブルシューティング

F-1. Office セーフモード

F-2. 「Normal.dot」テンプレートのファイル名を変更

 

Adobe Acrobat PDFMaker(PDFMaker ツールバー内の [Adobe PDF に変換] ボタン)は、Microsoft Office アプリケーションから動的に PDF ファイルを生成するアドインです。この機能は、Adobe Acrobat Professional/Standard をインストールすることによって追加されます。PDFMaker は Adobe PDF プリンタを使用して PostScript ファイルを生成し、Adobe Acrobat Distiller アプリケーションの Adobe PDF プリンタインターフェースから PDF ファイルを作成します。Distiller を単独で使用して PDF ファイルを作成することもできます。

 

 

この文書では、Office アプリケーションから PDFMaker を使用して PDF ファイルを作成する際のトラブルに対処する方法について説明します。この文書では主に Microsoft Word を前提とした説明を行なっていますが、ほとんどの手順は Microsoft PowerPoint や Microsoft Excel でも同様に行なうことができます。PDFMaker に関するさらに詳しい情報については、Acrobat ヘルプを参照してください。

 

 A. Microsoft Office と Acrobat の互換性を確認します

 

トラブルシューティングを開始する前に、使用している Acrobat のバージョンと Office のバージョンで互換性があるか確認してください。Acrobat 8 Professional/Standard は、Office 2003/XP/2000 と互換性があります。

 

 B. Distiller および Adobe PDF プリンタに関するトラブルシューティング

 

PDFMaker は Adobe PDF プリンタを使用するため、結果として Distiller が Word 文書の変換時に使用されることになります。トラブルシューティングの最初のステップとして、Distiller が正常に動作しているか確認します。

以下の B-1. ~ B-3. を順番に行い、Distiller が正しく動作しているか確認する必要があります。

 

 B-1. Adobe PDF プリンタから PDF を作成

 

問題の原因を特定するために、以下の操作手順を行い、Adobe PDF プリンタから PDF を作成します。

  1. Word で文書を開き、[ファイル] メニューから [印刷] を選択します。
  2. [プリンタ名] ポップアップメニューから [Adobe PDF] を選択して [OK] をクリックします。



[Adobe PDF] プリンタからの PDF ファイル作成はできるが PDFMaker からは作成できない場合 :

PDFMaker の機能が問題の原因となっている可能性があります。C. PDFMaker に関するトラブルシューティングへ進みます。

[Adobe PDF] プリンタからも PDF ファイルが作成できない場合 :

手順 B-2. へ進みます。

 

 B-2. Distiller から PDF を作成

 

以下の操作を行い、Distiller から PDF ファイルを作成できるか確認します。

 

 注意 : この方法は、リンクや文書構造を維持するなどの PDFMaker の高度な機能をサポートしません。

 

  1. Word 文書を開き、[ファイル] メニューから [印刷] を選択します。
  2. [プリンタ名] ポップアップメニューから PostScript プリンタ(例えば、Adobe PDF プリンタ)を選択します。

    ※ 1 [Adobe PDF] を選択した場合は [プロパティ] ボタンをクリックし、[Adobe PDF 設定] タブで [システムのフォントのみ使用し、文書のフォントを使用しない] のチェックをはずして [OK] をクリックし、手順 3. へ進みます。

    ※ 2 PostScript プリンタがインストールされていない場合、以下の弊社 Web サイトから PostScript プリンタドライバをダウンロードし、インストールしてください。

    URL : http://www.adobe.com/jp/downloads/
  3. [ファイルへ出力] にチェックを入れて [OK] をクリックします。



  4. PostScript(*.ps/*.prn)ファイルが作成されます。
  5. [スタート] メニューから [すべてのプログラム] - [Acrobat Distiller 8] を選択します。
  6. [デフォルト設定] ポップアップメニューから任意の設定を選択します。
  7. [ファイル] メニューから [開く] を選択します。
  8. [ファイルの種類] ポップアップメニューから [すべてのファイル] を選択します。
  9. 手順 4. で作成した PostScript(*.ps/*.prn)ファイルを選択して [開く] をクリックします。
  10. PDF のファイル名と保存場所を指定して [保存] をクリックします。(PDF 変換後、自動的に保存される場合もあります。)

Distiller から PDF ファイルが作成できた場合 :

C. PDFMaker に関するトラブルシューティングへ進みます。

Distiller から PDF ファイルが作成できなかった場合 :

手順 B-3. へ進みます。

 

 B-3. エラーログの確認

 

Distiller を使用して PDF ファイルへの変換を行うと、変換したファイル名、PDF ファイルの保存先、使用したジョブオプション、PostScript エラーにより PDF ファイルの作成ができなかった場合のエラー内容などが「message.log」ファイルに記録されます。「message.log」ファイルに記録されたエラー内容を確認することによって、問題の原因を特定することができます。

 

エラーログを確認するには、以下の操作を行います。

  1. Windows エクスプローラで以下のフォルダを開きます。



    Documents and Settings¥<ユーザ名>¥Application Data¥Adobe¥Acrobat¥Distiller <バージョン>
  2. 「messages.log」ファイルを開き、内容を確認します。

エラーの原因が記録されている場合 :

サポートデータベースで類似する文書を検索します。例えば、ファイルが PostScript エラーをリストアップしていた場合は、文書番号 214063 一般情報 (プリント):ポストスクリプトエラーのトラブルシューティング の手順に従ってトラブルシュートを行います。

エラーの原因が記録されていない場合 :

単語を少しだけ入力した新規文書を Word で作成し、Adobe PDF プリンタ および Distiller を使用して再度 PDF ファイルを作成します。

- 新しい文書から PDF ファイルを作成できた場合

PDFMaker が問題の原因になっている可能性があります。C. PDFMaker に関するトラブルシューティングへ進みます。

- 新しい文書から PDF ファイルを作成できない場合

他のアプリケーションのファイルを使用し、Distiller から PDF ファイルを作成できるか確認します。他のアプリケーションでも同様の問題が発生する場合は、Distiller を再インストールします。他のアプリケーションでは問題が発生しない場合、関連文書を参照するか、サポートデータベースを検索します。お困りの場合は弊社テクニカルサポートにお問い合わせください。

 

 C. Acrobat PDFMaker に関するトラブルシューティング

 

Adobe PDF プリンタまたは Distiller から PDF ファイルを作成できて、PDFMaker では作成できない場合、PDFMaker 機能に問題が発生している可能性があります。これらの機能が問題の原因となっているか確認するには、一度機能を無効にし、その後 PDF ファイルを作成します。

以下の操作を行います。

  1. Word で、[Adobe PDF] メニューから [変換設定の変更] を選択します。
  2. [Acrobat PDFMaker] ダイアログボックスで以下の操作を行い、[OK] をクリックします。



     注意 : 操作を行う前に、元の設定をメモなどに記録しておくことを推奨します。



    - [PDF 設定] ポップアップメニューから [最小ファイルサイズ] を選択します。

    - [セキュリティ] タブを選択し、セキュリティオプションのチェックをすべてはずします。

    - [Word] タブを選択し、すべてのオプションのチェックをはずします。

    - [しおり] タブを選択し、すべてのオプションのチェックをはずします。
  3. [Adobe PDF に変換] ボタンをクリックし、PDF ファイルを作成します。

PDF ファイルを作成できない場合 :

文書固有の問題が発生している可能性があります。D. 文書に固有の問題に関するトラブルシューティングへ進みます。

PDF ファイルを作成できる場合 :

どの機能が問題の原因となっているかを特定します。無効にした機能を 1 つずつ有効にして PDF ファイルを作成します。問題が再現するまでこの手順を繰り返してください。その後、短い文字列のみを入力した新しい Word 文書を作成し、問題が発生した設定のままで PDF ファイルを作成します。

- 新しい文書から PDF ファイルを作成できる場合、問題は文書に固有のものである可能性があります。D. 文書に固有の問題に関するトラブルシューティングへ進みます。

- 新しい文書からも PDF ファイルを作成できない場合、有効にした機能によって問題が発生している可能性があります。Acrobat を再インストールして問題が再現するか確認します。再インストール後も問題が改善されない場合は、弊社テクニカルサポートまでお問い合わせください。

 

 D. 文書に固有の問題に関するトラブルシューティング

 

文書に固有の問題が発生している場合、以下のトラブルシューティングを行います。

 

 D-1. 文書が使用している PDFMaker の機能のみ有効にします

 

変換する文書に必要最低限の PDFMaker 機能のみを有効にします。例えば、文書が「見出し 1」、「見出し 2」などの見出しスタイルだけを含んでいる場合、[Acrobat PDFMaker] ダイアログボックスで他の見出しスタイルを無効にして PDF ファイルを作成します。

以下の操作を行います。

  1. Word を起動し、PDF に変換する文書を開きます。
  2. [Acrobat PDF] メニューから [変換設定の変更] を選択します。
  3. [しおり] タブをクリックします。
  4. 文書で使用している機能以外のチェックをすべてはずします。



  5. [OK] をクリックして、[Acrobat PDFMaker] ダイアログボックスを閉じます。

 

 D-2. 表示モードの変更

 

文書の表示モードを [下書き] に変更し、PDFMaker を使用して PDF ファイルを作成します。

以下の操作手順を行います。

  1. Word を起動し、PDF に変換する文書を開きます。
  2. [表示] メニューから [下書き] を選択します。
  3. [Adobe PDF に変換] ボタンをクリックし、PDF ファイルを作成します。

 

 D-3. 文書の再作成

 

文書内の破損している部分などを削除するために Word 文書を再作成します。以下のいずれか、または複数の操作を行います。

- 既存の文書の内容を新規文書にすべてコピー&ペーストし、PDF ファイルを作成します。

- 文書内のすべてのテキストを選択し、フォントを変更して別のファイル名で保存します。ファイルを別名で保存することによって Word 文書が再作成されるため、PDFMaker とのコンフリクトが改善される可能性があります。文書を保存後、再度フォントの種類を指定しなおしてください。

- 他のバージョンの Word で作成した文書を開いて PDF を作成しようとしている場合、文書内に少しだけ修正を加えて別名保存します。これにより Word は文書を書き換えて、PDFMaker と競合を起こすような要素を排除します。

 

 D-4. 見出しスタイルの再作成

 

文書内のカスタマイズした見出しスタイルを再作成し、PDF ファイルを作成します。スタイルの作成方法について詳しくは、Word のヘルプを参照してください。

 

 D-5. コンフリクトの原因を特定

 

以下の操作を行い、文書内でコンフリクトを起こしている要素を特定します。

  1. 新規 Word 文書を作成します。
  2. オリジナル文書の半分をコピーし、新規文書にペーストします。
  3. PDFMaker を使用して、新規文書から PDF ファイルを作成します。

    - 問題が再現する場合、新規文書内にコンフリクトを起こす要素が存在します。さらに細かく問題の原因を特定する場合、手順 1. ~ 3. を繰り返します。

    - 問題が再現しない場合、オリジナル文書からコピーしなかった残りの半分にコンフリクトを起こす要素が存在します。さらに細かく問題の原因を特定する場合、手順 1. ~ 3. を繰り返します。オリジナルの文書と新規文書の両方とも正常に変換される場合、Office を含む他に起動しているプログラムをすべて終了し、*.tmp ファイルを削除します。(通常、「Windows¥Temp」フォルダに保存されます。)

 

 D-6. アプリケーションの再インストール

 

Acrobat と Office(または Word、PowerPoint、Excel などの Office の特定のアプリケーション)の両方をアンインストールします。その後 Office または特定の Officd アプリケーションを再インストールし、その後 Acrobat を再インストールします。Acrobat をアンインストールするには、「プログラムの追加と削除」(Windows XP)または「アプリケーションの追加と削除」(Windows 2000)を使用します。Acrobat のインストール方法については、文末の関連文書を参照してください。Office のアンインストール方法については、Office のヘルプを参照するか、Microsoft 社へお問い合わせください。

 

 D-7. 文書保護の解除

 

Word 文書が保護されている場合は保護を解除します。文書の保護を解除する方法について詳しくは、Word のヘルプを参照するか、Microsoft 社へお問い合わせください。

 

 E. Word の他のマクロとのコンフリクトに関するトラブルシューティング

 

PDFMaker は、ウイルスチェッカーや FAX ソフトウェアなどの他のマクロとコンフリクトを起こす場合があります。上記のトラブルシューティングを行っても問題が解決しない場合、またはサードパーティ製のマクロのインストール後に PDFMaker に問題が発生した場合、他のマクロとのコンフリクトに関するトラブルシューティングを行ないます。互換性の問題が発生するマクロは、Duden Korrektor Plus 2.0、ViaVoice 10 以前のバージョン、Personal Translator 2002 Office Plus、OfficeReady Stuffit、Leuchter Informatic AG WordPlus、GoldMine Link to Word などがあります。

 

PDFMaker が他のマクロとコンフリクトを起こしているか確認するには、一時的に他のマクロを無効にするか、または削除してから、PDFMaker を使用して文書を PDF ファイルに変換します。問題が改善された場合は、マクロの提供元へお問い合わせください。

 

 F. Word の問題に関するトラブルシューティング

 

以下の手順は、Microsoft 社の技術情報に基づいています。Word のトラブルシューティングの詳細については、Microsoft 社の Web サイトを参照してください。

 

  重要 : この文書は、レジストリの修正情報を含んでいます。レジストリを修正する前に、必ずバックアップを取り、また問題が発生した場合のレジストリの復元方法を確認してください。レジストリのバックアップ、復元、および編集の詳細については、Microsoft 技術情報(256986)「Microsoft Windows レジストリの説明」を参照してください。

 

 F-1. Office セーフモード

 

「/a」スイッチを使用して Word を起動すると、Word は一時的にすべてのオプションに対してデフォルトのビルトイン設定を使用し、アドイン、環境設定、ユーザ設定、およびマクロの読み込みを無効にします。これは、「Office セーフモード」と呼ばれます。また、すべての Office 2003 アプリケーションでは Ctrl キーを押しながら起動するセーフモードの起動オプションを使用することも可能です。Word をセーフモードで起動後、手動で PDFMaker を追加して問題が再現するか確認します。

 

Office セーフモードの詳細については、Microsoft 技術情報(291013)「[WD2002] Office セーフ モードについて」を参照してください。

 

 注意 : 「/a」スイッチで起動している状態で、環境設定やユーザ設定、マクロなどの設定を変更しても、Word の終了時に消去されます。

 

「/a」 スイッチを使用して Word を起動するには、以下の操作を行います。

  1. すべてのアプリケーションを終了します。
  2. [スタート] メニューから [ファイル名を指定して実行] を選択します。
  3. [名前] テキストボックスに「winword.exe /a」と入力します。



  4. [OK] をクリックすると Word が起動します。

 

 

 PDFMaker を手動で読み込むには以下の操作を行います。

  1. [ツール] メニューから [ユーザ設定] を選択します。
  2. [コマンド] タブをクリックして開き、左側の [分類] リストから [ツール] を選択します。
  3. [コマンド] リストに表示された一覧からツールバーへ [COM アドイン] をドラッグ&ドロップして追加します。



  4. [閉じる] ボタンをクリックします。
  5. ツールバーの [COM アドイン] をクリックします。
  6. [COM アドイン] ダイアログボックスの [追加] をクリックします。



  7. [アドインの追加] ダイアログボックスで、以下のファイルを選択して [OK] をクリックします。



    - Program Files¥Adobe¥Acrobat 8.0¥PDFMaker¥Office¥PDFMOfficeAddIn.dll
  8. Alt + F11 キーを押して Visual Basic Editor を起動します。
  9. Ctrl + G キーを押して [イミディエイト] ウインドウを表示します。
  10. 以下の文字列を入力し、Enter キーを押します。



    Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True
  11. Visual Basic Editor を終了します。
  12. [Adobe PDF] および [Acrobat コメント] メニューがツールバー右側に表示されることを確認します。

 

 

Word 文書を検証し PDFMaker を起動するには以下の操作を行います。

  1. Word 文書にいくつかの文字を入力します。
  2. [ファイル] メニューから [名前を付けて保存] を選択し、文書をデスクトップに保存します。
  3. [Adobe PDF に変換] をクリックします。

 

「/a」スイッチで Word を起動した場合に問題が解決した場合は、 Word の起動時に読み込まれるコンポーネントをすべて削除します。これらのコンポーネントは、 表示される順に、1 つずつ削除します。

 

以下のコンポーネントが Word 起動時に読み込まれます。

- Word の自動マクロ

- Windows レジストリ内の Word の Data キー

- 全文書対象のテンプレート(Normal.dot)

- Word および Office Startup フォルダ内のアドイン(WLL)およびテンプレート

- COM アドイン

- Windows レジストリ内の Word の Option キー

 

 注意 : Microsoft 製品サポートサービスの Troubleshoot Utility(「Support.dot」ファイル)を使用して Word が起動時に読み込むコンポーネントの削除と修復を自動的に行うことができます。「Support.dot」ファイルについての詳細は、Microsoft 技術情報(289506) 「[WD2002] トラブルシュートユーティリティの使用方法」を参照して下さい。

 

 F-2. 「Normal.dot」テンプレートのファイル名を変更

 

全文書対象のテンプレート(「Normal.dot」ファイル)に格納されている書式、AutoText、マクロによって Word の動作や開く文書への影響を防ぐには、全文書対象のテンプレート(Normla.dot)のファイル名を変更します。ファイル名を変更することによって「Normal.dot」ファイルが再作成されるため、テンプレートが問題の原因かどうかを確認することができます。

 

  重要 : 「Normal.dot」ファイルのファイル名を変更すると、カスタムスタイルやカスタムツールバー、マクロ、AutoText のエントリなどのいくつかのオプションが初期設定にリセットされます。このため、Microsoft 社では「Normal.dot」ファイルを削除しないことを強く推奨しています。

 

設定によっては複数の Normal.dot ファイルが作成される場合があります。例えば、複数のバージョンの Word が実行されたり、複数のワークステーションが同一コンピュータにインストールされている場合にこの問題が発生します。

 

「Normal.dot」ファイルの名前を変更するには、以下の操作を行います。

 

 注意 : Word の再起動時は「/a」スイッチを使用しないでください。

 

Windows XP の場合

  1. Word を終了します。電子メールエディタとして Word を使用している場合は、Outlook も終了します。
  2. [スタート] メニューから [検索] を選択します。
  3. [ファイルとフォルダすべて] をクリックし、[ファイル名のすべてまたは一部] テキストボックスに「Normal.dot」と入力します。
  4. [探す場所] にローカルハードディスクを選択します。またはネットワークから Word を実行している場合は、ユーザのテンプレートの場所を選択します。
  5. [検索] をクリックします。
  6. [検索結果] ダイアログボックスに表示されたすべての「Normal.dot」ファイルに対して、以下の操作を行います。
  • ファイルを右クリックし、[ファイル名を変更] を選択します。
  • 新しい名前に変更し、Enter キーを押します。例えば、「OldNormal.dot」または「Normal-1.dot」など、後で識別しやすい名前に変更します。
  1. 検索を終了し、 Word を再起動します。

 

Windows 2000 の場合

  1. Word を終了します。電子メールエディタとして Word を使用している場合は、Outlook も終了します。
  2. [スタート] メニューから [検索] - [ファイルやフォルダ] を選択します。
  3. [ファイルまたはフォルダの名前] テキストボックスに「Normal.dot」と入力します。
  4. [探す場所] にローカルハードディスクを選択し、[検索開始] をクリックします。
  5. [検索結果] ダイアログボックスに表示されたすべての「Normal.dot」ファイルに対して、以下の操作を行います。
  • ファイルを右クリックし、[ファイル名を変更] を選択します。
  • 新しい名前に変更し、Enter キーを押します。例えば、「OldNormal.dot」 または 「Normal-1.dot」など、後で識別しやすい名前に変更します。
  1. 検索を終了し、Word を再起動します。

 

問題が再現しない場合 :

「Normal.dot」ファイルの破損が原因であると考えられます。以前の環境を復元するには、いくつかの設定を変更しなければならない場合があります。「Normal.dot」ファイルにスタイルやマクロ、AutoText エントリーなどのカスタマイズが含まれていた場合は、[構成内容変更] ダイアログボックスで、新規「Normal.dot」ファイルに以前の「Normal.dot」ファイルの情報をコピーします。[構成内容変更] ダイアログボックスを表示するには、[ツール] メニューから [テンプレートとアドイン] を選択し、[構成内容変更] ボタンをクリックします。より詳しい情報については Word に付属のヘルプを参照してください。

 

問題が再現する場合 :

「Normal.dot」ファイルが問題の原因ではありません。以前の「Normal.dot」ファイルを使用するには、上記手順で再作成した「Normal.dot」ファイルのファイル名を変更し、以前使用していた「Normal.dot」ファイルのファイル名を元に戻します。

 

この文書に記載の手順をすべて行って問題が改善されない場合は、弊社テクニカルサポートにお問い合わせください。

RELATED RECORDS

アドビのロゴ

アカウントにログイン