この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

 

日本語環境での動作保証はしておりませんのでご了承ください。

 

内容 (What's Covered)

 

A. Macintosh の最適化

A-1. フォント

A-2. プリンタドライバ

B. ハードウェア構成の最適化

B-1. プロセッサの速度

B-2. 内蔵メモリ

B-3. ハードディスク

B-4. PostScript プリンタの使用

C. Illustrator 機能の効果的な使用

C-1. アウトライン表示

C-2. 画面表示のカスタマイズ

C-3. 表示パフォーマンス

C-4. ラスター効果の解像度

C-5. レイヤーの表示

C-6. 仮想記憶ディスク

C-7. 新規ドキュメントのプロファイル

C-8. テンプレート

C-9. リンクされたファイル

C-10. EPS プレビュー

C-11. [DCS 形式への透明の影響を表示] オプション

C-12. [ナビゲータ] パネル

C-13. アートワークのアンチエイリアス

C-14. パスの単純化

C-15. スマートガイド

 

この文書は、Macintosh 版 Adobe Illustrator CS4 のパフォーマンスを最適化するためのさまざまな方法を紹介します。Illustratorが遅くなったと感じたときにもお試し下さい。

 

 

Illustrator のパフォーマンスは、設定、ワークフロー、オペレーティングシステムやハードウェア構成などのさまざまな要因に左右されます。以下にあげる操作や設定を行うことで、特にサイズの大きいファイルで作業を行う際に効果を得られます。また、オペレーティングシステムやハードウェア構成を最適化することにより、Illustrator 以外の他のアプリケーションのパフォーマンスも向上します。

 

以下の操作を行う前に、必ず Illustrator を最新バージョンにアップデートしてください。アップデートには、多くの場合パフォーマンス関連の修正や強化が含まれています。最新バージョンの情報およびアップデートについては、弊社 Web サイト http://www.adobe.com/jp/downloads/updates/ を参照してください。

 

 A. Macintosh の最適化

 

システムが効率的に動作するように設定を行うことで、使用可能なメモリの容量が増え、アプリケーションが快適に動作するようになります。使用していないアプリケーションを終了したり、不要なフォントを使用停止することによって、Illustrator に割り当て可能なメモリ容量が増え、パフォーマンスが向上します。

 

 A-1. フォント

 

必要なフォントだけをインストールすることで、システムのパフォーマンスが向上し、フォントにアクセスするアプリケーションのパフォーマンスも向上します。フォントを 1 つインストールすると、その分システムが使用するメモリ容量が増加します。したがって、アプリケーションに割り当てられるメモリが減少し、フォント名をリストしたメニューの表示に時間がかかります。Extensis Suitcase Fusion などのフォント管理ユーティリティは、多くのフォントを管理する場合に役立ちます。

 

 A-2. プリンタドライバ

 

非 PostScript プリンタドライバと Illustrator がコンフリクトを起こす場合があります。PostScript プリンタドライバを Mac OS X のデフォルトのプリンタに設定することをお勧めします。

 

 注意 : 以下の操作を行うには、PostScript プリンタがコンピュータに直接、またはネットワーク経由で接続されている必要があります。PostScript プリンタを使用していない場合、以下の手順を行う必要はありません。

 

PostScript プリンタをデフォルトのプリンタに設定するには、以下のいずれかの操作を行います。

Mac OS X 10.5.x の場合 :

  1. [アップル] メニューから [システム環境設定] を選択します。
  2. [プリントとファックス] ダイアログボックスが開きます。
  3. [デフォルトのプリンタ] ポップアップメニューから、デフォルトに設定するプリンタを選択します。
  4. [プリントとファックス] ダイアログボックスを閉じます。

Mac OS X 10.4.11 の場合 :

  1. Finder の [移動] メニューから [アプリケーション] を選択します。
  2. [ユーティリティ] フォルダを開き、「プリンタ設定ユーティリティ」アイコンをダブルクリックします。
  3. [プリントリスト] ウィンドウに PostScript プリンタが表示されている場合は手順 6. に進みます。表示されていない場合は [追加] をクリックし、手順 4. 以降の操作を行います。
  4. [プリンタブラウザ] ウィンドウが表示されます。
  5. プリンタのリストに PostScript プリンタを追加します。



     注意 : プリンタを追加する方法の詳細については、Mac OS X ヘルプを参照してください。
  6. PostScript プリンタを選択し、[プリンタ] メニューから [デフォルトにする] を選択します。

Illustrator で Mac OS X のデフォルトのプリンタ以外のプリンタから印刷を行うにするには、以下の設定を行います。

  1. Illustrator を起動します。
  2. [ファイル] メニューから [プリント] を選択します。
  3. [プリンタ] ポップアップメニューから、実際の印刷に使用するプリンタを選択します。
  4. 以下のいずれかの操作を行います。



    設定のみを行う場合 :

    [完了] をクリックします。

    設定およびドキュメントの印刷を行う場合 :

    [プリント] をクリックし、ファイルをプリントします。

 

 B. ハードウェア構成の最適化

 

Illustrator のパフォーマンスは使用するハードウェアによって左右されます。プロセッサやハードディスクドライブが高速であれば、Illustrator でも情報をすばやく処理することができます。メモリの増設、マルチプロセッサシステムの使用、またはドライブの最適化とデフラグなど、ハードウェア構成を最適化することもパフォーマンスの向上につながります。

 

 B-1. プロセッサの速度

 

Illustrator は大量のデータを操作し、多くの計算を実行するため、プロセッサ(CPU)の速度が処理速度に大きな影響を与えます。高速なプロセッサが搭載されていると、その分処理速度も向上します。

 

 B-2. 内蔵メモリ

 

Illustrator の動作に十分なメモリがない場合は、ハードディスクスペース(仮想記憶ディスク)を使用して情報が処理されます。搭載メモリの容量が大きければ、仮想記憶ディスクを使用する必要がなくなり、Illustrator の動作はより高速になります。

 

 B-3. ハードディスク

 

ファイルの追加、削除、移動などを繰り返し行うことによって、ハードディスクに断片化が生じます。断片化したハードディスク上では、ファイルの読み取りに時間がかかるようになります。サードパーティ製のディスクユーティリティを使用してファイルの断片化を解消し、ハードディスクの空き領域を最適化することができます。

 

Illustrator は、ファイルの作業と同時に読み取りおよび書き込みを行います。したがって、ファイルを保存しているディスクまたは Illustrator の仮想記憶ディスクへのアクセス速度が高速であれば、それだけ高速にファイル情報を処理できます。ファイルの保存場所はネットワークサーバ(ネットワークドライブ)やリムーバブルメディア(Zip、Jaz、またはフロッピーディスクなど)のような低速なディスクは避け、内蔵ハードディスクドライブなどのアクセス速度が高速なディスクを選択します。また、リムーバブルメディアは、内蔵ハードディスクドライブと比べるとアクセス速度が遅く、ファイルが破損しやすい傾向があります。

 

Illustrator ファイルをネットワークまたはリムーバブルメディアに保存する場合、弊社では、一度ファイルを内蔵ハードディスクに保存してから外部メディアへ保存するか、もしくは Adobe Version Cue を使用することをお勧めします。

 

 B-4. PostScript プリンタの使用

 

Illustrator からプリントする際に最良の結果を得るためには、PostScript プリンタを使用します。多くの非 PostScript プリンタはディスプレイ情報、ホストコンピュータのリソース、および所有権のあるプリンタドライバに依存して、プリント情報をプリンタに送ります。また、PostScript プリンタと比べてプリントに要する時間が長くなる可能性があります。

 

 C. Illustrator 機能の効果的な使用

 

Illustrator での作業の方法、特にアートワークを表示する方法は、Illustrator のパフォーマンスに大きく影響します。Illustrator の画面表示オプションの変更、画像を埋め込まずにリンク、仮想記憶ディスクとスタートアップオプションの最適化などの方法を用いて、Illustrator の速度とメモリの使用率を向上できます。

 

 C-1. アウトライン表示

 

Illustrator のアウトライン表示ではペイント属性が隠され、アートワークは塗りのないパスとして表示されます。アートワークをアウトライン表示した状態で作業を行うと、グラデーションまたはパターンを含むオブジェクトなどの、複雑なアートワークを含むオブジェクトの形状をすばやく表示できます。アウトライン表示では塗りが非表示になるため、他の塗りつぶされたオブジェクトの背後に隠れたオブジェクトを編集する際にも便利です。アートワークをアウトラインで表示するには、[表示] メニューから [アウトライン] を選択します。

 

アートワークの表示に関する詳細は、Illustrator ヘルプの「アートワークのアウトライン表示」を参照してください。

 

 C-2. 画面表示のカスタマイズ

 

書類の画面モード、拡大率、スクロール位置およびレイヤーオプションをカスタマイズした状態の画面を 1 つの設定として登録しておくことで、[表示] メニューから設定をすばやく呼び出すことができるようになります。

画面表示の設定をカスタマイズするには、以下の操作を行います。

  1. Illustrator を起動し、画面表示をカスタマイズする書類を開きます。
  2. 画面モード、拡大率など、保存する画面属性を設定します。
  3. [表示] メニューから [新規表示] を選択します。
  4. [新規表示] ダイアログボックスで [名前] テキストボックスに任意の名前を入力し、[OK] をクリックします。



以上の操作で、[表示] メニューの一番下にカスタマイズした設定の名前が表示されます。

 

 C-3. 表示パフォーマンス

 

[手のひらツール] を使用してアートボードを移動する際の、画質および速度を指定します。表示パフォーマンスの設定を変更するには、以下の操作を行います。

  1. [Illustrator] メニューから [環境設定] - [単位・表示パフォーマンス] を選択します。
  2. [手のひらツール] のスライダを左に動かすと画質、右に動かすと速度のパフォーマンスが向上します。



  3. [OK] をクリックします。

 

 C-4. ラスター効果の解像度

 

Illustrator のパフォーマンスを最適化するために、ラスター効果の解像度を変更することができます。ラスター効果の解像度を変更するには以下の操作を行います。

  1. [効果] メニューから [ドキュメントのラスタライズ効果設定] を選択します。
  2. [解像度] セクションで以下のいずれかの設定を行い、[OK] をクリックします。

    - ファイルを編集する場合、[スクリーン] をクリックします。Illustrator はラスター効果を 72 ppi の解像度で使用し、表示速度が向上します。

    - ファイルを印刷する場合、[高解像度] をクリックします。Illustrator はラスター効果を 300 ppi の解像度で使用し、印刷の速度は低下しますが、印刷の品質は向上します。

 

 C-5. レイヤーの表示

 

複雑なアートワークや高解像度のビットマップ画像が配置されているファイルを編集する場合、アートワークやビットマップ画像が配置されたレイヤーを非表示にすることによってスクリーン再描画の速度を向上することができます。レイヤーを非表示にするには、レイヤー名の左側にある目のアイコンをクリックします。選択したレイヤー以外の全てのレイヤーを非表示にするには、Option キーを押しながら目のアイコンをクリックします。

 

[レイヤー] パネルには、上位レベルのレイヤー、ネスト化されたレイヤー、グループ、およびオブジェクトのサムネールを表示することができます。サムネールの数を減らし、Illustrator の再描画を高速化するには、以下の操作を行います。

  1. [レイヤー] パネルのメニューから、[パネルオプション] を選択します。
  2. いくつかのサムネールを削除します。

    - すべてのサムネールを非表示にするには、[行のサイズ] セクションで [小] を選択し、[OK] をクリックします。

    - 特定のレイヤーのサムネールを非表示にするには、[サムネール] セクションで [レイヤー]、[グループ] または [オブジェクト] からチェックをはずし、[OK] をクリックします。

 

 C-6. 仮想記憶ディスク

 

Illustrator では埋め込まれたビットマップ画像を操作する際、メモリが不足するとハードディスクスペースを仮想記憶ディスクとして使用します。ハードディスクの情報へのアクセスは、メモリの情報へのアクセスより時間を要します。したがって、ハードディスクの一部を仮想メモリとして使用すると、パフォーマンスが低下します。Illustrator で作業するための十分なメモリがない場合は、メモリの増設が効果的です。

Illustrator の初期設定では、オペレーティングシステムがインストールされているハードディスクが 1 番目の仮想記憶ディスクとして設定されます。最適なパフォーマンスを得るためには、OS がインストールされておらず、未使用領域が多い、読み書きのスピードが(ネットワークドライブや Zip ドライブなどよりも)速い、デフラグされたハードディスクを 1 番目の仮想記憶ディスクとして設定することを推奨します。複数のハードディスクがある場合は、追加の仮想記憶ディスクを指定することを推奨します。

 

仮想記憶ディスクの割り当てを変更するには、以下の操作を行います。

  1. [Illustrator] メニューから [環境設定] - [プラグイン・仮想記憶ディスク] を選択します。
  2. [ディスク 1] ポップアップメニューから適切なハードディスクを選択します。
  3. 必要に応じて [ディスク 2] ポップアップメニューから 2 番目のハードディスクを選択します。
  4. [OK] をクリックします。
  5. Illustrator を再起動します。

 

 注意 : Norton Utilities などのディスクユーティリティを使用して、ハードディスクを定期的に最適化し、断片化を解消することをお勧めします。

 

 C-7. 新規ドキュメントのプロファイル

 

Illustrator の新規ドキュメントのプロファイルには、デフォルトパターン、グラデーション、グラフのデザイン、カラーおよびカラーライブラリが含まれています。さらに、新規にファイルを開く際のデフォルトのズームレベル、ウィンドウサイズ、画面の環境設定およびスクロール位置も含まれます。新規文書のファイルサイズを最小にするには、不要なスウォッチ、グラデーション、グラフィックスタイル、ブラシを文書プロファイルから削除します。各パレットの操作についての詳細は、Illustrator のヘルプを参照してください。Illustrator CS4 では基本 RGB と基本 CMYK の他に、プリント、Web など 6 種類のドキュメントプロファイルが用意されています。

ドキュメントプロファイルの作成に関する詳細は、Adobe Illustrator CS4 ヘルプ「新しいドキュメントの作成」を参照してください。

 

 C-8. テンプレート

 

Illustrator テンプレートによって、共通の設定やデザイン要素を共有する新規ドキュメントを作成することができます。たとえば、似たような名刺をデザインしたり、アートボードの大きさ、ガイドなどの表示設定、印刷設定、などのテンプレートを作成します。不要なスウォッチ、シンボル、グラフィックスタイル、ブラシなどをテンプレートから除くことで、ファイルサイズを小さくすることができます。テンプレートは起動ファイルやドキュメントプロファイルを作成するよりも有効な手段です。また、テンプレートはいくつでも作成することができ、起動ファイルやドキュメントプロファイルのようにファイル名や場所が制限されていないため、任意の場所に保存して使用することができます。

 

テンプレートファイルを作成するには、以下の操作を行います。

  1. Illustrator を起動します。
  2. テンプレートとして使用するファイルを作成、もしくは開きます。
  3. [ファイル] メニューから [テンプレートとして保存] を選択します。
  4. 任意の場所に保存します。

 

作成したテンプレートを使用するには、以下の操作を行います。

  1. Illustrator を起動します。
  2. [ファイル] メニューから [テンプレートから新規] を選択します。
  3. 作成したテンプレートを選択します。

 

テンプレートファイルの作成に関する詳細は、Adobe Illustrator CS4 ヘルプ「新規テンプレートの作成」を参照してください。

 

 C-9. リンクされたファイル

 

TIFF 形式(Tagged-Image Files Format)、BMP 形式(BitMap)、Photoshop EPS 形式(Encapusulated PostScript)などの埋め込まれたビットマップ画像がある場合は、Illustrator ファイルのサイズが大きくなり、パフォーマンスが低下します。パフォーマンスを向上するためには、ビットマップ画像を配置する際に [配置] ダイアログボックスから [リンク] を選択します。[リンク] オプションを使用することによって、配置した画像の参照情報をハードディスクに作成することができます。サービスビューローが埋め込まれた画像を必要としている場合には、オリジナルファイルのコピーを保存するようにします。コピーを保存する際に、[Illustrator オプション](Adobe Illustrator 書類)または [EPS オプション](Illustrator EPS)ダイアログボックスで、[配置した画像を含む] にチェックを入れます。

 

 C-10. EPS プレビュー

 

ファイルが高解像度プレビューの EPS イメージへのリンクを含んでいるとき、アートワークの編集時に画像の描画に時間がかかる場合があります。Illustrator の低解像度 EPS プレビューを使用することで、描画速度が向上します。

低解像度 EPS プレビューを設定するためには以下の操作を行います。

  1. [Illustrator] メニューから [環境設定] - [ファイル管理・クリップボード] を選択します。
  2. [ファイル] セクションで [リンクされた EPS に低解像度の表示用画像(プレビュー)を使用] にチェックを入れます。
  3. [OK] をクリックします。

 

 C-11. [DCS 形式への透明の影響を表示] オプション

 

[リンク] パネルで [DCS 形式への透明の影響を表示] オプションが設定されている場合、[リンク] パレットに黄色のアイコンが表示され、透明オブジェクトに影響される EPS 画像を示します。このオプションによって、Illustrator がリンクされた EPS ファイルに透明の影響があるかどうかを定期的に判定することになるため、パフォーマンスが低下することがあります。

 

[DCS 形式への透明の影響を表示] オプションを無効にするには、以下の操作を行います。

  1. [リンク] パネルのメニューから [パネルオプション]を選択します。
  2. [パネルオプション]ダイアログボックスで、[DCS 形式への透明の影響を表示] のチェックをはずします。
  3. [OK] をクリックします。

 

 C-12. [ナビゲータ] パネル

 

[ナビゲータ] パネルは簡単な操作でアートワークのサムネールが表示されます。複雑なアートワークを編集している場合、変更を行うたびにサムネールを更新するため、処理に時間がかかることがあります。複雑なアートワークを含む Illustrator ファイルのスクリーン再描画速度とパフォーマンスを向上させるためには、[ナビゲータ] パネルを非表示にする方法が有効です。[ナビゲータ] パネルを非表示にするには、[ウインドウ] メニューから [ナビゲータ] のチェックをはずします。

 

※ 画面表示をカスタマイズしておけば文書の特定の範囲に、より効率的にズームできます。詳細については、C-2. を参照してください。

 

 C-13. アートワークのアンチエイリアス

 

[アートワークのアンチエイリアス] オプションを選択することによって、オブジェクトの端のピクセルと隣接したピクセルのカラーがブレンドされ、テキストやグラフィックスが滑らかに表示されますが、画像の再描画に要する時間が長くなります。このオプションを無効にするには、以下のの操作を行います。

  1. [Illustrator] メニューから [環境設定] - [一般] を選択します。
  2. [アートワークのアンチエイリアス] のチェックをはずします。
  3. [OK] をクリックします。

 

 C-14. パスの単純化

 

[パスの単純化] コマンドを使い、パスおよびパスシェイプのアンカーポイントの数を減らすことによって、ファイルサイズを減らし、パフォーマンスを向上させることができます。[パスの単純化] コマンドを適用するには、以下の操作を行います。

  1. 単純化するパスまたはオブジェクトを選択します。
  2. [オブジェクト] メニューから [パス] - [単純化] を選択します。
  3. [単純化] ダイアログボックスで適切な設定を行い、[OK] をクリックします。

[パスの単純化] コマンドに関する詳細は、Illustrator ヘルプの「パスのスムーズ処理と単純化」を参照してください。

 

 C-15. スマートガイド

 

スマートガイドは、Illustrator オブジェクトを他のオブジェクトとの相対関係で作成、整列、編集、および変形することができます。アートワークに多数のオブジェクトが含まれる場合は、スマートガイドを表示するために時間がかかります。スマートガイドを無効にするには、[表示] メニューを選択し、[スマートガイド] にチェックが表示されている場合はクリックして無効にします。

 

スマートガイドに関する詳細は、Illustrator ヘルプを参照してください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー