Flash Player에서 재생할 수 있는 슬라이드 쇼 형식의 내용을 만들려면 SWF 또는 FLA로 내보냅니다. SWF 파일은 바로 볼 수 있고 편집할 수는 없지만 FLA 파일은 Adobe Flash Professional로 편집해야만 Adobe Flash Player에서 볼 수 있다는 점이 두 형식의 주된 차이점입니다.

SWF

내보낸 SWF 파일은 Adobe Flash Player에서 바로 볼 수 있으며 페이지 전환, 하이퍼링크, 동영상, 사운드 클립, 애니메이션 및 내비게이션 단추 등의 대화형 요소를 포함할 수 있습니다.

FLA

내보낸 FLA 파일에는 몇 가지 대화형 요소만 포함됩니다. FLA 파일은 Flash Pro에서 열 수 있습니다. Flash Pro에서는 파일을 SWF로 내보내기 전에 사용자나 Flash 개발자가 고급 효과를 추가할 수 있습니다.

Flash로 내보내기
Flash로 내보내기

A. SWF로 바로 내보내기 B. Flash Professional에서 편집하기 위해 FLA로 내보내기 

웹에 사용할 대화형 SWF(Flash) 파일 만들기

SWF로 내보내면 Adobe Flash Player나 웹 브라우저에서 바로 볼 수 있는 대화형 파일을 만들어집니다. SWF 파일에는 InDesign에서 추가한 단추, 페이지 전환, 동영상 및 오디오 파일, 애니메이션 및 하이퍼링크가 포함될 수 있습니다. InDesign 문서를 기반으로 대화형 슬라이드 쇼나 플립북을 만들려면 SWF로 내보내는 것이 좋습니다.

SWF 파일을 만들기 전에 Flash Pro에서 문서를 편집하려면 SWF가 아닌 FLA로 내보내십시오. 웹에 사용할 FLA 파일 만들기 참조.

SWF 내보내기
SWF 내보내기

A. SWF로 내보내기 전 InDesign의 문서 B. 웹 브라우저의 대화형 SWF 파일 
  1. Flash로 내보낼 InDesign 문서를 만들거나 편집합니다. 내보낼 문서 설정에 대한 자세한 내용은 Flash 내보내기 문제를 참조하십시오.

    • 내보낸 SWF 파일의 페이지 간을 이동하는 데 사용하는 내비게이션 단추를 추가합니다. 개체를 그린 다음 [단추] 패널([창] > [대화형] > [단추] 선택)을 사용하여 이것을 단추로 변환하면 단추를 만들 수 있습니다. [샘플 단추] 패널을 사용하여 미리 정의된 내비게이션 단추를 문서로 드래그할 수도 있습니다. 자세한 내용은 단추 만들기를 참조하십시오.

    • 닦아내기, 흩어 뿌리기 등의 페이지 전환을 추가하려면 [페이지 전환] 패널([창] > [대화형] > [페이지 전환] 선택)을 사용합니다. SWF로 내보내는 경우 [대화형 페이지 말림 포함] 옵션을 선택하여 보는 사람이 페이지 모퉁이를 드래그하여 페이지를 넘기도록 할 수도 있습니다.

    • 모션 사전 설정을 추가하려면 [애니메이션] 패널([창] > [대화형] > [애니메이션] 선택)을 사용합니다. 자세한 내용은 애니메이션을 참조하십시오.

  2. 문서를 SWF 형식으로 내보내려면 파일 > 내보내기를 선택합니다. 

  3. 내보낸 파일에 다음에 내보낼 문서의 이름과 동일한 이름을 사용하려면 InDesign 문서 이름을 출력 파일 이름으로 사용을 선택합니다.

  4. 저장 유형(Windows) 또는 포맷(Mac OS) 메뉴에서 Flash Player(SWF)를 선택하고 저장을 클릭합니다.

  5. [SWF 내보내기] 대화 상자에서 옵션을 지정한 다음 [확인]을 클릭합니다. 자세한 내용은 SWF 내보내기 옵션을 참조하십시오.

SWF 파일을 내보내면 별도의 HTML 및 SWF 파일이 만들어집니다. SWF 파일에 동영상이나 사운드 클립이 있으면 리소스 폴더도 만들어집니다. 파일을 웹에 보내거나 업로드하려면 모든 에셋을 보내도록 해야 합니다.

SWF 내보내기 옵션

다음 옵션은 [SWF 내보내기] 대화 상자의 [일반] 및 [고급] 탭에 표시됩니다.

내보내기

현재 선택 항목, 문서의 모든 페이지 또는 페이지 범위 중에서 포함할 부분을 표시합니다. 내보낸 PDF 파일에서 사용하기 위해 내보낸 SWF 파일을 저장하려는 경우에는 [선택 항목]을 선택하는 것이 좋습니다. [범위]를 선택한 경우 페이지 범위를 지정합니다. 예를 들어 1-7페이지와 9페이지를 인쇄하려면 1-7, 9를 지정합니다. 자세한 내용은 인쇄할 페이지 지정을 참조하십시오.

HTML 파일 생성

이 옵션을 선택하면 SWF 파일을 재생하는 HTML 페이지가 생성됩니다. 이 옵션은 웹 브라우저에서 바로 SWF 파일을 미리 보려는 경우 특히 유용합니다.

내보낸 후 SWF 보기

이 옵션을 선택하면 기본 웹 브라우저에서 SWF 파일이 재생됩니다. 이 옵션은 HTML 파일을 생성한 경우에만 사용할 수 있습니다.

크기(픽셀)

SWF 파일의 크기를 백분율에 따라 조정할지, 지정한 모니터 크기에 맞출지 아니면 지정한 폭과 높이에 따라 조정할지 지정합니다.

배경

SWF의 배경을 투명하게 설정할지, 아니면 [색상 견본] 패널의 현재 [용지] 색상을 사용할지를 지정합니다. [투명]을 선택하면 [페이지 전환] 및 [대화형 페이지 말림] 옵션을 사용할 수 없습니다.

상호 작용 기능 및 미디어

내보낸 SWF 파일의 동영상, 사운드, 단추 및 애니메이션을 대화형으로 설정하려면 [모두 포함]을 선택합니다. 표준 상태의 단추와 비디오 포스터를 정적 요소로 포함하려면 [모양만]을 선택합니다. [모양만]을 선택하면 내보낼 때 레이아웃에 나타난 대로 애니메이션이 내보내집니다. [고급] 패널에서 [투명도 병합]을 선택하면 [모양만]이 선택됩니다.

페이지 전환

내보내기를 수행할 때 모든 페이지에 적용할 하나의 페이지 전환을 지정합니다. [페이지 전환] 패널을 사용하여 전환을 지정하는 경우 해당 설정을 사용하려면 [문서에서] 옵션을 선택합니다.

대화형 페이지 말림 포함

이 옵션을 선택하면 SWF 파일을 재생하는 사용자가 실제로 책장을 넘기는 것처럼 페이지 모퉁이를 드래그하여 넘길 수 있습니다.

프레임 속도

프레임 속도가 높을수록 애니메이션은 부드러워지지만 파일 크기가 커질 수 있습니다. 프레임 속도를 변경해도 재생 시간은 영향을 받지 않습니다.

텍스트

InDesign 텍스트 출력 방법을 지정합니다. [Flash Classic 텍스트]를 선택하면 검색 가능한 텍스트가 출력되며 이 경우 파일 크기가 가장 작습니다. [윤곽선으로 변환]을 선택하면 텍스트를 윤곽선으로 변환한 것처럼 텍스트가 일련의 매끄러운 직선으로 출력됩니다. [픽셀로 변환]을 선택하면 텍스트가 비트맵 이미지로 출력됩니다. 픽셀로 변환된 텍스트를 확대하면 고르지 않게 보일 수 있습니다.

페이지 래스터화

이 옵션은 모든 InDesign 페이지 항목을 비트맵으로 변환합니다. 이 옵션을 선택하면 SWF 파일이 더 커지며 확대 시 페이지 항목이 불규칙하게 나타날 수 있습니다.

투명도 병합

이 옵션은 SWF에서 활성 투명도를 제거하고 투명도 모양을 유지합니다. 하지만 이 옵션을 선택하면 내보낸 SWF 파일의 모든 상호 작용 기능이 제거됩니다.

압축

[자동]을 선택하면 InDesign에서 색상 및 회색 음영 이미지에 맞는 최적의 품질이 결정됩니다. 이 옵션을 선택하면 대부분의 파일에서 만족스러운 결과를 얻을 수 있습니다. 회색 음영이나 색상 이미지에는 [JPEG(손실)]를 선택하는 것이 좋습니다. JPEG 압축은 손실 압축이므로 이미지 데이터가 제거되고 이미지 품질이 저하될 수 있습니다. 하지만 이것을 사용하면 정보 손실을 최소화하면서 파일 크기를 줄일 수 있습니다. [JPEG] 압축은 데이터를 제거하므로 파일 크기를 훨씬 작게 만들 수 있습니다. [PNG(무손실)]를 선택하면 손실 압축을 하지 않고 파일을 내보냅니다.

참고:

SWF로 내보낼 때 투명 이미지의 이미지 품질이 손상된다면 [PNG(무손실)]를 선택하여 품질을 높입니다.

JPEG 품질

내보낸 이미지의 상세 정도를 지정합니다. 품질을 높게 하면 파일 크기가 커집니다. [압축]에서 [PNG(무손실)]를 선택하면 이 옵션이 흐리게 표시됩니다.

해상도

내보낸 SWF의 비트맵 이미지 해상도를 지정합니다. 내보낸 SWF의 픽셀 기반 내용을 보는 사람이 확대할 수 있도록 하려면 고해상도를 반드시 선택해야 합니다. 고해상도를 선택하면 파일 크기가 아주 커질 수 있습니다.

웹에서 사용할 FLA 파일 만들기

InDesign 문서를 FLA 파일 형식으로 내보내면 Adobe Flash® CS5 Professional에서 파일을 열어 내용을 편집할 수 있습니다. InDesign CS5의 FLA로 내보내기 형식은 InDesign CS4의 XFL 내보내기가 대체된 것입니다. 비디오, 오디오, 애니메이션 및 복잡한 상호 작용 기능을 편집 또는 추가하려면 Flash 작성 환경을 사용합니다.

InDesign 문서를 웹 브라우저에서 직접 열 수 있는 형식으로 바로 내보내려면 FLA가 아닌 SWF 형식을 사용합니다. 웹에 사용할 대화형 SWF(Flash) 파일 만들기를 참조하십시오.

FLA 내보내기
FLA 내보내기

A. FLA로 내보내기 전의 InDesign 문서 B. Flash Pro에서 연 FLA 파일 
  1. Flash로 내보낼 InDesign 문서를 만들거나 편집합니다. 내보낼 문서 설정에 대한 자세한 내용은 Flash 내보내기 문제를 참조하십시오.

  2. 문서를 FLA 형식으로 내보내려면 [파일] > [내보내기]를 선택합니다. [파일 형식](Windows) 또는 [형식](Mac OS) 메뉴에서 [Flash CS5 Professional(FLA)]을 선택하고 [저장]을 클릭합니다.

  3. [Flash CS5 Professional(FLA) 내보내기] 대화 상자에서 옵션을 지정한 다음 [확인]을 클릭합니다. 내보내기 옵션에 대한 자세한 내용은 FLA 내보내기 옵션을 참조하십시오.

  4. 내보낸 FLA 파일을 Flash Professional에서 엽니다.

FLA 내보내기 옵션

[Flash CS5 Professional(FLA) 내보내기] 대화 상자에는 다음 옵션이 표시됩니다.

내보내기

현재 선택 항목, 문서의 모든 페이지 또는 페이지 범위 중에서 포함할 부분을 표시합니다. [범위]를 선택한 경우 페이지 범위를 지정합니다. 예를 들어 1-7페이지와 9페이지를 인쇄하려면 1-7, 9를 지정합니다. 자세한 내용은 인쇄할 페이지 지정을 참조하십시오.

페이지 래스터화

이 옵션은 모든 InDesign 페이지 항목을 비트맵으로 변환합니다. 이 옵션을 선택하면 FLA 파일의 크기가 커지고 파일을 확대했을 때 페이지 항목이 고르지 않게 표시됩니다.

투명도 병합

이 옵션을 선택하면 모든 개체의 투명도가 병합됩니다. 병합된 개체에 대해서는 Adobe Flash Pro에서 애니메이션 효과를 사용하지 못할 수 있습니다.

크기(픽셀)

FLA 파일의 크기를 백분율에 따라 조정할지, 지정한 모니터 크기에 맞출지 아니면 지정한 폭과 높이에 따라 조정할지를 지정합니다.

상호 작용 기능 및 미디어

내보낸 FLA 파일에 동영상, 사운드, 단추 및 애니메이션을 포함하려면 [모두 포함]을 선택합니다. 문서에 다중 상태 개체가 포함되어 있는 경우 이 개체는 각 상태를 타임라인의 자체 프레임에 표시하는 동영상 클립 기호로 변환됩니다.

표준 상태의 단추와 비디오 포스터를 정적 요소로 포함하려면 [모양만]을 선택합니다. [모양만]을 선택하면 내보낼 때 레이아웃에 나타난 대로 애니메이션이 내보내집니다. [투명도 병합]을 선택하면 [모양만]이 선택됩니다.

텍스트

InDesign 텍스트 출력 방법을 지정합니다. Flash Professional의 풍부한 텍스트 레이아웃 프레임워크 특성을 활용하려면 [Flash TLF 텍스트]를 선택합니다. 이 옵션이 선택된 경우 [사전 하이픈 넣기 삽입 위치]를 선택하여 하이픈 넣기를 허용할 수 있습니다. [Flash Classic 텍스트]를 선택하면 검색 가능한 텍스트가 출력되며 이 경우 파일 크기가 작습니다. [윤곽선으로 변환]을 선택하면 텍스트를 윤곽선으로 변환한 것처럼 텍스트가 일련의 매끄러운 직선으로 출력됩니다. [픽셀로 변환]을 선택하면 텍스트가 비트맵 이미지로 출력됩니다. 픽셀로 변환된 텍스트를 확대하면 고르지 않게 보일 수 있습니다.

압축

[자동]을 선택하면 InDesign에서 색상 및 회색 음영 이미지에 맞는 최적의 품질이 결정됩니다. 이 옵션을 선택하면 대부분의 파일에서 만족스러운 결과를 얻을 수 있습니다. 회색 음영이나 색상 이미지에는 [JPEG(손실)]를 선택하는 것이 좋습니다. JPEG 압축은 손실 압축이므로 이미지 데이터가 제거되고 이미지 품질이 저하될 수 있습니다. 하지만 이것을 사용하면 정보 손실을 최소화하면서 파일 크기를 줄일 수 있습니다. [JPEG] 압축은 데이터를 제거하므로 파일 크기를 훨씬 작게 만들 수 있습니다. [PNG(무손실)]를 선택하면 손실 압축을 하지 않고 파일을 내보냅니다.

JPEG 품질

내보낸 이미지의 상세 정도를 지정합니다. 품질을 높게 하면 파일 크기가 커집니다. [압축]에서 [PNG(무손실)]를 선택하면 이 옵션이 흐리게 표시됩니다.

해상도

내보낸 FLA 파일의 비트맵 이미지 해상도를 지정합니다. 보는 사람이 픽셀 기반 내용을 확대할 수 있도록 하려면 고해상도를 반드시 선택해야 합니다. 고해상도를 선택하면 파일 크기가 아주 커질 수 있습니다.

Flash 내보내기 문제

SWF 또는 FLA 출력을 위한 InDesign 문서를 디자인할 때는 다음 요인을 고려해야 합니다.

문서 설정 문제

InDesign 페이지 변환 방식

SWF 또는 FLA로 내보내면 InDesign 스프레드는 슬라이드 쇼의 슬라이드처럼 타임라인의 개별 클립이 됩니다. 각 스프레드는 새 키프레임에 매핑됩니다. Flash Player에서 화살표 키를 누르거나 대화형 단추를 클릭하여 내보낸 문서의 스프레드를 탐색합니다.

참고:

웹에서 사용할 문서를 만드는 경우 [새 문서] 대화 상자의 [의도] 메뉴에서 [웹]을 선택합니다.

페이지 크기

문서를 만들 때 [새 문서] 대화 상자의 [페이지 크기] 메뉴에서 특정 해상도(예: 800 x 600)를 선택할 수 있습니다. 내보내기를 수행하는 동안 내보낸 SWF 또는 FLA 파일의 비율 또는 해상도를 조정할 수도 있습니다.

상호 작용 기능

내보낸 SWF 및 FLA 파일에는 단추, 페이지 전환, 하이퍼링크, 애니메이션 및 미디어 파일이 포함될 수 있습니다.

단추

내보낸 SWF 또는 FLA 파일에 있는 단추의 경우 [다음 페이지] 및 [이전 페이지] 동작은 Flash Player의 재생을 제어하는 데 특히 유용합니다. 하지만 대화형 PDF 파일에서 작동하는 일부 동작은 Flash Player에서 작동하지 않습니다. [단추] 패널에서 동작을 선택하는 경우 [PDF만] 섹션의 옵션을 선택하지 마십시오.

참고:

[다음 페이지로 이동] 및 [이전 페이지로 이동] 동작을 사용하여 서식 유지된 내비게이션 단추를 추가할 수 있습니다. [단추] 패널 메뉴에서 [샘플 단추]를 선택합니다. 자세한 내용은 샘플 단추 패널에서 단추 추가를 참조하십시오.

페이지 전환

페이지 전환은 모두 Flash Player에서 제대로 작동합니다. 내보내기 작업 중에는 페이지를 넘길 때 나타나는 페이지 전환 외에도 페이지 모서리를 드래그하여 페이지를 넘길 수 있도록 하는 [대화형 페이지 말림 포함]을 추가할 수 있습니다.

하이퍼링크

웹 사이트 링크 또는 문서 내의 다른 페이지로 이동하는 링크를 만듭니다. FLA 파일에서는 하이퍼링크가 끊어집니다.

동영상 및 사운드 클립

동영상 및 사운드 클립이 지원되는 형식인 경우 내보낸 SWF 파일에 포함됩니다. 지원되는 형식은 동영상의 경우 SWF, FLV, F4V 및 MP4이고 사운드 클립의 경우 MP3입니다.

FLA로 내보내는 경우에는 FLA 파일에 포스터 이미지만 포함됩니다. 지원되는 미디어 파일은 내보낸 FLA 파일과 같은 위치에 저장된 리소스 폴더에 표시됩니다.

변환 문제

색상

SWF 및 FLA 파일은 RGB 색상을 사용합니다. 문서를 SWF 또는 FLA로 내보내면 InDesign은 모든 색상 공간(예: CMYK 및 LAB)을 sRGB로 변환합니다. 별색을 동등한 RGB 원색으로 변환합니다.

투명도가 적용된 텍스트를 포함하는 아트워크에서 색상이 원치 않게 변경되지 않도록 하려면 [편집] > [투명도 혼합 공간] > [문서 RGB]를 선택합니다. 투명도가 적용된 이미지에서 원치 않는 색상 변경을 방지하려면 내보낼 때 손실 압축을 사용하지 마십시오.

텍스트

SWF 또는 FLA로 내보내는 경우 텍스트를 Flash 텍스트로 출력할지 아니면 윤곽선이나 픽셀로 변환할지를 결정할 수 있습니다. Flash Classic 텍스트로 내보낸 텍스트는 Adobe Flash CS5 Professional에서 FLA 파일을 열어서 계속 편집할 수 있으며, SWF 파일로 저장하면 웹 브라우저에서 검색할 수 있습니다.

이미지

이미지를 SWF 또는 FLA로 내보내는 경우, 내보내기를 수행하는 동안 이미지 압축, JPEG 품질 및 해상도 설정을 변경할 수 있습니다.

이미지를 FLA로 내보내는 경우, InDesign 문서에 여러 번 가져온 이미지는 공유 위치를 사용하는 단일 이미지 에셋으로 저장됩니다. InDesign 문서에 벡터 이미지가 많을 경우 내보낸 파일에 성능 문제가 발생할 수 있습니다.

파일 크기를 줄이려면 반복되는 이미지를 마스터 페이지로 가져오고 이미지를 복사하여 붙이지 않아야 합니다. 동일한 이미지를 문서로 여러 번 가져왔으며 변형하거나 자르지 않은 경우 파일의 사본 하나만 FLA 파일로 내보내집니다. 복사하여 붙인 이미지는 별도의 개체로 간주됩니다.

가져온 Illustrator 파일은 기본적으로 FLA 파일에서 단일 이미지로 처리되지만 복사하고 붙인 Illustrator 파일은 여러 개의 개별 개체를 생성합니다. 최상의 결과를 얻으려면 Illustrator 이미지를 Illustrator에서 복사하여 붙이는 것보다 PDF 파일로 가져오는 것이 좋습니다. 복사하여 붙이면 편집 가능한 패스가 여러 개 생성됩니다.

참고:

환경 설정 옵션을 변경하여 Illustrator 개체를 여러 개의 작은 벡터 대신 하나의 개체로 붙일 수 있습니다. Illustrator의 경우 [파일 처리] 및 [클립보드] 환경 설정에서 [PDF]를 선택하고 [AICB(투명도 지원 안함)]의 선택을 취소하십시오. InDesign의 경우 [클립보드 처리] 환경 설정에서 [붙일 때 PDF 우선]과 [클립보드에 PDF 복사]를 모두 선택하십시오.

투명도

SWF로 내보내기 전에 투명한 개체가 대화형 요소(예: 단추 또는 하이퍼링크)와 오버랩되지 않도록 해야 합니다. 투명도가 적용된 개체가 대화형 요소와 오버랩되면 내보내기 작업 중 상호 작용이 손실될 수 있습니다. FLA로 내보내기 전에 투명도를 병합할 수 있습니다.

경우에 따라 손실 압축을 선택하면 투명도가 적용된 이미지의 품질이 저하될 수도 있습니다. 내보내기를 수행할 때 품질을 높이려면 [PNG(무손실)]를 선택합니다.

3D 특성

내보낸 SWF 및 FLA 파일에서는 3D 특성이 지원되지 않습니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책