User Guide Cancel

Version 2019.1 | Substance 3D Sampler

  1. Substance 3D home
  2. Home
  3. Getting Started
    1. Getting Started overview
    2. Activation and licenses
    3. System requirements
    4. Shortcuts
    5. Importing Resources
    6. Report a bug
    7. Project Management
    8. Export
      1. Export overview
      2. Export Window
      3. Default Presets
        1. Default Presets overview
        2. Arnold 5
        3. Blender Cycles/Eevee
        4. Corona Renderer
        5. Enscape - Revit
        6. Keyshot9+
        7. Lens Studio
        8. Spark AR Studio
        9. Unity HDRP Standard
        10. Unity HDRP Specular
        11. Unity Standard
        12. Unity Specular
        13. Unreal Engine 4
        14. Redshift
        15. V-Ray Next
      4. Managing custom presets
      5. Managing Presets
  4. Interface
    1. Interface overview
    2. The Home Screen
    3. 2D and 3D Viewport
    4. Sidebars
    5. Panels
      1. Panels overview
      2. Project panel
      3. Assets panel
      4. Layers panel
      5. Properties panel
      6. Viewer Settings panel
      7. Shader Settings panel
      8. Channel Settings panel
      9. Metadata panel
      10. Export panel
      11. Physical Size Panel
      12. Exposed Parameters Panel
      13. Resources
    6. Tools and Widgets
      1. Tools and Widgets overview
      2. Sliders
      3. Color Picker
    7. Preferences
      1. Preferences overview
      2. Normal Format
      3. Layer Resolution
  5. Filters
    1. Filters overview
    2. Custom Filters
    3. Compound Filters
    4. Generators
      1. Generators overview
      2. Atlas Scatter
      3. Brickwall
      4. Cloth Weave
      5. Decal
      6. Embossing
      7. Embroidery
      8. Floor Tiles
      9. Gravel
      10. Panel
      11. Parquet
      12. Pattern
      13. Pavement
      14. Perforate
      15. Quilt Stitch
      16. Splatter
      17. Stonewall
      18. Surface Relief
      19. Weave
    5. Adjustments
      1. Adjustments overview
      2. Blur
      3. Brightness/Contrast
      4. Colorize
      5. Color Replace
      6. Color Variation
      7. Equalize
      8. Fill
      9. Hue/Saturation
      10. Invert
      11. Sharpen
      12. Vibrance
    6. Tools
      1. Tools overview
      2. Atlas Creator
      3. Atlas Splitter
      4. Channels Generation
      5. Channel Switch
      6. Clone Stamp
      7. Crop tool
      8. Delight (AI Powered)
      9. Height to AO
      10. Height to Normal
      11. Image To Material
      12. Make it Tile
      13. Match
      14. Multiangle To Material
      15. Normal to Height
      16. Paint Wrap *missing*
      17. PBR Validate
      18. Perspective Correction
      19. Tiling
      20. Transform
      21. Warp
      22. Warp Transform
      23. Upscale
    7. HDRI Tools
      1. HDRI Tools overview
      2. Color Temperature Adjustment
      3. Exposure
      4. Exposure Preview
      5. HDR Merge
      6. Line Light
      7. Nadir Extract
      8. Nadir Patch
      9. Panorama Patch
      10. Plane Light
      11. Shape Light
      12. Sphere Light
      13. Straighten Horizon
    8. Wear and Finish
      1. Wear and Finish overview
      2. Corrode
      3. Cracks
      4. Dirt
      5. Discarded Gums
      6. Dust
      7. Erode
      8. Metal Finish
      9. Moss
      10. Oxidate
      11. Paint
      12. Rust
      13. Scratch
      14. Snow
      15. Water
      16. Varnish
  6. Technical Support
    1. Technical Support overview
    2. Exporting the log file
    3. Configuration
      1. Configuration overview
      2. Retrieving the installation path
      3. Update Checker
      4. NVIDIA Driver Settings
      5. 3D CApture set-up on Linux *missing*
    4. Technical Issues
      1. Technical Issues overview
    5. Data or project issues
      1. Data or project issues overview
      2. Import Substance Alchemist projects in Substance 3D Sampler
    6. Filter issues
      1. Filter issues overview
      2. Image to Material and Delighter are missing
    7. Interface issues
      1. Interface issues overview
      2. Fonts are not displayed correctly
      3. Main interface is transparent
    8. Performance issues
      1. Performance issues overview
      2. Color picker takes long time to open the first time
      3. Interface lags when interacting with the layer stack or other elements
    9. Stability issues
      1. Stability issues overview
      2. Crash when exporting a material
      3. Crash when using the Image to Material or Delighter
    10. Startup issues
      1. Startup issues overview
      2. Application doesn't start on Linux
  7. Features and workflows
    1. Features and workflows overview
    2. 3D Capture
    3. Export parametric assets
    4. End to end Physical Size Workflow
    5. Texture Import
    6. Texture Generators
    7. Use As Bitmap
    8. Adobe Standard Material
  8. Pipeline and integrations
    1. Pipeline and integrations overview
    2. Environment variables
  9. Scripting and Development
    1. Scripting and Development overview
    2. Manage installed plugins and scripts
    3. Create a Plugin with Python and QML
    4. Create a Script with Python
      1. Create a Script with Python overview
      2. Example Scripts
  10. Release Notes
    1. Release Notes overview
    2. All Changes
    3. Version 4.3
    4. Version 4.2
    5. Version 4.1
    6. Version 4.0
    7. Version 3.4
    8. Version 3.3
    9. Old Versions
      1. Version 3.2
      2. Version 3.1
      3. Version 3.0
      4. Version 2020.3 (2.3)
      5. Version 2020.2 (2.2)
      6. Version 2020.1 (2.1)
      7. Version 2019.1
      8. Version 0.8.1
      9. Version 0.8.0
      10. Version 0.7.0
      11. Version 0.6.1
      12. 0.6.0
      13. 0.5.4
      14. 0.5.3
      15. 0.5.2
      16. 0.5.1
      17. 0.5.0

Version 2019.1

Substance Alchemist 2019.1 "Sesame" lets you share your assets with its new project management. The layer stack has been completely rebuild to improve the workflow. Additional controls and information have been added to the viewport. A new version of our delighter improves the quality and accuracy of your materials.

Release date: 4 November 2019

Note:
Note: Content produced with the beta version 0.8.1 or older is not compatible with version 2019.1. However nothing is lost and this data can still be accessed by launching version 0.8.1.

Major Features

New Welcome Screen

Substance Alchemist now has a welcome screen that allows you to quickly jump on your latest project but also to create new ones. The welcome screen also provides a few links to our existing platforms, such as Substance Academy.

Project Management

Version 2019.1 introduce the notion of projects, which can gather material collections. Projects can also be exported to be shared to other computers.

To learn more about projects, see: Project Management.

New Delighter

We improved our delighter, which is used to remove shadows from your photos. It now preserves details and the original colors of the various surfaces which should improve the accuracy of the generated materials.

New Layer Stack

The Layer Stack has been rebuild from scratch to expand its possibilities and actions. Notable changes are:

  • Materials and Masks can now be accessed directly via their dedicated icon
    When adding a material in the layer stack, it will now have a new mask icon. Clicking on this second icon will display the blending parameters of the material.

  • Blend mode can be directly changed from the toolbar
    From now on, when a Material layer is selected, its blending mode can be changed directly from the Layer Stack toolbar, without the need to click on the mask.

  • Assign bitmap to specific Scan inputs
    When imported bitmap to create your materials from scan, you can assign the right usage per bitmap.

Viewport Improvements

A few new features have been added to the viewport which improve its usage. These new settings can be accessed in the Viewer Settings panel.

  • Camera mode
    The camera projection mode allows to choose between Perspective and Orthographic.

  • Camera field of view
    You can now change the viewport's camera Field of View (FOV). Adjusting this value can help the visualizing realistically your materials. The Field of View can only be controlled when in Perspective projection mode.

  • Resolution and bit depth per channel
    The 2D view now displays the texture resolution and bit depth of each channel.

Release Notes

2019.1.4 Sesame

(Released January 30, 2020)

Added:

  • [Resources] Confirmation prompt when clearing a resources folder

Fixed:

  • [Layers] Move layers to two and more layers below or above
  • [Create] Allocation of enough VRAM budget to have good performances

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.3 Sesame

(Released January 28, 2020)

Added:

  • [Workflow] Support of multiple workflows
  • [Workflow] Support of PBR Specular Glossiness workflow
  • [Workflow] New Channel Settings panel
  • [Workflow] Workflow selection at project creation
  • [Channel Settings] Activate/Deactivate specific channel computation
  • [Channel Settings] Display list of custom channels available in the current material
  • [Channel Settings] Automatic computation of custom channels when required
  • [Channel Settings] Force/Block computation of custom channels
  • [Layers] New UI of material input placeholder in Atlas Scatter and Splatter filters
  • [Layers] Image Input parameter of a filter can be fed by underneath layers
  • [Layers] Display a notification when some layers are out of date
  • [Layers] Possibility to update to the latest version of outdated layers via the notification
  • [Project] New metadata fields at project creation
  • [Inspire] Generated variations are specific to a project
  • [2D View] Switch between the Layer inputs, layer outputs, and the material outputs
  • [Welcome Screen] Add Import project (.alch) option
  • [Preferences] New Preferences window to set cache location and analytics privacy settings
  • [UI] New UI buttons
  • [Performance] Overall improvement of the parallelization system
  • [Performance] Optimization of the number of material computes
  • [Engine] Substance Engine update
  • [Framework] Upgrade to Qt 5.13
  • [MacOS] Global improvements of macOS Catalina support
  • [Content] Adjustment filter - Normal intensity and invert parameters

Fixed:

  • [Layers] Unset Image Input parameter when deleting the layer
  • [Layers] Fix a crash when adding a clone patch layer
  • [Layers] Fix some crashes when blending layers stack materials in other layer stack materials
  • [Export] Channels selection for export is now respected
  • [Resources] Do not crash when navigating in the Resources panel
  • [Resources] Fix crash when importing corrupted Substance files
  • [Resources] Reduce the number of crashes when loading large folders
  • [Thumbnail] Thumbnail computation doesn't freeze the interface
  • [Image Import] Uniformization of image type supported across the application
  • [Preset] Save the description when creating a preset from an SBSAR
  • [Inspire] Fix image drag and drop
  • [Application] Fix crashes at exit
  • [Application] Fix crashes at the exit when exporting materials
  • [UI] Fixes and improvements
  • [UI] Rename temporary asset to "unsaved material"
  • [Content] Global update and cleaning of all filters

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.2 Sesame

(Released December 11, 2019)

Added:

  • [Workflow] Support of multiple workflows
  • [Workflow] Support of PBR Specular Glossiness workflow
  • [Workflow] New Channel Settings panel
  • [Workflow] Workflow selection at project creation
  • [Channel Settings] Activate/Deactivate specific channel computation
  • [Channel Settings] Display list of custom channels available in the current material
  • [Channel Settings] Automatic computation of custom channels when required
  • [Channel Settings] Force/Block computation of custom channels
  • [Layers] New UI of material input placeholder in Atlas Scatter and Splatter filters
  • [Layers] Image Input parameter of a filter can be fed by underneath layers
  • [Layers] Display a notification when some layers are out of date
  • [Layers] Possibility to update to the latest version of outdated layers via the notification
  • [Project] New metadata fields at project creation
  • [Inspire] Generated variations are specific to a project
  • [2D View] Switch between the Layer inputs, layer outputs, and the material outputs
  • [Welcome Screen] Add Import project (.alch) option
  • [Preferences] New Preferences window to set cache location and analytics privacy settings
  • [UI] New UI buttons
  • [Performance] Overall improvement of the parallelization system
  • [Performance] Optimization of the number of material computes
  • [Engine] Substance Engine update
  • [Framework] Upgrade to Qt 5.13
  • [MacOS] Global improvements of macOS Catalina support
  • [Content] Adjustment filter - Normal intensity and invert parameters

Fixed:

  • [Layers] Unset Image Input parameter when deleting the layer
  • [Layers] Fix a crash when adding a clone patch layer
  • [Layers] Fix some crashes when blending layers stack materials in other layer stack materials
  • [Export] Channels selection for export is now respected
  • [Resources] Do not crash when navigating in the Resources panel
  • [Resources] Fix crash when importing corrupted Substance files
  • [Resources] Reduce the number of crashes when loading large folders
  • [Thumbnail] Thumbnail computation doesn't freeze the interface
  • [Image Import] Uniformization of image type supported across the application
  • [Preset] Save the description when creating a preset from an SBSAR
  • [Inspire] Fix image drag and drop
  • [Application] Fix crashes at exit
  • [Application] Fix crashes at the exit when exporting materials
  • [UI] Fixes and improvements
  • [UI] Rename temporary asset to "unsaved material"
  • [Content] Global update and cleaning of all filters

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.1 Sesame

(Released November 26, 2019)

Added:

  • [Blend] New opacity Blend mode
  • [Engine] New Substance Engine version

Fixed:

  • [Layers] Fix crash while deleting a layer that is still computing
  • [Layers] Fix crash while removing the bottom layer
  • [Layers] Fix crash while the material name contains special characters
  • [Layers] Stop computing every filters that use a widget
  • [Layers] Avoid crash while using Clone Patch and Content Aware Fill filters
  • [Layers] Fix crash while drag and droping a filter in a splatter input slots
  • [Resources] Fix crash while linking local folders or importing resources in Substance Alchemist
  • [Collection] Fix crash while switching rapidly between materials
  • [UI] Fix crash while value is null or not valid in tiling, displacement sliders on the viewport
  • [Inspire] Fix crash while accessing the Inspire tab
  • [Inspire] Fix crash while inspiring on a just saved layers stack material
  • [Performance] Heavy Substance materials and Filters (Tiling) compute faster
  • [Help] Fix export log file
  • [Content] Randomizer filter works on all channels
  • [Content] Multiangle workflow takes all scans into account
  • [Content] AO Blend correct blending
  • [Content] Curvature Blend correct blending
  • [Content] Color ID Blend correct blending
  • [Content] Custom Mask Blend correct blending
  • [Content] Fix Adjustment filter for roughness modification
  • [Content] Fix Base Material filter for custom normal channels upload
  • [Content] Fix Custom Import pattern of the Embossing filter

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to Height filter can crash on MacOS

2019.1 Sesame

(Released November 04, 2019)

Added:

  • [Project] Creation of a project
  • [Project] Introduction of the .alch file format that contains project data
  • [Project] Export a .alch project containing the collections and their materials
  • [Project] Import a .alch project
  • [Project] Open recent projects
  • [Welcome Screen] A welcome screen is displayed at the launch
  • [Welcome Screen] Create a project from the welcome screen
  • [Welcome Screen] Access the list of all your projects in the welcome screen
  • [Welcome Screen] Quick links to access the documentation, the about popup and license management
  • [File Menu] Integration of a file Menu
  • [File Menu] Access the project commands from the File tab and the save of the layer stack
  • [File Menu] Access the undo and redo commands from the Edit tab
  • [File Menu] The previous help menu moved in the file menu under the Help tab
  • [Layers] New architecture of the layer stack
  • [Layers] New UI of the layer stack
  • [Layers] Select the blend mode directly on the toolbar
  • [Layers] Access separately the blend parameters and the material parameters
  • [Layers] Add materials directly in dedicated inputs of the Splatter filter in the layer stack
  • [Layers] Change scan order directly in the Image import layer
  • [Viewport] Control of the camera field of view
  • [Viewport] Possibility to switch between orthographic or perspective camera
  • [Viewport] Display resolution and bit depth information for each channel
  • [Resources] Base Materials is opened per default
  • [Cache] Locate your thumbnail cache folder
  • [Cache] Locate your render cache folder
  • [Panels] Material Settings panel is temporarily hidden
  • [Workflow] Specular/Glossiness temporarily deactivated
  • [MacOS] Catalina OS version notarization
  • [Content] New version of the Delighter filter
  • [Content] New Image Content Aware Fill filter
  • [Content] New Material Content Aware Fill filter
  • [Content] Transform filter has a safe transform option

Fixed:

  • All previous bugs related to Create are invalid today with new UI and architecture release
  • Tooltips don't hide the icons in the top bar (3D, 2D, 2D/3D)
  • [Content] Splatter filter accepts Atlas with complete height map
  • [Content] Transform filter works on images (scan1, scan2,...)

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to Height filter can crash on MacOS

Added:

  • [Blend] New opacity Blend mode
  • [Engine] New Substance Engine version

Added:

  • [Blend] New opacity Blend mode
  • [Engine] New Substance Engine version

Added:

  • [Workflow] Support of multiple workflows

 Adobe

Get help faster and easier

New user?