الصور المُصدَّرة ذات أبعاد غير صحيحة

تاريخ آخر تحديث 29 أكتوبر 2026

تعرّف على كيفية إصلاح مشكلة برنامج Adobe Photoshop على الكمبيوتر المكتبي عندما تُصدَّر الصور أو اللوحات الفنية بحجم أكبر بمقدار بكسل واحد عن المتوقع عند استخدام مربع الحوار Export As.

عندما تختلف أبعاد التصدير بمقدار بكسل واحد

بعد تصدير صورة أو لوحة فنية باستخدام ملف > تصدير > Export As، تصبح أبعاد التصدير أكبر بمقدار بكسل واحد عن المتوقع، سواء في العرض أو الارتفاع. على سبيل المثال، يؤدي تصدير مستند مقاسه 100 × 523 بكسل بنسبة مقياس 50% إلى ملف مُصدَّر بمقاس 51 × 262 بكسل بدلًا من النتيجة المتوقعة 50 × 262 بكسل.

يؤدي تغيير المقياس إلى كسور في وحدات البكسل

يؤدي تغيير مقياس المستند المصدر إلى ظهور كسر في وحدة البكسل. على سبيل المثال، 50% من 523 بكسل يساوي 261.5 بكسل، لذلك يقرّب Photoshop القيمة إلى عدد صحيح من وحدات البكسل ويزيد البعد الآخر بمقدار بكسل واحد.

ضبط أبعاد المصدر

احسب أبعاد التصدير المستهدفة قبل إنشاء المستند.

اضبط أبعاد المستند المصدر لتجنّب كسور وحدات البكسل عند المقياس المطلوب. غيّر المستند من 100 × 523 بكسل إلى 100 × 524 بكسل.

صدِّر بالمقياس الذي تريده.

يفيد هذا الأسلوب عندما يمكنك تعديل أبعاد المستند المصدر.

يتم تقريب أبعاد التصدير إلى قيمة غير صحيحة

تتضمن أبعاد التصدير المحسوبة كسرًا في وحدة البكسل يتم تقريبه إلى قيمة مختلفة من وحدات البكسل الصحيحة.

تعيين أبعاد دقيقة في Export As

حدد File > Export > Export As.

عيّن العرض أو الارتفاع أو المقياس على القيمة التي تريدها.

أدخل عرض لوحة الرسم وارتفاع لوحة الرسم لتعيين الأبعاد المستهدفة الدقيقة.

حدد تصدير لحفظ الملف بالأبعاد الدقيقة.

Delete cropped pixels

يؤدي حذف وحدات البكسل التي تم اقتصاصها إلى إزالة بيانات الصورة التي تم اقتصاصها، ما قد يحدّ من قدرتك على ضبط الاقتصاص عندما تكون أبعاد التصدير الدقيقة مطلوبة.

الاحتفاظ بوحدات البكسل التي تم اقتصاصها

حدد أداة اقتصاص من شريط الأدوات.

في شريط الخيارات، ألغِ تحديد حذف البكسلات المقتصة.

حدد منطقة الاقتصاص، واضغط على Enter لتطبيق الاقتصاص.

حدد ملف > تصدير > تصدير كـ لتصدير الصورة المقتصة.

يتيح لك الاحتفاظ بالبكسلات المقتصة ضبط منطقة الاقتصاص لاحقًا إذا احتجت إلى تحسين أبعاد التصدير.