Vanhentunut Mac-pakettisertifikaatti

Sertifikaatti, jolla Acrobatin ja Readerin Mac-asennusohjelma ja -päivityspaketit allekirjoitettiin vanheni 21.2.2017. Vanhentuneen sertifikaatin takia macOS on alkanut merkitä Acrobatin ja Readerin asennusohjelmia ja korjauspaketteja allekirjoittamattomiksi tai vanhentuneiksi.

Tämä vaikuttaa seuraaviin täysiin asennusohjelmiin ja korjauspaketteihin:

  • Acrobat DC Continuous -paketit ennen versiota 15.016.20041
  • Acrobat Reader DC Continuous -paketit ennen versiota 15.016.20039
  • Acrobat DC 2015 -paketit ennen versiota 15.006.30173
  • Acrobat Reader DC 2015 -paketit ennen versiota 15.006.30172
  • Acrobat- ja Reader XI -paketit ennen versiota 11.0.17

Kun yrität asentaa pakettia, jota tämä ongelma koskee, näkyviin tulee seuraavankaltainen varoitussanoma:

Asennuspaketin sertifikaatti on vanhentunut

Jos yrität asentaa paketteja komentoriviltä, Mac OS estää asennuksen ja se epäonnistuu.

Ratkaisu: lataa uusin versio tai korjauspaketti

Täydet asennusohjelmat

Tämä ongelma ei koske uusimpia täysiä asennusohjelmia. Jos täysi Acrobat-/Reader-asennusohjelmapaketti aiheuttaa varoituksen, lataa paketin uusin versio.

Linkitetyn sijainnin paketit on päivitetty, eikä niiden pitäisi aiheuttaa ongelmia. 

Korjauspaketit

Kaikkien sovellusten uusimmissa korjauspaketeissa ei esiinny tätä ongelmaa. Adobe suosittelee asentamaan uusimmat päivitykset:

Huomaa, että mikään näistä paketeista ei aiheuta mitään varoituksia ja ne voi asentaa ilman ongelmia. Jos kuitenkin erikseen haet paketin allekirjoittamiseen käytetyn sertifikaattiketjun napsauttamalla lukkokuvaketta, näet seuraavankaltaisen ilmoituksen siitä, että sertifikaatti on vanhentunut:

Sertifikaatin vanhentumisen virhesanoma

Paketin allekirjoitus on kuitenkin kelvollinen eikä käyttöjärjestelmä estä asennusta mitenkään. Voit tarkistaa tämän käyttämällä seuraavaa pkgutil-käskyä: 

pkgutil --check-signature <pkg-tiedoston polku>

Alla on malliksi Acrobatin 11.0.19-paketin tuottama käskyrivituloste, josta käy ilmi, että paketti on allekirjoitettu sertifikaatilla, jonka käyttöjärjestelmä katsoo luotettavaksi: 

Pkgutil-käsky

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö