Reader tai Acrobat latautuu jonkin muun sovelluksen sijaan, ja näkyviin tulee virheilmoitus tiedostotyypistä, jota ei tueta

Ongelma

Kun suoritat jonkin ohjelman Windows-käyttöjärjestelmässä, Adobe Reader tai Adobe Acrobat latautuu sen sijaan ja näyttää virheilmoituksen, jonka mukaan tiedostotyyppiä ei tueta Microsoft Windows Vistassa.

Syy

Sovellus tai virus on vahingoittanut Windowsin EXE-laajennusta; kun Windows pyysi määrittämään ohjelman, jolla EXE-tiedostot avataan, Adobe Reader tai Adobe Acrobat oli sovellusluettelossa ensimmäisenä, kun napsautit OK. Tällöin yhdistät Adobe Readerin tai Adobe Acrobatin .exe-laajennukseen, joka on tyypillisesti varattu sovellusten suorittamiseen.

Ratkaisu

Huomaa: Tämä on ongelma, jossa ulkopuolisen tahon sovellus korvaa EXE-laajennuksen Microsoft Windows Vistassa, eikä se johdu Adobe Reader- tai Adobe Acrobat -sovelluksesta tai Adobe Inc. Adoben tekninen tuki ei tarjoa tukea ulkopuolisten tahojen ohjelmistoille; tämä tieto tarjotaan vain osana palvelua.

Käytä Windows-rekisterieditoria EXE-luokan oletusasetusten palauttamiseen.

  1. Poista Adobe Reader tai Adobe Acrobat kohdasta Lisää tai poista ohjelmia.
    1. Valitse Käynnistä > kirjoita hakuruutuun appwiz.cpl ja paina Enter-näppäintä.
    2. Valitse Adobe Reader tai Adobe Acrobat ja napsauta Poista asennus. Jos saat asennuksen jälkeen kehotuksen käynnistää laite uudelleen, valitse Käynnistä uudelleen.
  2. Valitse Käynnistä, kirjoita hakukenttään regedit ja paina Enter-näppäintä.

Vastuuvapauslauseke: Tämä toimenpide sisältää Windows-rekisterin muokkauksen. Adobe ei tarjoa tukea sellaisen rekisterin muokkaamiseen, joka sisältää välttämättömiä järjestelmä- ja sovellustietoja. Varmista, että teet varmuuskopiot rekisteristä ennen kuin muokkaat sitä. Lisätietoja rekisteristä saat Windowsin dokumentoinnista tai ottamalla yhteyttä Microsoftiin.

  1. Siirry kohteeseen HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe.
  2. Napsauta kohdetta OpenWithList hiiren kakkospainikkeella ja valitse Poista.
  3. Napsauta kohdetta UserChoice hiiren kakkospainikkeella ja valitse Poista.
  4. Sulje Regedit.
  5. Asenna Adobe Reader tai Adobe Acrobat uudelleen.

Lisätietoja

Adoben tekninen tuki on jäljittänyt tämän ongelman kahteen tuotteeseen, jotka saattavat olla syynä ongelmaan: Intuitin päivityksenhallinta (Quickbookit) ja Corelin päivityksenhallinta (Wordperfect). Saat lisätietoja näistä tuotteista ottamalla yhteyttä tuotteesi mukaan joko Intuit Corporationiin tai Corel Corporationiin.

Pyydä apua nopeammin ja helpommin

Oletko uusi käyttäjä?