Ongelma
Kun suoritat jonkin ohjelman Windows-käyttöjärjestelmässä, Adobe Reader tai Adobe Acrobat latautuu sen sijaan ja näyttää virheilmoituksen, jonka mukaan tiedostotyyppiä ei tueta Microsoft Windows Vistassa.
Syy
Sovellus tai virus on vahingoittanut Windowsin EXE-laajennusta; kun Windows pyysi määrittämään ohjelman, jolla EXE-tiedostot avataan, Adobe Reader tai Adobe Acrobat oli sovellusluettelossa ensimmäisenä, kun napsautit OK. Tällöin yhdistät Adobe Readerin tai Adobe Acrobatin .exe-laajennukseen, joka on tyypillisesti varattu sovellusten suorittamiseen.
Ratkaisu
Huomaa: Tämä on ongelma, jossa ulkopuolisen tahon sovellus korvaa EXE-laajennuksen Microsoft Windows Vistassa, eikä se johdu Adobe Reader- tai Adobe Acrobat -sovelluksesta tai Adobe Inc. Adoben tekninen tuki ei tarjoa tukea ulkopuolisten tahojen ohjelmistoille; tämä tieto tarjotaan vain osana palvelua.
Käytä Windows-rekisterieditoria EXE-luokan oletusasetusten palauttamiseen.
-
Poista Adobe Reader tai Adobe Acrobat kohdasta Lisää tai poista ohjelmia.
-
Valitse Käynnistä > kirjoita hakuruutuun appwiz.cpl ja paina Enter-näppäintä.
-
Valitse Adobe Reader tai Adobe Acrobat ja napsauta Poista asennus. Jos saat asennuksen jälkeen kehotuksen käynnistää laite uudelleen, valitse Käynnistä uudelleen.
-
-
Valitse Käynnistä, kirjoita hakukenttään regedit ja paina Enter-näppäintä.
Vastuuvapauslauseke: Tämä toimenpide sisältää Windows-rekisterin muokkauksen. Adobe ei tarjoa tukea sellaisen rekisterin muokkaamiseen, joka sisältää välttämättömiä järjestelmä- ja sovellustietoja. Varmista, että teet varmuuskopiot rekisteristä ennen kuin muokkaat sitä. Lisätietoja rekisteristä saat Windowsin dokumentoinnista tai ottamalla yhteyttä Microsoftiin.
-
Siirry kohteeseen HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe.
-
Napsauta kohdetta OpenWithList hiiren kakkospainikkeella ja valitse Poista.
-
Napsauta kohdetta UserChoice hiiren kakkospainikkeella ja valitse Poista.
-
Sulje Regedit.
-
Asenna Adobe Reader tai Adobe Acrobat uudelleen.
Lisätietoja
Adoben tekninen tuki on jäljittänyt tämän ongelman kahteen tuotteeseen, jotka saattavat olla syynä ongelmaan: Intuitin päivityksenhallinta (Quickbookit) ja Corelin päivityksenhallinta (Wordperfect). Saat lisätietoja näistä tuotteista ottamalla yhteyttä tuotteesi mukaan joko Intuit Corporationiin tai Corel Corporationiin.