Problem

Po zalogowaniu się na konto danego użytkownika na komputerze Macintosh lub komputerze z systemem operacyjnym Windows 7 lub nowszym aplikacja Adobe zachowuje się w nieoczekiwany sposób. Przykładowo: aplikacja nie uruchamia się, polecenia są wykonywane nieprawidłowo, występują błędy lub aplikacja nieoczekiwanie kończy pracę. Problemy te nie występują po zalogowaniu do nowego lub innego konta użytkownika.

Zanim zaczniesz

Mac OS

Przed rozpoczęciem wykonywania operacji opisanych w tym dokumencie wykonaj kopię zapasową dysku startowego.

Po wykonaniu niektórych kroków opisanych w tym dokumencie w aplikacji Finder wyświetlane jest okno uwierzytelniania. Gdy to okno zostanie wyświetlone, wprowadź odpowiednia nazwę użytkownika i hasło administratora konta użytkownika, i kliknij przycisk OK.

Nieoczekiwane zachowania aplikacji na kontach użytkowników mogą być powodowane przez wiele czynników. W tym dokumencie opisano tylko najczęstsze powody. Aby uzyskać dodatkową pomoc w rozwiązywaniu problemów dotyczących konta użytkownika, skontaktuj się z pomocą techniczną Apple.

Windows

Przed rozpoczęciem wykonywania operacji opisanych w tym dokumencie wykonaj kopię zapasową dysku systemowego.

Te zadania niekiedy mogą powodować wyświetlenie okna dialogowego Kontrola konta użytkownika z monitem o zezwolenie na kontynuowanie. Zanim zdecydujesz się na kontynuowanie, przeczytaj dokładnie informacje zawarte w tym oknie dialogowym. Anulowanie tego okna dialogowego uniemożliwia kontynuowanie wykonywania zadania.

Niektóre operacje opisane w tym dokumencie dotyczą folderów ukrytych. Domyślnie w programie Eksplorator Windows pliki i foldery ukryte nie są wyświetlane. Aby wyświetlić ukryte foldery, zapoznaj się z artykułem Wyświetlanie ukrytych plików, ukrytych folderów i rozszerzeń nazwy pliku | Windows XP | Vista | Windows 7.

Nieoczekiwane zachowania aplikacji na kontach użytkowników mogą być powodowane przez wiele czynników. W tym dokumencie opisano tylko najczęstsze powody. Aby uzyskać dodatkową pomoc w rozwiązywaniu problemów dot. kont użytkowników, skontaktuj się z producentem komputera lub przejdź do witryny pomocy firmy Microsoft pod adresem http://support.microsoft.com.

Rozwiązania

Zaloguj się na konto użytkownika, w przypadku którego aplikacja Adobe zaczęła działać w nieoczekiwany sposób. Wykonaj następujące czynności w podanej kolejności:

Mac OS

1. Zapewnij uprawnienia do zapisu i odczytu w odpowiednich folderach.

Upewnij się, że w przypadku konta użytkownika zapewniono uprawnienia do zapisu i odczytu w następujących folderach:

  • /Applications/Adobe
  • /Applications/.AdobePatchFiles (zasób jest ukryty, użyj polecenia polecenie Idź > Idź do katalogu)
  • /Applications/Utilities/Adobe
  • /Library/Application Support/Adobe
  • /Library/Preferences/com.adobe
  • /Users/[nazwa użytkownika]/Library/Application Support/Adobe
  • /Users/[nazwa użytkownika]/Library/Caches/Adobe
  • /Users/[nazwa użytkownika]/Library/Caches/com.adobe
  • /Users/[nazwa użytkownika]/Library/Preferences/Adobe
  • /Users/[nazwa użytkownika]/Library/Preferences/com.adobe

Po zapewnieniu uprawnień należy zastosować zmiany, wylogowując się z konta użytkownika i ponownie logując lub ponownie uruchamiając komputer.

2. Odtwórz pliki preferencji danego konta w aplikacji Adobe.

W przypadku aplikacji Adobe niestandardowe ustawienia użytkownika są przechowywane w plikach preferencji. Każde konto użytkownika dysponuje osobnym zestawem plików preferencji.

Jeśli aplikacja Adobe zaczęła działać w nieoczekiwany sposób tylko w przypadku danego konta użytkownika, przyczyną mogą być uszkodzone plik preferencji aplikacji. W aplikacji Adobe można wymusić utworzenie nieuszkodzonych plików preferencji, zmieniając nazwę aktualnego pliku preferencji. Niektóre aplikacje Adobe przechowują kilka plików preferencji w folderze. W przypadku takich aplikacji można zmienić nazwę folderu.

Niektóre aplikacje Adobe zapisują preferencje w folderach i niezależnych plikach. Przykładowo: program Adobe Photoshop CS4 korzysta z pliku preferencji o nazwie com.adobe.Photoshop.plist i folderu preferencji o nazwie Adobe Photoshop CS4 Settings. Aby wymusić w programie Photoshop CS4 utworzenie nieuszkodzonych plików preferencji, należy zmienić nazwę pliku i folderu. Przykładowo: zmień nazwy na Old com.adobe.Photoshop.plist i Old Adobe Photoshop CS4 Settings.

Ogólnie w aplikacjach Adobe foldery i pliki preferencji są przechowywane w jednym z poniższych położeń (lub w obydwu):

  • /Users/[nazwa użytkownika]/Library/Preferences
  • /Users/[nazwa użytkownika]/Library/Preferences/Adobe
  • /Users/[nazwa użytkownika]/Library/Application Support/Adobe

Ważne: Zgodnie z ustawieniami firmy Apple folder biblioteki użytkownika jest domyślnie ukryty po wprowadzeniu wersji systemu Mac OS X 10.7. Jeśli musisz uzyskać dostęp do plików znajdujących się w ukrytym folderze biblioteki w celu rozwiązywania problemów powiązanych z programem Adobe, zobacz temat Jak uzyskać dostęp do ukrytych plików biblioteki użytkownika.

W przypadku niektórych aplikacji Adobe dodatkowe pliki preferencji są przechowywane w innych położeniach. Przykładowo: w programie Adobe Premiere Pro CS4 dodatkowe pliki preferencji są zapisywane w folderach o nazwach Styles, Settings i Layouts. Te pliki znajdują się w położeniu /Users/[nazwa użytkownika]/Documents/Adobe/Premiere Pro/4.0.

Aby określić dokładne nazwy i położenia folderów i plików preferencji aplikacji Adobe, w przypadku której rozwiązywane są problemy, przejdź do witryny www.adobe.com/pl/support. Przeszukaj bazę wiedzy pomocy technicznej pod kątem terminu „preferencje” oraz nazwy i wersji aplikacji. Następnie zapoznaj się z dokumentem „Błędy systemowe i zawieszanie aplikacji” (lub inne dokumenty) wyświetlonym w wynikach wyszukiwania.

Aby ponownie utworzyć pliki preferencji aplikacji Adobe, wykonaj następujące czynności:

  1. Zakończ aplikację Adobe.
  2. Zmień nazwę plików preferencji i folderów w przypadku aplikacji Adobe.
  3. Otwórz aplikację Adobe. Pliki preferencji zostaną utworzone w aplikacji.

Po ponownym utworzeniu plików preferencji i folderów spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że jego przyczyną nie jest uszkodzony plik preferencji. Aby przywrócić ustawienia niestandardowe konta użytkownika, należy usunąć nowe pliki preferencji i foldery. Następnie przywróć oryginalne nazwy wszystkich pozycji, które zostały zmienione.

Jeśli problem już nie występuje, przyczyną był uszkodzony plik preferencji. Ustawienia niestandardowe powiązane z poprzednimi plikami preferencji zostaną utracone.

3. Rozwiąż problemy dotyczące danych czcionek.

Czcionki w systemie Mac OS mogą być zainstalowane dla wszystkich kont użytkowników lub tylko dla określonego konta użytkownika. Pliki czcionek dla określonego konta znajdują się w położeniu /Users/[nazwa użytkownika]/Library/Fonts.

Jeśli aplikacja Adobe zaczęła działać w nieoczekiwany sposób tylko w przypadku danego konta, przyczyną może być uszkodzony plik czcionki zainstalowanej tylko w danym koncie.

Za pomocą aplikacji Zeszyt czcionek dostępnej w systemie Mac OS X tymczasowo wyłącz wszystkie czcionki związane tylko z danym kontem. Po wyłączeniu określonych czcionek wyszukaj i usuń pliki pamięci podręcznej czcionek Adobe. Wykonaj następujące czynności:

  1. Zakończ działanie wszystkich otwartych aplikacji.
  2. Jeśli standardowo użytkownik korzysta z narzędzia do zarządzania czcionkami dostarczanego przez inna firmę, takie narzędzie należy tymczasowo wyłączyć. Instrukcje można znaleźć w dokumentacji narzędzia.
  3. Otwórz program Zeszyt czcionek. (Domyślnie program Zeszyt czcionek znajduje się w folderze Applications).
  4. W kolumnie Kolekcja wybierz pozycję Użytkownik. Następnie wykonaj jedną z następujących czynności:

    • Jeśli kolumna Czcionki jest pusta, dla tego konta użytkownika nie zainstalowano czcionek. Pomiń pozostałe czynności i przejdź do Zadania 3.
    • Jeśli w kolumnie Czcionka widoczna jest co najmniej jedna czcionka, wybierz pozycje Edycja > Wyłącz „Użytkownika”.
  5. W programie Finder wybierz kolejno pozycje Plik > Znajdź. Opcje wyszukiwania są wyświetlane w górnej części okna programu Finder.

  6. Wyszukaj pliki pamięci podręcznej czcionek Adobe, ustawiając poniższe opcje wyszukiwania:

    • Mac OS X v.10.4.x: W górnym wierszu opcji wyszukiwania wybierz pozycję Główna. W drugim wierszu w dwóch menu podręcznych wybierz pozycje Nazwa i Rozpoczyna się od. Następnie ciąg AdobeFnt wpisz w polu tekstowym po prawej stronie opcji Rozpoczyna się od.
    • Mac OS X v.10.5.x lub nowszy: W górnym wierszu opcji wyszukiwania wybierz nazwę konta użytkownika (ujętą w cudzysłów). W drugim wierszu w dwóch menu podręcznych wybierz pozycje Nazwa i Rozpoczyna się od. Następnie ciąg AdobeFnt wpisz w polu tekstowym po prawej stronie opcji Rozpoczyna się od.
  7. W wynikach wyszukiwania usuń wszystkie pliki, których nazwy rozpoczynają się ciągiem AdobeFnt i kończą ciągiem .lst.

  8. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że jego źródłem nie jest czcionka dostępna w danym koncie. Ponownie włącz daną czcionkę, otwierając program Zeszyt czcionek, wybierając pozycję Użytkownik w kolumnie Kolekcja i wybierając polecenie Edycja > Włącz. Przejdź do Zadania 3.

Jeśli problem już nie występuje, oznacza to, że jego źródłem była czcionka dostępna w danym koncie. Aby określić, który plik czcionki odpowiada za występowanie problemu, wykonaj następujące czynności:

  1. Otwórz program Zeszyt czcionek.

  2. W kolumnie Kolekcja wybierz pozycję Użytkownik.

  3. W kolumnie Czcionka wybierz jedną z wyłączonych czcionek.

  4. Wybierz polecenie Edycja > Włącz [Nazwa czcionki].

  5. Otwórz aplikację Adobe i spróbuj odtworzyć problem. Następnie wykonaj jedną z następujących czynności:

    • Jeśli problem nadal występuje, zamknij aplikację Adobe i powtórz kroki od 3 do 5.
    • Jeśli problem nie wystąpi, oznacza to, że przyczyną była czcionka, która teraz została ponownie włączona. Nie włączaj tej czcionki lub usuń ją i skontaktuj się z jej dostawcą, aby uzyskać poprawioną wersję.

4. Usuń pliki pamięci tymczasowej Adobe dotyczące danego konta.

Niektóre aplikacje Adobe tworzą tymczasowe pliki danych nazywane pliki plikami pamięci tymczasowej. Zbyt liczne lub uszkodzone pliki pamięci tymczasowej dostępne na koncie użytkownika mogą powodować występowanie nieoczekiwanych zachowań aplikacji Adobe.

Wykonaj następujące czynności:

  1. Zakończ działanie wszystkich aplikacji firmy Adobe.

  2. W programie Finder przejdź do położenia /Users/[nazwa użytkownika]/Library/Caches.

  3. W folderze Cache usuń folder Adobe.

  4. Usuń wszystkie inne foldery znajdujące się w folderze Caches pochodzące z aplikacji Adobe powodującej problemy.

  5. Usuń wszystkie inne foldery znajdujące się w folderze Caches pochodzące ze składników aplikacji Adobe powodującej problemy. Przykładowo: w celu rozwiązania problemów z programem Photoshop CS4 należy również usunąć folder Adobe Camera Raw znajdujący się w folderze Caches.

  6. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, przejdź do kolejnego zadania.

5. Rozwiąż problemy dotyczące danych elementów logowania.

Elementy logowania to aplikacje lub dokumenty, które są otwierane automatycznie po zalogowaniu się do konta użytkownika. (Są one otwierane automatycznie po uruchomieniu komputera, jeśli włączona jest funkcja automatycznego logowania). Niektóre elementy logowania są ukrywane po otwarciu. Gdy aplikacja Adobe zachowuje się nieoczekiwanie w ramach jednego konta, prawdopodobnie jeden z elementów logowania w tym koncie jest uszkodzony, nie działa poprawnie lub nie współpracuje z używaną aplikacją Adobe.

Aby ustalić, czy to element logowania w koncie użytkownika jest przyczyną problemu w aplikacji Adobe, wykonaj następujące czynności:

  1. Wybierz menu Apple > Wyloguj się [nazwa użytkownika].

  2. W oknie dialogowym potwierdzenia kliknij przycisk Wyloguj się. Po chwili zostanie wyświetlone okno logowania.

  3. W oknie logowania wybierz nazwę konta użytkownika, z którym związane są problemy.

  4. W polu tekstowym Hasło wpisz hasło konta użytkownika; alenie naciskaj jeszcze klawisza Enter ani nie klikaj przycisku Zaloguj się.

  5. Przytrzymaj wciśnięty klawisz Shift i kliknij przycisk Zaloguj się. Zwolnij klawisz Shift, gdy pojawi się Dock. Elementy logowania będą wyłączone do momentu wylogowania (lub ponownego uruchomienia komputera).

  6. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że przyczyną nie był element logowania. Ponownie włącz elementy logowania, wylogowując się (za pomocą menu Apple > Wyloguj się [Nazwa użytkownika]). Następnie zaloguj się ponownie na to samo konto bez przytrzymania klawisza Shift. Przejdź do Zadania 5.

Jeśli problem nie wystąpi, oznacza to, że przyczyną był element logowania. Aby określić, który element logowania odpowiada za występowanie problemu, wykonaj następujące czynności:

Jeśli problem nadal występuje, oznacza to, że jego źródłem nie jest czcionka dostępna w danym koncie. Ponownie włącz daną czcionkę, otwierając program Zeszyt czcionek, wybierając pozycję Użytkownik w kolumnie Kolekcja i wybierając polecenie Edycja > Włącz. Przejdź do Zadania 3.

Jeśli problem już nie występuje, oznacza to, że jego źródłem była czcionka dostępna w danym koncie. Aby określić, który plik czcionki odpowiada za występowanie problemu, wykonaj następujące czynności:

  1. Wybierz menu Apple > Wyloguj się [Nazwa użytkownika].

  2. Zaloguj się ponownienato samo konto. Nie przytrzymuj klawisza Shift.

  3. Wybierz kolejno opcje Apple > Preferencje systemowe.

  4. W oknie Preferencje systemowe i kliknij opcję Konta.

  5. Jeśli ikona kłódki w dolnej części okna jest zamknięta, kliknij ja, aby uwierzytelnić.

  6. Wybierz konto użytkownika, na którym występują problemy.

  7. Kliknij kartę Elementy logowania.

  8. Przygotuj listę bieżących elementów logowania.

  9. Wybierz element logowania i naciśnij klawisz Delete.

  10. Otwórz aplikację Adobe i spróbuj odtworzyć problem. Następnie wykonaj jedną z następujących czynności:

    • Jeśli problem nadal występuje, zamknij aplikację Adobe, a następnie powtórz kroki 9 i 10.
    • Jeśli problem nie wystąpi, oznacza to, że przyczyną był element logowania, który teraz został usunięty. Skontaktuj się z wydawcą tego elementu logowania w celu uzyskania informacji o dostępności zaktualizowanej wersji. Przywróć pozostałe elementy logowania, przeciągając ich ikony do obszaru Elementy logowania w sekcji Preferencje systemowe. Lub ponownie zainstaluj aplikację powiązaną z danym elementem logowania.

6. Zresetuj ustawienia dostępu w przypadku folderu Library na koncie użytkownika.

Wykonaj to zadanie wyłącznie, gdy konto, w którym rozwiązywane są problemy, jest kontem administratora i jest chronione hasłem.

Każdy plik i folder na komputerze z systemem Mac OS X jest opatrzony niepowtarzalnymi ustawieniami własności i uprawnień Unix. Te ustawienia określają, które konta użytkowników dysponują dostępem do plików i folderów.

Aplikacja Adobe może się zachowywać nieoczekiwanie w ramach danego konta, jeśli ustawienia dostępowe folderu Library (lub jego podfolderu) są uszkodzone lub nieprawidłowo ograniczone. Za pomocą poleceń Unix chmod i chown można naprawić te ustawienia. Wykonaj następujące czynności:

  1. W programie Finder wybierz opcję Przejdź > Strona główna. W oknie programu Finder dostępnym na pierwszym planie zostanie wyświetlony folder główny konta użytkownika. Zapisz nazwę tytułu tego okna programu Finder. Ta nazwa stanowi „krótkąnazwę użytkownika” konta użytkownika. (Krótkanazwa użytkownikajest wymagana do wykonania operacji w kroku 3).

  2. Otwórz aplikację Terminal dostępną domyślnie w położeniu /applications/utilities.

  3. Za pomocą jednego z poniższych przykładowych poleceń wpisz rzeczywiste polecenie w oknie programu Terminal i naciśnij klawisz Return. (Po wciśnięciu klawisza Return zostanie wyświetlony monit o hasło. Wpisz hasło do konta użytkownika i ponownie naciśnij klawisz Return. Podczas wpisywania hasła nie są wyświetlane żadne znaki, nawet znaki gwiazdki. To zachowanie jest normalne).

    Ważne: Wszystkie poniższe polecenia stanowią szablony, a nie właściwe polecenia, które należy wpisać. W rzeczywistym wprowadzanym poleceniu ciąg nazwa użytkownika należy zastąpić krótką nazwą określoną w Kroku 1. Wpisz krótszą nazwę użytkownika, stosując tylko małe litery. (W systemie Mac OS X v10.4.x wpisz krótką nazwę dwukrotnie, oddzielając ją średnikiem. (W systemie Mac OS X v10.5.x wpisz krótką nazwę, średnik i ciąg staff).

    Wzory poleceń dla Mac OS X v.10.4.x:


    sudo chown-R nazwa użytkownika:nazwa użytkownika~/Biblioteka

    Wzory poleceń dla Mac OS X v.10.5.x:

    sudo chown-R nazwa użytkownika:staff~/Biblioteka

  4. Poniższe polecenie wpisz dokładnie w takiej formie jak przedstawiono i naciśnij klawisz Return.

    sudo chmod -R 700 ~/Library

  5. Zamknij Terminal.

  6. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, przejdź do kolejnego zadania.

7. Napraw dysk startowy.

Uszkodzenia dysku wpływające tylko na określone konto użytkownika mogą powodować niespodziewane zachowania aplikacji Adobe działającej na tym koncie.

Wykonaj poniższe kroki, jeśli dysponujesz systemowym dyskiem instalacyjnym Mac OS X dostarczonym wraz z komputerem. Jeśli dysk jest niedostępny, dysk startowy można naprawić, za pomocą polecenia fsck wpisanego w programie Terminal. Do naprawy można także użyć narzędzia innej firmy. Instrukcje na temat korzystania z polecenia fsck zawarto w artykule TS1417 w witrynie pomocy technicznej Apple. Instrukcje dotyczące korzystania z narzędzi naprawczych innych firm dostępne są w dokumentacjach tych narzędzi.

  1. Włóż płytę instalacyjną Mac OS X do napędu optycznego w komputerze.
  2. Wybierz menu Apple > Uruchom ponownie.
  3. Po dźwięku początkowym na klawiaturze przytrzymaj klawisz C.
  4. Gdy zostanie wyświetlone okno początkowe z paskiem postępu, puść klawisz C.
  5. Jeśli w instalatorze systemu Mac OS X zostanie wyświetlony monit o wybór języka, wybierz preferowany język.
  6. Po wyświetleniu menu instalatora (w lewej górnej części ekranu) wybierz polecenia Instalator > Narzędzie dyskowe.
  7. W oknie Narzędzia dyskowego po lewej stronie wybierz dysk startowy.
  8. Kliknij kartę Reanimacjapopo prawej stronie.

  9. Kliknij przycisk Napraw dysk.

  10. Jeśli proces naprawy zakończy się z informacją o naprawieniu błędów na dysku, powtórz krok 9. Gdy proces naprawy zakończy się bez żądnych błędów, otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, przejdź do kolejnego zadania.

8. Użyj nowego konta użytkownika.

Jeśli aplikacja nadal wykazuje nieoczekiwane zachowanie na określonym koncie użytkownika, skopiuj (lub przenieś) wszystkie pliki osobiste do nowego konta użytkownika. Nowego konta używaj jako standardowego konta.

Aby uzyskać pomoc dotyczącą kopiowania plików osobistych do nowego konta, skontaktuj się z pomocą techniczną Apple.

Windows

1. Zapewnij uprawnienia do zapisu i odczytu w odpowiednich folderach.

Upewnij się, że w przypadku konta użytkownika zapewniono uprawnienia do zapisu i odczytu w następujących folderach:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. Odtwórz pliki preferencji danego konta w aplikacji Adobe.

W przypadku aplikacji Adobe niestandardowe ustawienia użytkownika są przechowywane w plikach preferencji. Każde konto użytkownika dysponuje osobnym zestawem plików preferencji.

Jeśli aplikacja Adobe zaczęła działać w nieoczekiwany sposób tylko w przypadku danego konta użytkownika, przyczyną mogą być uszkodzone plik preferencji aplikacji. W aplikacji Adobe można wymusić utworzenie nieuszkodzonych plików preferencji, zmieniając nazwę folderu zawierającego pliki preferencji.

Przykładowo: programie Adobe Premiere Pro CS4 pliki preferencji są zapisywane w folderze o nazwie 4.0 znajdującym się w położeniu C:\Users\[nazwa użytkownika]\AppData\Roaming\Adobe\Premiere Pro. Aby w programie Adobe Premiere Pro CS4 odtworzyć pliki preferencji, zmień nazwę folderu 4.0 (na przykład na Stara wersja 4.0).

Ogólnie w aplikacjach Adobe foldery i pliki preferencji są przechowywane w jednym z poniższych położeń (lub obydwu):

  • C:\Users\[nazwa użytkownika]\AppData\Roaming\Adobe
  • C:\Users\[nazwa użytkownika]\AppData\Local\Adobe

W przypadku niektórych aplikacji Adobe dodatkowe pliki preferencji są przechowywane w innych położeniach. Przykładowo: w programie Adobe Premiere Pro CS4 dodatkowe pliki preferencji są zapisywane w folderach o nazwach Styles i Layouts w położeniu C:\Users\[nazwa użytkownika]\Documents\Adobe\Premiere Pro\4.0.

Aby określić dokładne nazwy i położenia folderów zawierających foldery preferencji aplikacji Adobe, w przypadku której rozwiązywane są problemy, przejdź do witryny www.adobe.com/support.Przeszukaj bazę wiedzy pomocy technicznej pod kątem terminu „preferencje” oraz nazwy i wersji aplikacji. Następniezapoznaj sięz dokumentem „Błędy systemowe i zawieszanie aplikacji” (lub inne dokumenty) wyświetlonym w wynikach wyszukiwania.

Aby ponownie utworzyć pliki preferencji aplikacji Adobe, wykonaj następujące czynności:

  1. Zamknij aplikację Adobe.

  2. Zmień nazwę folderu preferencji aplikacji Adobe.

  3. Uruchom aplikację Adobe. W aplikacji zostaną utworzone nieuszkodzone pliki preferencji.

Po ponownym utworzeniu plików preferencji spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że jego przyczyną nie jest uszkodzony plik preferencji. Aby przywrócić ustawienia niestandardowe konta użytkownika w aplikacji Adobe, usuń nowe foldery preferencji. Następnie przywróć oryginalne nazwy folderów, które zostały zmienione.

Jeśli problem już nie występuje, przyczyną był uszkodzony plik preferencji. (Na koncie użytkownika utracono ustawienia niestandardowe powiązane z poprzednimi plikami preferencji).

3. Usuń pliki tymczasowe określonego konta.

Niektóre aplikacje Adobe przechowują dane w plikach tymczasowych. W aplikacji Adobe mogą występować nieoczekiwane zachowania, gdy pliki tymczasowe konta są nieaktualne, uszkodzone lub jest ich zbyt wiele.

Aby usunąć pliki tymczasowe, użyj narzędzia Oczyszczanie dysku. Patrz sekcja Usuwanie plików tymczasowych przez narzędzie oczyszczania dysku (Windows 7 i Vista).

Domyślnie narzędzie Oczyszczanie dysku nie powoduje usunięcia plików w folderze Temp konta, do których dostęp uzyskiwano w ciągu poprzednich siedmiu dni. Pliki tymczasowe można usuwać gruntowanie, ręcznie kasując zawartość folderu Temp.

Wyłączenie odpowiedzialności: Aplikacje producentów innych niż Adobe mogą nie działać prawidłowo, jeśli zawartość folderu Temp zostanie usunięta ręcznie. W przypadku wykonywania tej operacji należy zachować ostrożność. Firma Adobe nie zapewnia pomocy technicznej w przypadku problemów powstałych w wyniku ręcznego usuwania plików w folderze Temp.

Aby ręcznie usunąć zawartość folderu Temp w koncie, wykonaj następujące czynności:

  1. Zamknij wszystkie aplikacje.

  2. Wybierz kolejno opcje Start > Wszystkie programy > Akcesoria. Kliknij prawym przyciskiem myszy Wiersz polecenia i wybierz polecenie Uruchom jako administrator.

  3. W oknie Wiersz polecenia wpisz następujące polecenia dokładnie tak jak przedstawiono je poniżej, a następnie naciśnij klawisz Enter:

    del %temp%\*.* /s /q

    Uwaga: del to polecenie służące do usuwania plików. %temp%\*.* to połączenie „zmiennej środowiskowej” lokalizacji folderu Temp konta i znaków wieloznacznych wskazujących wszystkie pliki./s zapewnia uwzględnienie wszystkich plików w podfolderach./q w systemie Windows wyłącza monitowanie o usuwanie każdego pliku.

  4. W oknie Wiersz polecenia zostanie wyświetlona lista usuniętych plików. (Lista może zawierać pliki, które nie mogą być usunięte. Niekiedy może zostać wyświetlony błąd „Brak dostępu” lub „Proces nie może uzyskać dostępu do pliku, ponieważ plik jest używany przez inny proces”. To zachowanie jest normalne).

  5. Zamknij okno dialogowe Wiersza polecenia.

Po usunięciu plików tymczasowych otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, przejdź do kolejnego zadania.

4. Rozwiąż problemy dot. konkretnych elementów startowych.

Elementy startowe to aplikacje lub dokumenty, które są otwierane automatycznie po zalogowaniu się do konta użytkownika. Gdy aplikacja Adobe zachowuje się nieoczekiwanie w ramach jednego konta, prawdopodobnie jeden z elementów startowych w tym koncie jest uszkodzony, nie działa poprawnie lub nie współpracuje z używaną aplikacją.

Aby ustalić, czy to element startowy konta użytkownika jest przyczyną problemu w aplikacji Adobe, wykonaj następujące czynności:

  1. W programie Eksplorator Windows przejdź do położenia C:\Users\[nazwa użytkownika]\AppData\Roaming\Microsoft\Windows\Menu Start\Programs\Startup.

  2. Wykonaj jedną z następujących czynności:

    • Jeśli folder Startup jest pusty lub nie istnieje, w tym koncie nie istnieją elementy startowe. Pomiń pozostałe kroki i przejdź do Zadania 4.
    • Jeśli istnieje przynajmniej jeden element startowy w folderze Startup, utwórz folder na pulpicie. Nowemu folderowi nadaj nazwę Holding.
  3. Przenieś wszystkie elementy z folderu Startup do utworzonego folderu Holding.

  4. Wybierz pozycje Start > Wyloguj się.

  5. Zaloguj się do tego samego konta.

  6. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że przyczyną nie był element startowy. Wszystkie elementy w folderze Holding można przenieść z powrotem do położenia C:\Users\[nazwa uśytkownika]\AppData\Roaming\Microsoft\Windows\Menu Start\Programs\Startup. Przejdź do Zadania 4.

Jeśli problem nie wystąpi, oznacza to, że przyczyną był element startowy. Aby określić, który element startowy odpowiada za występowanie problemu, wykonaj następujące czynności:

  1. Zamknij aplikację Adobe.

  2. Przenieś jeden z elementów z folderu Holding z powrotem do położenia C:\Users\[nazwa użytkownika]\AppData\Roaming\Microsoft\Windows\Menu Start\Programs\Startup.

  3. Wybierz pozycje Start > Wyloguj się.

  4. Zaloguj się do tego samego konta.

  5. Otwórz aplikację Adobe i spróbuj odtworzyć problem. Następnie wykonaj jedną z następujących czynności:

    • Jeśli problem nadal występuje, powtórz kroki od 1 do 5.
    • Jeśli problem nie wystąpi, oznacza to, że przyczyną był element startowy, który teraz został ponownie włączony. Usuń ten element z folderu Startup i skontaktuj się z wydawcą tego elementu startowego w celu uzyskania informacji o dostępności zaktualizowanej wersji. Przenieś wszystkie elementy z folderu Holding z powrotem do położenia C:\Users\[nazwa użytkownika]\AppData\Roaming\Microsoft\Windows\Menu Start\Programs\Startup.

5. Zresetuj ustawienia dostępu do folderów danych aplikacji w przypadku określonego konta.

Wykonaj to zadanie wyłącznie, gdy konto, w którym rozwiązywane są problemy, jest kontem administratora i nienależy dodomeny sieciowej.

Błędy dotyczące danego konta mogą występować, jeśli w koncie nie zapewniono pełnych uprawnień do odczytu/zapisu w folderze zawierającym pliki preferencji aplikacji Adobe i pliki danych określonego konta.Ustawieniadostępowemożna zresetować za pomocą polecenia icacls. Wykonaj następujące czynności:

  1. Zamknij wszystkie aplikacje.

  2. Wybierz kolejno opcje Start> Wszystkie programy > Akcesoria. Kliknij prawym przyciskiem myszy Wiersz polecenia i wybierz polecenie Uruchom jako administrator. Zostanie otwarte okno wiersza poleceń.

  3. W oknie wiersza poleceń wpisz następujące polecenia dokładnie tak jak przedstawiono je poniżej. Po każdym poleceniu naciśnij klawisz Enter. 

    Ważne: Przed każdym przełącznikiem i po każdym przełączniku -- /T, /C i /grant -- wpisz spację w każdym poleceniu.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. Zamknij okno wiersza poleceń.

  5. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, przejdź do kolejnego zadania.

6. Odtwórz klucz Adobe dla określonego konta w rejestrze systemu Windows.

Wyłączenie odpowiedzialności: Poniższe zadanie wymaga zmodyfikowania rejestru systemu Windows. W rejestrze przechowywane są informacje związane z systemem, które są krytyczne ważne w celu zapewnienia prawidłowej pracy komputera i aplikacji. Przed przystąpieniem do modyfikacji rejestru należy utworzyć jego kopię zapasową. Firma Adobe nie zapewnia pomocy technicznej w przypadku problemów wynikających z nieprawidłowej modyfikacji rejestru. Więcej informacji o rejestrze systemu Windows i Edytorze rejestru można znaleźć w witrynie pomocy firmy Microsoft pod adresem http://support.microsoft.com.

  1. Zamknij wszystkie aplikacje.

  2. Kliknij przycisk Start. Wpiszregeditw polu Wyszukiwanie w menu Start, a następnie naciśnij klawisz Enter. Zostanie otwarty Edytor rejestru.

  3. W lewym okienku programu Edytor rejestru przejdź do następującego klucza:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Wybierz kolejno opcje Plik > Eksportuj.

  5. W oknie dialogowym Eksportowanie pliku rejestru w obszarze Zakres eksportu wybierz opcję Wybrana gałąź. Wprowadź nazwę i lokalizację kopii zapasowej klucza rejestru i kliknij przycisk Zapisz.

  6. Prawym przyciskiem myszy kliknij klucz Adobe i kliknij przycisk Usuń.

  7. W oknie dialogowym Potwierdzanie usunięcia klucza kliknij przycisk OK.

  8. Zamknij Edytor rejestru systemu.

  9. Otwórz aplikację Adobe i spróbuj odtworzyć problem.

Jeśli problem nadal występuje, oznacza to, że jego przyczyną nie jest uszkodzony wpis w rejestrze. Kopię zapasową klucza Adobe można przywrócić, wykonując następujące czynności:

  1. Zamknij wszystkie aplikacje.

  2. Kliknij przycisk Start. Wpiszregeditw polu Wyszukiwanie w menu Start, a następnie naciśnij klawisz Enter. Zostanie otwarty Edytor rejestru.

  3. W programie Edytor rejestru wybierz polecenia Plik > Importuj.

  4. W oknie dialogowym Importuj plik rejestru przejdź do położenia kopii zapasowej klucza zapisanej w poprzednich krokach. Zaznacz plik i kliknij przycisk Otwórz.

7. Napraw systemowy dysk twardy.

Uszkodzenia dysku wpływające tylko na określone konto użytkownika mogą powodować błędy aplikacji Adobe działającej na tym koncie.

Aby naprawić systemowy dysk twardy, zapoznaj się z sekcją Naprawa i defragmentacja dysków twardych (Windows 7 i Vista).

Po naprawieniu dysku twardego otwórz aplikację Adobe i spróbuj odtworzyć problem. Jeśli problem nadal występuje, przejdź do kolejnego zadania.

8. Użyj nowego konta użytkownika.

Jeśli aplikacja nadal wykazuje nieoczekiwane zachowanie po uruchomieniu na określonym koncie użytkownika, skopiuj (lub przenieś) wszystkie pliki osobiste do konta użytkownika, na którym te zachowania nie występują. Następnie używaj nowego konta jako konta standardowego.

Aby uzyskać pomoc dotyczącą kopiowania plików osobistych do nowego konta użytkownika, skontaktuj się z producentem komputera. Lub przejdź do witryny pomocy firmy Microsoft pod adresem http://support.microsoft.com.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online