April 2018 release of After Effects CC (version 15.1)
after-effects

The April 2018 (15.1) release of After Effects rolls out exciting new features for visual effects artists, graphic editors, and animators. Read on for a quick introduction to the list of new features and enhancements.

For a summary of features introduced in earlier releases of After Effects CC, see Feature summary | Earlier releases.


Master Properties

 New in the April 2018 release

Master Properties allow you to access and edit layer and effect properties such as text, color, and opacity of a composition when it is nested in another composition. You can use master properties to reduce project complexity and save time while you build complex animations across multiple compositions. When you add properties like position, scale or color to the Essential Graphics panel, these properties appear as editable Master Properties in the timeline. You no longer have to open the nested compositions separately to view or change the layer properties.

To learn more, see Master Properties.

Master Properties workflow
Master Properties workflow

Advanced Puppet Tool

 New in the April 2018 release

The Advanced Puppet Tool adds new functionality and smoother deformations to the legacy Puppet Tool. The new puppet tool offers new pin behaviors and smoother, more customizable deformations, from ribbony to bendy. Apply pins to any shape or puppet and the Advanced Puppet Tool dynamically redraws the mesh based on where your pins are located. You can add multiple pins in an area and retain the detail in your image. The Advanced Puppet Tool also controls the rotation of pins for different style deformations to curve and bend your animations more flexibly.

To learn more, see Advanced Puppet tool.

Deformation with Advanced Puppet Tool
Deformation with Advanced Puppet Tool

Adobe Immersive Environment

 New in the April 2018 release

You can now preview your composition in a head-mount display (HMD), including HTC Vive, Windows Mixed Reality, and Oculus Rift. You can switch between the following video preview preferences:

  • Monoscopic
  • Stereoscopic Top / Bottom
  • Stereoscopic Side by Side

 

To learn more, see Adobe Immersive Environment.

Adobe Immersive Environment
Adobe Immersive Environment

Improved VR Plane to Sphere

 New in the April 2018 release

After Effects has improved the overall output quality of the VR Plane to Sphere effect which supports smoother and sharper rendering of the edges of your graphics.

Essential Graphics panel improvements

 New in the April 2018 release

Essential Graphics panel introduces a host of improvements:

  • You can add 2D point, 2D scale, and Angle property types.
  • You can add all Transform group properties of a 2D layer to the Essential Graphics panel.
  • You can drag multiple selected properties from the Timeline panel to the Essential Graphics panel.
  • You can undo and redo adding, removing, or reordering properties or comments in the Essential Graphics panel.
  • When you duplicate a composition in the Project panel, it now also duplicates properties and comments added to the Essential Graphics panel for that composition.
  • When you right-click a property in the Essential Graphics panel and select Reveal in Timeline, the composition opens if it was closed.

Use the Property Link pick whip

 New in the April 2018 release

Similar to the Expressions pick whip, the Property Link pick whip allows you to quickly link properties to create complex animations. The linked properties refer to the value of properties they are linked with, using an expression. The Property Link pick whip saves you the task of creating or writing an expression as it automatically assigns an expression to the linked property.

The Property Link pick whip achieves similar results as to using the Edit > Copy With Property Links option to copy and paste the value of a property onto a different property. The difference is that it creates the link in the opposite direction.

The pick whip is placed in the Parent & Link section (close to Effect properties) of the Timeline panel. This column was called Parent in the earlier versions of After Effects. To use the pick whip, click the pick whip icon next to the property you want to link, then drag it to the property (in the Timeline) you want it to be linked to.

To disable a pick whip link (disable the expression of that property), hold down Option (macOS) or the Alt(Windows) and click the Property Link pick whip.

Open a Motion Graphics template as a project

 New in the April 2018 release

You can now open Motion Graphics templates created in After Effects as a project file in After Effects, retaining compositions and assets. You can make edits to the template in After Effects and replace it with the original project (.aep) or export as a new Motion Graphics template for users in Premiere Pro.

Data-driven animation improvements

 New in the April 2018 release

After Effects introduces multiple improvements to how data files are used to drive animations within the application:

  • Support for comma-separated value (CSV) and tab-separate value (TSV) files.
  • Each individual data property has an expression applied which links that property to the data in the JSON, CSV, or TSV file. Display the data hierarchy of all data files in the Timeline panel. When you add a JSON, CSV, or TSV file to a composition and open the properties, they contain only a Data properties group, instead of the Transform properties group.
You can also write expressions that reference data in JSON, CSV, and TSV files either as layers or as footage items.
Data-driven animation improvement
Data-driven animation improvement

Video Limiter

 New in the April 2018 release

Video Limiter is a GPU-accelerated effect that limits video signals to broadcast-legal range. It compresses luminance and chrominance signals for broadcast specifications. You can apply this effect to individual layers, or to an adjustment layer to affect your entire composition.

To learn more, see Video Limiter Effect.

Color correction and color management improvements

 New in the April 2018 release

Lumetri Color custom LUT directory

You can now install custom LUT files that display in the Basic Correction > Input LUT and Creative > Look menu in the Lumetri Color effect. To install a custom LUT file, first create one or more of the directories listed below, and then copy your custom LUT files to that folder.
 
Custom LUT directories macOS Windows
Available only to the local user /Users/<user_name>/Library/Application Support/Adobe/Common/LUTs/Creative
 
/Users/<user_name>/Library/Application Support/Adobe/Common/LUTs/Technical
C:\Users\<user_name>\AppData\Roaming\Adobe\Common\LUTs\Creative
 
C:\Users\<user_name>\AppData\Roaming\Adobe\Common\LUTs\Technical
Available to all users /Library/Application Support/Adobe/Common/LUTs/Creative
 
/Library/Application Support/Adobe/Common/LUTs/Technical
C:\Program Files\Adobe\Common\LUTs\Creative
 
C:\Program Files\Adobe\Common\LUTs\Technical

After Effects  scans the folders at launch and loads LUT files from these directories. LUTs in the Creative directories appear in the Creative > Look menu and LUTs in the Technical directories appear in the Basic Correction > Input LUT menu.

Assume Working Gamma (no project working space)

When the project working pace is set to None, the new Assume Working Gamma control allows you to select whether to use a gamma value of 2.4 (Rec. 709) or 2.2 (sRGB) when converting to or from linear light.

Assume Working Gamma defaults to 2.4 (Rec. 709) for new projects. This is the recommended value unless you want to emulate the behavior of After Effects 14.2.1 and earlier releases. Projects last saved in After Effects 14.2.1 or earlier releases are set to 2.2 (sRGB).

Performance improvements

 New in the April 2018 release

Improved GPU memory usage

After Effects now utilizes GPU memory (VRAM) aggressively to avoid low VRAM conditions when Project Settings is set to Mercury GPU Acceleration. The Enable Aggressive GPU memory option has been removed as the GPU memory use is now always aggressive.

Grain effects CPU performance improvements

The Add Grain, Match Grain, and Remove Grain effects now perform faster on multi-core CPU systems.

Video and audio format support updates

 New in the April 2018 release

Camera Raw format support improvements

After Effects introduces improved support for importing video files in the following Camera Raw formats:
  • Canon EOS C200 Cinema RAW Light (.crm)
  • RED Image Processing Pipeline (IPP2) (.r3d)
  • Sony VENICE X-OCN 4K 4:3 Anamorphic and 6K 3:2 (.mxf)

Hardware-accelerated H.264 decoding (Windows only)

You can now use the hardware decoders in your system to speed up the process of editing H.264 file formats on Windows.

Start with enabling the Enable Accelerated H.264 Decoding option in Preferences > Import, then restart After Effects. The option does not work if the CPU of your computer does not support Intel Quick Sync Video.

Support details

  • H.264 video in MPEG-4 (.mp4) and QuickTime (.mov) containers are hardware accelerated.
  • MPEG Transport Stream (.mts) containers are not supported.
  • Only 4:2:0 8-bit per channel files are supported because of hardware limitations.

Dropped support for QuickTime 7 era formats and codecs

Adobe continuously aims to keep up with the most modern workflows and support formats and codecs broadly used across the professional film and video industry. As a result, future versions of After Effects, starting with version 15.1, will no longer support legacy QuickTime 7 era formats and codecs.

Professional codecs typically found in QuickTime movie files, such as ProRes, DNxHD, and Animation, are not impacted by this change. These codecs are supported natively in After Effects.

To learn more, see QuickTime 7 support has ended.

Importer for BMP, GIF, and Animated GIF formats

After Effects introduces a new importer for BMP, GIF, and Animated GIF formats as the previous importers are dependent on legacy 32-bit QuickTime libraries.

MPEG-1 Audio Layer II format support

After Effects can now import MPEG-1 Audio Layer II format audio in a WAV container file.

Expression access to project properties

 New in the October 2017 release

In this release, Expressions can now access the project object and the following project attributes:

  • The path to the project on disk.
  • The project color depth.
  • Whether Linear blending is enabled.

Team Projects improvements

 New in the April 2018 release

Improved presence of online collaborators

You can view the online status of your Team Projects collaborators and badge updates indicating project changes.

To learn more, see Collaborate with Team Projects.

Better project management

You can manage your projects effectively by embedding linked team projects within a Team Project. You can also import a local After Effects project as a shared project.

To learn more, see Create a Team Project.

Render a Team Project using Teamproject flag

The After Effects command line renderer can render a Team Project using the new -teamproject flag. To use this flag, ensure that the command line specifies the composition name and output file path. For example, aerender -teamproject my_team_project "My Comp" output C:\renders\my_render.mov.

Other enhancements

 New in the April 2018 release

Consolidated missing files dialog

When multiple source files referenced by the open project become unavailable, After Effects now presents a single dialog with the list of all the missing files.

Empty disk cache for older versions

You can now provides an option to clear the disk cache for all installed versions of After Effects. To clear cache, use any of the following options:

  • Use the Empty Disk button in Preferences > Media & Disk Cache.
  • Select Edit > Purge > All Memory & Disk Cache command.

This option works on the assumption that the disk cache for other versions is located in the same folder as the disk cache for the current version. If you have changed the location of the disk cache between versions, the disk cache for older versions is not found or cleared.

Disable the Missing Fonts dialog

A new preference allows you to disable the Missing Fonts dialog that appears when you open a project that uses a font not present on your computer. To disable the Missing Fonts dialog, select Preferences > Type and enable Do not warn me about missing fonts when opening projects.

Disable proxies for multiple footage items

In the Project panel, if you select multiple items with proxies, the File > Set Proxy > None command is now enabled.

Copy/paste in the Project panel pastes into a selected folder

When you copy and paste items in the Project panel, if a folder is selected, After Effects now pastes the item in the selected folder and not in the root level of the project.

Property reference text layers

You can drag properties from the Timeline panel to the Composition panel to create text layers. These properties are linked by an expression, that displays the current value of the property. The text layer is set as a Guide layer. 

You can use the value of a property as a text layer to visually represent a value such as for testing expressions, and for working with JSON data sources.

The following property types are supported:

  • Text
  • Numerical
  • 2D
  • 3D point and scale
  • Angle
  • Check boxes
  • Pop-up menu

Color properties are not supported. 

Center anchor point in new shape layers

When you create a shape layer, you can choose to center the anchor point of the layer in the first shape you draw, instead of the center of the composition. For example, you can use this to have the anchor point of the layer transform to animate a single shape. This saves the need to adjust the anchor point and also balances any offset to the shape transform properties.

To use this option, in Preferences > General, enable the Create Anchor Point in New Shape Layers option (disabled by default). When the option is enabled, the anchor point moves only when you draw the first shape layer. Creating more shapes does not impact the anchor point. When you use the Pen tool to draw a Bezier path shape, the anchor point is centered in the boundary of the Bezier shape either when you close the path or when you deselect the layer.

Create Shapes or Create Masks from Text create layers above the selected layer

After Effects can create shape layer or masked solid layer at the top of the selected text layer with the Create Shapes from Text and the Create Masks from Text options. Earlier versions of After Effects created the layer at the top of the composition.

Updated Darken, Lighten, and Soft Light blending modes

The Darken, Lighten, and Soft Light blending modes now use the same renderer as Photoshop. The key difference is that in After Effects, the renderer impacts only the regions of partial transparency.

Note:

If you render projects saved in earlier versions of After Effects, the results might look different as they use the new blending modes.

Layer menu command consolidation

Multiple items in the layer context menu (the menu that displays when you right-click a layer in the Timeline or the Composition panel) are now consolidated into the following sub-menus:

  • Track & Stabilize
  • Open
  • Reveal
  • Create

The consolidation is done to accommodate the increasing menu options. The Create menu is also part of the application Layer menu.

User voice community for After Effects

Your input is valuable to us and helps us shape the After Effects product. You can now submit feature ideas and report bugs through the After Effects User Voice site.

UserVoice works best when you file a single idea per submission, but feel free to file as many submissions as you’d like!

Known issues and fixed issues

For a list of known issues introduced in this release, see Known issues in After Effects CC (15.1).

For a list of fixed issues in this release, see List of bug fixes in the After Effects CC (15.1) release.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy