Convert footage items between video formats

You can use After Effects to convert one kind of video to another. When converting video, keep in mind the following guidelines:

  • Changes in resolution may result in a loss of picture clarity, especially when up-converting from a standard-definition format to a high-definition format.

  • Changes in frame rate may require the use of frame blending to smooth out the interpolated frames. For longer footage items, the use of frame blending can result in very long render times.

  1. Import the footage you’re converting into a composition using the preset of the format you’re converting to. Example: if you’re converting NTSC to PAL, add your NTSC footage item to a composition with the appropriate PAL composition settings preset.
  2. Select the layer with the footage to be converted and choose Layer > Transform > Fit To Comp Width (or Fit To Comp Height).

    Note:

    For converting between two formats with the same frame aspect ratio, either of these two Fit commands does the same thing; if the frame aspect ratios differ (for example, going from 4:3 to 16:9), fitting to width or height chooses between cropping or letterboxing the resulting image.

  3. Do one of the following:
    • If your footage has no scene cuts, choose Layer > Frame Blending > Pixel Motion. Pixel Motion provides the best results for interpolation of frames, but may require long rendering times.

    • If your footage has scene cuts, or if you want to sacrifice quality for shorter rendering times, choose Layer > Frame Blending > Frame Mix.

  4. Choose Composition > Add To Render Queue.
  5. In the Render Queue panel, next to Render Settings, choose the appropriate preset from the menu. For example, if you’re converting to DV footage, select DV Settings from the menu.
  6. In the Render Queue panel, next to Output Module, choose the appropriate output module preset from the menu, or choose Custom to enter custom settings. For example, if you’re converting to DV PAL, choose the D1/DV-PAL output module preset with the audio sampling rate that you require.
  7. Click the name of the output module preset that you chose in step 6 to select additional Format Options.
  8. Specify a name and destination for the output file using the controls to the right of the Output To heading in the Render Queue panel. (See Specify filenames and locations for rendered output.)
  9. Click the Render button to render your movie.

Convert DV footage from PAL to NTSC using pulldown

Because After Effects can easily convert film (24 fps) to video (29.97 fps) using 3:2 pulldown, you can perform a clean PAL-to-NTSC transfer by setting up 25-fps PAL video to act like 24-fps film. This lets you apply 3:2 pulldown to the footage when converting to 29.97 fps. This technique works especially well for progressive (noninterlaced) PAL video.

  1. Create a new composition with the DV NTSC or DV NTSC Widescreen preset.
  2. Import your DV PAL footage into the new composition.
  3. Select the layer with the DV PAL footage, and choose Layer > Transform > Fit To Comp Width (or Fit To Comp Height).
  4. Do one of the following:
    • To preserve audio synchronization but slightly lower the pitch, choose Layer > Time > Time Stretch, and then enter 95.904 in the Stretch Factor box.

    • To preserve audio pitch but not synchronization, or for clips without audio, right-click (Windows) or Control-click (Mac OS) the footage item in the Project panel, select Interpret Footage > Main, select Conform To Frame Rate, and then enter 23.976 in the Conform To Frame Rate box.

  5. Choose Composition > Add To Render Queue.
  6. Choose Custom from the Render Settings menu.
  7. In the Render Settings pane, enable Field Rendering (choose the field order required by your output type), select any option from the 3:2 Pulldown menu, and then click OK.
  8. Choose the output type from the Render Queue Output Module menu (for example, Microsoft DV NTSC 32 kHz).
  9. Specify a name and destination for the output file using the controls to the right of the Output To heading in the Render Queue panel. (See Specify filenames and locations for rendered output.)
  10. Click the Render button to render your movie.

Scaling a movie down

Several methods exist for producing a reduced-size movie from your composition, each with tradeoffs between speed and quality:

Nest the composition

Create a new composition at the smaller dimensions, and nest the large composition inside it. For example, if you create a 640x480 composition, place it in a 320x240 composition. Use the Fit To Comp command to scale the composition to fit the new smaller composition size: Press Ctrl+Alt+F (Windows) or Command+Option+F (Mac OS), and then collapse transformations by choosing Layer > Switches > Collapse. The resulting composition rendered at full resolution and best quality will have excellent image quality, better than if you had rendered using a reduced resolution.

Resize the composition

This method produces the highest quality reduced-size movie but is slower than nesting. For example, if you create a 640x480 composition and render it at full resolution, you can set the Resize value in the Output Module Settings dialog box to 50% to create a 320x240 movie. For a composition rendered at full resolution, the image quality is excellent when the Resize Quality is set to High.

Note:

Do not use resizing to change the vertical dimensions of a movie when field rendering is on. Resizing vertically mixes the field order, which distorts motion. Use either cropping or composition nesting if you need to vertically resize a field-rendered movie.

Crop the composition

This method is ideal for reducing the size of a movie by a few pixels. Use the Crop options in the Output Module Settings dialog box. Remember that cropping cuts off part of the movie, so objects centered in the composition may not appear centered unless the movie is cropped evenly on opposite edges.

Note:

In some special cases, After Effects will automatically crop rather than scale when creating an output movie with dimensions that don’t match the dimensions of the composition. For example, when creating a 720x480 movie with a pixel aspect ratio of 0.91 or 1.21 from a 720x486 composition, After Effects will crop instead of scale.

Crop to a region of interest

To render just a portion of the composition frame, define a region of interest in the Composition panel. Then, select the Region Of Interest option in the Output Module Settings dialog box before rendering. (See Region of interest (ROI).)

Note:

Cropping an odd number of pixels from the top of a field-rendered movie reverses the field order. For example, if you crop one row of pixels from the top of a movie with Upper Field First field rendering, the field-rendering order then becomes Lower Field First. Remember that if you crop pixels from the top of the movie, you need to add to the bottom row of the movie to maintain the original size. If you don’t mind losing one scan line, this technique gives you a way to output two movies from one render, each with a different field order.

Render the composition at a reduced resolution

This method is the fastest for creating reduced-size movies. For example, if you create a 640x480 composition, you can set the composition resolution to one half, reducing the size of the rendered composition to 320x240. You can then create movies or images at this size. The reduced resolution reduces the sharpness of the image and is best used for creating preview or draft movies.

Note:

When rendering at reduced resolution, set the quality of the composition to Draft. Rendering at Best quality while reducing resolution does not produce a clean image and takes longer to render than rendering at Draft quality.

Scaling a movie up

Increasing the size of the output from a rendered composition reduces the image quality of a movie and is not recommended. If you must enlarge a movie, to maintain highest image quality, enlarge a composition that was rendered at full resolution and highest quality using one of the following methods:

Nest the composition

Create a new composition at the larger dimensions and nest the smaller composition inside it. For example, if you create a 320x240 composition, you can place it in a 640x480 composition. Resize the composition to fit the new larger composition size, and then collapse transformations by choosing Layers > Switches > Collapse. The resulting composition rendered at full resolution and best quality will have better image quality than if you had resized the movie. However, this method also renders slower than if you created a composition and resized it.

Note:

To create a draft movie with specific dimensions, use both the Resize option and reduced resolution in the rendered composition.

Resize the composition

For example, if you create a 320x240 composition and render it at full resolution, you can set the Resize value in the Output Module Settings dialog box to 200% to create a 640x480 movie. For a composition rendered at full resolution, the image quality is usually acceptable.

Note:

Do not use resizing to change the vertical dimensions of a movie with field rendering. Resizing vertically mixes the field order, which distorts any motion. Use either cropping or composition nesting if you need to vertically resize a field-rendered movie.

Crop the composition

To enlarge a movie by a few pixels, increase the size using negative values for the Crop options in the Output Module Settings dialog box. For example, to increase the size of a movie by 2 pixels, enter –2 in the Cropping section of the Output Module Settings dialog box. Remember that negative cropping adds to one side of a movie, so objects originally centered in the composition may not appear centered when the movie is cropped.

Note:

Adding an odd number of pixels to the top of a field-rendered movie reverses the field order. For example, if you add one row of pixels to the top of a movie with Upper Field First field rendering, the field-rendering order then becomes Lower Field First. Remember that if you add pixels to the top of the movie, you need to crop from the bottom row of the movie to maintain the original size.

Note:

Adobe Photoshop provides fine control over resampling methods used for scaling of images. For fine control of resampling, you can export frames to Photoshop to change the image size and then import the frames back into After Effects.

For a list of plug-ins that provide high-quality scaling—including some designed to create high-definition images from standard-definition sources—see the Toolfarm website.

For a script that scales multiple compositions simultaneously, see the AE Enhancers forum.

Create a composition and render source footage items simultaneously

You can simultaneously create a composition from source footage and prepare it for rendering. This process is useful when you want to change some characteristic of the source footage, such as frame rate or compression method, and have that rendered version available in your project.

  1. Drag one or more footage items from the Project panel to the Render Queue panel, or select the footage items in the Project panel and do one of the following:
    • Choose Composition > Add to Render Queue.

    • Press Ctrl+Shift+/ or Ctrl+M(Windows) or Command+Shift+/ or Command+M (Mac OS).

    Note:

    If the Use System Shortcut Keys option is enabled in General preferences (Mac OS), the shortcut is Ctrl+Cmd+M.

  2. After Effects creates both a new item in the render queue and a new composition in the Project panel for each footage item.
  3. Adjust the render settings as desired, and click Render.

Introduce 3:2 pulldown

If you are creating output for film that’s been transferred to video, or if you want to simulate a film look for animation, use 3:2 pulldown. Footage items that were originally film transferred to video and had 3:2 pulldown removed when imported into After Effects can be rendered back to video with 3:2 pulldown reintroduced. You can introduce 3:2 pulldown by choosing one of five different phases. (See Remove 3:2 or 24Pa pulldown from video.)

Note:

It is important to match the phase of a segment that had 3:2 pulldown removed if it will be edited back into the video footage it came from.

  1. In the Render Queue panel, select the render item and then click the underlined text next to the Render Settings heading.
  2. For Field Render, choose a field order.
  3. For 3:2 Pulldown, choose a phase.
  4. Select other settings as appropriate, and then click Render.

Chris and Trish Meyer provides an overview of 3:2 pulldown in an article on the Artbeats website.

Test field-rendering order

When you render a composition containing separated footage, set the Field Rendering option to the same field order as your video equipment. If you field-render with the incorrect settings, the final movie may appear too soft, jerky, or distorted. A simple test can determine the order in which your video equipment requires fields.

Note:

The field order might get altered if you change the hardware or software of your production setup. For example, changing your device control software or VCR after setting the field order can reverse your fields. Therefore, any time you change your setup, test the field-rendering order.

The test takes about 15 minutes and involves creating two movie versions of the same composition (one rendered with Upper Field First and one with Lower Field First), and then playing the movies to see which choice looks right.

  1. Create a simple composition with the correct frame size and frame rate. Choose an NTSC or PAL preset in the Composition Settings dialog box, and make the composition at least 3 seconds long.
  2. Within the composition, make a layer that is a small rectangular solid. The layer can be any color as long as it contrasts sharply with the composition background. You may want to add a title (such as “Upper Field First”) to the solid to make identification of the movie easier.
  3. Apply some fast movement to the solid using keyframes in its Position property. Set keyframes from the upper-left of the Composition panel to the lower-right for 1 second.
  4. Save the project, and then drag the composition to the Render Queue panel.
  5. Click the underlined Render Settings name, and then choose Upper Field First from the Field Render menu.
  6. Click OK, and then click Render to make the movie.
  7. In the composition, change the color of the solid in the Composition panel, and add a new title, such as “Lower Field First”, to identify it.
  8. Render the composition again, choosing Lower Field First from the Field Render menu in the Render Settings dialog box.
  9. Record both movies to the same device.
  10. Play both movies.

    One movie will look distorted and have jumpy horizontal motion or shape distortion during vertical motion. The other movie will play back smoothly, with sharply defined edges. Use the field order for the smooth-playing movie whenever you render movies with that particular hardware configuration.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy