Preparing still-image files for importing

You can import individual still images into After Effects or import a series of still images as a sequence. For information about the still-image formats that After Effects imports, see Supported import formats.

After Effects works internally in an RGB color space, but it can import and convert CMYK images. However, when possible, you should work in an RGB color space in applications such as Illustrator and Photoshop when creating images for video, film, and other non-print media. Working in RGB provides a larger gamut and more accurately reflects your final output.

Before you import a still image into After Effects, prepare it as completely as possible to reduce rendering time. It is usually easier and faster to prepare a still image in its original application than to modify it in After Effects. Consider doing the following to an image before importing it into After Effects:

  • Make sure that the file format is supported by the operating system you plan to use.
  • Crop the parts of the image that you do not want to be visible in After Effects.

Note:

Illustrator files can have fractional dimensions (for example, 216.5x275.5 pixels). When importing these files, After Effects compensates for the fractional dimensions by rounding up to the next whole number of pixels (for example, 217x278 pixels). This rounding results in a black line at the right (width) or bottom (height) edge of the imported image. When cropping in Illustrator, make sure that the dimensions of the cropped area are whole numbers of pixels.

  • If you want to designate areas as transparent, create an alpha channel or use the transparency tools in applications such as Photoshop or Illustrator.

  • If final output will be broadcast video, avoid using thin horizontal lines (such as 1-pixel lines) for images or text because they may flicker as a result of interlacing. If you must use thin lines, add a slight blur so that the image or text appears in both video fields instead of flickering between them. (See Interlaced video and separating fields and Best practices for creating text and vector graphics for video.)

  • If final output will be broadcast video, make sure that important parts of the image fall within the action-safe and title-safe zones. When you create a document in Illustrator or Photoshop using a preset for film and video, the safe zones are shown as guide lines. (See Safe zones, grids, guides, and rulers.)

  • If the final output will be broadcast video, keep colors within the broadcast-safe ranges. (See Broadcast-safe colors.)

  • Save the file using the correct naming convention. For example, if you plan to import the file into After Effects on Windows, use a three-character filename extension.

  • Set the pixel dimensions to the resolution and frame aspect ratio that you will use in After Effects. If you plan to scale the image over time, set image dimensions that provide enough detail at the largest size the image has in the project. After Effects supports a maximum image size of 30,000x30,000 pixels for importing and rendering files. The size of image that you can import or export is influenced by the amount of physical RAM available to After Effects. The maximum composition dimensions are also 30,000x30,000 pixels.

Note:

The image size or pixel dimensions setting in Photoshop (or other image-editing application) is relevant for the preparation of image data for import into After Effects—not dpi (dots per inch) or ppi (pixels per inch) settings. The image size determines how many pixels wide and tall an image is, whether those pixels are the tiny ones on a mobile device or the big ones on a motion billboard. The dpi or ppi settings are relevant to printing an image and to the scale of copied and pasted paths.

Import a single still image or a still-image sequence

You can import still image files as individual footage items, or you can import a series of still image files as a still-image sequence, which is a single footage item in which each still image is used as a single frame.

To import multiple image files as a single still-image sequence, the files must be in the same folder and use the same numeric or alphabetic filename pattern (such as Seq1, Seq2, Seq3).

When you import a file that appears to After Effects to be one file in a still-image sequence, After Effects by default imports all other files in the same folder that appear to be in the same sequence. Similarly, when you select multiple files that appear to be in a sequence, After Effects by default imports them as a sequence. You can see what After Effects is about to import by looking at the bottom of the Import dialog box. You can also import images and sequences by dragging files and folders into the Project panel.  

Note:

To prevent After Effects from importing unwanted files when you want to import only a single file, or to prevent After Effects from interpreting multiple files as a sequence, deselect the Sequence option in the Import dialog box. After Effects remembers this setting and thereafter uses it as the default.

You can import multiple sequences from the same folder simultaneously by selecting files from different sequences and selecting Multiple Sequences at the bottom of the Import dialog box.

When importing a sequence of still images, you can use the Force Alphabetical Order option in the Import dialog box to import a sequence with gaps in its numbering (for example, Seq1, Seq2, Seq3, Seq5). If you import a sequence with gaps in its numbering without selecting this option, After Effects warns you of missing frames and replaces them with placeholders (if the Report Missing Frames option is checked in Edit > Preferences > Import).

After Effects uses settings of the first image in the sequence to determine how to interpret the images in the sequence.

If the image files in a sequence are of a layered file type—such as Adobe Photoshop or Adobe Illustrator documents—then you can choose to import the sequence as a standard footage item, or as a composition in which each layer in each file is imported as a separate sequence and appears as a separate layer in the Timeline panel.

Note:

When you render a composition that contains a numbered sequence, the output module uses the start frame number as the first frame number. For example, if you start to render on frame 25, the name of the file is 00025.

Import a still-image sequence
A sequence of still-image files (left) becomes one image sequence when imported into After Effects (right).

Verify individual image sequence files

When you import image sequence files in After Effects CC 2015.3 and later versions, it does not individually verify every file in the sequence. This accelerates the image sequence import process, especially when you import from network storage. However, if the sequence includes files that are aliases or shortcuts that do not resolve, for example if the drive is offline, After Effects does not report those files as missing.

If you encounter unexpected missing frames while importing an image sequence, you can enable the Verify Individual Files option, which is comparatively slower, but verifies all files in the sequence (Edit > Preferences > Import and enable the Sequence Footage: Verify Individual Files).

Import a still-image sequence as a single footage item

  1. Choose File > Import > File.
  2. Select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down Shift, and then select the last file to import.
  3. Choose Footage from the Import As menu.
  4. Click Open (Windows) or Import (Mac OS).
  5. Click OK.

If at any time you decide that you want access to the individual components of the footage item, you can convert it to a composition. See Convert a merged footage item into a composition.

Import a still-image sequence as a composition

When you import a Photoshop or Illustrator file as a composition, you have access to the individual layers, blending modes, adjustment layers, layer styles, masks, guides, and other features created in Photoshop or Illustrator. The imported composition and a folder containing each of its layers as footage items appears in the Project panel.

  1. Choose File > Import > File.
  2. Select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down Shift, and then select the last file to import.
  3. Choose one of the following from the Import As menu:

    Composition - Retain Layer Sizes

    Import the layers, each with its original dimensions.

    One reason to import as a composition with layers at their original dimensions (rather than importing each layer at the composition frame size) is so that each layer has its anchor point set at the center of the cropped graphics object, rather than at the center of the composition frame. This more often makes transformations work more as you’d expect and prefer when animating individual layers of an imported graphic item. For example, if you have a car with a separate layer for each wheel, importing as a composition with layers at their original sizes puts the anchor point of each wheel in the center of the wheel, which makes rotating the wheels work as you’d expect.

    Composition

    Import layers and have the dimensions of each match the dimensions of the composition frame.

  4. Click Open (Windows) or Import (Mac OS).

Convert a merged footage item into a composition

When you import a layered file, such as a Photoshop or Illustrator file, as footage, all of its layers are merged together. If at any time you decide that you want access to the individual components of the footage item, you can convert it to a composition.

  • To convert all instances of a footage item, select it in the Project panel and choose File > Replace Footage > With Layered Comp.
  • To convert only one instance of the footage item, select the layer in the Timeline panel, and choose Layer > Convert To Layered Comp.

Note:

It may take a few moments to convert a merged footage item to a layered composition.

Change the frame rate of a sequence

When you import a sequence of still images, it assumes the frame rate specified by the Sequence Footage preference in the Import category. The default rate is 30 frames per second (fps). You can change the frame rate after importing by reinterpreting the footage item:

  • Select the sequence in the Project panel, choose File > Interpret Footage > Main, and then enter a new value for Assume This Frame Rate.

For more information, see Frame rate.

Preparing and importing Photoshop files

Note:

For information and instructions that apply to all kinds of still image files, see Preparing still-image files for importing and Import a single still image or a still-image sequence.

Because After Effects includes the Photoshop rendering engine, After Effects imports all attributes of Photoshop files, including position, blending modes, opacity, visibility, transparency (alpha channel), layer masks, layer groups (imported as nested compositions), adjustment layers, layer styles, layer clipping paths, vector masks, image guides, and clipping groups.

Before you import a layered Photoshop file into After Effects, prepare it thoroughly to reduce preview and rendering time. Avoid problems importing and updating Photoshop layers by doing the following:

  • Organize and name layers. If you change a layer name in a Photoshop file after you have imported it into After Effects, After Effects retains the link to the original layer. However, if you delete a layer, After Effects is unable to find the original layer and lists it as Missing in the Project panel.

  • Make sure that each layer has a unique name. This is not a requirement of the software, but helps to keep you from becoming confused.

  • If you think that you might add layers to the Photoshop file in Photoshop after you have imported it into After Effects, go ahead and add a small number of placeholder layers before you import the file into After Effects. When you refresh the file in After Effects, it will not pick up any layers that have been added since the file was imported.

  • Unlock layers in Photoshop before importing into After Effects. This is not necessary for most kinds of layers, but it is required for some kinds of layers. For example, background layers that must be converted to RGB may not be imported correctly if they are locked.

A convenient command within After Effects is Layer > New > Adobe Photoshop File, which adds a layer to a composition and then opens the source of that layer in Photoshop for you to begin creating a visual element, such as a background layer for your movie. The layer in Photoshop is created with the correct settings for your After Effects composition. As with many of the Creative Suite applications, you can use the Edit Original command in After Effects to open a PSD file in Photoshop, make and save changes, and have those changes appear immediately in the movie that refers to the PSD source file. Even if you don’t use Edit Original, you can use the Reload Footage command to have After Effects refresh its layers to use the current version of the PSD file. (See Create a layer and new Photoshop footage item and Edit footage in its original application.)

Note:

One good way to prevent interlace flicker from thin horizontal lines in still images is to run the Interlace Flicker Removal action in Photoshop before you bring the still images into After Effects. Photoshop includes several video actions for utility purposes such as this.

Online resources about preparing and importing Photoshop files

Richard Harrington and Ian Robinson provide a free sample chapter from their “Motion Graphics with Adobe Creative Suite 5 Studio Techniques” book on the Peachpit Press website. This chapter shows how to prepare Illustrator and Photoshop files.

See this video tutorial by Andrew Devis on the Creative Cow website about importing and using Photoshop PSD files in After Effects.

Color modes

Layered Photoshop (PSD) files need to be saved in RGB or Grayscale color mode for After Effects to import them as a composition and to separate the layers. CMYK, LAB, Duotone, Monotone, and Tritone color modes are not supported for layered files; After Effects will import a file that uses one of these color modes as a single, flattened image. (Regarding the other color modes available in Photoshop such as Bitmap and Indexed: Photoshop does not support layers in these color modes.)

Note:

To determine or change the color mode of a document in Photoshop, choose Image > Mode. (The color mode is also displayed in the title bar of the document window.)

Masks and alpha channels

Adobe Photoshop supports a transparent area and one optional layer mask (alpha channel) for each layer in a file. You can use these layer masks to specify how different areas within a layer are hidden or revealed. If you import one layer, After Effects combines the layer mask (if present) with the transparent area and imports the layer mask as a straight alpha channel.

If you import a layered Photoshop file as a merged file, After Effects merges the transparent areas and layer masks of all the layers into one alpha channel that is premultiplied with white.

When you import a Photoshop file as a composition, vector masks are converted to After Effects masks. You can then modify and animate these masks within After Effects.

Photoshop clipping groups, layer groups, and Smart Objects

If the layered Photoshop file contains clipping groups, After Effects imports each clipping group as a precomposition nested within the main composition. After Effects automatically applies the Preserve Underlying Transparency option to each layer in the clipping-group composition, maintaining transparency settings. These nested precompositions have the same dimensions as the main composition.

Note:

Paul Tuersley provides a script on the AE Enhancers forum that crops the precompositions to the size of their contents, while retaining their correct position in the main composition.

Photoshop layer groups are imported as individual compositions.

It is often valuable to group layers into Smart Objects in Photoshop so that you can import meaningful collections of Photoshop layers as individual layers in After Effects. For example, if you used 20 layers to create your foreground object and 30 layers to create your background object in Photoshop, you probably don’t need to import all of those individual layers into After Effects if all that you want to do is animate your foreground object flying in front of your background object; consider grouping them into a single foreground Smart Object and a single background Smart Object before importing the PSD file into After Effects.

Photoshop layer styles and blending modes

After Effects also supports blending modes and layer styles applied to the file. When you import a Photoshop file with layer styles, you can choose the Editable Layer Styles option or the Merge Layer Styles Into Footage option:

Editable Layer Styles

Matches appearance in Photoshop and preserves supported layer style properties as editable.

Note:

A layer with a layer style interferes with intersection of 3D layers and the casting of shadows.

Merge Layer Styles Into Footage

Layer styles are merged into the layer for faster rendering, but the appearance may not match the appearance of the image in Photoshop. This option doesn’t interfere with intersection of 3D layers or casting of shadows.

Photoshop video layers

Photoshop files can contain video and animation layers. After Effects can import these files like any other Photoshop files, either as a footage item with all layers merged together or as a composition with each Photoshop layer separate and editable in After Effects. (Working with Photoshop video layers requires QuickTime 7.1 or later.)

Note:

After Effects can’t import a Photoshop video layer that uses an image sequence as its source.

In After Effects CS6 and later, video layer support in Photoshop .psd documents has been removed. The layers will still have a duration, but won't play. Animating layers with available properties in the Photoshop animation timeline (like Position and Opacity) are supported.

Preparing and importing Illustrator files

Note:

For information and instructions that apply to all kinds of still image files, see Preparing still-image files for importing and Import a single still image or a still-image sequence.

Before you save an Illustrator file for importing into After Effects, consider doing the following:

  • Create your document in Illustrator using one of the Video And Film document profiles. In addition to creating a document at the appropriate size for video or film work, this creates a document with two artboards: one at the appropriate frame size, and one much larger. When you bring such a document into After Effects, the area outside the smaller artboard isn’t cropped and lost; it’s retained outside of the composition frame. This only works for an Illustrator document with multiple layers imported as a composition.

  • To ensure that Illustrator files appear correctly in After Effects, select Create PDF Compatible File in the Illustrator Options dialog box.

  • To copy paths between Illustrator and After Effects, make sure that the Preserve Paths option is selected in the Files & Clipboard section of the Illustrator Preferences dialog box.

  • To ensure that files rasterize most faithfully in After Effects, save your file in AI format instead of Illustrator 8.x or 9.x EPS format.

  • To separate objects in an Illustrator file into separate layers, use the Release To Layers command in Illustrator. Then, you can import the layered file into After Effects and animate the layers separately.

  • If you are working with Edit Original to move objects and layers in Illustrator, import the Illustrator document into After Effects as a composition with document-sized layers (not using the Retain Layer Size option).

When you import an Illustrator file, After Effects makes all empty areas transparent by converting them into an alpha channel.

Note:

When you’ve imported an Illustrator file, you can specify whether anti-aliasing is to be performed at higher quality or at higher speed. Select the footage item in the Project panel and choose File > Interpret Footage > Main, and click the More Options button at the bottom of the dialog box.

After Effects does not read embedded color profiles from Illustrator files. To ensure color fidelity, assign an input color profile to the Illustrator footage item that matches the color profile with which the Illustrator file was created.

Note:

After Effects can’t read blending modes from AI documents saved as a version later than Illustrator CS2. If you need to retain blending mode information when importing a file into After Effects from Illustrator, save the document as an Illustrator CS2 document.

For information on preserving sharpness of vector graphics (avoiding pixelation), see Continuously rasterize a layer containing vector graphics.

Online resources for preparing and importing Illustrator files

Eran Stern provides a video tutorial on the Creative COW website that shows how to create text in Illustrator for use in After Effects.

Dave Nagel provides instructions on the DMN website for importing an Illustrator document into After Effects with the Illustrator objects on separate layers in After Effects.

In a thread on the After Effects user-to-user forum, JETalmage provides a script that converts sub-layers in Illustrator into top-level layers. This is a necessary step in preparing an Illustrator file for importing into After Effects if you intend to animate these items independently.

Steve Holmes provides a tutorial on the Layers Magazine website that shows how to create and prepare vines, swirls, and flourishes in Illustrator and then import, reveal, and animate them in After Effects using the Stroke effect.

Richard Harrington and Ian Robinson provide a free sample chapter from their “Motion Graphics with Adobe Creative Suite 5 Studio Techniques” book on the Peachpit Press website. This chapter shows how to prepare Illustrator and Photoshop files.

Importing camera raw files with Camera Raw

You can import sequences of camera raw files much as you import sequences of other kinds of still image files.

After Effects applies the settings for the first camera raw image in the sequence to all of the images in the sequence that do not have their own XMP sidecar files. After Effects does not check the Camera Raw database for image settings.

Note:

Camera raw files are uncompressed. Their large size may increase rendering time.

  • Choose File > Import > File.

  • Select the camera raw file, and click Open.

  • Make any necessary adjustments in the Camera Raw dialog box, and click OK.

You can adjust a camera raw image after importing it. To open the image in the Camera Raw dialog box, select the footage item in the Project panel, choose File > Interpret Footage > Main, and click More Options.

Note:

You can’t assign an input color profile to a camera raw image for use in a color-managed project. For information on how colors are automatically interpreted, see Interpret a footage item by assigning an input color profile.

Note:

See this blog post for links to free excerpts from books about Camera Raw by Conrad Chavez, Bruce Fraser, Jeff Schewe, Ben Willmore, and Dan Ablan. 

Cineon and DPX footage items

A common part of the motion-picture film production workflow is scanning the film and encoding the frames into the Cineon or DPX file format. The DPX (Digital Picture Exchange) format is a standard format closely related to the Cineon format.

You can import Cineon 4.5 or Digital Picture Exchange (DPX) files directly into an After Effects project as individual frames or as a sequence of numbered stills. Once you have imported a Cineon or DPX file, you can use it in a composition and then render the composition as an image sequence.

To preserve the full dynamic range of motion-picture film, Cineon files are stored using logarithmic 10-bpc color. However, After Effects internally uses 8‑bpc, 16‑bpc, or 32-bpc color, depending on the color bit depth of the project. Work with Cineon files in a 16- or 32-bpc project—by default, After Effects stretches the logarithmic values to the full range of values available.

Cineon data has a 10-bit white point of 685 and a 10-bit black point of 95. Values above 685 are retained, but are treated as highlights. Rather than abruptly clipping highlights to white, After Effects interprets highlights using a gradual ramp defined by the Highlight Rolloff value. You can modify the 10-bit white point and 10-bit black point input levels and the output (converted) white point and black point levels to match your specific footage items or creative needs.

Use a project color depth of 32 bpc when working with Cineon footage items so that highlights are preserved, in which case you don’t need to roll off the highlights.

When you choose DPX/Cineon Sequence from the Format menu in the Output Module Settings dialog box, you can then open the Cineon Settings dialog box to set output options. Choose whether to output DPX (.dpx) files or FIDO/Cineon 4.5 (.cin) files in the File Format section of the Cineon Settings dialog box.

After Effects provides three basic ways of working with the colors in Cineon footage items:

  • The easiest—and recommended—way is to enable color management and assign an input color profile to a Cineon footage item in the Color Management tab of the Interpret Footage dialog box, corresponding to the film stock on which the footage was recorded. If creating output for film, use the same profile as the output color profile so that the output file matches the film stock. One advantage of using color management features to work with Cineon footage items is that compositing with images from other footage types is made easier. See Interpret a footage item by assigning an input color profile.

  • If you need the settings for the interpretation of the Cineon footage item to change over time, then you can apply the Cineon Converter effect to a layer that uses the Cineon footage item as its source. See Cineon Converter effect.

  • If you need to manually modify the settings for a Cineon footage item, or if you don’t want to use color management, then you can use the Cineon Settings dialog box. To open this dialog box, click the Cineon Settings button in the Color Management tab of the Interpret Footage dialog box.

Manual settings in the Cineon Settings dialog box:

Converted Black Point

Specifies the black point used for the layer in After Effects.

Converted White Point

Specifies the white point used for the layer in After Effects.

10 Bit Black Point

Specifies the black level (minimum density) for converting a 10-bit Cineon layer.

10 Bit White Point

Specifies the white level (maximum density) for converting a 10-bit Cineon layer.

Current Gamma

Specifies the target gamma value.

Highlight Rolloff

Specifies the rolloff value used to correct bright highlights. To get over range values when working in 32 bpc, set the value to 0.

Logarithmic Conversion

Converts the Cineon sequence from log color space to the target gamma specified by the Current Gamma setting. When you’re ready to produce output from the Cineon file, it is important that you reverse the conversion. (To convert from logarithmic to linear, set Current Gamma to 1.)

Units

Specifies the units After Effects uses to display dialog values.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy