Create a camera layer and change camera settings

You can view 3D layers from any angle and distance using camera layers. Just as it’s easier in the real world to move cameras through and around a scene than it is to move and rotate the scene itself, it’s often easiest to get different views of a composition by setting up a camera layer and moving it around in a composition.

You can modify and animate camera settings to configure the camera to match the real camera and settings that were used to record footage with which you’re compositing. You can also use camera settings to add camera-like behaviors—from depth-of-field blur to pans and dolly shots—to synthetic effects and animations.

Cameras affect only 3D layers and 2D layers with an effect with a Comp Camera attribute. With effects that have a Comp Camera attribute, you can use the active composition camera or lights to view or light an effect from various angles to simulate more sophisticated 3D effects.

You can choose to view a composition through the active camera or through a named custom camera. The active camera is the topmost camera in the Timeline panel at the current time for which the Video switch is selected. The active camera view is the point of view used for creating final output and nesting compositions. If you have not created a custom camera, then the active camera is the same as the default composition view.

All cameras are listed in the 3D View menu at the bottom of the Composition panel, where you can access them at any time.

It’s often easiest to adjust a camera when using one of the custom 3D views. You can’t—of course—see the camera to manipulate it when you’re looking through the camera itself.

Example of a camera
Example of a camera

A. Point of interest B. Frame C. Camera 

Create a camera layer

  • Choose Layer > New > Camera, or press Ctrl+Alt+Shift+C (Windows) or Command+Option+Shift+C (Mac OS).

    Note:

    By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)).

Change camera settings

You can change camera settings at any time.

  • Double-click the camera layer in the Timeline panel, or select the layer and then choose Layer > Camera Settings.

Note:

By default, the Preview option in the Camera Settings dialog box is selected. This option shows the changes in the composition as you make them in the Camera Settings dialog box.

Camera settings

You can change camera settings at any time by double-clicking the layer in the Timeline panel or selecting the layer and choosing Layer > Camera Settings.

Note:

Select Preview in the Camera Settings dialog box to show results in the Composition panel as you modify settings in the dialog box.

Note:

The three things that affect depth of field are focal length, aperture, and focus distance. Shallow (small) depth of field is a result of long focal length, short focus distance, and a larger aperture (smaller F-stop). A shallower depth of field means a larger depth-of-field blur result. The opposite of a shallow depth of field is deep focus—meaning a smaller depth-of-field blur because more is in focus.  

Camera properties relating to camera lens blur and shape include Iris Shape, Iris Rotation, Iris Roundness, Iris Aspect Ratio, Iris Diffraction Fringe, Highlight Gain, Highlight Threshold, and Highlight Saturation.

Type

One-Node Camera or Two-Node Camera. A one-node camera orients around itself, whereas a two-node camera has a point of interest and orients around that point. Making a camera a two-node camera is the same as setting a camera’s auto-orientation option (Layer > Transform > Auto-Orient) to Orient Towards Point Of Interest. (See Auto-Orientation options.)

Name

The name of the camera. By default, Camera 1 is the name of first camera that you create in a composition, and all subsequent cameras are numbered in ascending order. You should choose distinctive names for multiple cameras to make it easier to distinguish them.

Preset

The type of camera settings you want to use. The presets are named according to focal lengths. Each preset is meant to represent the behavior of a 35mm camera with a lens of a certain focal length. Therefore, the preset also sets the Angle Of View, Zoom, Focus Distance, Focal Length, and Aperture values. The default preset is 50mm. You can also create a custom camera by specifying new values for any of the settings.

Zoom

The distance from the lens to the image plane. In other words, a layer that is the Zoom distance away appears at its full size, a layer that is twice the Zoom distance away appears half as tall and wide, and so on.

Angle Of View

The width of the scene captured in the image. The Focal Length, Film Size, and Zoom values determine the angle of view. A wider angle of view creates the same result as a wide-angle lens.

Depth Of Field

Applies custom variables to the Focus Distance, Aperture, F-Stop, and Blur Level settings. Using these variables, you can manipulate the depth of field to create more realistic camera-focusing effects. (The depth of field is the distance range within which the image is in focus. Images outside the distance range are blurred.)

Focus Distance

The distance from the camera to the plane that is in perfect focus.

Note:

Add this expression to the Focus Distance property to lock the focal plane to the camera's point of interest so that the point of interest is in focus: length(position, pointOfInterest)

Lock To Zoom

Makes the Focus Distance value match the Zoom value.

Note:

If you change the settings of the Zoom or Focus Distance options in the Timeline panel, the Focus Distance value becomes unlocked from the Zoom value. If you need to change the values and want the values to remain locked, then use the Camera Settings dialog box instead of the Timeline panel. Alternatively, you can add an expression to the Focus Distance property in the Timeline panel: Select the Focus Distance property, and choose Animation > Add Expression; then drag the expression pick whip to the Zoom property. (See Expression basics.)

Aperture

The size of the lens opening. The Aperture setting also affects the depth of field—increasing the aperture increases the depth of field blur. When you modify Aperture, the values for F-Stop change to match it.

Note:

In a real camera, increasing the aperture also allows in more light, which affects exposure. Like most 3D compositing and animation applications, After Effects ignores this result of the change in aperture values

F-Stop

Represents the ratio of the focal length to aperture. Most cameras specify aperture size using the f-stop measurement; thus, many photographers prefer to set the aperture size in f-stop units. When you modify F-Stop, Aperture changes to match it.

Blur Level

The amount of depth-of-field blur in an image. A setting of 100% creates a natural blur as dictated by the camera settings. Lower values reduce the blur.

Film Size

The size of the exposed area of film, which is directly related to the composition size. When you modify Film Size, the Zoom value changes to match the perspective of a real camera.

Focal Length

The distance from the film plane to the camera lens. In After Effects, the position of the camera represents the center of the lens. When you modify Focal Length, the Zoom value changes to match the perspective of a real camera. In addition, the Preset, Angle Of View, and Aperture values change accordingly.

Units

The units of measurement in which the camera setting values are expressed.

Measure Film Size

The dimensions used to depict the film size.

Note:

For best results, work in 32-bpc with Linearize Working Space selected in the project settings.

Camera Commands

After Effects has camera commands that can be used separately or with the Create Stereo 3D Rig function. To use the camera commands, select a camera layer, and then choose Layer > Camera.

Link Focus Distance to Point of Interest

Creates an expression on the selected camera layer’s Focus Distance property, setting the property’s value to the distance between the camera and its point of interest.

Link Focus Distance to Layer

Creates an expression on the selected camera layer’s Focus Distance property to be the distance between the camera’s position and another layer. This method allows the focus to follow the other layer automatically.

Set Focus Distance to Layer

Sets the value of the Focus Distance property at the current time to the distance at the current time between the camera and the selected layer.

Online resources about cameras

For a video tutorial that shows how to create and modify a camera and use the Camera tools, see the Adobe website.

Dale Bradshaw provides a script and sample project for automating the rigging of a camera on the Creative Workflow Hacks website.

Mark Christiansen provides tips and detailed techniques for working with cameras in the “Virtual Cinematography in After Effects” chapter of After Effects Studio Techniques on the Peachpit Press website. This chapter includes information about matching lens distortion, performing camera moves, performing camera projection (camera mapping), using rack focus, creating boke blur, using grain, and choosing a frame rate to match your story-telling.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the Focal Press website.

Richard Harrington provides a video tutorial on the Creative COW website that shows how to use the Camera tools and camera views in After Effects to create a camera move with 3D layers. (This tutorial is the second in a two-part series. Part 1 concentrates on working with photographs to isolate and create sky in Photoshop for use in After Effects.)

Andrew Kramer provides a two-part video tutorial on his Video Copilot website that demonstrates basic camera mapping and camera projection. In this tutorial, he shows how to project an image onto 3D layers using lights and light transmission properties.

Create a light and change light settings

A light layer can affect the colors of the 3D layers that it shines on, depending on the light’s settings and the Material Options properties of the 3D layers. Each light, by default, points to its point of interest.

Lights can be used to illuminate 3D layers and to cast shadows. You can use lights to match lighting conditions of the scene into which you are compositing or to create more interesting visual results. For example, you can use light layers to create the appearance of light streaming through a video layer as if it were made of stained glass.

You can animate all of the settings for a light, except for the light type and the Casts Shadows property.

Light types: Spot (upper-left); Point (upper-right); Parallelc(lower-left); Ambient lower-right)
Light types: Spot (upper-left); Point (upper-right); Parallelc(lower-left); Ambient lower-right)

A. Point of interest B. Light icon 

You can specify which 3D layers a light affects by designating the light as an adjustment layer: place the light in the Timeline panel above the layers on which you want it to shine. Layers that are above a light adjustment layer in the layer stacking order in the Timeline panel do not receive the light, regardless of the positions of the layers in the Composition panel.

Create a light

  • Choose Layer > New > Light, or press Ctrl+Alt+Shift+L (Windows) or Command+Option+Shift+L (Mac OS).

    Note:

    By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)).

Change light settings

  • Double-click a light layer in the Timeline panel or select the layer and choose Layer > Light Settings.

    Note:

    Select Preview in the Light Settings dialog box to show results in the Composition panel as you modify settings in the dialog box.

Light settings

Light Type

Parallel emits directional, unconstrained light from an infinitely distant source, approximating the light from a source like the Sun. Spot emits light from a source that is constrained by a cone, like a flashlight or a spotlight used in stage productions. Point emits unconstrained omnidirectional light, like the rays from a bare light bulb. Ambient creates light that has no source but rather contributes to the overall brightness of a scene and casts no shadows.

Note:

Because the position in space of an Ambient light does not affect its influence on other layers, an Ambient light does not have an icon in the Composition panel.

Intensity

The brightness of the light. Negative values create nonlight. Nonlight subtracts color from a layer. For example, if a layer is already lit, creating a directional light with negative values also pointing at that layer darkens an area on the layer.

Color

The color of the light.

Cone Angle

The angle of the cone surrounding the source of a light, which determines the width of the beam at a distance. This control is active only if Spot is selected for Light Type. The cone angle of a Spot light is indicated by the shape of the light icon in the Composition panel.

Note:

In After Effects CS6 or later, a selected spot light's cone can be extended to the point of interest.

Cone Feather

The edge softness of a spotlight. This control is active only if Spot is selected for Light Type.

Falloff

The type of falloff for a parallel, spot, or point light. Falloff describes how a light’s intensity is lessened over distance.

For details, tutorials, and resources about light falloff, see this article on the Adobe website.

Falloff types include the following:

None

Illumination does not decrease as the distance between the layer and the light increases.

Smooth

Indicates a smooth linear falloff starting at the Falloff Start radius and extending the length specified by Falloff Distance.

Inverse Square Clamped

Indicates a physically accurate falloff starting at the Falloff Start radius and decreasing proportionally to the inverse square of the distance away.

Radius

Specifies the radius of falloff from a light. Inside this distance, the light is a constant light. Outside this distance, the light falls off.

Falloff Distance

Specifies the distance a light falls off from a light.

Casts Shadows

Specifies whether the light source causes a layer to cast a shadow. The Accepts Shadows material option must be On for a layer to receive a shadow; this setting is the default. The Casts Shadows material option must be On for a layer to cast shadows; this setting is not the default.

Note:

Press Alt+Shift+C (Windows) or Option+Shift+C (Mac OS) to toggle Casts Shadows for selected layers. Press AA to show Material Options properties in the Timeline panel.

Shadow Darkness

Sets the darkness of the shadow. This control is active only if Cast Shadows is selected.

Shadow Diffusion

Sets the softness of a shadow based on its apparent distance from the shadowing layer. Larger values create softer shadows. This control is active only if Casts Shadows is selected.

Online resources about lights

Eran Stern provides a video tutorial on the Creative COW website that demonstrates the use of lights as adjustment layers, to precisely control which layers are affected by which lights.

Chris and Trish Meyer provide tips about shadows and lights in 3D in an article on the ProVideo Coalition website.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the Focal Press website.

Chris and Trish Meyer provide a tutorial on the Artbeats website that demonstrates how to use lights and 3D layers to project a video onto other layers, such as onto a wall.

Adjust a 3D view or move a camera, light, or point of interest

Camera layers and light layers each include a Point Of Interest property, which specifies the point in the composition at which the camera or light points. By default, the point of interest is at the center of the composition. You can move the point of interest at any time.

A one-node camera ignores the point of interest. (See Camera settings.)

To make a light ignore its point of interest, select an option other than Orient Towards Point Of Interest in the light’s Auto-Orientation options. (See Auto-Orientation options.)

Note:

As with all properties, you can also modify a camera or light’s properties directly in the Timeline panel.

Move a camera, light, or point of interest with the Selection and Rotation tools

  1. Select a camera or light layer.
  2. Using the Selection or Rotation tool, do one of the following:
    • To move the camera or light and its point of interest, position the pointer over the axis you want to adjust, and drag.

    • To move the camera or light along a single axis without moving the point of interest, Ctrl-drag (Windows) or Command-drag (Mac OS) the axis.

    • To move the camera or light freely without moving the point of interest, drag the camera icon or light icon.

    • To move the point of interest, drag the point of interest icon .

Move or adjust a camera or working 3D view with the Camera tools

You can adjust the Position and Point Of Interest properties of a camera layer by using the Camera tools in the Composition panel.

You can also use the Camera tools to adjust a working 3D view, a 3D view that is not associated with a camera layer. You can think of 3D views as being virtual cameras through which you can view and preview a composition. The working 3D views include the custom views and the fixed orthographic views (Front, Left, Top, Back, Right, or Bottom). The working 3D views are useful for placing and previewing elements in a 3D scene. If you use a Camera tool to adjust a working 3D view, no layer property values are affected.

After you’ve modified a 3D view, you can reset it by choosing View > Reset 3D View.

You can’t use the Orbit Camera tool on the fixed orthographic views.

For information on choosing and using 3D views, see Choose a 3D view.

  1. In the 3D View menu at the bottom of the Composition panel, choose the camera or 3D view to adjust.
  2. Activate a Camera tool.

    You can activate a Camera tool by selecting it in the Tools panel or pressing C to cycle through the Camera tools. The easiest way to switch between the various Camera tools is to select the Unified Camera tool and use the buttons on a three-button mouse.

    Orbit Camera

    Rotates the 3D view or camera by moving around the point of interest. (To temporarily activate the Orbit Camera tool when the Unified Camera Tool is selected, hold the left mouse button.)

    Note:

    Shift-dragging with the Unified Camera tool selected temporarily activates the Orbit Camera tool and constrains rotation to one axis.

    Track XY Camera

    Adjusts the 3D view or camera horizontally or vertically. (To temporarily activate the Track XY Camera tool when the Unified Camera Tool is selected, hold the middle mouse button.)

    Track Z Camera

    Adjusts the 3D view or camera along the line to the point of interest. If you are using an orthographic view, this tool adjusts the scale of the view. (To temporarily activate the Track Z Camera tool when the Unified Camera Tool is selected, hold the right mouse button.)

  3. Drag in the Composition panel. You can continue a drag operation outside the panel after you’ve begun dragging within the panel.

After you’ve modified a 3D view, you can reset it by choosing View > Reset 3D View.

Move or adjust a camera or working 3D view to look at layers

You can also move a camera or adjust a 3D view to look at selected layers or all layers. After Effects changes the point of view and direction of view to include the layers that you have selected.

  • To adjust a 3D view or move a camera to look at selected layers, choose View > Look At Selected Layers.
  • To adjust a 3D view or move a camera to look at all layers, choose View > Look At All Layers.

For keyboard shortcuts for these commands, see 3D layers (keyboard shortcuts).

Tips and online resources for moving and animating cameras and lights

Before moving a camera, choose a view other than Active Camera. If you use Active Camera view, you are looking through the camera, which makes it harder to manage.

By default, a camera's wireframe is only visible when the camera is selected. To always show the camera wireframe, set the view options for the Composition panel (View > View Options). (See Show or hide layer controls in the Composition panel.)

When working with a camera or light layer, create a null object layer and use an expression to link the Point Of Interest property of the camera or light to the Position property of the null layer. Then, you can animate the Point Of Interest property by moving the null object. It is often easier to select and see a null object than it is to select and see the point of interest.

In After Effects, there is a camera command, “Create Orbit Null.” This parents the selected camera layer to a new null layer. The new null layer is renamed, based on the camera’s name appended with Orbit Null

Trish and Chris Meyer show you how to use the Create Orbit Null camera command in this video tutorial on Adobe TV.

For a video tutorial that shows how to create and modify a camera and use the Camera tools, see the Adobe website.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the Focal Press website.

 

Mark Christiansen provides tips and detailed techniques for working with cameras in the “Virtual Cinematography in After Effects” chapter of After Effects Studio Techniques on the Peachpit Press website. This chapter includes information about matching lens distortion, performing camera moves, performing camera projection (camera mapping), using rack focus, creating boke blur, using grain, and choosing a frame rate to match your story-telling.

Richard Harrington provides a video tutorial on the Creative COW website that shows how to use the Camera tools and camera views in After Effects to create a camera move with 3D layers. (This tutorial is the second in a two-part series. Part 1 concentrates on working with photographs to isolate and create sky in Photoshop for use in After Effects.)

Rich Young provides a set of expressions on his AE Portal website that use the toWorld method link a camera and light to a layer with the CC Sphere effect.

Andrew Devis of Creative Cow has created a 3 tutorial series on Animating a Camera:

This video from video2brain demonstrates the command to create a new camera orbit null.

Material Options properties

3D layers have Material Options properties, which determine how a 3D layer interacts with light and shadow.

Casts Shadows

Specifies whether a layer casts shadows on other layers. The direction and angle of the shadows are determined by the direction and angle of the light sources. Set Casts Shadows to Only if you want the layer to be invisible but still cast a shadow.

Note:

Use the Only setting and a nonzero Light Transmission setting to project the colors of an invisible layer onto another layer. Steve Holmes provides a video tutorial on the Artbeats website in which he demonstrates how to use layers with Cast Shadows set to Only to cast shadows of specific shapes within a 3D scene.

Light Transmission

The percentage of light that shines through the layer, casting the colors of the layer on other layers as a shadow. 0% specifies that no light passes through the layer, casting a black shadow. 100% specifies that the full values of the colors of the shadow-casting layer are projected onto the layer accepting the shadow.

Note:

Use partial light transmission to create the appearance of light passing through a stained glass window.

Accepts Shadows

Specifies whether the layer shows shadows cast on it by other layers. There is an “Only” option in  the Accepts Shadows for when you want to render only a shadow on a layer.

Accepts Lights

Specifies whether the color of a layer is affected by light that reaches it. This setting does not affect shadows.

Ambient

Ambient (nondirectional) reflectivity of the layer. 100% specifies the most reflectivity; 0% specifies no ambient reflectivity.

Diffuse

Diffuse (omnidirectional) reflectivity of the layer. Applying diffuse reflectivity to a layer is like draping a dull, plastic sheet over it. Light that falls on this layer reflects equally in all directions. 100% specifies the most reflectivity; 0% specifies no diffuse reflectivity.

Specular

Specular (directional) reflectivity of the layer. Specular light reflects from the layer as if from a mirror. 100% specifies the most reflectivity; 0% specifies no specular reflectivity.

Shininess

Determines the size of the specular highlight. This value is active only if the Specular setting is greater than zero. 100% specifies a reflection with a small specular highlight. 0% specifies a reflection with a large specular highlight.

Metal

The contribution of the layer color to the color of the specular highlight. 100% specifies that the highlight color is the color of the layer. For example, with a Metal value of 100%, an image of a gold ring reflects golden light. 0% specifies that the color of the specular highlight is the color of the light source. For example, a layer with a Metal value of 0% under a white light has a white highlight.

Specify resolution to use for rendering shadows

The Advanced 3D rendering plug-in is used to render compositions containing intersecting 3D layers. To render shadows, the plug-in uses shadow maps, which are images rendered from the point of view of each light source. Normally, shadow resolution is computed automatically based on the composition resolution and the quality settings of the layers. If normal resolution doesn’t create the quality you want, odr renders too slowly, you can adjust the shadow map resolution. For example, if shadows are blurry and the Shadow Diffusion material option is set to 0, increase the shadow map resolution. Or, if shadows render too slowly, decrease the shadow map resolution.

When a shadow-casting layer intersects another layer, sometimes a small gap occurs behind the intersection that is supposed to be shadowed. To decrease the size of the gap, increase the shadow map resolution.

Stereoscopic 3D

You can create stereoscopic 3D videos with Adobe After Effects.

For tutorials, details, and resources about stereoscopic 3D, see this article on the Adobe website.

For an overview of stereoscopic 3D workflow in After Effects, see Understanding Stereoscopic 3D in After Effects.

Mark Christiansen shows compositing stereoscopic 3D footage (using free clip from Art Beats).

Stereoscopic 3D camera rig

After Effects has a Create Stereo 3D Rig menu command, allowing you to turn a 3D composition into a stereoscopic 3D composition. The Stereo 3D Rig creates all the elements for you, including the 3D Glasses effect.

Make a stereoscopic 3D camera rig by first creating a composition with 3D elements in it. A composition that contains items such as a 3D collapsed precomposition or 3D elements in the composition itself works well. If you already have a camera in use, you can select it when creating the stereoscopic 3D camera rig. If no camera is selected, then a new camera (named Master Cam) is created. Choose Layer > Camera > Create Stereo 3D Rig. The rig only works with two-node cameras.

The rig is produced by creating a master camera or by using the existing selected camera in the composition. There are left eye [compare Left Eye] and right eye [compare Right Eye] compositions. Each composition has a camera linked to the master camera, the original composition nested in them, and an output stereo 3D composition [compare Stereo 3D]. The output stereo 3D composition nests both eye compositions and contains a layer called Stereo 3D Controls. This layer contains a Stereo 3D Controls effect for controlling the rig and a 3D Glasses effect that combines the left and right eye compositions into a stereo image. (see 3D Glasses effect.)

Note:

The Stereo 3D Controls effect is an effect built as part of the Stereo 3D Rig and does not reside in the Effects and Presets panel.

The Stereo 3D Controls effect has the following settings for Camera Separation and Convergence:

Configuration

Center places the left and right camera on either side of the master camera. Hero Left places the left camera in the same spot as the master camera with the right camera to the right. Conversely, Hero Right places the right camera at the master camera position with the left camera to the left.

Stereo Scene Depth

Controls the interaxial separation between the cameras as a percentage of the composition’s width. That way, if the composition is resized, the separation amount is constant. This setting starts low at a value of 3% to keep the effect subtle. Ideally, this value does not need to increase to more than 14%-30% for reasonable 3D footage. However, it can be bigger depending on the scene content (objects are very close together) and the camera field of view, for example.

Note:

Changing this value affects the depth to which the Stereo 3D goes in and out of the scene. Note that pushing the value too high can cause eye strain.

Converge Cameras

When off, the cameras remain parallel to the master camera but offset to either side. When on, the position remains offset. However, the Point of Interest of the left and right cameras are joined at the location based upon the following two properties.

Converge To and Convergence Z Offset

Determines the Z distance away from the camera that the screen appears to be when looking through 3D glasses. Everything farther in Z space appears to be pushed into the screen, and everything closer appears to pop out of the screen. When working without converge the cameras check box on, and cameras are parallel, changing the scene convergence has the same effect as changing the Z offset. Use difference mode to set different elements in the scene to screen space in that case. (see 3D Glasses effect.)

Getting started with stereoscopic 3D

If you are working with stereoscopic 3D, you don’t necessarily need a 3D television. For example, you can use anaglyph (red-cyan) 3D glasses and view 3D stereoscopic footage right in the Composition panel. However, you can use a 3D television for doing live editing with a 3D television and active shutter glasses, as well. For that workflow, you’ll need a few things before getting started:

  • A monitor or television that supports 3D stereoscopic viewing.
  • Glasses for viewing stereoscopic 3D television.

Note:

For this workflow, use active shutter glasses that require an emitter device. Make sure that you are using the glasses that the television manufacturer recommends.

  • Stereoscopic footage or a 3D composition.

Once you have gathered these items, do the following:

  1. Connect the 3D TV to your computer with an HDMI cable (DVI is acceptable if HDMI is not available).

  2. Create a 3D composition in After Effects. Make sure that the composition size matches the current resolution of your output monitor.

  3. Make a new Composition panel for your Stereo 3D composition. Lock the composition, and then drag it to your 3D TV monitor.

  4. Ensure that the Composition panel is set to 100%.

  5. Type Control + \(backslash) twice to set the composition to full screen for the 3D TV. Set the dimensions of the composition and the 3D TV to be the same.

  6. Switch the 3D view in the 3D Glasses effect to one of the following:

    • Stereo Pair

    • Over Under

    • Interlaced

  7. Turn on 3D mode for your 3D TV and match the format to what was set in 3D View for the 3D Glasses effect. (Stereo Pair, and Over Under are supported on most 3D TVs.

  8. Put on your 3D glasses, and edit your composition in true stereoscopic 3D.

Stereoscopic 3D tips

  • If you are working with3D stereoscopic footage in the Composition panel and you do not have a 3D television, you can work with the anaglyph format. Ordinary red and cyan anaglyph 3D glasses work best for this 3D stereoscopic workflow.

  • Increase or decrease Stereo Scene Depth to change how deep the 3D environment appears.

  • Turn on Converge Cameras and change the Convergence Z Offset to move different objects behind and in front of the screen. Objects closer to the camera than the Z offset appears in front of the screen, objects farther away appears behind it.

  • You can make your composition’s depth of field to match your stereoscopic camera’s convergence by doing one of the following:

    • When using “Link Focus Distance to Point of Interest” on the master camera, and converge cameras for the rig, the depth of field and stereoscopic 3D convergence matches.

    • If you want the depth of field to change over time, you can animate the focus distance of the master camera. Then, set the convergence point to converge from “Camera Position”, and set an expression linking the convergence Z offset to the master camera’s Focus Distance

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy