Interlaced video and separating fields

Interlacing is a technique developed for transmitting television signals using limited bandwidth. In an interlaced system, only half the number of horizontal lines for each frame of video are transmitted at a time. Because of the speed of transmission, the afterglow of displays, and the persistence of vision, the viewer perceives each frame in full resolution. All of the analog television standards use interlacing. Digital television standards include both interlaced and noninterlaced varieties. Typically, interlaced signals are generated from interlaced scanning, whereas noninterlaced signals are generated from progressive scanning.

Each interlaced video frame consists of two fields. Each field contains half the number of horizontal lines in the frame; the upper field (or Field 1) contains the odd-numbered lines, and the lower field (or Field 2) contains the even-numbered lines. An interlaced video monitor displays each frame by first drawing all of the lines in one field and then drawing all of the lines in the other field. Field order specifies which field is drawn first. In NTSC video, new fields are drawn to the screen approximately 60 times per second, corresponding to a frame rate of approximately 30 frames per second.

Noninterlaced video frames aren’t separated into fields. A progressive‑scan monitor displays a noninterlaced video frame by drawing all the horizontal lines, from top to bottom, in one pass. Computer monitors are almost all progressive-scan monitors, and most video displayed on computer monitors is noninterlaced.

The terms progressive and noninterlaced are thus closely related and are often used interchangeably, but progressive scanning refers to the recording or drawing of the scan lines by a camera or monitor, whereas noninterlaced refers to the fact that the video data itself isn’t separated into fields.

Interlaced scanning of interlaced video fields compared with progressive scanning of noninterlaced video frame
Interlaced scanning of interlaced video fields compared with progressive scanning of noninterlaced video frame.

A. For interlaced video, entire upper field (odd-numbered lines) is drawn to screen first, from top to bottom, in one pass. B. Next, entire lower field (even-numbered lines) is drawn to screen, from top to bottom, in one pass. C. For noninterlaced video, entire frame (all lines in counting order) is drawn to screen, from top to bottom, in one pass. 

Separate video fields

If you want to use interlaced or field-rendered footage (such as NTSC video) in an After Effects project, you get the best results if you separate the video fields when you import the footage. After Effects separates video fields by creating a full frame from each field, preserving all of the image data from the original footage.

Separating fields is critical if you plan to make significant changes to the image. When you scale, rotate, or apply effects to interlaced video, unwanted artifacts, such as crossed fields, are often introduced. By separating fields, After Effects accurately converts the two interlaced frames in the video to noninterlaced frames, while preserving the maximum amount of image quality. Using noninterlaced frames allows After Effects to apply edits and effects consistently and at the highest quality.

After Effects creates field-separated footage from a single formerly interlaced frame by splitting it into two independent frames. Each new frame has only half the information of the original frame, so some frames may appear to have a lower resolution than others when viewed at Draft quality. When you render the final composition, After Effects reproduces high-quality interlaced frames for output. When you render a movie at Best quality, After Effects interpolates between the scan lines of a field to produce maximum image quality.

If your output will not be interlaced, it’s best to use noninterlaced source footage, to avoid the need to separate fields. However, if a noninterlaced version of your source footage is not available, interlaced footage will work fine.

Always separate fields for interlaced footage. Never separate fields for noninterlaced footage items.

You can only remove pull-down after you have separated fields.

When you render a composition containing field-separated footage, set the Field Rendering option to the same field order as your video equipment. If you don’t field-render the composition, or if you field-render with the incorrect settings, the final movie may appear too soft, jerky, or distorted.

Note:

To quickly give video footage a more film-like appearance, import the footage twice, and interpret each footage item with a different field order. Then add them both to the same composition and blend them together. The misinterpreted layer adds some film-like blur.

After Effects automatically separates fields for D1 and DV video footage items. You can manually separate fields for all other types of video footage in the Interpret Footage dialog box.

  1. Select the footage item in the Project panel.

  2. Choose File > Interpret Footage > Main.

  3. Choose an option from the Separate Fields menu.

  4. Click Preserve Edges (Best Quality Only) to increase image quality in nonmoving areas when the image is rendered at Best quality. Then click OK.

Note:

If the field settings in the Interpret Footage dialog box are correct for the input footage and the field settings in the Render Settings dialog box are correct for the output device, you can mix footage items of different field orders in a composition. If either of these settings is incorrect, however, the frames will be in the correct order, but the field order may be reversed, resulting in jerky, unacceptable images.

Determine the original field order

The field order for an interlaced video footage item determines the order in which the two video fields (upper and lower) are displayed. A system that draws the upper lines before the lower lines is called upper-field first; one that draws the lower lines before the upper lines is called lower-field first. Many standard-definition formats (such as DV NTSC) are lower-field first, whereas many high-definition formats (such as 1080i DVCPRO HD) are upper-field first.

The order in which the fields are displayed is important, especially when the fields contain motion. If you separate video fields using the wrong field order, motion does not appear smooth.

Some programs, including After Effects, label the field order when rendering interlaced video files. When you import a labeled video file, After Effects honors the field order label automatically. You can override this field order by applying different footage interpretation settings.

If a file does not contain a field order label, you can match the original field order of your footage. If you are not sure which field order was used to interlace a footage item, use this procedure to find out.

  1. Select the item in the Project panel.

  2. Choose File > Interpret Footage > Main.

  3. In the Interpret Footage dialog box, select Upper Field First from the Separate Fields menu, and then click OK.

  4. In the Project panel, press Alt (Windows) or Option (Mac OS) as you double-click the footage to open it in the Footage panel.

  5. If the Preview panel is not visible, choose Window > Preview.

  6. In the Footage panel, find a segment that contains one or more moving areas.

  7. Using the Next Frame button in the Preview panel, step forward at least five frames in the Footage panel. Moving areas should move consistently in one direction. If the moving areas move backward every other frame, the wrong field-separation option has been applied to the footage.

Online resources about fields and interlaced video

Chris Pirazzi provides technical details of fields and interlacing on his Lurker's Guide to Video website.

Trish and Chris Meyer provide a variety of materials about interlacing, field order, field dominance, field rendering, and separating fields:

Remove 3:2 or 24Pa pulldown from video

When you transfer 24-fps film to 29.97-fps video, you use a process called 3:2 pulldown, in which the film frames are distributed across video fields in a repeating 3:2 pattern. The first frame of film is copied to fields 1 and 2 of the first frame of video, and also to field 1 of the second video frame. The second frame of film is then spread across the next two fields of video—field 2 of the second video frame and field 1 of the third frame of video. This 3:2 pattern is repeated until four frames of film are spread over five frames of video, and then the pattern is repeated.

The 3:2 pulldown process results in whole frames (represented by a W) and split-field frames (represented by an S). The three whole video frames contain two fields from the same film frame. The remaining two split-field frames contain a video frame from two different film frames. The two split-field frames are always adjacent to each other. The phase of 3:2 pulldown refers to the point at which the two split-field frames fall within the first five frames of the footage.

Phase occurs as a result of two conversions that happen during 3:2 pulldown: 24-fps film is redistributed through 30-fps video, so each of four frames of 24-fps film is spread out over five frames of 30(29.97)-fps video. First, the film is slowed down 0.1% to match the speed difference between 29.97 fps and 30 fps. Next, each film frame is repeated in a special pattern and mated to fields of video.

Remove 3:2 or 24Pa pulldown from video
When you apply 3:2 pulldown to footage, one frame of the film (A) is separated into two or three interlaced video fields (B) which are grouped into video frames containing two fields each.

When importing interlaced video that was originally transferred from film, you can remove the 3:2 pulldown that was applied during the transfer from film to video as you separate fields so that effects you apply in After Effects don’t appear distorted.

It’s important to remove 3:2 pulldown from video footage that was originally film so that effects you add in After Effects synchronize perfectly with the original frame rate of film. Removing 3:2 pulldown reduces the frame rate by 1/5—from 30 to 24 fps or from 29.97 to 23.976 fps, which also reduces the number of frames you have to change. To remove 3:2 pulldown, you must also indicate the phase of the 3:2 pulldown.

After Effects also supports Panasonic DVX100 24p DV camera pulldown, called 24P Advance (24Pa). Some cameras use this format to capture 23.976 progressive-scan imagery using standard DV tapes.

Before you remove 3:2 pulldown, separate the fields as either upper-field first or lower-field first. Once the fields are separated, After Effects can analyze the footage and determine the correct 3:2 pulldown phase and field order. If you already know the phase and field order, choose them from the Separate Fields and the Remove menus in the Interpret Footage dialog box.

  1. In the Project panel, select the footage item from which to remove 3:2 pulldown.
  2. Choose File > Interpret Footage > Main.
  3. In the Fields and Pulldown section, select Upper Field First or Lower Field First from the Separate Fields menu.
  4. Do one of the following and click OK:
    • If you know the phase of the 3:2 or 24Pa pulldown, choose it from the Remove menu.

    • To have After Effects determine the correct settings, click Guess 3:2 Pulldown or Guess 24Pa Pulldown.

    Note:

    If your footage file contains frames from different sources, the phase may not be consistent. If the phase is inconsistent, import the footage multiple times, once for each phase, and interpret each footage item with a different setting. Then, add each footage item to your composition and trim each layer to use only the appropriate frames. In other words, if you have an asset that has multiple pulldown phases, then you need to cut that asset into pieces and remove pulldown separately for each of the pieces. This can come up if the asset is a movie that has been edited together from several sources in an NLE.

Import assets in Panasonic P2 format

A P2 card is a solid-state memory device that plugs into the PCMCIA slot of a Panasonic P2 video camera. The digital video and audio data from the video camera is recorded onto the card in a structured, codec-independent format known as MXF (Media eXchange Format). Specifically, Adobe Premiere Pro and After Effects support the Panasonic Op-Atom variant of MXF, with video in AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50, and DVCPRO HD formats. A clip is said to be in the P2 format if its audio and video are contained in Panasonic Op-Atom MXF files, and these files are located in a specific folder structure.

The root of the P2 folder structure is a CONTENTS folder. Each essence item (an item of video or audio) is contained in a separate MXF wrapper file; the video MXF files are in the VIDEO subfolder, and the audio MXF files are in the AUDIO subfolder. The relationships between essence files and the metadata associated with them are tracked by XML files in the CLIP subfolder.

Note:

Adobe Premiere Pro and After Effects do not support proxies recorded by Panasonic P2 camcorders in P2 card PROXY folders.

The video and audio on a P2 card are already in a digital form, as if the P2 card were a hard disk, so no capture step is involved in importing media from a P2 card. The process of reading the data from the card and converting it to a format that can be used in a project is sometimes referred to as ingest.

For your computer to read P2 cards, you must install the appropriate driver, which you can download from the Panasonic website. Panasonic also provides the P2 Viewer application, with which you can browse and play media stored on a P2 card.

Because Panasonic P2 cards use the FAT32 file system, each file is limited to a size of 4 GB. When a shot is recorded that requires more than the 4 GB, a P2 camera creates another file and continues recording the shot to the new file without interruption. This is referred to as clip spanning, because the shot spans more than one file or clip. Similarly, a camera may span a shot across files on different P2 cards: if the camera has more than one P2 card loaded, it will record the shot until it runs out of room on the first P2 card, create a new file on the next P2 card with available space, and continue recording the shot to it. Although a single shot can be recorded to a group of multiple spanned clips, the multiple-file shot is designed to be treated as a single clip or footage item in a video editing application. For After Effects to automatically import a group of spanned clips simultaneously and assemble them into a single footage item, they must all have been recorded to the same P2 card and none of the files can be missing, including the associated XML metadata file.

  1. (Optional) Copy the entire contents of the P2 card to a hard disk.

    Though it is possible to import assets into Adobe Premiere Pro or After Effects directly from a P2 card, it is usually more efficient to copy the contents of the P2 card to a hard disk before importing.

  2. Choose File > Import.
  3. Navigate to the CONTENTS folder.
  4. Select one or more MXF files:
    • To import a video essence item and its associated audio essence items, select the MXF files from the VIDEO folder.

    • To import only the audio essence items, select the MXF files from the AUDIO folder.

    • To import a group of spanned clips for a shot that were recorded onto the same P2 card, select only one of the MXF files in the group from the VIDEO folder. The group is imported as a single footage item with a duration equal to the total duration of all the spanned clips it includes. If you select more than one of these spanned clips, you import duplicates of the whole group of spanned clips, as duplicate footage items in the Project panel.

    You cannot import spanned clips from a shot that spans two different cards as a single footage item. Rather, you must select a single MXF file belonging to the shot from each card to create a separate footage item for the part of the shot recorded on each card. For example, if a group of spanned clips for a single shot itself spans two cards, you must select a spanned clip from the group on card 1 and another from the group on card 2. This imports the contents of the shot into two footage items in the Project panel.

The Date column in the Project panel shows when each source clip was acquired. After you import spanned clips, you can use the Date value to determine their correct chronological order within the shot.

Note:

After Effects can’t directly export to the P2 format. To render and export to the P2 format, use Adobe Media Encoder or Premiere Pro.

For additional information on the Panasonic P2 format and workflows with Adobe digital video software, see the Adobe website:

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy