Import an After Effects project

You can import one After Effects project into another. Everything from the imported project—including footage items, compositions, and folders—appears inside a new folder in the current Project panel.  

You can import an After Effects project from a different operating system, as long as you maintain the filenames, folder names, and either full or relative paths (folder locations) for all files in the project. To maintain relative paths, the source footage files must reside on the same volume as the project file. Use the File > Collect Files command to gather copies of all files in a project or composition into a single location. (See Cross-platform project considerations.)

  1. Choose File > Import > File.
  2. Select the After Effects project to import, and click Open.

If the operating system that you are using does not support a file format, if the file is missing, or if the reference link is broken, After Effects substitutes a placeholder item containing color bars. You can reconnect the placeholder to the appropriate file by double-clicking the entry in the Project panel and navigating to the source file. In most cases, you need to relink only one footage file. After Effects locates other missing items if they’re in the same location.

Note:

When you render a movie and export it to the QuickTime (MOV), Video for Windows (AVI) format, you can embed a link to the project in the container file. To import the project, import the MOV or AVI file, and choose Project from the Import As menu in the Import File dialog box. If the file contains a link to a project that has been moved, you can browse to locate the project..

Import an Adobe Premiere Pro project

Note:

Importing an Adobe Premiere Pro project into After Effects does not use Dynamic Link. After Effects can’t import a Premiere Pro project if one or more sequences in it are already dynamically linked to After Effects. (See Working with Adobe Premiere Pro and After Effects.)

When you import an Adobe Premiere Pro project, After Effects imports it into the Project panel as both a new composition containing each Adobe Premiere Pro clip as a layer, and as a folder containing each clip as an individual footage item. If your Adobe Premiere Pro project contains bins, After Effects converts them to folders within the Adobe Premiere Pro project folder. After Effects converts nested sequences to nested compositions.

Not all features of an Adobe Premiere Pro project are preserved when the project is imported into After Effects. The same features are preserved when you import a Premiere Pro project into After Effects as when you copy and paste between Premiere Pro and After Effects. (See Importing from After Effects and Adobe Premiere Pro.)

After Effects preserves the order of clips in the timeline, the footage duration (including all trimmed In and Out points), and marker and transition locations. After Effects bases the arrangement of layers in the Timeline panel on the arrangement of clips in the Adobe Premiere Pro Timeline panel. After Effects adds Adobe Premiere Pro clips to the Timeline panel as layers in the order in which they appeared—from the bottom up and from left to right—in the Adobe Premiere Pro Timeline panel. After Effects preserves changes made to the speed of a clip, for example, with the Clip > Speed command, and these changes appear as a value in the Stretch column in the After Effects Timeline panel.

After Effects imports effects common to Adobe Premiere Pro and After Effects, and preserves keyframes for these effects.

Transitions and titles (except for dissolves) included in your Adobe Premiere Pro project appear in the After Effects composition as solid layers with their original location and duration.

Audio Level keyframes are preserved.

  1. Choose File > Import > File or File > Import > Adobe Premiere Pro Project.

    If you choose Import > Adobe Premiere Pro Project, then only Adobe Premiere Pro projects are shown.

  2. Select a project, and click OK.
  3. Do any of the following:
    • To import only one sequence, choose a sequence from the menu.

    • To import audio, select Import Audio.

    Note:

    To add a single item from a track in an Adobe Premiere Pro project, copy the item in Adobe Premiere Pro, and choose Edit> Paste in After Effects.

Copy between After Effects and Adobe Premiere Pro

  • From the After Effects Timeline panel, you can copy layers based on audio or video footage items (including solids) and paste them into the Adobe Premiere Pro Timeline panel.

  • From the Adobe Premiere Pro Timeline panel, you can copy assets (any items in a track) and paste them into the After Effects Timeline panel.

  • From either After Effects or Adobe Premiere Pro, you can copy and paste footage items to the other’s Project panel.

Note:

You can’t, however, paste footage items from the After Effects Project panel into the Adobe Premiere Pro Timeline panel.

If you want to work with all clips or a single sequence from an Adobe Premiere Pro project, use the Import command instead to import the project into After Effects.

Note:

Use Adobe Dynamic Link to create dynamic links, without rendering, between new or existing compositions in After Effects and Adobe Premiere Pro. (See About Dynamic Link.)

Copy from After Effects to Adobe Premiere Pro

You can copy a layer based on a footage item from an After Effects composition and paste it into an Adobe Premiere Pro sequence. Adobe Premiere Pro converts these layers to clips in the sequence and copies the source footage item to its Project panel. If the layer contains an effect that is also used by Adobe Premiere Pro, Adobe Premiere Pro converts the effect and all of its settings and keyframes.

You can also copy nested compositions, Photoshop layers, solid-color layers, and audio layers. Adobe Premiere Pro converts nested compositions to nested sequences, and solid-color layers to color mattes. You cannot copy shape, text, camera, light, or adjustment layers to Adobe Premiere Pro.

  1. Start Adobe Premiere Pro (you must start Adobe Premiere Pro before you copy the layer in After Effects).
  2. Select a layer (or layers) from the After Effects Timeline panel.

    Note:

    If you select multiple layers and the layers don’t overlap in After Effects, they’re placed on the same track in Adobe Premiere Pro. On the other hand, if the layers overlap in After Effects, the order in which you select them determines the order of their track placement in Adobe Premiere Pro. Each layer is placed on a separate track, and the last selected layer appears on Track 1. For example, if you select layers from top to bottom, the layers appear in the reverse order in Adobe Premiere Pro, with the bottom-most layer on Track 1.

  3. Choose Edit > Copy.
  4. In Adobe Premiere Pro, open a sequence in the Timeline panel.
  5. Move the current-time indicator to the desired location, and choose either Edit > Paste or Edit > Paste Insert.

Results of pasting into Adobe Premiere Pro

When you paste a layer into an Adobe Premiere Pro sequence, keyframes, effects, and other properties in the copied layer are converted as follows:

After Effects item

Converted to in Adobe Premiere Pro

Notes

Audio volume property

Channel Volume filter

Blending modes

Blending modes supported by Adobe Premiere Pro are converted

Effect properties and keyframes

Effect properties and keyframes, if the effect also exists in Adobe Premiere Pro

Adobe Premiere Pro lists unsupported effects as offline in the Effect Controls panel. Some After Effects effects have the same names as those in Adobe Premiere Pro, but since they’re actually different effects, they aren’t converted.

Expressions

Not converted

Layer markers

Clip markers

Masks and mattes

Not converted

Stereo Mixer effect

Channel Volume filter

Time Remap property

Time Remapping effect

Time Stretch property

Speed property

Speed and time stretch have an inverse relationship. For example, 200% stretch in After Effects converts to 50% speed in Adobe Premiere Pro.

Transform property values and keyframes

Motion or Opacity values and keyframes

The keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Source settings for R3D source files

Source settings for R3D source files

Copy from Adobe Premiere Pro to After Effects

You can copy a video or audio asset from an Adobe Premiere Pro sequence and paste it into an After Effects composition. After Effects converts assets to layers and copies the source footage items into its Project panel. If the asset contains an effect that is also used by After Effects, After Effects converts the effect and all of its settings and keyframes.

You can copy color mattes, stills, nested sequences, and offline files, too. After Effects converts color mattes into solid-color layers and converts nested sequences into nested compositions. When you copy a Photoshop still image into After Effects, After Effects retains the Photoshop layer information. You cannot paste Adobe Premiere Pro titles into After Effects, but you can paste text with attributes from the Adobe Premiere Titler into After Effects.

  1. Select an asset from the Adobe Premiere Pro Timeline panel.
  2. Choose Edit > Copy.
  3. In After Effects, open a composition in the Timeline panel.
  4. With the Timeline panel active, choose Edit > Paste. The asset appears as the topmost layer in the Timeline panel.

    Note:

    To paste the asset at the current-time indicator, place the current-time indicator and press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS).

Results of pasting into After Effects

When you paste an asset into an After Effects composition, keyframes, effects, and other properties in a copied asset are converted as follows:

Adobe Premiere Pro asset

Converted to in After Effects

Notes

Audio track

Audio layers

Audio tracks that are either 5.1 surround or greater than 16‑bit aren’t supported. Mono and stereo audio tracks are imported as one or two layers.

Bars and tone

Not converted

 

Blending modes

Converted

 

Clip marker

Layer marker

 

Color mattes

Solid-color layers

 

Crop filter

Mask layer

 

Frame Hold

Time Remap property

 

Mask Converted All mask properties in Premiere Pro, for example, feather, opacity, expansion, and so on, get copied in After Effects when you copy the mask into an After Effects composition.

Motion or Opacity values and keyframes

Transform property values and keyframes

Keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Sequence marker

Markers on a new solid-color layer

To copy sequence markers, you must either copy the sequence itself or import the entire Adobe Premiere Pro project as a composition.

Speed property

Time Stretch property

Speed and time stretch have an inverse relationship. For example, 50% speed in Adobe Premiere Pro is converted to 200% stretch in After Effects.

Time Remapping effect

Time Remap property

 

Titles

Not converted

 

Universal counting leaders

Not converted

 

Video and audio transitions

Opacity keyframes (Cross dissolve only) or solid-color layers

 

Video effect properties and keyframes

Effect properties and keyframes, if the effect also exists in After Effects

After Effects doesn’t display unsupported effects in the Effect Controls panel.

Volume and Channel Volume audio filters

Stereo mixer effect

Other audio filters are not converted.

Source settings for R3D source files

Source settings for R3D source files

 

Note:

When you import a Premiere Pro project into After Effects, features are converted in the same manner as they are converted when copying from Premiere Pro to After Effects.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy