Layer properties in the Timeline panel

Each layer has properties, many of which you can modify and animate. The basic group of properties that every layer has is the Transform group, which includes Position and Opacity properties. When you add certain features to a layer—for example, by adding masks or effects, or by converting the layer to a 3D layer—the layer gains additional properties, collected in property groups.

All layer properties are temporal—they can change the layer over time. Some layer properties, such as Opacity, have only a temporal component. Some layer properties, such as Position, are also spatial—they can move the layer or its pixels across composition space.

You can expand the layer outline to display layer properties and change property values.

Most properties have a stopwatch . Any property with a stopwatch can be animated—that is, changed over time. (See About animation, keyframes, and expressions.)

Collapsed Layer properties in the Timeline panel
Collapsed property group in layer outline

Expanded Layer properties in the Timeline panel
Expanded property group in layer outline


Properties in the Effects property group (effect properties) are also layer properties. Many effect properties can also be modified in the Effect Controls panel.

Show or hide properties in the Timeline panel

  • To expand or collapse a property group, click the triangle to the left of the layer name or property group name.
  • To expand or collapse a property group and all of its children, Ctrl-click (Windows) or Command-click (Mac OS) the triangle.
  • To expand or collapse all groups for selected layers, press Ctrl+` (accent grave) (Windows) or Command+` (accent grave) (Mac OS).
  • To reveal an effect property in the Timeline panel, double-click the property name in the Effect Controls panel.
  • To hide a property or property group, Alt+Shift-click (Windows) or Option+Shift-click (Mac OS) the name in the Timeline panel.
  • To show only the selected properties or property groups in the Timeline panel, press SS.

Note:

The SS shortcut is especially useful for working with paint strokes. Select the paint stroke in the Layer panel, and press SS to open the property group for that stroke in the Timeline panel.

  • To show only a specific property or property group, press its shortcut key or keys. (See Showing properties and groups in the Timeline panel (keyboard shortcuts).)
  • To add a property or property group to the properties shown in the Timeline panel, hold Shift while pressing the shortcut key for the property or property group.
  • To show only properties that have been modified from their default values, press UU, or choose Animation > Reveal Modified Properties.
  • To show only properties that have keyframes or expressions, press U, or choose Animation > Reveal Animating Properties.

Note:

The U and UU commands are especially useful for learning how animation presets, template projects, or other animated items work, because they isolate the properties that were modified by the designer of those items.

You can also filter layers in the Timeline panel to show only layers with properties that match a search string. See Search and filter in the Timeline, Project, and Effects & Presets panels.

Select a property or property group in the Timeline panel

Anchor point selected
  • To select a property or property group—including all values, keyframes, and expressions—click the name in the layer outline in the Timeline panel.

Copy or duplicate a property or property group in the Timeline panel

  • To copy properties from one layer or property group to another, select the layer, property, or property group, press Ctrl+C (Windows) or Command+C (Mac OS), select the target layer, property, or property group, and press Ctrl+V (Windows) or Command+V (Mac OS).
  • To duplicate a property group, select the property group and press Ctrl+D (Windows) or Command+D (Mac OS).

    You can only duplicate some property groups, including shapes, masks, and effects. However, you can’t duplicate top-level property groups such as Contents, Masks, Effects, and Transforms. If you attempt to duplicate a top-level property group, the entire layer is duplicated, instead.

Copy a value from a layer property that contains no keyframes

You can copy the current value of a layer property to another layer, even when the original layer contains no keyframes.

  1. In the Timeline panel, show the layer property containing the value you want to copy.
  2. Click the name of the layer property to select it.
  3. Choose Edit > Copy.
  4. Select the layer into which you want to paste the value.
  5. If the target layer contains keyframes, move the current-time indicator to the time where you want to paste the value. If the target layer does not contain keyframes, the new value applies to the entire duration of the layer.
  6. Choose Edit > Paste.

Set a property value

If multiple layers are selected and you change a property for one layer, then the property is changed for all selected layers. Sliders, angle controls, and some other property controls are only available in the Effect Controls panel.

Note:

To change the units for a property, right-click (Windows) or Control-click (Mac OS) the underlined value, choose Edit Value, and choose from the Units menu. The available units are different for different property types. You can’t change the units for some properties.

  • Place the pointer over the underlined value, and drag to the left or right.
  • Click the underlined value, enter a new value, and then press Enter (Windows) or Return (Mac OS).

Note:

You can enter simple arithmetic expressions for property values and other number entries. For example, you can enter 2*3 instead of 6, 4/2 instead of 2, and 2e2 instead of 200. Such entries can be especially useful when incrementing a value by a specific amount from its original value.

  • Right-click (Windows) or Control-click (Mac OS) the underlined value and choose Edit Value.
  • Drag the slider left or right.
  • Click a point inside the angle control or drag the angle control line.

Note:

After you click inside the angle control, you can drag outside it for more precision.

  • To increase or decrease the property value by 1 unit, click the underlined value and press the Up Arrow or Down Arrow key. To increase or decrease by 10 units, hold Shift while pressing the Up Arrow or Down Arrow key. To increase or decrease by 0.1 units, hold Ctrl (Windows) or Command (Mac OS) while pressing the Up Arrow or Down Arrow key.
  • To reset properties in a property group to their default values, click Reset next to the property group name. To reset an individual property, right-click (Windows) or Control-click (Mac OS) the property name (not the value) and choose Reset from the context menu.

    If the property contains keyframes, a keyframe is added at the current time with the default value.

Note:

Alan Shisko provides a video tutorial on his Motion Graphics 'n Such blog shows how to use label colors and multiple selections to rapidly change properties for multiple layers simultaneously.

Charles Bordenave (nab) provides a script on the After Effects Scripts website that sets the properties in the Transform group for selected layers to random values within constraints that you set.

The LockProperties script, available from the After Effects Scripts website, locks only specified properties so that you can prevent accidental changes.

Layer anchor points

Transformations, such as rotation and scale, occur around the anchor point (sometimes called transformation point or transformation center) of the layer. By default, the anchor point for most layer types is at the center of the layer.

Though there are times when you’ll want to animate the anchor point, it’s most common to set the anchor point for a layer before you begin animating. For example, if you’re animating an image of a person made up of one layer for each body part, you’ll probably want to move the anchor point of each hand to the wrist area so that the hand rotates around that point for the whole animation.

Note:

The easiest way to pan and scan over a large image is to animate Anchor Point and Scale properties.

Alan Shisko provides a detailed video tutorial on his website, demonstrating how to create a complex 3D environment from 3D layers, beginning with simple 2D assets. Manipulating layer anchor points is a crucial part of this tutorial.

Layer anchor points
Anchor point in center of text layer (left) compared to anchor point moved to the end of the text layer (right)

Layer anchor points
When you use the Pan Behind (Anchor Point) tool to move the anchor point in the Composition panel (left), After Effects automatically compensates for the move so that the layer maintains its position relative to the composition frame (right).

Note:

If you don’t see the anchor point in the Layer panel, select Anchor Point Path from the View menu at the lower-right area of the Layer panel.

Move a layer anchor point

  • Drag the anchor point using the Selection tool in the Layer panel

Note:

Layers of some types, such as text layers and shape layers, can’t be opened in the Layer panel.

  • To move a layer anchor point 1 pixel, choose Anchor Point Path from the View menu at the lower-right area of the Layer panel, and press an arrow key. To move 10 pixels, hold Shift as you press an arrow key. Pixel measurements are at the current magnification in the Layer panel.
  • To move a layer anchor point in the Composition panel without moving the layer, select the layer and use the Pan Behind (Anchor Point) tool to drag the anchor point.

Note:

Moving an anchor point with the Pan Behind (Anchor Point) tool changes Position and Anchor Point values so that the layer remains where it was in the composition before you moved the anchor point. To change only the Anchor Point value, Alt-drag (Windows) or Option-drag (Mac OS) with the Pan Behind (Anchor Point) tool.

Charles Bordenave (nab) provides a script on the After Effects Scripts website that moves the anchor points of selected layers without moving the layers in the composition frame.

Reset a layer anchor point

  • To reset the anchor point to its default location in the layer, double-click the Pan Behind (Anchor Point) tool button in the Tools panel.
  • To reset the anchor point to its default location in the layer, Alt-double-click (Windows) or Option-double-click (Mac OS) the Pan Behind (Anchor Point) tool button. The layer moves to the center of the composition

Set layer anchor point to center of content

You can set the anchor point to be in the center of the layer content in any of the following ways:

  • Select Layer > Transform > Center Anchor Point In Layer Content
  • Use the keyboard shortcut Ctrl+Alt+Home (Windows) or Command+Option+Home (Mac OS)
  • Ctrl+double-click (Windows) or Command+double-click (Mac OS) the Pan Behind (Anchor Point) tool  

Here are a few uses of this command:

  • setting the anchor point of a shape layer to the center of a single shape or to the centroid of a group of shapes in a shape layer
  • setting the anchor point for a text layer to the center of the text content
  • setting the anchor point of a layer to the center of the visible area within a masked region

Scale or flip a layer

As with other transformations, scaling of a layer occurs around the anchor point of the layer. If you move the anchor point away from the center of the layer, the layer may move when you flip it. Some layers—such as camera, light, and audio-only layers—don’t have a Scale property.

You can scale a layer beyond the composition frame.

For information on scaling exponentially, as with a zoom lens, see Use Exponential Scale to change the speed of scaling.

For information on scaling or resizing entire movies rather than a single layer, see Scaling a movie up and Scaling a movie down.

To flip a layer is to multiply the horizontal or vertical component of its Scale property value by -1. A layer flips around its anchor point.

  • To flip selected layers, choose Layer > Transform > Flip Horizontal or Layer > Transform > Flip Vertical.
  • To scale a layer proportionally in the Composition panel, Shift-drag any layer handle.
  • To scale a layer freely in the Composition panel, drag a corner layer handle.
  • To scale one dimension only in the Composition panel, drag a side layer handle.
  • To increase or decrease Scale for a selected layer by 1%, hold down Alt (Windows) or Option (Mac OS) as you press + or – on the numeric keypad.
  • To increase or decrease Scale for selected layers by 10%, hold down Alt+Shift (Windows) or Option+Shift (Mac OS) as you press + or – on the numeric keypad.
  • To scale an entire composition, choose File > Scripts > Scale Composition.jsx.
  • To scale and center selected layers to fit in the composition frame, choose Layer > Transform > Fit To Comp.
  • To scale and center selected layers to fit the width or height of the composition frame, while preserving the aspect ratio of the layer, choose Layer > Transform > Fit To Comp Width, or Layer > Transform > Fit To Comp Height.
  • To scale a layer proportionally in the Timeline panel, select the layer, press S to display the Scale property, click the Constrain Proportions icon to the left of the Scale values, and enter a new value for the x, y, or z scale.

Note:

To activate the Constrain Proportions icon and match the height to the width, Alt-click (Windows) or Option-click (Mac OS) it.  

  • To scale to a specific set of pixel dimensions, right-click (Windows) or Control-click (Mac OS) the Scale value in the Timeline panel, choose Edit Value, and change the units to pixels in the Scale dialog box. Select Include Pixel Aspect Ratio to see and adjust dimensions in terms of the composition’s pixel aspect ratio.

Scaling down a raster (non-vector) layer sometimes causes a slight softening or blurring of the image. Scaling up a raster layer by a large factor can cause the image to appear blocky or pixelated.

Detail-preserving Upscale effect

The Detail-preserving Upscale effect is capable of scaling up images by large amounts while preserving details in the image.

For more information, see Detail-preserving Upscale effect.

Bilinear and bicubic sampling

You can choose between bicubic and bilinear sampling for selected layers, which determines how pixels are sampled for scaling and for all transformations applied using the Transform effect.

For more information, see Layer image quality and subpixel positioning.

Other tools and resources for scaling

Note:

Adobe Photoshop provides fine control over resampling methods used for scaling of images. For fine control of resampling, you can export frames to Photoshop to change the image size and then import the frames back into After Effects.

Though it's not very well suited for movies, the content-aware scaling feature in Photoshop is very useful for extending and scaling still images. This feature can be useful when repurposing images for wide-screen formats that were created for standard-definition formats.

For a script that scales multiple compositions simultaneously, go to the AE Enhancers forum.

Lloyd Alvarez provides a script on the After Effects Scripts website that scales selected layers to fit the composition frame, and provides options for cropping or letterboxing.

Aharon Rabinowitz provides a video tutorial on the Creative COW website that demonstrates the uses of changing and animating a 3D layer's Scale property, including changing only the z dimension of Scale.

Rotate a 2D layer

As with other transformations, rotation of a layer occurs around the anchor point of the layer.

Note:

To reveal the Rotation property value for selected layers in the Timeline panel, press R.

The first part of the Rotation property value is the number of whole rotations; the second part is the fractional rotation in degrees.

For information on rotating 3D layers, see Rotate or orient a 3D layer.

  • To rotate a layer by dragging in the Composition panel, drag the layer using the Rotation tool . To constrain rotation to 45° increments, hold down Shift as you drag.
  • To rotate selected layers by 1 degree, press plus (+) or minus (-) on the numeric keypad.
  • To rotate selected layers by 10 degrees, press Shift+plus (+) or Shift+minus (-) on the numeric keypad.

Adjust audio volume levels

When you use footage containing audio, the default audio level for playback is 0 dB, meaning that the level is unadjusted in After Effects. Setting a positive decibel level increases volume, and setting a negative decibel level decreases volume.

Note:

Double-clicking an Audio Levels keyframe activates the Audio panel.

The VU meter in the Audio panel displays the volume range for the audio as it plays. The red blocks at the top of the meter represent the volume limit of your system.

Note:

For more precision in setting audio levels by dragging sliders, increase the height of the Audio panel.

  • In the Audio panel, to adjust volume, do one of the following:
    • To set the level of the left and right channels together, drag the center slider up or down.

    • To set the level of the left channel, drag the left slider up or down, or type a new value in the levels box at the bottom of the left slider.

    • To set the level of the right channel, drag the right slider up or down, or type a new value in the levels box at the bottom of the right slider.

Parent and child layers

To synchronize changes to layers by assigning one layer’s transformations to another layer, use parenting. After a layer is made a parent to another layer, the other layer is called the child layer. When you assign a parent, the transform properties of the child layer become relative to the parent layer instead of to the composition. For example, if a parent layer moves 5 pixels to the right of its starting position, then the child layer also moves 5 pixels to the right of its position. Parenting is similar to grouping; transformations made to the group are relative to the anchor point of the parent.

Parenting affects all transform properties except Opacity: Position, Scale, Rotation, and (for 3D layers) Orientation.

Note:

When parenting layers, helpful text describing alternate parenting behaviors is displayed on the layer bar below the mouse position and in the Info panel.

A layer can have only one parent, but a layer can be a parent to any number of layers in the same composition.

You can animate child layers independent of their parent layers. You can also parent using null objects, which are hidden layers.

You cannot animate the act of assigning and removing the parent designation—that is, you cannot designate a layer as a parent at one point in time and designate it as a normal layer at a different point in time.

When you create a parenting relationship, you can choose whether to have the child take on the transform property values of the parent or retain its own. If you choose to have the child take on the transform property values of the parent, the child layer jumps to the parent’s position. If you choose to have the child retain its own transform property values, then the child stays where it is. In both cases, subsequent changes to the transform property values of the parent are applied to the child. Similarly, you can choose whether the child jumps when the parenting relationship is removed.

Note:

When parenting layers, you can use the Shift key to move the child layer to the location of the parent. This can be useful when you want to attach a layer to a null, but have the layer move to the location of the parent null (for example, attaching a 3D text layer to a null layer created from the 3D Camera Tracker).

Dragging the pick whip in the Timeline panel
Dragging the pick whip in the Timeline panel from Shape layer 1 (child layer) to designate Shape Layer 2 as the parent layer

Note:

To show or hide the Parent column in the Timeline panel, choose Columns > Parent from the Timeline panel menu.

  • To parent a layer, in the Parent column, drag the pick whip from the layer that is to be the child layer to the layer that is to be the parent layer.
  • To parent a layer, in the Parent column, click the menu of the layer that you want to be the child, and choose a parent layer name from the menu.
  • To remove a parent from a layer, in the Parent column, click the menu of the layer to remove the parent from, and choose None.
  • To extend the selection to include all child layers of a selected parent layer, right-click (Windows) or Control-click (Mac OS) the layer in the Composition or Timeline panel, and choose Select Children.
  • To make a child layer jump when a parent is assigned or removed, hold down Alt (Windows) or Option (Mac OS) as you assign or remove the parent.
  • To remove a parent from a layer (that is, set Parent to None), Ctrl-click (Windows) or Command-click (Mac OS) the parenting pick whip of the child layer in the Timeline panel. Alt+Ctrl-click (Windows) or Option+Command-click (Mac OS) the parenting pick whip of the child layer to remove the parent and cause the child layer to jump.

Online resources about parent and child layers

Paul Tuersley provides a script on the AE Enhancers forum for duplicating a parent layer and all of its children, preserving the parenting hierarchy.

Carl Larsen provides a video tutorial on the Creative COW website that demonstrates how to use expressions and parenting to relate the rotation of a set of wheels to the horizontal movement of a vehicle.

Robert Powers provides a video tutorial on the Slippery Rock NYC website that demonstrates the use of parenting and the Puppet tools to animate a character.

Null object layers

To assign a parent layer, but keep that layer from being a visible element in your project, use a null object. A null object is an invisible layer that has all the properties of a visible layer so that it can be a parent to any layer in the composition. Adjust and animate a null object as you would any other layer. You use the same commands to modify settings for a null object that you use for a solid-color layer (Layer > Solid Settings).

Note:

You can apply Expression Controls effects to null objects and then use the null object as a control layer for effects and animations in other layers. For example, when working with a camera or light layer, create a null object layer and use an expression to link the Point Of Interest property of the camera or light to the Position property of the null layer. Then, you can animate the Point Of Interest property by moving the null object. It is often easier to select and see a null object than it is to select and see the point of interest.

A composition can contain any number of null objects. A null object is visible only in the Composition and Layer panels and appears in the Composition panel as a rectangular outline with layer handles. Effects are not visible on null objects.

  • To create a null object, select the Timeline or Composition panel and choose Layer > New > Null Object.

Note:

The anchor point of a new null object layer appears in the upper-left corner of the layer, and the layer is anchored in the center of the composition at its anchor point. Change the anchor point as you would for any other layer.

Note:

If a null object is visually distracting in your composition frame, consider dragging it out of the frame, onto the pasteboard.

Andrew Kramer provides a video tutorial on his Video Copilot website that demonstrates the use of a null object to animate a 3D stroke.

Guide layers

You can create guide layers from existing layers to use for reference in the Composition panel, to help you position and edit elements. For example, you can use guide layers for visual reference, for audio timing, for timecode reference, or for storing comments to yourself.

A guide layer icon appears next to the name of a guide layer or its source in the Timeline panel.

By default, guide layers aren’t rendered when you create output but can be rendered when desired by changing the render settings for the composition.

Note:

Guide layers in nested compositions can’t be viewed in the containing composition.

  • To convert selected layers to guide layers, choose Layer > Guide Layer.
  • To render a composition with its visible guide layers, click Render Settings in the Render Queue panel, and choose Current Settings from the Guide Layers menu in the Render Settings dialog box.
  • To render a composition without rendering guide layers, click Render Settings in the Render Queue panel, and choose All Off from the Guide Layers menu in the Render Settings dialog box.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy