Organize, view, manage, and trim footage items

Compositions and footage items are listed in the Project panel. Unlike items in the Timeline panel and Effect Controls panel, the order of items in the Project panel has no influence on the appearance of the movies that you create. You can organize footage items and compositions however you like, including organizing them using folders. Solid-color footage items are automatically placed in the Solids folder.

Folders that you create in the Project panel exist only in the Project panel. You can expand a folder to reveal its contents, and put folders inside other folders. To move a file or folder to the top level of the Project panel, drag it to the gray information area at the top of the panel.

You can use the search field in the Project panel to find footage items that meet various criteria, such as those with missing source files. See Search and filter in the Timeline, Project, and Effects & Presets panels.

For a helpful video tutorial about organizing assets in the Project panel, see this video tutorial by Jeff Sengstack and Infinite Skills.

Scripts for managing footage items

Jeff Almasol provides a script on his redefinery website that automatically writes specified information about footage items or layers to the Comment fields for the respective items in the Project panel or Timeline panel.

Christopher Green provides a script (Project_Items_Renamer.jsx) on his website with which you can rename compositions and footage items selected in the Project panel. You can search and replace text in the names, append characters to the beginning or end of the names, or trim a specified number of characters from the beginning or end of the names.

Lloyd Alvarez provides a script on the After Effects Scripts website with which you can search an After Effects project and replace the file paths for the sources of footage items. This is convenient for swapping out source files, updating a project after moving sources, or updating a project after moving it to a different computer system.

Show information for items

  • To show information about a footage item or composition, select it in the Project panel. Information is displayed at the top of the Project panel next to the thumbnail image.
  • To show the file creator ID for a footage item, Alt-click (Windows) or Option-click (Mac OS) it in the Project panel.

Create a folder

  • Choose File > New > New Folder, or click the Create A New Folder icon  at the bottom of the Project panel.

Rename and sort items

  • To rename a composition, footage item, or folder, do one of the following:
    • Select the item in the Project panel, press Enter (Windows) or Return (Mac OS), and enter the new name.

    • Right-click (Windows) or Control-click (Mac OS) the item, choose Rename, and enter the new name.

  • To rename the Comment column, right-click (Windows) or Control-click (Mac OS) the column heading and choose Rename This.

Note:

You can use the Comment column to create a custom sorting option. Rename the column, enter corresponding information for each item (for example, camera number), and then sort by that column.

  • To sort items by entries in any column, click the column name in the Project panel.

Copy items

  • To duplicate or copy an item in the Project panel, select it and choose Edit > Duplicate or Edit > Copy.
  • To copy a footage item to Windows Explorer (Windows) or the Finder (Mac OS), drag the footage item from the Project panel to the desktop.

Reveal footage items

  • To reveal where a footage item is used in a composition, right-click (Windows) or Control-click (Mac OS) the footage item in the Project panel and choose Reveal In Composition; then select the specific instance you want to reveal (composition name, layer name).
  • To reveal the source footage item for a layer in the Project panel, right-click (Windows) or Control-click (Mac OS) the layer in the Timeline panel, and then choose Reveal Layer Source In Project.
  • To reveal the location of a footage item in Adobe Bridge, Windows Explorer, or the Finder, right-click (Windows) or Control-click (Mac OS) the footage item in the Project panel and choose Reveal In Bridge, Reveal In Windows Explorer, or Reveal In Finder.

Refresh footage items

  • To refresh footage items selected in the Project panel to use the current versions of the source footage files, choose File > Reload Footage.

View footage item in the Footage panel or media player assigned by operating system

When items are previewed in the Footage panel, they show the results of the footage interpretation operations. (See Interpret footage items.)

  • To open a footage item in a Footage panel, double-click the footage item in the Project panel.
  • To open selected footage items in the Footage panel, press Enter on the numeric keypad when the Project panel is active.

Note:

To open the source for a footage item using the player application associated with that file type, Alt-double-click (Windows) or Option-double-click (Mac OS) the footage item in the Project panel. See the documentation for your operating system for instructions for changing the associations between applications and file types.

Trim footage items in the Footage panel

You can use the Set In Point , Set Out Point , Ripple Insert Edit , and Overlay Edit controls in the Footage panel to trim a footage item and insert it into a composition. Trimming in the Footage panel can be more convenient than adding the footage item to a composition and then trimming its layer in the Timeline panel.

Edit footage in its original application

You can open and edit a footage item in the application in which it was created, directly from an After Effects project. The original application must be installed on the computer that you are using, which must have enough available RAM for it to run. When you edit and save changes to the footage in the original application, the changes are applied to all instances of the footage when After Effects becomes the active application.

Note:

If you’re editing footage that has an alpha channel, make sure that you’re viewing and editing all of the channels, including the alpha channel, in the other application. Otherwise, changes you make may not be applied to the alpha channel, and it may become misaligned with the color channels.

When you edit a still-image sequence selected in the Timeline or Composition panel, the individual image that is currently displayed opens. When you edit a still-image sequence selected in the Project panel, the first image in the sequence opens.

  1. In the Project panel, Composition panel, or Timeline panel, select the footage item or a layer that uses the footage item as its source. If you selected a still-image sequence from the Composition or Timeline panel, move the current-time indicator to the frame displaying the still image you want to edit.
  2. Choose Edit > Edit Original.
  3. Edit the footage in its original application, and save the changes.

Remove items from a project

Before reducing your project, removing unused footage, or consolidating footage, consider making a backup by incrementing and saving your project first. (See Save and back up projects in After Effects.)

Carl Larsen demonstrates the use of the Collect Files command and the Consolidate All Footage command in a video tutorial on the Creative COW website that shows how to organize, consolidate, and archive project files and footage.

  • To remove an item from a project, select the item in the Project panel and press Delete.
  • To remove all unused footage items from a project, choose File > Remove Unused Footage.
  • To remove all duplicate footage items from a project, Choose File > Consolidate All Footage. After Effects considers footage items to be duplicates only if they use the same Interpret Footage settings.

    When a duplicate item is removed, layers that refer to the duplicate item are updated to refer to the remaining copy.

  • To remove unselected compositions and unused footage items from selected compositions in the Project panel, choose File > Reduce Project. This command is available only when the Project panel is active.

    This command removes both unused footage items and all other compositions that are not included within a selected composition as nested (subordinate) compositions.

    If the selected composition includes items that are turned off (that is, the Video or Audio switch is deselected in the Timeline panel), the Reduce Project command does not remove those items.

    If an expression in a selected composition refers to an element in a nonsubordinate composition, Reduce Project removes the nonsubordinate composition and the applied expression. A message appears after you choose Reduce Project to remind you of this possibility, so you can undo the command if needed. To avoid removing the expressions from a nonsubordinate composition, drag the nonsubordinate composition into the composition that refers to it. Then deselect the Audio and Video switches for the composition that you added.

The SaveCompAsProject script from Sebastian Perier on the AEScripts website saves selected compositions as individual projects.

Placeholders and proxies

When you want to temporarily use a substitute for a footage item, use either a placeholder or a proxy.

Placeholder

A still image of color bars used to temporarily take the place of a missing footage item. Use a placeholder when you are building a composition and want to try out ideas for a footage item that is not yet available. After Effects generates placeholders automatically, so you do not have to provide a placeholder footage item.

Proxy

Any file used to temporarily replace a footage item, but most often a lower-resolution or still version of an existing footage item used to replace the original. Often, storyboard images are used as proxies. You can use a proxy either before you have the final footage or when you have the actual footage item but you want to speed up previewing or rendering of test movies. You must have a file available to use as a proxy.

Any masks, attributes, expressions, effects, and keyframes that you apply to the layer are retained when you replace its placeholder or proxy with the final footage item.

In the Project panel, After Effects marks the footage name to indicate whether the actual footage item or its proxy is currently in use:

  • A filled box indicates that a proxy item is currently in use throughout the project. The name of the proxy appears in bold type at the top of the Project panel when the footage item is selected.

  • An empty box indicates that the footage item is in use throughout the project, though a proxy has been assigned.

  • No box indicates that no proxy is assigned to the footage item.

Work with placeholders and missing footage items

For best results, set the placeholder to the same size, duration, and frame rate as the actual footage.

If After Effects cannot find source footage when you open a project, the footage item appears in the Project panel labeled Missing, and the name of the missing footage appears in italics. Any composition using that item replaces it with a placeholder. You can still work with the missing item in the project, and any effects you applied to the original footage remain intact. When you replace the placeholder with the source footage, After Effects places the footage in its correct location in all the compositions that use it.

Note:

You can find footage items for which the source items are missing by typing missing in the search field in the Project panel. See Search and filter in the Timeline, Project, and Effects & Presets panels.

  • To use a placeholder, choose File > Import > Placeholder.
  • To replace the selected footage item with a placeholder, choose File > Replace Footage > Placeholder.
  • To replace a placeholder with the actual footage item, select the placeholder you want to replace in the Project panel, choose File > Replace Footage > File, and locate the actual footage.

Work with proxies for footage items

When you use a proxy, After Effects replaces the actual footage with the proxy in all compositions that use the actual footage item. When you finish working, you can switch back to the actual footage item in the project list. After Effects then replaces the proxy with the actual footage item in any composition.

When you render your composition as a movie, you may choose to use either all the actual high-resolution footage items or their proxies. You may want to use the proxies for a rendered movie if, for example, you simply want to test motion using a rough movie that renders quickly.

For best results, set a proxy so that it has the same frame aspect ratio as the actual footage item. For example, if the actual footage item is a 640x480-pixel movie, create and use a 160x120-pixel proxy. When a proxy item is imported, After Effects scales the item to the same size and duration as the actual footage. If you create a proxy with a frame aspect ratio that is different from the frame aspect ratio of the actual footage item, scaling takes longer.

  • In the Project panel, do any of the following:
    • To locate and use a proxy, select a footage item, choose File > Set Proxy > File, locate, and select the file you want to use as a proxy, and click Open.

    • To toggle between using the original footage and its proxy, click the proxy indicator to the left of the footage name.

    • To stop using a proxy, select the original footage item, and choose File > Set Proxy > None.

Create a proxy

Use the Create Proxy command to create a proxy from footage or compositions selected in the Project panel or the Timeline panel. This command adds the selected footage to the Render Queue panel and sets the Post-Render Action option to Set Proxy.

  1. Open a footage item or composition in the Project or Timeline panel.
  2. Move the current-time indicator in the Footage panel to the frame that you want to use as the proxy still item, or for the poster frame for the movie footage item.
  3. Choose one of the following commands:
    • File > Create Proxy > Still to create a still image proxy.

    • File > Create Proxy > Movie to create a moving image proxy.

  4. Specify a name and output destination for the proxy.
  5. In the Render Queue panel, specify render settings, and click Render.

Create placeholders for output

You can create placeholder files that can be used in different compositions. For example, you can create a placeholder for an item in the render queue that will create a 24-fps movie and then drag that placeholder into a 30-fps composition. Then, when you render the 30-fps composition, After Effects first renders the placeholder at 24 fps and uses this rendered version as it renders the 30-fps composition.

  • Drag the Output Module heading for a queued item from the Render Queue panel to the Project panel. After Effects creates a placeholder for output in the Project panel and sets the Post-Render Action option for the item to Import & Replace Usage.

Additional resources for working with placeholders and proxies

Andrew Kramer provides a video tutorial with tips for working with proxies, output modules, and output module templates on the Video Copilot website.

Jeff Almasol provides a script on his redefinery website that creates, sets, and unsets proxies and placeholders.

Charles Bordenave (nab) provides a script on the After Effects Scripts website with which you can create proxies for multiple selected items.

See this video tutorial on the Video2Brain website by Todd Kopriva for information about saving time by pre-rendering and using proxies in After Effects.

Loop a footage item

If you intend to loop a visual footage item continuously in your project, you only need to create one cycle of the footage item in After Effects.

  1. In the Project panel, select the footage item to loop.
  2. Choose File > Interpret Footage > Main.
  3. Type an integer value for Loop and click OK.

Lloyd Alvarez provides a script on the After Effects Scripts website that automatically loops a footage item, composition, or layer.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy