Información general

Adobe Animate ofrece diversas alternativas para utilizar sonidos. Puede crear sonidos que se reproduzcan de manera constante, independientes de la línea de tiempo, o utilizar la línea de tiempo para sincronizar una animación con una pista de sonido. Puede añadir sonidos a botones para hacerlos más interactivos y hacer que aparezcan y desaparezcan de forma paulatina para refinar más la pista de sonido.

Hay dos tipos de sonidos en Animate: sonidos de evento y sonidos de flujo. Un sonido de evento debe descargarse por completo antes de empezar a reproducirse y continúa haciéndolo hasta que se detiene completamente. Los flujos de sonido empiezan a reproducirse en cuanto se ha descargado información suficiente para los primeros fotogramas y se sincronizan con la línea de tiempo para reproducirse en sitios web.

Si crea contenido de Animate para dispositivos móviles, Animate permite incluir también sonidos del dispositivo en el archivo SWF publicado. Estos sonidos están codificados en el formato de audio nativo de cada dispositivo, como MIDI, MFi o SMAF.

Puede utilizar bibliotecas compartidas para vincular un sonido a varios documentos. También puede utilizar el evento onSoundComplete de ActionScript® 2.0 o el evento soundComplete de ActionScript® 3.0 para activar un evento al concluir un sonido.

Puede cargar sonidos y controlar la reproducción mediante comportamientos predefinidos o con componentes de medios; estos últimos también proporcionan controles para detener la reproducción, ponerla en pausa, rebobinarla, etc. También puede utilizar ActionScript 2.0 o 3.0 para cargar sonidos dinámicamente.

Para obtener más información, consulte attachSound (método Sound.attachSound) y loadSound (método Sound.loadSound) en Referencia del lenguaje ActionScript 2.0 o la clase Sound en Referencia del lenguaje de componentes ActionScript 3.0.

Nota:

ActionScript 2.0 y ActionScript 1.0 no se admiten en Animate CC.

Importación de sonidos

Para colocar archivos de sonido en Animate, impórtelos a la biblioteca o directamente al escenario.

La opción del menú Archivo > Importar > Importar a biblioteca coloca el audio solo en la biblioteca, no en la línea de tiempo.

Al importar un archivo de audio mediante Archivo > Importar > Importar a escenario, o al arrastrar el archivo de audio y colocarlo directamente en la línea de tiempo, el audio se colocará en el fotograma activo de la capa activa. Si arrastra y coloca varios archivos de audio, solo se importará un archivo de audio porque un fotograma solo puede contener un audio. 

Para importar audio, utilice uno de los métodos siguientes:

  • Para importar un archivo de audio a la biblioteca, seleccione Archivo > Importar > Importar a biblioteca y seleccione el archivo de audio que desee importar.
  • Para importar un archivo de audio al escenario, seleccione Archivo > Importar > Importar a escenario y seleccione el archivo de audio que desee importar. 
  • Arrastre el archivo de audio y colóquelo directamente en el escenario.
import-sounds

Nota:

también puede arrastrar un sonido desde una biblioteca común a la biblioteca del documento actual.

Animate almacena los sonidos en la biblioteca junto con los mapas de bits y los símbolos. Sólo es necesaria una copia del archivo de sonido para utilizar ese sonido de varias formas en el documento.

Si desea compartir sonidos entre los documentos de Animate, puede incluir los sonidos en las bibliotecas compartidas.

Animate incluye una biblioteca de sonidos que contiene una gran variedad de útiles sonidos que se pueden emplear para aplicar efectos. Para abrir la biblioteca de sonidos, elija Ventana > Bibliotecas comunes > Sonidos. Para importar un sonido de la biblioteca de sonidos al archivo de Animate, arrastre el sonido desde la biblioteca de sonidos al panel Biblioteca del archivo de Animate. También puede arrastrar los sonidos de la biblioteca de sonidos a otras bibliotecas compartidas.

Los sonidos pueden necesitar una cantidad considerable de espacio en disco y de memoria RAM. No obstante, los datos de sonido mp3 están comprimidos y ocupan menos espacio que los datos de sonido WAV o AIFF. En general, cuando se usan archivos WAV o AIFF, es preferible utilizar sonidos mono de 16-22 kHz (los estéreo utilizan el doble de información), pero Animate puede importar sonidos de 8 o de 16 bits a velocidades de 11, 22 o 44 kHz. Los sonidos grabados en formatos con velocidades que no sean múltiplos de 11 kHz (como 8, 32 o 96 kHz) se vuelven a muestrear cuando se importan a Animate. Animate permite convertir los sonidos a velocidades más bajas al exportarlos.

Si desea añadir efectos a los sonidos de Animate, es preferible importar sonidos de 16 bits. Si la memoria RAM del sistema es limitada, trabaje con clips de sonido cortos o con sonidos de 8 bits en lugar de 16 bits.

Nota:

Para importar o reproducir sonidos en Animate, no es necesario preinstalar QuickTime ni iTunes.

Formatos de archivo de sonido admitidos

Puede importar a Animate los siguientes formatos de archivo de sonido:

  • Adobe Sound (.asnd). Se trata del formato de sonido nativo de Adobe® Soundbooth™.

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    Puede importar los siguientes formatos de archivo de sonido adicionales:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

Nota:

  • ASND es un formato de archivo de audio que no se puede destruir nativo a Adobe Soundbooth. Los archivos ASND pueden contener datos de audio con efectos que se pueden modificar más adelante, sesiones de varias pistas Soundbooth y capturas de pantalla que permiten volver a un estado anterior del archivo ASND.
  • Los tipos de documento WebGL y HTML5 Canvas solo admiten formatos MP3 y WAV.

Adición de sonidos en Animate

Adición de un sonido directamente desde el equipo a la línea de tiempo

Puede importar audio directamente desde el equipo a la línea de tiempo con cualquiera de los siguientes métodos:

  • Seleccione Archivo > Importar > Importar a escenario y seleccione el archivo de audio que desee importar.
  • Arrastre el archivo de audio y colóquelo en el escenario o la línea de tiempo. 

Tenga en cuenta que solo puede añadir un archivo de audio a la vez. Aunque se arrastren y coloquen varios archivos de audio a la vez, solo se importará un archivo de audio en la línea de tiempo.

Adición de un sonido de la biblioteca a la línea de tiempo

Puede añadir un sonido a un documento desde la biblioteca o cargar un sonido en un archivo SWF en tiempo de ejecución mediante el método loadSound o el objeto Sound. Para obtener más información, consulte la clase Sound en la Referencia del lenguaje ActionScript 3.0.

  1. Importe el sonido a la biblioteca, si no lo ha hecho ya.
  2. Seleccione Insertar > Línea de tiempo > Capa.

    timeline-layer
  3. Con la nueva capa de sonido seleccionada, arrastre el sonido desde el panel Biblioteca hasta el escenario. El sonido se añade a la capa activa.

    Puede colocar múltiples sonidos en una capa o en capas que contengan otros objetos. No obstante, se recomienda que cada sonido se coloque en una capa separada. Cada capa actúa como un canal de sonido separado. Los sonidos de todas las capas se combinan cuando se reproduce el archivo SWF.

  4. En la línea de tiempo, seleccione el primer fotograma que contiene el archivo de sonido.
  5. Seleccione Ventana > Propiedades y haga clic en la flecha que aparece en la parte superior derecha para ampliar el inspector de propiedades.

  6. En el inspector de propiedades, elija el archivo de sonido en el menú emergente Sonido.
  7. Elija una opción de efecto en el menú emergente Efectos:

    Ninguno

    No aplica ningún efecto al archivo de sonido. Seleccione esta opción para eliminar efectos aplicados con anterioridad.

    Canal izquierdo/Canal derecho

    Sólo reproducen el sonido en el canal izquierdo o derecho.

    Desvanecimiento de izquierda a derecha/Desvanecimiento de derecha a izquierda

    Cambia el sonido de un canal al otro.

    Difuminado

    Incrementa gradualmente el volumen de un sonido.

    Desaparecer

    Reduce gradualmente el volumen de un sonido.

    Personalizada

    Permite crear sus propios puntos de entrada y salida y de sonido mediante Editar envoltura.

    Nota:

    Los efectos no se admiten en documentos de WebGL y HTML5 Canvas.

  8. Seleccione una opción de sincronización en el menú emergente Sinc.:

    Evento

    Sincroniza el sonido con un evento. Se reproduce un sonido de evento cuando aparece el fotograma clave inicial y se reproduce por completo, independientemente de la cabeza lectora en la línea de tiempo, incluso si la reproducción del archivo SWF se detiene. Al reproducir el archivo SWF publicado, los sonidos de evento se mezclan.

    Si se está reproduciendo un sonido de evento y se vuelve a crear una instancia del sonido (por ejemplo, el usuario vuelve a hacer clic en un botón o la cabeza lectora pasa por el fotograma clave inicial del sonido), la primera instancia del sonido continúa reproduciéndose y otra instancia del mismo sonido comienza a reproducirse al mismo tiempo. Recuerde esto cuando utilice sonidos más largos, ya que podrían solaparse al final y provocar efectos de audio no deseados.

    Iniciar

    Es equivalente a Evento, pero si el sonido ya se está reproduciendo, no se reproduce una nueva instancia del mismo.

    Detener

    Detiene el sonido especificado.

    Flujo

    Sincroniza el sonido para reproducirlo en un sitio web. Animate hace que la animación vaya a la misma velocidad que los flujos de sonido. Si Animate no puede dibujar los fotogramas de animación a una velocidad suficiente, se los salta. Al contrario que los sonidos de evento, los flujos de sonido se detienen cuando el archivo SWF se detiene. Nunca pueden sonar durante un periodo más largo que la longitud de los fotogramas que ocupa. Al publicar el archivo SWF, los flujos de sonido se mezclan.

    Un ejemplo de flujo de sonido es la voz de un personaje en una animación que se reproduce en fotogramas múltiples.

    Animate recuerda las opciones de sincronización de audio en el inspector de propiedades. Si selecciona un sonido en la sección “Sonido” del inspector de propiedades, al intentar establecer otro sonido en un nuevo fotograma clave en el inspector de propiedades, Animate recuerda las opciones de sincronización “Flujo” o “Evento” del sonido anterior.

    Nota:

    si utiliza un sonido mp3 como flujo de sonido, deberá volver a comprimir el sonido para exportarlo. Puede exportar el sonido como archivo mp3 con la misma configuración de compresión que tenía cuando se importó.

    El ajuste de transmisión no se admite en documentos de WebGL y HTML5 Canvas.

  9. Introduzca un valor en Repetir para especificar el número de veces que el sonido debe reproducirse o seleccione Reproducir indefinidamente para que se repita continuamente.

    Para una reproducción continua, introduzca un número suficientemente alto para reproducir el sonido con una duración larga. Por ejemplo, para que un sonido de 15 segundos dure 15 minutos, introduzca 60. no se recomienda crear reproducciones indefinidas con flujos de sonido. Si un flujo de sonido se establece para reproducirse indefinidamente, los fotogramas se añadirán al archivo y el tamaño del archivo aumentará tantas veces como se reproduzca el sonido.

  10. Para probar el sonido, arrastre la cabeza lectora sobre los fotogramas que contienen el sonido o utilice los comandos del Controlador o del menú Control.
Vídeo: Audio sync settings in Animate CC (Ajustes de sincronización de audio en Animate CC, en inglés)

De Train Simple (www.trainsimple.com)

Eliminación de un sonido de la línea de tiempo

  1. En la capa de la línea de tiempo que contiene el sonido, seleccione un fotograma que también contenga el sonido.
  2. En el inspector de propiedades, vaya a la sección Sonido y seleccione Ninguno en el menú Nombre.

    Animate elimina el sonido de la capa de la línea de tiempo.

Adición de un sonido a un botón

Puede asociar sonidos con los diferentes estados de un símbolo de botón. Los sonidos se almacenan con el símbolo, por lo que funcionan en todas las instancias del mismo.

  1. Seleccione el botón del panel Biblioteca.
  2. Seleccione Editar en el menú Panel situado en la esquina superior derecha del panel.
  3. En la línea de tiempo del botón, añada una capa de sonido (Insertar > Línea de tiempo > Capa).

  4. En la capa de sonido, cree un fotograma clave normal o vacío para que se corresponda con el estado del botón al que desea añadir un sonido.

    Haga clic en Insertar > Línea de tiempo > Fotograma clave o Insertar > Línea de tiempo > Fotograma clave vacío.

    Por ejemplo, para añadir un sonido cuando el botón está presionado, cree un fotograma clave en el fotograma con la etiqueta Presionado.

    insert-keyframes
  5. Haga clic en el fotograma clave que ha creado.
  6. Seleccione Ventana > Propiedades.

  7. En el inspector de propiedades, elija un archivo de sonido en el menú emergente Sonido.
  8. Seleccione Evento en el menú emergente Sinc.

    Para asociar un sonido diferente a cada fotograma clave del botón, cree un fotograma clave vacío y añada otro archivo de sonido para cada fotograma clave. También puede usar el mismo archivo de sonido y aplicar un efecto de sonido distinto para cada fotograma clave del botón.

Sincronización de un sonido con animación

Para sincronizar un sonido con animación, inicie y detenga en sonido en los fotogramas clave.

  1. Añada un sonido a la línea de tiempo en su propia capa (consulta más arriba para obtener instrucciones).
  2. Para sincronizar este sonido con un evento de la escena, cree un fotograma clave inicial para el sonido que corresponda al fotograma clave del evento en la escena en la que quiere activar el sonido. Puede seleccionar cualquiera de las opciones de sincronización descritas arriba (consulte la sección Cómo añadir un sonido a la línea de tiempo).
  3. Cree un fotograma clave en la línea de tiempo de la capa de sonido, en el fotograma donde desee que termine el sonido. En la línea de tiempo aparece una representación del archivo de sonido.
  4. Seleccione Ventana > Propiedades y haga clic en la flecha que aparece en la parte superior derecha para ampliar el inspector de propiedades.

  5. En el inspector de propiedades, elija el mismo sonido en el menú emergente Sonido.
  6. Sin abandonar el inspector de propiedades, seleccione Detener en el menú emergente Sincronización.

    Cuando se reproduce el archivo SWF, el sonido se detiene al llegar al fotograma clave final.

  7. Para reproducir el sonido, arrastre la cabeza lectora en la línea de tiempo.

Edición de sonidos

Edición de sonidos en Animate

En Animate, se puede definir el punto inicial de un sonido o controlar el volumen del sonido mientras se reproduce. También puede modificar los puntos inicial y final de los sonidos. Esto es útil para reducir el tamaño de los archivos de sonido mediante la eliminación de las secciones no utilizadas.

  1. Añada un sonido a un fotograma o seleccione un fotograma que ya contenga un sonido.
  2. Seleccione Ventana > Propiedades.

    windows-properties
  3. Haga clic en el botón Editar situado en la parte derecha del inspector de propiedades.
  4. Siga uno de estos procedimientos:
    • Para cambiar los puntos inicial o final del sonido, arrastre los controles de comienzo y final de Editar envolvente.

    • Para cambiar la envoltura de sonido, arrastre los selectores de envoltura para modificar los niveles en los distintos puntos del sonido. Las líneas de envoltura muestran el volumen del sonido al reproducirse. Para crear selectores de envoltura adicionales (hasta 8 en total), haga clic en las líneas de envoltura. Para eliminarlos, arrástrelos fuera de la ventana.

    • Para ver una parte mayor o menor del sonido en la ventana, haga clic en los botones Acercar o Alejar.

    • Para cambiar la unidad de tiempo de segundos a fotogramas, haga clic en los botones Segundos y Fotogramas.

  5. Para escuchar sonidos editados, haga clic en el botón Reproducir.

Edición de sonidos en Soundbooth

Si tiene instalado Adobe Soundbooth, puede utilizar Soundbooth para editar sonidos que haya importado al archivo de Animate. Una vez se han introducido los cambios en Soundbooth, cuando se guarda el archivo y se sobrescribe el original, los cambios se reflejan automáticamente en el archivo de Animate.

Si cambia el nombre de archivo o el formato del sonido después de editarlo, tiene que volver a importarlo a Animate.

Nota:

Soundbooth sólo está disponible en equipos de Windows y equipos Macintosh basados en Intel®.®

Para editar un sonido importado en Soundbooth:

  1. Haga clic con el botón derecho (Windows) o con la tecla Ctrl presionada (Macintosh) y el sonido del panel Biblioteca.
  2. Elija Edición en Soundbooth en el menú contextual. Se abre el archivo en Soundbooth.
  3. Edite el archivo en Soundbooth.
  4. Después de completar los cambios, guarde el archivo. Para guardar los cambios en un formato que no se pueda destruir, elija el formato ASND. Si guarda el archivo en un formato distinto al original, tendrá que volver a importar el archivo de sonido en Animate.

  5. Vuelva a Animate para ver la versión editada del archivo de sonido en el panel Biblioteca.

Nota:

no se pueden editar sonidos de la biblioteca de sonidos (Ventana > Bibliotecas comunes > Sonidos) con el comando Edición en Soundbooth. Para editar estos sonidos en Soundbooth, abra la aplicación y seleccione el sonido en el panel Resource Central. Edite el sonido y, a continuación, impórtelo en Animate.

División o bucle de un sonido en la línea de tiempo

División de un sonido en la línea de tiempo

Puede dividir el flujo de audio incrustado en la línea de tiempo con el menú contextual Dividir audio. Dividir audio permite pausar el audio cuando es necesario y reanudar la reproducción de audio desde el punto en el que se ha detenido en un fotograma posterior de la línea de tiempo.

Para dividir un clip de audio en la línea de tiempo:

  1. Seleccione Archivo > Importar > Importar a biblioteca

  2. Seleccione el clip de audio e impórtelo a la biblioteca.

  3. Cree una nueva capa en la línea de tiempo y añada el clip de audio a la capa. 

  4. En Propiedades > Sonido, seleccione el tipo de sincronización como Transmisión.

    sound-properties-stream
  5. Haga clic con el botón derecho en el fotograma en el que desee dividir el audio y haga clic en Dividir audio

    Split-audio

Audio en bucle en la línea de tiempo

La reproducción de audio en bucle significa que una pequeña sección de sonido se repite de manera continua a lo largo de un número determinado de fotogramas en la línea de tiempo. Con la opción “bucle” activada en la línea de tiempo, se pueden reproducir en bucle flujos de audio dentro de un intervalo de fotogramas junto con otras animaciones.

Para crear un bucle, active la opción de bucle en la línea de tiempo de la siguiente forma:

Audio
El botón Bucle de audio de la línea de tiempo

Uso de sonidos en Flash Lite

Adobe® Flash® Lite admite dos tipos de sonido: sonidos Animate estándar, como los utilizados en aplicaciones de Animate de escritorio y sonidos de dispositivo. Flash Lite 1.0 admite únicamente sonidos de dispositivo, mientras que Flash Lite 1.1 y 2.x admiten tanto sonidos estándar como de dispositivo.

Los sonidos de dispositivo se almacenan en los archivos SWF publicados en su formato de audio nativo (como MIDI o MFi); durante la reproducción Flash Lite transmite los datos del sonido al dispositivo, que lo descodifica y reproduce. Como una mayoría de los formatos de audio de dispositivo no pueden importarse en Animate, debe importar un sonido proxy en un formato compatible (como mp3 o AIFF) que se sustituye por el sonido de dispositivo externo que especifique.

Los sonidos de dispositivo sólo pueden utilizarse como sonidos de evento y no pueden sincronizarse con la línea de tiempo, como ocurre con los sonidos estándar.

Flash Lite 1.0 y Flash Lite 1.1 no admiten las siguientes funciones disponibles en la versión de escritorio de Flash® Player:

  • El objeto Sound de ActionScript.

  • Carga de archivos mp3 externos

  • La opción de compresión de voz

Para obtener más información, consulte “Trabajo con sonido, vídeo e imágenes” en Desarrollo de aplicaciones de Flash Lite 2.x o “Trabajo con sonido” en Desarrollo de aplicaciones de Flash Lite 1.x.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea