Descubra cómo solucionar problemas de archivos de InDesign dañados.

Es posible que los documentos de InDesign se dañen si se produce un error o un comportamiento inesperado mientras se trabaja en ellos. InDesign cuenta con una función de recuperación de documentos que puede evitar los daños provocados por bloqueos del sistema o interrupciones de la alimentación eléctrica. Sin embargo, no puede evitar que se produzcan otros daños provocados por problemas relacionados con el sistema, como conflictos de software, espacio en disco insuficiente o virus. Esta guía de resolución de problemas puede ayudarle a identificar y reparar daños en documentos de InDesign. También puede ayudarle a resolver problemas del sistema que parecen daños de documentos pero que están relacionados con otras causas.

Buscar problemas relacionados con el sistema

Los problemas a nivel de sistema pueden provocar errores y otros comportamientos inesperados. Antes de actuar sobre la base de que un documento está dañado, asegúrese de que el sistema está relativamente libre de problemas. Por ejemplo, es recomendable ejecutar una utilidad de reparación de discos y, a continuación, volver a abrir el documento para ver si se ha solucionado el problema, antes de emprender las tareas de solución de daños de documento detalladas más abajo.

Windows: Consulte Comprobar si hay errores en el disco duro.

Mac OS: Consulte Resolver problemas de arranque y realizar el mantenimiento del disco.

Solución de problemas de documentos dañados

Realice estas tareas en el orden indicado: Deténgase cuando haya resuelto el problema. 

Nota:

Después de completar cada una de las tareas de solución, reinicie InDesign y abra el documento para ver si se ha corregido el problema. Abra el documento de esta forma:

Elija Archivo > Abrir, seleccione su documento y elija Copiar. Guarde el documento con otro nombre y compruebe si se ha solucionado el problema.

1. Cree una copia de seguridad del documento.

Antes de empezar con la solución de problemas, cree una copia de seguridad del documento dañado. Algunas de las siguientes tareas requieren la modificación o eliminación de información del documento. Una copia de seguridad del documento le permitirá restaurar la información con facilidad. Si el documento se encuentra en un volumen de red o en un medio extraíble (por ejemplo, una unidad de CD o jump), lleve la copia de seguridad a una unidad local.

2. Instale la actualización de InDesign más reciente.

  • En InDesign, elija Ayuda > Actualizaciones.

-o-

-o-

3. Vuelva a crear los archivos de preferencias.

InDesign almacena información sobre plugins, funciones y la propia aplicación en los archivos de preferencias: los archivos SavedData y Defaults de InDesign. Un archivo de preferencias de InDesign dañado puede provocar un comportamiento inesperado en un documento de InDesign. Puede determinar fácilmente si el problema está relacionado con los archivos de preferencias volviéndolos a crear.

Nota:

Al volver a crear los archivos de preferencias de InDesign, la configuración se restaura a los valores predeterminados, por lo que se pierde la configuración personalizada asociada a los antiguos archivos de preferencias. Para guardar estos ajustes personalizados, puede cambiar el nombre de los archivos de preferencias antiguos.

Para volver a crear los archivos de preferencias de InDesign:

  1. Salga de InDesign.

  2. Vuelva a iniciar InDesign y mantenga pulsadas las teclas requeridas según el sistema operativo:

    • Mac OS X: Control + Opción + Comando + Mayús
    • Windows: Ctrl + Alt + Mayús
  3. Cuando se le pregunte si desea eliminar los archivos de preferencias de InDesign, haga clic en . InDesign se iniciará con los valores predeterminados y con archivos de preferencia recién generados.

    Nota:

    Si no se le pregunta si desea eliminar los archivos de preferencias, puede eliminar sus preferencias de forma manual.

  4. Abra el documento y compruebe si se ha corregido. Si el problema persiste, continúe con la tarea 4 descrita a continuación.

    Elimine manualmente los archivos de preferencias o cámbieles el nombre

    Como alternativa u operación adicional, puede:

    • Eliminar manualmente los archivos de preferencias (por ejemplo, si no se le solicita automáticamente que lo haga al iniciar InDesign, como en el procedimiento anterior)

    -o-

    • Cambiar el nombre de los archivos de preferencias (por ejemplo, si tiene ajustes personalizados que no desea perder asociados a los archivos de preferencias antiguos)

    Localice su sistema operativo en la tabla siguiente para ver dónde se encuentran estos archivos.

    Sistema operativo Ubicaciones de archivos de preferencias
    Mac OS X

    InDesign Defaults

    Usuarios/[usuario]/Librería/Preferencias/Adobe InDesign/Version [versión]/[idioma]/InDesign Defaults

    InDesign SavedData

    Usuarios/[usuario]/Librería/Caches/Adobe InDesign/Version [versión]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[usuario]\Application Data\Adobe\InDesign\Version [versión]\InDesign Defaults

    Oculta de manera predeterminada. Aprenda a mostrar archivos ocultos.

    InDesign SavedData

    C:\Documents and Settings\[usuario]\Configuración local\Application Data\Adobe\InDesign\Version[versión]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Usuarios\[usuario]\AppData\Adobe\InDesign\Version[versión]\[idioma]\InDesign Defaults

    Oculta de manera predeterminada. Aprenda a mostrar archivos ocultos.

    InDesign SavedData

    C:\Usuarios\[usuario]\AppData\Local\Adobe\InDesign\Version[versión]\[idioma]\Caches\InDesign SavedData

    Cuando termine de eliminar archivos o cambiar sus nombres, reinicie InDesign para volver a crear los archivos de preferencias y, a continuación, abra el documento para ver si se ha solucionado el problema.

    Si el problema persiste, restaure las preferencias originales eliminando los archivos nuevos y poniendo de nuevo sus nombres originales a los archivos de preferencias.

4. Guarde el documento con formato IDML (InDesign CS4 y posteriores) o INX (InDesign CS3 y anteriores).

  1. Abra el archivo en InDesign.

  2. Elija Archivo > Exportar.

  3. En el menú Guardar como tipo, elija InDesign Markup (CS4 y posteriores) o InDesign Interchange (CS3 y anteriores).

  4. Asigne un nombre y una ubicación al archivo y haga clic en Guardar.

  5. En InDesign, abra el archivo IDML o INX.

    Si el problema desaparece, siga utilizando el archivo IDML o INX en lugar del documento original. Si el problema persiste, continúe con otro paso de resolución.

5. Solucione problemas de un documento convertido en su aplicación original.

Si el documento se convirtió desde Adobe PageMaker, QuarkXPress o una versión previa de InDesign, intente volver a convertir el documento. Si el problema se repite, repare el documento original dañado en su propia aplicación antes de convertirlo. Lo más probable es que un documento dañado de PageMaker o QuarkXPress siga estando dañado después de convertirlo.

6. Elimine estilos de carácter y de párrafo.

Los estilos que haya creado en InDesign o importado con archivos creados en otras aplicaciones podrían estar dañados. Para averiguar si es así, elimine los estilos y vuelva a guardar el documento.

Para eliminar los estilos de carácter:

  1. Abra el documento en InDesign y elija Texto > Estilos de carácter.

  2. En el panel de estilos de carácter, seleccione todos los estilos excepto [Ningún estilo de carácter]. Para seleccionar varios estilos, pulse la tecla Ctrl (Windows) o Comando (Mac OS) mientras hace clic para seleccionar los estilos.

  3. En el menú de estilos de carácter, seleccione Eliminar estilos.

  4. Guarde el documento y compruebe si se ha resuelto el problema. Si el problema persiste, pruebe a eliminar estilos de párrafo.

Para eliminar estilos de párrafo:

  1. En InDesign, abra el documento y elija Texto > Estilos de párrafo.

  2. En el panel Estilos de párrafo, seleccione todos los estilos excepto [Ningún estilo de párrafo]. Para seleccionar varios estilos, pulse la tecla Ctrl (Windows) o Comando (Mac OS) mientras hace clic para seleccionar los estilos.

  3. En el menú Estilos de párrafo, elija Eliminar estilos.

  4. Guarde el documento y compruebe si se ha resuelto el problema. Si el problema persiste, continúe con la tarea 7, descrita a continuación.

7. Compruebe si hay daños en la fuente.

Para determinar si el problema está relacionado con una fuente de texto dañada, sustituya todas las fuentes utilizadas en el documento por una fuente estándar (por ejemplo, Arial o Times New Roman).

Si el problema se repite después de cambiar las fuentes, es indicio de que el origen del problema es otro. Si el problema desaparece, la fuente o las fuentes originales podrían estar dañadas o desfasadas. Vuelva a instalar las fuentes originales o solicite al fabricante una versión más actualizada de las fuentes.

8. Compruebe si hay daños en objetos o gráficos.

Intente determinar si el problema se debe a un elemento específico en una página maestra o en una página de un documento. Para aislar elementos, en primer lugar elimine las páginas vacías y los elementos innecesarios, como los que se encuentran en un área de trabajo o capa oculta.

Para eliminar páginas:

  1. En InDesign, abra el documento y elija Ventana > Páginas.

  2. En el panel Páginas, seleccione la herramienta Selección para marcar las páginas que desee eliminar. Pulse la tecla Ctrl (Windows) o Comando (Mac OS) para seleccionar varias páginas o presione la tecla Mayús para marcar varias páginas consecutivas.

    Eliminar páginas
    Seleccione las páginas que desee eliminar en el panel Páginas.

  3. En el panel de páginas, haga clic en el icono de eliminación.

  4. Haga clic en Aceptar para confirmar la eliminación.

Si el problema se repite tras eliminar páginas, elimine la mitad de las páginas restantes y guarde el documento con otro nombre. Trate de reproducir el problema.

  • Si el problema se repite, es posible que una de las páginas que quedan contenga un elemento dañado. Siga eliminando páginas hasta que averigüe cuál es la que causa el problema.
  • Si el problema desaparece, es posible que una de las páginas eliminadas contuviera un elemento dañado. Restaure las páginas eliminadas hasta que averigüe cuál es la causante del problema.

Cuando haya detectado cuál es la página que provoca el problema, quite y sustituya sus elementos, incluyendo gráficos importados, objetos dibujados en InDesign y marcos de texto.

9. Copie elementos de la página en un nuevo documento.

Al copiar los elementos de una página en un nuevo documento dejamos atrás los daños estructurales (internos). Si el problema se repite tras copiar elementos de una página en un nuevo documento, elimine elementos de uno en uno para ver si alguno de ellos es el causante.

Para copiar los elementos de una página en un nuevo documento:

  1. En InDesign, abra el documento original.

  2. Elija Archivo > Nuevo y haga clic en Aceptar en el cuadro de diálogo Nuevo documento.

  3. Elija Ventana > Mosaico para mostrar los dos documentos.

  4. Haga clic en el documento original para activarlo.

  5. Elija Ventana > Páginas para activar el panel Páginas.

  6. Arrastre una página o despliéguela en la nueva ventana del documento. InDesign copia la página o la despliega en el nuevo documento, añadiendo tantas páginas como sea necesario.

  7. Guarde el nuevo documento con otro nombre (diferente del nombre del documento original) y trate de reproducir el problema.

    • Si el problema se repite, el daño no es estructural (no se encuentra, por ejemplo, en páginas maestras o páginas de documento). Elimine elementos de uno en uno para ver si alguno de ellos es el causante del problema.
    • Si el problema desaparece, es probable que el daño sea estructural. Repita los pasos 4 a 7 para cada página restante.

10. Obtenga otra copia del documento.

Si recibió el documento por correo electrónico, por FTP o en un medio extraíble (como un CD), consiga una copia por otro medio. O pida que se le reenvíe el documento. Unos medios dañados o una transmisión defectuosa por correo electrónico pueden dañar el documento. Si el documento se envía por correo electrónico, pida al remitente que lo comprima antes (por ejemplo, mediante WinZip o StuffIt de Smith Micro) para proteger los datos.

Otras sugerencias

¿Sigue teniendo problemas? Pruebe estas soluciones.

Quite plugins de terceros.

Puede desinstalar plugins de terceros desde InDesign. En ocasiones, los plugins pueden dañar archivos. Consulte Solución de problemas de plugins de terceros de InDesign.

Utilice un equipo diferente para abrir el documento.

Al cambiar a otro entorno, puede eliminar variables que causan el problema.

Visite los foros de usuarios de Adobe.

Hay mucha gente como usted. Puede que otros usuarios hayan tenido problemas similares y podrían haber publicado la solución encontrada. Consulte los foros de InDesign.

Vuelva a crear el documento.

Si no funciona nada de lo anterior, vuelva a crear el documento. Haga copias de seguridad a menudo y pruebe el documento periódicamente para comprobar que los elementos importados no son la causa del problema.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea