Benutzerhandbuch Abbrechen

Code-Linting

  1. Dreamweaver-Benutzerhandbuch
  2. Einführung
    1. Grundlagen von responsivem Webdesign
    2. Neue Funktionen in Dreamweaver
    3. Web-Entwicklung mit Dreamweaver – Überblick
    4. Dreamweaver/Häufige Fragen
    5. Tastaturbefehle
    6. Dreamweaver – Systemanforderungen
    7. Übersicht über die Funktionen
  3. Dreamweaver und Creative Cloud
    1. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    2. Creative Cloud-Bibliotheken in Dreamweaver
    3. Photoshop-Dateien in Dreamweaver verwenden
    4. Mit Adobe Animate und Dreamweaver arbeiten
    5. Web-optimierte SVG-Dateien aus Bibliotheken extrahieren
  4. Arbeitsbereiche und Ansichten in Dreamweaver
    1. Der Dreamweaver-Arbeitsbereich
    2. Dreamweaver-Arbeitsbereich für die visuelle Entwicklung optimieren
    3. Dateien anhand von Dateinamen oder Inhalten suchen | Mac OS
  5. Sites einrichten
    1. Dreamweaver-Sites
    2. Lokale Version Ihrer Site einrichten
    3. Verbindung mit einem Publishing Server herstellen
    4. Testserver einrichten
    5. Site-Einstellungen importieren und exportieren
    6. Vorhandene Websites von einem Remote-Server in Ihren lokalen Site-Stammordner kopieren
    7. Barrierefreie Funktionen in Dreamweaver
    8. Erweiterte Einstellungen
    9. Site-Voreinstellungen für die Übertragung von Dateien festlegen
    10. Proxyserver-Einstellungen in Dreamweaver festlegen
    11. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    12. Git in Dreamweaver verwenden
  6. Dateien verwalten
    1. Dateien öffnen und erstellen
    2. Dateien und Ordner verwalten
    3. Dateien vom Server abrufen/auf dem Server bereitstellen
    4. Dateien einchecken und auschecken
    5. Dateien synchronisieren
    6. Dateien auf Unterschiede vergleichen
    7. Dateien und Ordner in Ihrer Dreamweaver-Site von Operationen ausschließen (Cloaking)
    8. Design Notes für Dreamweaver-Sites aktivieren
    9. Potenzielle Gatekeeper-Angriffe verhindern
  7. Layout und Entwurf
    1. Visuelle Hilfsmittel für das Layout verwenden
    2. CSS für das Seitenlayout verwenden
    3. Responsive-Websites mit Bootstrap entwerfen
    4. Medienabfragen in Dreamweaver erstellen und verwenden
    5. Inhalte in Tabellen darstellen
    6. Farben
    7. Responsive Design mithilfe von fließenden Rasterlayouts
    8. Extract in Dreamweaver
  8. CSS
    1. Grundlegendes zu Cascading Stylesheets
    2. Gestalten von Seitenlayouts mit CSS Designer
    3. CSS-Präprozessoren in Dreamweaver verwenden
    4. Voreinstellungen für CSS-Stile in Dreamweaver festlegen
    5. CSS-Regeln in Dreamweaver verschieben
    6. Inline-CSS in Dreamweaver in eine CSS-Regel umwandeln
    7. Mit div-Tags arbeiten
    8. Verläufe auf den Hintergrund anwenden
    9. CSS3-Übergangseffekte in Dreamweaver erstellen und bearbeiten
    10. Code formatieren
  9. Seiteninhalt und Elemente
    1. Seiteneigenschaften festlegen
    2. CSS-Eigenschaften von Überschriften und Links festlegen
    3. Mit Text arbeiten
    4. Text, Tags und Attribute suchen und ersetzen
    5. DOM-Bedienfeld
    6. In der Live-Ansicht bearbeiten
    7. In Dreamweaver die Kodierung von Dokumenten festlegen
    8. Elemente im Dokumentfenster auswählen und anzeigen
    9. Texteigenschaften im Eigenschafteninspektor festlegen
    10. Rechtschreibprüfung für Web-Seiten durchführen
    11. Horizontale Linien in Dreamweaver verwenden
    12. Schriftkombinationen in Dreamweaver hinzufügen und ändern
    13. Mit Elementen arbeiten
    14. Datumsangaben in Dreamweaver einfügen und aktualisieren
    15. In Dreamweaver Favoritenelemente erstellen und verwalten
    16. Bilder in Dreamweaver einfügen und bearbeiten
    17. Medienobjekte hinzufügen
    18. Videos in Dreamweaver einfügen
    19. HTML5-Videos einfügen
    20. SWF-Dateien einfügen
    21. Audioeffekte hinzufügen
    22. In Dreamweaver HTML5-Audiodateien einfügen
    23. Mit Bibliothekselementen arbeiten
    24. Arabischen und hebräischen Text in Dreamweaver verwenden
  10. Hyperlinks und Navigation
    1. Allgemeines zu Hyperlinks und Navigation
    2. Hyperlinks erstellen
    3. Imagemaps
    4. Fehler in Hyperlinks beheben
  11. jQuery-Widgets und -Effekte
    1. jQuery UI- und Mobile-Widgets in Dreamweaver verwenden
    2. jQuery-Effekte in Dreamweaver verwenden
  12. Websites programmieren
    1. In Dreamweaver programmieren
    2. Programmierumgebung in Dreamweaver
    3. Voreinstellungen für Code festlegen
    4. Codehervorhebung anpassen
    5. Code schreiben und bearbeiten
    6. Codehinweise und Codevervollständigung
    7. Code aus- und einblenden
    8. Code mit Codefragmenten wiederverwenden
    9. Code-Linting
    10. Code optimieren
    11. Code in der Entwurfsansicht bearbeiten
    12. Mit den Head-Inhalten von Seiten arbeiten
    13. Server-Side Includes in Dreamweaver einfügen
    14. Tag-Bibliotheken in Dreamweaver verwenden
    15. Benutzerdefinierte Tags in Dreamweaver importieren
    16. JavaScript-Verhalten (allgemeine Anweisungen)
    17. Integrierte JavaScript-Verhalten anwenden
    18. XML und XSLT
    19. Server-seitige XSL-Transformationen in Dreamweaver durchführen
    20. Client-seitige XSL-Transformationen in Dreamweaver durchführen
    21. Zeichenentitäten für XSLT in Dreamweaver einfügen
    22. Code formatieren
  13. Produktübergreifende Arbeitsabläufe
    1. Erweiterungen für Dreamweaver installieren und verwenden
    2. In-App-Updates in Dreamweaver
    3. Microsoft Office-Dokumente in Dreamweaver einfügen (nur Windows)
    4. Mit Fireworks und Dreamweaver arbeiten
    5. Mithilfe von Contribute Inhalte in Dreamweaver-Sites bearbeiten
    6. Dreamweaver-Business Catalyst-Integration
    7. Personalisierte E-Mail-Kampagnen erstellen
  14. Vorlagen
    1. Dreamweaver-Vorlagen
    2. Vorlagen und vorlagenbasierte Dokumente erkennen
    3. Dreamweaver-Vorlagen erstellen
    4. Bearbeitbare Bereiche in Vorlagen erstellen
    5. Wiederholende Bereiche und Tabellen in Dreamweaver erstellen
    6. Optionale Bereiche in Vorlagen verwenden
    7. Bearbeitbare Tag-Attribute in Dreamweaver definieren
    8. Verschachtelte Vorlagen in Dreamweaver erstellen
    9. Vorlagen bearbeiten, aktualisieren und löschen
    10. XML-Inhalte in Dreamweaver exportieren und importieren
    11. Vorlage auf ein vorhandenes Dokument anwenden oder aus dem Dokument entfernen
    12. Inhalte in Dreamweaver-Vorlagen bearbeiten
    13. Syntaxregeln für Vorlagen-Tags in Dreamweaver
    14. Markierungseinstellungen für Vorlagenbereiche festlegen
    15. Vorteile von Vorlagen in Dreamweaver
  15. Mobilgeräte und Multiscreen
    1. Medienabfragen erstellen
    2. Seitenausrichtung für Mobilgeräte ändern
    3. Mit Dreamweaver Web-Anwendungen für Mobilgeräte erstellen
  16. Dynamische Websites, Seiten und Web-Formulare
    1. Grundlegendes zu Web-Anwendungen
    2. Computer für die Entwicklung von Anwendungen einrichten
    3. Fehlerbehebung bei Datenbankverbindungen
    4. Verbindungsskripts in Dreamweaver entfernen
    5. Dynamische Seiten entwerfen
    6. Quellen für dynamischen Inhalt – Überblick
    7. Quellen für dynamische Inhalte definieren
    8. Dynamische Inhalte in Seiten einfügen
    9. Dynamischen Inhalt in Dreamweaver ändern
    10. Datenbankdatensätze anzeigen
    11. Live-Daten in Dreamweaver bereitstellen und Fehlerbehebung bei der Anzeige
    12. Benutzerdefinierte Serververhalten in Dreamweaver hinzufügen
    13. Formulare mit Dreamweaver erstellen
    14. Formulare zum Sammeln von Benutzerinformationen verwenden
    15. ColdFusion-Formulare in Dreamweaver erstellen und aktivieren
    16. Web-Formulare erstellen
    17. Verbesserte HTML5-Unterstützung für Formularelemente
    18. Formularentwicklung mit Dreamweaver
  17. Visuelles Entwickeln von Anwendungen
    1. Master- und Detailseiten in Dreamweaver erstellen
    2. Such- und Ergebnisseiten erstellen
    3. Datensatz-Einfügeseiten erstellen
    4. Datensatz-Aktualisierungsseiten in Dreamweaver erstellen
    5. Datensatz-Löschseiten in Dreamweaver erstellen
    6. ASP-Befehle zum Ändern von Datenbanken in Dreamweaver verwenden
    7. Registrierungsseiten erstellen
    8. Anmeldeseiten erstellen
    9. Seiten erstellen, auf die nur autorisierte Benutzer zugreifen können
    10. Ordner in ColdFusion mit Dreamweaver schützen
    11. ColdFusion-Komponenten in Dreamweaver verwenden
  18. Websites testen, in der Vorschau anzeigen und veröffentlichen
    1. Seitenvorschau
    2. Dreamweaver-Web-Seitenvorschau auf mehreren Geräten
    3. Dreamweaver-Site testen
  19. Fehlerbehebung
    1. Behobene Probleme
    2. Bekannte Probleme

 

 

Hier erfahren Sie, wie Sie Linting mit HTML-, CSS-, DW-Vorlagen- und JS-Dateien in Adobe Dreamweaver verwenden. Fehler und Warnungen werden im Bedienfeld „Ausgabe“ angezeigt, Mit einem Mausklick können Sie dann zur Codezeile mit dem Fehler springen.

Sowohl Einsteigern wie auch erfahrenen Programmierern können beim Verfassen von Code immer einmal versehentlich oder aufgrund fehlender Informationen Fehler unterlaufen. Wenn die Darstellung der Webseite oder auch nur eines Teils nicht Ihren Erwartungen entspricht, müssen Sie den Code debuggen, um Syntax- oder Logikfehler zu finden. Das Debuggen kann äußerst mühsam und zeitaufwendig sein, insbesondere bei komplexen Implementierungen.

Dreamweaver vereinfacht und erleichtert durch Linting das Debuggen von Code, um häufige Fehler zu ermitteln. Als Linting wird das Analysieren von Code bezeichnet, um potenzielle Fehler und verdächtige Codeabschnitte zu kennzeichnen. Durch Linting werden in Dreamweaver beispielsweise HTML-Syntaxfehler, Analysefehler in CSS oder Warnungen in JavaScript-Dateien gekennzeichnet.

Die gefundenen Fehler und Warnungen werden in einem eigenen Bedienfeld – dem Ausgabe-Bedienfeld – aufgeführt, das am unteren Rand des Arbeitsbereichs angedockt ist. Sie können von jeder Zeile im Bedienfeld zu dem Codeabschnitt wechseln, in dem der Fehler aufgetreten ist, und so den Code einfach finden und korrigieren. Außerdem werden die Zeilennummern des fehlerhaften Codes markiert: Rot für Fehler und Gelb für Warnungen. Wenn Sie mit der Maus auf die hervorgehobenen Zeilennummern zeigen, wird eine Vorschau des Fehlers oder der Warnung in einem Popup-Fenster angezeigt.

Bei der Funktion „Linting bei Bearbeitung“ werden während der Bearbeitung des Codes gleichzeitig Fehler und Warnungen im Ausgabe-Bedienfeld angezeigt.

In Dreamweaver können Sie Linting bei HTML- (.htm und .html), CSS-, DW-Vorlagen- und JavaScript-Dateien verwenden. 

Führen Sie die folgenden Schritte aus, um Linting des Codes in diesen Dateien auszuführen:

  1. Legen Sie Linting-Regeln fest, indem Sie die HTML-, CSS-, DW-Vorlagen- und JS-Konfigurationsdateien bearbeiten. Weitere Informationen finden Sie unter Linting-Regeln festlegen.

  2. Aktivieren oder deaktivieren Sie Linting. Das Linting der Dateien kann beim Bearbeiten, Laden oder Speichern erfolgen.

In den Dateien gefundene Fehler und Warnungen werden im Ausgabe-Bedienfeld angezeigt. Weitere Informationen finden Sie unter Linting-Ergebnisse und das Ausgabe-Bedienfeld.

Linting und Linting bei Bearbeitung aktivieren und Linting-Regeln angeben

Klicken Sie auf Bearbeiten > Voreinstellungen (Windows) bzw. Dreamweaver > Voreinstellungen (Mac). Klicken Sie in der Liste „Kategorie“ auf Linting, wählen Sie Linting aktivieren und klicken Sie auf Übernehmen.

Linting bei Bearbeitung

In Dreamweaver ist die Funktion „Linting bei Bearbeitung“ standardmäßig aktiviert. Zum Deaktivieren klicken Sie auf Bearbeiten > Voreinstellungen (Windows) bzw. Dreamweaver > Voreinstellungen (Mac). Klicken Sie in der Liste „Kategorie“ auf Linting, wählen Sie Linting bei Bearbeitung und klicken Sie auf Übernehmen.

Linting bei Bearbeitung

Linting-Regeln festlegen

Linting ist für HTML-, CSS- und JS-Dateien möglich, indem Sie die Linting-Regeln in den entsprechenden Konfigurationsdateien bearbeiten:

  • HTML: DW.htmlhintrc
  • CSS: DW.csslintrc
  • JS: .eslintrc

Führen Sie die folgenden Schritte aus, um auf diese Dateien zuzugreifen und sie zu bearbeiten:

  1. Klicken Sie auf „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Dreamweaver“ > „Voreinstellungen“ (Mac). 

  2. Wählen Sie in der Liste „Kategorie“ den Eintrag Linting.

  3. Klicken Sie im Abschnitt „Regelsatz bearbeiten“ auf den gewünschten Dateityp und klicken Sie auf „Bearbeiten und Änderungen anwenden“.

    Die entsprechende Konfigurationsdatei wird in Dreamweaver geöffnet.

  4. Bearbeiten Sie Linting-Regeln oder fügen Sie den Konfigurationsdateien Linting-Regeln hinzu. Weitere Informationen zu Linting-Regeln finden Sie in der folgenden Dokumentation:

    In diesen Konfigurationsdateien können Sie auch die Typen von Fehlern oder Warnungen festlegen, die angezeigt werden sollen. 

Hinweis:

Die Konfigurationsdatei für Linting-Regeln bei früheren Versionen von Dreamweaver 19.0 ist „JS: DW.jshintrc“. Weitere Informationen finden Sie unter http://jshint.com/docs/options/.

ECMAScript 6-Linting

Dreamweaver unterstützt die Syntax von ECMAScript 6. Darüber hinaus unterstützt Dreamweaver Linting von ECMAScript-Code, wobei ESLint standardmäßig als JavaScript-Linter verwendet wird.

  1. Klicken Sie auf Site > Sites verwalten.

    Dialogfeld „Sites verwalten“
    Im Dialogfeld „Sites verwalten“ die entsprechende Site wählen

  2. Wählen Sie im linken Bereich des Dialogfensters „Site-Definition“ Erweiterte Einstellungen

  3. Wählen Sie JS Lint unter Erweiterte Einstellungen im linken Bereich. 

    Sie können neben ECMAScript-Version auf die Dropdown-Liste klicken und „3“, „5“ oder „6“ wählen. In Dreamweaver wird der Standardregelsatz der gewählten Version verwendet. 

    ECMAScript-Version wählen
    ECMAScript-Version wählen

  4. Um den Regelsatz anzupassen, können Sie in der Dropdown-Liste Konfigurationsdatei wählen und auf Konfigurationsdatei bearbeiten klicken. 

    JS Lint-Konfigurationsdatei bearbeiten
    JS Lint-Konfigurationsdatei bearbeiten

    Die unter „Site-Definition“ vorgenommenen Änderungen werden gespeichert und eine neue Datei mit dem Namen .eslintrc.js wird im Stammordner der Site erstellt, sofern sie nicht bereits vorhanden ist.

    Die Datei eslintrc.js im Stammordner der Site wird zum Bearbeiten geöffnet. Weitere Informationen finden Sie unter ESLint Rules (in englischer Sprache). 

    Konfigurationsdatei „.eslintrc.js“
    Konfigurationsdatei „.eslintrc.js“

    Hinweis:
    • Die im Dialogfeld „Site-Definition“ vorgenommene Einstellung der ECMAScript-Version steht in der Rangfolge über derjenigen in der Datei .eslintrc.js (im Stammordner der Site). 
    • Wenn in Ihrer Site keine ESLint-Konfigurationsdateien vorhanden sind, sucht Dreamweaver in allen Verzeichnissen bis zum Stammordner nach den Konfigurationsdateien.

    Weitere Informationen zu Konfigurationsdatei und Hierarchie finden Sie auf der ESLint-Website (in englischer Sprache). 

Linting-Ergebnisse und das Ausgabe-Bedienfeld

Die Linting-Ergebnisse – Fehler und Warnungen – werden im Ausgabe-Bedienfeld aufgeführt. Das Ausgabe-Bedienfeld befindet sich im angedockten Modus am unteren Rand aller Standardarbeitsbereiche. Wenn das Ausgabe-Bedienfeld geschlossen ist, können Sie es mit einer der folgenden Aktionen öffnen:

  • Durch Klicken auf das Linting-Statussymbol auf der Statusleiste des Dokumentfensters
  • Mit dem Tastaturbefehl Umschalt+F6
  • Über „Fenster“ > „Ergebnisse“ > „Ausgabe“
Ausgabe-Bedienfeld und Linting-Symbol

Das Linting-Symbol auf der Statusleiste gibt die Linting-Ergebnisse an:

  • Rot: Das aktuelle Dokument enthält Fehler und Warnungen.
  • Gelb: Das aktuelle Dokument enthält lediglich Warnungen.
  • Grün: Das aktuelle Dokument enthält keine Fehler.
Hinweis:

Über das Linting-Symbol auf der Statusleiste können Sie auch das Ausgabe-Bedienfeld öffnen und schließen, wenn das Symbol rot oder gelb ist (aber nicht grün). 

Die Zeilen, die Fehler oder Warnungen enthalten, sind rot bzw. gelb hervorgehoben. Sie können auf eine Meldung im Ausgabe-Bedienfeld doppelklicken, um zu der Zeile zu springen, in der der Fehler aufgetreten ist. In der Codeansicht können Sie auch mit der Maus auf die Zeilennummern der fehlerhaften Zeilen zeigen, um eine Vorschau des Fehlers oder der Warnung zu öffnen.

Im Ausgabe-Bedienfeld werden jeweils 50 Meldungen angezeigt, wobei Fehler vor Warnungen aufgeführt werden. Wenn Sie die Fehler beheben, wird in der Liste im Bedienfeld ein Bildlauf durchgeführt, um den nächsten Fehler anzuzeigen.

 Adobe

Schneller und einfacher Hilfe erhalten

Neuer Benutzer?