Benutzerhandbuch Abbrechen

Git in Dreamweaver verwenden

  1. Dreamweaver-Benutzerhandbuch
  2. Einführung
    1. Grundlagen von responsivem Webdesign
    2. Neue Funktionen in Dreamweaver
    3. Web-Entwicklung mit Dreamweaver – Überblick
    4. Dreamweaver/Häufige Fragen
    5. Tastaturbefehle
    6. Dreamweaver – Systemanforderungen
    7. Übersicht über die Funktionen
  3. Dreamweaver und Creative Cloud
    1. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    2. Creative Cloud-Bibliotheken in Dreamweaver
    3. Photoshop-Dateien in Dreamweaver verwenden
    4. Mit Adobe Animate und Dreamweaver arbeiten
    5. Web-optimierte SVG-Dateien aus Bibliotheken extrahieren
  4. Arbeitsbereiche und Ansichten in Dreamweaver
    1. Der Dreamweaver-Arbeitsbereich
    2. Dreamweaver-Arbeitsbereich für die visuelle Entwicklung optimieren
    3. Dateien anhand von Dateinamen oder Inhalten suchen | Mac OS
  5. Sites einrichten
    1. Dreamweaver-Sites
    2. Lokale Version Ihrer Site einrichten
    3. Verbindung mit einem Publishing Server herstellen
    4. Testserver einrichten
    5. Site-Einstellungen importieren und exportieren
    6. Vorhandene Websites von einem Remote-Server in Ihren lokalen Site-Stammordner kopieren
    7. Barrierefreie Funktionen in Dreamweaver
    8. Erweiterte Einstellungen
    9. Site-Voreinstellungen für die Übertragung von Dateien festlegen
    10. Proxyserver-Einstellungen in Dreamweaver festlegen
    11. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    12. Git in Dreamweaver verwenden
  6. Dateien verwalten
    1. Dateien öffnen und erstellen
    2. Dateien und Ordner verwalten
    3. Dateien vom Server abrufen/auf dem Server bereitstellen
    4. Dateien einchecken und auschecken
    5. Dateien synchronisieren
    6. Dateien auf Unterschiede vergleichen
    7. Dateien und Ordner in Ihrer Dreamweaver-Site von Operationen ausschließen (Cloaking)
    8. Design Notes für Dreamweaver-Sites aktivieren
    9. Potenzielle Gatekeeper-Angriffe verhindern
  7. Layout und Entwurf
    1. Visuelle Hilfsmittel für das Layout verwenden
    2. CSS für das Seitenlayout verwenden
    3. Responsive-Websites mit Bootstrap entwerfen
    4. Medienabfragen in Dreamweaver erstellen und verwenden
    5. Inhalte in Tabellen darstellen
    6. Farben
    7. Responsive Design mithilfe von fließenden Rasterlayouts
    8. Extract in Dreamweaver
  8. CSS
    1. Grundlegendes zu Cascading Stylesheets
    2. Gestalten von Seitenlayouts mit CSS Designer
    3. CSS-Präprozessoren in Dreamweaver verwenden
    4. Voreinstellungen für CSS-Stile in Dreamweaver festlegen
    5. CSS-Regeln in Dreamweaver verschieben
    6. Inline-CSS in Dreamweaver in eine CSS-Regel umwandeln
    7. Mit div-Tags arbeiten
    8. Verläufe auf den Hintergrund anwenden
    9. CSS3-Übergangseffekte in Dreamweaver erstellen und bearbeiten
    10. Code formatieren
  9. Seiteninhalt und Elemente
    1. Seiteneigenschaften festlegen
    2. CSS-Eigenschaften von Überschriften und Links festlegen
    3. Mit Text arbeiten
    4. Text, Tags und Attribute suchen und ersetzen
    5. DOM-Bedienfeld
    6. In der Live-Ansicht bearbeiten
    7. In Dreamweaver die Kodierung von Dokumenten festlegen
    8. Elemente im Dokumentfenster auswählen und anzeigen
    9. Texteigenschaften im Eigenschafteninspektor festlegen
    10. Rechtschreibprüfung für Web-Seiten durchführen
    11. Horizontale Linien in Dreamweaver verwenden
    12. Schriftkombinationen in Dreamweaver hinzufügen und ändern
    13. Mit Elementen arbeiten
    14. Datumsangaben in Dreamweaver einfügen und aktualisieren
    15. In Dreamweaver Favoritenelemente erstellen und verwalten
    16. Bilder in Dreamweaver einfügen und bearbeiten
    17. Medienobjekte hinzufügen
    18. Videos in Dreamweaver einfügen
    19. HTML5-Videos einfügen
    20. SWF-Dateien einfügen
    21. Audioeffekte hinzufügen
    22. In Dreamweaver HTML5-Audiodateien einfügen
    23. Mit Bibliothekselementen arbeiten
    24. Arabischen und hebräischen Text in Dreamweaver verwenden
  10. Hyperlinks und Navigation
    1. Allgemeines zu Hyperlinks und Navigation
    2. Hyperlinks erstellen
    3. Imagemaps
    4. Fehler in Hyperlinks beheben
  11. jQuery-Widgets und -Effekte
    1. jQuery UI- und Mobile-Widgets in Dreamweaver verwenden
    2. jQuery-Effekte in Dreamweaver verwenden
  12. Websites programmieren
    1. In Dreamweaver programmieren
    2. Programmierumgebung in Dreamweaver
    3. Voreinstellungen für Code festlegen
    4. Codehervorhebung anpassen
    5. Code schreiben und bearbeiten
    6. Codehinweise und Codevervollständigung
    7. Code aus- und einblenden
    8. Code mit Codefragmenten wiederverwenden
    9. Code-Linting
    10. Code optimieren
    11. Code in der Entwurfsansicht bearbeiten
    12. Mit den Head-Inhalten von Seiten arbeiten
    13. Server-Side Includes in Dreamweaver einfügen
    14. Tag-Bibliotheken in Dreamweaver verwenden
    15. Benutzerdefinierte Tags in Dreamweaver importieren
    16. JavaScript-Verhalten (allgemeine Anweisungen)
    17. Integrierte JavaScript-Verhalten anwenden
    18. XML und XSLT
    19. Server-seitige XSL-Transformationen in Dreamweaver durchführen
    20. Client-seitige XSL-Transformationen in Dreamweaver durchführen
    21. Zeichenentitäten für XSLT in Dreamweaver einfügen
    22. Code formatieren
  13. Produktübergreifende Arbeitsabläufe
    1. Erweiterungen für Dreamweaver installieren und verwenden
    2. In-App-Updates in Dreamweaver
    3. Microsoft Office-Dokumente in Dreamweaver einfügen (nur Windows)
    4. Mit Fireworks und Dreamweaver arbeiten
    5. Mithilfe von Contribute Inhalte in Dreamweaver-Sites bearbeiten
    6. Dreamweaver-Business Catalyst-Integration
    7. Personalisierte E-Mail-Kampagnen erstellen
  14. Vorlagen
    1. Dreamweaver-Vorlagen
    2. Vorlagen und vorlagenbasierte Dokumente erkennen
    3. Dreamweaver-Vorlagen erstellen
    4. Bearbeitbare Bereiche in Vorlagen erstellen
    5. Wiederholende Bereiche und Tabellen in Dreamweaver erstellen
    6. Optionale Bereiche in Vorlagen verwenden
    7. Bearbeitbare Tag-Attribute in Dreamweaver definieren
    8. Verschachtelte Vorlagen in Dreamweaver erstellen
    9. Vorlagen bearbeiten, aktualisieren und löschen
    10. XML-Inhalte in Dreamweaver exportieren und importieren
    11. Vorlage auf ein vorhandenes Dokument anwenden oder aus dem Dokument entfernen
    12. Inhalte in Dreamweaver-Vorlagen bearbeiten
    13. Syntaxregeln für Vorlagen-Tags in Dreamweaver
    14. Markierungseinstellungen für Vorlagenbereiche festlegen
    15. Vorteile von Vorlagen in Dreamweaver
  15. Mobilgeräte und Multiscreen
    1. Medienabfragen erstellen
    2. Seitenausrichtung für Mobilgeräte ändern
    3. Mit Dreamweaver Web-Anwendungen für Mobilgeräte erstellen
  16. Dynamische Websites, Seiten und Web-Formulare
    1. Grundlegendes zu Web-Anwendungen
    2. Computer für die Entwicklung von Anwendungen einrichten
    3. Fehlerbehebung bei Datenbankverbindungen
    4. Verbindungsskripts in Dreamweaver entfernen
    5. Dynamische Seiten entwerfen
    6. Quellen für dynamischen Inhalt – Überblick
    7. Quellen für dynamische Inhalte definieren
    8. Dynamische Inhalte in Seiten einfügen
    9. Dynamischen Inhalt in Dreamweaver ändern
    10. Datenbankdatensätze anzeigen
    11. Live-Daten in Dreamweaver bereitstellen und Fehlerbehebung bei der Anzeige
    12. Benutzerdefinierte Serververhalten in Dreamweaver hinzufügen
    13. Formulare mit Dreamweaver erstellen
    14. Formulare zum Sammeln von Benutzerinformationen verwenden
    15. ColdFusion-Formulare in Dreamweaver erstellen und aktivieren
    16. Web-Formulare erstellen
    17. Verbesserte HTML5-Unterstützung für Formularelemente
    18. Formularentwicklung mit Dreamweaver
  17. Visuelles Entwickeln von Anwendungen
    1. Master- und Detailseiten in Dreamweaver erstellen
    2. Such- und Ergebnisseiten erstellen
    3. Datensatz-Einfügeseiten erstellen
    4. Datensatz-Aktualisierungsseiten in Dreamweaver erstellen
    5. Datensatz-Löschseiten in Dreamweaver erstellen
    6. ASP-Befehle zum Ändern von Datenbanken in Dreamweaver verwenden
    7. Registrierungsseiten erstellen
    8. Anmeldeseiten erstellen
    9. Seiten erstellen, auf die nur autorisierte Benutzer zugreifen können
    10. Ordner in ColdFusion mit Dreamweaver schützen
    11. ColdFusion-Komponenten in Dreamweaver verwenden
  18. Websites testen, in der Vorschau anzeigen und veröffentlichen
    1. Seitenvorschau
    2. Dreamweaver-Web-Seitenvorschau auf mehreren Geräten
    3. Dreamweaver-Site testen

 

In diesem Artikel erfahren Sie, wie Sie Ihre Dateien und Ihren Quellcode in Dreamweaver mit Git verwalten.

Dreamweaver unterstützt Git, ein verteiltes Open-Source-Versionskontrollsystem, mit dem Sie Quellcode verwalten können. Dank der Git-Integration mit Dreamweaver können Sie ortsunabhängig an Ihrem Code arbeiten und ihre Änderungen später in einem zentralen Git-Repository zusammenführen. Git hilft bei der Nachverfolgung aller Änderungen an einer Datei und ermöglicht Ihnen das Wiederherstellen vorheriger Versionen.

Git-Repositorys sind zudem hilfreich, wenn Sie im Team arbeiten, denn mit Git können Sie leicht Verzweigungen erstellen und verwalten. Wenn Sie beispielsweise als Designer an einer Änderung am Site-Design arbeiten, während ein anderes Teammitglied Änderungswünsche für dieselbe Seite umsetzt, können Sie mit Git unabhängig voneinander arbeiten. In einem solchen Fall können beide Benutzer unabhängig voneinander Verzweigungen erstellen und Änderungen am jeweiligen lokalen Repository vornehmen. Das lokale Repository enthält den vollständigen Verlauf aller von Ihnen am Quellcode vorgenommenen Änderungen. Sie können die Synchronisation Ihrer Änderungen mit dem zentralen Repository jederzeit unterbrechen und fortsetzen. Durch Zusammenführen wird sichergestellt, dass der Code im zentralen Repository stets bei beiden Änderungen auf dem neuesten Stand ist.

Machen Sie sich im Folgenden mit den ersten Schritten bei der Verwendung von Git in Dreamweaver vertraut.

Erste Schritte mit Git in Dreamweaver

Wenn Sie Git zum ersten Mal verwenden, müssen Sie zunächst einen Git-Client herunterladen und ein Git-Konto erstellen. Ein Git-Client ist zwingend erforderlich, um Git in Dreamweaver verwenden zu können.

Wenn Sie bereits über ein Git-Konto verfügen, melden Sie sich bei Ihrem Konto an. Stellen Sie sicher, dass Sie den Git-Client auf Ihr System heruntergeladen haben. 

Führen Sie die folgenden Schritte aus, um mit Git in Dreamweaver zu starten:

  1. Laden Sie den Git-Client für Ihr Betriebssystem herunter.

  2. Erstellen Sie ein Konto für den Git-Client.

    Wenn Sie bereits über ein Git-Konto verfügen, geben Sie Ihre Anmeldeinformationen an, um sich beim Git-Client anzumelden.

Das Git-Bedienfeld

Es wird empfohlen, den Git-Client mit den Standardkonfigurationseinstellungen zu installieren. Dreamweaver erkennt den Pfad zur ausführbaren Datei dann automatisch.

Sie können Dreamweaver nun starten und Ihre Site mit einem Git-Repository verknüpfen.

Dreamweaver unterstützt Git-Vorgänge über das Git-Bedienfeld („Fenster“ > „Git“). Als Dreamweaver-Benutzer können Sie in diesem Bedienfeld häufige Git-Vorgänge ausführen, z. B. Commit, Übertragung, Abruf und Holen.

Hinweis:

Sie können dieses Bedienfeld in Dreamweaver nur anzeigen, nachdem Sie den Git-Client auf Ihren Computer heruntergeladen haben.

Das Git-Bedienfeld in Dreamweaver CC
Git-Bedienfeld in Dreamweaver

A. Commit B. Alle Remote-Repositorys abrufen und Zähler aktualisieren C. Git-Abruf D. Git-Übertragung E. Repository-Verlauf anzeigen F. Dateiverlauf anzeigen G. Tag erstellen H. Bash-/Terminal-Konsole öffnen I. Weitere Aktionen J. Suchen K. Versionsvergleich L. Datei zurücksetzen 

Verknüpfen Ihrer Site mit Git

Bevor Sie Git in Dreamweaver verwenden können, müssen Sie Ihre Dreamweaver-Site einem Git-Repository zuordnen. Sie können ein Git-Repository mit einem Ordner vergleichen, den Sie erstellen, um Dateiänderungen zu verfolgen. Sie können über eine beliebige Anzahl von Git-Repositorys auf Ihrem Computer verfügen. Jedes Repository in Ihrem System ist unabhängig. Das heißt, dass sich die in einem Git-Repository gespeicherten Änderungen nicht auf den Inhalt eines anderen Repositorys auswirken.

Sie können Ihre Website mit einem Repository verknüpfen, indem Sie entweder ein Repository erstellen oder ein vorhandenes klonen. Beim Initialisieren oder Erstellen eines neuen Repositorys wird im aktuellen Arbeitsverzeichnis ein leeres Git-Repository erstellt. Der Ordner enthält die Datei .gitignore.

Wenn Sie jedoch einen Klon eines bestehenden Git-Repositorys erstellen, werden alle Dateien aus dem übergeordneten Repository im lokalen System geklont.

Im Folgenden erfahren Sie, wie Sie ein Git-Repository initialisieren und ein Repository klonen.

Git-Repository initialisieren

Wenn Sie mit der Arbeit mit Git in Dreamweaver beginnen, erstellen Sie zunächst ein neues Repository. Beim Initialisieren eines Git-Repositorys für die Site erstellen Sie ein Git-Repository, in dem Sie die mit der Dreamweaver-Site verknüpften Dateien hinzufügen können.

  1. Dreamweaver-Benutzer können entweder mit einer neuen Site beginnen oder eine vorhandene Site mit einem Git-Repository verknüpfen. Befolgen Sie in beiden Fällen diese Vorgehensweise zum Initialisieren eines Git-Repositorys.

    • Klicken Sie zum Verknüpfen einer neuen Dreamweaver-Site auf „Site“ > „Neue Site“.
    • Klicken Sie zum Verknüpfen einer vorhandenen Dreamweaver-Site auf „Site“ > „Sites verwalten“. Doppelklicken Sie im Dialogfeld „Sites verwalten“ auf die Site, die Sie mit einem Git-Repository verknüpfen möchten.
  2. Wenn Sie eine neue Site erstellen, geben Sie einen Namen für die Site an.

    Wenn Sie über einen Ordner mit Dateien zu Ihrer Site verfügen, verweisen Sie im Feld „Lokaler Site-Ordner“ auf den betreffenden Ordner.

    Namen und Pfad für die neue Dreamweaver-Site angeben
    Namen und Pfad für die neue Dreamweaver-Site angeben

    Wenn Sie Ihre neue Site mit einem vorhandenen Git-Repository verknüpfen möchten, stellen Sie sicher, dass der lokale Site-Ordner auf das entsprechende Git-Repository verweist.

  3. Aktivieren Sie das Kontrollkästchen „Git-Repository mit dieser Site verknüpfen“. Wählen Sie die Option „Als Git-Repository initialisieren“ aus

    Initialisieren eines Git-Repositorys in Dreamweaver
    Git-Repository für Ihre neue Dreamweaver-Site initialisieren

  4. Klicken Sie auf „Speichern“.

    Die Dateien aus dem lokalen Ordner werden nun im Bedienfeld „Dateien“ (in der Git-Ansicht) angezeigt. Die Dateien befinden sich in einem nicht verfolgten Status. Das heißt, diese Dateien wurden noch nicht in Ihr Git-Repository übernommen.

    Sie können die Dateien entweder weiter bearbeiten und später übernehmen oder Sie können das Git-Bedienfeld öffnen („Fenster“ > „Git“) und die Dateien in das Repository übernehmen. Weitere Informationen zum Übernehmen von Dateien in Git finden Sie unter Bearbeitungen in Git nachverfolgen.

Klonen eines vorhandenen Repositorys

Wenn Sie bereits mit einem bestehenden Git-Repository arbeiten, das von Github, Bitbucket oder einem anderen verbreiteten Hostingdienst gehostet wird, können Sie wie folgt vorgehen, um das Repository aus Dreamweaver heraus zu klonen. Beim Klonen eines bestehenden Repositorys erstellen Sie eine Kopie des Ziel-Repositorys auf dem lokalen System.

  1. Klicken Sie auf „Site“ > „Neue Site“.

  2. Aktivieren Sie im Dialogfeld „Site-Definition“ das Kontrollkästchen „Git-Repository mit dieser Site verknüpfen“. Wählen Sie anschließend die Option „Bestehendes Git-Repository anhand der URL klonen“ aus.

  3. Geben Sie die URL des Repositorys ein, das geklont werden soll.

    Vergewissern Sie sich, dass die von Ihnen eingegebene HTTPS-URL für das Ziel-Repository gültig ist. Um zu überprüfen, ob die URL gültig ist, klicken Sie in diesem Dialogfeld auf die Schaltfläche „Testen“. Eine ungültige URL führt beim Klonen sowie bei Git-Aktionen wie dem Laden oder Abrufen zu Fehlern.

    Klonen eines Git-Repositorys in Dreamweaver
    Klonen eines Git-Repositorys in Dreamweaver

    Hinweis:

    Das Klonen einer URL unter Verwendung eines SSH-Schlüssels mit Passphrase wird derzeit in Dreamweaver nicht unterstützt. Die Felder für Benutzername und Kennwort sind deaktiviert.

  4. Aktivieren Sie zum Speichern der eingegebenen Anmeldeinformationen das Kontrollkästchen „Anmeldeinformationen speichern“. So brauchen Sie Ihre Anmeldeinformationen nicht mehr bei jeder Remote-Aktion wie Git-Übertragung und Git-Abruf erneut einzugeben.

  5. Klicken Sie auf „Speichern“.

    Nachdem Sie ein Repository geklont haben, wird eine lokale Kopie des ursprünglichen Repositorys erstellt. Sie können die lokalen Dateien in Dreamweaver anzeigen und bearbeiten.

    Der Schnappschuss des zu klonenden ursprünglichen Repositorys wird rechts oben im Git-Bedienfeld unter „Ursprung“ angezeigt.

    Verweis auf das ursprüngliche Repository im Git-Bedienfeld
    Verweis auf das ursprüngliche Repository im Git-Bedienfeld

Git zur Versionskontrolle verwenden

Nachdem Sie Ihre Dreamweaver-Site einem Git-Repository zugeordnet haben, werden die Dateien auf Git im Bedienfeld „Dateien“ (Git-Ansicht) angezeigt. Dateien werden von Git im lokalen Repository in folgende Kategorien unterteilt:

  • Nicht nachverfolgte Dateien: Dateien, die noch nie in das Git-Repository übernommen wurden. Nachdem Sie ein Git-Repository initialisiert haben, gelten Dateien so lange als nicht nachverfolgt, bis Sie sie übernehmen.
  • Nicht geänderte Dateien: Dateien, die nicht geändert wurden.
  • Geänderte Dateien: Dateien, die bearbeitet wurden.
  • Bereitgestellte Dateien: Dateien, die geändert wurden und jetzt übernommen werden können.

Mit Git können Sie Änderungen an den Dateien nachverfolgen. Wenn Sie die Dateien auf Ihrem lokalen System ändern, werden die geänderten Dateien im Bedienfeld „Dateien“ in einer anderen Farbe angezeigt. Doppelklicken Sie auf die Datei, um sie in der Codeansicht zu öffnen. Zeilen mit Änderungen werden am Zeilenrand gekennzeichnet. Sie können Ihre geänderten Dateien jetzt in Git übernehmen, um die Änderungen zu synchronisieren.

Beim Übernehmen von Dateien ermöglicht es Ihnen Git, Protokollmeldungen für jede Übernahme einzugeben und die Änderungen mit der Versionsvergleichsfunktion zu überprüfen. Sie können auch den Versionsverlauf für jede Datei und für das gesamte Repository anzeigen.

Im Folgenden wird erläutert, wie Sie Ihre vorgenommenen Änderungen in Dreamweaver verfolgen und in Git übernehmen können.

Bearbeitungen in Git nachverfolgen

Über das Git-Symbol im Bedienfeld „Dateien“ von Dreamweaver können Sie zwischen der FTP-Ansicht und der Git-Ansicht wechseln. Klicken Sie auf das Git-Symbol, um zur Git-Ansicht zu wechseln.

Wenn Sie ein Git-Repository initialisiert und Ihre Dateien nicht übernommen haben, werden die Dateien nicht nachverfolgt. Wenn Sie die Dateien hingegen nach dem Initialisieren des Repositorys übernommen haben, werden die Dateien von Git erkannt.

Nicht nachverfolgte Dateien im Bedienfeld „Dateien“ anzeigen
Nicht nachverfolgte Dateien im Bedienfeld „Dateien“ anzeigen

Dateien nach dem Übernehmen in das Git-Repository
Von Git erkannte übernommene Dateien anzeigen

Wenn Sie alle Ihre Dateien aus einem anderen Repository geklont haben, werden die Dateien wieder von Git erkannt.

Wenn Sie eine Datei ändern und auf „Speichern“ klicken, werden die geänderten Dateien im Bedienfeld „Dateien“ in einer anderen Farbe angezeigt. Doppelklicken Sie auf die geänderte Datei, um die genauen Änderungen in der Codeansicht anzuzeigen.

Kennzeichnungen am Zeilenrand in der Codeansicht
Kennzeichnungen am Zeilenrand in der Codeansicht

Am Zeilenrand sind die Zeilen gekennzeichnet, in denen Änderungen vorgenommen wurden. Grüne Kennzeichnungen am Zeilenrand geben an, dass neuer Code hinzugefügt wurde. Gelbe Kennzeichnungen am Zeilenrand geben geänderten Code an, während eine rote Kennzeichnung am Zeilenrand bedeutet, dass eine Codezeile gelöscht wurde.

Kennzeichnungen am Zeilenrand zeigen Codeänderungen in Dreamweaver an
Kennzeichnungen am Zeilenrand zeigen Codeänderungen an

Wenn Sie auf die gelbe Kennzeichnung am Zeilenrand klicken, wird die Änderung am Code in der Anwendung angezeigt. Die gelöschte Codezeile wird rot angezeigt, neu hinzugefügter Code hingegen grün.

Beachten Sie links neben den gelöschten Codezeilen das R-Symbol. Klicken Sie auf das R-Symbol, um den gelöschten Code wieder zur Datei hinzuzufügen.

Auf R-Symbol klicken, um gelöschten Code in Dreamweaver-Git hinzuzufügen
Auf R-Symbol klicken, um gelöschten Code hinzuzufügen

Am Zeilenrand können Sie die Unterschiede ablesen und Ihre Änderungen prüfen, bevor Sie sie für das Git-Repository übernehmen.

Unterschiede bei geänderten Dateien anzeigen

Wenn Sie das Git-Bedienfeld öffnen, wird eine Liste der geänderten Dateien angezeigt. Sie können auf eine Datei in der Liste klicken und die Änderungen anzeigen, die seit dem letzten Commit an der Datei vorgenommen wurden (Versionsvergleich). Um den Versionsvergleich für eine Datei anzuzeigen, führen Sie einen der folgenden Schritte im Git-Bedienfeld aus:

  • Sie können auf die einzelnen Dateien klicken, um die Änderungen auf Dateiebene anzuzeigen. Die roten Markierungen zeigen die frühere Version an, während die grünen Hervorhebungen die Änderungen angeben, die Sie gerade vorgenommen haben.
  • Wählen Sie die Datei aus, für die der Versionsvergleich angezeigt werden soll. Klicken Sie auf  (Vergleichssymbol). Das Dialogfeld „Git-Versionsvergleich“ wird angezeigt, in dem die Änderungen rot und grün hervorgehoben sind.
Unterschiede bei geänderten Dateien anzeigen
Unterschiede bei geänderten Dateien anzeigen

Änderungen übernehmen

Damit alle Änderungen im lokalen Repository aufgezeichnet werden, müssen Sie die an den Dateien vorgenommenen Änderungen übernehmen. So übernehmen Sie Ihre Änderungen in Git:
  1. Wählen Sie die Datei oder die Dateien, die Sie übernehmen möchten, im Git-Bedienfeld aus.

    Änderungen im lokalen Git-Repository übernehmen
    Änderungen im lokalen Git-Repository übernehmen

  2. Klicken Sie auf  (Commit-Symbol).

    Nachdem Sie auf „Commit“ geklickt haben, wird das Dialogfeld „Git-Commit“ geöffnet. In diesem Dialogfeld werden die Dateien angezeigt, die geändert wurden.

    Vor dem Commit können Sie die Änderungen an den einzelnen Dateien anzeigen.

  3. Geben Sie für den Commit der Dateien im Meldungsfeld eine Commit-Nachricht ein und klicken Sie auf „OK“.

    Nach dem Commit der Dateien werden die Dateien auch aus dem Git-Bedienfeld entfernt.

    Änderungen in Git übernehmen
    Änderungen in Git übernehmen

Änderungen zurücksetzen

Wenn Sie Ihre Änderungen bereits übernommen haben und die vorige Version einer Datei wiederherstellen möchten, gehen Sie wie folgt vor:

  1. Wählen Sie die Datei oder die Dateien, die Sie wiederherstellen möchten, im Git-Bedienfeld aus.

  2. Klicken Sie im Git-Bedienfeld auf das Ordnersymbol und wählen Sie die Option „Alle Änderungen seit letztem Commit zurücksetzen“ aus.

    Im lokalen Repository wird die vorherige Version der Dateien wiederhergestellt. Sie können die wiederhergestellten Dateien auch über das Bedienfeld „Dateien“ anzeigen.

    Änderungen nach dem Commit von Dateien zurücksetzen
    Änderungen nach dem Commit von Dateien zurücksetzen

    Hinweis:

    Wenn Sie eine Datei nach einem Commit wiederherstellen möchten, müssen Sie mindestens zweimal einen Commit der Datei ausgeführt haben.

  3. Wenn Sie die Änderungen vor einem Commit zurücksetzen möchten, führen Sie die folgenden Schritte aus:

    Wenn Sie die zuletzt übernommene Version einer Datei vor dem Commit der Datei beibehalten möchten:

    1. Klicken Sie im Git-Bedienfeld auf die beizubehaltende Datei und dann auf das Symbol „Aktualisieren“.
    2. Klicken Sie im Bestätigungsdialogfeld auf „OK“.

    Die ausgewählte Datei wird aus der Liste der geänderten Dateien entfernt und die vorherige Version der Datei wird wiederhergestellt.

    Datei vor einem Commit der Änderungen in Git zurücksetzen
    Datei vor einem Commit der Änderungen zurücksetzen

Erstellen von Tags

Bei jedem Commit von Änderungen in Git können Sie Tags erstellen. Mithilfe von Tags können Sie wichtige Commits kennzeichnen, zum Beispiel, wenn Sie auf Wunsch des Kunden eine umfangreiche Änderung einchecken. Die Tags fungieren als Zeiger auf einen bestimmten Commit.

  1. Klicken Sie zum Erstellen eines Tags im Git-Bedienfeld auf  (Symbol „Tag erstellen“).

  2. Geben Sie im Dialogfeld „Tag erstellen“ einen Namen für das Tag an. Klicken Sie auf „OK“.

    Tag für einen Commit erstellen
    Tag für einen Commit erstellen

    Das erstellte Tag wird dem Commit zugeordnet.

    Wenn Sie nach dem Durchführen eines Commits ein Tag erstellen, wird dieses automatisch dem letzten Commit zugeordnet.

Anzeigen des Dateiverlaufs

Bei jedem Commit einer Datei in Git können Sie zusätzlich zu den Einzelheiten zum Commit den Verlauf der Datei anzeigen lassen. Diese Funktion erleichtert Ihnen das Ermitteln wichtiger Commits sowie der den Commits zugeordneten Tags.

  1. Führen Sie im Git-Bedienfeld einen der folgenden Schritte aus:
  • Wählen Sie die gewünschte Datei aus und klicken Sie auf  (Symbol „Dateiverlauf anzeigen“).
  • Klicken Sie im Bedienfeld „Dateien“ mit der rechten Maustaste auf die Datei und wählen Sie die Option „Dateiverlauf“.

Im System wird der Git-Dateiverlauf für die ausgewählte Datei angezeigt. Im gleichen Dialogfeld können Sie auch die Details des Commits für diese Datei anzeigen lassen.

Dateiverlauf in Git anzeigen
Dateiverlauf in Git anzeigen

Anzeigen des Repository-Verlaufs

Zusätzlich zum Verlauf einer Datei in Git können Sie auch die auf Repository-Ebene vorgenommenen Änderungen anzeigen. Sie können sämtliche auf Repository-Ebene vorgenommenen Änderungen und Commits anzeigen. Führen Sie die folgenden Schritte durch, um den Repository-Verlauf anzuzeigen:

  1. Klicken Sie im Git-Bedienfeld auf das Symbol „Repository-Verlauf anzeigen“. Im System wird der Git-Repository-Verlauf zusammen mit den Details sämtlicher Commits angezeigt.

  2. Sie können die Commit-Nachricht, das Datum und die Uhrzeit anzeigen, zu denen die Dateien übernommen wurden. Außerdem werden die einem Commit zugeordneten Tags sowie Angaben zum Benutzer angezeigt, der die Dateien übernommen hat.

  3. Im Repository-Verlauf wird normalerweise die Liste der übernommenen Dateien auf Repository-Ebene angegeben. Sie können auf die einzelnen Dateien klicken, um den Änderungsverlauf auf Dateiebene aufzurufen.

Git für die Zusammenarbeit verwenden

Eine der einzigartigen Funktionen von Git sind Verzweigungen (auch „Branches“ genannt). Im Gegensatz zu den meisten Versionskontrollsystemen kann eine Git-Verzweigung eine einzelne Zeile der gesamten verknüpften Dateien oder des Codes darstellen. Standardmäßig hat das Repository eine Verzweigung namens „Master“. Bei der Master-Verzweigung handelt es sich um die Haupt- oder maßgebliche Verzweigung. Sie können vom Master ausgehend Verzweigungen erstellen und an jeder Verzweigung Änderungen vornehmen.

Sie können auch eine Verzweigung von einer anderen Verzweigung erstellen, in die Sie die übergeordnete Verzweigung kopieren. Sie können die beiden Verzweigungen im Git-Repository unabhängig voneinander bearbeiten. So können Sie z. B. in einer Verzweigung an einer neuen Funktion für Ihre Site arbeiten und gleichzeitig Änderungswünsche in einer anderen Verzweigung umsetzen.

In Git können Sie außerdem Verzweigungen zusammenführen, wenn Sie die Änderungen aus der aktuellen Verzweigung in eine Zielverzweigung einschließen möchten. Wenn Sie zwei Verzweigungen zusammenführen, bleiben beide Verzweigungen weiterhin unabhängig voneinander bestehen. Sie können die übergeordnete und die Zielverzweigung weiter bearbeiten.

Wenn in Dreamweaver viele Entwickler und Designer an einer Site zusammenarbeiten, kann jeder Benutzer eine Verzweigung vom Master erstellen und unabhängig Änderungen vornehmen. Bei Bedarf können sie alle Änderungen mit einer anderen Verzweigung zusammenführen und weiterhin mit beiden Verzweigungen arbeiten.

Weitere Informationen zum Erstellen und Verwalten von Verzweigungen in Git finden Sie in den folgenden Abschnitten:

Erstellen von Verzweigungen in Git

  1. Wählen Sie im Bedienfeld „Dateien“ die Dropdown-Liste aus, in der alle Verzweigungen aufgeführt werden.

  2. Klicken Sie auf „Verzweigungen verwalten“.

    Verzweigung in Git erstellen
    Verzweigung in Git erstellen

  3. Klicken Sie links unten im Dialogfeld „Verzweigungen verwalten“ auf das Pluszeichen (+).

    Im Dialogfeld „Verzweigungen verwalten“ unten auf das Pluszeichen klicken
    Im Dialogfeld „Verzweigungen verwalten“ unten auf das Pluszeichen klicken

  4. Wählen Sie im Dialogfeld „Neue Verzweigung erstellen“ die ursprüngliche Verzweigung aus, von der Sie eine Kopie erstellen möchten.

    Wenn es sich um die erste erstellte Verzweigung handelt, ist die ursprüngliche Verzweigung die Master-Verzweigung.

    Ursprüngliche Verzweigung auswählen
    Ursprüngliche Verzweigung auswählen

  5. Geben Sie im Feld „Verzweigungsname“ einen Namen für die neue Verzweigung an.

  6. Klicken Sie auf „OK“.

Zusammenführen von Verzweigungen

  1. Wählen Sie im Bedienfeld „Dateien“ die Dropdown-Liste aus, in der alle Ihre Verzweigungen aufgeführt werden.

  2. Klicken Sie auf „Verzweigungen verwalten“. Wählen Sie im Dialogfeld „Verzweigungen verwalten“ die zusammenzuführende Verzweigung aus.

  3. Klicken Sie auf  (Symbol „Verzweigung zusammenführen“) am unteren Rand des Dialogfelds.

  4. Wählen Sie im Dialogfeld „Verzweigung zusammenführen“ die Zielverzweigung aus. Bei dieser Verzweigung handelt es sich um das Ziel-Repository, mit dem Ihre Verzweigung zusammengeführt werden soll.

    Optional können Sie eine Nachricht zu dieser Zusammenführung angeben.

  5. Klicken Sie auf „OK“, um die Verzweigung mit dem Ziel zusammenzuführen.

    Verzweigungen in Git zusammenführen
    Verzweigungen in Git zusammenführen

    Wenn die Dateiänderungen in einem Commit mit den Änderungen an einer anderen Verzweigung in Konflikt stehen, wird die Zusammenführung angehalten. Es wird eine Konfliktmeldung zusammen mit den Dateien angezeigt, die den Konflikt verursachen.

    Im Git-Bedienfeld werden zudem die Dateien angezeigt, bei denen ein Konflikt vorliegt. Beachten Sie das Symbol, das auf einen Konflikt hinweist.

    Git-Bedienfeld mit Dateien, bei denen beim Zusammenführen ein Konflikt aufgetreten ist
    Git-Bedienfeld mit Dateien, bei denen beim Zusammenführen ein Konflikt aufgetreten ist

    Um mit der Zusammenführung fortzufahren, müssen Sie den Konflikt auflösen. Verwenden Sie dazu die Option „Rebase“ oder die Zusammenführung mit der Option „Kein Fast-Forward“.

  6. Wenn ein Merge-Konflikt auftritt, wählen Sie eine der folgenden Optionen:

    • Rebase verwenden: Wenn Sie die Option „Rebase“ auswählen, werden die aktuellen Änderungen ungeachtet der Konflikte in der Zielverzweigung angewendet. Nachdem Sie „Rebase“ ausgewählt und auf „OK“ geklickt haben, öffnen Sie das Git-Bedienfeld, um die Dateien anzuzeigen, die noch übernommen werden müssen. Sie können den Rebase-Vorgang dann abbrechen oder neu starten. Wenn Sie Rebase abbrechen, wird der Rebase-Vorgang angehalten und es werden keine Änderungen auf die Zielverzweigung angewendet. Beim Neustarten von Rebase werden die Änderungen in Bezug auf die in der Zielverzweigung festgestellten Konflikte übersprungen.
    • Merge-Commit erstellen, auch wenn Merge als Fast-Forward aufgelöst wird: Sie können den Commit auch trotz der festgestellten Konflikte zwischen Ihrer Verzweigung und der Zielverzweigung zusammenführen. In diesem Fall wird die Zusammenführung mit Ihren Änderungen erzwungen, wobei die Änderungen in der Zielverzweigung überschrieben werden.

    Weitere Informationen zu Rebase in Git finden Sie unter Git-Rebase.

Arbeiten mit Remote-Repositorys

Remote-Repositorys in Git sind Versionen eines Projekts, die in einem anderen Netzwerk gehostet werden. Sie können auf Remote-Repositorys zugreifen, indem Sie eine Verbindung mit dem betreffenden Repository herstellen. In Abhängigkeit von den im Remote-Repository angegebenen Zugriffsrechten verfügen Sie entweder über Lesezugriff oder über Schreibzugriff auf dieses Repository.

Bei der Arbeit in einem Team ermöglichen Ihnen Remote-Repositorys das Übertragen und Abrufen von Daten zwischen Repositorys. Im Dreamweaver-Git-Bedienfeld können Sie eine Remoteverbindung erstellen und diverse Git-Vorgänge wie Laden, Git-Übertragung, Git-Abruf und Remote-Aktualisierungen ausführen.

Lesen Sie die folgenden Vorgehensweisen, um zu erfahren, wie Sie Remote-Repositorys erstellen und verwalten.

Hinzufügen eines Remote-Repositorys

Sie können ein Remote-Repository hinzufügen, um Dateien und Ihren Arbeitsfortschritt mit anderen zu teilen und um auf Projektdateien zuzugreifen, die in einem anderen Netzwerk gehostet werden. Indem Sie ein Remote-Repository hinzufügen, stellen Sie eine Remoteverbindung mit dem Ziel-Repository her. Dreamweaver ermöglicht es Ihnen, im Git-Bedienfeld Remote-Repositorys zu erstellen.

Vergewissern Sie sich vor dem Hinzufügen eines Remote-Repositorys, dass für das andere Repository die Einstellung „Öffentlich“ aktiviert ist.

  1. Klicken Sie im Git-Bedienfeld auf „Remote-Repository erstellen“.

  2. Geben Sie einen Namen für das Remote-Repository an.

  3. Geben Sie die URL und die Anmeldeinformationen für das Remote-Repository ein.

    Um sicherzustellen, dass Sie beim Hinzufügen eines Remote-Repositorys eine gültige URL eingegeben haben, klicken Sie nach dem Eingeben der URL auf „Testen“. Wenn Sie auf „Testen“ klicken, wird die Gültigkeit der URL getestet.

    Mit diesem Test können keine Anmeldeinformationen überprüft werden.

    Remote-Repository in Dreamweaver hinzufügen
    Remote-Repository hinzufügen

    Vorsicht:

    Wenn Sie keine gültige URL oder ungültige Anmeldeinformationen eingeben, treten beim Ausführen von Git-Abruf, Git-Übertragung, Laden und anderen Vorgängen Fehler auf.

  4. Klicken Sie auf „OK“.

    Wenn Sie ein Remote-Repository hinzufügen, wird das Repository in der Dropdown-Liste am oberen Rand des Git-Bedienfelds aufgeführt. Sie können zudem weitere Symbole zum Ausführen von Git-Übertragung, Git-Abruf, Laden von Remote-Repository und Zähleraktualisierungen anzeigen.

    Remote-Repositorys in Git hinzufügen
    Remote-Repositorys in Git hinzufügen

Verwalten von Remote-Repositorys

Nach dem Hinzufügen eines Remote-Repositorys und dem Einrichten einer Verbindung können Sie Dateien aus dem Remote-Repository in Ihr lokales Repository laden und abrufen. Sie können Ihre Dateien auch in das Remote-Repository übertragen. Sie müssen jedoch zunächst Dateien aus dem Remote-Repository laden, bevor Sie zum ersten Mal eine Git-Übertragung ausführen.

Denken Sie daran, dass Sie einen Commit aller Dateien im lokalen Repository ausführen müssen, bevor Sie versuchen, Ihre Dateien zu übertragen. Wenn im lokalen Repository bereits bereitgestellte Dateien vorhanden sind, schlägt die Git-Übertragung fehl. 

Sie können in Dreamweaver die folgenden Git-Vorgänge ausführen:

Alle abrufen

Klicken Sie auf , um alle Dateien über sämtliche Remoteverbindungen abzurufen. Es wird empfohlen, einen Git-Ladevorgang auszuführen, bevor Sie Git-Übertragung oder Git-Abruf ausführen. Bei dieser Aktion werden lediglich die Dateien aus dem Remote-Repository geladen und das lokale Repository wird nicht geändert.

Dateien aus dem Remote-Repository abrufen

Sie können Änderungen aus einem einzelnen Repository oder aus einer Gruppe von Repositorys abrufen. Wenn Sie auf das Symbol „Git-Abruf“ klicken, wird das Dialogfeld „Git-Abruf“ mit verschiedenen Optionen im System geöffnet.

  1. Klicken Sie im Git-Bedienfeld auf  (Symbol „Git-Abruf“), um die geänderten Dateien aus dem Remote-Repository abzurufen und die Änderungen mit Ihrem lokalen Repository zusammenzuführen.

  2. Wählen Sie im Dialogfeld „Git-Abruf“ die Verzweigung mit Nachverfolgung aus. Geben Sie an, ob Änderungen aus der aktuellen oder einer anderen Verzweigung abgerufen werden sollen, und legen Sie dann die Abrufeinstellungen fest.

    Git-Abruf aus Remote-Repositorys durchführen
    Git-Abruf aus Remote-Repositorys durchführen

  3. In der Standardeinstellung ist „Standard-Merge“ ausgewählt. In diesem Fall werden die Dateien aus dem Remote-Repository in das lokale Repository abgerufen und die Änderungen werden mit dem lokalen Repository zusammengeführt.

  4. Sie können auch eine der folgenden Optionen wählen:

    • Manuellen Merge vermeiden: Wählen Sie diese Option, um die manuelle Zusammenführung von Dateien zu deaktivieren.
    • Merge ohne Commit: Wählen Sie diese Option, um die Zusammenführung mit dem Remote-Repository auch ohne Commit der bereitgestellten Dateien fortzusetzen.
    • Rebase verwenden: Wählen Sie diese Option, um einen Rebase-Vorgang auszuführen. Bei einem Rebase werden die Änderungen aus der aktuellen Verzweigung für den Verlauf der Verzweigung übernommen, aus der Sie Dateien abrufen. Der zuletzt übernommene Verlauf der Verzweigung wird umgeschrieben. Die Dateien entsprechen jetzt den Versionen in der Zielverzweigung, aus der Sie die Dateien abrufen. Obwohl bei Rebase-Vorgängen ein ordnungsgemäßer Verlauf für Ihre Verzweigung generiert wird, müssen Sie bei Verwendung der Option „Rebase verwenden“ vorsichtig vorgehen.
    • Kontrolliert zurücksetzen: Wählen Sie diese Option, um eine Zurücksetzung oder einen kontrollierten Rebase durchzuführen. Sie können die Option „Kontrolliert zurücksetzen“ verwenden, wenn Sie zum ersten Mal Dateien aus einem Remote-Repository abrufen. In diesem Fall fungiert das Remote-Repository als übergeordnetes Repository, aus dem das lokale Repository alle Änderungen erhält. Die Änderungen in Ihrem lokalen Repository bleiben jedoch erhalten. Dateien, die in Ihrem lokalen Repository vorhanden sind, im Remote-Repository jedoch fehlen, werden von Git nicht erkannt. Diese Dateien werden nach einem kontrollierten Zurücksetzen als gelöschte Dateien angezeigt. Wenn Sie diese Dateien in Ihrem lokalen Repository beibehalten, gehen die Änderungen im Remote-Repository verloren.
    Vorsicht:

    Wenn Sie mit dem kontrollierten Zurücksetzen fortfahren, werden die nicht erkannten Dateien gelöscht.

Dateien in Remote-Repository übertragen

Wenn Sie die Dateien nach dem Herstellen einer Verbindung mit Remote-Repositorys ändern und übernehmen, werden diese Änderungen von Git erfasst. Im Symbol „Git-Übertragung“  im Git-Bedienfeld wird sofort die Anzahl der geänderten Dateien angezeigt. Diese Dateien können nun in das Remote-Repository übertragen werden.

Wenn Sie eine Git-Übertragung ausführen, werden die für das lokale Repository durchgeführten Commits in das Remote-Repository übertragen.

So übertragen Sie Dateien aus Dreamweaver heraus:

  1. Klicken Sie im Git-Bedienfeld auf das Symbol „Git-Übertragung“.

    Das Dialogfeld „Git-Übertragung“ wird geöffnet. Sie können die Commits entweder in die aktuelle Verzweigung mit Nachverfolgung oder in eine andere von Ihnen angegebene Verzweigung übertragen.

    Lokale Commits an ein Git-Remote-Repository übertragen
    Lokale Commits an ein Git-Remote-Repository übertragen

  2. In diesem Dialogfeld können Sie auch die Übertragungseinstellungen festlegen. In der Standardeinstellung ist die Option „Standardübertragung“ ausgewählt.

  3. Hier können Sie auch folgende Optionen auswählen:

    • Erzwungene Übertragung: Wählen Sie diese Option, um die Übertragung Ihrer Änderungen unabhängig von potenziellen Konflikten in das Remote-Repository zu erzwingen.
    • Remote-Verzweigung löschen: Wählen Sie diese Option, wenn die bestehende Remote-Verzweigung gelöscht und die lokalen Dateien in das Remote-Repository übertragen werden sollen.
  4. Aktivieren Sie optional das Kontrollkästchen „Tags senden“, um die Tags in das Remote-Repository zu übertragen.

  5. Klicken Sie auf „OK“.

    Wenn zwischen Ihren lokalen Commits und den für das Remote-Repository ausgeführten Commits Konflikte auftreten, wird empfohlen, erst alle Konflikte aufzulösen. Anschließend können Sie die Änderungen übertragen.

    Dazu müssen Sie zunächst die Änderungen aus dem Remote-Repository abrufen, die Konflikte auflösen und die Dateien dann ohne Konflikte übertragen.

Dateien im Git-Bedienfeld suchen

Mit der Suchleiste im Git-Bedienfeld können Sie Dateien anhand des Dateinamens suchen. Diese Funktion ist besonders hilfreich, wenn Ihre Website eine große Anzahl von Dateien umfasst.

Geben Sie zum Suchen einer Datei einfach den Dateinamen in der Suchleiste ein. Die Dateien, deren Name den Text der Suchanfrage enthält, werden sofort angezeigt.

Hinzufügen von Dateien zur Liste der ignorierten Dateien

Wenn Git für eine bestimmte Datei keine Aktionen ausführen soll, können Sie die betreffende Datei zu „.gitignore“ hinzufügen. Die Dateien in diesem Ordner werden von Git ignoriert, wenn Sie eine Aktion wie Commit, Übertragung oder Abruf ausführen. Sie müssen die Datei „.gitignore“ in Ihr Repository übernehmen, sodass die Dateien im Ordner „.gitignore“ auch allen anderen Benutzern bekannt sind, die Ihr Repository klonen.

Wenn Sie Dateien „.gitignore“ hinzufügen möchten, wechseln Sie in das Bedienfeld „Dateien“ in Dreamweaver. Wählen Sie die von Git zu ignorierende Datei aus und klicken Sie mit der rechten Maustaste darauf. Wählen Sie anschließend „Git“ > „Zu „.gitignore“ hinzufügen“ aus.

Dateien zu „.gitignore“ hinzufügen
Dateien zu „.gitignore“ hinzufügen

Wenn Sie eine Datei zu einem späteren Zeitpunkt aus „.gitignore“ entfernen möchten, wählen Sie die betreffende Datei im Bedienfeld „Dateien“ aus. Klicken Sie mit der rechten Maustaste darauf und wählen Sie „Git“ > „Aus „.gitignore“ entfernen“ aus.

Stellen Sie sicher, dass Sie die Datei „.gitignore“ in das lokale Repository und die Remote-Repositorys übernehmen, nachdem Sie sie geändert haben.

Zugreifen auf Git über die Befehlszeile

In den vorherigen Abschnitten dieses Artikels wurde die Verwendung des Git-Bedienfelds (Benutzeroberfläche) zum Zuordnen eines Git-Repositorys zu Ihrer Site, zum Erstellen und Verwalten von Remote-Verbindungen, zum Übertragen von Dateien an ein Repository oder zum Abrufen von Dateien aus einem Repository erläutert. Sie können diese und viele weitere Aktionen auch mithilfe von Git-Befehlen durchführen.

Führen Sie einen der folgenden Schritte durch, um beliebige Git-Vorgänge über das Git-Terminal durchzuführen:

  • Klicken Sie auf „Fenster“ > „Git“ und klicken Sie auf das Symbol „Bash-/Terminal-Konsole öffnen“.
  • Wechseln Sie im Bedienfeld „Dateien“ zur Git-Ansicht. Klicken Sie neben der Dropdown-Liste der Repositorys auf das Symbol „Git-Terminal öffnen“.

Eine Auflistung der am häufigsten verwendeten Git-Befehle finden Sie in der Git-Kurzreferenz

Hinweis:

Einige Aktionen wie Git-Stash und das Kombinieren von Commits nach dem Übertragen sind derzeit nur über die Befehlszeile möglich.

Wenn Sie bestimmte Aktionen wie das Initialisieren eines Git-Repositorys über die Befehlszeile ausführen, werden diese Aktionen auch auf der Dreamweaver-Benutzeroberfläche widergespiegelt.

Sie können allerdings Dateien über die Befehlszeile bearbeiten, wenn Dreamweaver nicht geöffnet ist. Dann wird beim nächsten Start von Dreamweaver folgende Meldung angezeigt:

Meldung bei Dateien, die über die Befehlszeile bearbeitet wurden
Meldung bei Dateien, die über die Befehlszeile bearbeitet wurden

Festlegen von Git-Voreinstellungen in Dreamweaver

Mit den Git-Voreinstellungen in Dreamweaver können Sie einige Einstellungen für die Verwendung von Git in Dreamweaver definieren. Sie können im Dialogfeld „Voreinstellungen“ Git-Einstellungen wie den Pfad zum Terminal, Zeitüberschreitungseinstellungen usw. festlegen.

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ aus.

  2. Wählen Sie im Dialogfeld „Voreinstellungen“ die Option „Git“ aus.

  3. Legen Sie im Dialogfeld für Git-Voreinstellungen Folgendes fest:

    • Pfad zur ausführbaren Git-Datei: Die EXE-Datei Ihres Git-Clients. Wenn die ausführbare Datei in einem anderen Verzeichnis gespeichert ist, navigieren Sie zum Speicherort der Git-EXE-Datei.
    • Standardzeitüberschreitung für Git-Vorgänge: Geben Sie die Zeitüberschreitung für Remote-Git-Vorgänge in Sekunden an.
    • Pfad zu Terminal: Der vollständige Pfad zur ausführbaren Datei zum Öffnen und Verwenden des Git-Terminals.
    • Befehlsargumente: Geben Sie Befehlsargumente für die Git-Befehle an (sofern erforderlich).
    Voreinstellungen für Git in Dreamweaver festlegen
    Voreinstellungen für Git in Dreamweaver festlegen

  4. Klicken Sie zum Speichern der Einstellungen auf „Anwenden“.

Hinweis:

Starten Sie Dreamweaver neu, um die aktualisierten Einstellungen zu übernehmen.

Adobe-Logo

Bei Ihrem Konto anmelden