Benutzerhandbuch Abbrechen

Optimieren von Code

  1. Dreamweaver-Benutzerhandbuch
  2. Einführung
    1. Grundlagen von responsivem Webdesign
    2. Neue Funktionen in Dreamweaver
    3. Web-Entwicklung mit Dreamweaver – Überblick
    4. Dreamweaver/Häufige Fragen
    5. Tastaturbefehle
    6. Dreamweaver – Systemanforderungen
    7. Übersicht über die Funktionen
  3. Dreamweaver und Creative Cloud
    1. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    2. Creative Cloud-Bibliotheken in Dreamweaver
    3. Photoshop-Dateien in Dreamweaver verwenden
    4. Mit Adobe Animate und Dreamweaver arbeiten
    5. Web-optimierte SVG-Dateien aus Bibliotheken extrahieren
  4. Arbeitsbereiche und Ansichten in Dreamweaver
    1. Der Dreamweaver-Arbeitsbereich
    2. Dreamweaver-Arbeitsbereich für die visuelle Entwicklung optimieren
    3. Dateien anhand von Dateinamen oder Inhalten suchen | Mac OS
  5. Sites einrichten
    1. Dreamweaver-Sites
    2. Lokale Version Ihrer Site einrichten
    3. Verbindung mit einem Publishing Server herstellen
    4. Testserver einrichten
    5. Site-Einstellungen importieren und exportieren
    6. Vorhandene Websites von einem Remote-Server in Ihren lokalen Site-Stammordner kopieren
    7. Barrierefreie Funktionen in Dreamweaver
    8. Erweiterte Einstellungen
    9. Site-Voreinstellungen für die Übertragung von Dateien festlegen
    10. Proxyserver-Einstellungen in Dreamweaver festlegen
    11. Dreamweaver-Einstellungen mit Creative Cloud synchronisieren
    12. Git in Dreamweaver verwenden
  6. Dateien verwalten
    1. Dateien öffnen und erstellen
    2. Dateien und Ordner verwalten
    3. Dateien vom Server abrufen/auf dem Server bereitstellen
    4. Dateien einchecken und auschecken
    5. Dateien synchronisieren
    6. Dateien auf Unterschiede vergleichen
    7. Dateien und Ordner in Ihrer Dreamweaver-Site von Operationen ausschließen (Cloaking)
    8. Design Notes für Dreamweaver-Sites aktivieren
    9. Potenzielle Gatekeeper-Angriffe verhindern
  7. Layout und Entwurf
    1. Visuelle Hilfsmittel für das Layout verwenden
    2. CSS für das Seitenlayout verwenden
    3. Responsive-Websites mit Bootstrap entwerfen
    4. Medienabfragen in Dreamweaver erstellen und verwenden
    5. Inhalte in Tabellen darstellen
    6. Farben
    7. Responsive Design mithilfe von fließenden Rasterlayouts
    8. Extract in Dreamweaver
  8. CSS
    1. Grundlegendes zu Cascading Stylesheets
    2. Gestalten von Seitenlayouts mit CSS Designer
    3. CSS-Präprozessoren in Dreamweaver verwenden
    4. Voreinstellungen für CSS-Stile in Dreamweaver festlegen
    5. CSS-Regeln in Dreamweaver verschieben
    6. Inline-CSS in Dreamweaver in eine CSS-Regel umwandeln
    7. Mit div-Tags arbeiten
    8. Verläufe auf den Hintergrund anwenden
    9. CSS3-Übergangseffekte in Dreamweaver erstellen und bearbeiten
    10. Code formatieren
  9. Seiteninhalt und Elemente
    1. Seiteneigenschaften festlegen
    2. CSS-Eigenschaften von Überschriften und Links festlegen
    3. Mit Text arbeiten
    4. Text, Tags und Attribute suchen und ersetzen
    5. DOM-Bedienfeld
    6. In der Live-Ansicht bearbeiten
    7. In Dreamweaver die Kodierung von Dokumenten festlegen
    8. Elemente im Dokumentfenster auswählen und anzeigen
    9. Texteigenschaften im Eigenschafteninspektor festlegen
    10. Rechtschreibprüfung für Web-Seiten durchführen
    11. Horizontale Linien in Dreamweaver verwenden
    12. Schriftkombinationen in Dreamweaver hinzufügen und ändern
    13. Mit Elementen arbeiten
    14. Datumsangaben in Dreamweaver einfügen und aktualisieren
    15. In Dreamweaver Favoritenelemente erstellen und verwalten
    16. Bilder in Dreamweaver einfügen und bearbeiten
    17. Medienobjekte hinzufügen
    18. Videos in Dreamweaver einfügen
    19. HTML5-Videos einfügen
    20. SWF-Dateien einfügen
    21. Audioeffekte hinzufügen
    22. In Dreamweaver HTML5-Audiodateien einfügen
    23. Mit Bibliothekselementen arbeiten
    24. Arabischen und hebräischen Text in Dreamweaver verwenden
  10. Hyperlinks und Navigation
    1. Allgemeines zu Hyperlinks und Navigation
    2. Hyperlinks erstellen
    3. Imagemaps
    4. Fehler in Hyperlinks beheben
  11. jQuery-Widgets und -Effekte
    1. jQuery UI- und Mobile-Widgets in Dreamweaver verwenden
    2. jQuery-Effekte in Dreamweaver verwenden
  12. Websites programmieren
    1. In Dreamweaver programmieren
    2. Programmierumgebung in Dreamweaver
    3. Voreinstellungen für Code festlegen
    4. Codehervorhebung anpassen
    5. Code schreiben und bearbeiten
    6. Codehinweise und Codevervollständigung
    7. Code aus- und einblenden
    8. Code mit Codefragmenten wiederverwenden
    9. Code-Linting
    10. Code optimieren
    11. Code in der Entwurfsansicht bearbeiten
    12. Mit den Head-Inhalten von Seiten arbeiten
    13. Server-Side Includes in Dreamweaver einfügen
    14. Tag-Bibliotheken in Dreamweaver verwenden
    15. Benutzerdefinierte Tags in Dreamweaver importieren
    16. JavaScript-Verhalten (allgemeine Anweisungen)
    17. Integrierte JavaScript-Verhalten anwenden
    18. XML und XSLT
    19. Server-seitige XSL-Transformationen in Dreamweaver durchführen
    20. Client-seitige XSL-Transformationen in Dreamweaver durchführen
    21. Zeichenentitäten für XSLT in Dreamweaver einfügen
    22. Code formatieren
  13. Produktübergreifende Arbeitsabläufe
    1. Erweiterungen für Dreamweaver installieren und verwenden
    2. In-App-Updates in Dreamweaver
    3. Microsoft Office-Dokumente in Dreamweaver einfügen (nur Windows)
    4. Mit Fireworks und Dreamweaver arbeiten
    5. Mithilfe von Contribute Inhalte in Dreamweaver-Sites bearbeiten
    6. Dreamweaver-Business Catalyst-Integration
    7. Personalisierte E-Mail-Kampagnen erstellen
  14. Vorlagen
    1. Dreamweaver-Vorlagen
    2. Vorlagen und vorlagenbasierte Dokumente erkennen
    3. Dreamweaver-Vorlagen erstellen
    4. Bearbeitbare Bereiche in Vorlagen erstellen
    5. Wiederholende Bereiche und Tabellen in Dreamweaver erstellen
    6. Optionale Bereiche in Vorlagen verwenden
    7. Bearbeitbare Tag-Attribute in Dreamweaver definieren
    8. Verschachtelte Vorlagen in Dreamweaver erstellen
    9. Vorlagen bearbeiten, aktualisieren und löschen
    10. XML-Inhalte in Dreamweaver exportieren und importieren
    11. Vorlage auf ein vorhandenes Dokument anwenden oder aus dem Dokument entfernen
    12. Inhalte in Dreamweaver-Vorlagen bearbeiten
    13. Syntaxregeln für Vorlagen-Tags in Dreamweaver
    14. Markierungseinstellungen für Vorlagenbereiche festlegen
    15. Vorteile von Vorlagen in Dreamweaver
  15. Mobilgeräte und Multiscreen
    1. Medienabfragen erstellen
    2. Seitenausrichtung für Mobilgeräte ändern
    3. Mit Dreamweaver Web-Anwendungen für Mobilgeräte erstellen
  16. Dynamische Websites, Seiten und Web-Formulare
    1. Grundlegendes zu Web-Anwendungen
    2. Computer für die Entwicklung von Anwendungen einrichten
    3. Fehlerbehebung bei Datenbankverbindungen
    4. Verbindungsskripts in Dreamweaver entfernen
    5. Dynamische Seiten entwerfen
    6. Quellen für dynamischen Inhalt – Überblick
    7. Quellen für dynamische Inhalte definieren
    8. Dynamische Inhalte in Seiten einfügen
    9. Dynamischen Inhalt in Dreamweaver ändern
    10. Datenbankdatensätze anzeigen
    11. Live-Daten in Dreamweaver bereitstellen und Fehlerbehebung bei der Anzeige
    12. Benutzerdefinierte Serververhalten in Dreamweaver hinzufügen
    13. Formulare mit Dreamweaver erstellen
    14. Formulare zum Sammeln von Benutzerinformationen verwenden
    15. ColdFusion-Formulare in Dreamweaver erstellen und aktivieren
    16. Web-Formulare erstellen
    17. Verbesserte HTML5-Unterstützung für Formularelemente
    18. Formularentwicklung mit Dreamweaver
  17. Visuelles Entwickeln von Anwendungen
    1. Master- und Detailseiten in Dreamweaver erstellen
    2. Such- und Ergebnisseiten erstellen
    3. Datensatz-Einfügeseiten erstellen
    4. Datensatz-Aktualisierungsseiten in Dreamweaver erstellen
    5. Datensatz-Löschseiten in Dreamweaver erstellen
    6. ASP-Befehle zum Ändern von Datenbanken in Dreamweaver verwenden
    7. Registrierungsseiten erstellen
    8. Anmeldeseiten erstellen
    9. Seiten erstellen, auf die nur autorisierte Benutzer zugreifen können
    10. Ordner in ColdFusion mit Dreamweaver schützen
    11. ColdFusion-Komponenten in Dreamweaver verwenden
  18. Websites testen, in der Vorschau anzeigen und veröffentlichen
    1. Seitenvorschau
    2. Dreamweaver-Web-Seitenvorschau auf mehreren Geräten
    3. Dreamweaver-Site testen

 

Hier erfahren Sie, wie Sie Code in Dreamweaver optimieren, die Browserkompatibilität prüfen, die Gültigkeit von XML-Dokumenten sicherstellen und Seiten zu XHTML kompatibel machen.

Code optimieren

Sie können automatisch leere Tags entfernen, verschachtelte font-Tags kombinieren und unleserlichen oder unübersichtlichen HTML- bzw. XHTML-Code besser strukturieren.

Wie Sie aus einem Microsoft Word-Dokument generierte HTML-Dokumente optimieren, erfahren Sie unter Öffnen und Erstellen von Dokumenten.

  1. Wählen Sie in einem geöffneten Dokument „Werkzeuge“ > „HTML optimieren“.

  2. Aktivieren Sie im angezeigten Dialogfeld die gewünschten Optionen und klicken Sie auf „OK“.
    Hinweis:

    Dieser Vorgang kann mehrere Sekunden dauern, je nachdem, wie groß Ihr Dokument ist und wie viele Optionen Sie ausgewählt haben.

    Entfernen: Leere Container-Tags

    entfernt alle Tags, zwischen denen keine Inhalte stehen. Beispielsweise sind <b></b> und <font color="#FF0000"></font> leere Tags, das <b>-Tag in <b>Beispieltext</b> ist dagegen nicht leer.

    Entfernen: Überflüssige verschachtelte Tags

    entfernt alle nicht benötigten Instanzen eines Tags. Beispielsweise sind in dem Code <b>Das wollte ich <b>wirklich</b> sagen</b> die b-Tags um das Wort wirklich überflüssig und werden daher entfernt.

    Entfernen: HTML-Kommentare, nicht Dreamweaver

    entfernt alle Kommentare, die nicht von Dreamweaver eingefügt wurden. Zum Beispiel würde <!‑‑begin body text--> entfernt werden. Der Kommentar <!‑‑TemplateBeginEditable name="doctitle"‑‑> aber nicht, da es sich hierbei um einen Dreamweaver-Kommentar handelt, der den Anfang eines bearbeitbaren Bereichs in einer Vorlage markiert.

    Entfernen: Spezielles Dreamweaver-Markup

    entfernt Kommentare, die von Dreamweaver dem Code hinzugefügt werden, damit Dokumente bei der Aktualisierung von Vorlagen und Bibliothekselementen automatisch aktualisiert werden können. Wenn Sie diese Option beim Optimieren von Code in einem Dokument aktivieren, das auf einer Vorlage basiert, wird die Verknüpfung des Dokuments mit der Vorlage getrennt. Weitere Informationen finden Sie unter Dokument von einer Vorlage lösen.

    Entfernen: Spezifische(s) Tag(s)

    entfernt die Tags, die im angrenzenden Textfeld angegeben werden. Löschen Sie mit dieser Option benutzerdefinierte Tags, die von anderen visuellen Editoren eingefügt wurden, und andere Tags, die nicht in der Site erscheinen sollen (beispielsweise blink). Mehrere Tags müssen durch Kommas voneinander getrennt werden (z. B. font,blink).

    Verschachtelte <font>-Tags, wenn möglich kombinieren

    fasst zwei oder mehr font-Tags zusammen, die sich auf denselben Textbereich beziehen. So würde beispielsweise <font size="7"><font color="#FF0000">big red</font></font> in <font size="7" color="#FF0000">big red</font> geändert.

    Protokoll nach Abschluss zeigen

    zeigt abschließend ein Meldungsfeld an, in dem die Änderungen aufgeführt werden, die bei der Optimierung am Dokument vorgenommen wurden.

Überprüfen, ob Tags und Klammern paarweise vorhanden sind

Sie können überprüfen lassen, ob die Tags, Klammern ( ), geschweiften Klammern { } und eckigen Klammern [ ] in der Seite korrekt geöffnet und geschlossen werden. Dies bedeutet, dass Tags, Klammern, geschweifte und eckige Klammern jeweils paarweise vorhanden sein müssen.

Prüfen, ob Tags paarweise vorhanden sind

  1. Öffnen Sie das Dokument in der Codeansicht.
  2. Setzen Sie die Einfügemarke in den verschachtelten Code, den Sie prüfen möchten.
  3. Wählen Sie „Bearbeiten“ > „Übergeordnetes Tag auswählen“.

    Die den Abschnitt umgebenden Tag-Paare (und der zugehörige Inhalt) werden im Code ausgewählt. Wenn Sie den Befehl „Bearbeiten“ > „Übergeordnetes Tag auswählen“ mehrmals ausführen und Ihre Tags paarweise vorhanden sind, wählt Dreamweaver schließlich das äußerste Tag-Paar aus, also html und /html.

Prüfen, ob Klammern, geschweifte Klammern und eckige Klammern paarweise vorhanden sind

  1. Öffnen Sie das Dokument in der Codeansicht.
  2. Setzen Sie die Einfügemarke in den Code, den Sie prüfen möchten.
  3. Wählen Sie „Bearbeiten“ > „Code“ > „Fehlende Klammern einfügen“.

    Der gesamte Code zwischen den umgebenden runden Klammern, geschweiften Klammern bzw. eckigen Klammern wird ausgewählt. Wenn Sie erneut „Bearbeiten“ > „Code“ > „Fehlende Klammern einfügen“ wählen, wird der gesamte Code innerhalb der Klammern, geschweiften Klammern bzw. eckigen Klammern ausgewählt, die die neue Auswahl umgeben.

Browserkompatibilität überprüfen

Mithilfe der Funktionen für die Browserkompatibilitätsprüfung können Sie Kombinationen von HTML und CSS aufspüren, die zu Browserfehlern führen können. Darüber hinaus untersucht diese Funktion den Code Ihrer Dokumente auf sämtliche CSS-Eigenschaften oder -Werte, die von den Zielbrowsern nicht unterstützt werden.

XML-Dokumente überprüfen

Sie können für den Validator Voreinstellungen festlegen, spezifische zu überprüfende Probleme vorgeben und die Fehlertypen auswählen, die im Überprüfungsbericht ausgegeben werden sollen.

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie bei einer XML- oder XHTML-Datei den Befehl „Datei“ > „Überprüfen“ > „Als XML“ aus.

    • Im Bedienfeld „Ergebnisse“ wird auf der Registerkarte „Überprüfung“ entweder „Keine Fehler oder Warnungen gefunden“ gemeldet oder es werden die gefundenen Syntaxfehler aufgelistet.

  2. Doppelklicken Sie auf eine Fehlermeldung, um den zugehörigen Fehler im Dokument hervorzuheben.
  3. Wenn Sie den Bericht als XML-Datei speichern möchten, klicken Sie auf die Schaltfläche „Bericht speichern“.
  4. Wenn Sie den Bericht in Ihrem Primärbrowser anzeigen möchten (von dem aus Sie den Bericht drucken können), klicken Sie auf die Schaltfläche „Bericht durchsuchen“.

Dokumente mit der W3C-Überprüfung überprüfen

In Dreamweaver können Sie durch die integrierte Unterstützung der W3C-Überprüfung standardkonforme Webseiten erstellen. Mit der W3C-Überprüfung werden Ihre HTML- und XML-Dokumente auf die Konformität mit HTML-, XHTML- oder XML-Standards überprüft. Sie können sowohl geöffnete Dokumente als auch auf einem Live-Server bereitgestellte Dateien überprüfen.

Mithilfe des Berichts, der nach der Überprüfung erstellt wird, können Sie Fehler in Ihrer Datei beheben.

Hinweis:

In Dreamweaver können Sie den Parser angeben, mit dem die Dokumente überprüft werden müssen. Diese Voreinstellung wird als Fallback-Einstellung verwendet, wenn der DOCTYPE nicht automatisch ermittelt werden kann.

Geöffnete Dokumente überprüfen

  1. Wählen Sie „Fenster“ > „Ergebnisse“ > „Überprüfung“, um das Bedienfeld „Überprüfung“ zu öffnen. In diesem Bedienfeld werden die Ergebnisse der Überprüfung angezeigt.

  2. Wählen Sie „Datei“ > „Überprüfen“ > „Aktuelles Dokument (W3C)“.

Live-Dokumente überprüfen

Bei Live-Dokumenten wird der vom Browser empfangene Code überprüft. Dieser Code wird angezeigt, wenn Sie im Browser mit der rechten Maustaste klicken und dann die Option zum Anzeigen des Quellcodes auswählen. Die Überprüfung von Live-Dokumenten empfiehlt sich vor allem bei dynamischen Seiten mit PHP, JSP usw.

Die Option „Live-Dokument überprüfen“ ist nur aktiviert, wenn die URL der zu überprüfenden Seite mit http beginnt.

  1. Wählen Sie „Fenster“ > „Ergebnisse“ > „Überprüfung“, um das Bedienfeld „Überprüfung“ zu öffnen. In diesem Bedienfeld werden die Ergebnisse der Überprüfung angezeigt.

  2. Klicken Sie auf „Live-Ansicht“.

  3. Wählen Sie „Datei“ > „Überprüfen“ > „Live-Dokument (W3C)“.

Wenn Sie bei Live-Dokumenten im Bedienfeld „W3C-Überprüfung“ auf einen Fehler doppelklicken, wird ein separates Fenster geöffnet. In diesem Fenster wird der vom Browser generierte Code angezeigt und die Zeile mit dem Fehler wird hervorgehoben.

Einstellungen für die Überprüfung anpassen

  1. Wählen Sie „Fenster“ > „Ergebnisse“ > „Überprüfung“, um das Bedienfeld „Überprüfung“ zu öffnen.

  2. Klicken Sie im Bedienfeld „W3C-Überprüfung“ auf das Symbol für die W3C-Überprüfung (Wiedergabesymbol). Wählen Sie „Einstellungen“ aus.

  3. Wählen Sie einen DOCTYPE für die Überprüfung aus, wenn für das Dokument nicht ausdrücklich ein DOCTYPE festgelegt wurde.

  4. Wenn Fehler und Warnungen nicht angezeigt werden sollen, deaktivieren Sie die entsprechenden Optionen.

  5. Klicken Sie auf „Verwalten“, wenn Warnungen oder Fehler, die Sie in der W3C-Überprüfung ausgeblendet haben, gelöscht werden sollen. Wenn Sie Warnungen und Fehler entfernen, werden diese bei Auswahl von „Alles anzeigen“ im Bedienfeld „W3C-Überprüfung“ nicht angezeigt.

  6. Wählen Sie „Dialogfeld zur Benachrichtigung für die W3C-Überprüfung nicht anzeigen“ aus, wenn das Dialogfeld zur Benachrichtigung für die W3C-Überprüfung beim Starten der Überprüfung nicht angezeigt werden soll.

Überprüfungsberichte verwenden

Nach Abschluss der Überprüfung werden die Überprüfungsberichte im Bedienfeld „W3C-Überprüfung“ angezeigt.

  • Wenn Sie weitere Informationen zu einem Fehler oder einer Warnung anzeigen möchten, markieren Sie den Fehler bzw. die Warnung im Bedienfeld „W3C-Überprüfung“. Klicken Sie dann auf „Weitere Informationen“.

  • Wenn Sie den Bericht als XML-Datei speichern möchten, klicken Sie auf „Bericht speichern“.

  • Wenn Sie den gesamten Bericht im HTML-Format anzeigen möchten, klicken Sie auf „Bericht durchsuchen“. Im HTML-Bericht sind die vollständige Liste der Fehler und Warnungen sowie eine Zusammenfassung aufgeführt.

  • Um zu dem Codeabschnitt mit dem Fehler zu springen, markieren Sie den Fehler im Bedienfeld „W3C-Überprüfung“. Klicken Sie auf die Schaltfläche „Optionen“ und wählen Sie „Gehe zu Zeile“ aus.

  • Wenn Sie Fehler oder Warnungen ausblenden möchten, wählen Sie den entsprechenden Fehler oder die betreffende Warnung aus. Klicken Sie auf die Schaltfläche „Optionen“ und wählen Sie dann „Fehler ausblenden“ aus.

  • Wenn alle Fehler und Warnungen, einschließlich der ausgeblendeten Fehler und Warnungen angezeigt werden sollen, klicken Sie auf die Schaltfläche „Optionen“. Wählen Sie dann „Alles anzeigen“ aus. Alle ausgeblendeten Fehler und Warnungen, die Sie im Dialogfeld „Voreinstellungen“ gelöscht haben, werden nicht angezeigt.

  • Klicken Sie zum Löschen aller Ergebnisse im Bedienfeld „W3C-Überprüfung“ auf die Schaltfläche „Optionen“. Wählen Sie dann „Ergebnisse löschen“ aus.

Voreinstellungen für die Überprüfung festlegen

Zusätzlich zur Standard-W3C-Überprüfung unterstützt Dreamweaver externe Codeüberprüfungsprogramme, die als Erweiterungen installiert sind. Wenn Sie eine Erweiterung für ein externes Überprüfungsprogramm installieren, werden die zugehörigen Voreinstellungen in Dreamweaver in der Kategorie „W3C-Überprüfung“ des Dialogfelds „Voreinstellungen“ aufgeführt.

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Dreamweaver“ > „Voreinstellungen“ (Mac).
  2. Wählen Sie links in der Kategorieliste die Option „W3C-Überprüfung“.

  3. Wählen Sie die Tag-Bibliotheken aus, die für die Überprüfung herangezogen werden sollen.

    Sie können nicht mehrere Versionen der gleichen Tagbibliothek oder Sprache auswählen. Wenn Sie z. B. HTML 4.01 auswählen, können Sie nicht auch HTML 5 auswählen. Wählen Sie die früheste Version aus, die für die Überprüfung herangezogen werden soll. Enthält ein Dokument beispielsweise gültigen HTML 4.01-Code, handelt es sich dabei auch um gültigen HTML 5-Code.

  4. Wählen Sie Anzeigeoptionen für die Arten von Fehlern und Warnungen, die im Validator-Bericht aufgeführt werden sollen.
  5. Klicken Sie auf „Anwenden“, um die Änderungen zu übernehmen, und klicken Sie auf „Schließen“, um das Dialogfeld „Voreinstellungen“ zu schließen.

Seiten mit XHTML kompatibel machen

Wenn Sie eine Seite erstellen, können Sie diese XHTML-kompatibel machen. Es ist auch möglich, ein vorhandenes HTML-Dokument XHTML-kompatibel zu machen.

XHTML-kompatible Dokumente erstellen

  1. Wählen Sie „Datei“ > „Neu“.
  2. Wählen Sie die Kategorie und den Typ der zu erstellenden Seite aus.
  3. Wählen Sie ganz rechts im Dialogfeld im Popupmenü „Dok.typ“ eine der XHTML-DTDs (Dokumenttypdefinitionen) aus und klicken Sie auf „Erstellen“.

    Sie können beispielsweise ein HTML-Dokument XHTML-kompatibel machen, indem Sie „XHTML 1.0 Transitional“ oder „XHTML 1.0 Strict“ im Popupmenü auswählen.

    Hinweis:

    Nicht alle Dokumenttypen können XHTML-kompatibel gemacht werden.

Standardmäßig XHTML-kompatible Dokumente erstellen

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ bzw. „Dreamweaver“ > „Voreinstellungen“ (Mac OS X) und wählen Sie die Kategorie „Neues Dokument“.
  2. Wählen Sie ein Standarddokument und dann im Popupmenü „Standard-Dokumenttyp (DDT)“ eine der XHTML-DTDs (Dokumenttypdefinitionen) aus. Klicken Sie auf „OK“.

    Sie können beispielsweise ein HTML-Dokument XHTML-kompatibel machen, indem Sie „XHTML 1.0 Transitional“ oder „XHTML 1.0 Strict“ im Popupmenü auswählen.

Vorhandene HTML-Dokumente XHTML-kompatibel machen

  1. Öffnen Sie ein Dokument und führen Sie einen der folgenden Schritte aus:

    • Wählen Sie für ein Dokument ohne Frames „Datei“ > „Konvertieren“ und anschließend eine der XHTML-Dokumenttypdefinitionen.

      Sie können beispielsweise ein HTML-Dokument XHTML-kompatibel machen, indem Sie „XHTML 1.0 Transitional“ oder „XHTML 1.0 Strict“ im Popupmenü auswählen.

    • Wählen Sie für ein Dokument mit Frames einen Frame aus. Wählen Sie dann „Datei“ > „Konvertieren“ und anschließend eine der XHTML-Dokumenttypdefinitionen aus.

  2. Um das gesamte Dokument zu konvertieren, wiederholen Sie diesen Schritt für jeden Frame sowie für das Frameset-Dokument.

Hinweis:

Es ist nicht möglich, eine Instanz einer Vorlage zu konvertieren, da sie in derselben Sprache vorliegen muss wie die Vorlage, auf der sie basiert. So ist zum Beispiel ein auf einer XHTML-Vorlage basierendes Dokument immer in XHTML kodiert. Ein auf einer nicht XHTML-kompatiblen HTML-Vorlage basierendes Dokument ist immer in HTML kodiert und kann nicht in XHTML oder eine andere Sprache konvertiert werden.

Adobe-Logo

Bei Ihrem Konto anmelden