Sobre imagens HDR

O intervalo dinâmico (proporção entre regiões claras e escuras) no mundo visível supera facilmente o intervalo de visão humana e de imagens impressas ou exibidas no monitor. Mas, embora o olho humano possa adaptar-se a vários níveis de brilho diferentes, a maioria das câmeras e monitores de computadores pode reproduzir apenas um intervalo dinâmico fixo. Fotógrafos, artistas cinematográficos e outros profissionais que trabalham com imagens digitais devem ser seletivos sobre o que é importante na cena, pois estão trabalhando com um intervalo dinâmico limitado.

As imagens High Dynamic Range (HDR) promovem um mundo de possibilidades, porque podem representar todo o intervalo dinâmico do mundo visível. Como todos os valores de luminescência na cena do mundo real são representados proporcionalmente e armazenados em uma imagem HDR, o ajuste da exposição da imagem HDR é como o ajuste da exposição ao fotografar uma cena do mundo real.

Mesclar imagens do Photoshop
Mesclagem de imagens de diferentes exposições para criar imagens HDR

A. Imagem com detalhes de sombras mas com cortes de realces B. Imagem com detalhes de realce mas com cortes de sombras C. Imagem HDR contendo o intervalo dinâmico da cena 

No Photoshop, os valores de luminescência da imagem HDR são armazenados com uma representação numérica de ponto flutuante de 32 bits (32 bits por canal). Os valores de luminescência em uma imagem HDR estão diretamente relacionados à intensidade de luz da cena. Em contraste, arquivos de imagem com ponto não flutuante de 16 ‑ e 8 bpc armazenam valores de luminescência somente de preto ao branco de papel, refletindo um segmento extremamente pequeno do intervalo dinâmico no mundo real.

No Photoshop, o comando Mesclar para HDR Pro permite a criação de imagens HDR combinando-se múltiplas fotografias capturadas em exposições diferentes. Uma vez que uma imagem HDR contém níveis de brilho que excedem em muito as capacidades de exposição de um monitor de 24‑bits padrão, o Photoshop permite o ajuste da visualização HDR. Se precisar imprimir ou usar ferramentas e filtros que não funcionam com imagens HDR, converta-os em imagens de 16 ou 8 bpc.

Tire fotos para imagens HDR

Quantas fotos são necessárias para processar uma mesclagem HDR de qualidade?

Leia estas notas de orientação e dicas de Rikk Flohr (Engenheiro de qualidade de software do ecossistema de aplicativos do Lightroom, Adobe).

As fotos HDR são usadas para capturar cenas com um grande intervalo dinâmico. No entanto, o uso de maior quantidade de fotos pode gerar artefatos indesejados de alinhamento incorreto ou efeito fantasma. Para uma excelente mesclagem HDR, o objetivo é capturar fotos de uma maneira que cada parte da cena fique bem exposta, que não fique nem apagada e nem subexposta em pelo menos uma das fotos.

Use as seguintes diretrizes para identificar quantas fotos funcionam melhor no seu caso:

  • Se o agrupamento HDR tiver menos de 3,0 paradas na separação total (-1,5, 0, +1,5), use apenas as exposições mais escuras e claras para gerar um HDR. Nesses casos, a captura da exposição média, ou exposição zero, não é necessária para gerar uma mistura de exposição de qualidade. Se você exceder a separação de 3 paradas entre as exposições mais escuras e as mais claras, uma compensação de exposição adicional será necessária para processar uma foto HDR de boa qualidade.
Consulte o gráfico abaixo para determinar rapidamente o número de fotos necessárias para processar uma mesclagem HDR de qualidade
Configurações do agrupamento da câmera Número ideal de exposições para mesclar fotos em HDR
-1,5 a +1,5 2
-3,0 a +3,0 3
-4,5 a +4,5 4
-6,0 a +6,0 5
  • Se você é um fotógrafo usando o agrupamento de exposição de ± 1,5, poderá ignorar a exposição zero ou média. Isso ajuda na renderização mais rápida e melhora as probabilidades de alinhamento no HDR resultante, reduzindo as chances de possíveis movimentos da câmera entre as exposições. No entanto, a exposição zero pode ser útil em cenários em que a cena de captura está dentro da faixa aceitável de uma única exposição e pode ser desenvolvida de forma independente.
  • Se você está fazendo capturas em HDR padrão usando um agrupamento de ± 2,0, idealmente você precisará de apenas três fotos para mesclar em um HDR.
  • Se você está fazendo capturas com paradas de 5 ± 4,0, você pode passar de 5 para 4 capturas para mesclar e processar HDR. No entanto, se você está capturando com paradas de 7 ± 6,0, você pode conseguir uma mistura otimizada de HDR com apenas 5 capturas (-6,0, –3,0, 0, 3,0, 6,0) geradas pela sua câmera com etapa de 3 paradas na função de agrupamento de exposição.

Lembre-se das seguintes dicas ao tirar fotos que serão combinadas com o comando Mesclar para HDR Pro

  • Fixe a câmera em um tripé.

  • Tire fotos suficientes para cobrir o intervalo dinâmico completo da cena. Tente tirar, pelo menos, de cinco a sete fotos, mas poderá ser necessário usar mais exposições, dependendo do intervalo dinâmico da cena. O número mínimo de fotos deve ser três.

  • Varie a velocidade do obturador para criar exposições diferentes. A mudança da abertura altera a profundidade de campo em cada exposição e pode produzir resultados de qualidade mais baixa. A mudança do ISO ou da abertura pode também gerar ruídos ou vinhetas na imagem.

  • Em geral, não use o recurso de parênteses automáticos da sua câmera, pois as mudanças de exposição normalmente são muito pequenas.

  • As diferenças de exposição entre as fotos devem ser de uma ou duas etapas EV (valor de exposição), equivalentes a aproximadamente uma ou duas interrupções em F.

  • Não varie a iluminação, por exemplo, usando flash em uma exposição e não usando na seguinte.

  • Não deve haver movimentos na cena. Mesclagem de Exposição funciona apenas com imagens da mesma cena expostas de forma diferente.

Recursos que oferecem suporte a imagens HDR de 32 bpc

É possível usar as seguintes ferramentas, ajustes e filtros com imagens HDR de 32 bpc. (Para trabalhar com mais recursos do Photoshop, converta uma imagem de 32 bpc em uma imagem de 16 bpc ou 8 bpc. Para preservar a imagem original, crie uma cópia com o comando Salvar como.)

Ajustes

Níveis, Exposição, Matiz/Saturação, Misturador de Canais, Filtro de Foto.

Observação:

embora o comando Exposição possa ser usado com imagens de 8 e 16 bpc, ele foi desenvolvido para fazer ajustes de exposição em imagens HDR de 32 bpc.

Modos de Mesclagem

Normal, dissolver, escurecer, multiplicar, clarear, cor mais escura, subexposição linear (adicionar), cor mais clara, diferença, subtrair, dividir, matiz, saturação, cor e luminosidade.

Criação de novos documentos de 32 bpc

Na caixa de diálogo Novo, 32 bits é uma opção no menu pop-up de profundidade de bits, à direita do menu pop-up Modo de cores.

Comandos do menu Editar

Todos os comandos incluindo Preencher, Traçar, Transformação livre e Transformação.

Formatos de Arquivo

Photoshop (PSD, PSB), Radiance (HDR), Portable Bit Map (PBM), OpenEXR e TIFF.

Observação:

embora o Photoshop não possa salvar uma imagem HDR no formato de arquivo LogLuv TIFF, pode abrir e ler arquivos com esse formato.

Filtros

Média, Desfoque de Caixa, Desfoque Gaussiano, Desfoque de Movimento, Desfoque Radial, Desfoque de Forma, Desfoque de Superfície, Adicionar Ruído, Nuvens, Nuvens por Diferença, Reflexo de Flash, Aplicação Inteligente de Nitidez, Tirar nitidez da máscara, Entalhe, Desentrelaçamento, Cores NTSC, Alta Frequência, Máximo, Mínimo e Deslocamento.

Comandos de imagem

Tamanho da imagem, Tamanho da Tela de Pintura, Rotação de Imagem, Corte, Aparar, Duplicar, Aplicar Imagem, Cálculos e Variáveis.

Exibir

Proporção de pixels (Personalizar proporção de pixels, Excluir proporção de pixels, Redefinir proporção de pixels etc.)

Camadas

Novas camadas, camadas duplicadas, camadas de ajuste (Níveis, Vibratilidade, Matiz/Saturação, Misturador de canais, Filtro de fotos e Exposição), camadas de preenchimento, máscaras de camada, estilos de camada, modos de mesclagem suportados e Objetos inteligentes.

Modos

Cores RGB, Tons de Cinza, conversão em 8 bits/canal ou 16 bits/canal.

Proporções de pixel

Suporte para documentos quadrados e não quadrados.

Seleções

Inverter, Modificar borda, Transformar seleção, Salvar seleção e Carregar seleção.

Ferramentas

Todas as ferramentas da caixa de ferramentas, exceto: Laço magnético, Varinha mágica, Pincel de recuperação para manchas, Pincel de recuperação, Olhos vermelhos, Substituição de cor, Pincel história da arte, Borracha mágica, Borracha de plano de fundo, Lata de tinta, Subexposição, Superexposição e Esponja. Algumas ferramentas funcionam apenas com modos de mesclagem suportados.

Mesclagem de imagens para HDR

O comando Mesclar para HDR combina múltiplas imagens com diferentes exposições da mesma cena, capturando a faixa dinâmica completa em uma imagem HDR única. Você pode efetuar a saída da imagem mesclada como um arquivo de 32, 16 ou 8 bpc. No entanto, somente um arquivo de 32 bpc pode armazenar todos os dados da imagem HDR.

A mescla HDR funciona melhor quando as fotos são otimizadas para o processo. Para obter recomendações, consulte Tirar fotos para imagens HDR.

  1. Siga um destes procedimentos:
    • (Photoshop) Escolha Arquivo > Automatizar > Mesclar para HDR Pro.

    • (Bridge) Selecione as imagens que deseja usar e escolha Ferramentas > Photoshop > Mesclar para HDR Pro. Pule para a etapa 5.

  2. Na caixa de diálogo Mesclar para HDR Pro, clique em Procurar para selecionar imagens específicas e clique em Adicionar arquivos abertos ou escolha Usar > Pasta. (Para remover um determinado item, selecione-o na lista de arquivos e clique em Remover.)
  3. (Opcional) Selecione a opção Tentar alinhar automaticamente as imagens de origem, caso tenha fotografado as diversas imagens com a câmera nas mãos.
  4. Clique em OK.

    Observação:

    Se imagens não tiverem metadados de exposição, insira valores na caixa de diálogo Definir EV manualmente.

    Uma segunda caixa de diálogo Mesclar para HDR Pro exibe miniaturas das imagens de origem e uma visualização do resultado mesclado.

  5. No canto superior direito da visualização, escolha uma profundidade de bits para a imagem mesclada.

    Observação:

    Escolha 32 bits se quiser que a imagem mesclada armazene a faixa dinâmica inteira da imagem HDR. Os arquivos de imagem de 8 bits (ponto não flutuante) e de 16 bits não podem armazenar a faixa inteira dos valores de luminescência em uma imagem HDR.

  6. (Opcional) Para salvar as configurações de tons para uso futuro, escolha Predefinição > Salvar predefinição. (Para voltar a aplicar depois as configurações, escolha a Carregar predefinição.)

Opções para imagens de 32 bits

Mova o controle deslizante em baixo do histograma para ajustar a visualização do ponto branco da imagem mesclada. Mover o controle deslizante somente ajusta a visualização da imagem. Todos os dados da imagem HDR permanecem no arquivo mesclado.

O ajuste da visualização é armazenado no arquivo HDR e aplicado sempre que você abrir o arquivo no Photoshop. Para reajustar a visualização do ponto branco a qualquer momento, selecione Visualizar > Opções de visualização de 32 bits.

Observação:

O Filtro do Camera Raw não funciona com arquivos de 32 bits nos seguintes programas:

  • Adobe Camera Raw 9.10
  • Photoshop CC 2017

Se você estiver usando um dos programas acima, veja O Filtro do Camera Raw não funciona mais com arquivos de 32 bits para conferir as soluções alternativas para esse problema.

Opções para imagens de 16 ou 8 bits

As imagens de HDR contêm níveis de luminescência que de longe excedem a faixa dinâmica que as imagens de 16 ou 8 bpc podem armazenar. Para produzir uma imagem com a faixa dinâmica desejada, ajuste a exposição e o contraste ao converter de 32 bpc para uma profundidade de bits menor.

Escolha um dos seguintes métodos de mapeamento de tom:

Adaptação local

Ajusta a tonalidade HDR ao ajustar regiões de brilho locais através da imagem.

Brilho da aresta

O raio especifica o tamanho das regiões de brilho locais. A intensidade especifica a separação que deve haver para os valores tonais de dois pixels antes de eles deixarem de existir na mesma região de brilho.

Tom e detalhe

A faixa dinâmica é maximizada na configuração de Gama de 1.0. Configurações mais baixas acentuam tons médios, enquanto as configurações mais altas acentuam realces e sombras. Os valores de exposição refletem as f-interrupções. Arraste o controle deslizante de detalhe para ajustar a nitidez e os controles deslizantes de sombra e realce para clarear ou escurecer estas regiões.

Cor

A vibratilidade ajusta a intensidade de cores sutis, minimizando o corte de cores altamente saturadas. A saturação ajusta a intensidade de todas as cores de -100 (monocromático) a +100 (saturação dupla).

Curva de tonalização

Exibe uma curva ajustável por cima de uma histograma que mostra valores de luminescência na imagem HDR original de 32 bits. As marcas de seleção vermelhas ao longo do eixo horizontal estão com incrementos de EV (aproximadamente uma interrupção em F).

Observação:

Por padrão, a curva de tonalização e histograma limita e equaliza as alterações de ponto a ponto. Para remover o limite e aplicar ajustes mais extremos, selecione a opção Vértice depois de inserir um ponto na curva. Quando você insere e move um segundo ponto, a curva se torna angular.

Ajuste da Curva de tonalização e histograma do Photoshop
Ajuste da Curva de tonalização e histograma usando a opção Vértice

A. Inserção de um ponto e seleção da opção Vértice. B. O ajuste de novo ponto torna a curva angular no ponto em que a opção Vértice foi aplicada. 

Equalizar Histograma

Compacta a faixa dinâmica da imagem HDR, tentando preservar o contraste. Não é necessário nenhum ajuste adicional; esse método é automático.

Exposição e Gama

Permite ajustar manualmente o brilho e o contraste da imagem HDR. Mova o controle deslizante de Exposição para ajustar o ganho e o controle deslizante Gama para ajustar o contraste.

Compactação de Realces

Compacta os valores de realce da imagem HDR para que eles fiquem dentro do intervalo de valores de luminescência do arquivo de imagem de 8 ou 16 bpc. Não é necessário nenhum ajuste adicional; esse método é automático.

Compensar por objetos em movimento

Se as imagens tiverem conteúdo diferente devido aos objetos em movimento, como carros, pessoas ou folhagem, selecione Remover fantasmas na caixa de diálogo Mesclar para HDR Pro.

O Photoshop exibe um contorno verde em torno da miniatura com o melhor equilíbrio de tom, identificando a imagem baseada. Os objetos em movimento encontrados em outras imagens são removidos. (Se o movimento ocorre em áreas muito claras ou escuras, clique em uma miniatura diferente onde os objetos em movimento estão melhor expostos para melhorar os resultados).

Observação:

Para assistir um tutorial sobre a opção Remover Fantasmas, consulte este vídeo. (A discussão de Remover fantasmas começa às 15:00.)

Salvar ou carregar curvas de resposta de câmera

As curvas de resposta indicam como os sensores de câmera interpretam níveis diferentes da luz de entrada. Por padrão, a caixa de diálogo Mesclar para HDR Pro calcula automaticamente uma curva de resposta da câmera com base na gama tonal de imagens que você está mesclando. Você pode salvar a curva de resposta atual e depois aplicá-la a outro grupo de imagens mescladas.

  • No canto superior direito da caixa de diálogo Mesclar para HDR Pro, clique no menu de curva de resposta  e a seguir escolha Salvar curva de resposta. (Para voltar a aplicar depois a curva, escolha Carregar curva de resposta.)

Conversão de 32 bits em 16 ou 8 bpc

Se você originalmente criou uma imagem de 32 bits durante o processo Mesclar para HDR Pro, poderá mais tarde convertê-la em uma imagem de 16 ou 8 bits.

  1. Abra uma imagem de 32 bpc no Photoshop e escolha Imagem > Modo > 16 bits/canal ou 8 bits/canal.
  2. Ajuste a exposição e o contraste para produzir uma imagem com a faixa dinâmica desejada. (Consulte Opções para imagens de 16 ou 8 bits.)
  3. Clique em OK para converter a imagem de 32 bits.

Ajuste da faixa dinâmica exibida para imagens de HDR de 32 bits

O intervalo dinâmico de imagens HDR excede as capacidades de exibição dos monitores padrão de computador. Quando uma imagem HDR é aberta no Photoshop, ela pode parecer muito escura ou clara. O Photoshop permite ajustar a visualização para que o monitor exiba uma imagem HDR cujos realces e sombras não estejam claros nem escuros demais. As configurações da visualização são armazenadas no arquivo de imagem HDR (apenas PSD, PSB e TIFF) e são aplicadas sempre que o arquivo é aberto no Photoshop. Os ajustes da visualização não editam o arquivo de imagem HDR; todas as informações da imagem HDR permanecem intactas. Use o ajuste Exposição (Imagem > Ajustes > Exposição) para efetuar edições de exposição na imagem HDR de 32 bpc.

Observação:

Para visualizar leituras de 32 bits no painel Informações, clique no ícone Conta-gotas do painel Informações e escolha 32 bits no menu pop-up.

  1. Abra uma imagem HDR de 32 bpc no Photoshop e escolha Exibir > Opções de Visualização em 32 bits.
  2. Na caixa de diálogo Opções de Visualização em 32 Bits, escolha uma opção no menu Método:

    Exposição e Gama

    Ajusta o brilho e o contraste.

    Compactação de Realces

    Compacta os valores de realce da imagem HDR para que eles fiquem dentro do intervalo de valores de luminescência do arquivo de imagem de 8 ou 16 bpc.

  3. Se escolher Exposição e Gama, mova os controles deslizantes de Exposição e Gama para ajustar o brilho e o contraste da visualização da imagem.
  4. Clique em OK.

    Observação:

    É possível também ajustar a visualização de uma imagem HDR aberta no Photoshop clicando no triângulo da barra de status da janela do documento e escolhendo Exposição de 32 Bits no menu pop-up. Mova o controle deslizante para definir o ponto branco da visualização da imagem HDR. Clique duas vezes no controle deslizante para retornar às configurações de exposição padrão. Como o ajuste é feito por exibição, a mesma imagem HDR pode ser aberta em várias janelas, cada uma com ajuste de visualização diferente. Os ajustes de visualização feitos por esse método não são armazenados no arquivo de imagem HDR.

Sobre o Seletor de Cores HDR

O Seletor de Cores HDR permite visualizar e selecionar cores com precisão para uso em imagens HDR de 32 bits. Como no Adobe Color Picker, você seleciona uma cor clicando no campo de cores e ajustando o controle deslizante de cores. O controle deslizante de Intensidade permite ajustar o brilho de uma cor para corresponder à intensidade das cores na imagem HDR em que você está trabalhando. Uma área de Visualização permite visualizar amostras de uma cor selecionada para ver como ela será exibida em exposições e intensidades diferentes.

Seletor de cores HDR do Photoshop
Seletor de Cores HDR

A. Área de visualização B. Cor ajustada C. Cor original D. Valores de ponto flutuante de 32 bits E. Controle deslizante de Intensidade F. Cor selecionada G. Controle deslizante de cores H. Valores de cor 

Exibição do Seletor de Cores HDR

Com uma imagem de 32 bpc aberta, siga um destes procedimentos:

  • Na caixa de ferramentas, clique na caixa de seleção de cores de primeiro plano ou de plano de fundo.

  • No painel Cor, clique na caixa de seleção Definir Cor de Primeiro Plano ou Definir Cor de Plano de Fundo.

O Seletor de Cores também está disponível quando os recursos permitem escolher uma cor. Por exemplo, clicando na amostra de cores na barra de opções para algumas ferramentas, ou nos conta-gotas em algumas caixas de diálogo de ajuste de cor.

Escolher cores para imagens HDR

A parte inferior do Seletor de Cores HDR funciona como o Seletor de Cores regular no que se refere às imagens de 8 e 16 bits. Clique no campo de cores para selecionar uma cor e mover o controle deslizante de cores para alterar os matizes, ou use os campos HSB ou RGB para inserir valores numéricos para uma cor específica. No campo de cores, o brilho aumenta de baixo para cima e a saturação aumenta da esquerda para a direita.

Use o controle deslizante de Intensidade para ajustar o brilho da cor. O valor da cor mais o valor de intensidade são convertidos em valores de ponto flutuante de 32 bits no seu documento HDR.

  1. Selecione uma cor clicando no campo de cores e movendo o controle deslizante de cores, ou inserindo valores numéricos HSB ou RGB, como no Adobe Color Picker.
  2. Ajuste o controle deslizante de Intensidade para aumentar ou reduzir o brilho da cor. A nova amostra de cores na escala Visualização, na parte superior do Seletor de Cores, mostra o efeito do aumento ou da diminuição das interrupções para a cor selecionada.

    As interrupções da Intensidade correspondem inversamente às interrupções das configurações de exposição. Se você aumentar a configuração de Exposição da imagem HDR para duas interrupções, a redução de duas interrupções da Intensidade manterá a mesma aparência de cores, como se a exposição da imagem HDR e a intensidade de cores estivessem definidas como 0.

    Se você souber os valores RGB de 32 bits exatos para a cor desejada, você pode inseri-los diretamente nos campos de valor RGB de 32 bits.

  3. (Opcional) Ajuste as configurações para a área de Visualização.

    Tamanho de Interrupção da Visualização

    Define os incrementos de interrupção para cada amostra de visualização. Por exemplo, uma configuração de 3 resultados em amostras de -9, -6, -3, +3, +6, +9. Estas amostras permitem que você visualize a aparência da cor selecionada em configurações de exposição diferentes.

    Relativo ao Documento

    Selecione para ajustar as amostras de visualização para refletir a configuração de exposição atual para a imagem. Por exemplo, se a exposição do documento possuir uma configuração superior, a nova amostra de visualização será mais clara do que a cor selecionada no campo cor do Seletor de Cores, para exibir o efeito da maior exposição na cor selecionada. Se a exposição atual for definida como 0 (o padrão), marcar ou desmarcar essa opção não mudará a nova amostra.

  4. (Opcional) Clique em Adicionar a Amostras para adicionar a cor selecionada ao painel Amostras.
  5. Clique em OK.

Pintura em imagens HDR

É possível editar e adicionar efeitos a imagens HDR/32 bpc usando qualquer uma destas ferramentas do Photoshop: Pincel, Lápis, Caneta, Forma, Carimbo, Carimbo de Padrão, Borracha, Degradê, Desfoque, Tornar Nítido, Borrar e Pincel do Histórico. Também é possível usar a ferramenta Texto para adicionar camadas de texto de 32 bpc a uma imagem HDR.

Ao editar ou pintar em imagens HDR, é possível visualizar seu trabalho em diferentes configurações de exposição usando o controle deslizante de Exposição de 32 Bits na área de informações do documento ou a caixa de diálogo Opções de Visualização em 32 bits (Exibir > Opções de Visualização em 32 bits). O Seletor de Cores HDR também permite visualizar a cor do primeiro plano selecionada em diferentes configurações de intensidade, para corresponder às diferentes configurações de exposição em uma imagem HDR.

  1. Abra uma imagem HDR.
  2. (Opcional) Defina a exposição para a imagem. Consulte Ajuste da faixa dinâmica exibida para imagens de HDR de 32 bits.
  3. Para as ferramentas Pincel ou Lápis, clique na cor do primeiro plano para abrir o Seletor de Cores HDR e selecionar uma cor. Para a ferramenta Texto, clique no chip da cor na barra de opções dessa ferramenta para definir a cor do texto.

    A área de Visualização do Seletor de Cores HDR ajuda a selecionar e ajustar uma cor de primeiro plano em relação a diferentes configurações de exposição na imagem HDR. Consulte Sobre o Seletor de Cores HDR.

    Observação:

    Por padrão, a curva de tonalização e histograma limita e equaliza as alterações de ponto a ponto. Para remover o limite e aplicar ajustes mais extremos, selecione a opção Vértice depois de inserir um ponto na curva. Quando você insere e move um segundo ponto, a curva se torna angular.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online