Gráficos orientados por dados possibilitam a criação rápida e precisa de várias versões de uma imagem para projetos de impressão ou da Web. Por exemplo, com base em um único projeto de modelo, é possível criar 100 versões de um banner da Web com textos e imagens diferentes.

Siga estas etapas gerais para criar gráficos a partir de modelos e conjuntos de dados:

Crie o gráfico base que será usado como modelo.

Use camadas para separar os elementos a serem alterados no gráfico.

Defina variáveis no gráfico.

Variáveis especificam as partes da imagem que são alteradas. (Consulte Definição de variáveis.)

Crie ou importe os conjuntos de dados.

É possível criar os conjuntos de dados no modelo ou importá-los a partir de um arquivo de texto. (Consulte Definição de um conjunto de dados e Criação de conjuntos de dados em arquivos externos.)

Visualize o documento com cada conjunto de dados.

Para verificar a aparência final dos gráficos, é possível visualizá-los antes de exportar todos os arquivos. (Consulte Visualização ou aplicação de um conjunto de dados.)

Gere os gráficos exportando-os junto com os dados.

Esses gráficos podem ser exportados como arquivos PSD (Photoshop).. (Consulte Geração de dados com o uso de conjuntos de dados.)

Versões diferentes de uma imagem usando variáveis do Photoshop
Criação de diferentes versões de uma imagem usando variáveis

A. Modelo de arquivo de origem B. O usuário define camadas como variáveis. C. Diferentes versões da imagem podem ser criadas, cada qual com um conjunto distinto de dados de variáveis. 

Definição de variáveis

Variáveis são usadas para definir quais elementos são alterados em um modelo. É possível definir três tipos de variáveis. Variáveis de visibilidade mostram ou ocultam o conteúdo de uma camada. Variáveis de Substituição de Pixel substituem os pixels na camada pelos pixels de outro arquivo de imagem. Variáveis de Substituição de Texto substituem uma seqüência de texto em uma camada de texto.

Observação:

o GoLive reconhece todas as variáveis de texto e de visibilidade, mas não reconhece as variáveis de Substituição de Pixel.

Variáveis de definição do Photoshop
Duas versões de uma imagem com base no mesmo modelo

A. Variável de visibilidade B. Variável de Substituição de Pixel C. Variável de Substituição de Texto 

Não é possível definir variáveis para a camada de Plano de Fundo.

  1. Escolha Imagem > Variáveis > Definir.
  2. No menu pop-up Camada, selecione uma camada que inclua o conteúdo a ser definido como variável.
  3. Selecione um ou mais tipos de variáveis:

    Visibilidade

    Mostra ou oculta o conteúdo da camada.

    Substituição de Pixel

    Substitui os pixels na camada pelos pixels de outro arquivo de imagem.

    Substituição de Texto

    Substitui uma seqüência de texto em uma camada de texto.

  4. Siga um destes procedimentos:
    • Escolha Nome e digite um nome para a variável. Nomes de variáveis devem começar com uma letra, um caractere de sublinhado ou um caractere de dois pontos e não podem conter espaços ou caracteres especiais (exceto pontos, hifens, sublinhados e dois pontos).

    • No menu pop-up Nome, escolha uma variável existente à qual vincular a camada em questão. As camadas vinculadas à mesma variável aparecem ao lado do menu Nome, junto com o ícone de vínculo.

  5. Para variáveis de Substituição de Pixel, defina as seguintes opções.
    • Escolha um método para o dimensionamento da imagem de substituição: A opção Ajustar dimensiona a imagem de forma a ajustá-la à caixa delimitadora (podendo deixar partes da caixa delimitadora em branco). A opção Preencher dimensiona a imagem de forma que ela preencha a caixa delimitadora totalmente (podendo fazer com que a imagem ultrapasse os limites delimitados). A opção Como Está não dimensiona a imagem, enquanto a opção Encaixar dimensiona essa imagem desproporcionalmente de forma a ajustá-la à caixa delimitadora.

    • Clique em uma alça do ícone de alinhamento para escolher um alinhamento que colocará a imagem na caixa delimitadora. (Ela não está disponível para o método Encaixar.)

    • Selecione a opção Recorte para Caixa Delimitadora para recortar áreas da imagem que não se ajustam à caixa delimitadora. Essa opção apenas está disponível com a seleção do método de substituição Preencher ou Como Está. (Ela não está disponível para o método Encaixar.)

  6. Para definir variáveis em uma outra camada, escolha essa camada no menu.pop-up Camada.. Um asterisco é exibido ao lado do nome de uma camada que contenha variáveis. É possível usar as setas de navegação para percorrer camadas.
  7. Clique em OK.

Renomeação de uma variável

  1. Escolha Imagem > Variáveis > Definir.
  2. No menu pop-up Camada, escolha a camada que contém a variável.
  3. Para renomear a variável, digite um nome na caixa de texto Nome. Nomes de variáveis devem começar com uma letra, um caractere de sublinhado ou um caractere de dois pontos e não podem conter espaços ou caracteres especiais (exceto pontos, hifens, sublinhados e dois pontos).
  4. Para remover a variável, basta cancelar sua seleção.

Definição de um conjunto de dados

Um conjunto de dados é um agrupamento de variáveis e dados associados. Um conjunto de dados é definido para cada versão do gráfico que o usuário pretende gerar.

  1. Siga um destes procedimentos:
    • Escolha Imagem > Variáveis > Conjuntos de Dados.

    • Se a caixa de diálogo Variáveis estiver aberta, escolha Conjuntos de Dados, no menu pop-up localizado na parte superior da caixa de diálogo, ou clique em Próximo.

    Observação:

    defina pelo menos uma variável antes de editar o conjunto de dados padrão.

  2. Clique no botão Novo conjunto de dados .
  3. No menu pop-up Nome ou na lista localizada na parte inferior da caixa de diálogo, selecione uma variável.
  4. Edite os dados das variáveis:
    • Para variáveis de Visibilidade., selecione Visível para mostrar o conteúdo da camada ou Invisível para ocultar esse conteúdo.

    • Para variáveis de Substituição de Pixel., clique em Selecionar Arquivo, e selecione um arquivo de imagem de substituição. Clique em Não Substituir antes de aplicar o conjunto de dados para manter a camada em seu estado atual.

    Observação:

    a opção Não Substituir não redefinirá o arquivo para seu estado original se outra substituição já tiver sido aplicada.

    • Para variáveis de Substituição de Texto , digite uma seqüência de texto na caixa de texto Valor.
  5. Defina conjuntos de dados adicionais para cada versão do gráfico a ser gerado.

Posteriormente, será possível editar, renomear ou excluir o conjunto de dados escolhendo-o no menu pop-up Conjunto de Dados e, em seguida, editando suas opções. Use os ícones de seta para percorrer conjuntos de dados. Clique no ícone Excluir para excluir um conjunto de dados.

Visualização ou aplicação de um conjunto de dados

É possível aplicar o conteúdo de um conjunto de dados à imagem base e, ao mesmo tempo, deixar todas as variáveis e todos os conjuntos de dados inalterados. Essa ação altera a aparência do documento PSD de forma a incluir os valores do conjunto de dados. Também é possível visualizar a aparência de cada versão do gráfico com cada conjunto de dados.

Observação:

a aplicação de um conjunto de dados sobrescreve o documento original.

  1. Escolha Imagem > Aplicar Conjuntos de Dados. Selecione o conjunto de dados na lista e visualize a imagem na janela de documentos. Para aplicar um conjunto de dados, clique em Aplicar. Clique em Cancelar se você não estiver visualizando e não quiser alterar a imagem base.

    Também é possível aplicar e visualizar um conjunto de dados na página Conjunto de Dados, localizada na caixa de diálogo Variáveis.

Geração de gráficos como o uso de conjuntos de dados

Depois de definir variáveis e um ou mais conjuntos de dados, é possível gerar imagens, no modo em lote, usando os valores desse(s) conjunto(s) de dados e como arquivos PSD.

  1. Escolha Arquivo > Exportar > Conjuntos de Dados como Arquivos.
  2. Digite um nome base para todos os arquivos gerados. Se desejar, crie um esquema personalizado de nomenclatura de arquivo.
  3. Clique no botão Selecionar Pasta para selecionar um diretório de destino para os seus arquivos.
  4. Escolha conjuntos de dados a serem exportados.
  5. Clique em OK.

Criação de conjuntos de dados em arquivos externos

É possível criar rapidamente vários conjuntos de dados criando um arquivo de texto externo que inclua todas as informações sobre variáveis e carregando esse arquivo em um documento PSD que possua variáveis. Um dos métodos para fazer isso é digitar dados em um arquivo de texto ou em uma planilha do Microsoft Excel e, em seguida, exportar esses dados como um arquivo separado por vírgula ou tabulação.

A sintaxe do arquivo de texto externo é a seguinte (em que cada linha iniciada com "Variable" ou "Value" corresponde a uma linha inteira no arquivo):

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl> 
Value1-1<sep>Value2-1<sep><sep>ValueN-1<nl> 
Value1-2<sep>Value2-2<sep><sep>ValueN-2<nl> 
Value1-M<sep>Value2-M<sep><sep>ValueN-M<nl>

Todos os nomes de variáveis são listados na primeira linha, seguindo a ordem na qual os valores são fornecidos nas linhas subseqüentes. Cada linha subseqüente representa um conjunto de dados, com os valores para cada variável especificada.

Observação:

Para criar várias linhas de texto em uma única linha de texto em um conjunto de dados, delimite o texto por aspas duplas e quebras de linha forçadas no arquivo separado por vírgula ou tabulação no qual deseja que as divisões ocorram.  

Elementos de sintaxe de arquivos de texto externos

<sep>

Arquivo separado por vírgula (CSV) ou por tabulação que separa cada nome ou valor de variável.

<nl>

Caractere de nova linha que termina cada conjunto de dados e que pode consistir em uma alimentação de linha e/ou em um retorno de carro.

“true” e “false”

Valores permitidos para uma variável de visibilidade.

Espaços

Espaços ao redor do delimitador são removidos durante a análise do arquivo. Espaços entre palavras em uma sequência de valores (por exemplo, valores idênticos) são preservados, e espaços à esquerda e à direita serão mantidos se estiverem entre aspas duplas (por exemplo, “exclusivo”).

Aspas duplas

Podem ser parte de um valor caso estejam precedidas por outras aspas duplas (por exemplo, ““B”” pode corresponder a “B” no conjunto de dados).

Se <sep> ou <nl> fizer parte do valor da variável, o valor inteiro deverá ser delimitado por aspas duplas.

Todas as variáveis definidas no documento PSD devem estar especificadas no arquivo de texto. Será exibido um erro se o número de variáveis no arquivo de texto não corresponder ao número no documento.

Exemplo de conjunto de dados:

Com o uso de um modelo para “flores”, que possui variáveis para “tulipa” e “girassol”, é possível configurar um arquivo de texto com a seguinte aparência:

{contents of FlowerShow.txt} 
Variable 1, Variable 2, Variable 3 
true, TULIP, c:\My Documents\tulip.jpg 
false, SUNFLOWER, c:\My Documents\sunflower.jpg 
false, CALLA LILY, c:\My Documents\calla.jpg 
true, VIOLET, c:\My Documents\violet.jpg

Observação:

um caminho relativo poderá ser usado para o local da imagem se o arquivo de texto estiver na mesma pasta que o arquivo original. Por exemplo, o último item do modelo apresentado pode ser: true, VIOLET, violet.jpg.

Importação de um conjunto de dados

  1. Siga um destes procedimentos:
    • Escolha Arquivo > Importar > Conjunto de Dados Variáveis.

    • Escolha Imagem > Variáveis > Conjuntos de Dados e clique no botão Importar.

  2. Navegue até o arquivo de texto a ser importado.
  3. Configure as opções de importação.

    Usar Primeira Coluna para Nomes de Conjuntos de Dados

    Nomeia cada conjunto de dados usando o conteúdo da primeira coluna do arquivo de texto (os valores referentes à primeira variável listada). Caso contrário, os conjuntos de dados serão nomeados como “Conjunto de Dados 1, Conjunto de Dados 2, etc.”

    Substituir Conjuntos de Dados Existentes

    Exclui todos os conjuntos de dados existentes antes da importação.

  4. Defina a codificação do arquivo de texto ou mantenha a configuração Automático.
  5. Clique em OK.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online