О классической анимации движения

Примечание.

Как и для большинства операций в Animate, для анимации не требуется ActionScript. Однако если необходимо, можно создать анимации с помощью ActionScript.

Классическая анимация — это старый способ создания анимации в Animate. Эти анимации похожи на новые анимации движения, однако иногда их сложнее создавать и они менее гибкие. Однако классическая анимация предоставляет некоторые возможности управления, недоступные для анимации движения. Большинство пользователей предпочтет работу с новой анимацией движения, но некоторые пользователи по-прежнему будут использовать классическую анимацию. Дополнительные сведения о различиях см. в разделе «Различия между анимацией движения и классической анимацией».

Приступая к работе:

Перед началом работы с классической анимацией движения следует учитывать следующее:

  • Классическая анимация — это старый способ создания анимации движения в Animate. Новый более простой способ заключается в использовании анимации движения. См. «Анимация движения».

  • С помощью классической анимации нельзя анимировать 3D-свойства.

Примеры классической анимации см. на веб-странице «Примеры Animate» по адресу www.adobe.com/go/learn_fl_samples_ru. Доступны следующие примеры.

  • Анимированное отбрасывание тени. Чтобы получить доступ к примеру, загрузите и распакуйте файл Samples.zip и перейдите в папку Graphics\AnimatedDropShadow.

  • Анимация и градиенты. Чтобы получить доступ к примеру, загрузите и распакуйте файл Samples.zip и перейдите в папку Graphics\AnimationAndGradients.

Создание и редактирование ключевых кадров для классической анимации движения

Примечание.

Этот раздел посвящен созданию ключевых кадров для старой классической анимации. Справку по ключевым кадрам свойств для новой анимации движения см. в разделе «Создание анимации движения».

Изменения в классической анимации описаны в ключевом кадре. В tween-анимации ключевые кадры задаются в основных моментах анимации, а Animate создает содержимое кадров между ключевыми кадрами. Промежуточные кадры tween-анимации выделяются светло-синим или светло-зеленым со стрелкой, нарисованной между кадрами. Поскольку в документах Animate фигуры сохраняются в каждом ключевом кадре, ключевые кадры следует создавать только в тех точках анимации, в которых что-то изменяется.

Ключевые кадры обозначаются на временной шкале следующим образом: сплошной круг представляет собой ключевой кадр с содержимым, пустой круг перед кадром представляет собой пустой ключевой кадр. Последующие кадры, добавленные в один слой, имеют то же содержимое, что и ключевой кадр.

В классической анимации можно редактировать только ключевые кадры. Tween-кадры можно просмотреть, но их невозможно редактировать напрямую. Чтобы отредактировать tween-кадры, измените один из определяющих ключевых кадров или добавьте новый ключевой кадр между начальным и завершающим кадром. Чтобы добавить элементы в текущий ключевой кадр, перетащите элементы из панели «Библиотека» в рабочую область.

Отображение и редактирование одновременно более одного кадра см. в разделе «Использование режима калькирования».

Создание ключевых кадров

  1. Выполните одно из следующих действий.
    • Выберите кадр на временной шкале и выберите команду «Вставка» > «Временная шкала» > «Ключевой кадр».

    • Щелкните кадр на временной шкале правой кнопкой мыши (Windows) или при нажатой клавише «Control» (Macintosh) и выберите команду «Вставить ключевой кадр».

Вставка кадров во временную шкалу

  • Чтобы добавить новый кадр, выберите команду «Вставка» > «Временная шкала» > «Кадр».

  • Чтобы добавить новый ключевой кадр, выберите «Вставка» > «Временная шкала» > «Ключевой кадр», щелкнув правой кнопкой мыши (Windows) или удерживая нажатой клавишу «Control» (Macintosh), кадр, в который помещается ключевой кадр, и выберите команду «Вставить ключевой кадр».

  • Чтобы добавить новый пустой ключевой кадр, выберите «Вставка» > «Временная шкала» > «Ключевой кадр», щелкните правой кнопкой мыши (Windows) или удерживая нажатой клавишу «Control» (Macintosh), кадр, в который помещается ключевой кадр, и выберите команду «Пустой ключевой кадр».

Удаление или изменение кадра или ключевого кадра

  • Чтобы удалить кадр, ключевой кадр или последовательность кадров, выберите их, щелкнув правой кнопкой мыши (Windows) или удерживая нажатой клавишу «Control» (Macintosh), и выберите команду «Удалить кадры». Соседние кадры остаются без изменений.

  • Чтобы переместить кадр или последовательность кадров вместе с содержимым, выберите их и перетащите в нужное положение.

  • Чтобы увеличить продолжительность ключевого кадра, перетащите его, удерживая нажатой клавишу «Alt» или «Option», к конечному кадру новой последовательности.

  • Чтобы скопировать и вставить кадр или последовательность кадров, выберите их и выберите команду «Правка» > «Временная шкала» > «Копировать кадры». Выберите кадр или последовательность кадров для замены и выберите команду «Правка» > «Временная шкала» > «Вставить кадры». Чтобы заменить на целевой временной шкале точное количество скопированных кадров, выберите параметр «Вставить и перезаписать кадры».

  • Чтобы преобразовать ключевой кадр в простой кадр, выберите ключевой кадр и выберите команду «Модификация» > «Временная шкала» > «Очистить ключевой кадр» или щелкните ключевой кадр правой кнопкой мыши (Windows) или при нажатой клавише «Control» (Macintosh) и выберите команду «Очистить ключевой кадр». Очищенный ключевой кадр и все кадры, вплоть до следующего ключевого кадра, будут замещены содержимым кадра, предшествующего очищенному кадру.

  • Чтобы скопировать ключевой кадр или последовательность кадров с помощью перетаскивания, выберите их и перетащите в новое место, удерживая нажатой клавишу «Alt» (Windows) или «Option» (Macintosh).

  • Чтобы изменить длину последовательности tween-кадров, перетащите влево или вправо начальный или конечный кадр.

  • Чтобы добавить элемент из библиотеки в текущий ключевой кадр, перетащите элемент из панели «Библиотека» в рабочую область.

  • Чтобы инвертировать последовательность анимации, выберите нужные кадры в одном или нескольких слоях и выберите команду «Модификация» > «Временная шкала» > «Обратить кадры». В начале и в конце последовательности должны быть ключевые кадры.

Добавление классической анимации движения в экземпляр, группу или текст

Примечание.

Этот раздел посвящен созданию старой классической анимации. Справку по созданию новой анимации движения см. в разделе «Создание анимации движения».

Чтобы анимировать изменения свойств экземпляров, групп и типов, можно использовать классическую анимацию движения. Animate может создать промежуточную позицию, размер, поворот и наклон экземпляров, групп и шрифта. Кроме того, Animate может создать промежуточные цвета экземпляров и шрифта, создавая постепенные сдвиги цвета или заставляя экземпляр постепенно исчезать или появляться.

Прежде чем создавать промежуточные кадры цвета групп или шрифта, превратите их в символы. Прежде чем анимировать отдельные символы в блоке текста, поместите каждый символ в отдельный текстовый блок.

Если применить классическую анимацию, а затем изменить число кадров между двумя ключевыми кадрами либо переместить группу или символ в другой ключевой кадр, Animate снова автоматически создает промежуточные кадры.

 

Создание классической анимации движения

  1. Щелкните имя слоя, чтобы сделать его активным, и выберите пустой ключевой кадр слоя, с которого должна начинаться анимация. Это будет первый кадр классической анимации.
  2. Чтобы добавить содержимое в первый кадр классической анимации, выполните одно из следующих действий.
    • Создайте графический объект с помощью инструментов «Перо», «Овал», «Прямоугольник», «Карандаш» или «Кисть», а затем преобразуйте его в символ.

    • Создайте экземпляр, группу или текстовый блок в рабочей области.

    • Перетащите экземпляр символа с панели «Библиотека».

    Примечание.

    Для создания анимации движения необходимо, чтобы на слое находился только один элемент.

  3. Создайте второй ключевой кадр, на котором должна заканчиваться анимация, и оставьте новый ключевой кадр выбранным.
  4. Чтобы изменить элемент в конечном кадре, выполните одно из следующих действий:
    • Переместите элемент в новую позицию.

    • Измените размер, поворот и наклон элемента.

    • Измените цвет элемента (только экземпляра или текстового блока). Чтобы создать промежуточные кадры для цвета элементов, которые не являются экземплярами или текстовыми блоками, используйте анимацию формы.

  5. Чтобы создать классическую анимацию, выполните одно из следующих действий.
    • Щелкните любой кадр в диапазоне кадров анимации и выберите «Вставка» > «Классическая анимация движения».

    • В диапазоне кадров анимации щелкните любой кадр правой кнопкой мыши (Windows) или удерживая клавишу Control (Macintosh) и в контекстном меню выберите «Создать классическую анимацию движения».

    Если на шаге 2 был создан графический объект, Animate автоматически преобразует объект в символ и присвоит ему имя tween1.

  6. Если на шаге 4 был изменен размер элемента, выберите «Масштаб» и разделе «Анимация» инспектора свойств, чтобы анимировать изменение размера выделенного элемента.
  7. Чтобы обеспечить более реалистичное ощущение движения, примените замедление/ускорение к классической анимации движения. Чтобы применить замедление к классической анимации, используйте поле «Замедление» в разделе «Анимация» инспектора свойств, чтобы указать значение замедления для каждого экземпляра классической анимации движения. В диалоговом окне «Пользовательское замедление и ускорение» можно более точно контролировать скорость классической анимации движения.

    Перетащите значение в поле «Замедление» или введите значение, чтобы настроить скорость изменений между промежуточными кадрами.

    • Чтобы начать классическую анимацию движения медленно и ускорить по направлению к конечному кадру анимации, введите отрицательное значение между -1 и -100.

    • Чтобы начать классическую анимацию движения быстро и замедлить по направлению к конечному кадру анимации, введите положительное значение между 1 и 100.

    • Чтобы выполнить более сложное изменение скорости в пределах диапазона кадров анимации, щелкните кнопку «Редактировать» рядом с полем «Замедление», чтобы открыть диалоговое окно «Пользовательское замедление и ускорение».

      По умолчанию скорость изменений между промежуточными кадрами постоянна. Ускорение дает более естественный вид ускорения или замедления за счет постепенного изменения скорости изменений.

  8. Чтобы повернуть выделенный элемент в процессе анимации, выберите нужный вариант в меню «Вращение» инспектора свойств.
    • Чтобы запретить поворот, выберите «Нет» (параметр по умолчанию).

    • Чтобы повернуть объект один раз в направлении, требующем наименьшего движения, выберите «Авто».

    • Чтобы повернуть объект как указано, а затем ввести число поворотов, выберите «По часовой стрелке» или «Против часовой стрелки».

    Примечание.

    Поворот на шаге 8 добавляется к любому повороту, который был применен к конечному кадру на шаге 4.

  9. При использовании траектории движения выберите параметр «Ориентация по контуру» в инспекторе свойств, чтобы сориентировать базовую линию анимируемого элемента по отношению к траектории движения.
  10. Чтобы синхронизировать анимацию экземпляров графических символов с основной временной шкалой, выберите параметр «Синхр.» в инспекторе свойств.

    Примечание.

    Как команда «Модификация» > «Временная шкала» > «Синхронизировать символы», так и параметр «Синхр.» заново вычисляют число кадров в анимации движения, чтобы число соответствовало числу кадров, выделенных на временной шкале. Используйте команду «Синхронизировать», если число кадров в последовательности анимации внутри символа не кратно числу кадров, которое занимает в документе графический экземпляр.

  11. При использовании контура движения выберите «Привязать», чтобы прикрепить анимируемый элемент к контуру движения по точке регистрации.

Работа с классической анимацией, сохраненной в виде XML-файлов

Animate позволяет работать с классической анимацией в виде XML-файлов. Собственная среда Animate позволяет применять следующие команды для любой классической анимации:

  • Копировать движение как XML

  • Экспортировать движение как XML

  • Импортировать движение как XML

 

Копировать движение как XML

Позволяет копировать свойства движения, примененные к любому объекту в указанном кадре в рабочей области.

  1. Создайте классическую анимацию.

  2. Выберите ключевой кадр на временной шкале.

  3. Выберите «Команды» > «Копировать движение как XML».

Свойства движения копируются в буфер обмена как XML-данные, после этого их можно редактировать в любом текстовом редакторе.

Экспортировать движение как XML

Позволяет экспортировать свойства движения, примененные к любому объекту в рабочей области, в XML-файл, который можно сохранить.

  1. Создайте классическую анимацию.

  2. Выберите «Команды» > «Экспортировать движение как XML».

  3. Найдите подходящее местоположение для сохранения файла.

  4. Укажите имя для XML-файла и нажмите кнопку «Сохранить».

Классическая анимация экспортируется как XML-файл в указанное местоположение.

Импортировать движение как XML

Позволяет импортировать существующий XML-файл, для которого определены свойства движения.

  1. Выберите объект в рабочей области.

  2. Выберите «Команды» > «Импортировать движение как XML».

  3. Укажите местоположение и выберите XML-файл. Нажмите кнопку «ОК».

  4. В диалоговом окне «Специальная вставка движения» выберите свойства, которые требуется применить к выбранному объекту.

  5. Нажмите кнопку «ОК».

Создание направляющего слоя движения

Для управления движением объектов при классической анимации движения создайте направляющий слой.

Нельзя перетащить слой с анимацией движения или слой с позами обратной кинематики на направляющий слой.

  1. Перетащите обычный слой на направляющий слой. В результате направляющий слой превратится в направляющий слой движения и свяжет обычный слой с новым направляющем слоем движения.

    Примечание.

    Чтобы избежать случайного преобразования направляющего слоя, все направляющие слои лучше поместить в нижней части списка слоев.

Создание классической анимации движения вдоль траектории

Примечание.

Этот раздел посвящен работе со старой классической анимацией движения. Сведения об использовании новой анимации движения с траекториями движения см. в разделе «Изменение траектории движения анимации движения».

Ведущие слои позволяют рисовать контуры, вдоль которых можно анимировать экземпляры, группы и текстовые блоки. Чтобы несколько объектов следовали по одному контуру, можно привязать несколько слоев к ведущему слою. Обычный слой, привязанный к ведущему слою, становится ведомым слоем.

Траектория движения
В этом примере два объекта на отдельных слоях прикрепляются к одному и тому же контуру движения.

Создание траектории движения для классической анимации движения

  1. Создание последовательности классической анимации движения.

    При выборе параметра «Ориентировать по контуру» в инспекторе свойств базовая линия промежуточных элементов ориентируется по траектории движения. При выборе параметра «Привязать» точка регистрации промежуточного элемента привязывается к траектории движения.

  2. Щелкните имя слоя, содержащего классическую анимацию движения, правой кнопкой мыши (Windows) или удерживая клавишу Control (Macintosh) и выберите команду «Добавить направляющую классической анимации».

    Animate добавляет слой направляющей движения над слоем классической анимации движения и делает отступ перед именем слоя классической анимации движения, чтобы показать, что он привязан к слою направляющей движения.

    Примечание.

    Если на временной шкале уже есть слой направляющей, можно перетащить слой с классической анимацией движения под слой направляющей, чтобы превратить его в направляющую движения и привязать к нему классическую анимацию движения.

    Направляющий слой движения
    Слой направляющей движения над слоем, содержащий классическую анимацию движения.

  3. Чтобы добавить в слой направляющей движения траекторию для классической анимации движения, выделите слой направляющей движения и нарисуйте нужную траекторию с помощью инструмента «Перо», «Карандаш», «Линия», «Круг», «Прямоугольник» или «Кисть».

    Также в слой направляющей движения можно вставить контур.

  4. Перетащите анимируемый объект, чтобы привязать его к началу линии в первом кадре и к концу линии в последнем кадре.
    Изображение, привязанное к началу направляющего контура
    Изображение автомобиля, привязанное к началу направляющего контура.

    Примечание.

    Для достижения лучших результатов привязки перетащите символ к его точке преобразования.

  5. Чтобы скрыть слой направляющей и траекторию так, чтобы во время работы было видно только перемещение объекта, щелкните столбец со значком глаза на ведущем слое.

    При воспроизведении анимации группа или символ следует вдоль контура движения.

Дополнительные сведения о направляющих анимации на базе обводки с переменной шириной см. в документе Направляющая анимации.

  1. Выполните одно из следующих действий.
    • Перетащите существующий слой под ведущий слой. Слой под ведущим слоем располагается с отступом. Все объекты на этом слое автоматически привязываются к контуру движения.

    • Создайте новый слой под ведущим слоем. Объекты на этом слое, для которых применяется tween-анимация, автоматически двигаются вдоль контура движения.

    • Выберите слой под ведущим слоем. Выберите «Модификация» > «Временная шкала» > «Свойства слоя» и выберите «Направляющая».

  1. Выделите слой для отмены связи и выполните одно из следующих действий.
    • Перетащите слой в положение над ведущим слоем.

    • Выберите «Модификация» > «Временная шкала» > «Параметры слоя» и выберите «Обычный» для типа слоя.

Вставка свойств классической анимации движения

Примечание.

Этот раздел посвящен вставке свойств старой классической анимации. Сведения о вставке свойств новой анимации движения см. в разделе «Копирование и вставка свойств анимации движения».

Команда «Вставить движение» позволяет скопировать классическую анимацию и вставить только определенные свойства, которые нужно применить к другому объекту.

  1. На временной шкале выделите кадры, содержащие копируемую классическую анимацию. Выделенные кадры должны располагаться на одном слое, однако они не обязательно должны охватывать одну классическую анимацию. Выбранная область может охватывать tween-анимацию, пустые кадры либо две или несколько tween-анимаций.
  2. Выберите меню «Правка» > «Временная шкала» > «Копировать движение».
  3. Выберите экземпляр символа, который получает копируемую классическую анимацию движения.
  4. Выберите меню «Правка» > «Временная шкала» > «Вставить специальное движение». Выберите особые свойства классической анимации движения, которые следует добавить к экземпляру символа. Существуют следующие свойства классической анимации движения.

    Положение по оси X

    Смещение объекта по оси X.

    Положение по оси Y

    Смещение объекта по оси Y.

    Масштаб по горизонтали

    Отношение между текущим размером объекта и его фактическим размером по горизонтали (X).

    Масштаб по вертикали

    Указывает отношение между текущим размером объекта и его фактическим размером по вертикали (Y).

    Поворот и наклон

    Поворот и наклон объекта Эти свойства должны быть применены к объекту одновременно. Наклон — это мера поворота в градусах, поэтому при одновременном повороте и наклоне каждое из этих свойств влияет на другое.

    Color

    К объекту применяются все значения цвета, такие как оттенок, яркость и альфа-канал.

    Фильтры

    Все значения и изменения фильтра для выбранного диапазона. Если к объекту применяются фильтры, то фильтр добавляется с неизмененными значениями и его состояние (включен или выключен) тоже применяется к новому объекту.

    Режим наложения

    Применяет режим наложения объекта.

    Изменить конечные свойства масштаба

    Если свойство не установлено, то оно указывает, что все свойства добавляются относительно целевого объекта. Если установлено, то этот параметр перезаписывает свойства масштаба целевого объекта.

    Изменить конечные свойства поворота и наклона

    Если свойство не установлено, то оно указывает, что все свойства добавляются относительно целевого объекта. Если установлено, то добавляемые свойства перезаписывают существующие свойства поворота и наклона объекта.

    Необходимые кадры, tween-анимация и сведения о символах добавляются так, чтобы соответствовать исходной копируемой tween-анимации.

    Чтобы скопировать классическую анимацию движения символа на панель «Действия» или использовать ее в другом проекте в качестве ActionScript, используйте команду «Копировать движение как ActionScript 3.0».

Создание наборов настроек замедления

Наборы настроек замедления — это предварительно настроенные замедления, которые можно применять к объектам в рабочей области.

Для классической анимации движения доступен ряд нескольких распространенных наборов настроек замедления. Можно выбрать набор настроек из списка и применить его к выбранному свойству.

  1. Щелкните слой, содержащий анимацию, на временной шкале Animate.

  2. Чтобы открыть свойства анимации, выберите категорию Анимация на панели «Свойство». Выбрать замедление с учетом свойств можно в раскрывающемся списке «Тип замедления».

    property-dropdown-ease
    Свойства анимации

    Можно применить к классической анимации наборы настроек замедления с учетом свойств. На панели «Свойства» предоставляется возможность выбрать замедление с учетом свойств. Установите этот флажок, если требуется применить разные наборы настроек замедления для каждого свойства. А если требуется применить одинаковое замедление ко всем свойствам анимации, выберите вариант Все свойства вместе, как показано на следующем снимке экрана.

  3. Выберите нужный стандартный набор настроек замедления из всплывающего окна «Тип замедления», затем нажмите Применить.

    Если применяется классическое замедление, можно также увеличить или уменьшить интенсивность замедления, переместив ползунок. 

    property-wise-presets
    Список наборов замедления
  4. Чтобы применить пользовательское замедление, щелкните значок «Изменить» рядом с элементом Замедление

Если используется тип документа HTML5 Canvas, можно оптимизировать выходной файл js для наборов настроек замедления. При создании выходных данных технология HTML5 Canvas использует функции замедления анимации JS. 

Применение пользовательского ускорения/замедления к классической анимации движения

Примечание.

Этот раздел посвящен добавлению замедления к старой классической анимации. Сведения о добавлении замедления к новой анимации движения см. в разделе «Замедление анимации движения».

Диалоговое окно «Заказное замедление/ускорение» выводит диаграмму, в которой дается графическое представление о скорости движения во времени. На горизонтальной оси показаны кадры, а на вертикальной — процент изменений. Первый ключевой кадр представлен как 0%, а последний ключевой кадр — как 100%.

Наклон кривой диаграммы показывает скорость изменений объекта. Если кривая горизонтальна (без наклона), то скорость равна нулю; если кривая вертикальна, то изменение происходит мгновенно.

Диаграмма пользовательского замедления и ускорения
Диаграмма «Заказное замедление/ускорение», на которой отображена постоянная скорость. Откройте это диалоговое окно, выбрав кадр в классической анимации движения и нажав кнопку «Изменить» в разделе «Замедление» в инспекторе свойств.

Сохранение пользовательского замедления

Можно сохранить пользовательское замедление, нажав соответствующую кнопку, а затем использовать его, выбрав в пользовательском списке. Нажмите кнопку «Сохранить и применить» в режиме редактирования после внесения изменений. На следующем снимке экрана пользовательский набор настроек замедления отображается под именем MyEase1

saving-custom-ease
Customized easing preset

Предварительно настроенное замедление можно использовать в нескольких диапазонах временной шкалы, выбрав соответствующие диапазоны и применив к ним замедление.

multi-span
Easing preset across multiple spans

Дополнительные элементы управления для диалогового окна «Пользовательское замедление и ускорение»

Использование флажка «Одна настройка для всех свойств»

По умолчанию установлен; отображаемая кривая используется для всех свойств, а всплывающее меню выключено. Если флажок снят, то всплывающее меню включено и каждое свойство имеет отдельную кривую, которая задает скорость изменения этого свойства.

Всплывающее меню «Свойства»

Включено только в том случае, если флажок «Использовать один параметр для всех свойств» не установлен. Если включено, то для каждого из пяти свойств, появляющихся в меню, имеется отдельная кривая. При выборе свойства в меню отображается кривая для этого свойства. Существуют следующие свойства.

Позиция

Указывает заказные настройки замедления для положения анимированного объекта в рабочей области.

Поворот

Задает заказные настройки замедления для поворота анимированного объекта. Например, можно настроить, насколько быстро или медленно анимированный символ вращается в рабочей области, прежде чем повернется к пользователю.

Масштаб

Задает заказные настройки замедления для масштаба анимированного объекта. Например, можно намного проще настроить масштаб объекта, чтобы он выглядел так, как будто он уходит от наблюдателя, затем приближается к наблюдателю, а затем снова уходит от наблюдателя.

Color

Задает заказные настройки замедления скорости изменения цвета, применяемых к анимированному объекту.

Фильтры

Задает заказные настройки замедления скорости изменения фильтров, применяемых к анимированному объекту. Например, можно управлять параметром замедления отбрасываемой тени, которая имитирует изменение направления источника света.

Кнопки воспроизведения и остановки

Позволяют выполнить предварительный просмотр анимации в рабочей области с помощью всех текущих кривых скорости, определенных в диалоговом окне «Заказное замедление/ускорение».

Кнопка сброса

Позволяет сбросить кривую скорости к линейному состоянию, которое является состоянием по умолчанию.

Положение выбранной опорной точки

Числовое значение в нижнем правом углу диалогового окна отображает ключевой кадр и положение выбранной опорной точки. Если опорная точка не выбрана, значение не появляется.

Чтобы добавить к линии опорную точку, щелкните мышью один раз диагональную линию. Чтобы более точно управлять движением объекта, перетащите позиции опорных точек.

Используя индикаторы кадра (представленных квадратными маркерами), нажмите область, где перемещение объекта должно быть замедлено или ускорено. При щелчке квадратного маркера управляющей точки эта опорная точка выделяется и отображаются точки касательных по обе стороны от нее. Точки касательных представлены полыми окружностями. Чтобы переместить опорную точку или точки ее касательных, перетащите их с помощью мыши или используйте клавиши со стрелками на клавиатуре.

Совет. По умолчанию опорная точка привязана к сетке. Привязку можно отключить, нажав клавишу X во время перетаскивания опорной точки.

Если щелкнуть мышью область кривой в месте, свободном от опорных точек, то в этом месте кривой будет добавлена новая управляющая точка, при этом форма кривой останется неизменной. Если щелкнуть мышью область вне кривой и управляющих точек, то с текущей выделенной опорной точки будет снято выделение.

Добавление пользовательского замедления

  1. Выберите на временной шкале слой, к которому применена классическая анимация движения.

  2. В инспекторе свойств нажмите кнопку «Изменить» рядом с ползунком «Замедление».
  3. (При необходимости) Чтобы отобразить кривую для отдельного свойства анимации движения, снимите флажок «Использовать один параметр для всех свойств» и выберите свойство в меню.
  4. Чтобы добавить опорную точку, щелкните мышью диагональную линию, удерживая нажатой клавишу «Ctrl» (Windows) или «Command» (Macintosh).
  5. Чтобы увеличить скорость объекта, перетащите опорную точку наверх, чтобы уменьшить скорость объекта, перетащите управляющую точку вниз.
  6. Для дальнейшей настройки кривой замедления и настройки значения ускорения tween-анимации перетащите маркеры вершин.
  7. Чтобы просмотреть анимацию в рабочей области, нажмите кнопку воспроизведения в левом нижнем углу.
  8. Выполняйте настройку до тех пор, пока не будет достигнут нужный эффект.

Примечание.

Если для пользовательского ускорения в кадре используется диалоговое окно «Пользовательское замедление и ускорение», то в окне редактирования, где отображаются значения ускорения, показывается '--'. Если для пользовательского замедления в кадре используется поле редактирования или всплывающий ползунок, то в диаграмме «Пользовательское замедление» устанавливается эквивалентная кривая и устанавливается флажок «Использовать один параметр для всех свойств».

Копирование и вставка кривой замедления

  • Чтобы скопировать текущую кривую замедления, нажмите клавиши «Ctrl» +«C» (Windows) или «Command» +«C» (Macintosh).

  • Чтобы вставить скопированную кривую замедления в другую кривую ускорения, нажмите клавиши «Ctrl» +«V» (Windows) или «Command» +«V» (Macintosh).

    Кривую замедления можно копировать и вставлять. Скопированная кривая остается доступной до выхода из приложения Animate.

Неподдерживаемые кривые ускорения

Некоторые типы кривых ускорения не поддерживаются. Никакая часть диаграммы не может представлять нелинейную кривую (такую как окружность).

Диалоговое окно «Заказное замедление» автоматически блокирует перемещение опорной точки или маркера касательной в положение, в котором кривая становится недопустимой.

  • Все точки должны существовать на диаграмме. Опорные точки нельзя переместить за границы диаграммы.

  • Все сегменты кривой должны существовать внутри диаграммы. Форма кривой уплощенная, что предотвращает выход кривой за границы диаграммы.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет