Цветовые модели используются для описания отображаемых в цифровой графике цветов, с которыми можно работать. Каждая цветовая модель, такая как RGB, HSB или CMYK, представляет отдельный метод описания и классификации цвета. В цветовых моделях используются числовые значения для представления видимых цветов спектра. Цветовое пространство является вариантом цветовой модели и характеризуется определенным охватом (диапазоном) цветов. Например, в цветовой модели RGB есть ряд цветовых пространств: Adobe® RGB, sRGB и Apple® RGB. В каждом из этих цветовых пространств цвет определяется с использованием одних и тех же трех осей (R, G и B), но предусмотренные в них цветовые охваты разные.

При работе с цветами изображения изменяются числовые значения, содержащиеся в файле. Однако слишком просто было бы представить цвета в виде чисел. Числовые значения сами по себе не являются абсолютными цветами — они всего лишь представляют цвета в цветовом пространстве устройства вывода.

Поскольку каждое устройство имеет собственное цветовое пространство, оно способно воспроизводить цвета только в своем цветовом охвате. При перемещении изображения с одного устройства на другое цвета изображения могут измениться, поскольку каждое устройство интерпретирует значения RGB или HSB в соответствии с собственным цветовым пространством. Например, невозможно, чтобы все цвета, отображаемые на мониторе, полностью соответствовали бы цветам, напечатанным с помощью настольного принтера. Принтер работает в цветовом пространстве CMYK, а монитор — в цветовом пространстве RGB. Их цветовые охваты разные. Некоторые цвета, воспроизводимые с помощью красок, не могут быть отображены на мониторе, а некоторые цвета, отображаемые на мониторе, не могут быть воспроизведены с помощью красок на бумаге.

При создании цветов для документов Animate помните, что, даже несмотря на то, что добиться одинаковой передачи цвета всеми устройствами невозможно, можно добиться хороших результатов, если принимать во внимание графические возможности устройств, которыми будут пользоваться ваши зрители.

Adobe Animate СС позволяет применять, создавать и модифицировать цвета с помощью цветовых моделей RGB или HSB. С помощью палитры по умолчанию или созданной пользователем палитры можно выбирать цвета, которые применяются к обводке или заливке создаваемого или уже созданного объекта.

Применяя цвет обводки к фигуре, можно выполнить одно из следующих действий.

  • Применить сплошной тон, градиент или растровое изображение к заливке фигуры. Чтобы применить растровую заливку к фигуре, необходимо импортировать растровое изображение в текущий файл. Выбрать любой сплошной тон, градиент, стиль и толщину обводки.

  • Создать контур фигуры без заливки, используя значение параметра заливки «Нет цвета».

  • Создать фигуру с заливкой без контура, используя значение параметра обводки «Нет цвета».

  • Применить сплошной тон заливки к тексту.

С помощью панели «Цвет» можно создавать и редактировать сплошные тона и заливки градиентом в режимах RGB и HSB.

Для получения доступа к палитре цветов системы выберите значок палитры цветов  в элементе управления «Цвет обводки» или «Цвет заливки» на панели «Цвет», панели «Инструменты» или в инспекторе свойств фигуры.

Панель «Цвет»

Панель «Цвета» позволяет модифицировать цветовую палитру FLA, а также цвет обводки и заливки, включая следующие действия:

  • импорт, экспорт, удаление или другие изменения цветовой палитры для FLA-файла с помощью панели «Образцы».

  • выбирать цвета в шестнадцатеричном формате.

  • создавать многоцветные градиенты.

  • использовать градиенты, чтобы сформировать широкий диапазон эффектов, например эффект глубины двумерного объекта.

Панель «Цвет» содержит следующие элементы управления:

Цвет обводки

Изменяет цвет обводки или границы графического объекта.

Цвет заливки

Изменяет цвет заливки. Заливка — это область цвета, который заполняет фигуру.

Меню «Тип цвета»

Изменяет стиль заливки:

Не задано

Удаляет заливку.

Чистый цвет

Обеспечивает сплошной единый цвет заливки.

Линейный градиент

Создает градиент, который линейно изменяется вдоль контура.

Радиальный градиент

Создает градиент, который меняется от центральной фокальной точки в круговом контуре к краям.

Растровая заливка

Заполняет выбранную область заливки мозаикой из растрового изображения, которое можно выбрать. Если выбрать «Растровое изображение», диалоговое окно позволит выбрать растровое изображение на локальном компьютере и добавить его в библиотеку. Можно применить растровое изображение в качестве заливки; внешний вид похож на мозаику, в которой изображение повторяется внутри фигуры.

HSB

Позволяет изменить цветовой тон, насыщенность и яркость цвета заливки.

RGB

Позволяет изменить плотность красного, зеленого и синего (RGB) цветов в заливке.

Альфа-канал

Устанавливает прозрачность для сплошной заливки или устанавливает текущий выбранный ползунок для заливки градиентом. Значение альфа-канала, равное 0%, задает невидимую (прозрачную) заливку. Значение альфа-канала, равное 100%, задает непрозрачную заливку.

Текущий образец цвета

Отображает текущий выбранный цвет. Если в меню «Тип заливки» выбрать тип заливки градиентом (линейный или радиальный), то текущий образец цвета отображает переходы цвета внутри создаваемого градиента.

Системная палитра цветов

Позволяет визуально выбрать цвет. Щелкните системную палитру цветов и перемещайте указатель-перекрестие до тех пор, пока не найдется необходимый цвет.

Шестнадцатеричное значение

Отображает шестнадцатеричное значение текущего цвета. Чтобы изменить цвет с помощью шестнадцатеричного значения, введите новое значение. Шестнадцатеричные значения цвета — это шестизначные буквенно-цифровые сочетания, которые представляют цвет.

Нажим

Позволяет управлять цветами, которые применяются за пределами линейного или радиального градиента.

Расширить цвет

Применяет указанные цвета до конца градиента (по умолчанию).

Отразить цвет

Вызывает заливку фигуры цветами градиента с применением отражающего зеркального эффекта. Указанные градиенты повторяются в образце с начала и до конца градиента, а потом повторяются в противоположной последовательности от конца градиента к его началу, а потом снова повторяются от начала градиента к его концу до тех пор, пока выбранная фигура не будет заполнена.

Повторить цвет

Повторяет градиент от начала градиента к концу до тех пор, пока выбранная фигура не заполнится.

Примечание. Режимы переполнения поддерживаются только в Adobe Flash Player 8 и более поздней версии.

Линейный RGB

Создает SVG-совместимый (SVG — формат масштабируемой векторной графики) линейный или радиальный градиент.

Палитра «Образцы»

С помощью образцов можно без труда повторно использовать и обновлять цвета во всем документе. Теперь можно создавать образцы с тегами, выбирая цвет из своей коллекции образцов. Когда вы создаете образец с тегами и применяете его к фигурам и контурам в содержимом Animate, то при изменении цвета в образце с тегами автоматически обновится все содержимое, для которого этот образец используется.  

  1. Выберите пункт Окно > Цвет.

  2. На вкладке Образцы панели Цвета выберите цвет, который требуется преобразовать в образец с тегами, затем нажмите кнопку Преобразовать в образец с тегами в нижней части панели.

  3. В диалоговом окне Определение цвета с тегами задайте следующие параметры:

    • Имя нового образца
    • Тип образцы: сплошной цвет, линейный градиент или радиальный градиент
    • Цвет в виде значения HSB (цветовой тон, насыщенность и яркость) или RGB (красный, зеленый и синий)
    Диалоговое окно «Определение цвета с тегами»

    Новый образец с тегами отображается на вкладках Цвета и Образцы панели Цвета и на панели Инструменты.

    Вновь созданный образец с тегами на панелях «Цвета», «Образцы» и «Инструменты»

  4. Когда вы открываете панель «Цвет» после выбора объекта, который использует образец с тегами, отображаются параметры для редактирования свойств цвета. Если вы вносите изменения в свойства цвета, они автоматически отражаются во всех элементах на рабочей области, которые используют образец с тегами.

  5. Дважды щелкните образец или выделите его и нажмите кнопку Изменить, чтобы открыть диалоговое окно Определение цвета с тегами и внести изменения в цвет образца.

  6. Чтобы отвязать фигуру, использующую образец, от цвета образца, выберите ее, а затем нажмите кнопку Отменить связь. Для фигуры можно выбрать новый цвет в палитре цветов.

    Параметр «Отменить связь»

    Выбор другого цвета в палитре цветов для фигуры

Цветовые палитры

Каждый файл Animate CC содержит свою собственную цветовую палитру, хранимую в документе Animate. Animate CC отображает палитру файла в виде цветовых образцов в элементах «Цвет заливки» и «Цвет обводки» и на панели «Образцы». Палитра цветов по умолчанию — это палитра, состоящая из 216 безопасных цветов Web. Для добавления цветов в текущую цветовую палитру используйте панель «Цвет». Также возможен импорт и экспорт как сплошной, так и градиентной цветовой палитры между файлами Animate, а также между Animate CC и другими приложениями.

Палитра по умолчанию и палитра веб-совместимых цветов

Сохраните текущую палитру в качестве палитры по умолчанию, замените текущую палитру палитрой по умолчанию, определенной для файла, или загрузите палитру безопасных цветов Web, чтобы заменить текущую палитру.

  • Чтобы загрузить или сохранить палитру по умолчанию, на панели «Образцы» выберите в меню в правом верхнем углу одну из следующих команд.

    Загрузить цвета по умолчанию:

    Замещает текущую палитру палитрой по умолчанию.

    Сохранить как значение по умолчанию:

    Сохраняет текущую палитру цветов в качестве палитры по умолчанию. При создании новых файлов используется новая палитра по умолчанию.

  • Чтобы сохранить палитру из 216 веб-совместимых цветов, на панели «Образцы» в меню в верхнем правом углу выберите «Веб 216»..
  1. На панели «Образцы» выберите в меню в правом верхнем углу «Сортировать по цвету».

Организация и повторное использование цветов

На панели «Образцы» предусмотрена организация цветов в иерархическую структуру при помощи папок и цветовых палитр.

Создание папки

По умолчанию все цвета располагаются в папке «Образцы по умолчанию». Существующие цвета можно перемещать между папками на панели «Образцы». Для создания новой папки выполните следующие действия:

  1. В Animate CC выберите Окно > Образцы.

  2. На панели «Образцы» нажмите кнопку .
  3. Введите описательное имя для папки цветовых образцов.

Кроме того, папку можно создать, выбрав какую-либо папку, цветовую палитру или образец и щелкнув пункт «Дублировать в виде папки» из контекстного меню.

Создание цветовой палитры (группы образцов)

Цветовая палитра — это группа цветовых образцов, характеризующая цветовое решение вашего содержимого. Цветовые палитры можно создавать внутри папок и добавлять в них образцы. Для создания цветовой палитры выполните следующие действия:

  1. В Animate CC выберите Окно > Образцы.

  2. На панели «Образцы» выберите любую папку и нажмите кнопку для создания пустой палитры.
  3. В эту цветовую палитру можно перетащить существующие образцы или добавить новые с помощью кнопки .

Кроме того, цветовую палитру можно создать, выбрав какую-либо папку, цветовую палитру или образец и щелкнув пункт «Дублировать в виде палитры» из контекстного меню.

Создание или добавление цветов в цветовую палитру

Для цветовой палитры можно создать новые образцы или добавить существующие. Для создания образца выполните следующие действия:

  1. В Animate CC выберите «Окно» > «Образцы».

  2. На панели «Образцы» выберите любую цветовую палитру в одной из папок и нажмите кнопку для создания цветового образца. Новый образец будет соответствовать цвету заливки, выбранному на данный момент на панели «Цвет». Также можно выбрать существующий образец и нажать кнопку для дублирования этого образца внутри данной палитры.

Кроме того, образец можно создать, выбрав какую-либо папку, цветовую палитру или образец и щелкнув пункт Дублировать в виде образца из контекстного меню.

  1. На панели «Образцы» выберите в меню в правом верхнем углу одну из следующих команд:
    • Чтобы добавить импортируемые цвета в текущую палитру, выберите «Добавить цвета».

    • Чтобы заменить текущую палитру импортируемыми цветами, выберите «Заменить цвета».

  2. Перейдите к нужному файлу, выберите его и нажмите «ОК».
  1. На панели «Образцы» выберите в меню в правом верхнем углу «Сохранить цвета» и введите имя цветовой палитры.
  2. Для параметра «Сохранить как» (Windows) или «Format» (Macintosh) выберите значение «Палитра Animate» или «Таблица цветов». Нажмите кнопку «Сохранить».

Создание и изменение сплошного цвета

С помощью панели «Цвет» можно создать любой цвет. Если в рабочей области выбран объект, то изменения цвета, сделанные на панели «Цвет», будут применены к выделению. Можно выбрать цвета в режимах RGB или HSB либо расширить панель и использовать шестнадцатеричный режим. Можно также указать альфа-значение, чтобы определить степень прозрачности цвета. Кроме того, можно выбрать цвет в существующей палитре цветов.

Панель «Цвет» можно развернуть, так что на ней будут отображаться большее цветовое пространство на месте цветовой шкалы, отдельный образец цвета, показывающий текущий и предыдущие цвета, и ползунок «Яркость», позволяющий модифицировать яркость цвета во всех цветовых режимах.

  1. Чтобы применить цвет к существующей иллюстрации, выберите объект в рабочей области и выберите пункт «Окно» > «Цвет».

  2. Щелкните значок «Обводка» или «Заливка», чтобы указать, какой атрибут необходимо модифицировать.

    Примечание.

    Щелкните значок, а не элемент цвета, иначе откроется палитра цветов.

  3. Если на шаге 3 был выбран значок «Заливка», проверьте, что в меню «Тип» выбрано значение «Сплошная».

  4. Если в рабочей области выбран объект, то изменения цвета, сделанные на панели «Цвет», будут применены к выделению. Выполните одно из следующих действий.

    • Чтобы выбрать цвет, щелкните мышью цветовое пространство на панели «Цвет». Чтобы настроить яркость цветов, перетащите ползунок «Яркость».

      Примечание. Чтобы создать цвет, отличный от черного или белого, убедитесь, что ползунок «Яркость» не установлен в какое-либо из крайних положений.

    • Введите значения в поля значений цветов: значения красного, зеленого и синего канала для отображения RGB, значения цветового тона, насыщенности и яркости для отображения HSB либо шестнадцатеричные значения для шестнадцатеричного отображения. Введите значение альфа-канала, чтобы указать степень прозрачности: от 0 для полной прозрачности до 100 для полной непрозрачности.

    • Для возвращения параметров цвета по умолчанию (черная обводка и белая заливка) нажмите на кнопку «Черно-белый» .

    • Чтобы поменять местами цвета обводки и заливки, нажмите кнопку «Поменять местами цвета» .

    • Чтобы не применять цвет к обводке или заливке, нажмите кнопку «Нет цвета» .

      Примечание. Невозможно применить настройку заливки или обводки «Нет цвета» к существующему объекту. Вместо этого выберите существующую обводку или заливку и удалите ее.

    • Нажмите элемент «Цвет обводки» или «Цвет заливки» и выберите цвет.

  5. Чтобы добавить новый цвет к списку образцов цвета для текущего документа, выберите в меню в правом верхнем углу «Добавить образец».

Дублирование, удаление и очистка цветов

Дублирование цветов в палитре, удаление отдельных цветов и очистка всех цветов в палитре.

  • Чтобы дублировать или удалить цвет, выберите пункт «Окно» > «Образцы», щелкните дублируемый или удаляемый цвет и в меню панели выберите пункт «Дублировать образец» или «Удалить образец». При дублировании образца появляется символ заливки. Щелкните мышью пустую область панели «Образцы» символом заливки, чтобы сделать копию выбранного цвета.

  • Чтобы удалить все цвета на цветовой палитре, на панели «Образцы» выберите «Удалить цвета» в меню панели. Все цвета, кроме черного и белого, будут удалены из палитры.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет