Команды «Отменить», «Повторить» и панель «История»

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

Команды «Отменить», «Вернуть» и «Повторить»

Чтобы отмена и восстановление действий выполнялись над отдельными объектами или над всеми объектами в документе, для команд «Отменить» и «Вернуть» (меню «Правка» > «Отменить» или «Правка» > «Вернуть») можно задать уровень объекта или уровень документа. По умолчанию для этих команд назначен уровень документа.

Чтобы выбрать параметры отмены на уровне объекта или документа, выполните следующие действия.

  1. В Animate CC выберите «Правка» > «Установки».
  2. На вкладке «Общие» выберите «Отмена на уровне объекта» в раскрывающемся меню «Отмена».

Примечание. Если для команды «Отменить» задан уровень объекта, то некоторые действия отменить нельзя. Эти действия включают вход в режим редактирования и выход из него, выделение, редактирование и перемещение элементов библиотеки, а также создание, удаление и перемещение монтажных кадров.

Чтобы повторно применить действие к тому же или другому объекту, выберите команду «Повторить». Например, при перемещении фигуры с именем фигура_A выберите меню «Правка» > «Повторить», чтобы еще раз переместить эту фигуру, либо выделите другую фигуру, с именем фигура_B и выберите команду «Правка» > «Повторить», чтобы переместить эту фигуру.

По умолчанию программа Animate поддерживает для команды «Отменить» 100 операций. Задать число операций отмены и восстановления (от 2 до 300) можно в установках Animate.

По умолчанию при отмене шага через меню «Правка» > «Отменить» или на панели «Журнал» размер файла документа не изменяется даже после удаления элементов из документа. Например, если в документ импортируется видеофайл, а затем импорт отменяется, то размер файла все равно останется большим. Все элементы, удаляемые из документа по команде «Отменить», сохраняются в документе, давая возможность восстановить их командой «Вернуть».

Использование панели «Журнал»

На панели «Журнал» (меню Окно > Журнал) представлен список шагов, которые выполнялись в активном документе с момента его создания или открытия, указанное в настройках число операций. (Панель «Журнал» не отражает операции, выполненные в других документах.) По умолчанию ползунок на панели «Журнал» установлен на последнюю выполненную операцию.

  • Панель «Журнал» позволяет отменить или восстановить отдельный шаг (или несколько шагов). Шаги на панели «Журнал» применяются к тому же объекту или другим объектам документа. Порядок очередности шагов на панели «Журнал» нельзя изменить. Они заносятся в журнал в порядке их выполнения.

    Примечание. Если отменить один шаг или последовательность шагов, а затем выполнить в разделе новую операцию, то отмененные шаги нельзя будет восстановить, они исчезают из списка панели «Журнал».

  • По умолчанию программа Animate поддерживает на панели «Журнал» 100 операций. Задать число операций отмены и восстановления (от 2 до 300) можно в установках Animate.

  • Чтобы стереть список шагов для текущего документа, очистите панель «Журнал». После этого отменить очищенные шаги будет нельзя. Очистка списка шагов означает отмены шагов. Они просто удаляются из памяти текущего документа.

При закрытии документа список шагов очищается. Чтобы выполненные шаги были доступны после закрытия документа, скопируйте их командой «Копировать шаги» или сохраните в виде команды.

Отмена шагов с помощью панели «Журнал»

При отмене шага он затеняется на панели «Журнал».

  • Чтобы отменить последний выполненный шаг, перетащите ползунок на панели «Журнал» вверх на один шаг.

  • Чтобы одновременно отменить несколько шагов, перетащите ползунок на нужный шаг или щелкните мышью слева от нужного шага рядом с ползунком. Ползунок автоматически смещается на этот шаг, отменяя все последующие шаги по мере прокрутки.

Примечание. Прокрутка до определенного шага (и выделение последующих шагов) — не то же самое, что выбор отдельного шага. Чтобы выполнить прокрутку до определенного шага, щелкните мышью слева от него.

Воспроизведение шагов с помощью панели «Журнал»

При воспроизведении шагов с помощью панели «Журнал» воспроизводятся шаги, выделенные (подсвеченные) на панели «Журнал». Это не обязательно тот шаг, на который указывает ползунок.

Шаги на панели «Журнал» применяются ко всем выделенным объектам в документе.

Воспроизведение одного шага

  1. Выделите шаг на панели «Журнал» и нажмите кнопку «Повтор».

Повторение последовательности смежных шагов

  1. Выделите шаги на панели «Журнал», выполнив одно из следующих действий.
    • Перетащите мышью от одного шага до другого. (Не перетаскивайте ползунок, перетащите текстовую метку одного шага до текстовой метки другого шага.)

    • Выделите первый шаг и, удерживая нажатой клавишу «Shift», нажмите последний шаг. Или выделите последний шаг и, удерживая нажатой клавишу «Shift», нажмите первый шаг.

  2. Нажмите кнопку «Повтор». Шаги воспроизводятся в том порядке, в каком они выполнялись, а на панели «Журнал» появляется новый шаг под названием «Воспроизвести шаги».

Воспроизведение несмежных шагов

  1. Выделите шаг на панели «Журнал», а затем нажмите другие шаги, удерживая нажатой клавишу «Control» (Windows) или «Command» (Macintosh). Чтобы отменить выделение шага, щелкните его еще раз, удерживая нажатой клавишу «Control» (Windows) или «Command» (Macintosh).
  2. Нажмите кнопку «Повтор».

Перенос шагов из одного документа в другой

Каждый открытый документ содержит собственный список шагов. Копирование шагов из одного документа и их вставка в другой производится по команде «Копировать шаги» в меню панели «Журнал». При копировании шагов в текстовый редактор шаги вставляются в виде кода JavaScript™.

  1. Выделите нужные шаги в соответствующем документе на панели «Журнал».
  2. В меню панели «Журнал» выберите команду «Копировать шаги».
  3. Откройте документ, в который должны быть вставлены шаги.
  4. Выделите объект, к которому они должны быть применены.
  5. Чтобы вставить шаги, выберите меню «Правка» > «Вставка». При вставке в панель «Журнал» эти шаги воспроизводятся. На панели «Журнал» они отображаются в виде одного шага с именем «Вставить шаги».
Логотип Adobe

Вход в учетную запись