Экспорт изображений и графики

Последовательность PNG

Можно экспортировать последовательность файлов изображений из отдельного клипа, кнопки или графического символа в библиотеке или рабочей области. В процессе экспорта Animate CC (ранее Flash Professional CC) создаст отдельный файл изображения для каждого кадра символа. Если выполняется экспорт из рабочей области, любые преобразования (например, масштабирование), примененные к экземпляру символа, сохраняются в выводе изображения.

Чтобы экспортировать последовательность PNG, выполните следующие действия.

  1. Выберите отдельный ролик, кнопку, графический символ в библиотеке или в рабочей области.

  2. Щелкните выбранный объект правой кнопкой мыши и выберите Экспортировать последовательность PNG.

    select-png-sequence
  3. В диалоговом окне «Сохранить как» выберите, куда следует поместить результат экспорта, и нажмите кнопку ОК.

     

  4. В диалоговом окне Экспортировать последовательность PNG задайте необходимые параметры.

    export-pngsequence

    Ширина — ширина выходного изображения. Изменение этого параметра приведет к масштабированию выходного изображения. Значение по умолчанию соответствует ширине символьного содержимого.

    Высота — высота выходного изображения. Изменение этого параметра приведет к масштабированию выходного изображения. Значение по умолчанию соответствует высоте символьного содержимого.

    Разрешение — разрешение выходного изображения. Значение по умолчанию равно 72 точкам/дюйм.

    Цвета — глубина цвета в битах для выходного изображения. Для этого параметра доступны значения 8, 24 или 32 бита. Значение по умолчанию — 32 бита, что обеспечивает поддержку прозрачности. При выборе значения 24 бита или 8 бит, при которых не поддерживается прозрачность, параметр «Фон» принимает значение «Рабочая область». См. ниже.

    Фон — цвет фона, используемый в выходном изображении. Данная настройка доступна только в том случае, если параметр «Цвет» имеет значение 8 или 24 бита. Если выбран 32-битный цвет, фон изображения всегда будет прозрачным. Если выбран 8- или 24-битный цвет, параметр «Фон» по умолчанию устанавливается равным цвету рабочей области. Для 8- или 24-битных изображений можно изменить настройку на «Непрозрачный» и затем выбрать цвет фона на палитре цветов. Также можно выбрать значение альфа-канала в качестве фона, чтобы создать прозрачность.

    Сглаживание — этот параметр определяет, будет ли использоваться сглаживание краев объектов выходного изображения. Отключите этот параметр, если не используется прозрачный фон и изображения могут размещаться на фоне, цвет которого отличен от текущего цвета рабочей области.

  5. Нажмите кнопку Экспорт, чтобы экспортировать последовательность изображений PNG.

Экспорт анимированного GIF-файла

В Animate можно экспортировать анимированные GIF-файлы, выполнив следующие действия. 

  1. Выберите Файл > Экспорт > Экспортировать анимированный GIF.

    Откроется диалоговое окно. 

    export-animated-gif
  2. В это окне выберите необходимые параметры и нажмите кнопку Готово, чтобы экспортировать анимацию в виде анимированного GIF-файла. 

    animated-gif-dialog

    Можно также экспортировать статичное изображение в формате GIF, выбрав Файл > Экспорт > Экспорт изображения.

Экспорт изображений и графики в библиотеку CC Library

Чтобы экспортировать изображения и графические объекты в библиотеку CC Library, выберите Окно > CC Library

Откроется окно CC Libraries. 

add-to-cc-library

Щелкните значок + в нижнем левом углу окна CC Libraries, выберите изображения или графические файлы и нажмите кнопку Добавить.

Графический формат FXG (не используется в Animate CC)

Сведения о FXG-файлах

Формат FXG — это графический формат обмена файлами для платформы Animate/Flash. Формат FXG основан на подмножестве MXML — языка программирования на основе XML, используемого платформой Flex. Формат FXG обеспечивает более эффективную совместную работу дизайнеров и разработчиков, помогая им надежный способ обмена графическим содержимым. Дизайнер может создавать графику в средствах разработки Adobe, а затем экспортировать ее в формат FXG. После этого FXG-файл может быть открыт в программе Adobe Flash Builder или Adobe Flash Catalyst и использован для разработки веб-интерфейсов и приложений.

При создании FXG-файла векторная графика сохраняется в этом файле. Элементы, для которых нет соответствующего тега в FXG, экспортируются в виде растровых изображений и ссылок на них в FXG-файле. В число этих объектов входят растровые изображения, некоторые фильтры и режимы наложения, градиенты, маски и 3D. Некоторые из этих эффектов можно экспортировать в формате FXG, но нельзя импортировать в приложение, которое открывает FXG-файлы.

При экспорте FXG-файла, содержащего векторные и битовые изображения, вместе с FXG-файлом создается отдельная папка. Эта папка носит имя <имя_файла.assets> и содержит битовые изображения, связанные с данным FXG-файлом.

Дополнительные сведения о формате FXG-файла см. в разделе Спецификации FXG 2.0.

Ограничения на экспорт в формате FXG

Animate позволяет экспортировать один или несколько выбранных объектов в рабочей области в формате FXG. При экспорте в формат FXG названия слоев и объектов сохраняются.

При сохранении FXG-файла действуют следующие ограничения.

  • Сетки Scale-9: экспортируются, но могут быть считаны только в Adobe Illustrator.

  • Звук и видео: не экспортируются.

  • Компоненты: не экспортируются.

  • Анимация (включая анимацию из множества кадров): не экспортируется; экспортируется только выбранный кадр в качестве статического объекта.

  • Внедренные шрифты: не экспортируются.

  • Символы кнопок: Animate экспортирует только состояние «Не нажата».

  • Свойства 3D-объектов: не экспортируются.

  • Свойства обратной кинематики: не экспортируются.

  • Атрибуты текста: экспорт некоторых атрибутов может оказаться невозможен.

Экспорт содержимого Animate в формат FXG

Экспорт содержимого Animate в формат FXG можно осуществить двумя способами.

  • Чтобы экспортировать объекты в рабочей области в формате FXG, выделите объекты и выберите Экспорт > Экспортировать выделение, а затем выберите формат FXG в меню Тип файла.

  • Чтобы сохранить всю рабочую область в формате FXG, выберите Экспорт > Экспорт изображения и выберите пункт Adobe FXG в меню Тип файла.

Последовательность JPEG и изображение JPEG

Эти параметры соответствуют Параметрам публикации JPEG. Однако параметр По размеру экрана подгоняет размер экспортированного изображения под размер содержимого Animate, отображающегося на экране. Параметр Как в ролике согласует JPEG-изображение с содержимым Animate и сохраняет пропорции исходного изображения.

Последовательность PNG и изображение PNG

Параметры экспорта в формат PNG аналогичны параметрам публикации PNG (которые также можно применять) со следующими исключениями.

Размеры

Устанавливает размер экспортированного растрового изображения равным числу пикселей, введенных в поля Ширина и Высота.

Разрешение

Вводится разрешение «dpi» (точки на дюйм). Чтобы использовать разрешение экрана и сохранить пропорции исходного изображения, выберите параметр По размеру экрана.

Цвета

Соответствует параметру Глубина в битах во вкладке Параметры публикации PNG. Позволяет задать количество битов на пиксель при создании изображения. Для 256-цветного изображения выберите величину 8 бит; для тысяч цветов выберите 24 бит на канал; для тысяч цветов с прозрачностью (32 бит на канал) выберите 24 бит на канал с альфа-каналом. Чем лучше качество цветопередачи, тем больше файл.

Включить

Устанавливается для экспорта наименьшей области изображения или документа в полном размере.

Примечание.

Размеры экспортированного GIF-изображения не могут превышать 4000 пикселей. Это ограничение размеров действует для CS6 и более поздних версий.

Примечание.

Функция «Дизеринг чистых цветов» не работает, если выбрана опция «256 цветов». Таким образом, GIF-рисунок не подвергается дизерингу, если для него выбрана цветовая схема 256 цветов.

(Не поддерживается в Animate CC) Растровое изображение BMP

Создание растровых изображений для использования в других приложениях. В диалоговом окне Экспорт растрового изображения есть следующие параметры.

Размеры

Задает размер экспортированного растрового изображения в пикселях. Пропорции сторон всегда такие же, как у исходного изображения.

Разрешение

Задает разрешение экспортированного растрового изображения в «dpi» (точках на дюйм) и автоматически вычисляет ширину и высоту на основе размера рисунка. Чтобы задать разрешение в соответствии с характеристиками монитора, выберите режим По размеру экрана.

Глубина цвета

Задает качество цветопередачи в битах. Некоторые приложения Windows не поддерживают новое качество цветопередачи 32 бита на канал для растровых изображений. Если при применении формата 32 бита на канал возникают проблемы, используйте формат 24 бита на канал.

Смягчение

Применяет сглаживание к экспортированному растровому изображению. Сглаживание повышает качество растровых изображений, но может привести к появлению ореола серых пикселей вокруг изображения, помещенного на цветном фоне. Отмените сглаживание, если появляется ореол.

Документ Animate (SWF)

Чтобы поместить содержимое Animate в другое приложение, такое как Dreamweaver, экспортируйте документ целиком как SWF-файл. Animate экспортирует SWF-файл, используя текущие параметры на вкладке Настройки публикации в параметрах публикации FLA-файла.

Экспортирование HD-видео с помощью Adobe Media Encoder

Animate позволяет экспортировать анимации движения, символы и графику в HD-видео различных форматов. HD-видео, экспортированное с помощью Animate можно использовать в приложениях с поддержкой стандартов Communications для видеоконференций, потоковой передачи и общего доступа.

По умолчанию Animate может экспортировать файлы только в формате QuickTime Movie (.MOV). Для работы функции экспорта необходимо установить последнюю версию QuickTime Player, так как Animate использует библиотеки QuickTime при экспорте в MOV-файлы.

Рабочий процесс экспорта HD-видео изменен, так как теперь компонент Animate интегрирован в Adobe Media Encoder. Он позволяет конвертировать MOV-файлы в различные другие форматы. В связи с этим компонент Adobe Media Encoder оптимизирован и представляет список только тех форматов экспорта, которые релевантны для содержимого Animate. Дополнительные сведения о кодировке и экспорте видео с помощью Adobe Media Encoder см. в разделе Кодировка и экспорт видео и аудио.

Примечание.

Adobe Media Encoder автоматически устанавливается при установке Animate CC из компьютерного приложения Creative Cloud.

Различия между прежним и новым рабочими процессами экспорта видео

Новый рабочий процесс отличается от процесса экспорта видео во CS6 и более ранних версий.

Ниже перечислены основные различия:

  • Интеграция с Adobe Media Encoder: продукт Animate CC интегрирован с Adobe Media Encoder 7.0, а более ранние версии не зависели от использования AME.
  • Форматы экспорта: Animate CC может экспортировать только фильмы в формате QuickTime.
  • HD-видео. Animate CC имеет возможность экспорта HD-видео.

Кроме того, рабочий процесс CS6 сопряжен со следующими проблемами:

  • Рабочий процесс экспортирования в файл MOV с помощью QuickTime был подвержен ошибкам и потреблял много памяти.
  • При экспорте в AVI не поддерживались видеоролики.

В Animate CC перечисленные выше проблемы исправлены, в том числе потеря кадров. Используя рабочий процесс Adobe Media Encoder, можно экспортировать содержимое в файлы MOV Animate СС без каких-либо затруднений. Новый рабочий процесс на основе AME дает возможность экспортировать содержимое Animate только в файлы MOV, которые затем с помощью AME можно преобразовать в любой желаемый выходной формат.

Экспорт начинается с кадра № 2.

В зависимости от структуры временной шкалы экспорт видео может выполняться по одному из следующих сценариев:

  1. Если на корневой временной шкале содержится более одного кадра, экспорт начинается с кадра № 2.
  2. Если на корневой временной шкале содержится только один кадр, экспорт будет включать кадр № 1.
  3. Если имеется более одного кадра на корневой временной шкале, при этом код ActionScript или звук добавлен к первому кадру, этот код или звук не сможет быть вызван после экспорта.

Экспорт HD-видео

Перед началом экспорта выполните следующие действия.

  • Установите QuickTime.
  • Задайте частоту кадров, которая меньше или равна 60 кадр/сек. Дополнительные сведения см. в разделе Основы анимации.
  1. Создайте или откройте существующий FLA-файл.

  2. Выберите Файл > Экспорт > Экспортировать видео.

    export-video
    Диалоговое окно «Экспорт видео»

  3. В диалоговом окне Экспорт видео в качестве параметров Ширина рендеринга и Высота рендеринга используются значения ширины и высоты, заданные в качестве размера рабочей области.

  4. В диалоговом окне «Экспорт видео» настройте требуемые параметры.

    • Размер после рендеринга В и Ш: настройте размер рендеринга в соответствии с разрешением, в котором требуется экспортировать документ, выбрав нужное качество (HD-видео или обычное видео). Задайте значения, равные ширине и высоте рабочей области соответственно. Если требуется изменить значения Ширина рендеринга и Высота рендеринга, соответствующим образом измените размеры рабочей области. Animate сохраняет соотношение сторон в соответствии с размерами рабочей области.
    • Игнорировать цвет рабочей области (создать альфа-канал): создается альфа-канал с использованием цвета рабочей области. Альфа-канал кодируется в виде прозрачной дорожки. Она позволяет наложить экспортированный ролик QuickTime поверх другого содержимого для изменения фонового цвета или кадра.
    • Преобразовать видео в Adobe Media Encoder: установите этот флажок, если требуется преобразовать экспортированный MOV-файл в другой формат с помощью AME. Если он установлен, AME запускается после того, как Animate завершает экспорт видео.
    • Путь к экспортированному видео: введите или укажите путь к папке, в которую требуется экспортировать видео.
    • Остановить экспорт: укажите, когда программа Animate должна остановить экспорт.
      • Когда достигнут последний кадр: выберите этот вариант, если требуется остановить экспорт на последнем кадре.
    Остановить экспорт когда достигнут последний кадр
    Остановить экспорт когда достигнут последний кадр
    • Остановить экспорт: укажите, когда программа Animate должна остановить экспорт.
      • По истечении: выберите этот вариант и укажите промежуток времени, по истечении которого экспорт должен быть остановлен. Этот вариант позволяет экспортировать видео по частям.
    Остановить экспорт через 1 минуту 15 секунд
    Остановить экспорт через 1 минуту 15 секунд
    Остановить экспорт через 3 секунды
    Остановить экспорт через 3 секунды

  5. Нажмите кнопку Экспортировать. Если установлен флажок Преобразовать видео в Adobe Media Encoder, AME запускается и экспортированный MOV-файл появляется в новой очереди. Дополнительные сведения о кодировке и преобразовании видео с помощью AME см. в разделе Кодировка и экспорт видео и аудио.


Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет