Создание и упорядочивание слоев

Слои позволяют упорядочить графические объекты в документе. Рисование и редактирование объектов в одном слое не влияет на объекты, находящиеся в другом слое. Сквозь участки рабочей области, где на слое ничего нет, виден нижележащий слой.

Чтобы рисовать, закрашивать или другим образом изменять слой или папку слоев, его необходимо выделить на временной шкале, сделав активным. Значок карандаша рядом со слоем или именем папки на временной шкале указывает, что этот слой или папка слоев активны. Одновременно может быть активным только один слой (хотя выделено может быть несколько слоев).

При создании документ Animate CC (прежнее название — Flash Professional CC) содержит только один слой. Для упорядочивания изображений, анимации и других элементов в документе добавляются новые слои. Слои могут быть скрыты, блокированы и переупорядочены. Число создаваемых слоев ограничивается лишь памятью компьютера, и не влияет на размер публикуемого SWF-файла. Размер файла увеличивается только за счет объектов, добавляемых к слоям.

Для упорядочивания и упрощения работы со слоями создаются папки слоев. Папки слоев на временной шкале могут разворачиваться или сворачиваться, не влияя на отображение в рабочей области. Для звуковых файлов, кода ActionScript, меток кадров и комментариев к кадрам используются отдельные слои или папки. Использование отдельных слоев помогает быстро найти нужный элемент для редактирования.

Для поддержки создания сложных эффектов применяются специальные направляющие слои, которые упрощают рисование и редактирование, а также создание маскирующих слоев.

Animate позволяет использовать пять типов слоев:

  • Обычные слои содержат самую большую часть графики в FLA-файле.

  • Маскирующие слои: они содержат объекты, используемые в качестве масок для скрытия отдельных областей нижних слоев. Дополнительные сведения см. в разделе Использование маскирующих слоев.

  • Маскируемые слои: эти слои лежат под маскирующим слоем и ассоциируются с этим маскирующим слоем. Видна только та часть слоя, которая не покрыта маской. Дополнительные сведения см. в разделе Использование маскирующих слоев.

  • Направляющие слои содержат обводки, которые можно использовать для правильного расположения объектов на других слоях. Также их можно использовать для задания движения при классической анимации на других слоях. Дополнительные сведения см. в разделах «Направляющие слои» и «Создание классической анимации движения вдоль траектории».

  • Направляемые слои: эти слои связываются с направляющим слоем. Объекты на направляемом слое могут располагаться или анимироваться по обводкам, нанесенным на направляющий слой. Направляемые слои могут содержать статичную графику и классическую анимацию, но не анимацию движения.

  • Слои анимации движения содержат объекты, для которых используется анимация движения. Дополнительные сведения см. в разделе «Об анимации движения».

  • Слои каркасов содержат объекты, к которым прикреплены кости обратной кинематики. Дополнительные сведения см. в разделе Использование инструмента «Кость» для создания анимации обратной кинематики.

Обычные, маскирующие, маскируемые и направляющие слои могут содержать анимацию движения и кости обратной кинематики. При наличии этих элементов в одном из указанных слоев накладываются ограничения на типы содержимого, которое можно добавлять к слою. Дополнительные сведения см. в разделах Анимация движения и Использование инструмента «Кость» для создания анимации обратной кинематики.

Создание слоя

После создания слоя он появляется над выделенным слоем. Новый слой становится активным.

  1. Выполните одно из следующих действий.
    • Нажмите кнопку «Создать слой»  в нижней части временной шкалы.

    • Выберите меню Вставка > Временная шкала > Слой.

    • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), имя слоя на временной шкале и выберите в контекстном меню пункт Вставить слой.

Создание папки слоев

  1. Выполните одно из следующих действий.
    • Щелкните на временной шкале слой или папку слоев и выберите меню Вставка > Временная шкала > Папка слоев.

    • Щелкните имя слоя на временной шкале правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), а затем выберите в контекстном меню пункт «Вставить папку». Новая папка появляется над выделенным слоем или папкой слоев.

    • Щелкните значок новой папки  внизу временной шкалы. Новая папка появляется над выделенным слоем или папкой слоев.

Упорядочивание слоев и папок слоев

Чтобы упорядочить документ, можно перегруппировать слои и папки на временной шкале.

Папки слоев помогают организовать рабочий процесс, позволяя размещать слои в виде древовидной структуры. Чтобы увидеть слои, которые содержатся в папке слоев, не затрагивая другие слои в рабочей области, разверните или сверните папку. В папках слоев могут содержаться слои и вложенные папки слоев, что позволяет упорядочивать слои таким же образом, как файлы на компьютере.

Элементы управления слоями на временной шкале воздействуют на все слои, содержащиеся в папке. Например, при блокировке папки слоев будут заблокированы все слои, содержащиеся в этой папке.

  • Чтобы переместить слой или папку в папку слоев, перетащите имя слоя или папки слоев на имя нужной папки слоев.
  • Для изменения порядка расположения слоев или папок слоев перетащите один или несколько слоев или папок на временной шкале в нужное местоположение.
  • Чтобы развернуть или свернуть папку слоев, щелкните треугольник слева от ее имени.
  • Чтобы развернуть или свернуть все папки слоев, щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), а затем выберите пункт Развернуть все папки или Свернуть все папки.

Переименование слоя или папки слоев

По умолчанию Animate присваивает имена новым слоям в порядке их создания: «Слой 1», «Слой 2» и так далее. Чтобы имена слоев отражали их содержимое, переименуйте слои.

  1. Выполните одно из следующих действий.
    • Дважды щелкните мышью имя слоя или папки слоев на временной шкале и введите новое имя.

    • Щелкните мышью имя слоя или папки слоев правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), а затем выберите в контекстном меню пункт «Свойства». В текстовом поле «Имя» введите новое имя и нажмите кнопку «ОК».

    • Выделите слой или папку на временной шкале и выберите меню Модификация > Временная шкала > Свойства слоя. В текстовом поле Имя введите новое имя и нажмите кнопку ОК.

Выделение слоя или папки слоев

  1. Выполните одно из следующих действий.
    • Щелкните мышью имя слоя или папки слоев на временной шкале.

    • Щелкните мышью любой кадр нужного слоя на временной шкале.

    • Выделите в рабочей области объект, принадлежащий этому слою.

    • Чтобы выделить смежные слои или папки слоев, щелкните их имена на временной шкале, удерживая нажатой клавишу «Shift».

    • Чтобы выделить несмежные слои или папки слоев, щелкните их имена на временной шкале, удерживая нажатой клавишу «Control» (Windows) или «Command» (Macintosh).

Копирование кадров из одного слоя

  1. Выделите диапазон кадров в слое. Чтобы выделить весь слой, нажмите его имя на временной шкале.
  2. Выберите меню Правка > Временная шкала > Копировать кадры.

  3. Щелкните кадр, в котором требуется начать вставку, и выберите Редактирование > Временная шкала > Вставить кадры. Чтобы заменить на целевой временной шкале точное количество скопированных кадров, выберите параметр Вставить и перезаписать кадры.

    Overwrite_frames_process_1
    Рабочий процесс «Вставка и перезапись кадров»

    A. Выберите и скопируйте кадры. B. Правой кнопкой мыши щелкните кадр, в котором требуется вставить скопированные, и выберите «Вставить и перезаписать кадры». C. Вставленные кадры перезаписывают соответствующее количество кадров в временной шкале. 

Копирование кадров из папки слоев

  1. Сверните папку (нажмите на треугольник слева от ее имени на временной шкале) и щелкните имя папки, чтобы выделить ее полностью. 

  2. Выберите меню Правка > Временная шкала > Копировать кадры.

  3. Чтобы создать папку слоев, выберите меню Вставка > Временная шкала > Папка слоев.

  4. Нажмите новую папку и выберите меню Правка > Временная шкала > Вставить кадры.

Удаление слоя или папки слоев

  1. Чтобы выделить слой или папку, нажмите ее имя на временной шкале или любой кадр этого слоя.
  2. Выполните одно из следующих действий.
    • Нажмите кнопку «Удалить слой» на временной шкале.

    • Перетащите слой или папку на кнопку «Удалить слой».

    • Нажмите имя слоя или папки слоев правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), а затем в контекстном меню выберите пункт Удалить слои.

    Примечание.

    При удалении папки слоя все вложенные слои удаляются вместе с содержимым.

Блокирование и разблокирование одного или нескольких слоев или папок слоев

  • Чтобы заблокировать слой или папку слоев, щелкните столбец «Заблокировать» справа от имени слоя. Чтобы разблокировать слой или папку слоев, еще раз щелкните столбец «Заблокировать».

  • Чтобы заблокировать все слои и папки, щелкните значок замка. Чтобы разблокировать все слои и папки слоев, щелкните его еще раз.

  • Чтобы заблокировать или разблокировать несколько слоев или папок, перетащите указателем по столбцу «Заблокировать».

  • Чтобы заблокировать все другие слои или папки слоев, нажмите столбец «Заблокировать», удерживая нажатой клавишу Alt (Windows) или Option (Macintosh). Чтобы разблокировать все слои и папки слоев, еще раз щелкните столбец «Заблокировать», удерживая нажатой клавишу Alt (Windows) или Option (Macintosh).

Копирование и вставка слоев (только для CS5.5)

Можно копировать целые слои и папки слоев на временной шкале и вставить их в ту же или в другую временную шкалу. Можно скопировать слой любого типа.

При копировании и вставке слоев сохраняется структура папок копируемых слоев.

  1. Выберите один или несколько слоев на временной шкале, щелкнув имя слоя. Для выбора нескольких слоев, следующих друг за другом, щелкайте их, удерживайте клавишу Shift. Удерживайте клавишу Control (Windows) или Command (Macintosh), чтобы выбрать несмежные слои.

  2. Выберите Редактирование > Временная шкала > Копировать слои или Вырезать слои. Также можно щелкнуть слои правой кнопкой и в контекстном меню выбрать команду Копировать слои или Вырезать слои.

  3. На нужной временной шкале выберите слой, который находится непосредственно под местом, в которое требуется вставить скопированные слои.

  4. Выберите Редактирование > Временная шкала > Вставить слои.

Слои добавляются на временной шкале над выбранным слоем. Если скопирована папка слоев, вставленные слои отображаются внутри папки.

Чтобы вставить слой в маскирующий или направляющий слой, необходимо сначала выбрать слой, находящийся под маской или направляющей, а затем выполнить вставку. Маскирующий, направляющий слой или слой папки нельзя вставить под маскирующий или направляющий слой.

Также можно дублировать слои. Для этого выделите слои и выберите Редактирование > Временная шкала > Дублировать слои. К имени новых слоев прибавляется слово «Копия».

Настройка свойств для нескольких слоев

  1. В Animate CC создайте новый FLA-файл или откройте существующий.

  2. Выберите те слои, свойства которых требуется изменить, щелкните их правой кнопкой мыши и выберите Свойства.

  3. В диалоговом окне Свойства слоя измените свойства.

  4. Нажмите кнопку ОК.

Отображение или скрытие папки или папки слоев

Красный крестик рядом с именем слоя (папки слоев) на временной шкале указывает, что он скрыт. В параметрах публикации можно задать, включать ли скрытые слои в публикуемый SWF-файл.

  • Чтобы скрыть слой или папку слоев, на временной шкале щелкните столбец под изображением глаза справа от имени слоя или папки слоев. Чтобы отобразить слой или папку, щелкните этот столбец еще раз.

  • Чтобы скрыть все слои и папки на временной шкале, нажмите значок глаза. Чтобы отобразить все слои и папки слоев, нажмите значок еще раз.

  • Чтобы отобразить или скрыть несколько слоев или папок, перетащите указателем по столбцу со значком глаза.

  • Чтобы скрыть все слои и папки слоев за исключением текущего слоя или папки, щелкните в столбце со значком глаза, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh). Чтобы отобразить все слои и папки слоев, нажмите еще раз, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh).

Просмотр содержимого слоя в виде контуров

Чтобы отличить, к какому слою принадлежит тот или иной объект, отобразите все объекты слоя в виде окрашенных контуров.

  • Чтобы отобразить все объекты слоя в виде контуров, щелкните столбец «Контур» справа от имени слоя. Чтобы отключить отображение контура, щелкните его еще раз.

  • Чтобы отобразить все объекты во всех слоях в виде контуров, щелкните значок контура. Чтобы отключить отображение контуров для всех слоев, нажмите его еще раз.

  • Чтобы отобразить объекты во всех слоях, отличных от текущего слоя, удерживая нажатой клавишу Alt (Windows) или клавишу Option (Macintosh), щелкните в столбце «Контур». Чтобы отключить контурное отображение для всех слоев, нажмите его еще раз, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh).

Примечание.

Траектории движения, расположенные на слое, также используют цвет обводки слоя.

Изменение цвета контура для слоя

  1. Выполните одно из следующих действий.
    • Дважды щелкните мышью значок слоя (слева от имени слоя) на временной шкале.

    • Щелкните имя слоя правой кнопкой мыши (Windows) или щелкните его, удерживая нажатой клавишу Control (Macintosh), а затем выберите в контекстном меню пункт Свойства.

    • Выделите слой на временной шкале и выберите меню Модификация > Временная шкала > Свойства слоя.

  2. В диалоговом окне Свойства слоя нажмите поле Цвет контура, выберите новый цвет и нажмите кнопку ОК.

Просмотр слоев и папок слоев

Отображение или скрытие папки или папки слоев

Красный крестик рядом с именем слоя (папки слоев) на временной шкале указывает, что он скрыт. В параметрах публикации можно задать, включать ли скрытые слои в публикуемый SWF-файл.

  • Чтобы скрыть слой или папку слоев, на временной шкале щелкните столбец под изображением глаза справа от имени слоя или папки слоев. Чтобы отобразить слой или папку, щелкните этот столбец еще раз.

  • Чтобы скрыть все слои и папки на временной шкале, нажмите значок глаза. Чтобы отобразить все слои и папки слоев, нажмите значок еще раз.

  • Чтобы отобразить или скрыть несколько слоев или папок, перетащите указателем по столбцу со значком глаза.

  • Чтобы скрыть все слои и папки слоев за исключением текущего слоя или папки, щелкните в столбце со значком глаза, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh). Чтобы отобразить все слои и папки слоев, нажмите еще раз, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh).

Просмотр содержимого слоя в виде контуров

Чтобы отличить, к какому слою принадлежит тот или иной объект, отобразите все объекты слоя в виде окрашенных контуров.

  • Чтобы отобразить все объекты слоя в виде контуров, щелкните столбец «Контур» справа от имени слоя. Чтобы отключить отображение контура, щелкните его еще раз.

  • Чтобы отобразить все объекты во всех слоях в виде контуров, щелкните значок контура. Чтобы отключить отображение контуров для всех слоев, нажмите его еще раз.

  • Чтобы отобразить объекты во всех слоях, отличных от текущего слоя, удерживая нажатой клавишуAlt (Windows) или клавишу Option (Macintosh), щелкните в столбце «Контур». Чтобы отключить контурное отображение для всех слоев, нажмите его еще раз, удерживая нажатой клавишу Alt (Windows) или Option (Macintosh).

Изменение цвета контура для слоя

  1. Выполните одно из следующих действий.
    • Дважды щелкните мышью значок слоя (слева от имени слоя) на временной шкале.

    • Щелкните имя слоя правой кнопкой мыши (Windows) или щелкните его, удерживая нажатой клавишу Control (Macintosh), а затем выберите в контекстном меню пункт Свойства.

    • Выделите слой на временной шкале и выберите меню Модификация > Временная шкала > Свойства слоя.

  2. В диалоговом окне Свойства слоя нажмите поле Цвет контура, выберите новый цвет и нажмите кнопку ОК.

Примечание.

Траектории движения, расположенные на слое, также используют цвет обводки слоя.

Настройка прозрачности слоев

  1. В Animate CC создайте новый FLA-файл или откройте существующий.

  2. Удерживая клавишу Shift, щелкните столбец со значком глаза на временной шкале, чтобы задать прозрачность отображения.

    Примечание.

    Щелчок с удерживанием нажатой клавиши Shift не влияет на скрытые слои.

    Настройка прозрачности слоев
    Настройка прозрачности слоев
  3. Для настройки прозрачности слоев используйте один из следующих вариантов.

    • Щелкните правой кнопкой мыши любой слой и в контекстном меню выберите Свойства. В диалоговом окне Свойства слоя выберите Видимость > Прозрачный.
    • Щелкните правой кнопкой мыши любой слой и в контекстном меню выберите Показать остальные прозрачными.
    Свойства слоя
    Свойства слоя
  4. Нажмите кнопку ОК.

Примечание.

Изменение прозрачности слоя не влияет на скрытые слои. 

Использование расширенных слоев

В Animate CC в режиме «Расширенные слои» все слои на временной шкале публикуются в виде символов. Режим «Расширенные слои» позволяет получить доступ к следующим функциям:

Режим Расширенные слои по умолчанию включен. Режим «Расширенные слои» можно включить или отключить в параметрах: «Модификация» > «Документ». После применения изменений щелкните Сделать значением по умолчанию, чтобы сохранить текущий параметр для последующих документов, а также в сеансах Animate. 

Режим «Расширенные слои»
Режим «Расширенные слои»

В Animate при получении доступа к этим символам с помощью сценария слой следует использовать как объект. Например, если вы не используете расширенные слои, вы можете напрямую получить доступ к символу, как в следующем примере: 

getchildbyname("symbol1");

Но при использовании расширенных слоев вы можете получить доступ к символу только с помощью сценария, аналогичного следующему примеру:

Layer=getchildbyname("L1");

Layer.getchildbyname("symbol1");

Пример кода для доступа к символам с помощью расширенных слоев для типа документа AS3: 

Var Layer:MovieClip =MovieClip(getchildbyname("L1"));
Layer.getchildbyname("symbol1");

Пример кода для доступа к символам с помощью расширенных слоев для типа документа HTML5 Canvas: 

Layer=this.getchildbyname("L1");
Layer.getchildbyname("symbol1");

На следующем изображении показан порядок доступа к символу с помощью сценария с расширенными слоями и без расширенных слоев. 

Изображение порядка доступа к символу с использованием расширенных слоев и без
Изображение порядка доступа к символу с использованием расширенных слоев и без

Примечание.

Размер публикуемых анимированных проектов может увеличиваться при использовании в Animate расширенных слоев. Если при использовании камеры или глубины слоя возникают проблемы, проверьте, включены ли расширенные слои. Если они отключены, включите их, чтобы получить ожидаемый результат. 

Применение эффектов слоя

Фильтры и цветовые эффекты, применяемые только в видеороликах. В режиме расширенных слоев фильтры и цветовые эффекты теперь можно применять к отдельным кадрам и соответственно ко всему содержимому кадров, включая фигуры, графические объекты, графические символы и т. д. Эффекты слоя можно также анимировать с помощью классических анимаций, фигур и анимаций обратной кинематики в кадрах.

Эффекты слоя можно применить к отдельным кадрам или выбрать несколько нужных кадров. Чтобы применить эффекты слоя ко всем кадрам слоя, выберите слой целиком. Эффекты слоя можно также применить к временной шкале символа, например, к видеоролику и графическому символу на всех сценах.

Примечание.

Эффекты слоя можно применить, только если включен режим «Расширенные слои». Возможно, чтобы использовать эту функцию, потребуется явно включить режим «Расширенные слои» для файлов.

Использование фильтров для кадров

Чтобы добавить фильтры на определенный кадр, сначала выберите кадр. Панель инспектора свойств загрузит определенные свойства кадра. Щелкните значок + в раскрывающемся списке Фильтры

Фильтры кадра
Фильтры кадра

При добавлении фильтров в кадры появится инспектор свойств, как показано на следующем снимке экрана. 

Вы можете задать свойства для каждого фильтра в соответствии с вашими требованиями и применить их на уровне кадра. Промежуточные кадры применимы ко всем фильтрам кадров. 

Свойства фильтров кадров в инспекторе свойств
Свойства фильтров кадров в инспекторе свойств

Примечание.

Эффекты слоя поддерживаются только в документах типа ActionScript 3. Анимация движения и слои камеры не поддерживают эффекты слоя. 

Использование цветовых эффектов

Чтобы применить цветовой эффект к определенному кадру, сначала выберите кадр. Панель инспектора свойств загрузит определенные свойства кадра. Выберите любое необходимое свойство цвета на панели инспектора свойств.

Цветовые эффекты
Цветовые эффекты

Применение глубины слоя

Как аниматор вы можете размещать слои в различных плоскостях двухмерной анимации, создавая иллюзию глубины. 

С помощью панели Глубина слоя вы можете динамически изменять глубину различных слоев. Чтобы открыть панель глубины слоя, щелкните «Окно» > «Глубина слоя».

Глубина для каждого слоя
Глубина для каждого слоя

Примечание.

Можно задать значение глубины слоя от -5000 до 10 000.

Как показано на приведенном выше снимке экрана, значения глубины слоя отображаются рядом с именем каждого слоя для данного кадра.

  • Наводите курсор на каждое значение, щелкайте мышью и перетаскивайте ползунок к вправо или влево.
  • Чтобы уменьшить глубину. перетащите ползунок влево. Чтобы увеличить глубину, перетащите ползунок вправо. 
  • Можно задавать более низкие положительные значения для представления объектов, расположенных ближе, и более высокие положительные значения для представления объектов, которые находятся вдали.

Можно анимировать значения глубины слоя в любом диапазоне анимации. 

Каждый слой представлен уникальными цветными линиями на панели «Глубина слоя». Цвета, представляющие каждый из слоев, можно посмотреть на временной шкале. 

Кроме того, можно увеличить или уменьшить глубину объектов на каждом слое путем перемещения этих разноцветных линий вверх или вниз.

  • Чтобы уменьшить глубину объектов на слое, щелкните и переместите линию вверх.
  • Чтобы увеличить глубину объектов на слое, щелкните и переместите линию вниз.

Изображения с анимациями с глубиной слоев или без нее:

Содержимое без эффекта «Глубина слоя»
Содержимое без эффекта «Глубина слоя»
Содержимое с эффектом «Глубина слоя»
Содержимое с эффектом «Глубина слоя»

Изображение анимации с применением эффекта «Глубина слоя»:

Можно использовать камеру на слоях с несколькими плоскостями для создания эффекта смещения или масштабирования содержимого на плоскости. Кроме того, можно закрепить камеру на определенном слое или применить эффекты камеры во время выполнения с помощью интерактивных API-интерфейсов. Дополнительные сведения см. в разделе Создание эффекта смещения с помощью камеры и глубины слоя.

Примечание.

Глубину слоя можно применить только на основной временной шкале.

Сохранение размера для глубины слоя

Вы можете изменить глубину слоя объектов, не затрагивая размер и положение объектов. Для использования функции сохранения размера нажмите кнопку Сохранить размер в правом верхнем углу панели Глубина слоя.

Сохранить размер можно в двух режимах.

  • Нажмите кнопку Сохранить размер и измените глубину нужного слоя. Кнопка Сохранить размер переключится автоматически.
  • Нажмите и удерживайте клавишу ALT, чтобы временно включить параметр Сохранить размер при перетаскивании значений глубины слоя.
Сохранение размера для глубины слоя
Сохранение размера для глубины слоя

Применение глубины слоя во время выполнения

Также можно добавлять камеры на объектах и применять эффекты с помощью API-интерфейсов камеры. Дополнительные сведения см. в разделеИспользование интерактивной камеры во время выполнения

API-интерфейс глубины слоя для AS3

Можно управлять слоями во время выполнения с помощью API-интерфейсов. Например, если во время выполнения вам необходимо ввести дополнительный слой в анимации или уменьшить глубину одного из слоев в анимации. 

Метод Прототип Пример Описание
setLayerZDepth fl.Layer.setLayerZDepth(timeline,
layerName,zDepth)
fl.Layer.setLayerZDepth("layerName", 100); Настройка значения глубины конкретного слоя по оси Z.
getLayerZDepth fl.Layer.getLayerZDepth(layerName) :zDepth fl.Layer.getLayerZDepth("layerName"); Возврат значения глубины конкретного слоя по оси Z.
addNewLayer fl.Layer.addNewLayer(layerName,
zDepth=0)
fl.Layer.addNewLayer("layerName",-80); Добавление нового слоя на временную шкалу и настройка глубины по оси Z.
removeLayer fl.Layer.removeLayer(layerName) fl.Layer.removeLayer("layerName"); Удаление слоя с временной шкалы.

API-интерфейс глубины слоев для HTML Canvas

Метод Прототип Пример Описание
setLayerZDepth AdobeAn.Layer.setLayerZDepth(layerName,
zDepth)
console.log(fl.Layer.setLayerZDepth
("layerName",100));
Настройка значения глубины конкретного слоя по оси Z.
getLayerZDepth AdobeAn.Layer.getLayerZDepth(layerName)
:zDepth
console.log(fl.Layer.getLayerZDepth
("layerName"));
Возврат значения глубины конкретного слоя по оси Z.

Родительские слои

Animate позволяет сделать один слой родительским по отношению к другому. Родительские слои — это простой способ позволить одному слою или объекту анимации управлять другим слоем или объектом. Это помогает аниматорам и гейм-дизайнерам легче контролировать движения разных частей персонажа для более быстрого создания анимации.

Для отображения родительских слоев нужно включить Расширенные слои. По умолчанию Расширенные слои включены для новых файлов. Чтобы включить представление родительских слоев, щелкните значок иерархии в правом верхнем углу временной шкалы. 

Отображение родительских слоев
Отображение родительских слоев

Примечание.

Родительские слои для деформированных объектов работают, только если точка преобразования дочернего слоя находится на объекте родительского слоя.

Родительские и дочерние слои

В представлении родительских слоев при перетаскивании слоя 1 на слой 2 первый слой становится дочерним по отношению ко второму. Объект на дочернем слое наследует положение и поворот объекта родительского слоя, а также все его свойства. Таким образом, когда вы перемещаете или поворачиваете объект на родительском слое, он также перемещается или поворачивается на дочернем. Можно создать несколько связей между родительскими и дочерними объектами, чтобы сформировать иерархию.

Родительские слои

Один слой можно связать с другим, щелкнув маркер слоя (цветной прямоугольник) и перетащив его на другой слой. Кроме того, можно щелкнуть область горизонтального прямоугольника рядом с именем слоя и перетащить ее на другой слой. Можно также щелкнуть любой слой и выбрать для него родительский слой в раскрывающемся списке. 

При перетаскивании цветного прямоугольника рядом появится пунктирная линия. После перетаскивания между слоями будет создана иерархическая связь.

Задание родительского слоя
Задание родительского слоя

Крайний левый цветной прямоугольник в иерархии обозначает родительский слой. Иерархия родительско-дочерних отношений указывается слева направо.

Чтобы удалить связь, щелкните любой цветной прямоугольник слоя и перетащите пунктирную линию. Кроме того, можно щелкнуть область горизонтального прямоугольника и выбрать Удалить родительский слой, как показано на снимке экрана ниже. 

Удаление родительского слоя
Удаление родительского слоя

На снимках ниже показаны представления иерархии слоев до и после изменения, а также позиции при использовании родительских слоев.

До и после применения родительских слоев
До и после применения родительских слоев

Ниже показан пример иллюстрации, в которой используются родительские слои для частей человеческого тела.

Пример иллюстрации частей тела с родительскими слоями
Пример иллюстрации частей тела с родительскими слоями

В представленной выше иллюстрации:

  • Torso (Туловище) — родительский слой для всех частей тела.
  • Legs_thigh (Бедро) — это родительский слой с разными частями ноги: Sneaker (Стопа), Leg_lower (Голень) и Ankle (Щиколотка).
  • Head (Голова) — дочерний слой для родительского слоя Neck (Шея), а Torso — родительский слой для слоя Neck. Таким образом, при перемещении шеи голова также будет перемещаться.

Примечание.

Родительские слои — это свойство, которое нужно задать для каждого ключевого кадра на дочернем слое. На ключевом кадре можно разорвать иерархическую связь или привязать дочерний слой к другому родительскому.

Руководство по родительским слоям

Руководство по родительским слоям
Узнайте о том, как создать иерархию родительских и дочерних слоев, и научитесь с легкостью манипулировать композициями.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет