Об AI-файлах Adobe Illustrator

Animate позволяет импортировать AI-файлы из Adobe® Illustrator®, сохраняя большинство возможностей редактирования и визуальной надежности изображения. AI Importer также обеспечивает высокую степень контроля при определении метода импорта изображений Illustrator в Animate, позволяя указать режим импорта конкретных объектов в AI-файл.

Animate AI Importer располагает следующими основными характеристиками.

  • Сохраняет возможность редактирования большинства широко используемых эффектов Illustrator как фильтров Animate.

  • Сохраняет возможность редактирования режимов наложения, общих для Animate и Illustrator.

  • Сохраняет точность и возможность редактирования градиентных заливок.

  • Обеспечивает согласованное представление RGB-цветов (красного, зеленого, синего).

  • Импортирует символы Illustrator как символы Animate.

  • Сохраняет число и положение опорных точек Безье.

  • Точно сохраняет маски обрезки.

  • Сохраняет точный вид обводки и заливки.

  • Сохраняет прозрачность объектов.

  • Преобразует слои AI-файла в отдельные слои, ключевые кадры или в один слой Animate. Можно также импортировать AI-файл как единое растровое изображение, в этом случае Animate выполняет сведение (растрирует) файл.

  • Улучшает процедуры копирования и вставки между Illustrator и Animate. Настройки диалогового окна копирования и вставки применяются к AI-файлам, которые вставляются в рабочую область Animate.

Совместимость между Animate и Illustrator

Определенные визуальные атрибуты не могут быть точно импортированы, или после импорта теряется возможность редактировать их в среде разработчика Animate. AI Importer обеспечивает несколько способов импорта и размещения иллюстрации, чтобы оптимально сохранить ее внешний вид и возможность редактирования. Однако, сохранить некоторые визуальные атрибуты нельзя. Следуйте следующим указаниям, чтобы улучшить внешний вид AI-файлов, импортированных в Animate:

  • Animate поддерживает только цветовое пространство RGB, но не цветовое пространство CMYK, широко применяемое в печати. Animate может преобразовать изображения CMYK в RGB, однако цвета лучше сохраняются при преобразовании цветов в систему RGB в Illustrator.

  • Чтобы сохранить AI-эффекты тени, внутреннего свечения слоя, внешнего свечения слоя и размытия по Гауссу в виде редактируемых фильтров Animate, Animate импортирует объекты, к которым применены эти эффекты как фрагмент ролика Animate. При попытке импортировать объект с этими атрибутами как отличный от фрагмента ролика Animate выводит предупреждение о несовместимости и рекомендует импортировать объект как фрагмент ролика.

Работа с Illustrator и Animate

Графический объект, созданный в приложении Illustrator, можно переместить в среду редактирования Animate или напрямую открыть в приложении Flash Player. Графические объекты можно копировать и вставлять, сохранять в формате SWF или экспортировать напрямую в приложение Animate. Кроме того, Illustrator обеспечивает поддержку динамического текста Animate и символов роликов.

Вставка графического объекта Illustrator

Созданный в приложении Illustrator графический объект можно быстро, просто и без затруднений скопировать и вставить в приложение Animate.

При вставке графического объекта Illustrator в приложение Animate сохраняются следующие атрибуты.

  • Контуры и фигуры

  • Масштаб

  • Толщина штрихов

  • Определения градиентов

  • Текст (включая шрифты OpenType)

  • Связанные изображения

  • Символы

  • Режимы наложения

Кроме того, Illustrator и Animate поддерживают следующие возможности при вставке графического объекта.

  • При выделении в графическом объекте Illustrator слоев верхнего уровня целиком и вставке их в приложение Animate сохраняются слои и их свойства (видимость и блокировка).

  • Цветовые форматы Illustrator, отличные от RGB (CMYK, градации серого и пользовательские форматы), преобразуются приложением Animate в формат RGB. Цвета RGB вставляются обычным образом.

  • При импорте или вставке графического объекта Illustrator можно с помощью различных параметров сохранить определенные эффекты (например, тень, отбрасываемую текстом) в виде фильтров Animate.

  • Animate сохраняет маски Illustrator.

Экспорт SWF-файлов из приложения Illustrator

SWF-файлы, экспортируемые из приложения Illustrator, соответствуют по качеству и степени сжатия SWF-файлам, экспортируемым из приложения Animate.

При экспорте можно выбрать один из многочисленных заранее заданных стилей, обеспечивающих оптимальный вывод, и указать способ использования нескольких монтажных областей, способ преобразования символов, слоев, текста и масок. Например, можно указать экспорт символов Illustrator в виде роликов или графических изображений, а также создание SWF-символов из слоев Illustrator.

Импорт файлов Illustrator в приложение Animate

Чтобы создать полный макет в приложении Illustrator, а затем импортировать его в приложение Animate за один шаг, можно сохранить графический объект в собственном формате Illustrator (AI) и импортировать его с высокой точностью в приложение Animate с помощью команд «Файл» > «Импортировать в рабочую область» или «Файл» > «Импортировать в библиотеку».

Если файл Illustrator содержит несколько монтажных областей, выберите монтажную область для импорта в диалоговом окне «Импорт» программы Animate и укажите настройки для каждого слоя в этой монтажной области. Все объекты в выбранной монтажной области могут быть импортированы как один или несколько слоев или ключевых кадров Animate в программу Animate.

При импорте графического объекта Illustrator в виде файлов AI, EPS или PDF приложение Animate сохраняет те же атрибуты, что и при вставке графических объектов Illustrator. Кроме того, если импортируемый файл Illustrator содержит слои, их можно импортировать одним из следующих способов.

  • Преобразование слоев Illustrator в слои Animate

  • Преобразование слоев Illustrator в кадры Animate

  • Преобразование слоев Illustrator в один слой Animate

Работа с символами

Работа с символами в приложении Illustrator похожа на работу с символами в Animate.

Преобразование текста

Если AI-файл содержит текст, его можно преобразовать в следующие объекты.

  • Текст, доступный для редактирования 
  • Векторный контур
  • Сведенное растровое изображение

Преобразование слоя

Animate CC позволяет конвертировать слои в импортированном AI-файле, получая на выходе следующее:

  • Файл растрового изображения, сведенного в один слой
  • Редактируемые контуры и эффекты

(только для Flash Professional CS6 и более ранних версий) Свойства символа и ссылки

С помощью палитры «Символы» или панели·«Управление» можно легко назначать имена экземплярам символов, разрывать связи между экземплярами и символами, замещать экземпляр символа другим символом или создавать копию символа. Функции редактирования панели «Библиотека» в Animate работают аналогично.

(только для Flash Professional CS6 и более ранних версий) Объекты статического, динамического и вводимого текста

При переносе статического текста из приложения Illustrator в приложение Animate он преобразуется в контуры. Кроме того, можно настроить текст в приложении Illustrator как динамический текст. Динамический текст позволяет редактировать содержимое текста в приложении Animate программным образом и легко управлять проектами, требующими локализации на разные языки.

В приложении Illustrator отдельные текстовые объекты могут быть статическими, динамическими или объектами для ввода текста. Динамические текстовые объекты в приложениях Illustrator и Animate имеют схожие свойства. Например, в обоих приложениях можно использовать кернинг, оказывающий влияние на все символы текстового блока, а не на отдельные символы; оба приложения одинаково производят сглаживание текста и поддерживают связь с внешним XML-файлом, содержащим текст.

Об импорте AI-файлов в библиотеку Animate

Импорт AI-файла в библиотеку аналогичен импорту в рабочую область. Различие заключается в том, что весь AI-файл инкапсулирован в символ Animate. Содержимое импортируется в библиотеку и упорядочивается в структуре слоев и групп AI-файла.

Когда AI-файл импортируется в библиотеку, для корневой папки используется имя AI-файла. После импортирования AI-файла в библиотеку можно изменить имя корневой папки или переместить слои из папки.

Примечание. Содержимое импортированного AI-файла упорядочивается на панели библиотеки по алфавиту. Иерархическая структура групп и папок остается неизменной, но в библиотеке они переупорядочиваются по алфавиту.

 

При преобразовании AI-слоев в ключевые кадры AI-файл импортируется как фрагмент ролика; при преобразовании AI-слоев во Flash-слои AI-файл импортируется как графический символ. Полученный в результате фрагмент ролика или графический символ включает все содержимое AI-файла, импортированного на временную шкалу, как если бы содержимое было импортировано в рабочую область. Почти со всеми фрагментами ролика связаны растровые изображения и другие ресурсы. Чтобы избежать недоразумений и конфликтов имен, эти ресурсы хранятся в папке Assets в одной папке с фрагментом ролика.

Примечание. При импорте в библиотеку содержимое AI-файла импортируется на временную шкалу видеоролика, а не на основную временную шкалу Animate.

 

Панель «Библиотека» после импорта AI-файла

(только для Flash Professional CS6 и более ранних версий) Параметры средства импорта AI-файлов

В диалоговом окне «Настройки» в Animate можно задать настройки импорта для AI-файлов и диалогового окна «Импорт AI-файлов». Заданные настройки импорта AI-файлов влияют на параметры, первоначально установленные в диалоговом окне «Импорт AI» для типов объектов Illustrator.

Примечание.

Используйте диалоговое окно «Импорт AI», чтобы изменить для отдельных объектов настройки, заданные для слоев различных типов. Выберите слой, объект или группу, чтобы изменить соответствующие параметры импорта, и укажите необходимые параметры.

Общие

Настройки, которые влияют на действия AI-импортера при импорте AI-файлов.

Показать диалоговое окно «Импорт»

Указывает, что появляется диалоговое окно «Импортер AI-файлов».

Вынести объекты за область кадрирования

Исключает объекты на холсте Illustrator, которые находятся вне макета или области кадрирования.

Импортировать скрытые слои.

Указывает, что скрытые слои будут импортированы по умолчанию.

Импортировать текст как

Позволяет указать следующие установки импорта для текстовых объектов.

Текст, доступный для редактирования

Указывает, что импортированный из программы Illustrator текст является редактируемым в среде Animate. Допускается ухудшение вида текста, чтобы сохранить редактируемость текста.

Векторные кривые

Преобразует текст в векторные контуры. Этот параметр используется, чтобы сохранить внешний вид текста. Могут быть потеряны некоторые визуальные эффекты (в частности, неподдерживаемые режимы наложения и фильтры), но визуальные атрибуты (такие как текст по контуру) сохраняются, если текст импортируется как фрагмент ролика. Сам текст более нельзя редактировать, но сохраняется редактируемость степени плотности цвета и совместимых режимов наложения.

Примечание. Чтобы сохранить AI-эффекты тени, внутреннего свечения, внешнего свечения и размытия по Гауссу в виде редактируемых фильтров Animate, выберите команду «Создать фрагмент ролика для импорта», чтобы импортировать текст как фрагмент ролика.

Растровые изображения

Преобразует текст в растровое изображение, чтобы сохранить точный вид текста, каким он был в Illustrator. Если применяются фильтры или другие эффекты, которые не совместимы с Animate, то импорт текста как растрового изображения сохраняет его внешний вид. Растрированный текст больше нельзя редактировать.

Создать фрагменты ролика

Указывает, что текстовые объекты импортируются во фрагмент ролика. Чтобы сохранить поддерживаемые режимы наложения, AI-эффекты и прозрачность менее 100% при передаче между Illustrator и Animate, укажите, что текстовый объект импортируется как фрагмент ролика.

Импортировать пути как

Позволяет указать следующие установки импорта контуров.

Редактируемые контуры

Создает редактируемый векторный контур. Сохраняются поддерживаемые режимы наложения, эффекты и прозрачность объекта, но атрибуты, не поддерживаемые в Animate, отбрасываются.

Растровые изображения

Преобразует контур в растровое изображение, чтобы сохранить точный вид контура в Illustrator. Растрированное изображение более нельзя редактировать.

Создать фрагменты ролика

Указывает, что объекты контура импортируются во фрагмент ролика.

Изображения

Позволяет задать установки импорта для изображений.

Свести растровое изображение для сохранения оформления

Преобразует изображение в растровое, чтобы сохранить внешний вид режимов наложения и эффектов, не поддерживаемых в Animate. Растрированное изображение более нельзя редактировать.

Создать фрагменты ролика

Указывает, что изображения импортируются во фрагмент ролика.

Группы

Позволяет указать установки импорта для групп.

Импортировать как растровое изображение

Преобразует группу в растровое изображение, чтобы сохранить вид объектов, каким он был в Illustrator. После преобразования группы в растровое изображение объекты в ней нельзя выделить или переименовать.

Создать фрагменты ролика

Указывает, что все объекты в группе инкапсулируются в одном фрагменте ролика.

Слои

Позволяет задать установки импорта для слоев.

Импортировать как растровое изображение

Преобразует слой в растровое изображение, чтобы сохранить внешний вид объектов, который они имели в Illustrator.

Создать фрагменты ролика

Указывает, что слой инкапсулирован во фрагменте ролика.

Регистрация фрагмента ролика

Указывает глобальную точку регистрации для создаваемых роликов. Этот параметр применяется для точки регистрации для всех типов объектов. Этот параметр может быть изменен для отдельных объектов в диалоговом окне «Импорт AI-файла»; это начальный параметр для всех типов объектов. Дополнительные сведения о точке регистрации фрагмента ролика см. в разделе Изменение символов.

Импорт файлов Adobe Illustrator

Чтобы создать полный макет в приложении Illustrator, а затем импортировать его в приложение Animate за один шаг, можно сохранить графический объект в собственном формате Illustrator (AI) и импортировать его с высокой точностью в приложение Animate с помощью команд «Файл» > «Импортировать в рабочую область» или «Файл» > «Импортировать в библиотеку».

Если файл Illustrator содержит несколько монтажных областей, выберите монтажную область для импорта в диалоговом окне «Импорт» программы Animate и укажите настройки для каждого слоя в этой монтажной области. Все объекты в выбранной монтажной области могут быть импортированы как один или несколько слоев flash/ключевых кадров в программу Animate.

При импорте графического объекта Illustrator в виде файлов AI, EPS или PDF приложение Animate сохраняет те же атрибуты, что и при вставке графических объектов Illustrator. Кроме того, если импортируемый файл Illustrator содержит слои, их можно импортировать одним из следующих способов.

  • Преобразовать слои Illustrator в слои Flash.
  • Преобразовать слои Illustrator в кадры Flash.
  • Преобразовать все слои Illustrator в один слой Flash.

Работа с символами

Работа с символами в приложении Illustrator похожа на работу с символами в Animate.

Преобразование текста

Если AI-файл содержит текст, его можно преобразовать в следующие объекты.

  • Текст, доступный для редактирования 
  • Векторный контур
  • Сведенное растровое изображение

Преобразование слоя

Animate CC позволяет конвертировать слои в импортированном AI-файле, получая на выходе следующее:

  • Файл растрового изображения, сведенного в один слой
  • Редактируемые контуры и эффекты

(только для Flash Professional CS6 и более ранних версий) Свойства символа и ссылки

С помощью палитры «Символы» или панели·«Управление» можно легко назначать имена экземплярам символов, разрывать связи между экземплярами и символами, замещать экземпляр символа другим символом или создавать копию символа. Функции редактирования панели «Библиотека» в Animate работают аналогично.

(только для Flash Professional CS6 и более ранних версий) Объекты статического, динамического и вводимого текста

При переносе статического текста из приложения Illustrator в приложение Animate он преобразуется в контуры. Кроме того, можно настроить текст в приложении Illustrator как динамический текст. Динамический текст позволяет редактировать содержимое текста в приложении Animate программным образом и легко управлять проектами, требующими локализации на разные языки.

В приложении Illustrator отдельные текстовые объекты могут быть статическими, динамическими или объектами для ввода текста. Динамические текстовые объекты в приложениях Illustrator и Animate имеют схожие свойства. Например, в обоих приложениях можно использовать кернинг, оказывающий влияние на все символы текстового блока, а не на отдельные символы; оба приложения одинаково производят сглаживание текста и поддерживают связь с внешним XML-файлом, содержащим текст.

Дополнительные параметры импорта AI: «Рабочая область»

  1. Дополнительные параметры импорта AI: «Библиотека»

    Выберите Файл > Импортировать в рабочую область или Импортировать в библиотеку.

  2. Перейдите к импортируемому файлу AI, выделите его и нажмите «ОК». Появляется диалоговое окно «Импорт документа Illustrator в рабочую область» или «Импорт документа Illustrator в библиотеку».

    В этом диалоговом окне содержатся параметры для импорта файла Illustrator. В зависимости от типа объектов в импортируемом файле Illustrator могут быть доступны различные параметры.

  3. Чтобы подготовить список элементов AI-файла, несовместимых с Animate, нажмите кнопку Отчет о несовместимости (необязательно). Кнопка «Отчет о несовместимости» появляется только в том случае, если в AI-файле существуют несовместимости с Animate.

    В «Отчете о несовместимости» анализируются возможные несовместимости между Illustrator и Animate. В области «Параметры импорта» (рядом с кнопкой «Запрос») диалогового окна «Импорт AI» приводятся рекомендации, позволяющие добиться максимальной совместимости для любого несовместимого элемента.

    В разделе «Отчет о несовместимости» имеется флажок «Применить рекомендуемые параметры импорта». Если флажок установлен, то Animate автоматически применяет рекомендованные параметры импорта к любым несовместимым объектам в AI-файле. Исключение составляют случаи, когда размер AI-документа больше, чем допускается в Animate или когда в AI-документе используется цветовой режим CMYK. Чтобы исправить любую из этих несовместимостей, повторно откройте документ в Illustrator CS3 и измените размер документа или измените цветовой режим на RGB.

  4. На экране «Импорт» выберите следующие параметры:

    • Выбрать макет Illustrator: позволяет выбрать монтажную область для импорта.
    • Импортировать как растровое изображение: создает растровое изображение из импортированного ресурса AI в формате asset.c3.
    • Создать фрагменты ролика: при импорте в Animate слои изображения будут преобразованы во фрагменты ролика. Этот параметр может быть изменен в диалоговом окне «Импорт AI» для отдельных слоев, если нежелательно, чтобы все слои изображения были преобразованы во фрагменты ролика.
    • Регистрация: позволяет указать точку регистрации для фрагмента ролика.
    • Преобразование слоев Illustrator в слои Animate, в один слой Animate и в ключевые кадры:
      • Слои Animate: выделенные слои в списке выбора слоев Photoshop помещаются в собственный слой. Каждый слой помечается именем слоя в файле Photoshop.
      • Один слой Animate: все слои AI помещаются в один слой Animate.
      • Ключевые кадры: все выделенные слои в списке выбора слоев AI помещаются в отдельные ключевые кадры в новом слое.
    • Разместить объекты в исходных позициях: содержимое AI-файла сохраняется точно в той же позиции, в котором оно находилось в Illustrator. Например, если объект находился в Illustrator в позиции с координатами X = 100, Y = 50, то в рабочей области Animate ему будут присвоены те же координаты. (Не отображается в параметре «Импортировать в библиотеку».)
    • Импортировать как единое растровое изображение: все слои AI сводятся в одно растровое изображение.
    • Импортировать неиспользуемые символы: импортируются даже неиспользуемые символы
    • Установить размер рабочей области равным размерам монтажной области Illustrator: задает размеры рабочей области в соответствии с размерами монтажной области Illustrator. Рядом также отображаются размеры выбранной монтажной области.
    • Выберите Импорт для импорта файлов, Отмена для отмены процесса или Скрыть дополнительные параметры, чтобы показать основные параметры.
    Основные параметры AI: «Библиотека»

    Основные параметры AI: «Рабочая область»

  5. В основных параметрах выберите параметры из разделов Преобразование слоя, Преобразование текста и Преобразовать слои.

    • Выбрать макет Illustrator: позволяет выбрать монтажную область для импорта. Если изменить монтажную область в основных параметрах, древовидная структура в дополнительных параметрах изменяется в соответствии с выбранной монтажной областью.
    • Импортировать как растровое изображение: создает растровое изображение из импортированного ресурса AI.
    • Сохранять редактируемые контуры и эффекты: создание редактируемой векторной фигуры с растровым изображением, обрезанным внутри нее. Сохраняются поддерживаемые режимы наложения, фильтры и степень плотности цвета.
    • Изображение, сведенное в один слой: преобразование фигуры в растровое изображение, чтобы сохранить точный вид слоя фигуры в Illustrator.
    • Редактируемый текст: создание редактируемого текстового объекта из текста в выделенном слое Illustrator. Допускается ухудшение вида текста, чтобы сохранить возможность его редактирования.
    • Векторные кривые: преобразование текста в векторные контуры для сохранения его визуального облика.
    • Сведенное растровое изображение: преобразование текста в растровое изображение для сохранения точного вида текстового слоя в Illustrator. Растрированный текст более нельзя редактировать.
    • Слои Animate: выделенные слои в списке выбора слоев Illustrator помещаются в собственный слой. Каждый слой помечается именем слоя в файле Illustrator.
    • Один слой Animate: все слои AI помещаются в один слой Animate.
    • Ключевые кадры: все выделенные слои в списке выбора слоев AI помещаются в отдельные ключевые кадры в новом слое.
    • Разместить объекты в исходных позициях: сохраняется точная позиция, в котором объекты находилось в Illustrator. Например, если объект находился в Illustrator в позиции с координатами X = 100, Y = 50, то в рабочей области Animate ему будут присвоены те же координаты. (Не отображается в параметре «Импортировать в библиотеку».)
    • Импортировать как единое растровое изображение: все слои AI сводятся в одно растровое изображение.
    • Импортировать неиспользуемые символы: импортируются даже неиспользуемые символы
    • Установить размер рабочей области равным размерам монтажной области Illustrator (612x792): задает размеры рабочей области в соответствии с размерами монтажной области Illustrator, если она выбрана. (Не отображается, если выполняется импорт в библиотеку.)
  6. Текст описания шага
  7. Выберите Импорт для импорта файлов, Отмена для отмены процесса и Показать дополнительные параметры, чтобы показать дополнительные параметры.

    AI-файлы в библиотеке

Параметры импорта объекта Illustrator

Слои управляют всеми элементами, составляющими изображение Illustrator. По умолчанию все элементы организованы в одном родительском слое. Можно импортировать все элементы данного родительского слоя как единое, сведенное растровое изображение или выделить каждый объект отдельно и задать параметры импорта, соответствующие типу объекта (текст, контур, группа и т.д.). Средство импорта AI-файлов позволяет выбрать слои в импортируемой иллюстрации и задать отдельные параметры импорта, чтобы сохранить внешний вид объекта или возможность его редактирования в Animate.

Корректировка несовместимых графических эффектов

  1. Чтобы подготовить отчет о несовместимости, нажмите кнопку «Отчет о несовместимости». В отчете о несовместимости перечислены элементы в AI-файле, несовместимые с Animate.

  2. Установите режим «Чтобы устранить проблемы совместимости, измените параметры импорта». Многие несовместимости между Illustrator и Animate могут быть автоматически исправлены с использованием отчета о несовместимости и рекомендаций по импорту в области «Параметры импорта» в диалоговом окне «Импорт AI».

Выделение отдельных объектов

  1. Выделите объект, для которого предстоит задать параметры импорта. Можно выделять объекты Illustrator, содержащие слои, группы, отдельные контуры, текст и изображения.
  2. В разделе параметров объекта диалогового окна просмотрите параметры импорта, применимые к объекту выбранного типа. Обратите внимание на любые перечисленные несовместимости и рекомендуемые исправления для импорта объекта.
  3. Выберите нужные параметры импорта и выберите другой объект, чтобы задать для него параметры импорта, или нажмите кнопку «ОК».

(только для Flash Professional CS6 и более ранних версий) Выбор слоев

На панели «Слои» перечислены объекты в документе. По умолчанию в каждом документе Illustrator содержится по крайней мере один слой, и каждый объект в данном файле перечислен под этим слоем.

Если элемент на панели «Слои» содержит другие элементы, то слева от имени элемента отображается треугольник. Чтобы показать или скрыть содержимое, нажмите треугольник. Если треугольник не показан, то слой не содержит дополнительных элементов.

Примечание. Можно развернуть или свернуть все группы и слои с использованием контекстного меню средства импорта AI-файлов. Щелкните правой кнопкой мыши, чтобы отобразить контекстное меню, и выберите пункт «Развернуть все» или «Свернуть все».

Столбец «Выделение»

Определяет, выбраны ли элементы для импорта. Если элемент отмечен, то можно выбрать этот слой и задать параметры импорта; если режим редактирования не установлен, то слой затенен и задать параметры импорта для элемента в этом слое нельзя.

Столбец «Тип объекта»

Значок указывает, каким будет при импорте тип объекта Animate, размещенного в этом слое, а для видимого элемента показывает, что элемент выбран. Типы объектов:

  • Текст 

  • Контур 

  • Группа 

  • Фрагмент ролика

  • Графический символ 

  • Изображение 

Параметры импорта текста

Animate обеспечивает импорт текста как редактируемого текста, векторных кривых или сведенного растрового изображения. Чтобы сохранить поддерживаемые режимы наложения, AI-эффекты и прозрачность менее 100% при передаче между Illustrator и Animate, импортируйте текст как фрагмент ролика. При импорте текста как фрагмента ролика сохраняется возможность редактировать совместимые визуальные эффекты.

Текст, доступный для редактирования

По умолчанию текст Illustrator импортируется как редактируемый текст Animate. Допускается ухудшение вида текста, чтобы сохранить редактируемость текста.

Векторные кривые

Преобразует текст в векторные контуры. Этот параметр используется, чтобы сохранить внешний вид текста. Могут быть потеряны некоторые визуальные эффекты (в частности, неподдерживаемые режимы наложения и фильтры), но визуальные атрибуты (такие как текст по контуру) сохраняются, если текст импортируется как фрагмент ролика. Сам текст более нельзя редактировать, но сохраняется редактируемость степени плотности цвета и совместимых режимов наложения.

Примечание. Чтобы сохранить AI-эффекты тени, внутреннего свечения, внешнего свечения и размытия по Гауссу в виде редактируемых фильтров Animate, выберите команду «Создать фрагмент ролика для импорта», чтобы импортировать текст как фрагмент ролика.

 

Растровое изображение

Преобразует текст в растровое изображение, чтобы сохранить точный вид текста, каким он был в Illustrator. Если применяются фильтры или другие эффекты, которые не совместимы с Animate, то импорт текста как растрового изображения сохраняет его внешний вид. Растрированный текст больше нельзя редактировать.

Параметры импорта контуров

Контур — это линия, полученная в результате рисования в Illustrator. Контур может быть открытым, как дуга, или замкнутым, как круг. Начальная и конечная узловые точки открытого контура называются конечными точками. Редактируемые контуры можно импортировать в Animate, однако, если к контуру применяются определенные режимы наложения, фильтры и другие эффекты, то эти эффекты могут оказаться несовместимыми с Animate.

Растровое изображение

Преобразует контур в растровое изображение, чтобы сохранить точный вид контура в Illustrator. Растрированное изображение более нельзя редактировать.

Редактируемый контур

Создает редактируемый векторный контур. Сохраняются поддерживаемые режимы наложения, эффекты и прозрачность объекта, но атрибуты, не поддерживаемые в Animate, отбрасываются.

Параметры импорта изображений

Битовые изображения — наиболее широко распространенная электронная среда для однотонных изображений, таких как фотографии или цифровые рисунки. Illustrator создает растровые эффекты с использованием фильтров, эффектов и графических стилей. Многие из этих эффектов совместимы с Animate, но некоторые приходится сводить (растрировать), чтобы сохранить их внешний вид.

Примечание. Если растровый файл в Illustrator связан, то импортируются только JPEG, GIF или PNG в исходном формате. Все другие типы файлов преобразуются в PNG-формат в Animate. Кроме того, преобразование (в формат PNG) зависит от установленной в компьютере версии QuickTime®.

 

Сводить растровые изображения для сохранения внешнего вида

Преобразует изображение в растровое, чтобы сохранить внешний вид режимов наложения и эффектов, не поддерживаемых в Animate. Растрированное изображение более нельзя редактировать.

Создать фрагмент ролика

Импортирует изображения Illustrator как фрагменты ролика.

(Только Flash Professional CS6 и более ранние версии) Параметры импорта групп

Группы — наборы графических объектов, которые обрабатываются как одно целое. С помощью группирования можно переместить или преобразовать несколько объектов, не влияя на их атрибуты или относительное расположение. Например, можно сгруппировать объекты в проект эмблемы, чтобы перемещать и масштабировать эмблему как единое целое. Группы могут быть вложенными. То есть, они могут быть сгруппированы с другими объектами или группами в более крупные группы.

Группы представлены как элементы <Группа> на панели «Импорт». Если такой элемент, как группа, содержит другие элементы, то слева от имени элемента отображается треугольник. Щелкните треугольник, чтобы показать или скрыть содержимое группы. Если треугольник не показан, то элемент не содержит дополнительных элементов.

Импортировать как растровое изображение

Преобразует группу в растровое изображение, чтобы сохранить вид объектов, каким он был в Illustrator. После преобразования группы в растровое изображение объекты в ней нельзя выделить или переименовать.

Создать фрагмент ролика

Инкапсулирует все объекты в группе в один фрагмент ролика.

Операции копирования и вставки между Illustrator и Animate

При копировании и вставке (или перетаскивании мышью) иллюстраций между Illustrator и Animate появляется диалоговое окно «Вставка», в котором представлены параметры импорта для копируемого (или вставляемого) AI-файла.

Вставить как растровое изображение

Выполняет сведение копируемого файла в один растровый объект.

Вставить с использованием настроек импорта AI-файлов

Импортирует файл с использованием параметра импорта AI-файла, заданного в установках Animate («Правка» > «Установки»).

Применить рекомендуемые параметры импорта, чтобы устранить проблемы совместимости

Активируется по умолчанию, если выбран режим «Вставить с использованием установок импортера AI-файлов». Автоматически устраняет любые несовместимости, обнаруженные в AI-файле.

Сохранять слои

Активируется по умолчанию, если выбран режим «Вставить с использованием установок импортера AI-файлов». Указывает, что слои в AI-файле преобразуются в слои Animate (так же, как в режиме «Преобразовать в слои Flash», установленном в диалоговом окне «Импорт AI»). При отмене все слои сводятся в один слой.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет