Покадровая анимация в Animate

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

Создание покадровой анимации

При покадровой анимации содержимое рабочей области изменяется в каждом кадре. Покадровая анимация наиболее хорошо подходит для сложной анимации, при которой изображение меняется в каждом кадре, а не перемещается по рабочей области. При покадровой анимации размер файла увеличивается сильнее, чем при tween-анимации. В покадровой анимации Animate хранит значения для каждого завершенного кадра.

Для создания покадровой анимации определите все кадры как ключевые и создайте различные изображения для каждого кадра. Изначально каждый новый ключевой кадр имеет то же содержимое, что и предшествующий ему ключевой кадр, поэтому можно последовательно модифицировать кадры анимации.

  1. Щелкните имя слоя, чтобы сделать его активным, и выберите кадр слоя, с которого должна начинаться анимация.
  2. Если кадр еще не является ключевым, выберите команду «Вставка» > «Временная шкала» > «Ключевой кадр».
  3. Создайте иллюстрацию для первого кадра последовательности. Используйте инструменты рисования, вставьте графику из буфера или импортируйте файл.
  4. Чтобы добавить новый ключевой кадр, содержимое которого не отличается от содержимого первого ключевого кадра, щелкните следующий кадр справа в той же самой строке. Выберите команду «Вставка» > «Временная шкала» > «Ключевой кадр» (Windows) или нажмите кадр, удерживая нажатой клавишу «Control», и выберите «Вставить ключевой кадр» (Macintosh).

  5. Чтобы добавить следующий фрагмент анимации, измените содержимое этого кадра в рабочей области.
  6. Чтобы завершить последовательность покадровой анимации, повторяйте шаги 4 и 5 до тех пор, пока не будет создана нужная анимация.
  7. Чтобы протестировать последовательность анимации, выберите команду «Управление» > «Воспроизвести» или нажмите кнопку «Воспроизвести» на средстве управления («Окно» > «Панели управления» > «Средство управления»).

Создание покадровой анимации путем преобразования классической анимации или анимации движения

Можно преобразовать диапазон классической анимации или анимации движения в покадровую анимацию. В покадровой анимации у каждого кадра есть ключевые кадры (не путать с ключевыми кадрами свойств), каждый из которых содержит экземпляры анимированных символов. Покадровая анимация не содержит интерполированных значений свойств.

  1. Щелкните правой кнопкой мыши (Windows) или левой кнопкой с удержанием клавиши Ctrl (Macintosh) на диапазоне анимации, который необходимо преобразовать, и выберите в контекстном меню «Преобразовать в покадровую анимацию».

Использование режима калькирования.

Обычно в рабочей области находится один кадр из последовательности анимации. Для упрощения рисования, размещения и редактирования покадровой анимации в режиме калькирования в рабочей области отображается содержимое предыдущего и следующих кадров. Кадр, над которым находится указатель воспроизведения, отображается в полном цвете, а прошлые и будущие кадры отличаются по цвету и прозрачности. 

Предыдущий и следующий кадры в режиме калькирования имеют цветовые оттенки по умолчанию. Чтобы настроить эти цвета, используйте параметр «Дополнительные настройки».

Включение и отключение режима калькирования

  • Нажмите кнопку «Многослойная структура» , чтобы включить или отключить режим калькирования.
  • Чтобы исключить кадры из заголовка временной шкалы или включить в него, нажмите правой кнопкой мыши любой кадр многослойной структуры в диапазоне многослойных структур.
  • Нажмите кнопку «Многослойная структура»  и удерживайте кнопку мыши для просмотра и выбора вариантов.

Дополнительные настройки в режиме калькирования

Нажмите кнопку «Многослойная структура»  и удерживайте кнопку мыши, затем выберите  Дополнительные настройки.

Настройка диапазона

Настройка цветов для отображения многослойной структуры

  1. Чтобы настроить цвета кадров кальки, выберите Кадр кальки на панели «Временная шкала».
  2. Нажмите кнопку «Многослойная структура»  и удерживайте кнопку мыши, затем выберите Дополнительные настройки.
  3. Измените тон цвета предыдущего и следующего кадров.

Контурный режим и режим заливки

Настройка непрозрачности

  1. Чтобы изменить непрозрачность кадра многослойной структуры, который предшествует активному кадру или следует за ним, нажмите и перетащите ползунок Начальная непрозрачность.

  2. Чтобы уменьшить приращение каждого кадра многослойной структуры на значение в процентах, перетащите ползунок Уменьшение.

Отображение только ключевых кадров

  1. Чтобы настроить цвета кадров кальки, выберите Кадр кальки на панели «Временная шкала».
  2. Выберите «Правка» > «Настройки».
  3. В разделе Цвет многослойной структуры настройте цвет для прошлых, текущих и последующих кадров при помощи кнопок выбора цвета. 

Маркеры привязки

Одновременный просмотр нескольких кадров анимации в рабочей области

Нажмите кнопку «Многослойная структура» . Все кадры между режимами начала и конца многослойной структуры (в заголовке временной шкалы) наложены друг на друга как один кадр в окне документа.

Маркеры кальки

Калькирование с цветомаркировкой

Цветомаркировка в режиме калькирования помогает различать прошлые, последующие и текущий кадры. Чем дальше калька кадра от активного кадра, тем меньше ее прозрачность.

Калькирование на временной шкале

Цветомаркировка в режиме калькирования, выделяющая прошлый, последующий и текущий кадры

Контурный режим калькирования

Настройка цветов для отображения многослойной структуры

  1. Чтобы настроить цвета кадров кальки, выберите Кадр кальки на панели «Временная шкала».
  2. Выберите «Правка» > «Настройки».
  3. В разделе Цвет многослойной структуры настройте цвет для прошлых, текущих и последующих кадров при помощи кнопок выбора цвета. 
Примечание.

Цветомаркировка также применима для контурного режима.

Режим многослойной структуры временной шкалы

Настроенное калькирование

  • Чтобы изменить позицию любого маркера кальки, перетащите его указатель в новое место. Обычно маркеры кальки перемещаются вместе с указателем текущего кадра. Удерживайте клавишу Control или Command и используйте перетаскивание для изменения положения маркера с обеих сторон.
  • Чтобы включить редактирование всех кадров между маркерами кальки, нажмите кнопку «Редактировать несколько кадров» в . Обычно режим калькирования позволяет редактировать только один текущий кадр. Однако можно отобразить содержимое всех кадров между маркерами кальки с целью редактирования.
  • Чтобы переместить диапазон цикла по временной шкале в любое место, включающее точку воспроизведения, используйте маркеры на временной шкале и перетащите диапазон, удерживая клавишу Shift. 
  • Чтобы задать маркеры диапазона, удерживая клавишу Shift, перетащите маркеры диапазона или диапазон цикла, используя один из маркеров на временной шкале. 
Примечание.

Заблокированные слои (со значком замка) не отображаются при включенном режиме калькирования. Чтобы избежать отображения множества сбивающих с толку рисунков, заблокируйте или скройте слои, которых не должно быть в режиме кальки.

Предварительный просмотр работы

Чтобы проверить работу калькирования, наведите курсор мыши на весь диапазон временной шкалы. Ваша анимация будет воспроизводиться с использованием цветных контуров, что поможет составить точное представление об изменениях. 

Логотип Adobe

Вход в учетную запись