О фильтрах

Обзор фильтров

Фильтры (графические эффекты) позволяют добавлять визуальные эффекты к тексту, кнопкам и роликам. Уникальность Animate состоит в том, что применяемые фильтры можно анимировать с помощью анимации движения.

Режимы наложения Animate позволяют создавать совмещенные изображения. Совмещение — это процесс изменения прозрачности или взаимодействия цветов двух или более перекрывающихся объектов. Режимы наложения дают также дополнительный контроль над непрозрачностью цвета объектов и изображений. Режимы наложения Animate можно использовать для создания подсветки или теней, которые позволяют показать детали нижнего изображения или добавить цвет в ненасыщенное изображение.

Об анимированных фильтрах

Фильтры анимируются на временной шкале. Объекты в отдельных ключевых кадрах, соединенных анимацией движения, имеют параметры для соответствующих фильтров, соединенных анимацией движения в промежуточных кадрах. Если фильтру не соответствует фильтр того же типа на противоположном конце анимации движения, второй фильтр добавляется автоматически, чтобы эффект обязательно появлялся в конце последовательности анимации.

Во избежание неправильной анимации движения в случае, если фильтр на одном из концов анимации отсутствует или фильтры на концах применяются в разном порядке, Animate делает следующее.

  • Если применить анимацию движения к фрагменту ролика с фильтрами и вставить ключевой кадр на противоположном конце анимации движения, то в конечном кадре анимации движения фрагмента ролика автоматически появятся те же фильтры и в том же порядке, что и в первом кадре анимации движения.

  • Если поместить фрагменты ролика на два кадра с разными фильтрами, а потом применить анимацию движения между кадрами, Animate сначала обрабатывает фрагмент ролика с наибольшим количеством фильтров. Затем Animate сравнивает фильтры первого фрагмента ролика с фильтрами, используемыми вторым фрагментом ролика. Если соответствующие фильтры во втором фрагменте ролика не найдены, Animate создает пустой фильтр без параметров и с цветами существующих фильтров.

  • Если между двумя ключевыми кадрами существует анимация движения и к объекту в одном из ключевых кадров добавляется фильтр, то Animate автоматически добавляет фиктивный фильтр к фрагменту ролика, когда достигает ключевого кадра на другом конце анимации движения.

  • Если между двумя ключевыми кадрами существует анимация движения и из объекта в одном из ключевых кадров удаляется фильтр, Animate автоматически удаляет соответствующий второй фильтр из фрагмента ролика, когда достигает ключевого кадра на другом конце анимации движения.

  • Если заданные параметры фильтров между началом и концом анимации движения не согласуются, Animate применяет к интерполированным кадрам параметры фильтров начального кадра. Несогласованность параметров возникает в случае, если следующие параметры установлены по-разному в начале и в конце анимации движения: маскирование, внутренняя тень слоя и внутреннее свечение слоя, а также тип градиентного свечения и градиентная фаска.

    Например, если создать анимацию движения с помощью фильтра «Тень» и применить в первом кадре анимации движения тень с маскированием, а в последнем — внутреннюю тень слоя, Animate устранит несогласованность фильтров в анимации движения. В этом случае Animate применяет параметры фильтров, используемые в первом кадре анимации движения: отбрасываемая тень с маскированием исходного объекта.

О фильтрах и скорости воспроизведения Flash Player

Тип, количество и качество фильтров, применяемых к объектам, может влиять на скорость воспроизведения SWF-файлов. Чем больше фильтров применяется к объекту, тем больше вычислений должен выполнить Adobe® Flash® Player, чтобы правильно отобразить созданные визуальные эффекты. Adobe® рекомендует ограничить количество фильтров, применяемых к объекту.

Каждый фильтр содержит элементы управления, которые позволяют настроить интенсивность и качество применяемого фильтра. Использование более низких параметров повышает скорость воспроизведения на менее мощных компьютерах. Если создается содержимое для воспроизведения на разных компьютерах или вы не знаете, насколько мощные компьютеры доступны пользователям, задайте уровень качества «Низкое», чтобы максимально увеличить скорость воспроизведения.

О фильтрах Pixel Bender

Adobe Pixel Bender™ — это язык программирования, разработанный компанией Adobe. Он позволяет создавать пользовательские фильтры, эффекты и режимы наложения для использования в ПО Animate и After Effects. Pixel Bender работает независимо от аппаратных средств и автоматически обеспечивает эффективную работу в разных конфигурациях графического и центрального процессоров.

Для создания фильтра разработчики Pixel Bender пишут код Pixel Bender и сохраняют его в текстовом файле с расширением pbj. Созданный таким образом фильтр Pixel Bender можно использовать в документе Animate. Используйте ActionScript® 3.0 для загрузки фильтра и применения его элементов управления.

Дополнительная информация о работе с Pixel Bender через ActionScript приведена в Руководстве разработчика ActionScript 3.0.

Ли Браймлоу (Lee Brimelow) опубликовал несколько полезных примеров Pixel Bender в своем блоге по адресу http://theflashblog.com/?cat=44.

В следующих видеоруководствах показано использование фильтров Pixel Bender в среде Animate:

Работа с фильтрами

Новые возможности в Animate CC

Каждый раз, когда к объекту добавляется новый фильтр, этот фильтр добавляется в список фильтров, применяемых к объекту, в инспекторе свойств. Можно применить к объекту несколько фильтров или удалить прежние фильтры. Фильтры можно применить только к тексту, кнопке, ролику, его компонентам и скомпилированным роликам.

Можно создать библиотеку параметров фильтров, которая позволит легко применять к объекту тот же самый фильтр или наборы фильтров. Animate сохраняет наборы настроек фильтров, созданные в разделе «Фильтры» инспектора свойств, в меню «Фильтры» > «Наборы настроек».

В программе Flash Professional CS6 и более ранних ее версиях применение фильтров ограничивается только роликами и символами кнопок. В программе Animate CC можно также применять фильтры к компонентам роликов и скомпилированных роликов. Это позволяет добавлять различные эффекты к компонентам напрямую — одним или двумя щелчками кнопки мыши — и легко совершенствовать внешний вид приложений. Во Flash CS6 для добавления фильтров или других эффектов к компоненту необходимо «заключить» его внутри символа ролика. Инструкция:

  1. Создание или добавление компонента в рабочей области.
  2. Щелкните по компоненту правой кнопкой мыши и выберите «Преобразовать в символ».
В программе CS6 (и более ранних ее версиях) можно добавлять фильтры и другие виды эффектов после заключения компонента внутри символа. Однако, это только обходной путь, а не рекомендованное решение.
 
В Animate CC фильтры к компонентам можно добавлять напрямую, используя параметры «Фильтры», «Цветовые эффекты» и «Настройки дисплея» на панели «Свойства». Для более четкого понимания принципа действия этого усовершенствования рассмотрим следующий пример.
 
Добавление фильтра фаски к компоненту кнопки
 
  1. Создайте или добавьте кнопку в рабочей области с помощью панели компонентов, последовательно выбрав команду «Кнопка».
  2. В инспекторе свойств нажмите раскрывающийся список в разделе «Фильтры»·и выберите «Фильтр фаски». Будут отображены свойства и значения для фильтра фаски.
  3. Измените или задайте подходящие значения для необходимых свойств. Например «Размытие X», «Размытие Y», «Интенсивность», «Тень» и т. д. Можно сразу же просмотреть применение этих эффектов к выбранной кнопке.
Меню «Добавить фильтр» в инспекторе свойств

Применение или удаление фильтра

  1. Выберите текст, кнопку или объект фрагмента ролика, где применяется фильтр или удаляется фильтр.
  2. В разделе «Фильтры» инспектора свойств выполните одно из следующих действий.

    • Чтобы добавить фильтр, нажмите кнопку и выберите фильтр. Экспериментируйте с параметрами, пока не получите нужный внешний вид.

    • Чтобы удалить фильтр, выберите этот фильтр в списке примененных фильтров и нажмите кнопку «Удалить фильтр» . Можно удалить или переименовать любой набор настроек.

Копирование и вставка фильтра

  1. Выберите объект, из которого копируется фильтр, и панель «Фильтры».
  2. Выберите фильтр, который необходимо скопировать, и нажмите кнопку . В раскрывающемся списке нажмите «Копировать выбранный фильтр». Для копирования всех фильтров выберите «Копировать все фильтры».

  3. Выберите объект, к которому нужно применить фильтр, и нажмите кнопку. В раскрывающемся списке нажмите «Вставить фильтры».

Применение набора настроек фильтра к объекту

  1. Выберите объект, к которому хотите применить набор настроек фильтра, и вкладку «Фильтр».
  2. Нажмите кнопку , чтобы открыть раскрывающееся меню.

  3. Выберите набор настроек фильтра из списка наборов настроек в нижней части раскрывающегося списка.

Примечание.

Когда к объекту применяется набор настроек фильтра, Animate замещает все фильтры, применяемые к выделенным объектам на данный момент, фильтрами набора настроек.

Включение или выключение фильтра, примененного к объекту

  1. По умолчанию все фильтры включены. Щелкните значок рядом с именем фильтра, чтобы отключить его. Нажмите кнопку «X» рядом с именем фильтра, чтобы включить его.

    Примечание.

    Чтобы включить другие фильтры в списке, щелкните значок включения в списке «Фильтры» при нажатой кнопке «Alt» (Windows) или «Option» (Macintosh). Если щелкнуть значок при нажатой клавише «Alt», выбранный фильтр будет включен, а все остальные фильтры в списке будут отключены.

Включение и выключение всех фильтров, примененных к объекту

  1. Нажмите кнопку и выберите «Включить все» или «Отключить все» в раскрывающемся списке.

    Примечание.

    Чтобы включить или выключить все фильтры в списке, щелкните значок включения или выключения в списке «Фильтры» при нажатой клавише «Control».

Создание библиотек наборов настроек фильтров

Сохраняйте параметры фильтров в виде библиотек наборов настроек, которые можно легко применить к фрагменту ролика или текстовым объектам. Используйте готовые наборы настроек фильтров вместе с другими пользователями, предоставляя им файл конфигурации фильтров. Файл конфигурации фильтра — это XML-файл, который хранится в папке конфигураций Animate:

 

  • Windows 7 и 8: C:\Пользователи\имя пользователя\AppData\Local\Adobe\Flash CC\язык\Configuration
  • (только для Flash Professional CS6 и более ранних версий) Windows XP: C:\Documents and Settings\имя пользователя\Local Settings\Application Data\Adobe\Flash CS6\язык\Configuration\Filters\название_фильтра.xml
  • (только для Flash Professional CS6 и более ранних версий) Windows Vista: C:\Пользователи\имя пользователя\Local Settings\Application Data\Adobe\Flash CS6\язык\Configuration\Filters\название_фильтра.xml
  • Macintosh: жесткий диск Macintosh/Пользователи/имя пользователя/Библиотеки/Application Support/Adobe/Flash /язык/Configuration/Filters/имя_фильтра.xml

Создание библиотеки фильтров с параметрами наборов настроек

  1. Применение одного или нескольких фильтров к объекту.

  2. Для добавления нового фильтра нажмите кнопку .

  3. Выберите фильтр, нажмите кнопку  и выберите «Сохранить как набор».

  4. Введите имя для параметров фильтра в диалоговом окне «Сохранить набор настроек как» и нажмите кнопку «ОК».

Переименование наборов настроек фильтра

  1. Нажмите кнопку и добавьте новый фильтр.

  2. Выберите фильтр и нажмите кнопку . Нажмите «Изменить наборы».

  3. Дважды щелкните имя набора настроек, которое хотите модифицировать.

  4. Введите новое имя набора и нажмите кнопку «ОК».

Удаление набора настроек фильтра

  1. Нажмите кнопку и добавьте новый фильтр.

  2. Выберите фильтр и нажмите кнопку .

  3. Нажмите «Изменить наборы».

  4. В диалоговом окне «Изменить наборы» выберите набор, который необходимо удалить, и нажмите «Удалить».

Применение фильтров

Применение тени

Фильтр «Тень» имитирует вид объекта, отбрасывающего тень на поверхность.

Текст с применением фильтра «Тень»

Пример отбрасываемой тени c классической анимацией движения см. на странице «Примеры Animate» по адресу www.adobe.com/go/learn_fl_samples_ru. Загрузите и распакуйте файл «Samples.zip» и перейдите в каталог «Graphics\AnimatedDropShadow».

  1. Выберите объект, к которому нужно применить отбрасывание тени.
  2. В разделе «Фильтры» инспектора свойств нажмите кнопку и выберите фильтр «Тень».

  3. Редактирование параметров фильтра.
    • Чтобы задать ширину и высоту отбрасываемой тени, установите значения «Размытие X» и «Размытие Y».
    • Чтобы задать интенсивность тени, установите значение «Интенсивность». Чем больше значение, тем темнее тень.
    • Выберите уровень качества для тени. Значение «Высокое» близко к размытию по Гауссу. Значение «Низкое» увеличивает производительность воспроизведения.
    • Чтобы задать угол отбрасывания тени, введите значение.
    • Чтобы задать расстояние от объекта до тени, установите значение «Расстояние».
    • Выберите «Выбивка», чтобы замаскировать (или скрыть) исходный объект и отобразить только тень на изображении с замаскированным объектом.
    • Чтобы применить тень внутри границ объекта, выберите «Внутренняя тень слоя».
    • Чтобы скрыть объект и отобразить только его тень, выберите «Скрыть объект». Параметр «Скрыть объект» позволяет легко создавать реалистичные тени.
    • Чтобы открыть палитру цветов и задать цвет тени, щелкните элемент цвета.

Создание тени с наклоном

Наклон тени, созданной фильтром «Тень», для более реалистичного вида тени

  1. Выберите объект с тенью, которую хотите наклонить.
  2. Создайте дубликат исходного объекта (выберите «Правка» > «Создать дубликат»).
  3. Выберите дублированный объект и наклоните его с помощью инструмента «Свободное преобразование» («Модификация» > «Преобразование» > «Вращение и наклон»).
  4. Примените фильтр «Тень» к дублированному фрагменту ролика или текстовому объекту. (Этот фильтр будет применен, если отбрасываемая тень уже была у дублируемого объекта.)
  5. На панели «Фильтры» выберите «Скрыть объект», чтобы скрыть дублированный объект и оставить видимой только его тень.
  6. Выберите «Модификация» > «Упорядочить» > «На задний план», чтобы дублированный объект и его тень находились за исходным объектом.
  7. Корректируйте параметры фильтра «Тень» и угол наклона тени, пока не получите нужный результат.

Применение размытия

Фильтр «Размытие» смягчает края и детали объектов. Объект, к которому применен фильтр «Размытие», может выглядеть так, как если бы он был позади других объектов или двигался.

Текст с применением фильтра «Размытие»

  1. Выберите объект, к которому хотите применить размытие, а затем «Фильтры».
  2. Нажмите кнопку и выберите «Размытие»

  3. Отредактируйте параметры фильтра на вкладке «Фильтр» следующим образом.
    • Чтобы задать ширину и высоту размытия, задайте значения «Размытие X» и «Размытие Y».
    • Выберите уровень качества для размытия. Значение «Высокое» близко к размытию по Гауссу. Значение «Низкое» увеличивает производительность воспроизведения.

Применение свечения

Фильтр «Свечение» позволяет применить цвет вокруг границ объекта.

Текст с применением фильтра «Свечение»

  1. Выберите объект, к которому хотите применить свечение, затем выберите «Фильтры».
  2. Нажмите кнопку и выберите «Свечение»

  3. Отредактируйте параметры фильтра на вкладке «Фильтр».
    • Чтобы задать ширину и высоту свечения, задайте значения «Размытие X» и «Размытие Y».
    • Чтобы открыть палитру цветов и задать цвет свечения, щелкните элемент цвета.
    • Чтобы настроить четкость свечения, задайте значение «Интенсивность».
    • Выберите «Выбивка», чтобы замаскировать (или скрыть) исходный объект и отобразить только тень на изображении с замаскированным объектом.
    Использование фильтра «Свечение» с параметром «Выбивка»

    • Чтобы применить свечение внутри границ объекта, выберите «Внутреннее свечение».
    • Выберите уровень качества для свечения. Значение «Высокое» близко к размытию по Гауссу. Значение «Низкое» увеличивает производительность воспроизведения.

Применение фаски

Фаска создает подсветку объекта, так что она кажется изогнутой над поверхностью фона.

Текст с примененным эффектом фаски

  1. Выберите объект, к которому хотите применить фаску, и «Фильтры».
  2. Нажмите кнопку и выберите «Фаска».

  3. Отредактируйте параметры фильтра на вкладке «Фильтр».
    • Чтобы задать тип фаски, выберите фаску в меню «Тип».
    • Чтобы задать ширину и высоту фаски, задайте значения «Размытие X» и «Размытие Y».
    • Выберите тень и цвет подсветки для фаски из всплывающей палитры цветов.
    • Чтобы задать непрозрачность фаски, не изменяя ее ширину, задайте значение «Интенсивность».
    • Чтобы изменить угол тени, отбрасываемой скошенным краем, введите значение угла.
    • Чтобы задать ширину фаски, введите значение параметра «Расстояние».
    • Выберите «Выбивка», чтобы замаскировать (или скрыть) исходный объект и отобразить только фаску на изображении с замаскированным объектом.

Применение градиентного свечения

В результате применения градиентного свечения это свечение отображается с градиентным цветом по поверхности свечения. Градиентное свечение требует одного цвета в начале градиента со значением «Альфа-канал», равным 0. Невозможно изменить позицию этого цвета, но можно изменить цвет.

Текст с градиентным свечением

  1. Выделите объект, к которому требуется применить градиентное свечение.
  2. В разделе «Фильтры» инспектора свойств нажмите кнопку и выберите «Градиентное свечение».

  3. Отредактируйте параметры фильтра на вкладке «Фильтр» следующим образом.
    • Выберите тип свечения для объекта во всплывающем меню «Тип».
    • Чтобы задать ширину и высоту свечения, задайте значения «Размытие X» и «Размытие Y».
    • Чтобы задать непрозрачность свечения, не изменяя его ширину, задайте значение «Интенсивность».
    • Чтобы изменить угол тени, отбрасываемой свечением, введите значение угла.
    • Чтобы задать расстояние от объекта до тени, установите значение «Расстояние».
    • Выберите «Выбивка», чтобы замаскировать (или скрыть) исходный объект и отобразить только градиентное свечение на изображении с маскированным объектом.
    • Укажите градиентный цвет для свечения. Градиент содержит два цвета или более, которые сливаются или накладываются друг на друга. Цвет, выбранный для начала градиента, называется цветом альфа-канала.
    • Чтобы изменить цвет в градиенте, выберите один из курсоров цвета под панелью определения градиента и щелкните цветовое пространство прямо под панелью градиента, чтобы отобразить палитру цветов. Перемещение этих курсоров настраивает уровень и позицию цвета в градиенте.
    • Чтобы добавить курсор к градиенту, щелкните панель определения градиента или ниже. Чтобы создать градиент с цветовыми переходами (до 15), добавьте до 15 цветовых курсоров. Чтобы изменить положение курсора на градиенте, перетащите курсор вдоль панели определения градиента. Чтобы удалить курсор, перетащите его вниз и с панели определения градиента.
    • Выберите уровень качества для градиентного свечения. Значение «Высокое» близко к размытию по Гауссу. Значение «Низкое» увеличивает производительность воспроизведения.

Применение градиентной фаски

В результате применения градиентной фаски кажется, что объект приподнят над фоном с градиентным цветом вдоль поверхности фаски. Для градиентной фаски необходимо, чтобы в середине градиента был один цвет с значением «Альфа-канал», равным «0».

  1. Выделите объект, к которому требуется применить градиентную фаску.

  2. В разделе «Фильтры» инспектора свойств нажмите кнопку и выберите «Градиентная фаска».

  3. Отредактируйте параметры фильтра на вкладке «Фильтр» следующим образом.

    • Выберите тип фаски для объекта во всплывающем меню «Тип».

    • Чтобы задать ширину и высоту фаски, задайте значения «Размытие X» и «Размытие Y».

    • Чтобы изменить гладкость фаски, не затрагивая ширину, введите значение интенсивности.

    • Чтобы задать угол, под которым свет падает из источника, введите значение в поле «Угол».

    • Выберите «Выбивка», чтобы замаскировать (или скрыть) исходный объект и показать только градиентную фаску на изображении с замаскированным объектом.

    • Укажите градиентный цвет для фаски. Градиент содержит два цвета или более, которые сливаются или накладываются друг на друга. Средний курсор управляет цветом альфа-канала для градиента. Можно изменить цвет курсора альфа-канала, но невозможно поменять позицию цвета в градиенте.

      Чтобы изменить цвет градиента, выберите один из курсоров цвета под панелью определения градиента и щелкните цветовое пространство под панелью градиента, чтобы отобразить палитру цветов. Для настройки уровня и позиции этого цвета в градиенте передвиньте эти курсоры.

      Чтобы добавить курсор к градиенту, щелкните панель определения градиента или ниже. Чтобы создать градиент с цветовыми переходами (до 15), добавьте до 15 цветовых курсоров. Чтобы изменить положение курсора на градиенте, перетащите курсор вдоль панели определения градиента. Чтобы удалить курсор, перетащите его вниз и с панели определения градиента.

Применение фильтра «Настроить цвет»

Фильтр «Настроить цвет» позволяет точно управлять атрибутами цвета выделенного объекта, включая контраст, яркость, насыщенность и цветовой тон.

  1. Выделите объект, для которого требуется настроить цвет.
  2. В разделе «Фильтры» инспектора свойств нажмите кнопку и выберите фильтр «Настроить цвет».

  3. Введите значения атрибутов цвета. Вот список атрибутов и их значений:

    Контрастность

    Настройка подсветок, теней и средних тонов изображения.

    Яркость

    Настройка яркости изображения.

    Насыщенность

    Настройка интенсивности цвета.

    Цветовой тон

    Настройка оттенка цвета.

  4. Чтобы сбросить все цветовые настройки до 0 и вернуть объект в исходное состояние, нажмите кнопку «Сброс фильтра».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет