Использование ActionScript в Animate

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

Начало работы с ActionScript

Язык сценариев ActionScript® позволяет добавлять в приложение сложные функции интерактивности, управления воспроизведением и отображения данных. Использовать ActionScript в среде разработчика можно с помощью панели «Действия», в окне «Сценарий» или с помощью внешнего редактора.

ActionScript имеет собственный синтаксис и зарезервированные ключевые слова, он позволяет использовать переменные для хранения и извлечения информации. ActionScript включает обширную библиотеку встроенных классов, которые позволяют создавать объекты для выполнения многих полезных задач. Дополнительные сведения о языке ActionScript см. в следующих разделах справки:

Вам не требуется понимать принцип действия каждого элемента ActionScript, чтобы начать создавать сценарии. Если у вас четкая цель, вы можете начать создание сценариев с простых действий.

Языки сценариев ActionScript и JavaScript основаны на стандарте ECMA-262 — международном стандарте для языка сценариев ECMAScript. По этой причине разработчики, знающие JavaScript, сразу найдут ActionScript хорошо известным языком. Дополнительные сведения о языке ECMAScript см. на сайте ecma-international.org.

Какую версию ActionScript можно использовать?

Animate включает несколько версий языка ActionScript, которые удовлетворяют требованиям разных разработчиков и аппаратных средств воспроизведения. ActionScript 3.0 и 2.0 несовместимы друг с другом.

 

  • Язык ActionScript 3.0 выполняется быстро. Эта версия требует более близкого знакомства с понятиями объектно-ориентированного программирования, чем остальные версии ActionScript. Язык ActionScript 3.0 полностью соответствует спецификации ECMAScript, предлагает лучшую обработку XML, усовершенствованную модель событий и архитектуру для работы с экранными элементами. Файлы FLA, использующие язык ActionScript 3.0, не могут включать ранние версии ActionScript.

  • (Не поддерживается только в Animate.) Изучить ActionScript 2.0 проще, чем ActionScript 3.0. Хотя проигрыватель Flash выполняет скомпилированный код ActionScript 2.0 медленнее, чем код ActionScript 3.0, язык ActionScript 2.0 по-прежнему может быть полезным для множества разных проектов. Язык ActionScript 2.0 также полезен на проектов нетребовательных к вычислительным ресурсам. Например, для содержимого, более ориентированного на оформление ActionScript 2.0 также основан на спецификации ECMAScript, но соответствует ей не полностью.

  • (Не поддерживается в Animate.) ActionScript 1.0 — это простейшая форма ActionScript, которая все еще используется в некоторых версиях проигрывателя Adobe Flash Lite. Один файл FLA может одновременно использовать ActionScript 1.0 и 2.0.

  • (Не поддерживается в Animate.) Flash Lite 2.x ActionScript является вариантом ActionScript 2.0, который поддерживается во Flash Lite 2.x на мобильных телефонах и устройствах.

  • (Не поддерживается в Animate.) Flash Lite 1.x ActionScript является вариантом ActionScript 1.0, который поддерживается во Flash Lite 1.x на мобильных телефонах и устройствах.

 

Использование документации по языку ActionScript

Существует несколько версий языка ActionScript (2.0 и 3.0) и несколько методов его включения в файлы FLA, поэтому изучить ActionScript можно разными способами.

Вы можете найти описание графического интерфейса пользователя для работы с ActionScript. Этот интерфейс включает панель «Действия», окно «Сценарий», режим «Помощник по сценариям», панель «Поведение», панель «Вывод» и панель «Ошибки компиляции». Следующие разделы применимы ко всем версиям языка ActionScript.

Другие руководства по языку ActionScript от корпорации Adobe содержат описания конкретных версий ActionScript.

Методы работы с языком ActionScript

Существует несколько методов работы с языком ActionScript.

  • (Не поддерживается в Animate.) Режим «Помощник по сценариям» позволяет добавлять код ActionScript в файл FLA без необходимости писать код вручную. Пользователь выбирает действия, а программа предлагает пользовательский интерфейс для ввода нужных параметров. Необходимо представлять, какие функции требуются для выполнения той или иной задачи, но при этом не обязательно знать синтаксис языка. Этим методом пользуются многие дизайнеры и пользователи, не владеющие программированием.

  • (Не поддерживается в Animate.) Другим способом добавления кода к файлу без ручного написания кода являются варианты поведения. Варианты поведения — это заранее написанные сценарии для типовых задач. Можно добавить вариант поведения, а потом легко настроить его на панели «Поведение». Варианты поведения доступны только в языке ActionScript версии 2.0 и более ранних.

  • Написание собственных сценариев ActionScript обеспечивает большую гибкость в управлении документом, но требует знания языка ActionScript и соглашений по нему.

  • Компоненты — это ранее созданные фрагменты ролика, которые помогают реализовать сложные функции. Компонентом может быть простой пользовательский элемент управления, например флажок, или сложный элемент управления, например панель прокрутки. Функциональность и внешний вид компонента можно настраивать, имеется возможность загрузить компоненты, созданные другими разработчиками. Для создания большинства компонентов требуется написать собственный код на языке ActionScript, чтобы запустить компонент или управлять им. Дополнительные сведения см. в руководстве Использование компонентов ActionScript 3.0.

 

Создание сценариев на языке ActionScript

При написании кода ActionScript в среде разработчика используется панель «Действия» или окно «Сценарий». Панель Действия и окно «Сценарий» содержат полнофункциональный редактор программного кода, включающий подсказки кода и выделение цветом, форматирование, цветовую подсветку синтаксиса. Он также включает отладку, номера строк, перенос слов и поддержку Юникода.

  • Панель «Действия» используется для создания сценариев, которые включены в документ Animate (то есть являются внедренными в FLA-файл). Панель Действия содержит такие элементы, как панель инструментов «Действия», которая обеспечивает быстрый доступ к основным элементам языка ActionScript. Вы получаете подсказки для элементов, необходимых для создания сценариев.

  • Окно «Сценарий» используется для создания внешних сценариев, то есть сценариев или классов, хранящихся во внешних файлах. (Для создания внешнего AS-файла можно также использовать текстовый редактор.) Окно «Сценарий» содержит функции, облегчающие написание кода, например подсказки кода, выделение цветом, проверку синтаксиса и автоформатирование.

Дополнительные рекомендуемые материалы сообщества

В следующих статьях и руководствах приводится дополнительная подробная информация о работе с языком ActionScript:

Обзор панели «Вывод»

При выполнении документа любого типа, на панели «Вывод» отображается информация или предупреждение, связанные с операциями, такими как преобразование и публикация документов. Для отображения такой информации добавьте к коду операторы trace() или используйте команды «Создать список объектов» или «Создать список переменных».

Если в сценарии используется оператор trace(), во время воспроизведения SWF-файла на панель «Вывод» можно выводить определенную информацию. Это могут быть данные о состоянии SWF-файла или значении выражения. 

Панель «Вывод»

Панель Вывод включает следующие параметры меню:

  • Копировать: копирует все содержимое панели «Вывод» в буфер обмена компьютера. Чтобы скопировать часть содержимого, выделите нужную область и выберите «Копировать».
  • Очистить: очищает содержимое панели «Вывод».
  • Показать вывод: отображается содержимое панели «Вывод».
  • Заблокировать: блокирует панель. Можно только изменить размер панели, но нельзя перемещать или перетаскивать панель. 
  • Справка: загружает онлайн-справку для панели «Вывод».
  • Закрыть: закрывает панель «Вывод».
  • Закрыть группу: закрывает всю группу панелей. Можно одновременно закрепить несколько панелей, таких как «Временная шкала», «Вывод» и «Ошибки компиляции».

Чтобы показать или скрыть панель «Вывод», выберите Окно > Вывод или нажмите клавишу F2.

Панель «Действия»

Требуется справка по языку?

Чтобы найти справочную документацию по конкретному элементу языка ActionScript, выполните одно из следующих действий.

  • Откройте страницу Справка по языку ActionScript 3.0 и выполните поиск элемента языка.

  • (Не поддерживается в Animate.) Откройте Справочник по языку ActionScript 2.0 и найдите элемент языка, который вас интересует.

  • Введите элемент языка на панели «Действия», выберите его и нажмите клавишу F1 (сразу нажмите клавишу F1).

Примечание.

Чтобы открыть справку в веб-браузере вместо программы помощи сообщества, изучите следующую статью: http://kb2.adobe.com/community/publishing/916/cpsid_91609.html.

Изучение ActionScript

Сведения о написании кода ActionScript доступны в следующих ресурсах:

Примечание.

ActionScript 3.0 и 2.0 несовместимы друг с другом. Выберите одну из версий для каждого создаваемого FLA-файла.

Обзор панели «Действия»

Чтобы создать сценарии, встроенные в FLA-файл, введите ActionScript непосредственно в панель «Действия» («Окно» > «Действия» или нажмите F9).

Панель «Действия»

Панель «Действия» состоит из следующих двух областей.

Панель «Сценарий»

Позволяет ввести с клавиатуры код ActionScript, связанный с текущим выбранным кадром.

Навигатор сценариев

Выводит список сценариев в документе Animate и позволяет быстро перемещаться между ними. Чтобы просмотреть сценарий на соответствующей панели, выберите элемент в средстве навигации «Сценарий».

Панель «Действия» позволяет использовать функции, которые упрощают и ускоряют написание кода ActionScript. Можно добавить не связанные с кадрами глобальные и сторонние сценарии, которые можно применить ко всей анимации прямо в Animate. Дополнительные сведения см. в разделе Добавление глобальных и сторонних сценариев на этой странице. 

  • Выполнить сценарий: выполняется сценарий
  • Закрепить сценарий: сценарий закрепляется на вкладках закрепления отдельных сценариев на панели «Сценарий» и перемещается соответствующим образом. Эта функция полезна, если код FLA-файла не упорядочен относительно одного централизованного местоположения. Она также полезна, если используется несколько сценариев. Можно закрепить сценарий, чтобы оставить открытым расположение кода на панели «Действия» и переключаться между несколькими открытыми сценариями. Эта функция может быть полезна при отладке.
  • Вставить путь и имя образца: позволяет установить абсолютный или относительный путь назначения для действия в сценарии (только для панели «Действия»).
  • Найти: выполняет поиск и замену текста в сценарии.
  • Форматирование кода: помогает выполнять форматирование кода.
  • Фрагменты кода: открывает панель «Фрагменты кода», содержащую типовые фрагменты кода.
  • Добавить с помощью мастера: нажмите эту кнопку, чтобы добавить операции с помощью удобного мастера, который не требует написания кода. 
  • Справка: отображает справочную информацию для элемента языка ActionScript, выделенного на панели «Сценарий». Например, если нажать оператор import, а затем инструмент «Справка», на панель «Справка» выводится справочная информация для оператора import.

Использование мастера кода операций

Можно добавлять интерактивность в композиции HTML5 с помощью параметров функции Добавить с помощью мастера на панели Операции. Функция «Добавить с помощью мастера» представляет собой простейший пользовательский интерфейс для добавления кода в композиции.

  1. Создайте документ HTML5 Canvas и выберите Окно > Операции.

  2. Щелкните Добавить с помощью мастера на панели Операции, как показано на следующем снимке экрана. 

    Панель «Действия» с кнопкой «Добавить с помощью мастера»

  3. Выберите действие, для которого требуется создать код в мастере создания кода.

    Пример снимка экрана, на котором представлены параметры мастера создания кода действий

    На приведенном выше снимке экрана выбрана операция Получить номер кадра, и в окне операции обновлен соответствующий код.

    В зависимости от выбранного типа операции можно также выбрать соответствующий объект, к которому требуется применить операцию. Можно выполнять поиск конкретных объектов в рабочей области, если они имеют имя экземпляра. Кроме того, можно применить операцию для текущего выбора. 

    Список объектов, к которым следует применить действие

  4. Нажмите кнопку Далее, чтобы выбрать запускающее событие. Набор запускающий событий указывается в окне в зависимости от выбранного типа действия и выбранного объекта в предыдущий шагах. 

    Список запускающих событий

  5. Выберите подходящее запускающее событие и соответствующие запускаемые объекты, если они имеются, и нажмите кнопку Заверш. и добав.

Можно выбрать в меню параметр Текущее выделение при выборе объекта в рабочей области и запуске мастера кода операций. Для кода также можно выбрать операции с временной шкалой и компонентами.

Расширение интерактивности анимации

Интерактивность — ключевой аспект анимации, позволяющий усилить визуальные впечатления зрителей. Хотите научиться добавлять в видео действия, не используя код? Посмотрите учебный видеоролик в конце этого примера и выполните следующие шаги.

  1. Выберите ролик для действия на Временной шкале.

  2. Нажмите Окно > Действия.

  3. На панели Действия нажмите Добавить с помощью мастера.

  4. В текущем кадре сделайте следующее.

    • Выберите действие: выберите Воспроизведение.
    • Объект, к которому применить действие: выберите нужный объект.
  5. Нажмите Далее.

Как сделать анимации более интерактивными

Посмотрите видео, чтобы узнать больше о воспроизведении, перемещении по вертикали, размещении объекта и других действиях.

Использование окна «Сценарий»

В окне «Сценарий» создаются внешние файлы сценариев, которые впоследствии импортируются в приложение. Это могут быть файлы сценариев ActionScript или Animate JavaScript.

Также можно добавлять глобальные и сторонние сценарии в документы HTML5 Canvas. Дополнительные сведения см. в разделе Добавление глобальных и сторонних сценариев статьи Создание и публикация документов HTML5 Canvas в Animate.

Окно «Сценарий»

Если открыты несколько внешних файлов, их имена выводятся на вкладках вверху окна «Сценарий».

В окне «Сценарий» предлагаются следующие функции: закрепление сценария, поиск с заменой, цветовая окраска синтаксиса, форматирование кода, подсказки кода, комментирование кода и свертывание кода. Также можно использовать функции отладки (только для файлов ActionScript) и автоматический перенос строки. В окне «Сценарий» также можно отображать номера строк и скрытые символы.

Создание внешнего файла в окне «Сценарий»

  1. Выберите Файл > Создать.

    Новый документ
    Новый документ

  2. Задайте предполагаемый замысел на вкладках вверху экрана: «Анимация персонажей», «Социальные сети», «Игры», «Образование», «Реклама», «Интернет» и «Дополнительно». Выберите тип внешнего файла (файл ActionScript или Animate JavaScript).

Редактирование внешнего файла в окне «Сценарий»

  • Чтобы открыть существующий сценарий, выберите меню Файл > Открыть и откройте существующий AS-файл.

  • Для редактирования уже открытого сценария перейдите на вкладку документа с именем сценария.

Инструменты на панели «Действия» и в окне «Сценарий»

Панель «Действия» позволяет использовать функции, которые упрощают и ускоряют написание кода ActionScript.

Найти 

Поиск и замена текста в сценарии.

 

Вставить целевой путь 

Позволяет установить абсолютный или относительный путь назначения для действия в сценарии (только для панели «Действия»).

 

Справка 

Отображает справочную информацию для элемента языка ActionScript, выделенного на панели «Сценарий». Например, если нажать оператор import, а затем инструмент Справка, на панель Справка выводится справочная информация для оператора import.

 

Фрагменты кода

Открывает панель Фрагменты кода, содержащую типовые фрагменты кода.

 

Добавить с помощью мастера

Позволяет добавлять код для действий с помощью интерфейса без необходимости написания кода. 

Доступ к контекстно-зависимой справке из панели «Действия»

  1. Чтобы выбрать элемент для справки, выполните одно из следующих действий.
    • Выберите термин ActionScript на панели инструментов панели «Действия» (слева на панели Действия).

    • Выберите элемент ActionScript на панели «Действия» панели «Сценарий».

    • Поместите курсор вставки перед элементом ActionScript на панели «Действия» панели «Сценарий».

  2. Чтобы открыть страницу справки панели «Справка» для выбранного элемента, выполните одно из следующих действий.
    • Нажмите клавишу F1.

    • Щелкните элемент правой кнопкой мыши и выберите пункт «Просмотр справки».

    • Нажмите «Справка»  над панелью «Сценарий».

Установка параметров языка ActionScript

При редактировании программного кода на панели «Действия» или в окне «Сценарий» можно устанавливать и модифицировать набор настроек.

  1. Выберите Правка > Настройки (Windows) или Animate > Настройки (Macintosh) и нажмите Редактор кода в списке «Категория».

  2. Установите любой из следующих параметров.

    Автоматические отступы

    При установке автоотступа текст, который вводится после открытой простой «(» скобки, автоматически смещается вправо в соответствии с параметром табуляции. Это поведение также применимо при использовании открытой фигурной «{» скобки.

    Размер шага табуляции

    Задает количество символов при отступе новой строки.

    Подсказки кода

    Включает подсказки кода в поле «Сценарий».

    Задержка

    Задает задержку (в секундах) для вывода подсказок кода. Этот параметр не поддерживается в Animate.

    Шрифт

    Задает шрифт, который используется в сценарии.

    Открыть/Импортировать

    Задает кодировку символов, которая используется при открытии или импорте файлов ActionScript.

    Сохранить/Экспортировать

    Задает кодировку символов, которая используется при сохранении или экспорте файлов ActionScript.

    Повторно загружать измененные файлы

    Определяет действие, которое выполняется при изменении, перемещении или удалении файла сценария. Выберите «Всегда», «Никогда» или «Запрос».

    Всегда

    Предупреждение не выводится, и файл автоматически перезагружается.

    Никогда

    Предупреждение не выводится, и файл остается в текущем состоянии.

    Запрос

    Выводится предупреждение, и появляется возможность определить, нужно ли перезагрузить файл (по умолчанию).

    При создании приложения с внешними файлами сценариев эта установка помогает избежать замены сценария. Или избежать публикации приложения со старыми версиями сценариев. Предупреждение позволяет автоматически закрыть сценарий и загрузить новую, измененную версию.

    Цвета синтаксиса

    Задает цвета подсветки синтаксиса в сценарии.

    Параметры ActionScript 3.0

    При нажатии этих кнопок открываются диалоговые окна «Параметры ActionScript», где можно задать исходный путь, путь к библиотеке, путь к внешней библиотеке для ActionScript 3.0.

Логотип Adobe

Вход в учетную запись